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What is Affinity Photo? 

Affinity Photo brings a new beginning to image editing for professional photographers, photo 

retouchers and conceptual artists. With high-end image editing in mind, Photo has been designed 

with power, speed and performance from its inception, balanced with an intuitive workflow-oriented 

user interface. 

About Affinity Photo 

Here's an overview of what you can expect. 

 Stunning performance with instant redraw 

 Real-time pro-level dynamic tools 

 Built from the ground up to live in the Cloud-connected App store world 

 Different tool sets (Personas) for different design needs—Photo, Liquify, Develop (RAW), HDR 

and Export 

 Develop Persona—a dedicated studio for camera RAW processing 

 End-to-end CMYK, RGB, LAB, and grayscale pro color spaces 

 Non-destructive Adjustment Layers and Live Filters 

 Comprehensive blend mode set 

 Retouching heaven with all the industry standard tools you'll ever need 

 Liquify tools for retouch or crazy effects 

 PSD import/export with fidelity 

 Interworking with other Affinity products 

and much more... 

Why not review the product's key features in more detail? 

Apple Photos application and Affinity Retouching 

The Affinity Photo architecture and a powerful suite of retouch tools have been brought together to 

create a photo retouching solution integrated within Apple Photos as an extension. 

The extension is a component of Affinity Photo itself so requires Affinity Photo to be installed. 
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Personas 

Think of Personas as different ways of working within Affinity Photo. If you want to work purely with 

core photo editing tools you can edit in the default Photo Persona. However, Affinity Photo packs a 

punch with additional Personas that each offer either a specific design environment or analogous 

toolsets, features or functions. 

Naturally, an Export Persona is always at hand to export your design. 

Here's an overview of the set of Personas available to you: 

 Photo Persona: The default Persona for photo editing including crop, selection, brush, 

retouch, erase, warping and vector-based tools. 

 Liquify Persona: A stunning design environment for distortion of image areas. Great 

for retouching and special warping effects. 

 Develop Persona: For in-app development of raw images, giving you full control of 

image color and tone. 

 Tone Mapping Persona: An environment dedicated to tone mapping images. Although 

intended for 32-bit documents, you can also enter this persona from 8-bit or 16-bit 

documents and tone map non-HDR images. 

 Export Persona: You can output your image, layer, or slice to a range of image formats. 

 Panorama Persona: Only accessible by creating a stitched panorama, provides a dedicated 

environment for fine tuning stitched images to create panoramic compositions. 

You can switch between Personas with a single click, with the workspace tools and panels changing to 

that Persona's way of working. 

 

 

 

  

file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Panorama/panorama_stitching.html


Key features 

Here's a overview of the key features of Affinity Photo: 

Power, performance and compatibility: 

 Optimized for: 

o Grand Central Dispatch (GCD) 

o OpenGL 

o Core Graphics 

o Direct3D 

o Metal hardware acceleration 

o 64-bit engine 

 Create massive gigapixel-sized documents 

 16-bits per channel editing 

 Sub-pixel accuracy 

 For all Intel 64-bit Macs (Core 2 Duo onwards) 

 For OS X 10.7 (and above) or macOS Sierra 10.12.0 (and above) 

 64-bit plug-in support 

 Up to date Tablet support 

 Multi-touch support 

 Force Touch support (Magic Trackpad 2/MacBook/MacBookPro) 

 Touch Bar support (MacBook Pro) 

 End-to-end EXIF preservation 

Raw development: 

 Choice of Serif or Apple Core Image RAW engines 

 Serif Raw Engine 

 Remove automatic tone curve and apply your own 

 Develop assistant for setting default tone and exposure control behavior 

 Dedicated tones, lens, noise reduction and sharpening panels 

 Support for the latest cameras 



 Split view with syncing 

 Solid and gradient overlays for restricting adjustments 

 Show clipped highlights, shadows, and tones 

Color: 

 CMYK, Lab, Grayscale and RGB color modes 

 Color panel (RGB, HSL, LAB, CMYK, Grayscale) 

 Swatches panel (Apple, System, Web Safe colors, Crayons) 

 Swatches panel 

 Generate palette from image 

 Global colors 

 Color tints 

 Color Picker Tool (color mode aware, pick from anywhere on screen, color averaging, layer 

selection) 

 Color Replacement Brush 

 Paint Mixer Brush 

 Gradient tool (Linear, Elliptical, Radial, Conical, Bitmap) 

 Professional color support 

 Spot colors and overprint 

 PANTONE® color support 

 ICC color profiling 

 Import Adobe ASE color palettes 

Solid photo-editing tools: 

 Sizing and transforming: 

o Resize images and canvas 

o Crop to original/custom ratios, absolute dimensions or print sizes 

o Straighten photos 

o Mesh Warp Tool 

o Non-destructive perspective filter 

o Liquify tools in dedicated Persona workspace 



o Pixel art resizing 

 HDR 

o Merge bracketed exposures together to create 32-bit images 

o Unique Persona for Advanced Tone Mapping 

o Edit effortlessly in 32-bit unbounded color format 

o Maintain a true 32-bit lossless workflow and preview full tonal range 

o OpenEXR and Radiance import and export 

 Panorama Persona for powerful auto-stitched panoramas 

 Live projections (equirectangular and perspective) 

 Stacking 

o For noise reduction 

o For exposure merging 

o For moving object removal 

o Auto-alignment 

o Non-destructive behavior 

 Focus merging with source cloning 

 Powerful layer management: 

o Drag-and-drop layers 

o Non-destructive adjustment layers with clipping previews 

o Non-destructive Live Filter layers with 'live' before/after split views 

o Apply adjustments, filters and blend modes at the stack, layer, group, selection or 

object level 

o Clipping within layers 

o Blend modes 

o Blend ranges (linear and non-linear) and blend gamma control 

o Lock child layer positions 

o High-quality layer effects 

o Layer masks (brush-based and gradient) 

  



 Selection tools: 

o Shaped selections 

o Intelligent Selection Brush 

o Refine selections to capture fine detail 

o Store and save selections 

o Quick masks 

 Image control: 

o Place images on dedicated layers 

o Resampling: Nearest Neighbor, Bilinear, Bicubic and Lanczos 3 pixel scaling 

o Media browser (to access Photos and Pictures folders) 

 Painting: 

o High-quality brush galleries 

o Change brush size, hardness, and opacity on the fly 

o Undo Brush with 'paintback' to saved snapshot 

o Import/export brushes, including ABR file import 

o Custom brushes (including image-based brushes) 

o Assign tools to brushes selectively 

o Optimized for graphics tablets 

o Multi-controller support including pressure and velocity 

o Controller-specific brush dynamics 

o Customizable controller ramps 

 Retouching tools: 

o Red-eye removal 

o Inpainting for object removal 

o Clone Brush/Healing Brush 

o Blemish Removal/Patching 

 Retouching brushes: 

o Dodge, Burn and Sponge brushes 

o Blur, Sharpen, Median and Smudge brushes 



 Macros and batch processing: 

o Record and save actions as macros 

o Edit individual recorded steps and their parameters 

o Customize macro settings post recording  

o Import, export, and maintain a macro library 

o Run batch jobs for bulk processing and conversion of images 

o Apply macros in batch jobs for a seamless custom workflow 

Supporting vector design tools and concepts: 

 Precise Pen tool 

 Intuitive Move tool (moves, scales and transforms) 

 Rotate from movable origin 

 Customizable nudge distances 

 Node tool for fine tuning vectors 

 Customizable geometric shapes 

 Full range of non-destructive Boolean geometry operations 

 Duplicate and transform objects with precision 

 Add noise to fills and strokes as a solid or graduated attribute 

 Customizable stroke styles 

 Styles presets 

 Artistic and frame text 

 Character and Paragraph panels 

 Advanced typography including ligatures 

o Flowing text 

o Spellchecking 

o OpenType font features 

 Convert shapes and text to fully editable curves 

 Save and synchronize defaults 



User interface: 

 Persona task-orientated workspaces 

 Customizable tabbed workspace 

 High DPI (retina) support 

 Multiple document views 

 Windowed, Full Screen, and Separated modes 

 Docked or floating panels 

 Comprehensive keyboard shortcuts and modifiers 

 Customizable keyboard shortcuts 

 Customizable toolbars 

Design Aids: 

 Rotate canvas 

 Incredible zoom range 

 Intuitive panning 

 Saveable zoom viewpoints 

 Dynamic snapping guides 

 Pixel-accurate alignment for web graphics and website mockups 

 Managers for Brushes, Grids, Snapping and other operations 

 Pixel, Retina, and Outline view modes with Split View support 

 Automatic, fixed and projection grids 

 Context toolbar and hintline 

 Fluid document History <8192 steps 

 Save history with document (multi-session) 

 Snapshots 

 Keyboard modifiers for on-the-fly tool changes 

 Mixed-mode assistant for layer creation behavior according to the user’s preferences 

Interoperability: 

 Affinity Photo files can be opened in other Affinity products and vice versa 

 iCloud sync and merge 



Import, Export and Printing 

 High-quality Adobe® Photoshop® PSD import and export 

 SVG import and export, including Inkscape extended SVG support 

 Export layers, groups and pages to PNG, JPEG, TIFF, GIF, EPS, SVG and PDF 

 Preserve layers in exported TIFF images 

 Draw custom-sized slices at export time 

 Use slice presets for popular image formats 

 Multiple export setups, formats and resolutions per slice 

 Output all slices at once, just one slice, or selected slices 

 Export automatically to retina (@2x, @3x) 

 Export automatically to high DPI 

 Set export areas and file formats during or after photo editing 

 Deliver UI design assets (iOS) 

 Desktop printing with Layout, Paper Handling, Feed, and Duplexing control 

 Web-ready PDFs (Acrobat) with presets 

 Professional hi-res PDF/X printing (CMYK) with presets 

 Spot colors and overprint control 

 Bleed and printer marks 

  



Switching Personas 

When you switch to a different Persona, you get a different design environment designed for specific 

photo-editing needs—each Persona is equipped with its own tailored set of tools and panels for 

maximum efficiency and design focus. Personas ensure that everything you need to unleash your 

creativity is at your fingertips. 

To switch to a different Persona:  

 On the Persona toolbar, click the button for the Persona that you want to use. 

 

 

 From the top Affinity Photo menu, choose a Persona you wish to switch to. 

The Panorama Persona is only accessible by choosing the New Panorama feature on the File menu. 

  



Open documents and images 

You can open photos and raster images as well as a range of popular camera raw images in Affinity 

Photo, ready for editing and designing. You can open previously saved Affinity Photo documents, as 

well as vector images (SVGs) and projects from other, selected professional photo editing apps. For a 

comprehensive list of compatible import file formats, see Import and export file formats. 

A key feature of the Affinity product range is the ability to seamlessly open any Affinity project file in 

any Affinity product, regardless of the original Affinity product it was created in. In doing so, you can 

enhance your work with another Affinity product's features with no concern over file compatibility on 

saving. 

Affinity Photo documents are saved with the .afphoto file extension. 

You can add additional photos and raster images to your project page as a new layer. For more 

information, see Place images. 

To open a document or photo:  

1. Do one of the following: 

o From the File menu, click Open. 

o Double-click anywhere in the empty view. (Only available in Normal mode when no 

other documents are open.) 

2. Select the file you want and click Open. 

To open a recently used document:  

 From the File menu, click Open Recent, then select a file from the submenu. 

To open an image as a new document (via Finder):  

 Open Finder and drag the file to an off page area of your workspace. 

Photos opened using the above methods will create a new document with one layer, named 

'Background'. The document will adopt the image name as its file name. 

On opening, a file's colour space is preserved by default, but you can convert it to the default working 

color space via Affinity Photo>Preferences (Color option) using the Convert opened files.. option. 

The document's current color profile is displayed at the top-left of your workspace. 

On opening, a file's color space is preserved by default, but you can convert it to the default working 

color space via Edit>Preferences (Color option) using the Convert opened files.. option. The 

document's current color profile is displayed at the top-left of your workspace. 
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The 'Background' layer is locked by default. (This can be changed by updating your Preferences.) 

Layers which are locked show in the Layers panel with a lock symbol next to them. Selected locked 

layers appear with crosses around the bounding box. 

Adobe Photoshop project files can also be opened in Affinity Photo as described above. 

To open Adobe PDF files:  

1. From the File menu, click Open. 

2. From the PDF Options dialog, you can choose: 

o A specific or all pages to import. 

o Set the resolution for the PDF content. 

o If text is to remain more editable at the expense of accurate design reproduction. 

o If separate text lines can be treated as a single text frame to aid text flow. 

o To substitute a missing font with a similar replacement font. 

For multi-page PDF files, each page is placed on its own layer. Switch on a hidden page's layer to view 

its content. 

Opening a raw image 

You can open raw images from your digital camera directly into Affinity Photo. In doing so, you'll be 

able to process the unprocessed image, deciding for yourself how your image is to be developed. 

For a comprehensive list of supported raw image files that can be imported, see Import and export file 

formats. 

Processing raw images is carried out exclusively within Affinity Photo's Develop Persona. Once you 

commit to how you want to your image to be developed, the image can then be worked on in other 

Personas. 

To open a raw image:  

1. From the File menu, click Open. 

2. Select the raw file you want and click Open. 

The raw image is loaded into Develop Persona for processing. 

To open a recently used raw image:  

 From the File menu, click Open Recent, then select a raw file from the submenu. 

To open a raw image as a new document (via Finder):  

 Open Finder and drag the file to an off page area of your workspace. 
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Create new documents 

When you create your new document you specify a range of color settings plus page dimensions 

depending on the purpose of your document. 

Available new document settings are as follows: 

 Type—Select the aim and deliverable for your project (for quickly populating settings below). 

As well as print (press-ready CMYK), you can work to specific Photo print sizes, specific Web 

screen resolutions, and with the Devices option, design to iPad, iPhone, and Nexus document 

specifications.  

 Page Preset—Offers sizes for UK/US print, photos, screen use, and mobile devices. A Custom 

option indicates if your page is using non-standard page dimensions. 

 Document Units—Displays your rulers and object dimensions in pixels, points or using 

physical measurement units. 

 Color Format—Sets the color mode to RGB or Gray (8 or 16 bit), CMYK (8 bit), or Lab (16 bit). 

 Color Profile—Sets the color gamut for the previously chosen color format. 

 Transparent background—Check to set your page background to be transparent. 

 Page Width/Height—Change these values to make a custom page size. (An alternative to 

selecting a Page Preset size above.) 

 DPI—Sets the resolution of your document. For example, for professional print quality, set 

your resolution to 300 dpi. 

 'Actual Size' Zoom—Sets the device which is mimicked when presenting the document at 

'Actual Size' (from the View menu). This option is only available when the document units are 

set to Pixel or Points. Select from the pop-up menu. 

 Portrait—Uncheck to present your document in landscape orientation. 

 Include Margins—Check to switch on page margins. 

 Left Margin, Right Margin, Top Margin, Bottom Margin— Sets the printer margins, 

showing as non-printable blue lines. Click Retrieve Margin from Printer to use your default 

printer's settings. 

When creating a new document, the Document Units define the exact size of your document on 

screen. For example, if you chose 'pixels', your document will display at its exact pixel size when 

exported and viewed on screen at 100%. Similarly, for physical Document Units (e.g., millimeters) 

you'll get the exact print size at 100%. 



To change document units once a document has been created, use the settings on the context toolbar 

when the View Tool or Zoom Tool is selected. 

You can also create a new document based on the contents of the clipboard. 

Full transparency can be applied to the background of the document at any point by selecting 

Transparent Background from the Document menu. 

To create a new document:  

1. From the File menu, click New. 

2. From the dialog, choose document settings. 

3. Click OK. 

Creating new documents from clipboard contents 

You can create a new document based on the current contents on the clipboard. This 'paste as new 

document' feature allows you to start a new project from a copied section (layer or selection) of 

another project in Affinity Photo or other supported applications. 

To create a new document based on clipboard contents:  

 From the File menu, click New From Clipboard. 
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Embedding documents 

Embedding documents allows you to place any Affinity (Designer, Photo, etc.), Photoshop, Illustrator, 

Freehand, SVG, EPS or PDF document into your current document without the need to open each file 

in turn. 

 

 
Before and after documents from Affinity Photo and Affinity Designer embedded into 

current document. 

Once you've added embedded documents onto your page, you can edit each document without 

leaving your current document. 

To embed a document:  

1. From the File menu, select Place. 

2. In the pop-up dialog, navigate to and select a document, and click Open. 

3. Do one of the following: 



o Click to place the document at a default size. 

o Drag on the page to set the size and position of the document. 

Embedded documents are shown in the Layers panel using their original document name and the 

suffix '(Embedded document)'. 

If your embedded document is a Designer file which has multiple artboards, you'll be provided with an 

Artboard option on the document's context toolbar so you can choose which artboard is displayed. 

To edit an embedded document:  

 Do one of the following: 

o Double-click the placed document. 

o From the context toolbar, select Edit Document. 

Changes are saved within the main document without affecting the original. 

The editability of the embedded document may be affected by how the original document was saved 

in its native application. 

To replace a document:  

1. Select the document. 

2. From the context toolbar, select Replace Document. 

  



Place images 

You can add additional photos and raster images to your page as a new layer. 

Photos and images placed in this way can be replaced using the options on the context toolbar. 

The image's embedded color profile will always be converted to the document's current working 

space. 

To place an image:  

1. From the File menu, select Place. 

2. In the pop-up dialog, navigate to and select a file, and click Open. 

3. Do one of the following: 

o Click to place the image at its default, displayed size. 

o Drag on the page to set the size and position of the image. 

To add an image to a layer (via Finder):  

 Drag an image from Finder to your page. The image will be added to the project as a new 

layer. 

To replace an image:  

1. Select an image. 

2. From the context toolbar, select Replace Image. 

  



Using stock photos 

The Stock panel allows you to search various stock imagery websites to find images for your designs 

and then add them to the page. 

When you add images from the Stock panel to your document, they are placed as watermarked 

versions. This allows you to use them in your design so you and your clients can visualize their use 

before you purchase them. 

 

 
Before and after purchase of stock image. 

When the design is complete, the features within Affinity Photo allow you to quickly locate the image 

online (so you can purchase it) and then help you replace the placeholder with a purchased version. 

To search for stock images:  
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On the Stock panel: 

1. Select a stock imagery website from the pop-up menu. 

2. In the search box, type in your keyword(s) and then click the search icon or press the Return 

key. 

Thumbnails of all images matching the search criteria will display in the panel. 

You can clear search results using the close icon. 

To add a placeholder of the stock image to the page:  

 Drag the thumbnail of an image from the Stock panel onto the page. 

To purchase and replace a stock image:  

1. Select the watermarked placeholder image on the page. 

2. On the context toolbar, select Open Stock URL. Your default web browser will launch 

displaying your selected image on the chosen stock imagery website. 

3. Purchase the image and save the file to a convenient local location. 

4. With the placeholder image still selected, on the context toolbar, click Replace Image. 

5. Navigate to, and select, the purchased image and click Open. 

To view an image on its stock imagery website:  

 On the Stock panel, double-click a thumbnail. 

  



View 

There are a variety of viewing options available which give you maximum flexibility when editing your 

images. 

New View 

There are times when it is useful to view a design at different zoom levels simultaneously. This can be 

achieved by opening your current project in a New View. The views can then be set to different zoom 

levels. Changes made to any view are replicated in the other. 

To open the current project in a new view:  

 From the View menu, select New View. The project opens in a new tab/window which 

includes a numerical reference in its title. 

To switch between open projects and views:  

Do one of the following: 

 Click a project/view tab in Normal mode. 

 Click a project/view tab. 

 Click a project/view window header in Separated mode. 

 From the View menu, select a project/view from the Views sub-menu. 

Full Screen View 

Regardless of which layout mode you choose to work in, you also have the option of full screen view. 

In this view, Affinity Photo is effectively maximized to its own desktop, giving you every available pixel 

to work with. 

To display full screen:  

Do one of the following: 

 Click the Full Screen button at the top of your window (this is the top-left green button for OS 

X Yosemite users). 

 From the Window menu, select Toggle Full Screen. 

The Menu bar is not visible in full screen view. However, it remains accessible by moving the pointer 

to the upper edge of the screen. 

Using the Separated Workspace mode, you can be working on several documents at a time, each 

having their own full screen desktop! 
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When in full screen view, you cannot switch between Normal and Separated mode. You must choose 

which mode you wish to work in before entering full screen view. 

  



Zooming 

Zooming into areas of your document is an essential part of the editing and design process. Several 

zooming options are possible. 

To zoom in or out of a document:  

Do one of the following: 

 Click the Zoom Tool (shortcut Z) and then: 

o Drag on the page—right to zoom in or left to zoom out. 

o Click on the page to zoom in a step. 

o -click on the page to zoom out a step. 

o -drag on the page to zoom into a rectangle area. 

o Select a zoom level from the context toolbar. 

 Click the View Tool (shortcut H) and select a zoom level from the context toolbar. 

 Select the View menu and then Zoom options. 

 Use and your mouse scroll wheel (if available). 

 Zoom in or out using the options in the Navigator panel. 

Shortcuts: 

 Zoom In using +. 

 Zoom Out using -. 

 Zoom to Fit using 0 or double-click the View Tool icon. 

 Zoom to 100% using 1 or double-click the Zoom Tool icon. 

 Actual Size using 8. 

 Pixel Size using 9. 

For Trackpad users, see Gestures. 

When creating a new document, the Document Units define the exact size of your document on 

screen. For example, if you chose 'pixels', one pixel in your document corresponds to one pixel on 

screen; your document will display at its exact pixel size at 100%. Similarly, for physical Document 

Units (e.g., millimeters) you'll get the exact print size on screen using the Actual Size option. 
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Pan/Scroll the Document view 

When your document is zoomed-in, you can work on different areas of your design by using panning. 

To pan an image with the View tool:  

1. From the Tools panel on the left, click the View Tool. 

2. Drag the zoomed-in document in relation to its view. 

Temporarily activate the View Tool by using Hot key panning by pressing . As soon as you release, 

the tool will switch back to the previously selected tool. 

You can also pan the Document view using your mouse wheel, scroll bars, or the Navigator panel. 

For Trackpad users, see Gestures. 
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Save 

When you save your document all project information is preserved, allowing you to edit it at a later 

date. The project is saved as a single file with the extension .afphoto. 

The first time you save your document, you'll be asked to give the project a name and save location. 

Following this, future saves will overwrite the previous version. 

Optionally, you can save a current project as a new project. In this case, the new file will not overwrite 

the saved version. 

A document's history can be saved along with the document, so earlier edits can be returned to even 

if the document is closed and reopened. 

To save as a new project:  

1. From the File menu, select Save As. 

2. Adjust the dialog settings as required. 

3. Click Save. 

To save the current project:  

 From the File menu, select Save. 

If you have only made modifications that are supported by an image file type (for example, a JPG or 

PNG), then using the Save function will simply save over the top of the current file. If you have made 

modifications that are not supported, such as adding layers, then you can save the image as a project 

file (click Save As) or flatten and merge the changes to the existing file (click Save, then Save 

Flattened in the dialog). 

To save history with a document:  

1. From the File menu, select Save History With Document. 

2. In the Saving With History dialog, click Yes to accept the conditions discussed in the dialog. 

3. Save your document. 

Saving your document's history with your document may significantly increase the size of your project 

file. 

You can switch off the save history feature by repeating step 1 of the procedure above. 

Affinity Photo autosaves your document at regular intervals. To change the autosave interval, go to 

Affinity Photo>Preferences (Performance). 

Affinity Photo autosaves your document at regular intervals. To change the autosave interval, go to 

Edit>Preferences (Performance). 



Developing a raw image using Develop Persona 

Develop Persona is a dedicated environment used for processing raw images captured using a digital 

camera. 

Working in Develop Persona 

If a supported raw file format is opened in Affinity Photo, it will automatically display in Develop 

Persona. You can then process the image using the dedicated adjustments, panels and tools. 

Develop Persona gives you access to the following: 

 Develop Assistant to choose a RAW engine for RAW processing, 16-bit or 32-bit output, and 

to enable/disable automatic tonal and/or exposure adjustments on loading the RAW image. 

 Develop Assistant to enable/disable automatic tonal and/or exposure adjustments on 

loading the RAW image. 

 Tonal adjustments using the Basic and Tones panels. 

 Sharpening and Noise adjustments using the Details Panel. 

 Lens correction adjustments using the Lens Panel. 

 Overlays for applying adjustments to specific brushed image regions. 

 Crop tool for cropping your image. 

 Blemish Removal tool for correcting image imperfections. 

 Focus Panel. 

 Scope Panel. 

At any point while working with an image or any selected pixel layer, you can switch to Develop 

Persona to make use of its unique features. 

Split view options 

There are a variety of split view options available in Develop Persona which give you the opportunity 

of seeing how your processed image compares to the original raw data. 

 None—presents the processed image in isolation on a single page. 

 Split—presents the processed and original raw images simultaneously on the same page. A 

sliding divider can be repositioned to view the image 'Before' and 'After' processing. 

 Mirror—presents the processed and original raw images simultaneously on separate pages. 

Panning and zooming affects both pages simultaneously so the same area is always displayed 

in both pages. 
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Rather than comparing the processed image with the original raw data, you can sync the views so 

'Before' adopts the current applied adjustments. The 'After' view continues to update as more 

adjustments are made. See below for details. 

Syncing 

While applying adjustments, you can update the 'Before' and 'After' view to give you a more focused 

representation of the applied changes. 

 Sync Before—updates the 'Before' view using the settings applied in the 'After' view. 

 Sync After—removes all the settings applied in the 'After' view to return the image to the 

'Before' view. 

 Swap—switches the applied settings of the 'Before' and 'After' views. 

Show Clipping 

An incorrect level of exposure within an image can lead to pixels 'falling out' of the viewable intensity 

range. This results in the loss of detail in areas of shadow, highlights, or midtones and is known as 

clipping. 

In Develop Persona, you have the ability to display Clipped Shadows, Clipped Highlights and/or 

Clipped Tones directly on the image. This can help you identify areas which need correcting as well as 

preventing overenthusiastic modifications which result in clipping. 

To work in Develop Persona:  

1. Do one of the following: 

o Open a raw image. Develop Persona will analyze the data and pre-process it, ready 

for editing.* 

o Select a pixel layer and then, from the Persona toolbar, click Develop Persona. 

2. Activate your preferred view mode. 

3. Adjust the image using the various panel options and tools. 

4. (Optional) Sync applied settings within the view and repeat the above step. 

5. On the context toolbar, select Develop. 

The photo or layer will adopt all the settings as displayed in the 'None' or 'After' view. The 

'Before' view is for comparison purposes only. 

*To remove the pre-processing from a raw image, change the develop options available in the 

Develop Assistant. 

When adjusting settings, you can double click each adjustment slider to reset it to its default value. 
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To activate view modes:  

On the Toolbar, do one of the following: 

 Click None to display the processed image in isolation. 

 Click Split to display both processed and raw image on the same page. 

 Click Mirror to display processed and raw image side-by-side on separate pages. 

To synchronize applied settings in view modes:  

On the Toolbar, do one of the following: 

 Click Sync Before to update the 'Before' view to the most recent applied settings. 

 Click Sync After to revert the settings applied in the 'After' view back to the settings shown in 

the 'Before' view. 

 Click Swap to switch the applied settings between the views. 

To show clipping:  

On the Toolbar, do one of the following: 

 Click Show Clipped Highlights to display all 'blown' highlights as a high-contrast red color. 

 Click Show Clipped Shadows to display all clipped shadow areas as a high-contrast blue 

color. 

 Click Show Clipped Tones to display all clipped midtone areas as a high-contrast yellow 

color. 

To change initial develop settings:  

On the Toolbar, do the following: 

1. Click the Develop Assistant to open its settings dialog. 

2. Choose from the following settings: 

o RAW Engine: Provides a choice of RAW processing engines for you to use—Affinity's 

own Serif Labs engine or Apple's Core Image RAW engine. 

o RAW output format: Choose between RGB (16 bit) or RGB (32 bit HDR) output 

when developing a raw image. Choosing RGB (32 bit HDR) allows you to maintain a 

full 32-bit float environment from initial raw development to export and take 

advantage of extra precision. 

o Tone curve: If the default 'Apply tone curve' option is active, your raw image is 

adjusted using a suggested tone curve. The 'Take no action' option makes no tonal 

correction; the image can be altered within the Basic panel later. 



o Alert when assistant takes an action: When checked, a pop-up message appears on 

loading the RAW image to indicate that adjustments have been applied automatically. 

o Exposure bias: Choose whether to apply exposure bias value if stored in the raw 

image's EXIF data. Like Histogram stretch, both 'default' and 'initial' give the same 

results but reports zeroed or actual values, respectively. The 'Take no action' option 

ignores the exposure bias value. 

o Map default region: Sets the region that displays in the Location panel, if the raw 

image contains no GPS location data in its EXIF data. 

If you choose not to apply initial develop settings, your images will not undergo any processing. They 

may look flat, dull in tone and lacking contrast, but you will have absolute control in how the image is 

processed. This approach is similar to "log" video footage that maintains maximum dynamic range 

before color grading. 

  



Using overlays 

The Overlay tools can be used in combination with the Overlays panel to allow you to apply standard 

adjustments to isolated areas of an image. 

About overlays 

Overlays are elements within Develop Persona which are placed on top of an image. Any adjustment 

applied to an overlay affects the image below. 

However, overlays can have a varying level of visibility, which varies the impact its adjustments have 

on the underlying image. In this respect, Overlays in Develop Persona act in a similar way to masks in 

Photo Persona. 

Areas of an overlay which are transparent ignore the overlay's adjustments, while opaque areas 

display the applied adjustments. Areas of semi-transparency (such as those created with the Overlay 

Gradient Tool) will display the adjustments by a varying degree. 

The adjustments applied to an overlay are determined using the Overlays panel. 

Types of overlay 

There are two types of overlay: Brush and Gradient. 

Brush overlays can only be edited using the Overlay Paint and Overlay Erase tools. Areas are added 

to an overlay using the Overlay Paint Tool. Areas are removed using the Overlay Erase Tool. 

The Overlay Gradient Tool applies a gradient from transparent to opaque across Gradient overlays 

only. 

Settings (  Overlay Paint and Erase Tools only) 

 Size—controls the size of the overlay brush in pixels. 

 Hardness—how hard the edges of the brush are. The painted overlay appears softer and 

more feathered as the percentage decreases. 

 Edge Aware—when checked, enables edge detection, which allows for easier overlay painting 

around edges without having to zoom in and reduce the brush size. 

To create an overlay:  

Do any of the following: 

 On the Overlays panel, select Add Brush Overlay to create a transparent, pixel overlay. 

 On the Overlays panel, select Add Gradient Overlay to create an opaque Gradient overlay. 
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 With no overlay selected, drag on the image with the Overlay Paint Tool. A Brush overlay is 

added automatically. 

 With no overlay selected, drag on the image with the the Overlay Gradient Tool. A Gradient 

overlay is added automatically. 

To apply adjustments to an overlay:  

1. On the Overlays panel, select an overlay. 

2. From the Basic panel, click an adjustment's checkbox to activate it. 

3. Drag the adjustment slider to set the value. 

4. Click Reset to set the adjustments slider(s) back to default. 

To remove an overlay:  

On the Overlays panel: 

1. Select an overlay. 

2. Click Delete Overlay. 

Basic Panel (Develop Persona only) 

The Basic panel provides standard adjustments which can be applied to an image. 

Available Adjustments: 

 Exposure—adjusts the overall exposure of the image, changes black point and overall 

brightness. 

 Enhance—adjusts contrast, clarity, saturation and vibrance. 

 White Balance*—removes undesirable color casts from a photo by adjusting the 'temperature' 

of the light. The default value is the 'As shot' White balance setting from your camera. 

 Shadows & Highlights—applies tonal adjustment to the darkest and/or lightest areas in a 

photo. 

 Profiles—sets a system-installed ICC Output Profile for color managing the developed image. 

Settings 

 Preset—manages adjustment presets via a pop-up menu. 

o Add Preset—saves the current adjustment settings as a named preset for later use. 

The pop-up menu populates with the preset name on saving. 
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o Delete Preset—deletes the preset currently checked in the Preset pop-up menu. 

o Default—reverts the current adjustment settings back to default settings. 

 Active/Inactive—when checked, the adjustment is applied to the image. 

 Reset—sets adjustment slider(s) back to default. 

*The White Balance adjustment can be set automatically using the White Balance Tool. 

Tones Panel 

The Tones panel provides adjustments for correcting the tonal and color values of pixels in an image. 

Available Adjustments: 

 Curves—uses graph manipulation to precisely adjust the lightness and contrast of a photo. 

 Black & White—converts a color photo to grayscale. 

 Split Toning—tints and recolors highlights and shadows. 

Settings 

 Preset—manages adjustment presets via a pop-up menu. 

o Add Preset—saves the current adjustment settings as a named preset for later use. 

The pop-up menu populates with the preset name on saving. 

o Delete Preset—deletes the preset currently checked in the Preset pop-up menu. 

o Default—reverts the current adjustment settings back to default settings. 

 Active/Inactive—when checked, the adjustment is applied to the image. 

 Reset—sets adjustment slider(s) back to default. 
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Details Panel (Develop Persona only) 

The Details panel provides adjustments to refine the edges of images and remove (or add) noise. 

Available Adjustments: 

 Detail Refinement—sharpen edges to add clarity to raw images. Can be used in conjunction 

with the Noise Reduction adjustment. 

 Noise Reduction—reduce and remove random luminance and/or color pixels. 

 Noise Addition—adds random pixels to an image to introduce and enhance noise. 

Settings 

 Preset—manages adjustment presets via a pop-up menu. 

o Add Preset—saves the current adjustment settings as a named preset for later use. 

The pop-up menu populates with the preset name on saving. 

o Delete Preset—deletes the preset currently checked in the Preset pop-up menu. 

o Default—reverts the current adjustment settings back to default settings. 

 Active/Inactive—when checked, the adjustment is applied to the image. 

 Reset—sets adjustment slider(s) back to default. 
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Lens Panel (Develop Persona only) 

The Lens panel provides adjustments which can be used to correct lens distortions which can appear 

in images. 

Available Adjustments: 

 Lens Correction—fixes various types of lens distortion by straightening and aligning lines in 

an image. 

 Chromatic Aberration Reduction—fixes chromatic aberration by realigning blue, green, and 

red planes. 

 Defringe—corrects purple fringing (bichrominance) at the edges of high contrast areas. 

 Remove Lens Vignette—corrects unwanted vignetting by adjusting the brightness at the 

edges of an image. 

 Post Crop Vignette—As with Lens Vignette but adjusted after a crop has been applied to an 

image. 

Settings 

 Preset—manages adjustment presets via a pop-up menu. 

o Add Preset—saves the current adjustment settings as a named preset for later use. 

The pop-up menu populates with the preset name on saving. 

o Delete Preset—deletes the preset currently checked in the Preset pop-up menu. 

o Default—reverts the current adjustment settings back to default settings. 

 Active/Inactive—when checked, the adjustment is applied to the image. 

 Reset—sets adjustment slider(s) back to default. 
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Overlays Panel (Develop Persona only) 

The Overlays panel (in combination with the Overlay tools) allows you to apply standard adjustments 

to isolated areas of a raw image. 

About the Overlays panel 

The Overlays panel allows you to add new blank overlays to your raw image as well as setting the 

adjustments which are applied to individual overlays. 

Options 

The following options are available in the panel: 

 Opacity—Adjusts opacity of the selected overlay. 

 Add Brush Overlay—adds a new overlay set which can be modified using the Overlay 

Paint and Overlay Erase tools. 

 Add Gradient Overlay—adds a new overlay set which can be modified using the Overlay 

Gradient Tool. 

 Delete Overlay—removes the currently selected overlay set. 

Focus Panel (Develop Persona only) 

The Focus panel reports the camera settings at the point at which the image was captured. Reported 

settings include Mode, Beam, CoC and Hyperfocal. 

Settings 

The following settings are available in the panel: 

 Show AF Regions—when selected, areas of the image, which are within the auto focus region 

set by the camera, are highlighted. 
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Changing image size (scaling and resampling) 

In Affinity Photo there are options to change a document's or image's pixel dimensions and/or print 

resolution. 

You can change the 'size' of an image by scaling or resampling it. These can be undertaken 

independently or simultaneously. 

Scaling 

Scaling will embed a specific print resolution into an image's metadata to force it to print at a specific 

dpi (e.g. 300 dpi). The image's pixel dimensions remain unaffected. 

Resampling 

Resampling will do one of the following: 

 increase the number of pixels in an image (i.e stretch it) to make its overall pixel dimensions 

bigger. This is known as upsampling. This will also increase the image's file size. 

 decrease the number of pixels in an image (i.e compress it) to make its overall pixel 

dimensions smaller. This is known as downsampling. This will also decrease the image's file 

size. 

When you resample an image, you have the option to: 

 Maintain the image's aspect ratio or resize unconstrained. 

 Select from a variety of interpolation methods (see note below). 

 Simultaneously scale your image. 

Resampling may be carried out to: 

 Enlarge an image to specific dimensions in preparation for printing. 

 Reduce an image for on-screen display and to optimize file size. 

To scale an image:  

1. From the Document menu, select Resize Document. 

2. Ensure the Resample option is switched off. 

3. Change the DPI to control the number of pixels (dots) which will be printed per inch when 

your document is printed. Set higher values (e.g., 300dpi) for professional printing. 

4. Click Resize. 

You will see no change in the image on the page as this procedure only affects the image's metadata. 



To resample an image:  

1. From the Document menu, select Resize Document. 

2. Ensure the Resample option is switched on. 

3. Enter your new document dimensions in the Size boxes—left box for width, right box for 

height. 

o To resize the width and height independently, click the lock icon (to unlock) between 

the Size boxes. 

4. (Optional) Select a different measurement unit from the Units pop-up menu. Rulers will 

update to the new measurement unit. 

5. Change the DPI to control the number of pixels (dots) which will be printed per inch when 

your document is printed. Set higher values (e.g., 300dpi) for professional printing. 

6. Select a Resample method from the pop-up menu. 

7. Click Resize. 

Resampling methods 

The following resample settings are available: 

 Nearest Neighbor—simple resampling which has the fastest processing time. Use for hard-

edge images. 

 Bilinear—algorithmic resampling for use when shrinking images. 

 Bicubic—algorithmic resampling for use when enlarging images. Resampling is smoother 

than Bilinear but has a slower processing time. 

 Lanczos 3—complex algorithmic resampling which gives the best results but with the longest 

processing time. Available as 'separable' and 'non-separable'; the latter gives marginally better 

results, but is slightly slower than 'separable'. 

Instead of adding absolute input values you can enter expressions instead. See Expressions for field 

input for details. 
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Pixel Art resizing 

The Resize Pixel Art Document option, found on the Document menu, allows you to upsample your 

document using one of two renowned pixel art resampling algorithms: XBR and HQX. 

 



Before: Image upsampled 4x using Bicubic filter. Observe the jaggy edges and ringing. 

After: Image upsampled 4x using XBR filter. See how the edges are smoother and more 

refined.To resize using pixel art filters:  

1. From the Document menu, select Resize Pixel Art Document. 

2. Choose from either HQX or XBR as the resampling method, and pick a size multiplier from 

2x, 3x or 4x. 

If you are seeking very smooth results, it is recommended to try XBR as the resampling method. HQX 

produces sharper results but exhibits more jaggedness around fine edges. 

  



Changing canvas size 

In Affinity Photo there are options to resize the canvas of opened images and newly created 

documents. 

Changing the canvas size involves adding or taking away pixels from around the edge of your image, 

much like adding a border to a picture or cropping the image to a smaller size, respectively. 

Unaffected pixels are not stretched or squashed. 

 

 
Resizing the image canvas 



Unwanted canvas area can be removed (trimmed) from the document edge, and conversely, you can 

expand your canvas to fit layer content which extends over your document edge. 

To change canvas size:  

1. From the Document menu, select Resize Canvas. 

2. Enter your new canvas dimensions in the Size boxes—left box for width, right box for height. 

o To resize the width and height independently, click the lock icon (to unlock) between 

the Size boxes. 

3. (Optional) Select a different measurement unit from the Units pop-up menu. Rulers will 

update to the new measurement unit. 

4. In the Anchor box, select alignment options to resize the the canvas 'under' the image from 

that anchor point. 

5. Click Resize. 

To remove unwanted canvas areas:  

 From the Document menu, select Clip Canvas. 

To expand the canvas to fit layer content:  

 From the Document menu, select Unclip Canvas. 

  



Cropping and straightening 

Cropping removes unwanted areas of your image for either practical reasons or better composition. 

Straightening simply means correcting a crooked image. 

About cropping 

Use cropping for practical reasons or aesthetic reasons equally. For instance, an unwanted object or 

person can be excluded which might otherwise detract from your desired image. Aesthetically, you 

can balance image content in your composition so that it is more appealing to the eye. 

Affinity Photo lets you crop unconstrained or to original or custom aspect ratios. For print or web 

delivery, you can specify common print sizes (e.g., 6" x 4") or create pixel-accurate custom crop 

regions, respectively. 

If snapping is active, the crop area can snap to page edges and guides when being resized or moved. 

Original / Portrait / Rotational / 16x9 Ratio / Absolute Pixel / 6x4" Print Crop 
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The Crop Tool affects the entire canvas, which is typically the native dimensions of an opened image. 

When a crop is applied, the regions outside the drawn crop area will be hidden. However, cropping is 

non-destructive, which means you can uncrop your image at a later date. 

  



Crop modes 

When cropping, you may wish to work unconstrained or to specific ratios or absolute dimensions. 

These are some of the options available: 

 Unconstrained—The crop area can be sized freely. 

 Original Ratio—Retains your image's original aspect ratio. 

 Custom Ratio—Uses the adjacent input boxes to set the ratio—width in the left box, height 

in the right box. Can be saved as a preset. 

 Absolute Dimensions—Use the adjacent input boxes to set absolute dimensions for the crop 

area. Set your Units if needed. Can be saved as a preset. 

 Presets—A combination of commonly used, and custom saved, presets are presented for ease 

of use. 

Straighten mode 

When activated, dragging on the page will orient the photo to align it with the drawn line. We 

recommend using a reference within your photo such as the horizon or the edge of a building. 

Compositional overlays 

If you're cropping to remove unwanted subject matter in your image, compositional overlays can be 

ignored. However, if you're looking for better composition, one of several overlays can be used. 

 Thirds Grid—Shown by default, the Rule of Thirds grid's intersection lines can be positioned 

over an object of interest in your image. 

 Golden Spiral—Size and position the grid so the inner origin of the spiral is centered over the 

subject of interest; this balances the composition naturally. Also known as Fibonacci Spiral or 

divine proportions. 

 Diagonals—Position two objects of interest under the diagonal line intersections to balance 

the objects against each other. 

You can quickly toggle between these overlays by pressing O. 

To crop an image:  

1. From the Tools panel on the left, select the Crop Tool. 

2. From the context toolbar, select a crop mode from the Mode pop-up menu. 

3. Adjust the context toolbar settings. 

4. Drag a corner or edge handle on the grid to reposition the grid to suit. 



5. From the context toolbar, click Apply. 

To uncrop the cropped image:  

 From the Document menu, click Unclip Canvas. 

To straighten an image:  

1. From the Tools panel on the left, select the Crop Tool. 

2. From the context toolbar, select Straighten. 

3. Drag on the image to define the new alignment. 

4. From the context toolbar, click Apply. 

To save crop settings as a preset:  

1. Adjust the context toolbar settings. 

2. From the context toolbar, click the Mode pop-up menu and select Add Preset. 

3. Type a name for the crop preset, then click OK. 

The new preset will appear at the bottom of the Mode pop-up menu. 

To delete a crop preset:  

1. From the context toolbar, click the Mode pop-up menu and select the preset you wish to 

delete. 

2. Click the Mode pop-up menu again and select Delete Preset. 

  



Transforming  

Layer content can be flipped, rotated, positioned and sized accurately. 

 

 
Flipping an image horizontallyTo flip or rotate layer contents:  

1. Select one or more layers. 

2. From the Arrange menu, select a flip or rotate option. 

You can also rotate layer content directly on the page by dragging its rotation handle or by using the 

Transform panel. 
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To position layer contents accurately:  

1. Select one or more layers. 

2. On the Transform panel, change X and/or Y values. 

To nudge layer content:  

1. Select layer content. 

2. Do one of the following: 

o For nudging by a single unit of measurement: Press an arrow key. 

o For 10x the single unit of measurement: Press an arrow key with the pressed. 

You can change nudge distances via Affinity Photo>Preferences>Tools. 

You can change nudge distances via Edit>Preferences>Tools. 

To size layer content accurately:  

1. Select one or layers. 

2. On the Transform panel, change W and/or H values. 

  



Mesh warping 

Mesh warping lets you distort specific areas of your image without affecting other areas. It can be 

used for dramatic warping effects or for more subtle focused retouching of facial features. 

 

 

Warping an image 



About mesh warping 

The Mesh Warp tool provides a flexible mesh grid which can warp your image by repositioning the 

grid's lines, nodes, and patches; underlying pixels are transformed under the line, node or patch. The 

extent of warping you want to carry out is governed by the complexity of the grid. 

You'll initially start with a mesh grid without lines, but adding your own lines and nodes lets you warp 

with ease. Position lines adjacent to areas in your image that you want to apply warping to. 

To create a mesh:  

1. From the Tools panel on the left, click the Mesh Warp Tool. 

2. Double-click on the edge of the mesh grid—the top edge gives a vertical line; a side edge 

gives a horizontal line. 

3. Repeat for as many lines as you need. 

If you want to start again, click Reset on the context toolbar. 

To add nodes to the grid:  

 Double-click anywhere within the grid. 

To select multiple nodes in the grid:  

Do one of the following: 

 Press the and click each node in turn. 

 Drag across multiple nodes to create a marquee selection. 

To apply warping:  

1. (Optional) On the context toolbar, use the Mode option to manipulate just the grid ('Source') 

or both grid and image simultaneously ('Destination'). 

2. Drag a node, a node's corner handle, line or patch. Patch warping is achieved by clicking in an 

area contained by mesh lines and dragging the circle—this warps the entire area. 

3. Select Apply or press . 

The mesh is really just an assembly of bendable curves. When you alter these curves, distorting the 

grid, the underlying image deforms accordingly. 

  



Perspective 

Perspective gives your image a three-dimensional appearance by applying a warp along one or more 

planes. By reshaping a supporting perspective grid you can transform your image. 

 

 

Using the Perspective Tool to alter the appearance of a building/structure.  To apply 

perspective:  

1. From the Tools panel on the left, click the Mesh Warp flyout, then the Perspective Tool. 

2. (Optional) For two opposing, but independent, perspective planes, select 'Dual Plane' on the 

Planes pop-up menu. 

3. (Optional) Use the Mode option to set the mode in which the grid will operate. 'Destination' 

shows the image with perspective applied. 'Source' lets you size, position and shape the grid 

without affecting the image; you can then apply perspective to the image by jumping back to 

the 'Destination' option and dragging handles. 

4. Drag a corner handle on the grid. Use the to snap a grid handle to vertical or horizontal. 

With Snapping enabled, the grid handles will snap to any page edge. 



About layers 

Layers allow you to edit and design using a non-destructive methodology. This gives you maximum 

flexibility for your photographic projects. 

What are layers? 

You can think of layers as being like sheets of paper that are stacked one on top of the other. 

Transparent areas of a layer reveal the layer below, while opaque parts of a layer obscure the layers 

below. 

All layer management is carried out from the Layers panel. 

Here are some important points regarding layers: 

 Once editing and designing has begun, all documents will have at least one layer. 

 The order of your layers is important. A layer at the top of the panel is at the front of your 

document and vice versa. 

 Any selected layer(s) are highlighted, so that you can always see what layer you are working 

on. 

 Any layer can be hidden, to exclude its content from displaying in your project. 

  

The effect of layer order on a document. 

  



Types of layer 

There are several types of layers that can be created: 

 Pixel layer—containing raster images where pixel-based editing takes place. 

 Mask layer—special layer that allows you to define what content is hidden to reveal layers 

beneath. 

 Adjustment layer—special layer that can be used to correct or enhance the layers beneath. 

 Fill layer—special layer that contains an adjustable solid or gradient color. 

 Snapshot layer—special layer that contains a predefined project snapshot as a single, 

flattened pixel layer. 

 Vector layer—vector content, such as curves, shapes, text and placed images, occupy their 

own unique layer. 

Vector layers are automatically created whenever you: 

 Draw lines and shapes using the Pen Tool 

 Use any geometric shapes 

 Add Artistic or Frame text 

 Use the Place command to add an additional image to your project. 

Create layers 

Empty layers can be created in the Layers panel or from the Layer menu. Layers are created above the 

currently selected layer. Once created, layers can be renamed for easy identification. 

You can also copy and paste selections, layer groups and entire layers using Edit>Copy and 

Edit>Paste. If you copy a layer group, all layers within the group will be duplicated. 

This operation can also be performed between documents. In Separated mode only, you can also drag 

layers between documents from window to window. 

To create a new layer: Do one of the following: 

 From the Layers panel, click Add Layer. 

 From the Layer menu, select New Layer. 

 With no layers selected, paint on your page with the Paint Brush Tool. 

By default, the Assistant will create a new layer to accommodate your paint strokes. 

To change a layer name: Click the layer's label and type a new name. 
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Layer opacity 

A layer's opacity determines how see through a layer is and how much of the layer beneath is 

obscured or revealed. At 1% opacity, the layer is almost transparent, whereas at 100% the layer is 

completely opaque. 

 

 

Before and after opacity reduced. 

Numerical keys can be used to quickly set the opacity of selected layers. 

Different levels of opacity can also be applied to brush strokes, filter effects and the fills of vector 

content. 

To change the opacity of a layer:  



1. From the Layers panel, select one or more layers. 

2. Use the Opacity control to set an opacity value. 

To quickly select an opacity value, drag left or right over the panel's Opacity label. 

To use opacity quick keys:  

1. Select a single layer or multiple layers. 

2. Press a numerical key, or two numerical keys in quick succession, to set the opacity. For 

example: 

o Press 4 for 40% opacity. 

o Press 0 for 100% opacity. 

o Press 4 and 5 for 45% opacity. 

o Press 0 and 7 for 7% opacity. 

Layer blending 

A layer's blend mode determines how the layer's pixels or contents blend with the pixels on the layer 

beneath. 

Blend mode types 

Affinity Photo supports an impressive selection of different blend modes. The most commonly used 

blend modes are as follows: 

 Normal—The default blend mode. The top pixels display over underlying pixels according to 

the level of top layer opacity. 

 Multiply—The blending result is a combination of the top and bottom color at each pixel 

position, always producing a darker value. 

 Screen—The opposite of Multiply, where the blending result is a combination of the inverse 

of the top and bottom color at each pixel position, always producing a lighter value. 

 Overlay—Applies either Multiply or Screen blend mode, depending on the bottom color at 

each pixel position. If the bottom layer pixels are <50% gray, it multiplies; if >50% it screens. 

 Color Burn—Darkens the bottom color pixels relative to the values of the top color pixels. 

Other available blend modes include Darken, Darker Color, Lighten, Lighter Color, Color Dodge, Add, 

Soft Light, Hard Light, Vivid Light, Pin Light, Linear Light, Hard Mix, Difference, Exclusion, Subtract, 

Hue, Saturation, Luminosity, Color, Average, Negation, Reflect, Glow, Contrast Negate, Erase and 

Passthrough. 



Any layer can have a blend mode assigned. The default blend mode is 'Normal'—no special 

compositing is applied. For a layer group, the default is 'Passthrough' (i.e. the group itself has no 

special blend properties of its own). 

The same blend modes can be utilized on layer effects and brushes. 

To change the blend mode of a layer:  

1. On the Layers panel, select a layer. 

2. Choose a blend mode from the pop-up menu on the panel. 

Layer blend ranges 

Blend ranges specify the range of colors on a current layer which are blended with the underlying 

layer(s). 

About blend ranges 

Blend ranges allow you to specify how tonal values of a layer blend with the layer(s) below. You can 

set the range of the tonal values affected and can set the range to have any level of opacity (from 

opaque to transparent). 

 



Before and after blend range applied. 

The blend range of the selected layer and the underlaying layer(s) is controlled in the Blend Ranges 

dialog. 

You can change the blend range for individual color channels within the dialog. 

About blend gamma and antialiasing (RGB documents only) 

The Blend Ranges dialog allows you to adjust the blend gamma of the selected layer. This gives you 

the option of designing using a linear-RGB color space (1.0), regular sRGB-blending (2.2) or any 

gamma value up to 3.0. In other words, it gives you full control over how the tones of semi-

transparent or antialiased edged objects interact with colors underneath. 

 
 

Blue rectangle using regular sRGB-blending (2.2 gamma; before) and linear-RGB (1.0 gamma; 

after). 

By default, text layers are set to a gamma of 1.45 and all other types of layer to 2.2 (regular sRGB-

blending). These default settings can be changed in Preferences (Tools options). 

Antialiasing is the reduction of the jagged appearance of lines on a pixel grid. Antialiasing is 

achieved by the addition of semi-transparent pixels along the line to smooth the transition from the 

line's edge to background objects. This area of transition is sometimes referred to as the antialiasing 

ramp or antialiasing coverage. 

In the Blend Ranges dialog, you can adjust the antialiasing ramp (coverage) of the selected layer. 

 
 

Antialiased line with linear coverage map (before) and custom coverage map (after). Viewed 

at 800% zoom. 
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Settings 

The following settings are available in the Blend Ranges dialog: 

 Gamma—controls the layer's blend gamma. 

 Coverage Map—controls the layer's antialiasing ramp. 

 Channels—controls which channel is affected when adjusting the blend range. Select from the 

pop-up menu. 

The following settings can be adjusted for both the Source Layer Ranges and the Underlying 

Composition Ranges in the Blend Ranges dialog: 

 Graph—controls the affected range of pixels and the opacity of pixels within the specified 

range. 

 In—sets the horizontal position of the selected node. Type directly in the text box or drag the 

pop-up slider to set the value. 

 Out—sets the vertical position of the selected node. Type directly in the text box or drag the 

pop-up slider to set the value. 

 Linear—when selected (default), the graduation between two nodes is linear (i.e. nodes on 

the graph are connected using straight lines). If this option is off, nodes are connected using 

smooth curves. 

 Reset—returns the graph to the default position (a straight line between two nodes 

positioned at the top of the grid). 

 When adjusting the graphs in the dialog it is worth noting the following: 

 The graphs represent tonal values from darkest on the left to lightest on the right. 

 Pixels on the selected layer become less visible as nodes on the Source Layer Ranges graph 

are moved downwards. 

 Pixels on the underlaying layer(s) become more visible as nodes on the Underlying 

Composition Ranges graph are moved downwards. 

To change blend ranges:  

1. On the Layers panel, select a layer and then click Blend Ranges. 

2. Adjust the settings in the dialog. 

3. Close the dialog. 

To adjust a graph directly:  

Do any of the following: 



 Drag a node horizontally to affect more or less pixels. 

 Drag a node vertically to affect the visibility of pixels at the tonal value selected. 

 Click on the curve to add additional nodes. 

 Click to select a node and then press the to remove it. 

To modify the antialiasing ramp:  

1. Click the Coverage Map thumbnail. 

2. From the displayed chart, select a node on the profile's line and drag it vertically or 

horizontally to a new position. 

3. Repeat for other nodes as needed. 

For more complex profiles, click on the profile line to add a node which can be positioned as for any 

generated node. 

To remove antialiasing, set a straight, horizontal profile line at the top of the chart. 

To reset antialiasing ramp to linear:  

1. Click the Coverage Map thumbnail. 

2. From the displayed chart's pop-up dialog, click Reset. 

To save a coverage map profile:  

 Under the chart, click Save Profile. The profile shows under the chart. 

To apply a custom coverage map profile:  

1. Click the Coverage Map thumbnail. 

2. Select a custom profile thumbnail from below the chart. The chart will update, showing the 

chosen profile.  

  



Using adjustment layers 

Adjustment layers allow you to make non-destructive corrections and enhancements to your photo 

project (or individual layers). 

 

 
Before and after a Recolor adjustment layer was applied. 

About adjustment layers 

The Adjustment and Layers panels provide a range of adjustments you can apply to your photo or 

design. Once selected, an adjustment layer is added to the Layers panel. 

There may be times that you only want to apply an adjustment layer to either a single layer or a group 

of layers. This is easily achieved by clipping. 

Adjustment layers also have mask layer properties. Areas of an adjustment layer can be revealed or 

hidden in the same way as with a mask layer. 

If you have a pixel selection in place when you add an adjustment layer, the area selected is 

automatically masked. 
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To apply an adjustment from the Layers panel:  

1. On the Layers panel, select a layer. 

2. Click Adjustments and select an adjustment from the pop-up menu. 

3. If a dialog appears for the adjustment, follow the steps below: 

i. Adjust the settings in the dialog. 

ii. Close the dialog to apply. 

The adjustment is added directly above the selected layer. 

To modify, merge or delete an adjustment layer:  

1. On the Layers panel, double-click the adjustment layer that you want to modify. 

2. Adjust the settings in the dialog. 

3. Close the dialog to apply the changes, Merge to apply the changes and merge the 

adjustment with the layer beneath, or Delete to remove entirely. 

To move an adjustment layer:  

Do one of the following: 

 Drag the adjustment to the top of the Layers panel so it affects all layers below it. 

 Drag the adjustment above or below layers to affect more or fewer layers in the project. 

 Drag the adjustment onto a layer or group to apply the adjustment to that layer or group 

only. 

To mask an adjustment layer:  

1. On the Layers panel, select the Adjustment layer. 

2. Do any of the following: 

o To 'erase' from the mask, paint with the Erase Brush Tool. 

o To 'restore' the mask, select the Paint Brush Tool and paint. 

o To apply a gradient mask, select the Gradient tool from the Tools panel and drag 

across the layer. Adjust the gradient colors from the context toolbar. 

 

  



Using Live Filters 

Live Filters allow you to apply filter effects such as blurring, sharpening, noise and distortion non-

destructively, meaning you can modify or remove the effects without having to use the History panel 

to undo other operations on your work. 

About live filters 

Live filters provide a way of applying creative effects to your images whilst retaining the ability to 

modify the effect settings or remove the effect altogether. The filter is added to the active layer, 

similar to applying Adjustment Layers. 

If you have a pixel selection in place when you add a live filter, the area is automatically masked. 

To create a new live filter:  

Do one of the following: 

 From the Layers panel, click Live Filters and select a filter from the list. 

 From the Layer menu, select New Live Filter Layer. 

To modify, merge or delete a live filter:  

1. On the Layers panel, double-click the live filter that you want to modify. 

2. Adjust the settings in the dialog; the changes will be applied in real time. 

3. Close the dialog to apply the changes, Merge to apply the changes and merge the 

adjustment with the layer beneath, or Delete to remove the filter layer entirely. 

To move a live filter:  

Do one of the following: 

 Drag the live filter to the top of the Layers panel so it affects all layers below it. 

 Drag the live filter above or below layers to affect more or fewer layers in the project. 

 Drag the live filter onto a layer or group to apply the filter to that layer or group only. 

To mask a live filter:  

1. On the Layers panel, select the live filter. 

2. Do any of the following: 

o To 'erase' from the mask, paint with the Erase Brush Tool. 

o To 'restore' the mask, select the Paint Brush Tool and paint. 

o To apply a gradient mask, select the Gradient tool from the Tools panel and drag 

across the layer. Adjust the gradient colors from the context toolbar. 
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Blur filters. 

Gaussian Blur 

The Gaussian Blur filter is used to reduce image noise or detail by creating a pleasing, smooth blur 

using a weighted average. It's especially useful for reducing moiré (interference) patterns. 

 
 

Gaussian blur added to the water. 

About the Gaussian Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls how much dissimilar pixels are blurred. Type directly in the text box or drag 

the slider to set the value. 

 Preserve Alpha—when checked, object edges are not subject to blurring. 
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Box Blur 

The Box Blur filter blurs an image based on the average color of neighboring pixels. At high radius 

levels, this results in an obvious 'box' effect. At lower radius levels, it results in an effect similar to 

Gaussian Blur. 

 
 

About the Box Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls intensity of the filter. Type directly in the text box or drag the slider to set 

the value. 
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Median Blur 

The Median Blur filter broadens color regions in the image. At low settings it’s useful for removing 

noise, especially as it retains edges better than Gaussian Blur. At much higher intensities it introduces 

flat areas of color. 

 

 

Median Blur on a photograph. 

About the Median Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls intensity of the filter. At high levels it creates large, flat areas of color. Type 

directly in the text box or drag the slider to set the value. 
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Bilateral Blur 

The Bilateral Blur filter blurs an image while retaining areas of high contrast. As these contrast changes 

most commonly occur at edges, it makes the filter very useful both for noise reduction and for 

creating interesting stylistic effects. 

 

 

About the Bilateral Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls the size of the area sampled for the blur. Type directly in the text box or 

drag the slider to set the value. 

 Tolerance—controls whether pixels are included within the blur based on the difference 

between tonal values of neighboring pixels. At larger tolerance values, pixels with greater 

tonal differences will be included within the blur. Type directly in the text box or drag the 

slider to set the value. 
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Motion Blur 

The Motion Blur filter blurs in a specified direction to give the impression of movement. This gives an 

effect similar to panning with a camera at slower shutter speeds. 

 
 

Motion Blur can add the impression of speed or movement to images. 

About the Motion Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls the amount of 'zoom'. Type directly in the text box or drag the slider to set 

the value. 

 Rotation—controls the angle at which the blur is applied. Drag the dial to set the value. 
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Lens Blur 

The Lens Blur filter mimics the blur applied to a photo when a wide aperture is used to achieve a 

narrow depth of field. It can be used to improve the composition of a photo by applying a shallow 

depth of field to blur unwanted background. Unlike the Gaussian Blur filter, the Lens Blur filter 

recreates the the bokeh effects generated with a real camera lens. 

 

 

About the Lens Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls the number of pixels affected. Type directly in the text box or drag the slider 

to set the value. 

 Number of Blades—sets the number of virtual aperture blades which controls the shape of 

the 'iris' and the shape of the specular highlights. Type directly in the text box or drag the 

slider to set the value. 

 Blade Curvature—sets how round the iris shape becomes. Type directly in the text box or 

drag the slider to set the value. 

The shape of the iris affects the shape of the specular highlights (bokeh). The most noticeable bokeh 

shapes are created using a low blade curvature and fewer aperture blades. To mimic the effects of 

your own lenses, be sure to match the number of aperture blades. 

file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_gaussianBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Layers/livefilters.html


Depth Of Field Blur filter 

The Depth Of Field Blur filter applies a blur gradient that can be used to simulate extreme depth of 

field and miniaturization effects, such as tilt shift. 

 

 

Using the Tilt-Shift mode to produce a miniature model effect. 



About the Depth of Field Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Modes 

 Elliptical—useful for photos with a single subject, as it creates an graduated elliptical blur 

vignette. 

 Tilt Shift—often used to simulate a scene created by models. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Mode—choose from the pop-up menu to define the type of blur generated. 

 Radius—controls intensity of the blur. Type directly in the text box or drag the slider to set 

the value. 

 Vibrance—controls the color intensity of less saturated colors (a high value increases the 

'model-like' effect). 

 Clarity—increases the local contrast and gives the appearance of increasing the sharpness of 

the image. 

Modifying the applied blur gradient  

The gradient stops determine the position and extent of the transition between the areas in sharp 

focus and those that are blurred. 

 

(A) Focus origin, (B) Inner lines, (C) Outer lines, (D) Transition areas. 
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The focus origin (A) defines the central point at which the image is kept completely in focus. 

Reposition the focus origin by dragging on the stop. 

The inner lines (B) define the width of the area in focus. For the Tilt Shift mode these can be set 

independently by dragging each of the stops in turn, or, symmetrically by dragging one of the stops 

while holding the . The Elliptical mode always matches the shape of the inner lines to the outer lines 

so that only the width can be specified. 

The outer lines (C) define the end of the blur transition. For the Tilt Shift mode, these can be set 

independently by dragging each of the stops in turn, or, symmetrically by dragging one of the stops 

while holding the . The Elliptical mode always sets the stops in pairs. 

The transition areas (D) between the inner and outer lines are where the blurring gradually increases. 

The wider the lines, the more gradual the transition. The area on the outside of the lines has the filter 

applied at the full amount set by the Radius slider. 

The angle of the filter can be changed by dragging the stops at an angle. Once the desired angle is 

achieved, holding the will temporarily lock the angle to allow for further adjustment of the width of 

the adjustment. 

When using the tilt shift effect to "miniaturize" a scene, you will get the best effect if you choose your 

images carefully. Models are generally viewed from above, so the tilt shift effect will work best on 

images taken with an elevated viewpoint and a wide angle of view. Buildings, roads, traffic and 

railways make excellent subjects. 

  



Field Blur filter 

The Field Blur filter lets you control blurring at specific areas of your image. 

 
 

About the Field Blur filter 

Against a uniformly blurred image, one or more selection handles can be added, positioned and 

edited to control the extent of blurring at that handle position, i.e.the focus origin. Multiple areas of 

focus can therefore be created. 

Handles are independent of each other and can be repositioned and edited individually. 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Global Radius—controls the intensity of the blur across the whole image. Type directly in the 

text box or drag the slider to set the value. 

 Selected Handle Level—controls the amount of blurring at the selected handle. Decreasing 

the value brings the image under the handle increasingly into focus. 

 Selected Handle Power—controls the extent of the transition out from the area under the 

handle between sharp focus and blurring. 

To add additional selection handles:  

 Click on the page. 

A selected handle shows as a double ring, as opposed to a single ring (deselected). 
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Diffuse Glow 

Diffuse Glow broadens highlights in the active layer or selection by brightening gradually outward 

from existing highlights, producing a soft halo effect. This creates a romantic, almost dreamy effect, 

similar to that of photographing an image through a soft diffusion filter. 

 
 

Using diffuse glow to add intensity and softness to the highlights of an image. 

About the Diffuse Glow filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls how much the pixels surrounding the highlights are affected. Type directly 

in the text box or drag the slider to set the value. 

 Intensity—controls the strength of the highlights. Type directly in the text box or drag the 

slider to set the value. 

 Threshold—determines the range of lightness values affected. As the tolerance decreases, the 

effect spreads to areas that were darker to begin with. Type directly in the text box or drag the 

slider to set the value. 

 Opacity—alters the transparency of the effect. Type directly in the text box or drag the slider 

to set the value. 
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Sharpen filters. 

Clarity 

The Clarity filter enhances the local contrast in an image. Its greatest influence is in the mid-tonal 

range. This results in a sharpening effect. 

 
 

Using the Clarity filter to accentuate the outline and details of the image's subject. 

About the Clarity filter 

In Photo Persona, this filter can be applied as a non-destructive, live filter. It can be accessed via the 

Layer menu, from the New Live Filter Layer category. 

In Develop Persona, this filter is available on the Basic panel (Enhance). 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls intensity of the filter. Type directly in the text box or drag the slider to set 

the value. 

Setting the value via a text box is not available in Develop Persona. 
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Unsharp Mask 

In spite of its misleading name, the Unsharp Mask filter is a flexible and powerful way to increase 

apparent sharpness in an image. 

 
 

Unsharp Mask can be used to add punch to an image, or to help sharpen soft images. 

About the Unsharp Mask filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls the number of pixels affected around the existing light pixels. A smaller 

radius enhances smaller scale detail. Type directly in the text box or drag the slider to set the 

value. 

 Factor—controls how much contrast is added. Type directly in the text box or drag the slider 

to set the value. 

 Threshold—controls how much contrast there needs to be between colors before the 

sharpening effect 'kicks in'. Use higher values for grainy images or skin tones. 

The Unsharp Mask filter affects the whole image (or selection). For fine control, it can be useful to 

apply it to a separate duplicate layer(s), and then either use a mask to allow sharpening of only 

specific areas, or use blends modes set to lighten/darken and change the opacity of these layers to 

get the effect that you want. 

  

file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Layers/livefilters.html


High Pass 

The High Pass filter retains details where sharp color transitions occur, generally at the edges, and 

suppresses the rest of the image.  

 
 

High Pass filter applied with an Overlay blend mode for sharpening. 

About the High Pass filter 

When a High Pass filter is applied at a high radius value to a duplicate layer and combined with a 

contrast blend mode (such as overlay, soft light or hard light), it can be used as a useful sharpening 

technique. 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls how many pixels are kept and how many are suppressed. (At higher radius 

values, only edge pixels are kept.) 

 Monochrome—when selected, the final effect only contains grayscale values. 
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Distort filters. 

Ripple 

The Ripple filter adds a watery, undulating pattern, like ripples on the surface of a pond. 

 
 

The Ripple filter used to achieve a unique effect. 

About the Ripple filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Drag on the image to set the origin. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Intensity—controls the extent of the effect. Type directly in the text box or drag the slider to 

set the value. 
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Twirl 

The Twirl filter applies a clockwise or counter-clockwise distortion effect to images. 

 
 

The Twirl filter applied to a fireworks photograph. 

About the Twirl filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Drag on the image to set the origin. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Angle—sets the type and value of the distortion. Negative values give a counter-clockwise 

effect, positive values give a clockwise effect. Type directly in the text box or drag the slider to 

set the value. 

 Radius—changes the number of pixels affected. Type directly in the text box or drag the 

slider to set the value. 
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Spherical 

The Spherical filter gives objects the appearance of being wrapped around a spherical shape, 

distorting the image and stretching it to fit the curve. 

 
 

Sharks have good days too! 

About the Spherical filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Drag on the image to set the origin. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Intensity—sets the type and value of the distortion. Negative values give a concave effect, 

positive values give a convex effect. Type directly in the text box or drag the slider to set the 

value. 

 Radius—controls the size of the effect. Type directly in the text box or drag the slider to set 

the value. 
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Displace 

The Displace filter applies distortion according to a pattern defined by a displacement map. The 

lightness values of pixels within the displacement map determine the degree to which the distortion 

occurs. 

 
 

Using a texture as a displacement map to blend objects together. 

About the Displace filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Strength—sets the intensity of pixel displacement. Negative values shift pixels upwards, 

positive values shift pixels downwards. Type directly in the text box or drag the slider to set 

the value. 

 Scale To Fit—when selected (default), the displacement map stretches or shrinks to fit the 

document size. If this option is off, the displacement map retains its native dimensions. 

 Load Map From File—sets the displacement map used in the filter. In the pop-up dialog, 

navigate to and select a file, and click Open. 

 Load Map From Layers Beneath—determines the displacement map using layers beneath 

the selected layer. 
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Pinch/Punch 

The Pinch/Punch filter can be used either in small amounts to correct or enhance portraits, or in 

extreme amounts to create bizarre effects. 

Pinch creates a concave spherical distortion (squeezes an area) and Punch creates convex spherical 

distortion (bulges an area). 

 
 

About the Pinch/Punch filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Drag on the image to set the origin. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Pinch/Punch—sets the type and value of the distortion. Negative values give a pinch effect, 

positive values give a punch effect. Type directly in the text box or drag the slider to set the 

value. 

 Radius—controls intensity of the filter. Type directly in the text box or drag the slider to set 

the value. 
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Lens Distortion 

The Lens Distortion filter provides a way of correcting distortion caused by the curvature of a camera 

lens. It's especially useful for correcting barrel distortion (where straight edges are bowed outwards), 

or for correcting pincushion distortion (where straight edges are bowed inwards). 

 
 

About the Lens Distortion filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Drag on the image to set the origin. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Distortion—controls how much the filter is applied. Type directly in the text box or drag the 

slider to set the value. Drag to the left (negative value) to remove barrel distortion, drag to the 

right (positive value) to remove pincushion distortion.  

Most lenses only need values between +5 and -3 to correct distortion. It's also useful to turn grids on 

so that you can see when the lines are straight. 
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Perspective 

The Perspective filter can be used to either correct converging perspective lines caused by lens 

distortion, or to apply perspective for a creative effect. 

Lens distortion can often cause the perspective of a photo to be out, creating the appearance that 

lines are not vertical or horizontal when they should be. 

 
 

Using the Perspective Tool to alter the appearance of a building/structure. 

About the Perspective filter 

The Perspective filter can be adjusted in single or dual plane mode, if applied via the Filters menu 

(Distort category). If using the non-destructive, live filter, only single plane mode is available. 

The live filter can be accessed via the Layer menu, from the New Live Filter Layer category. 
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Settings 

The following settings can be adjusted in the filter dialog: 

 Planes—the initial grid layout options. Select from the pop-up menu. 

 Mode—the preview options. Select from the pop-up menu. 

o Source—the image remains static as the perspective box is positioned. When the 

perspective filter is applied, the image is stretched and cropped to the original canvas 

size. 

o Destination—the image is directly linked to the perspective box and transforms with 

the box as the anchor points are dragged. 

 Show grid—when selected (default), a grid is displayed between anchor points and lines. If 

this option is off, only anchor points and lines display. 

 Autoclip—(Available in Dual Plane mode) Specifies whether or not to alter the image beyond 

the boundaries of the perspective grid points. If disabled, the image will look continuous; if 

enabled, the image will have visible seams where the perspective tool has been applied that 

can then be retouched. 

 Before/After—if this option is off (default), your page displays your image with the current 

perspective applied. When selected, your page displays the adjusted and original images 

simultaneously with a sliding divider which can be repositioned and shows 'Before' and 'After'. 

  



Noise filters. 

Denoise 

The Denoise filter is a powerful form of noise reduction. At higher settings, it also creates a really 

pleasing, posterizing effect. 

About the Denoise filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

 
 

Settings 

The following settings can be adjusted in the filter dialog: 

 Luminance Denoise—controls the intensity of noise removal from the luminance channel. 

Type directly in the text box or drag the slider to set the value. 

 Color Denoise—controls the intensity of noise removal from the chrominance channel. Type 

directly in the text box or drag the slider to set the value. 

 Detail—controls the final quality of the reduction. Higher values will give a better quality 

finish but the application of the filter will take longer. Type directly in the text box or drag the 

slider to set the value. 

 Contribution—determines the opacity of corrected pixels. '100%' makes corrected pixels fully 

opaque; 50% makes pixels 50% transparent. 

This process is very complex and therefore may take some time to apply. 
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Add Noise 

All digital images have a certain level of noise (random pixel distribution) which helps to create 

atmosphere, texture, and depth. After image manipulation, such as resizing, cloning, applying 

gradients, etc., this texture noise is often lost and the image can take on a very flat appearance. The 

Add Noise filter adds random pixels to the image, introducing a level of noise to help return the 

textures in the image. This also helps to seamlessly blend effects. 

 
 

About the Add Noise filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Intensity—controls the level of noise generated. Type directly in the text box or drag the 

slider to set the value. 

 Monochromatic—When checked, only tones in the image are affected. 

 Noise distribution type: 

o Uniform—produces completely random noise distribution. It is often best used in 

color images. 

o Gaussian—produces a wider range of light and dark pixels as it uses a special curve 

to generate the noise. It's often the best choice for grayscale images. 
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Diffuse 

The Diffuse filter adds noise to the edges in the image (or selection). 

 
 

About the Diffuse filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Intensity—controls the level of noise generated. Type directly in the text box or drag the 

slider to set the value. 
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Color filters. 

Vignette 

The Vignette filter can be used to either add vignetting to an image, or remove it from the image.  

 
 

About the Vignette filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Exposure—sets the type and value of the effect. Negative values darken the effect, positive 

values lighten the effect. Type directly in the text box or drag the slider to set the value. 

 Hardness—controls how much feather/blur is applied to the transition. Type directly in the 

text box or drag the slider to set the value. 

 Scale—controls the size of the vignette. Type directly in the text box or drag the slider to set 

the value. 

 Shape—determines whether the vignette is circular or elliptical. 

  

file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Layers/livefilters.html


Defringe 

Purple fringing, or bichrominance as it's more correctly termed, is a form of chromatic aberration 

caused by the over-excitation of the pixels on the sensor in the camera. The effect can occur anywhere 

within an image but it's most common at the edges of high contrast areas, especially when a dark 

element is strongly backlit, such as branches silhouetted against a blue sky. The Defringe filter 

selectively adjusts these areas to remove the color fringing. 

 
 

Using the Defringe filter to remove purple fringing from the window edges. 

  



About the Defringe filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

On selecting the Defringe filter, it will default to settings which remove the purple fringing, as this is 

the most common type. This can be manually adjusted as necessary in the dialog, or by sampling the 

fringe color on the page to remove it. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Fringe Color—defines the color of the fringe to be desaturated. Drag the slider or click on the 

image to define the hue. 

 Also Remove Complementary Hue—also removes fringing matching the chosen hue's 

complementary color (e.g., choosing purple would also remove yellow fringing). 

 Tolerance—defines how close the fringe color must be to the defined color before it is 

affected. Type directly in the text box or drag the slider to set the value. 

 Radius—defines the radius of the pixels affected around the fringed areas. Type directly in the 

text box or drag the slider to set the value. 

 Edge Brightness Threshold—defines the amount of contrast needed between the fringed 

areas before affecting the pixels. Type directly in the text box or drag the slider to set the 

value. 
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Lighting effects 

The Lighting feature simulates lighting from one or more light sources. 

 

 

About lighting 

Lighting effects simulate ambient, point, directional, and spot lighting in your design. You can 

supplement the single light source with additional light sources for more advanced lighting control; 

different light source types can be used in combination, each being independently configured and 

positioned using on-screen handles. 

Affinity Photo also lets you create lighting effects from 3D bump maps made from texture inherent in 

any image. 

  



Source types 

Different source types give dramatically different results. The types are best imagined with a few 

examples. 

 Spot: Casts a elliptical beam of light focusing on a specific subject of interest, like a torch. 

 Point: Casts omnidirectional light, like a light bulb. 

 Directional. Casts light directionally from infinity, e.g. from the sun. 

Lighting effects can be applied as a non-destructive, live filter, which can be accessed via the Layer 

menu, from the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the dialog: 

 Diffuse—sets the level of diffused 'scattered' light reflected from the surface. Higher values 

reflect more light. 

 Specular—sets the level of light reflected from the surface that reflects in a single outgoing 

direction (rather than being diffused), to form a highlight (hotspot). 

 Shininess—controls the spread of the specular reflection above. Set the value lower for larger 

and more widespread highlights; higher for smaller, sharper highlights. 

 Specular color—sets the color for specular reflection. 

 Ambient—Sets the level of uniform 'background' lighting. 

 Ambient light color—Sets a color for ambient light. 

 Light—Click to select a point light source. You can Add, Copy or Remove additional light 

sources. 

 Type—selects the light source type (see above). 

 Color—selects the light source color. 

 Distance—selects the light source distance from the page. 

 Texture—Creates texture from the image itself. 

For 3D Bump Maps: 

 Load bump map—click to load an image that you want to convert to a 3D bump map. Use 

Clear bump map to remove any applied map. 

 Uncheck Scale Horizontal To Fit to retain the imported images native width. When checked, 

the image is stretched/shrunk to the main image. 
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 Uncheck Scale Vertical To Fit to retain native height. 

 Opacity—alters the transparency of the texture. Type directly in the text box or drag the slider 

to set the value. 

To apply a spot light:  

1. From the Filters menu, select Lighting. 

2. From the Type pop-up menu, select 'Spot'. 

3. Drag the on-screen handle at the apex of the 'fan' shape to adjust the distance and direction 

of the light. 

4. (Optional) Drag the Elevation handle situated along the center line to set the height of the 

spot light above the page. 

5. (Optional) Drag the outer and inner handles at the end of the fan to set the outer and inner 

cone, respectively.  

To apply a point light:  

1. From the Filters menu, select Lighting. 

2. From the Type pop-up menu, select 'Point'. 

3. Reposition the default point light by dragging the center handle over a subject of interest. 

4. Drag the circle's edge inwards or outwards to set the light's distance from the page. 

To apply a directional light:  

1. From the Filters menu, select Lighting. 

2. From the Type pop-up menu, select 'Directional'. 

3. On the Lighting panel, drag the cross-hair within the Direction dial. 

To load a 3D bump map:  

1. On the Lighting panel, click Load bump map, navigate to, then select your image. 

2. Click OK. 

3. Adjust Texture to set the amount of texture displayed. 

  



Shadows / Highlights 

The Shadows / Highlights filter allows for stronger manipulation of the shadow and highlight tonal 

regions in an image. It can be used to reduce contrast, boost shadow detail and recover highlight 

detail. 

 
 

About the Shadows / Highlights filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Shadows Strength—control how much shadow detail is boosted. 

 Shadows Range—specify the tonal range to boost. Moving the slider to the right will boost a 

greater range of shadow tones. 

 Shadows Radius—controls the range of neighboring pixels that are analyzed when boosting 

shadow detail. Moving the slider to the right produces a stronger contrast, similar to the 

Clarity filter. Move the slider to the left for a flatter result. 

 Highlights Strength—control how much highlight detail is recovered. 

 Highlights Range—sets the tonal threshold for recovering highlight detail. Move the slider to 

the right to recover a greater range of highlights. 

 Highlights Radius—controls the range of neighboring pixels that are analyzed when 

recovering highlight detail. Moving the slider to the right produces a stronger contrast, 

moving the slider to the left produces a smoother result but may make posterization more 

visible. 
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Fill layers 

Fill layers contain an adjustable solid or gradient color. They can be used for photo editing and 

corrective or creative purposes. 

 

Fill Layer (radial gradient) based on model's lipstick color. 

When using fill layers it is common to apply a specific opacity and/or blend mode to the layer to 

achieve highly customizable photo effects. 

A fill layer will automatically resize to fill the page if the canvas size is modified. 

To create a new fill layer:  

 From the Layer menu, select New Fill Layer. 

A new layer is added above the current layer (or at the top of the Layers panel if no layer is 

selected) with a solid color applied. 

You can use the Color panel or Swatches panel to update the solid color. Color picking from another 

layer is also popular for harmonizing colors. For details see Selecting colors. 

To apply a gradient to a fill layer:  

1. Select the Gradient tool from the Tools panel. 

2. From the context toolbar, select a fill type from the Type pop-up menu. 

3. Drag the cursor across the content. 

Hold down the to constrain the angle of the gradient path to 45°. 

Once applied, you can modify the gradient and its colors to suit your specific needs. For details see 

Gradient editing. 
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Snapshot layers 

A snapshot layer is created from a predefined project snapshot and is added to your project as a 

single, flattened pixel layer. 

To create a snapshot layer:  

 From the Layer menu, select a snapshot from the New Layer From Snapshot sub-menu. 

The snapshot layer is added above the current layer (or at the top of the Layers panel if no 

layer is selected). 

  



Layer masking 

A layer mask is used to reveal a portion of a layer while the rest of the layer remains hidden. This 

means that you can use a mask layer to 'delete' areas of a layer that you don't want.  

In Affinity Photo, two types of masking are possible: 

 Pixel masking: performs a similar task to the erase tools with one important difference; a 

pixel mask can be modified, or even discarded, at any point in time. 

 Vector masking: this involves using vector content as a mask over another layer that crops to 

the vector content's outline. 

Masking can be applied at any level in the Layers panel—as an independent mask layer or applied to a 

specific layer or to a layer group. This is governed by the mask layer's positioning in the layer stack. 

The non-destructive power of masking 

Masks are applied as a separate layer, allowing them to be freely edited and moved. Mask layers affect 

any layer below them within the Layers panel. They can also be clipped to individual layers so that 

only that layer is affected. Alternatively, mask layers can be added to layer groups so they only affect 

that group. 

Adjustment layers and Live Filter layers also have mask layer properties. Areas of an adjustment layer 

can be revealed or hidden in the same way as with a mask layer. 

To create a mask layer:  

Do one of the following: 

 From the Layers panel, click Mask Layer. 

The added mask will hide areas outside a selection (if a selection is in place) or display the 

entire layer (if no selection is in place). 

 From the Layer menu, select New Empty Mask Layer. 

The added mask will hide the entire layer regardless of any selection in place. 

 From the Layers panel, -click a layer and select Mask to Below. 

The selected layer becomes a mask for the layer below it. 

By default, a created mask layer is clipped to the selected layer or added at the top of the Layers panel 

if no layer is selected. It can be moved within the Layers panel to affect greater or lesser areas. 

You can create a mask from a selection which has been 'painted' on your image using Quick Mask 

mode. See Edit selection as layer using Quick Mask mode for more information. 
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You can use the Pen Tool to draw a closed shape that can be made into a mask. From the tool's 

context toolbar, click Mask. 

To create a luminosity mask:  

1. On the Layers panel, click on the layer's thumbnail with the and s pressed. 

2. From the Layers panel, click Mask Layer. 

To edit a pixel mask:  

1. On the Layers panel, select the mask thumbnail representing the mask layer. 

2. Do one of the following: 

o To 'erase' from the mask, paint on the page using the Erase Brush Tool. 

o To 'restore' the mask, paint on the page using the Paint Brush Tool. A white fill 

completely restores, while greyscale fills partially restore the mask by varying 

amounts. 

o To apply a gradient mask, select the Gradient tool from the Tools panel and drag 

across the layer. Adjust the gradient colors from the context toolbar. 

The Erase Brush Tool always erases using 100% black (ignoring the current fill swatch). 

To refine a pixel mask:  

1. On the Layers panel, select the mask's thumbnail. 

2. From the Layer menu, select Refine Mask. 

To invert a pixel mask:  

1. On the Layers panel, select the mask's thumbnail. 

2. Do one of the following: 

o From the Layer menu, select Invert. 

o On the Channels panel, -click the mask's alpha channel entry and select Invert. 

o Press +I. 

To change pixel mask properties:  

 As you erase or paint on the mask, adjust Width, Opacity, Flow and Hardness from the brush's 

context toolbar. 

To view/edit a pixel mask in isolation:  

 -click on the mask thumbnail. 

To return to normal view, click the thumbnail or press the . 



To hide/show a pixel mask:  

 Uncheck/check the check box on the mask layer. 

To add a vector mask:  

1. Add vector content, e.g., draw a line or shape or add text. 

2. On the Layers panel, drag the created vector content's layer directly onto the thumbnail of 

another 'target' layer. The thumbnail of the target layer changes to indicate that a mask (and 

crop) has been applied. 

To add a pixel mask to vector content:  

1. On the Layers panel, select a layer with vector content. 

2. Paint on the page using the Erase Brush Tool. 

By default, the Assistant will add a layer mask to the selected layer to accommodate your 

paint strokes. Once the mask is in place, you can 'restore' the mask using the Paint Brush 

Tool. 

To delete a mask:  

1. On the Layers panel, select the mask's thumbnail. 

2. Press the . 
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Layer operations. 

Viewing 

Show or hide layers to include/exclude layers (and layer content) in your document and any output. 

Alternatively, you can view and edit a single layer (including layer masks, adjustment layers and fill 

layers) in isolation. 

 

 
Before and after layer hidden.  To hide or show a layer:  



 On the Layers panel, click Show/Hide Layer. 

To hide or show multiple layers simultaneously:  

In the Layers panel: 

1. Select multiple layers using -click or -click. 

2. Click Show/Hide Layer on one of the selected layers. 

To isolate a layer for focused editing:  

 In the Layers panel, -click a layer. 

Select any other layer in the Layers panel to resume standard editing view. 

  



Selecting 

Before you can move or modify layers, you must first select them. Furthermore, you can select and 

edit a single layer (including layer masks, adjustment layers and fill layers) in isolation. 

To select a layer:  

Do one of the following: 

 With the Move Tool selected, click layer content on the page. 

 On the Layers panel, click a layer. 

To select multiple layers:  

Do one of the following: 

 With the Move Tool selected, click the layers' contents on the page while pressing the . 

 With the Move Tool selected, drag to draw a marquee around the layer contents. 

 On the Layers panel, -click each layer. 

 On the Layers panel, -click two layers to select them and all layers between. 

To select a specific child layer:  

1. On the Layers panel, expand the parent layer or layer group to show its contents by clicking 

the layer's arrow. 

2. Click to select the child layer. 

To deselect layers:  

 With the Move Tool selected, click on any empty area of the canvas or anywhere else in the 

Document view. 

To isolate a layer for focused editing:  

 In the Layers panel, -click a layer. 

Select any other layer in the Layers panel to resume standard editing view. 

Modifier keys 

When using the Move Tool, the following modifier keys can be used to aid layer selection: 

 The selects multiple layers by clicking their layer contents in turn. 

 The selects layer content on a layer located behind the currently selected layer. 

You can Lock/Unlock layers from the Layers panel or Layer menu. 

Locate a layer in the Layers panel, by -clicking and selecting Find in Layers Panel. 



Duplicating 

Affinity Photo lets you make duplicate layers to increase workflow or to temporarily create a 'backup' 

layer. A power duplicate feature also allows you to duplicate and repeatedly transform layer contents. 

 

 

Layers panel before and after layer duplication.To duplicate:  

Do one of the following: 

 On the Layers panel, -click a layer or group and select Duplicate. 

 On the page, -drag a selection. 

A duplicated layer is placed immediately above the original layer. 

You can also duplicate a selected layer using the same command from the Layer menu. 

Power duplicate 

If you duplicate a layer(s) and then transform the duplicated contents, you can immediately duplicate 

the transformed content. The transform is applied accumulatively to subsequent duplicates. 

 



(A) original content, (B) original content duplicated and rotated, (C) transformed duplicate 

duplicated numerous times.To 'power duplicate':  

1. Select a layer(s). 

2. From the Layer menu, select Duplicate. 

3. Transform the duplicated layer content. 

4. From the Layer menu, select Duplicate. A duplicate is created and the transform is 

automatically applied to the duplicate. 

5. Repeat step 4 to create more duplicates with the transform accumulatively applied. 

  



Aligning  

Layer content can be aligned on the page accurately using the Arrange commands. 

 

 
Before and after alignment applied. 

Settings 

Settings can be adjusted from the Arrange pop-up panel on the Toolbar: 

 Align to—the pop-up menu sets the alignment criteria for the operation. For example, you 

can align in relation to Selection Bounds, page Spread or page Margin. If margins are not set, 

alignment is to the page edge instead. 

The Arrange pop-up panel also offers options for distributing objects. 

file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/LayerOperations/distribute.html


For aligning layer content across multiple layers, settings can also be adjusted from the context 

toolbar, but always in relation to selection bounds: 

 Align Horizontal—aligns selected layers' contents using the Left edges, Center points, or 

Right edges of the layer content. 

 Align Vertical—aligns selected layers' contents using the Top edges, Center points (Middle), 

or Bottom edges of the objects. 

Make use of more Align options by customizing the Toolbar (View>Customize Toolbar). 

To align layer content:  

1. Select your layer(s). 

2. Do one of the following: 

o On the Toolbar, click Arrange, set your options from the pop-up panel, and then click 

Done. 

o From the Arrange menu, select an alignment option. 

  



Layer clipping 

Clipping involves positioning one layer inside another, creating a parent - child layer relationship. The 

path of the parent layer becomes the new boundaries for the child layer. Any areas of the child layer 

which lie outside the parent layer's path are masked (hidden). 

Clipping can also be used to confine an adjustment, filter or mask to a single layer or layer group. 

 

 
Before and after the middle pixel layer has been clipped to the top pixel layer. 



 

Layers panel showing clipping procedure. 

About clipping 

When scaling a parent layer, child (clipped) layer scale to maintain the correct aspect ratio. Scaling a 

clipped layer has no effect on the parent layer. A clipped layer can be edited independently from its 

parent, e.g. adjusting opacity, and/or blend mode. 

Any layer can act as a parent or child in clipping relationships. Therefore both pixel and vector layer 

content can be either clipped or clipping. 

Layers can be clipped on creation by activating Insert inside the selection targeting. For more 

information, see the Targeting topic. 

To clip layers:  

 On the Layers panel, drag the layer to be clipped on top of the layer which is to perform the 

clipping. 

The clipped layer is nested within the clipping layer in the Layers panel, becoming a child of the 

clipping layer. 

To select clipped layers:  

1. On the Layers panel, expand the clipping layer's contents (if needed) by clicking the layer's 

arrow. 

2. Click to select the clipped layer. 

The clipped layer can now be edited as needed. 

To remove clipping (unclip):  

 On the Layers panel, drag the clipped layer from inside the parent layer. 
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Paste Inside 

This feature allows you to paste on or more layers inside another layer. The layer to be pasted could 

be copied from another document. 

 

 
The model image layer was pasted inside a transparent pixel layer of brush strokes; a light 

blue gradient fill layer was used under other layers.To copy and paste inside:  

1. Select one or more layers from the current or other loaded document. 

2. From the Edit menu, select Cut.* 

3. Select the layer which will act as the parent layer. 



4. From the Edit menu, select Paste Inside. 

The pasted layer is shown within the path of the parent layer, producing layer clipping. 

*Alternatively, you can copy (rather than cut) the layer. From the Edit menu, select Copy. 

  



Distributing 

Layer content across multiple layers can be distributed or spaced evenly on the page using the 

Arrange commands. 

Distribution and spacing 

Distribution involves setting an even distance between layer content across multiple layers. 

 

 
Before and after auto-distribution. 

  



Spacing ensures there is an equal distance between the edges of layer content. 

 

 
Before and after spacing. 

Settings 

Settings can be adjusted from the Arrange pop-up panel on the Toolbar. Distribution is always carried 

out within the selection bounds: 

 Space Horizontally—evenly distributes selected layers' contents horizontally. 



 Space Vertically—evenly distributes the selected layers' contents vertically. 

 Auto Distribute—when selected (default), the selected layers' contents are distributed evenly 

within the selection bounds. If this option is off, a specified distance between selected layers' 

contents can be set adjacent to the Auto Distribute option. 

Make use of more distribute options by customizing the Toolbar (View>Customize Toolbar). 

To distribute layers' contents:  

1. Select your layers. 

2. On the Toolbar, click Arrange, set your options from the pop-up panel, and then click Done. 

  



Grouping 

Layers can be grouped together for easier management and for restricting adjustments or masks to 

particular layers within your project. Layer groups can be nested together within a 'parent' layer 

group. 

Grouped layers remain together so they can be easily selected, moved and copied. Furthermore, once 

a layer group is established, adjustments and masks can be applied to the group and will affect all the 

layers within the group but not those outside the group. 

Groups, and nested groups, can be broken apart at any time into their separate layers. 

Layer groups display as a nested Group layer on the Layers panel. 

To create a group:  

1. Select multiple layers. (In the Layers panel, -click each layer.) 

2. Do one of the following: 

o On the Layers panel, click Group Layers.  

o From the Arrange menu, select Group. 

To ungroup layer content:  

1. On the Layers panel, select the layer group. 

2. From the Arrange menu, select Ungroup. 

To release a layer from a layer group:  

Do one of the following: 

 Drag the layer out of the group to another layer position. 

 -click the layer, and from the menu, choose Release. 

To select a specific layer within a layer group:  

1. On the Layers panel, expand the layer group to show its contents by clicking the layer's arrow. 

2. Click to select a layer within the group. 

  



Merging and flattening 

Merging layers combines multiple layers together. Pixel, vector, mask, adjustment or image layers can 

be merged into a new merged layer or into the first available pixel layer beneath it in the layer stack. 

The entire document can also be flattened to produce a single-layer document. 

Once layers have been merged, they become a single layer and their previous contents are no longer 

separately editable. There are several ways of merging layers. 

To merge all visible layers:  

In the Layers panel: 

1. Click Show/Hide Layer to set the visibility of layers in the project. 

2. -click a layer and select Merge Visible. 

A new layer is added one step above the selected layer. This layer is a merged copy of all visible layers. 

To merge selected layers:  

1. On the Layers panel, select multiple layers using -click or -click. 

2. From the Layer menu, select Merge Selected. 

The selected layers merge down into the lowest layer in the selection. 

To merge a layer with a pixel layer below:  

 On the Layers panel, -click a layer and select Merge Down. 

The selected layer merges with the first available pixel layer beneath it. 

Any non-pixel layer existing between the layers to be merged will not be included in the merge. 

To create a copy of all visible layers merged:  

1. On the Layers panel, click Show/Hide Layer to set the visibility of layers in the project. 

2. From the Edit menu, select Copy Merged. 

A flattened version of the visible layers is added to the Clipboard. 

To flatten all layers:  

 From the Document menu, select Flatten. 

The document will then contain a single flattened layer. 

  



Ordering  

Once created, any layer in the layer stack can be reordered. 

This stacking order will dictate which layer content will show in front of other layer content; the higher 

the layer in the layer stack the more that layer will be brought to the front of the image. 

 

 

The effect of layer order on a document.  To change a layer's position:  

Do one of the following: 

1. From the Layers panel, drag a layer entry up/down the layer stack. When you see a blue line 

between two layers, drop the layer to place. 



2. With layer(s) selected, choose one of the following from the toolbar: 

o Move to Back—repositions the selected layer(s) at the bottom of the layer stack. 

o Back One—moves the selected layer(s) down one position in the layer stack. 

o Forward One—moves the selected layer(s) up one position in the layer stack. 

o Move to Front—repositions the selected layer(s) at the top of the layer stack. 

The above options are also available from the Arrange menu. 

Targeting 

Targeting controls where new layers are placed in the layer stack on creation. 

By default, layers are positioned: 

 Directly above the currently selected layer. 

 At the top of the layer stack, if there is no layer selected. 

This default targeting behavior can be modified so a new layer can be created below the current layer, 

at the top of the layer stack (regardless of selection), or nested inside a layer. 

To change targeting behavior:  

From the Toolbar, choose one of the following: 

 Insert behind the selection 

 Insert at the top of the layer 

 Insert inside the selection 

To revert to default targeting ensure the active button is switched off. 

Alternatively, you can access the default behavior, as well as the other targeting options, from the 

Arrange menu. 

  



Rotating and shearing 

Layer content can be rotated and sheared directly on the page using the Move Tool. 

 

 
Before and after rotate and shear applied. 

Positioning the cursor around the bounding box of your layer content will allow you to rotate or shear 

the layer content. Feedback is provided by the following cursors. 

 

Rotation is also possible about a custom rotation center placed on your page. 

To rotate layer content:  

1. With the Move Tool, select layer content on a chosen layer. 

2. Do one of the following: 



o Drag the selected layer content's rotation handle. 

o Position the cursor close to a corner handle and drag on the page. 

You can rotate layer content with more precision using the Transform panel. 

To move the rotation center:  

1. Select layer content. 

2. Select the Move Tool, then click Show Rotation Center on the context toolbar. The center 

shows centrally within the selected layer content. 

3. Drag the rotation center to a new position in the selected layer content or anywhere on the 

page. 

Once you've moved the center, you can rotate your layer content about it as described above. 

For vector shapes, lines and text, you can snap the rotation center to the bounding box, center, key 

points, or the geometry of other objects (or even the same object). 

To reset the rotation center:  

 Double-click the rotation center. 

To shear layer content:  

1. With the Move Tool, select layer content on a chosen layer. 

2. Position the cursor close to a side handle and drag on the page. 

You can shear objects with more precision using the Transform panel. 

Modifier keys 

When using the Move Tool, the following modifier keys can be used to aid rotating and shearing: 

 The constrains rotation to 15° increments. 

 The shears the opposite edge in the opposite direction by the same value. 

 When rotating from an object or selection's corner handle, the temporarily repositions the 

rotation origin to the opposite corner. 

 When rotating from an object or selection's corner handle, holding the right mouse button 

temporarily repositions the rotation origin to the opposite corner. 

  



Locking 

Locking is useful when you need to prevent a layer from being moved or transformed unintentionally. 

To lock a layer:  

1. On the Layers panel, select the layer to be locked. 

2. Do one of the following: 

o Select Lock/Unlock. 

o From the Layer menu, select Lock. 

Select Lock/Unlock again, or use the Layer menu's Unlock item, to allow the layer to be editable. 

Layers which are locked show in the Layers panel with a lock symbol next to them. Selected locked 

layers appear with crosses around the bounding box. 

Opened images, or images developed from Develop Persona, appear as a locked background layer by 

default. 

Rasterizing 

Shape, Line, and Text layers can be rasterized to create raster layers. This "flattening" operation can be 

performed manually or automatically (when applying filters or retouch brushes). 

Rasterization is only a requirement if the appearance of complex vector gradients or effects need to 

be honored, particularly for print artwork. 

To rasterize a shape, line or text layer:  

 On the Layers panel, -click a layer and select Rasterize. 

When applying filters or retouch brushes to the above layers, automatic rasterization occurs. This 

means the layers can't be edited as vectors afterwards. Ensure shapes, lines and text are completely 

edited to your satisfaction beforehand. 

  



Creating pixel selections 

A pixel selection is simply a drawn area on your image (bounded by a flashing dashed line, often 

called 'marching ants'). A selection is created for various reasons: 

 To limit editing (e.g., painting, applying fills, etc.) to within that selection area only. 

 To selectively copy pixels. 

 As a precursor to creating a mask layer. 

 To draw areas for removal (cutout). 

Selection boundaries are defined depending on whether individual pixels are included or excluded. 

Once your selection has been created, you can invert it so all included pixels are excluded and vice 

versa. 

Selection tools  

There are several tools you can use to create pixel selections: 

 Selection Brush Tool (see Painting pixel selections) 

 Flood Select Tool (see Flooding pixel selections) 

 Rectangular Marquee Tool (see Marquee pixel selections) 

 Elliptical Marquee Tool 

 Column Marquee Tool 

 Row Marquee Tool 

 Free Hand Selection (see Drawing pixel selections) 

Selection procedures  

Alongside the many selection tools available, there are also a variety of procedures you can follow to 

create a pixel selection from: 

 The contents of a layer (see Pixel selections from layers) 

 The luminance of a layer (see Pixel selections from layers) 

 Layer and composite channels (see Pixel selections from channels) 

 Curves and shapes (see Pixel selections from shapes) 

 Tonal or color ranges (see Range pixel selections) 

 Sampled colors (see Sampled color pixel selections) 
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 Quick Masks (see Quick Mask selections) 

 Previously created selections (see Creating outline selections) 

About selection modes 

When working with, and creating, selections, you may have access to the following Modes which 

affect how your selection develops: 

 New—cancels all current selections and creates a new selection. 

 Add—adds areas to the current selection. If there is no selection in place, a new selection will 

be created. 

 Subtract—removes areas from the current selection. 

 Intersect—a new selection area is created from the overlap between the newly added 

selection area and the current selection. 

Modifier keys 

The following Mode modifier keys may be available for some selection tools and can aid in the 

creation of selections: 

 The automatically adds areas to the current selection. 

 The automatically removes areas from the current selection. 

 Dragging using the right mouse button (rather than the left mouse button) automatically 

adds areas to the current selection. 

To select every pixel in the image:  

Do one of the following: 

 On the Toolbar, select Select All. 

 From the Select menu, select Select All. 

To invert a pixel selection:  

With a selection in place, do one of the following: 

 On the Toolbar, select Invert Selection. 

 From the Select menu, select Invert Pixel Selection. 

If you 'invert' when no selection is in place, a marquee is placed around your entire page, therefore 

selecting every pixel in your image. 

To hide/show a pixel selection temporarily:  
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 From the View menu, select Show Pixel Selection. 

To remove a pixel selection:  

Do one of the following: 

 On the Toolbar, select Deselect. 

 From the Select menu, select Deselect. 

  



Painting pixel selections 

Using the Selection Brush Tool you can define a selection by painting on your page. 

Default Selection Brush 'expansion' behavior 

By default the Selection Brush Tool is set to expand the selection to include similar color value pixels 

to those selected, even if these are not directly painted. In other words, the selection will grow up to 

high contrast edges within the image. 

 

 

Before and after selection painted. 
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The number of pixels selected is determined by the size (width) of the brush in two ways: 

 A larger brush size will paint a larger area in one stroke and therefore more pixels are 

selected. 

 A larger brush size will give Affinity Photo a larger sample size in which to determine how far 

the selection should expand when selecting similar color value pixels. 

This makes selecting an area of similar color and tone effortless. 

The selection will only expand to pixels with similar color values if they are adjacent to the stroke 

painted. To select a separated area, you must start another stroke within that area. 

Alternative 'non-expansion' behavior 

As an alternative to the expansion method detailed above, the Selection Brush Tool also has a non-

expansion method of selection. This method will only select pixels which are under the brush when the 

stroke is painted. 

 



 

Difference in selection method between non-expansion (before) and expansion (after).  To 

create a pixel selection:  

With the Selection Brush Tool selected: 

1. Adjust the context toolbar settings. (See Selection Brush Tool for details.) 

2. Drag on your page. 

To refine a pixel selection:  

With the Selection Brush Tool selected, do any of the following: 

 Switch the tool's working Mode on the context toolbar. 

 Change the brush size (Width). 

See the note below for details. 

Modifier keys 

The following modifier keys can be used to aid in the creation of selections: 

 The automatically adds areas to the current selection. 

 The automatically removes areas from the current selection. 

 Dragging using the right mouse button (rather than the left mouse button) automatically 

adds areas to the current selection. 
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 Press the and s and drag on the page. Dragging left or right will decrease or increase the 

brush size, respectively. Alternatively, use the [ or ] s, respectively. 

 Press the right mouse button, then left mouse button and drag on the page. Dragging left or 

right will decrease or increase the brush size, respectively. 

To set 'non-expansion' method:  

 With the Selection Brush Tool selected, on the context toolbar, ensure the Snap to edges 

option is off. 

  



Flooding pixel selections 

Using the Flood Select Tool you can define a selection of similar color value pixels with a single click. 

Flooding and tolerance 

When using the Flood Select Tool, Affinity Photo will analyze the target (clicked) pixel and use its color 

value to create a selection which includes pixels with similar color values. 
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Before and after pixel clicked. 

The number of pixels selected is determined by the tool's tolerance setting. The higher the tolerance 

the more variance allowed between the target pixel and selected pixels. Therefore a higher tolerance 

will likely lead to more pixels being included in the selection. 

This makes selecting an area of similar color and tone effortless. 

Contiguous behavior 

By default, flood selecting is contiguous. This means pixels with similar color values must be adjacent 

to one another to be selected. Therefore, pixels must be directly connected to the target pixel (or 

other selected pixels) to be selected. If there is a high contrast edge between areas of similar color, the 

pixels on the opposite side of the edge will not be selected using a single click. 

As an alternative, the contiguous behavior can be switched off. This will mean pixels of similar color to 

the target pixel will be selected regardless of their position within the image. 

 

 



Difference in selection method with contiguous on (before) and off (after).  To create a 

pixel selection:  

With the Flood Select Tool selected: 

1. (Optional) On the context toolbar, set the Tolerance. 

2. Click on your page. 

To create a pixel selection using multiple target pixels:  

With the Flood Select Tool selected: 

1. On the context toolbar, set the Mode to Add. 

2. Click on your page. 

3. Repeat step 2 as needed. 

Alternatively, you can subtract or intersect a 'flood selection' from the current selection using the 

other Mode options. For more information on the available selection modes, see Creating pixel 

selections. 

To switch off contiguous selection:  

 With the Flood Select Tool selected, on the context toolbar, ensure the Contiguous option is 

off. 
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Drawing pixel selections 

Using the Free Hand Selection tool you can draw on your page to define a pixel selection. As your 

cursor moves across the page, the selection will extend to follow its path and continually be 

connected to the initial starting point. 

 

Free hand selection in the process of being drawn.  To create a pixel selection:  

With the Free Hand Selection tool selected: 

 From the context toolbar, choose from the Freehand, Polygonal or Magnetic selection types. 

 With the Freehand type: 

o Click-drag to add freehand lines to the selection. 

o Hold the whilst single clicking to add straight lines to the selection. 

 With the Polygonal type: 

o Single-click to add straight lines to the selection. 

o Click-drag to add freehand lines to the selection. 

o Hold the whilst dragging to add magnetic lines to the selection. 

 With the Magnetic type: 

o Single-click then drag to add magnetic nodes that snap to edges. 

o Click-drag to add freehand lines to the selection. 

o Hold the whilst single clicking to add straight lines to the selection. 



Range pixel selections 

You can create a pixel selection using color, tonal or transparency (alpha/opacity) ranges from your 

image. 

If you decide to create a selection based on any range, your image is analyzed and all pixels which fall 

into the chosen range are included in the selection. Pixels which are not in the chosen range are 

excluded. 

Color, tonal and transparency range selections are available from the Select menu. These include: 

 From the Color Range sub-menu: 

o Select Reds 

o Select Blues 

o Select Greens 

 From the Tonal Range sub-menu: 

o Select Midtones 

o Select Shadows 

o Select Highlights 

 From the Alpha Range sub-menu: 

o Select Fully Transparent—only pixels which have an opacity of 0% are selected. 

o Select Partially Transparent—all pixels with a transparency higher than 0% are 

selected. 

o Select Opaque—only pixels that are 0% transparent are selected. 

Try creating range pixel selections before applying an adjustment layer. This allows you to target the 

adjustment directly to any one of the Color or Tonal ranges. 
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Pixel selections from layers 

You can create pixel selections based on layers (or layer groups) or layer luminance. 

If the layer or layer group contains areas which have an opacity lower than 100%, these are partially 

selected. This partial selection is based on the percentage of their opacity (i.e. areas of 20% opacity 

will be selected by 20%). Transparent areas will not be included in the selection. 

A selection marquee only appears around areas which are selected by more than 50%. Areas selected 

by 50% or less will not display a marquee at their edges. 

To create a pixel selection from layer contents:  

Do one of the following: 

 On the Layers panel, select a layer. From the Select menu, select Selection From Layer. 

 On the Layers panel, click the chosen layer's thumbnail while pressing the . 

To create a pixel selection from layer luminance:  

 On the Layers panel, click the chosen layer's thumbnail while pressing the s. 

  



Pixel selections from channels 

You can create pixel selections based on a single channel or combination of channels. This feature is 

available from the Channels panel. 

 

Selection created from the image's blue channel. 

Pixels are selected based on the contribution that the chosen channel makes to its color value. If a 

channel only contributes partially to a pixel, that partial amount is selected (i.e. where a channel 

contributes 20% of the color to that pixel, that 20% is selected). 

A selection marquee only appears around areas which are selected by more than 50%. Areas selected 

by 50% or less will not display a marquee at their edges. 

To create a pixel selection from a channel:  

 In the Channels panel, -click any channel and select Load to Pixel Selection. 

To combine channels in a single pixel selection:  

In the Channels panel: 

1. -click any channel and select Load to Pixel Selection. 

2. -click any other channel and select Add to Pixel Selection. 

3. Repeat step 2 as needed. 

Alternatively, you can subtract or intersect a channel from a selection using the other options on the 

context (-click) menu. For more information on the available selection modes, see Creating pixel 

selections. 

To create a pixel selection from a selected layer's channel:  

1. In the Layers panel, select a layer. 

2. In the Channels panel: 

o -click a channel named after the selected layer (e.g. Background Red) and select 

Create Spare Channel 

o -click the newly created spare channel and select Load to Pixel Selection. 
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Pixel selections from shapes 

You can convert a curve or shape (path) drawn using the Pen Tool into a selection. When created 

from a curve, the resulting selection will be closed using a straight line between the end nodes. 

The original line or shape will be discarded when the selection is created. Ensure you keep a copy of 

your original line or shape if you wish to use it later in your project. 

To create a pixel selection from a drawn line or shape (path):  

1. Do one of the following: 

o Using the Pen Tool draw a curve or closed shape on your page. 

o Select a previously drawn curve or shape and then select the Pen Tool. 

2. From the context toolbar, click Selection. 

You can convert geometric shapes created using the Shape tools into selections by converting them 

to curves and then using the procedure above or creating a selection from the shape's layer. 

Sampled color pixel selections 

You can create a pixel selection by sampling colors from pixel layers. 

Settings 

The following settings can be adjusted from the dialog: 

 Tolerance—determines how closely pixels must match the selected color to be included in 

the selection. For lower tolerance settings, pixels must be very close in value to the clicked 

pixel. For higher tolerance settings, pixel color can vary widely from the clicked pixel. Drag the 

slider to set the value. 

 Model—determines the color model used when sampling. Select from the pop-up menu. 

To create a pixel selection from a sampled color:  

1. Select the pixel layer containing the color to be sampled. 

2. From the Select menu, choose Select Sampled Color. 

3. Click on the color to be sampled. 

4. Adjust the settings in the dialog. 

5. Click Apply. 
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Marquee pixel selections 

The marquee selection tools allow you to create selections based on standard geometric shapes, such 

as ellipses and rectangles. 

Selection tools 

There are several marquee tools you can use to create pixel selections: 

 Rectangular Marquee Tool—creates a rectangular or square selection. 

 Elliptical Marquee Tool—creates an elliptical or circular selection. 

 Column Marquee Tool—creates a rectangular selection of the set pixel width which spans 

the entire image's height. 

 Row Marquee Tool—creates a rectangular selection of the set pixel height which spans 

the entire image's width. 

For pixel-accurate selection, Force Pixel Alignment on the top Toolbar will snap pixel selection areas 

to full pixels when created, moved or modified. If this option is off, selections can occupy partial pixels. 

Furthermore, if snapping is active, selection areas can snap to page edges and guides when being 

created (using the Marquee Selection Tools) or moved. 

To create a pixel selection:  

 With a marquee selection tool selected, drag on your page. 

Modifier keys 

The following modifier keys can be used to aid in the creation of selections: 

 The constrains a Marquee Tool's proportions. 

 The automatically removes areas from the current selection. 

 The automatically adds areas to the current selection. 

Drag with left and right button down (Marquee and Free hand Selection tools) to 

automatically add areas to the current selection.  

To set the width of a column/row selection:  

 With the Column Marquee Tool or Row Marquee Tool selected, on the context toolbar, 

adjust the Width setting. 
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Modifying pixel selections 

Once you have a pixel selection in place, it can be modified in several ways. 

You can modify your pixel selection by enlarging or shrinking it, applying a feather to its edge, and/or 

by smoothing its curve. These options are available from the Select menu as Grow/Shrink, Feather, 

and Smooth, respectively. 

Transforming and editing selection 

In addition to the options mentioned above, you can move or transform a selection using the Move 

Tool or edit it using pixel-editing tools in Quick Mask mode. 

Settings 

The following settings can be adjusted from the relevant dialogs: 

 Radius—controls the extent of the effect. 

o Negative values for Grow/Shrink will shrink the selection while positive values 

enlarge it. 

 Circular—if this option is unchecked (default), resizing honors the original selection shape. 

When checked, the selection shape is made more rounded with increasing Radius values. 

For some selection tools, feathering can be applied to a selection from the context toolbar. 

In addition to the modifications discussed here, you can also refine the edges of your selection. This 

option is available from the context toolbar and the Select menu. 
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Moving and transforming pixel selections 

Once a selection has been made, it can be moved and transformed in a variety of ways. 

Moving and transforming a selection and its contents 

If you have a selection in place, you can move and transform it, and the pixels it encompasses, using 

the Move Tool. Furthermore, with the Move Tool active, the Transform panel can also be used for 

precision working. 

Moving and transforming a selection only 

If you're looking to reposition a selection, but leave the pixel content untouched, you can use the 

Marquee tools. However, if you wish to transform your selection while leaving the pixel content 

untouched, you need to enter Quick Mask mode. Once in Quick Mask mode, you can resize, 

reposition, rotate or shear a selection using the Move Tool or Transform panel. 

To move and transform a selection and the pixels it encompasses:  

1. With a selection in place, select the Move Tool. 

2. Resize, reposition, rotate or shear the selection on the page using the displayed handles or, 

for precision, use the settings on the Transform panel. The pixels within the selection will be 

moved and transformed to match the new selection. 

Every time the selection is moved or transformed, new pixels may be included within the new 

selection area. These new pixels will then be moved and transformed if the above procedure is 

followed again. 

To move a pixel selection (leaving pixel unaffected):  

1. With a selection in place, select a marquee selection tool or the Free Hand Selection tool. 

2. Drag inside the selection 

To transform a selection (leaving pixel unaffected):  

1. Do one of the following: 

o Press Q. 

o On the Toolbar, click Toggle Quick Mask. 

o From the Select menu, select Edit Selection As Layer. 

2. Select the Move Tool. 

3. Resize, reposition, rotate or shear the selection on the page using the displayed handles or, 

for precision, use the settings on the Transform panel. 
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4. Repeat step 1 to exit Quick Mask mode and display the selection as a marquee. 

By default, the Quick Mask is presented in the workspace as a translucent, red overlay. The red areas 

are not included in the selection. For more information on using Quick Mask mode, see Edit selection 

as layer using Quick Mask mode. 
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Edit selection as layer using Quick Mask mode 

Using Quick Mask mode, you can modify (or create) a selection using pixel-editing tools. 

When entering this mode, your selection is temporarily presented as a pixel mask. Pixels can be added 

or erased using the standard Painting and Erase tools. 

 Painting in black will erase areas from the selection. 

 Painting in white will add areas to the selection. 

 Painting a gray will vary the opacity of the selection depending on the tone of gray used. 

 Erased areas are always removed from a selection. 

By default, the Quick Mask is presented in the workspace as a translucent, monochrome overlay. The 

monochrome areas are not included in the selection. This default view can be changed depending on 

your preferences. 

Tools which can be used in conjunction with Quick Mask include, but are not limited to, the Erase 

Brush Tool, Flood Erase Tool, Flood Fill Tool, Gradient Tool, Paint Brush Tool, Paint Mixer Brush and 

Pixel. 

You can create a new selection from scratch using the Painting tools by entering Quick Mask mode 

without a selection in place.  

To edit a selection using Quick Mask mode:  

1. Do one of the following: 

o Press Q. 

o On the Toolbar, click Quick Mask. 

o From the Select menu, select Edit Selection As Layer. 

2. Click or drag on the page using any pixel-editing tool. 

3. Repeat step 1 to exit Quick Mask mode and display the selection as a marquee. 

4. (Optional) To create a layer mask using the current selection, from the Layer menu, select 

New Mask Layer. 

To change Quick Mask view:  

 On the Toolbar, click the arrow next to Quick Mask Enabled and then select a Show As 

option from the pop-up menu. 
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Refining pixel selection edges 

Once a selection has been created, you can refine its edges to ensure your selection is as accurate as 

needed. 

For very fine selection, e.g. of hair against a colored background, use an adjustment brush as part of 

the refinement to 'brush-in' fine detail. 

Settings 

The following settings can be adjusted from the dialog: 

 Preview—sets the way your selection and page display. Select from the pop-up menu. 

 Matte Edges—when selected (default), the selection area closely follows image edges. If this 

option is off, selection doesn't follow image edges which is useful for more accurately refining 

straight selection edges. 

 Border width—expands the selection by adjusting the width of its border. Drag the slider to 

set the value. 

 Smooth—determines the curvature of the selection's edge. Drag the slider to set the value. 

 Feather—determines the softness (opacity) of the transition at the edge of the selection. Drag 

the slider to set the value. 

 Ramp—changes the size of the selection. Drag the slider to set the value. Negative values will 

shrink the selection while positive values enlarge it. 

 Adjustment brush—determines the adjustment brush's refinement mode. 

o Matte—re-analyses the selection and attempts to separate foreground detail from 

the background. Great for selecting hair at the edges of photos, etc. 

o Foreground—adds to the selection (revealing more of the foreground). 

o Background—deletes from the selection (revealing more of the background). 

o Feather—softens the alpha edge of the selection. 

 Width—sets the width of the brush tip. Type directly in the text box or drag the pop-up slider 

to set the value. 

 Output—determines how the selection is applied upon exiting the dialog. Select from the 

pop-up menu. 

To refine pixel selection edges:  

1. With a selection in place, from the Select menu, select Refine Edges. 



2. Adjust the settings in the dialog. 

3. If you wish to adjust the selection edges by painting, drag on the preview. 

4. Click Apply. 

Modifier keys 

The following modifier (s) can be used: 

 Press the and s together and drag on the page. Dragging left or right will decrease or increase 

the brush size, respectively. Alternatively, use the [ or ] s, respectively. Dragging up or down 

will decrease or increase the brush hardness, respectively. 

 Press the right mouse button, then left mouse button and drag on the page. Dragging left or 

right will decrease or increase the brush size, respectively. Dragging up or down will decrease 

or increase the brush hardness, respectively. 

 

  



Creating outline selections 

The Outline feature allows you to create a new selection based on the outer edges of a previously 

created selection. 

 

 
Before and after outline selection created. 

Settings 

The following settings can be adjusted from the relevant dialogs: 

 Radius—controls the width of the selection. 

 Circular—when selected, the selection edges become increasingly rounded with increasing 

Radius values. 

 Alignment—determines to origin for the expansion. Select from the pop-up menu. 

To create an outline selection:  

1. With a selection in place, from the Select menu, select Outline. 

2. Adjust the settings in the dialog. 

3. Click Apply. 



Saving and loading selections 

You can save pixel selections for later use in the current project or future projects. It's useful to be able 

to reinstate more complex selections at any time and stage of your project. 

Saving selections as alpha channels 

Any number of selections can be stored as spare alpha channels in the Channels panel for future use. 

From there you can reinstate any selection on demand. 

 

Channels panels showing stored selections (each named as Spare Channel) for future use. 

Saving selections to file 

Instead of using the Channels panel, selections can be saved to a standalone file. Saved selections can 

then be loaded from the file into the same or another project. 

To save a selection as an alpha channel:  

 With a pixel selection in place, -click the 'Pixel Selection' entry and select Create Spare 

Channel. 

The selection is stored at the bottom of the Channels panel as a new 'Spare Channel' entry. 

To reinstate a saved selection:  

On the Channels panel, -click the 'Spare Channel' entry, which lets you: 

 Load to Pixel Selection—the saved selection is added as a new selection on the page. 



 Add/Subtract/Intersect to Pixel Selection—the saved selection is added to, subtracted from, or 

intersected with an existing selection on the page. 

 Load to "Layer name"—the saved selection is added to the mask, adjustment, or Live filter 

layer if previously selected in the Layers panel. 

 Load to "Layer name" channel—loads the selection to a channel (e.g., Red) if the channel's 

layer was previously selected in the Layers panel. 

The selection is stored at the bottom of the Channels panel as a new 'Spare Channel' entry. 

To save a selection to a file:  

1. With a pixel selection in place, from the Select menu, select Save Selection. 

2. Adjust the dialog settings as required. 

3. Click Save. 

To load a selection from a file:  

1. From the Select menu, select Load Selection from File. 

2. Select the .afselection file you want and click Open. 

  



Retouching. 

Removing Red Eye 

Red eye is an unsightly effect caused by a camera's flash in low light conditions. However, it can be 

easily corrected using the Red Eye Removal Tool. 

The Red Eye Removal Tool detects red coloration in a subject's pupil and instantly removes it. 

To fix red eye:  

1. Use the Layers panel to select the layer containing a subject with the red eye effect. 

2. Click the Red Eye Removal Tool. 

3. Place the pointer above and slightly to the left of the pupil. 

4. Drag the bounding box so that it covers the pupil and release. The pupil should change color. 

If the initial selection is wrong, undo the result and reselect the bounding box. 

5. The effect of the tool is cumulative. If the result is not dark enough, repeat the selection. 

Avoid making the rectangle too large as you may affect other red-based areas of the image. 
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Retouching 

Retouching techniques utilize a selection of brush-based tools for focused color and tonal adjustment. 

In contrast to the adjustment layers, the retouch brushes apply modifications to a selected pixel layer, 

thereby affecting individual pixels on the layer. 

The retouch brushes provide the opportunity for precision work in editing images and pixel layers. For 

example, the Dodge Brush Tool is ideal for lightening areas of shadow within a photo while leaving 

other areas unaffected. 

The retouch brushes available include:  

Dodge Brush Tool 

Dodging adjusts the exposure under the brush stroke to lighten the painted area. This has the 

opposite effect to Burning. 

Burn Brush Tool 

Burning adjusts the exposure under the brush stroke to darken the painted area. This has the opposite 

effect to Dodging. 

Sponge Brush Tool 

Sponging lets you increase or decrease the color saturation under the brush. 

Blur Brush Tool 

Blurring reduces the contrast between pixels under the brush stroke, thereby softening the edges of 

the painted area. This has the opposite effect to Sharpening. Blurring does not smear color within the 

painted area like Smudging. 

Sharpen Brush Tool 

Sharpening increases the contrast between pixels under the brush stroke, thereby enhancing the 

edges of the painted area. This has the opposite effect to Blurring. 

Median Brush Tool 

Painted pixels are blended together to reduce noise under the stroke. 

  



Smudge Tool 

Smudging is a technique which allows you to blend pixels within an image. The brush 'picks up' color 

from the click point and 'drags' it in the brush stroke direction. 

Don't forget other retouching tools such as Cloning and Healing Brush tools, Blemish Removal Tool, 

and Inpainting Brush Tool. You'll also be able to use the Patch Tool and Red Eye Removal Tool. 

To use a retouch brush:  

1. Use the Layers panel to select the pixel layer that you want to work on. 

2. Select a retouch brush tool from the Tools panel. 

3. The tool uses a soft-round brush by default. To use a different brush style, choose one from 

the Brushes panel. 

4. On the context toolbar, change the brush values as desired. 

5. Drag on the image to apply the effect under the brush stroke. 

 

  



Removing blemishes 

Use the Blemish Removal Tool to remove small imperfections such as pimples, with a single click. 

The Blemish Removal Tool works by blending a target area with a sample area to remove (or reduce) 

the undesired discoloration. 

 

 

Before and after cloning to fix skin imperfections.  To remove blemishes:  



1. Use the Layers panel to select a layer to work on. 

2. Click Blemish Removal Tool from the Tools panel. 

3. Adjust the context toolbar settings. 

4. Do one of the following: 

o Click on the target area. 

o Drag from the target area to the sample area. 

Modifier keys 

The following modifier (s) can be used: 

 To change brush size, use the [ or ] . 

  



Cloning and healing 

Cloning is the process of duplicating samples from one part of an image to introduce replicated 

content for creative effect or to repair the original. 

About cloning 

The clone source 

The Clone Brush Tool copies pixels from one part of an image (or layer) to another. The tool uses a 

source (shown as a '+' cursor) to clone from; this moves in relation to the tool's cursor (shown as an 'o' 

cursor) with its position being able to be redefined as you clone from different areas. 
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Before and after cloning. Introducing a cloned object to your image. 

The clone source can be one of the following context toolbar options: 

 Current Layer—pixels on the selected layer only. 

 Current Layer & Below—pixels on the currently selected layer and any visible layers beneath 

(including vector objects and the effects produced by adjustment layers). 

 Layers Beneath—pixels on any visible layer beneath the currently selected layer (including 

those from any vector objects and the effects produced by any visible adjustment layers). 

 Global—pixels previously sampled by cloning in from one or more other documents (raster 

layer only). 

Global source 

You can define a global source in a secondary open document and paint the sampled pixels into your 

working document by selecting the clone source option 'Global'. The Sources panel stores all your 

global sources; you can then select any stored global source and clone from it. Any new documents 

can make use of the panel's global sources. 

The Global source can only be defined from a single, raster layer. To use a document containing 

multiple layers and/or vector objects, you must flatten the document first. 

  



About healing 

The Healing Brush Tool paints samples from one part of an image onto another. It's useful for 

removing defects and for general photo retouching. In many respects it works like the cloning, 

however, it blends the target pixels with the sample pixels by matching the texture, tone, and 

transparency of the sample pixels with the target pixels. 

 

 

Before and after healing of an unwanted line crossing an image. 



Using the Clone or Healing Brush Tools 

To clone/heal a sample from the current image:  

1. Use the Layers panel to either select an existing raster layer to copy to, or to create a new 

raster layer. 

2. Select the Clone Brush Tool or Healing Brush Tool from the Tools panel. 

3. The tool uses a soft-round brush by default. To use a different brush style, choose one from 

the Brushes panel. 

4. Adjust the context toolbar settings. 

5. To define (or re-define) the cloning source, hold the and click on the area you wish to begin 

sampling from. 

6. (Optional) Rotate the sample by either using the left and right arrow keys or the Rotation 

control on the context toolbar. 

7. (Optional) Set the scale of the sample by either using the up and down arrow keys or the 

Scale control on the context toolbar. 

8. (Optional) Transform the sample by using the Flip pop-up menu on the context toolbar. 

9. Drag on the image to paint the sample. 

It is best practice to temporarily hide adjustment layers during the above procedure. This allows you 

to copy the original image. If the adjustment layers are visible, the adjusted pixels will be permanently 

applied. 

Modifier keys 

The following modifier (s) can be used: 

 To change brush size, use the [ or ] . 

To clone/heal a sample from one image to another:  

1. Open the image that you want to copy pixels from and use the Layers panel to select the 

raster layer that you wish to copy from. To source from vector layers you need to rasterize it 

first. 

2. Click the Clone Brush Tool or Healing Brush Tool. 

3. To define (or re-define) the cloning source, hold the and click on the area you wish to begin 

sampling from. 

4. On the context toolbar, click Add Global Source. 



The source is stored, along with other global sources, in the Sources panel. The panel can be switched 

on via View>Studio. 

5. Open the image that you want to paint the sample into. 

6. Use the Layers panel to either select an existing raster layer to copy to, or to create a new 

raster layer. 

7. Click the Clone Brush Tool or Healing Brush Tool. 

8. The tool uses a soft-round brush by default. To use a different brush style, choose one from 

the Brushes panel. 

9. Adjust the context toolbar settings. 

10. Select a stored global source from the Sources panel. If you only have one global source you 

can simply select the Global source from the pop-up menu on the context toolbar instead of 

using the panel. 

11. (Optional) Select rotate, scale or flip options as described above. 

12. Drag on the image to paint the sample. 

 

  



Inpainting 

Inpainting (image interpolation) is the process by which lost or deteriorated image data is 

reconstructed, but within the context of digital photography can also refer to replacing or removing 

unwanted areas of an image. For example, you can remove or replace: 

 Power lines and other obstructions 

 People and animals 

 Vignetting 

 Lens flares 

 Background details 

 Dust spots and scratches 

 Stuck or "hot" pixels 

 

 



Removing objects from a landscape image. 

About inpainting 

The Inpainting Brush Tool is used to paint over (and identify) damaged or unwanted areas. Complex 

algorithms then take over to harvest information from the surrounding areas of the image in order to 

reconstruct the missing data. 

Inpainting is particularly useful for repairing physically damaged printed photos which have been 

subsequently digitized. 

To restore image data using the Inpainting Brush Tool:  

1. Use the Layers panel to select a layer to work on. 

2. Click the Inpainting Brush Tool. 

3. The tool uses a soft-round brush by default. To use a different brush style, choose one from 

the Brush panel. 

4. Adjust the context toolbar settings. 

5. Drag across the image to identify the area of lost or damaged data. 

Best Practices: 

 Zoom in close to the area you wish to inpaint. 

 Set a suitable brush size from the context toolbar. 

 If you are painting out people or complex shapes, try painting over gaps (e.g., inbetween legs 

and arms) as well for better consistency. 

 Remember you can always do multiple passes if the result of the inpainting does not look 

authentic or seamless enough. Simply paint over the areas again. 

Modifier keys 

The following modifier (s) can be used: 

 To change brush size, use the [ or ] . 

As a supplementary method to brush-based inpainting, you can inpaint areas selected in advance via 

Edit>Inpaint. 
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Patching 

Patching is a retouching technique which involves replacing an undesirable pixel region with a patch 

(a drawn freehand selection area) made up of pixels sourced from another, more suitable, part of your 

image or another document. 

 

 



Patching out an extensive mascara smudge enclosed within the patch's freehand selection 

area. 

About patching 

Patching, like healing, blends the target pixels with the sample pixels by matching the texture, tone, 

and transparency of the sample pixels with the target pixels. When patching, you can also select 

whether to only apply the texture of the source to the target and whether there is a level of 

transparency applied. 

Selection 

The selection can act as any of the following: 

 As Target—pixels are modified based on the properties of the source pixels. These pixels are 

sourced from under the cursor anywhere outside the selected area. 

 As Source—pixels are used to modify the target area(s) selected. 

For both, the sample can be scaled or rotated before or after it has been applied. 

Global source 

You can define a source in one open document and paint the sampled pixels into another open 

document using Set Global Source. 

Once a source is defined, the Global source option becomes available from the layer selection 

dropdown. It will remain available until a new source is defined, even if the original global source 

document is closed. 

The Global source can only be defined from a single, raster layer. To use a document containing 

multiple layers and/or vector objects, you must flatten the document first. 

To patch when selection is target:  

1. Use the Layers panel to either select an existing raster layer to copy to, or to create a new 

raster layer. 

2. Select the Patch Tool from the Tools panel. 

3. Drag on the image to draw a freehand selection area. This will be the target area. 

4. Adjust the context toolbar settings. Repeat the above step if necessary. 

5. Click on the image to define the source area. 

6. (Optional) Drag the nodes of the applied area to modify the scale and rotation. Alternatively, 

use the Scale and Rotation controls on the context toolbar. 
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7. Click anywhere on the image to confirm placement and remove the selection. 

It is generally best practice to temporarily hide adjustment layers during the above procedure. This 

allows you to copy the original image. If the adjustment layers are visible, the adjusted pixels will be 

permanently applied. 

To patch when selection is source:  

1. Use the Layers panel to either select an existing raster layer to copy to, or to create a new 

raster layer. 

2. Click the Patch Tool. 

3. On the context toolbar, select Selection is source. 

4. Drag on the image to define a selection. This will be the source area. 

5. Adjust the context toolbar settings. Repeat the above step if necessary. 

6. Click on the image to place pixels from the source area. 

7. (Optional) Drag the nodes of the applied area to modify the scale and rotation. Alternatively, 

use the Scale and Rotation controls on the context toolbar. 

You can patch repeatedly with the same source by clicking on different areas of your image. 

To patch from a global source:  

1. Open the image that you want to copy pixels from and use the Layers panel to select the 

raster layer that you wish to copy from. 

2. Click the Patch Tool. 

3. On the context toolbar, select Selection is source. 

4. Drag on the image to define a selection. This will be the global source area. 

5. On the context toolbar, click Set Global Source. 

6. Open the image that you want to paint the sample into. 

7. Use the Layers panel to either select an existing raster layer to copy to, or to create a new 

raster layer. 

8. Click the Patch Tool. 

9. On the context toolbar: 

o Ensure Selection is source is still selected. 

o Select Global from the layer selection dropdown. 

10. Click on the image to place pixels from the source area. 



11. (Optional) Drag the nodes of the applied area to modify the scale and rotation. Alternatively, 

use the Scale and Rotation controls on the context toolbar. 

  



Frequency separation 

Frequency separation allows you to retouch texture and tone/color independently for powerful 

portrait retouching. 

 

 

Before and after retouch on high and low frequency layers. 

Frequency separation 

Although the term frequency separation is initially intimidating, the concept is straightforward. By 

automatically separating your image color/tone and texture into separate low and high frequency 

layers, respectively, you'll be able to retouch color/tone and texture independently. 

 Skin tone and color (shadows, blotches, etc.) are made smoother by blurring with the Dodge 

or Blur Brush Tool. The Healing Brush Tool also works well here. 



 Unwanted textures (spots, stray hair, blemishes, dimples, and wrinkles) can be removed with 

the Clone Brush Tool or Blemish Removal Tool. 

In frequency separation, a Gaussian Blur and High Pass filter are applied to created low and high 

frequency layers. 

To apply frequency separation:  

1. From the Filters menu, select Frequency Separation. 

2. Drag on either high or low pass preview panes, to set the Radius (or use the slider in the 

dialog); this sets the balance between texture and tone. Set the value so the image's Low 

Frequency preview blends image color and tone but without losing major features within it. 

3. (Optional) From the dialog, check Feature Protection Tolerance and set a tolerance value on 

the slider. This preserves major facial features when applying subsequent brush strokes. 

Use selection tools and masking on both frequency layers just as with other layers. 

Press the F key to switch from the High frequency layer to the Low frequency layer (and vice versa). 

To retouch color or tone:  

1. From the Layers panel, select the Low Frequency layer. 

2. Apply retouch tools to the layer as appropriate. 

To retouch textures:  

1. From the Layers panel, select the High Frequency layer. 

2. Apply retouch tools to the layer as appropriate. 

  



Applying adjustments 

There are a range of adjustments which can be applied to your photo as a new layer for corrective or 

creative purposes. 

Available Adjustments:  

 LUT 

 Black and White 

 Brightness and Contrast 

 Channel Mixer 

 Color Balance 

 Curves 

 Exposure 

 Gradient Map 

 HSL 

 Invert 

 Levels 

 OCIO 

 Posterize 

 Recolor 

 Selective Color 

 Shadows/Highlights 

 Soft Proof 

 Split Toning 

 Threshold 

 Vibrance 

 White Balance 

Adjustments are applied to your image from the Adjustment panel and most include customizable 

settings alongside general adjustment options. 

Adjustment layers only affect layers which are below them. Alternatively, you can make an adjustment 

a child of a layer (or layer group), thereby affecting that layer (or layer group) only. 
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Some adjustments (i.e., Curves, Levels, or Channel Mixer) can be made in any color space 

independently of the document color space. 

There are additional adjustments available in Develop Persona which are arranged on various panels. 

For more information, see Developing a raw image. 

For specific targeting of adjustments, create a pixel selection before applying an adjustment layer. 

Only those pixels included in the selection are affected by the adjustment layer. (A layer mask is 

applied.) For more information, see the Using adjustment layers topic. 

Settings 

The following general settings are available from all adjustment dialogs: 

 Delete—closes the dialog and deletes the adjustment layer, removing the adjustment from 

the image. 

 Merge—merges the current adjustment layer with the layer immediately below it in the layer 

order. 

 Add Preset—adds the current adjustment settings as a preset for use with later images and 

projects. 

 Reset—reverts all dialog settings to default. 

 Opacity—how see through the adjustment layer is. 

 Blend mode—changes how the applied pixels interact with existing pixels on the layer below. 

Choose mode type from a pop-up menu. 

 Blend Ranges—click to access a dialog for setting the blend ranges, blend gamma and 

antialiasing settings for the selected layer. 

Not all adjustments have a dedicated dialog or customizable settings. 

To apply an adjustment:  

1. On the Adjustment panel, select an adjustment. 

The adjustment is added directly above the selected layer or at the top of the stack if no layer 

was selected. 

2. (Optional) Click one of the adjustment preset thumbnails. 

3. If a dialog appears for the adjustment, follow the steps below: 

i. Adjust the settings in the dialog. 

ii. (Optional) Click Add Preset to make your custom settings available in step 2 for future 

sessions. 
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iii. Close the dialog. 

You can replace an applied adjustment of the same type by selecting a new preset or custom 

adjustment from the bottom of the Layers panel. This maintains the adjustment layer's position in the 

layer stack. 

To rename or delete a saved adjustment:  

 On the Adjustment panel, -click a custom adjustment, then select an option. 

To view an applied adjustment's settings:  

 On the Layers panel, double-click the adjustment layer's thumbnail. 

To apply an adjustment from the Layers panel:  

1. On the Layers panel, select a layer. 

2. Click Adjustments and select an adjustment from the pop-up menu. 

The adjustment is added directly above the selected layer. 

3. If a dialog appears for the adjustment, follow the steps below: 

i. Adjust the settings in the dialog. 

ii. Close the dialog. 

Adjustments are also available from the Layer menu's New Adjustment Layer sub-menu. 

  



Tonal adjustments 

Tonal adjustments are used to correct and modify the lightness values within photos. 

Available tonal adjustments include: 

 Brightness and Contrast—uses two settings to adjust the lightness of all pixels within a photo 

and the tonal differences between them, respectively. 

 Curves—uses graph manipulation to precisely adjust the lightness and contrast of a photo. 

 Exposure—retrieves lost detail in highlights or shadows caused by poor exposure. 

 Levels—reassigns the black, white and gamma points within a photo to redistribute pixel 

lightness. 

 Shadows/Highlights—applies tonal adjustment to the darkest and/or lightest areas in a photo. 
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Brightness and Contrast adjustment 

Adjust the values in the shadows and highlights, and the overall tonal range, of images. 

 
 

Before and after adjustment applied. 

You can also adjust the tonal range of images using the Levels and Curves adjustments. 

Settings 

The following settings can be adjusted: 

 Brightness—controls the lightness/darkness of the image. Drag the slider to the left to 

decrease brightness, drag to the right to increase it. 

 Contrast—controls the tonal range of the image. Drag the slider to the left to decrease the 

contrast between dark and light areas, drag to the right to increase it. 

 Linear—by default, the adjustment prevents shadow and highlight clipping by modifying 

pixels relative to their original lightness value. When selected, this option modifies pixels using 

absolute values and clipping may occur. 

  



Curves adjustment 

Adjust the color, tone and alpha channels with the curves adjustment, either on individual channels or 

by adjusting the master curve. 

 

 

This adjustment is available in Develop Persona on the Tones panel. 

Adjustments can be made in any color mode, regardless of the document's current color mode (so 

you can edit LAB curves in an RGB document and vice versa). 

Settings 

The following settings can be adjusted: 

 Select a color mode (GRAY/RGB/CMYK/LAB) from the first pop-up menu. 
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 Specify a single color channel to apply the adjustment to, including the layer's alpha channel. 

Master (the default choice) applies the adjustment to all channels. Select from the second 

pop-up menu. 

 Picker—allows you to drag on the image to modify the adjustment. The initial click will place 

a node on the curve in relation to the pixel selected. Dragging up will lighten the image while 

dragging down will darken it. The curve graph will update accordingly. 

 Input minimum and Input maximum are useful for 32-bit documents with out of range 

tonal values, but can also be used to fine tune the manipulated tonal range in 8-bit and 16-bit 

documents: 

o Input minimum—specify, in float, a minimum value to use as tonal input. 

o Input maximum—specify, in float, a maximum value to use as tonal output. 

The color mode, Alpha channel and Picker options are not available in Develop Persona. 

To adjust a curves graph:  

On the curves graph, do any of the following: 

 In the dialog, click Picker and then drag up or down on the page. 

 Drag the curve to adjust the tonal range of the image. 

 Click on the curve to add additional nodes. 

 Click to select a node and then press the to remove it. 

In general: 

 Drag the curve downwards to correct overexposure. 

 Drag the curve upwards to correct underexposure. 

 Create a gentle S-shape by adding nodes (see above) and dragging the curve in opposite 

directions to correct washed out images. 

  



Exposure adjustment 

Alters the overall exposure of the image: good for correcting overexposure/underexposure, or for 

giving an image a high key or low key look. 

 
 

Settings (Photo Persona; as adjustment layer) 

The following setting can be adjusted: 

 Exposure—controls the highlight/shadow levels of the image. Drag the slider to the left to 

increase shadows, drag to the right to increase highlights. 

Settings (Develop Persona; in Basic panel) 

The following settings can be adjusted: 

 Exposure—controls the highlight/shadow levels of the image. Drag the slider to the left to 

increase shadows, drag to the right to increase highlights. 

 Blackpoint—determines the range of pixels in the image considered to be pure black. Drag 

the slider to the right to include pixels in the range (thereby increasing shadows), drag to the 

left to exclude pixels (thereby reducing shadows). 

 Brightness—controls the lightness/darkness of the image. Drag the slider to the left to 

decrease brightness, drag to the right to increase it. 

  



Levels adjustment 

Adjust the tonal values and color balance of an image by setting the black point, white point, and 

gamma. Adjusting the levels affects the pixel distribution within an image. 

 
 

Before and after adjustment applied. 

Adjustments can be made in any color mode, regardless of the document's current color mode. 

Settings 

The following settings can be adjusted: 

 Select a color mode from the first pop-up menu. 

 Specify a single color channel to apply the adjustment to, including the layer's alpha channel. 

Master (the default choice) applies the adjustment to all channels. Select from the second 

pop-up menu. 

 Black Level—determines the range of pixels in the image considered to be pure black. Drag 

the slider to the right to include pixels in the range (thereby increasing shadows), drag to the 

left to exclude pixels (thereby reducing shadows). 

 White Level—determines the range of pixels in the image considered to be pure white. Drag 

the slider to the left to include pixels in the range (thereby increasing highlights), drag to the 

right to exclude pixels (thereby reducing highlights). 

 Gamma—determines the distribution of mid-tone pixels in the image. Enter a gamma value 

or drag the slider to the left to redistribute pixels towards the black point, drag to the right to 

redistribute towards the white point. 

To create a negative-style (inverted) image, position the Black Level slider further to the right than 

the White Level. 

Holding whilst modifying the Black Level or White Level provides a real time clipping preview. 



Shadows/Highlights adjustment 

Adjust the lightness of the shadows and highlights in your image. 

 

 

Before and after adjustment applied. 

Rather than applying a lighting adjustment to your entire image, making it lighter or darker, this 

adjustment affects the image's shadow and highlight areas and surrounding pixels. 

This adjustment is available in Develop Persona on the Basic and Overlays panels. 

Settings 

The following settings can be adjusted: 

 Shadows—controls the lightness of image shadows. Drag the slider to the left to darken 

shadow areas, drag to the right to lighten them. 

 Highlights—controls the lightness of image highlights. Drag the slider to the left to darken 

highlight areas, drag to the right to lighten them. 
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Color adjustments 

Color adjustments are used to modify the color of all, or a range of, pixels within a photo. Depending 

on the adjustment, the modification can be subtle or extreme. 

Available color adjustments include: 

 Black and White—converts a color photo to grayscale. 

 Channel Mixer—adjusts the color of a photo by modifying individual RGB channels. 

 Color Balance—adjusts the contribution of particular colors to a set tonal range. 

 Gradient Map—uses the lightness value of pixels in a photo to recolor it using a specified 

gradient. 

 HSL—shifts the hue, saturation and luminosity values of pixels in a photo. 

 Lens Filter—emulates the use of a lens filter to tint the color of the image. 

 OCIO—(OpenColorIO only) provides source and destination color space transforms. 

 Recolor—converts a color photo to monochrome using a specified tint. 

 Selective Color—subtly adjusts the color of a photo by modifying individual RGB, CMYK and 

lightness channels. 

 Split Toning—tints and recolors highlights and shadows. 

 Threshold—converts any photo into a two-tone, black and white image based on pixel 

lightness. 

 Vibrance—adjusts the intensity of subtle colors within a photo. 

 White Balance—removes undesirable color casts from a photo by adjusting the 'temperature' 

of the light. 
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Black and White adjustment 

Convert a color image to monochrome while maintaining full control over how individual colors are 

converted. 

 
 

In Photo Persona, this adjustment comes with a handy Picker setting which identifies the predominant 

color of a selected area and adjusts the relevant slider automatically. 

This adjustment is available in Develop Persona on the Tones panel. 

You may wish to apply a color tone, such as sepia, to the resulting grayscale image. To do this, you 

could use a Recolor adjustment or add a fill layer above with a blend mode and/or reduced opacity 

applied. 

You can also create black and white images using the HSL, Gradient Map, and Threshold 

adjustments. 

Settings 

The following settings can be adjusted: 

 The sliders control the lightness value of the named color areas of the image. Drag the slider 

to the left to darken areas of the named color, drag the slider to the right to lighten them. 

 Picker—allows you to drag on the image to modify the adjustment. The initial click will 

identify the predominant color, dragging left will darken areas of the identified color while 

dragging right will lighten them. The corresponding slider will be updated. 

The Picker option is not available in Develop Persona. 
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Channel Mixer adjustment 

Adjust the color of individual channels to produce effects not easily achieved with other color 

adjustment tools. 

 

 



Adjustments can be made in any color mode, regardless of the document's current color mode. 

Settings 

The following settings can be adjusted: 

 Output Channel: 

o Select a color mode from the first pop-up menu. 

o Specify a single color channel to apply the adjustment to, including the layer's alpha 

channel. Select from the second pop-up menu. 

 The sliders control the contribution of the named color to the selected output channel. Drag 

the slider to the left to decrease the level of the named color, drag the slider to the right to 

increase it. 

 Offset—controls the overall influence the selected output channel has on the image as a 

whole. Drag the slider to the left to decrease the output channel's contribution, drag the slider 

to the right to increase it. 

Modifying the alpha channel produces a keying/matting effect. 

  



Color Balance adjustment 

The Color Balance adjustment provides a way to modify the contribution of particular colors to a set 

tonal range. 

 

 

Settings 

The following settings can be adjusted: 

 Tonal Range—determines the tones to be adjusted. Select from the pop-up menu. 

 The sliders control the balance of the named colors in the selected Tonal Range. Drag the 

slider toward the color you wish to emphasize. 

 Preserve luminosity—if this option is off (default), the adjustment ignores the original 

lightness value of pixels. When selected, the adjustment modifies pixel colors with respect to 

their original lightness value. 

  



Gradient map adjustment 

The Gradient Map adjustment maps the equivalent grayscale range of an image to a specified color 

gradient. This provides an effective (and creative) way of recoloring an image. 

 

 

A Gradient Map applied using a custom opacity and blend mode. 

Settings 

For dialog settings, see the Gradient editing topic. 

To create a black and white image, ensure the gradient contains only grayscale values. 
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HSL adjustment 

Fine-tune the colors in your image, or even completely change them, by modifying the hue, saturation 

and luminosity (lightness). 

 
 

Before and after adjustment applied. 

Settings 

The following settings can be adjusted: 

 Channel—alter all colors at once (Master) or choose an individual color set (e.g., Yellows). 

 HSV—when checked, uses the Hue Saturation Value (HSV) model instead of Hue Saturation 

Lightness (HSL). The Saturation and Luminosity sliders behave differently between the two 

models. 

 Hue Shift—controls the color tint of pixels in the image. Drag the lower slider to shift the 

colors through the spectrum. (See note below.) 

 Saturation Shift—controls the intensity of the colors in the image. Drag the slider to the left 

to decrease color intensity, drag to the right to increase it. 

 Luminosity Shift—controls the overall brightness of the image. Drag the slider to the left to 

decrease brightness, drag to the right to increase it. 

Why two spectrums for Hue Shift? 

The upper spectrum represents pixel colors in the original image, using cyan as a midpoint. This 

spectrum is not a slider and cannot be adjusted. 



The upper spectrum is a reference for the color shift of image pixels when the lower slider is adjusted. 

Before adjustment, the spectrums are identical. 

If, for example, you drag the slider to the right the green section of the lower spectrum will soon lie 

under the cyan midpoint. All cyan pixels in the image will now appear green. All other pixels in the 

image will all shift to an equal degree, e.g. blue will become cyan, and green will become orange. 

To create a desaturated (black and white) image, position the Saturation Shift slider to the far left. 

Lens Filter adjustment 

Emulates the use of a lens filter to tint the color of the image. 

 

 

Before and after adjustment applied. 

Settings 

The following settings can be adjusted: 

 Filter Color—Choose the color/tint of your lens filter. 

 Optical Density—Adjust the density (or strength) of the lens filter: this controls how much of 

the tint is blended into the image. 

 Preserve Luminosity—When checked, prevents the change in color from affecting the 

luminance channel of the image. If unchecked, increasing the optical density will typically 

reduce the luminosity of the image. 



OpenColorIO adjustment 

The OpenColorIO adjustment is designed to help with OpenColorIO color-managed workflows by 

allowing color transforms between source and destination color spaces. See Using OpenColorIO for 

more information. 

 

 

Before (ACEScg) and after (Linear sRGB) adjustment applied. 

Settings 

The following settings can be adjusted: 

 Source Color Space—sets the input color space to use for transforming. 

 Destination Color Space—sets the output color space. 

This adjustment requires a valid OpenColorIO configuration in order to be usable. See Using 

OpenColorIO for instructions on setting up a configuration. 
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Recolor adjustment 

Create a monochrome image using the full spectrum of colors. 

 

 

Before and after adjustment applied. 

Settings 

The following settings can be adjusted: 

 Hue—controls the color tint applied to the image. Drag the slider to shift the tint through the 

spectrum. 

 Saturation—controls the intensity of the image's color. Drag the slider to the left to decrease 

color intensity, drag to the right to increase it. 

Creating black and white and sepia images: 

 To create a desaturated (black and white) image, position the Saturation slider to the far left. 

 To create a sepia image, position the Hue slider anywhere around the orange section of the 

spectrum and position the Saturation slider anywhere left of the center. 



Selective Color adjustment 

The Selective Color adjustment provides a way to subtly adjust and enhance colors in your image on 

an individual channel basis. It makes a useful tool for color balance corrections. 

 

 

Before and after adjustment applied. 

This adjustment produces subtle effects. Even at the extreme ends of the adjustment, you shouldn't 

see many artefacts or saturated pixels. If you intend to make extreme adjustments, such as completely 

recoloring pixels, then the HSL adjustment will be more suitable. 

Settings 

The following settings can be adjusted: 

 Color—determines the color to be adjusted. Select from the pop-up menu. 

 Relative—when selected (default), color is added or subtracted in proportion to the amount 

of that color present in the source pixels, giving a more natural effect. If this option is off, 

colors are added or subtracted based on the absolute percentage specified, regardless of the 

how much of that color is present in the image. 

 The sliders control the levels of the named color in the selected Color. Drag the slider to the 

left to decrease the level of the named color, drag the slider to the right to increase it. 

 



Split Toning adjustment 

Tints and recolors highlights and shadows. 

 
 

Before and after adjustment applied. 

Settings 

The following settings can be adjusted: 

 Hue—controls the color tint of highlights/shadows. Drag the slider to set the value. 

 Saturation—controls the intensity of the highlight/shadow colors. Drag the slider to the left 

to decrease color intensity, drag to the right to increase it. 

 Balance—controls the emphasis of the adjustment. Drag the slider to the left to emphasize 

highlight color, drag to the right to emphasize shadow color. 

The first set of Hue/Saturation sliders adjusts highlight areas, while the second set adjusts shadow 

areas. 

  



Threshold adjustment 

Create a two-tone, black and white image from grayscale or color images based on a pixel intensity 

threshold. 

 

 

Before and after adjustment applied. 

Any pixels lighter than the threshold are converted to white; any pixels darker than the threshold are 

converted to black. 

Settings 

The following settings can be adjusted: 

 Threshold—controls the transition point between pixels being converted to black or white. 

Drag the slider to the left to convert more pixels to white, drag the slider to the right to 

convert more pixels to black. 



Vibrance adjustment 

Adjust the intensity of subtle colors in your images while minimizing the over-saturation (clipping) of 

more intense colors. Skin tones are also preserved to retain a natural appearance. 

 

 

Before and after adjustment applied. 

This adjustment is also available in Develop Persona on the Basic panel (Enhance). 

Settings 

The following settings can be adjusted: 

 Vibrance—controls the intensity of colors in the image. Drag the slider to the left to reduce 

color intensity, drag the slider to the right to increase color intensity. 
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White Balance adjustment 

Remove unwanted color casts or give an image a warmer or cooler feel. 

 

 

Before and after adjustment applied. 

The adjustment lets you control white balance using: 

 the dialog's sliders 

 a white point picker (Photo Persona only) 



 a White Point Tool (Develop Persona only) 

In Photo Persona, white balance is available as an adjustment layer. In Develop Persona, it appears on 

the Basic and Overlays panels. 

Settings 

The following settings can be adjusted: 

 White Balance—controls the 'temperature' of the image. In the Develop Persona this is 

measured in Kelvin (K). Drag the slider to the left to cool the image, or drag the slider to the 

right to warm the image. 

 Tint—tints the image either towards magenta or green. This is useful for removing color casts, 

especially if the image was taken under artificial lighting (e.g., tungsten or fluorescent). 

 Picker—allows you to sample the image to set the white point on which the white balance 

will be calculated. You can sample using one of the following methods: 

o Click to sample a pixel under the cursor. 

o Drag the cursor across the image to sample all pixels under the cursor. The averaged 

color from those pixels is used. 

o Press the and drag to sample under a rectangular marquee, again using the averaged 

color of those pixels. 

In Develop Persona, a dedicated White Point Tool is used instead of the Picker. It offers the same 

sampling functionality as the Picker. 

In Develop Persona, the image uses the camera's "As Shot" White Balance values by default. Checking 

the adjustment's check box displays those values, which can be reverted to at any time by unchecking 

the adjustment's check box. 
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Other adjustments 

As well as tonal and color adjustments, there are a range of other adjustments which can be applied 

to your photo for corrective, creative or proofing purposes. 

Available adjustments include: 

 LUT—adjusts the color values of a photo based on a defined matrix. 

 Invert—reverses the color values of a photo to create a negative image. 

 Posterize—expresses a photo as blocks of solid color. 

 Soft Proof—provides a preview of a photo when output for a specific color space or device. 
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LUT adjustment 

The LUT adjustment allows you to emulate image colors used in a variety of media platforms. 

 

 



A LUT (look-up table) remaps pixel color values based on a defined XYZ matrix. This allows you to 

quickly replicate the appearance of various types of media, such as reproducing the cold, blue tone 

attributed to science fiction and horror movies. 

The look up table is stored within a file previously exported from Affinity Photo or other applications 

(e.g., video packages). Alternatively, it can be inferred by comparing images. 

Settings 

The following settings can be adjusted: 

 Load LUT—sets the LUT used in the adjustment. In the pop-up dialog, navigate to and select 

a file, and click Open. 

 Infer LUT— Applies a LUT adjustment without the need of a separate LUT file by comparing a 

'source' image and its adjusted exported image. With a new 'target' image loaded, click Infer 

LUT, then in the pop-up dialog, navigate to and select both source and adjusted files in turn, 

and click Open. 

The following types of LUT files are available: *.3dl, *.csp, *.cube, and *.look. 

  



Invert adjustment 

Create a negative image by inverting all color channels. 

 

 

This adjustment has no customizable settings. 

You can use Invert as part of the process of making edge masks and to apply sharpening and other 

adjustments to selected areas of an image. 

For more control in creating a negative-style (inverted) image, you can use a Levels adjustment. 



Posterize adjustment 

Creates large, flat areas of color or tone in your images. 

 

 

Settings 

The following settings can be adjusted: 

 Posterize Levels—controls the number of colored areas produced and the complexity of the 

resulting image. Drag the slider to the left to decrease the number of colored areas (thereby 

simplifying image layout), drag to the right to increase colored areas (thereby giving a more 

complex image layout). 

The number displayed in the dialog represents the level of complexity rather than the number of 

resulting colors. 

  



Soft Proof adjustment 

Preview the effect of creating an output for a specific color space or device. 

 
 

This adjustment allows you to preview different output options for your photo or design. It can also 

be used creatively for tonal effects. As it behaves like a standard adjustment layer, it must be hidden 

or removed before exporting or sending to print, otherwise its effect will be included in the output. 

Settings 

The following settings can be adjusted: 

 Proof Profile—determines the color profile used. Select from the menu or use the up/down 

arrow keys to cycle through options. 

 Rendering Intent—sets the visual purpose for applying the adjustment. Select from the pop-

up menu. 

 Black point compensation—when selected (default), the photo's black point is adjusted to 

honor the current contrast within the current proof profile. If this option is off, the photo's 

black point is not adjusted and image contrast may not be honored. 

 Gamut check—when selected, RGB colors without a CMYK equivalent will display as gray. 

  



Exporting custom adjustments as LUTs 

You can create your own LUTs based on the adjustments applied to a project. 

You can create custom LUTs from custom adjustments for future use or distribution. 

Settings 

The following settings can be adjusted: 

 Title—sets the descriptive name of the adjustment. 

 Format—sets the exported file type. Select from the pop-up menu. 

 Quality—sets the complexity of the exported adjustment. Drag the slider to set the value. 

The following types of LUT files are available: *.3dl, *.csp, *.cube, and *.look. 

To export as a LUT:  

1. Apply one or more adjustments to your project. 

2. From the File menu, select Export LUT. 

3. Adjust the settings in the dialog. 

4. Click Export. 

5. Navigate to and select storage folder, name the file, and then click Save. 
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Applying filters 

Filters can be applied to layers within your document for corrective or creative purposes. 

About filters 

In Affinity Photo, filters are available in both non-destructive and destructive forms. A variety of filters 

are available as Live Filters which are non-destructive. 

For destructive filters, it's a great idea to make a duplicate layer of the layer you planned to work on. 

By applying a filter to the duplicated layer, you preserve the original layer's contents, with the option 

to hide the 'filter' layer as needed. 

If a selection is in place before the filter is applied, the filter will only affect pixels within the selection. 

Available filters:  

 Blur 

o Average 

o Gaussian Blur 

o Diffuse Glow 

o Box Blur 

o Motion Blur 

o Radial Blur 

o Zoom Blur 

o Lens Blur 

o Depth Of Field Blur 

o Field Blur 

o Maximum Blur 

o Minimum Blur 

o Bilateral Blur 

o Median Blur 

o Custom Blur 

 Sharpen 

o Unsharp Mask 

o Clarity 

file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Layers/livefilters.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_average.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_gaussianBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_diffuseGlow.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_boxBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_motionBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_radialBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_zoomBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_lensBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_DOFBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_FieldBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_maximumBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_minimumBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_bilateralBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_medianBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_customBlur.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_unsharpMask.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Filters/filter_clarity.html


o High Pass 

 Distort 

o Deform 

o Perspective 

o Twirl 

o Pinch/Punch 

o Spherical 

o Ripple 

o Lens Distortion 

o Rectangular to Polar 

o Polar to Rectangular 

o Pixelate 

o Displace 

o Shear 

o Mirror 

o Affine 

o Equations 

 Noise 

o Denoise 

o Add Noise 

o Diffuse 

o Perlin Noise 

o FFT Denoise 

o Dust & Scratches 

 Detect 

o Detect Edges 

o Detect Horizontal Edges 

o Detect Vertical Edges 

 Colors 
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o Vignette 

o Remove Vignette 

o Chromatic Aberration 

o Defringe 

o Erase White Paper 

o Monochrome Dither 

o Web Safe Dither 

o Emboss 

o Solarize 

o Halftone 

 Other 

o Lighting 

o Haze Removal 

o Shadows / Highlights 

Available live filters:  

 Blur 

o Gaussian Blur 

o Box Blur 

o Median Blur 

o Bilateral Blur 

o Motion Blur 

o Lens Blur 

o Depth Of Field Blur 

o Field Blur 

o Diffuse Glow 

 Sharpen 

o Clarity 

o Unsharp Mask 

o High Pass 
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 Distort 

o Ripple 

o Twirl 

o Spherical 

o Displace 

o Pinch/Punch 

o Lens Distortion 

o Perspective 

 Noise 

o Denoise 

o Add Noise 

o Diffuse 

o Dust & Scratches 

 Colors 

o Vignette 

o Defringe 

o Halftone 

 Lighting/Tonal 

o Lighting 

o Shadows / Highlights 

Settings 

The following general settings are available from all filter dialogs: 

 Before/After—when selected, a dividing line is displayed over the document to show a 

before and after preview. Drag the dividing line to reposition it. 

 Cancel—exits the dialog without applying the changes to the filter. 

 Apply—exits the dialog and applies the filter settings to the layer. 

Live filters have these additional settings: 

 Delete—closes the dialog and deletes the filter layer, removing the filter from the image. 
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 Merge—merges the current filter layer with the layer immediately below it in the layer order. 

 Add Preset—adds the current settings as a preset for use with later images and projects. 

 Reset—reverts all dialog settings to default. 

 Opacity—how see through the filter layer is. 

 Blend mode—changes how the applied pixels interact with existing pixels on the layer below. 

Choose mode type from a pop-up menu. 

To apply a filter:  

1. On the Layers panel, select a layer (we recommend that this is a duplicate layer). 

2. Select the filter from the Filters menu. 

3. If a dialog appears for the filter, follow the steps below: 

i. Adjust the settings in the dialog. 

ii. Click Apply. 

Not all filters have a dedicated dialog or customizable settings. 

To apply a live filter from the Layers panel:  

1. On the Layers panel, select a layer. 

2. Click Live Filters and select a filter from the pop-up menu. 

3. If a dialog appears for the filter, follow the steps below: 

i. Adjust the settings in the dialog. 

ii. Close the dialog to apply. 

The filter is clipped to the selected layer, restricting its effect to just that layer. 

  



 

Blur filters 

Use blur filters to apply creative blurring effects to your photo. 

Available filters include: 

 Average—applies a uniform color averaged across your image. 

 Bilateral Blur—blurs while retaining high contrast. 

 Box Blur—blurs based on a boxed region. 

 Custom Blur—applies your own blur using a customizable pixel matrix. 

 Depth Of Field Blur—applies elliptical or Tilt-shift blur gradients. 

 Diffuse Glow—blurs with a soft glow effect. 

 Field Blur—adds focal points to a blurred image. 

 Gaussian Blur—a smoothing blur for noise reduction. 

 Lens Blur— simulates blurring from wide aperture lens usage. 

 Maximum Blur—broadens highlights, reduce shadows. 

 Median Blur—blurs while affecting color regions. 

 Minimum Blur—shrinks highlights, increase shadows. 

 Motion Blur—blurs to simulate directional movement. 

 Radial Blur—gives a circular blur at a chosen position. 

 Zoom Blur—blurs to simulate zooming-in motion effect. 
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Average 

The Average filter calculates the average color in the current layer (or selection) and then applies it 

throughout that area. 

 

 

About the Average filter 

This filter can be found in the Filters menu, in the Blur category. 

This filter has no customizable settings. 

  



Bilateral Blur 

The Bilateral Blur filter blurs an image while retaining areas of high contrast. As these contrast changes 

most commonly occur at edges, it makes the filter very useful both for noise reduction and for 

creating interesting stylistic effects. 

 

 

About the Bilateral Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls the size of the area sampled for the blur. Type directly in the text box or 

drag the slider to set the value. 

 Tolerance—controls whether pixels are included within the blur based on the difference 

between tonal values of neighboring pixels. At larger tolerance values, pixels with greater 

tonal differences will be included within the blur. Type directly in the text box or drag the 

slider to set the value. 
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Box Blur 

The Box Blur filter blurs an image based on the average color of neighboring pixels. At high radius 

levels, this results in an obvious 'box' effect. At lower radius levels, it results in an effect similar to 

Gaussian Blur. 

 
 

About the Box Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls intensity of the filter. Type directly in the text box or drag the slider to set 

the value. 
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Custom Blur 

The Custom Blur filter allows you to construct your own filter to apply a customized blur. 

 

Custom Blur matrix window. 

About the Custom Blur filter 

When this blur filter is applied to an image, each pixel's brightness value is recalculated according to 

the customized formula. 

The cells in the matrix represent a target pixel (at the center) and its surrounding pixels. Numbers in 

these cells are multipliers ("coefficients") by which each pixel's brightness will be multiplied. The filter 

examines each pixel, takes the sum of all these multiplications, and comes up with a new value for 

each target pixel. If a cell's value is 0, the corresponding pixel makes no contribution to the 

recalculated value of the target pixel. 

This filter can be found in the Filter menu, in the Blur category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Matrix cell—sets the multiplier used to determine pixel brightness. Type directly in the text 

box or use the arrow s to set the value. 

 Divisor—sets the value by which the overall multiplied brightness is divided. Type directly in 

the text box to set the value. 

 Offset—adjusts the overall brightness. Positive values increase the overall brightness, 

negative values decrease the overall brightness. Type directly in the text box to set the value. 

 Normalize— when selected (default), the Divisor is automatically set to the sum of all the 

values set in the matrix cells to maintain the overall lightness of the original image. If this 

option is off, the Divisor can be adjusted manually. 



Depth Of Field Blur filter 

The Depth Of Field Blur filter applies a blur gradient that can be used to simulate extreme depth of 

field and miniaturization effects, such as tilt shift. 

 

 

Using the Tilt-Shift mode to produce a miniature model effect. 



About the Depth of Field Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Modes 

 Elliptical—useful for photos with a single subject, as it creates an graduated elliptical blur 

vignette. 

 Tilt Shift—often used to simulate a scene created by models. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Mode—choose from the pop-up menu to define the type of blur generated. 

 Radius—controls intensity of the blur. Type directly in the text box or drag the slider to set 

the value. 

 Vibrance—controls the color intensity of less saturated colors (a high value increases the 

'model-like' effect). 

 Clarity—increases the local contrast and gives the appearance of increasing the sharpness of 

the image. 

Modifying the applied blur gradient  

The gradient stops determine the position and extent of the transition between the areas in sharp 

focus and those that are blurred. 

 

(A) Focus origin, (B) Inner lines, (C) Outer lines, (D) Transition areas. 
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The focus origin (A) defines the central point at which the image is kept completely in focus. 

Reposition the focus origin by dragging on the stop. 

The inner lines (B) define the width of the area in focus. For the Tilt Shift mode these can be set 

independently by dragging each of the stops in turn, or, symmetrically by dragging one of the stops 

while holding the . The Elliptical mode always matches the shape of the inner lines to the outer lines 

so that only the width can be specified. 

The outer lines (C) define the end of the blur transition. For the Tilt Shift mode, these can be set 

independently by dragging each of the stops in turn, or, symmetrically by dragging one of the stops 

while holding the . The Elliptical mode always sets the stops in pairs. 

The transition areas (D) between the inner and outer lines are where the blurring gradually increases. 

The wider the lines, the more gradual the transition. The area on the outside of the lines has the filter 

applied at the full amount set by the Radius slider. 

The angle of the filter can be changed by dragging the stops at an angle. Once the desired angle is 

achieved, holding the will temporarily lock the angle to allow for further adjustment of the width of 

the adjustment. 

When using the tilt shift effect to "miniaturize" a scene, you will get the best effect if you choose your 

images carefully. Models are generally viewed from above, so the tilt shift effect will work best on 

images taken with an elevated viewpoint and a wide angle of view. Buildings, roads, traffic and 

railways make excellent subjects. 

  



Diffuse Glow 

Diffuse Glow broadens highlights in the active layer or selection by brightening gradually outward 

from existing highlights, producing a soft halo effect. This creates a romantic, almost dreamy effect, 

similar to that of photographing an image through a soft diffusion filter. 

 
 

Using diffuse glow to add intensity and softness to the highlights of an image. 

About the Diffuse Glow filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls how much the pixels surrounding the highlights are affected. Type directly 

in the text box or drag the slider to set the value. 

 Intensity—controls the strength of the highlights. Type directly in the text box or drag the 

slider to set the value. 

 Threshold—determines the range of lightness values affected. As the tolerance decreases, the 

effect spreads to areas that were darker to begin with. Type directly in the text box or drag the 

slider to set the value. 

 Opacity—alters the transparency of the effect. Type directly in the text box or drag the slider 

to set the value. 
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Field Blur filter 

The Field Blur filter lets you control blurring at specific areas of your image. 

 
 

About the Field Blur filter 

Against a uniformly blurred image, one or more selection handles can be added, positioned and 

edited to control the extent of blurring at that handle position, i.e.the focus origin. Multiple areas of 

focus can therefore be created. 

Handles are independent of each other and can be repositioned and edited individually. 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Global Radius—controls the intensity of the blur across the whole image. Type directly in the 

text box or drag the slider to set the value. 

 Selected Handle Level—controls the amount of blurring at the selected handle. Decreasing 

the value brings the image under the handle increasingly into focus. 

 Selected Handle Power—controls the extent of the transition out from the area under the 

handle between sharp focus and blurring. 

To add additional selection handles:  

 Click on the page. 

A selected handle shows as a double ring, as opposed to a single ring (deselected). 
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Gaussian Blur 

The Gaussian Blur filter is used to reduce image noise or detail by creating a pleasing, smooth blur 

using a weighted average. It's especially useful for reducing moiré (interference) patterns. 

 

 

Gaussian blur added to the water. 

About the Gaussian Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls how much dissimilar pixels are blurred. Type directly in the text box or drag 

the slider to set the value. 

 Preserve Alpha—when checked, object edges are not subject to blurring. 
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Lens Blur 

The Lens Blur filter mimics the blur applied to a photo when a wide aperture is used to achieve a 

narrow depth of field. It can be used to improve the composition of a photo by applying a shallow 

depth of field to blur unwanted background. Unlike the Gaussian Blur filter, the Lens Blur filter 

recreates the the bokeh effects generated with a real camera lens. 

 

 

About the Lens Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls the number of pixels affected. Type directly in the text box or drag the slider 

to set the value. 

 Number of Blades—sets the number of virtual aperture blades which controls the shape of 

the 'iris' and the shape of the specular highlights. Type directly in the text box or drag the 

slider to set the value. 

 Blade Curvature—sets how round the iris shape becomes. Type directly in the text box or 

drag the slider to set the value. 

The shape of the iris affects the shape of the specular highlights (bokeh). The most noticeable bokeh 

shapes are created using a low blade curvature and fewer aperture blades. To mimic the effects of 

your own lenses, be sure to match the number of aperture blades. 
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Maximum Blur 

The Maximum Blur filter broadens highlight regions in the image, and shrinks darker areas. It works by 

comparing each pixel to its neighbor and replaces darker pixels with lighter pixels. This is most useful 

for modifying masks. 

 

 

About the Maximum Blur filter 

This filter can be found in the Filters menu, in the Blur category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls the intensity of the filter. Type directly in the text box or drag the slider to 

set the value. 

 Circular—if this option is off (default), highlight regions expand to form square areas. When 

selected, expanded highlight regions are circular. 



Median Blur 

The Median Blur filter broadens color regions in the image. At low settings it’s useful for removing 

noise, especially as it retains edges better than Gaussian Blur. At much higher intensities it introduces 

flat areas of color. 

 

 

Median Blur on a photograph. 

About the Median Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls intensity of the filter. At high levels it creates large, flat areas of color. Type 

directly in the text box or drag the slider to set the value. 
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Minimum Blur 

The Minimum Blur filter shrinks highlight regions in the image, and broadens darker areas. It works by 

comparing each pixel to its neighbor and replaces lighter pixels with darker pixels. This is most useful 

for modifying masks. 

 

 

About the Minimum Blur filter 

This filter can be found in the Filters menu, in the Blur category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls intensity of the filter. Type directly in the text box or drag the slider to set 

the value. 

 Circular—if this option is off (default), darker regions expand to form square areas. When 

selected, expanded darker regions are circular. 



Motion Blur 

The Motion Blur filter blurs in a specified direction to give the impression of movement. This gives an 

effect similar to panning with a camera at slower shutter speeds. 

 
 

Motion Blur can add the impression of speed or movement to images. 

About the Motion Blur filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls the amount of 'zoom'. Type directly in the text box or drag the slider to set 

the value. 

 Rotation—controls the angle at which the blur is applied. Drag the dial to set the value. 
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Radial Blur 

The Radial Blur filter creates blur in concentric circular lines from an origin point. This gives the 

impression of movement and rotation, similar to the effect of a fast rotating object taken at a slower 

shutter speed. 

 

 

About the Radial Blur filter 

This filter can be found in the Filters menu, in the Blur category. 

Drag on the image to set the origin. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Angle—controls the amount of 'spin'. Type directly in the text box or drag the slider to set the 

value. 



Zoom Blur 

The Zoom Blur filter applies converging streaks from an origin point. This gives the impression of 

movement, similar to the effect of using a long exposure while zooming in to a subject. 

 

 

Using Zoom Blur to convey power and sound.. 

About the Zoom Blur filter 

This filter can be found in the Filters menu, in the Blur category. 

Drag on the image to set the origin. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls the amount of 'zoom'. Type directly in the text box or drag the slider to set 

the value. 



Color filters 

Use color filters to add creative color effects or correct color anomalies in your photo. 

Available filters include: 

 Chromatic Aberration—removes lens-related color fringing automatically. 

 Defringe—remove color fringing by sampling. 

 Emboss—creates a convex rounded-edge effect. 

 Erase White Paper—intelligently removes white and replaces with transparency. 

 Monochrome Dither—converts the image to black and white monochrome. 

 Remove vignette—fixes unwanted vignetting around your image. 

 Solarize—sets lightness above which image colors are inverted. 

 Vignette—adds an elliptical surround to your image. 

 Web Safe Dither—makes your image web safe by reducing colors. 

 Halftone—simulates continuous tone reproduction. 
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Chromatic Aberration 

Lateral chromatic aberration is caused when the camera lens focuses different wavelengths of light at 

slightly different distances. This causes the red, blue and green planes to go out of alignment, causing 

multiple color fringes and out of focus details. The problem often gets more pronounced with 

increasing distance from the center of the image. 

The Chromatic Aberration filter fixes chromatic aberration by warping the blue and red planes so they 

align with the green plane—which is usually the most in focus—and finds the best alignment. 

 

 

Aligning the chroma planes using the filter. 

About the Chromatic Aberration filter 

This filter can be found in the Filters menu, in the Colors category. 

This filter has no customizable settings. 

If there is any remaining chromatic aberration this can be mitigated by using the Defringe filter. You 

should always apply the chromatic aberration filter before the defringe filter, and always apply it to an 

uncropped image. 
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Defringe 

Purple fringing, or bichrominance as it's more correctly termed, is a form of chromatic aberration 

caused by the over-excitation of the pixels on the sensor in the camera. The effect can occur anywhere 

within an image but it's most common at the edges of high contrast areas, especially when a dark 

element is strongly backlit, such as branches silhouetted against a blue sky. The Defringe filter 

selectively adjusts these areas to remove the color fringing. 

 

 

Using the Defringe filter to remove purple fringing from the window edges. 

About the Defringe filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 
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On selecting the Defringe filter, it will default to settings which remove the purple fringing, as this is 

the most common type. This can be manually adjusted as necessary in the dialog, or by sampling the 

fringe color on the page to remove it. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Fringe Color—defines the color of the fringe to be desaturated. Drag the slider or click on the 

image to define the hue. 

 Also Remove Complementary Hue—also removes fringing matching the chosen hue's 

complementary color (e.g., choosing purple would also remove yellow fringing). 

 Tolerance—defines how close the fringe color must be to the defined color before it is 

affected. Type directly in the text box or drag the slider to set the value. 

 Radius—defines the radius of the pixels affected around the fringed areas. Type directly in the 

text box or drag the slider to set the value. 

 Edge Brightness Threshold—defines the amount of contrast needed between the fringed 

areas before affecting the pixels. Type directly in the text box or drag the slider to set the 

value. 

  



Emboss 

The Emboss filter uses the contrast of an image to remap contours to create a 3D effect, similar to 

bas-relief. Like many of the other filters, it's very versatile and most useful when combined with other 

techniques. 

 

 



Using Emboss on a duplicate layer with its blend mode set to "Saturation". 

About the Emboss filter 

This filter can be found in the Filter menu, in the Colors category. 

Settings 

The following settings can be adjusted in the effects dialog: 

 Radius—controls the number of pixels affected. Type directly in the text box or drag the slider 

to set the value. 

 Amount—controls the intensity of the filter. Type directly in the text box or drag the slider to 

set the value. 

 Rotation—controls the angle of the lighting. Drag the dial to set the value. 

 Monochrome—when selected, the final effect only contains grayscale values. 

This filter can effectively sharpen images suffering from small amounts of motion blur. 

  



Erase White Paper 

The Erase White Paper filter applies transparency to white areas of an image to remove them. All other 

colors remain unaffected. 

 

 

Using the filter to remove white paper from a scanned document. 

About the Erase White Paper filter 

The filter is really useful if want to use line art previously drawn on physical media (paper). After 

scanning, the areas of scanned white paper can be stripped away by using the filter, allowing coloring 

and texture to be added to complete the design. 

This filter can be found in the Filter menu, in the Colors category. 

This filter has no customizable settings. 



Monochrome Dither 

The filter converts the image to black and white monochrome. 

 

 

About the Monochrome Dither filter 

This filter can be found in the Filter menu, in the Colors category. 

This filter has no customizable settings. 

  



Remove Vignette 

The Remove Vignette filter automatically removes unwanted vignetting from the edges of your image. 

The filter makes a best effort attempt at removal. For heavily vignetted images (showing extreme 

instances or if a vignette has been applied by design), results may vary. 

 

 

About the Remove Vignette filter 

This filter can be found in the Filter menu, in the Colors category. 

This filter has no customizable settings. 

  



Solarize 

The Solarize filter lets you set a lightness value above which image colors are inverted. 

 

 

Solarize used with a blend mode of Subtract to create a stark contrast between shadows and 

highlights. 

About the Solarize filter 

This filter is used to imitate the darkroom technique of re-exposing a partially developed image to 

light to produce dramatic changes in mid-tone regions in the image. 

This filter can be found in the Filter menu, in the Colors category. 

This filter has no customizable settings. 

  



Vignette 

The Vignette filter can be used to either add vignetting to an image, or remove it from the image.  

 
 

About the Vignette filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Exposure—sets the type and value of the effect. Negative values darken the effect, positive 

values lighten the effect. Type directly in the text box or drag the slider to set the value. 

 Hardness—controls how much feather/blur is applied to the transition. Type directly in the 

text box or drag the slider to set the value. 

 Scale—controls the size of the vignette. Type directly in the text box or drag the slider to set 

the value. 

 Shape—determines whether the vignette is circular or elliptical. 
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Web Safe Dither 

The Websafe Dither filter minimizes flat colors and loss of detail when reducing the color depth of 

your image. This helps make the image more acceptable for viewing on the web. 

 

 

About the Web Safe Dither filter 

This filter can be found in the Filter menu, in the Colors category. 

This filter has no customizable settings. 

  



Halftone 

The Halftone filter simulates the look of continuous tone through a choice of screen types. 

 
 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Screen Type—provides a choice of how the continuous tone is generated from Dot, Line, 

Circular or Color. 

 Screen Angle—changes the direction of the tone reproduction. 

 Cell Size—dictates the size of each individual dot, line or circle that makes up the continuous 

tone. 

 Contrast—increases or decreases the tonal contrast between each cell. 

 Gray Component Replacement—(Color screen type only) controls the contrast of areas 

between color cells. 

 Under Color Removal—(Color screen type only) controls the influence of the color cells. 

Increase to lessen their influence and desaturate the image. 
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Distortion filters 

Distortion filters move pixels in your image to produce various distortion effects. 

Available filters include: 

 Deform—distorts from one or more anchor point positions. 

 Displace—distorts using a displacement map. 

 Lens Distortion—fixes barrel and pincushion lens distortions. 

 Mirror—provides a reflection using one or more mirrors. 

 Perspective—a filter based on the Perspective Tool. 

 Pinch/Punch—squeezes or bulges an image area. 

 Pixelate—creates blocks of color to obscure image areas. 

 Polar to Rectangular—distorts by changing polar to rectilinear X/Y coordinates. 

 Spherical—creates a convex or concave sphere distortion. 

 Rectangular to Polar—distorts by changing rectilinear X/Y to polar coordinates. 

 Ripple—produces a radial rippling effect. 

 Shear—apply a linear or curved shear to an image horizontally and/or vertically. 

 Twirl—creates a clockwise or counter-clockwise twirl effect. 

 Affine—moves, scales, or rotates by percentage amounts. 

 Equations—apply custom transform filter based on mathematical expressions. 
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Deform 

The Deform filter allows you to warp areas of your image from one or more placed anchor points. It 

can be useful for making subtle corrections or targeted distortions! 

 

 

About the Deform filter 

This filter can be found in the Filters menu, in the Distort category. 

Click on an image to set the anchor point and then click again to set a second point; the image 

deforms by dragging placed points by varying amounts. 

Click-dragging to create a marquee selection allows multiple anchor points to be selected and 

manipulated simultaneously. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Master—controls intensity of the warp when dragging points. Type directly in the text box or 

drag the slider to set the value. 

 Linear Constraints—choose from the pop-up menu. Rigid only allows the pixels directly 

related to the anchor point to change. The pixels can rotate and move, but not stretch. 

Similarity affects surrounding pixels and allows them to stretch as well as rotate. 



Displace 

The Displace filter applies distortion according to a pattern defined by a displacement map. The 

lightness values of pixels within the displacement map determine the degree to which the distortion 

occurs. 

 

 

Using a texture as a displacement map to blend objects together. 



About the Displace filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Strength—sets the intensity of pixel displacement. Negative values shift pixels upwards, 

positive values shift pixels downwards. Type directly in the text box or drag the slider to set 

the value. 

 Scale To Fit—when selected (default), the displacement map stretches or shrinks to fit the 

document size. If this option is off, the displacement map retains its native dimensions. 

 Load Map From File—sets the displacement map used in the filter. In the pop-up dialog, 

navigate to and select a file, and click Open. 

 Load Map From Layers Beneath—determines the displacement map using layers beneath 

the selected layer. 
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Lens Distortion 

The Lens Distortion filter provides a way of correcting distortion caused by the curvature of a camera 

lens. It's especially useful for correcting barrel distortion (where straight edges are bowed outwards), 

or for correcting pincushion distortion (where straight edges are bowed inwards). 

 

 

About the Lens Distortion filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Drag on the image to set the origin. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Distortion—controls how much the filter is applied. Type directly in the text box or drag the 

slider to set the value. Drag to the left (negative value) to remove barrel distortion, drag to the 

right (positive value) to remove pincushion distortion.  

Most lenses only need values between +5 and -3 to correct distortion. It's also useful to turn grids on 

so that you can see when the lines are straight. 
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Mirror 

The Mirror filter produces mirror effects ranging from horizontal single-mirror reflections to multi-

mirror kaleidoscopes. 

 

 

Mirror used with the Ripple and Motion Blur filters to create the impression of a subject 

submerged in water. 

About the Mirror filter 

This filter can be found in the Filters menu, in the Distort category. 

Click and drag on the image to move the reflection point from its default position. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Number of mirrors—Sets the number of mirror for image reflections. 

 Input—Rotates the original image and reflection about a rotation point in opposite 

directions. 

 Output—Further rotates the mirrored image by a chosen degree. 



Perspective 

The Perspective filter can be used to either correct converging perspective lines caused by lens 

distortion, or to apply perspective for a creative effect. 

Lens distortion can often cause the perspective of a photo to be out, creating the appearance that 

lines are not vertical or horizontal when they should be. 

 

 

Using the Perspective Tool to alter the appearance of a building/structure. 

About the Perspective filter 

The Perspective filter can be adjusted in single or dual plane mode, if applied via the Filters menu 

(Distort category). If using the non-destructive, live filter, only single plane mode is available. 

The live filter can be accessed via the Layer menu, from the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 
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 Planes—the initial grid layout options. Select from the pop-up menu. 

 Mode—the preview options. Select from the pop-up menu. 

o Source—the image remains static as the perspective box is positioned. When the 

perspective filter is applied, the image is stretched and cropped to the original canvas 

size. 

o Destination—the image is directly linked to the perspective box and transforms with 

the box as the anchor points are dragged. 

 Show grid—when selected (default), a grid is displayed between anchor points and lines. If 

this option is off, only anchor points and lines display. 

 Autoclip—(Available in Dual Plane mode) Specifies whether or not to alter the image beyond 

the boundaries of the perspective grid points. If disabled, the image will look continuous; if 

enabled, the image will have visible seams where the perspective tool has been applied that 

can then be retouched. 

 Before/After—if this option is off (default), your page displays your image with the current 

perspective applied. When selected, your page displays the adjusted and original images 

simultaneously with a sliding divider which can be repositioned and shows 'Before' and 'After'. 

  



Pinch/Punch 

The Pinch/Punch filter can be used either in small amounts to correct or enhance portraits, or in 

extreme amounts to create bizarre effects. 

Pinch creates a concave spherical distortion (squeezes an area) and Punch creates convex spherical 

distortion (bulges an area). 

 

 

About the Pinch/Punch filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Drag on the image to set the origin. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Pinch/Punch—sets the type and value of the distortion. Negative values give a pinch effect, 

positive values give a punch effect. Type directly in the text box or drag the slider to set the 

value. 

 Radius—controls intensity of the filter. Type directly in the text box or drag the slider to set 

the value. 
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Pixelate 

The Pixelate filter creates blocks of uniform color. The filter is especially useful when confined within a 

selection area to obscure subject matter. 

 

 

About the Pixelate filter 

This filter can be found in the Filters menu, in the Distort category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Quantization—controls the size of the generated blocks. Type directly in the text box or drag 

the slider to set the value. 

  



Polar to Rectangular 

The Polar to Rectangular filter converts an image from polar coordinates to rectangular coordinates. 

This means that a circle can be turned into a straight line. 

 

 

About the Polar to Rectangular filter 

This filter can be found in the Filters menu, in the Distort category. 

This filter has no customizable settings. 



Spherical 

The Spherical filter gives objects the appearance of being wrapped around a spherical shape, 

distorting the image and stretching it to fit the curve. 

 

 

Sharks have good days too! 

About the Spherical filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Drag on the image to set the origin. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Intensity—sets the type and value of the distortion. Negative values give a concave effect, 

positive values give a convex effect. Type directly in the text box or drag the slider to set the 

value. 

 Radius—controls the size of the effect. Type directly in the text box or drag the slider to set 

the value. 
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Rectangular to Polar 

The Rectangular to Polar filter converts your image from rectangular coordinates to polar coordinates. 

This means that horizontal lines can be turned into circles, sunburst effects can be created, and various 

other effects. It's a handy effect if you want to create a circular frame from a rectangular border. 

 

 

About the Rectangular to Polar filter 

This filter can be found in the Filters menu, in the Distort category. 

This filter has no customizable settings. 

This filter can also be used to create a cylinder anamorphosis—an art form popular in the 18th 

century. When viewed in a mirrored cylinder, the distorted image appears completely normal! 

  



Ripple 

The Ripple filter adds a watery, undulating pattern, like ripples on the surface of a pond. 

 
 

The Ripple filter used to achieve a unique effect. 

About the Ripple filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Drag on the image to set the origin. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Intensity—controls the extent of the effect. Type directly in the text box or drag the slider to 

set the value. 

  

file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Layers/livefilters.html


Shear 

The Shear filter applies distortion according to customizable linear or curved graphs. Horizontal 

and/or vertical shearing is possible via separate graphs. 

 

 

About the Shear filter 

The graphs are set and modified in the filter dialog. They can apply linear shearing by moving end 

nodes in the graph only. Shearing to a curve is possible by reshaping the line. 

This filter can be found in the Filters menu, in the Distort category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Horizontal/Vertical shear graph (left/right): Move end nodes horizontally or vertically (for 

linear shearing), or click along the graph's line and move the added node to reshape the curve 

(for curve shearing). For the latter, add more nodes if needed for more complex curved 

shearing. 

  



Twirl 

The Twirl filter applies a clockwise or counter-clockwise distortion effect to images. 

 

 



The Twirl filter applied to a fireworks photograph. 

About the Twirl filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Drag on the image to set the origin. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Angle—sets the type and value of the distortion. Negative values give a counter-clockwise 

effect, positive values give a clockwise effect. Type directly in the text box or drag the slider to 

set the value. 

 Radius—changes the number of pixels affected. Type directly in the text box or drag the 

slider to set the value. 
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Affine 

The Affine filter allows you to move, scale and rotate either a selection or the entire document by 

percentage amounts. 

 

 

Using the Affine filter to flip the direction of a subject within an image (additional cloning 

and inpainting work required). 

About the Affine filter 

This filter can be found in the Filters menu, in the Distort category. 

  



Settings 

The following settings can be adjusted in the filter dialog: 

 Rotation—controls the rotation of the document or selection. 

 Scale X/Y—independent controls for horizontal and vertical scaling. 

 Offset X/Y—controls the horizontal and vertical offset of the document or selection. 

 Extend Mode—specifies how to handle the blank area created by the filter: 

o Zero: Does not fill the blank space. 

o Full: Fills the blank space with pure white. 

o Repeat: Repeats the last edge of pixels continuously to fill the blank space. 

o Wrap: Wraps the selection back around; useful for seamless texture work. 

o Mirror: Produces a mirror image of the selection. 

 
Using Affine with 50% X and Y offset to expose the image edges: cloning these out will 

create a seamless texture. 

  



Equations 

The Equations filter allows you to apply transform filters through mathematical expressions. 

 

 

Before and after a transform equation. 



About the Equations filter 

This filter allows you to apply a transform to a raster layer using mathematical expression. You can 

achieve a number of distortion-type effects through the use of predetermined variables, trigonometry, 

exponentiation, etc. Additionally, you can use custom variables a, b and c in the equations and control 

their values through sliders on the filter dialog. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Coordinate System—choose from Cartesian or Polar coordinates. 

 Cartesian 

o x = —enter expressions for the X-axis. 

o y = —enter expressions for the Y-axis. 

 Polar 

o r = —enter expressions for the radius. 

o t = —enter expressions for the polar angle (theta). 

 Parameter A (a)—controls the value of custom variable a. 

 Parameter B (b)—controls the value of custom variable b. 

 Parameter C (c)—controls the value of custom variable c. 

 Extend Mode—chooses how to treat pixels outside of the image bounds: 

o Zero—fills pixels outside the image bounds with zeros (alpha values). 

o Full—fills pixels outside the image bounds with constant values (pure white). 

o Repeat—fills pixels outside the image bounds with repetitions of the image's edge 

pixels. 

o Wrap—fills pixels outside the image bounds with copies of the image; useful for 

positional offset filters and seamless texture authoring. 

o Mirror—fills pixels outside the image bounds with mirrored (reflected) copies of the 

image. 



 
An example equation being entered into the filter dialog. 

  



Edge detection filters 

Edge detection filters isolates and strengthens vertical edges, horizontal edges, or both, while 

darkening the rest of the image. 

Available filters include: 

 Detect Edges—isolates all edges in your image. 

 Detect Horizontal Edges—isolates horizontal edges in your image. 

 Detect Vertical Edges—isolates vertical edges in your image. 
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Detect Edges 

The Detect Edges filter isolates and strengthens both horizontal and vertical edges while darkening 

the rest of the image. It is useful for creating stylized effects and edge masks. 

 

 

Detect Edges used on a duplicate layer whose blending mode is then set to "Subtract", 

giving a cell shaded look. 

About the Detect Edges filter 

This filter can be found in the Filters menu, in the Detect category. 

This filter has no customizable settings. 

This filter works by detecting changes in RGB values. It is most useful when used in conjunction with 

blending modes and masks for other filters and adjustments.  



Detect Horizontal Edges 

The Detect Horizontal Edges filter isolates and strengthens horizontal edges while darkening the rest 

of the image. It is useful for creating stylized effects and edge masks. 

 

 

Detect Horizontal Edges filter with Pin Light blend mode applied. 

About the Detect Horizontal Edges filter 

This filter can be found in the Filters menu, in the Detect category. 

This filter has no customizable settings. 

This filter works by detecting changes in RGB values. This means that some images will work better 

than others. 



Detect Vertical Edges 

The Detect Vertical Edges filter isolates and strengthens vertical edges while darkening the rest of the 

image. It is useful for creating stylized effects and edge masks. 

 

 

Detect Vertical Edges filter with Pin Light blend mode applied. 

About the Detect Vertical Edges filter 

This filter can be found in the Filters menu, in the Detect category. 

This filter has no customizable settings. 

This filter works by detecting changes in RGB values. This means that some images will work better 

than others. 



Noise filters 

Noise filters can be used to reduce or add noise (graininess) to your photo. 

Available filters include: 

 Add Noise—introduces noise to recreate natural texture. 

 Clarity—gives contrast-based image sharpening. 

 Denoise—reduces luminance and color noise. 

 Diffuse—adds noise to image edges. 

 FFT Denoise—reduces noise using a Fourier Transform algorithm. 

 Perlin Noise—creates noise with a cloud-like appearance. 

 Dust & Scratches—removes dust and scratch artefacts. 

 Deinterlace— converts field based video images to progressive images. 
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Add Noise 

All digital images have a certain level of noise (random pixel distribution) which helps to create 

atmosphere, texture, and depth. After image manipulation, such as resizing, cloning, applying 

gradients, etc., this texture noise is often lost and the image can take on a very flat appearance. The 

Add Noise filter adds random pixels to the image, introducing a level of noise to help return the 

textures in the image. This also helps to seamlessly blend effects. 

 
 

About the Add Noise filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Intensity—controls the level of noise generated. Type directly in the text box or drag the 

slider to set the value. 

 Monochromatic—When checked, only tones in the image are affected. 

 Noise distribution type: 

o Uniform—produces completely random noise distribution. It is often best used in 

color images. 

o Gaussian—produces a wider range of light and dark pixels as it uses a special curve 

to generate the noise. It's often the best choice for grayscale images. 
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Clarity 

The Clarity filter enhances the local contrast in an image. Its greatest influence is in the mid-tonal 

range. This results in a sharpening effect. 

 
 

Using the Clarity filter to accentuate the outline and details of the image's subject. 

About the Clarity filter 

In Photo Persona, this filter can be applied as a non-destructive, live filter. It can be accessed via the 

Layer menu, from the New Live Filter Layer category. 

In Develop Persona, this filter is available on the Basic panel (Enhance). 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls intensity of the filter. Type directly in the text box or drag the slider to set 

the value. 

Setting the value via a text box is not available in Develop Persona. 
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Denoise 

The Denoise filter is a powerful form of noise reduction. At higher settings, it also creates a really 

pleasing, posterizing effect. 

About the Denoise filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

 
 

Settings 

The following settings can be adjusted in the filter dialog: 

 Luminance Denoise—controls the intensity of noise removal from the luminance channel. 

Type directly in the text box or drag the slider to set the value. 

 Color Denoise—controls the intensity of noise removal from the chrominance channel. Type 

directly in the text box or drag the slider to set the value. 

 Detail—controls the final quality of the reduction. Higher values will give a better quality 

finish but the application of the filter will take longer. Type directly in the text box or drag the 

slider to set the value. 

 Contribution—determines the opacity of corrected pixels. '100%' makes corrected pixels fully 

opaque; 50% makes pixels 50% transparent. 

This process is very complex and therefore may take some time to apply. 
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Diffuse 

The Diffuse filter adds noise to the edges in the image (or selection). 

 

 

About the Diffuse filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Intensity—controls the level of noise generated. Type directly in the text box or drag the 

slider to set the value. 
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FFT Denoise 

The FFT denoise filter (Fast Fourier Transform) removes periodic noise from scanned images. 

 

 



About the FFT Denoise filter 

Periodic noise is encountered on scanned images when the scanner has been subject to electrical or 

electromagnetic interference. By using a grayscale Fourier spectrum generated from the image, 

periodic noise peaks can be edited out of the spectrum by using a brush. 

 

Paired noise peaks on Fourier spectrum mirrored across both horizontal and vertical lines. 

This filter can be found in the Filters menu, in the Noise category. 

Settings 

The following settings can be adjusted in the Fourier spectrum: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. 100% opacity erases pixels completely on the first 

pass. A lower opacity only partially erases the peaks. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

To remove periodic noise:  

 From the grayscale Fourier spectrum, select brush properties from the top toolbar. Take care 

to set a brush width that encompasses the noise peaks entirely. 

 Paint out the frequency noise pairings on both horizontal and vertical lines. 

Use your to zoom in/out of areas of the spectrum. 
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Perlin Noise 

Perlin noise generates pixels with values that vary between the foreground and background colors, 

resulting in a cloud pattern. Sometimes known as Clouds or Difference Clouds. It can be used to 

create realistic looking scalable textures, including cloud, smoke, and rock or earth-like effects, and is 

a great way of adding realism to textured areas. 

 

 

Perlin Noise used to add texture to a photograph using blend modes. 



About the Perlin Noise filter 

This filter can be found in the Filters menu, in the Noise category. 

When the filter is applied, the clouds are generated using the currently selected background and 

foreground colors. The image data on the active layer is replaced. 

If the layer is fully transparent, the filter will not be applied. The layer must have some pixel data. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Octaves—controls the cloud complexity. Type directly in the text box or drag the slider to set 

the value. 

 Zoom—controls the zoom level of the clouds and the complexity of the noise. Type directly in 

the text box or drag the slider to set the value. 

 Persistence—controls how blurred or grainy the effect is. Type directly in the text box or drag 

the slider to set the value. 

 Blend mode—changes how the applied pixels (noise) interact with existing pixels on a layer. 

Select from the pop-up menu. 

You can create marble textures and other interesting patterns by applying the filter several times 

using a Difference blend mode. 

  



Dust & Scratches 

The Dust & Scratches filter removes artefacts like dust and scratch marks from your images by 

mapping out dissimilar pixels. 

 



 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls the size threshold for determining dust and scratch artefacts. If the artefacts 

are mainly fine in detail, use a smaller radius. Larger radius values will tackle larger artefacts. 

 Tolerance—determines how aggressively the filter should analyze the image. Increase the 

slider to reduce the amount of the image that the filter will affect. 

 Channel Tolerance—when checked, the Tolerance slider works on a per-channel basis. 

Useful for color images as it can produce smoother results and fewer artefacts. 

If you are struggling to remove all dust and scratch marks whilst maintaining a sharp image, don't 

forget that you can use the Undo Brush tool to remove the effect from areas where you want to 

retain detail. 
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Deinterlace 

The Deinterlace filter removes the line "combing" effect found in images taken from interlaced video 

streams. It takes either the even (top) or odd (bottom) set of fields and interpolates the other set to 

produce a whole, progressive image. 

 
 

Before and after deinterlacing of an interlaced video frame. 

About the Deinterlace filter 

This filter can be found in the Filter menu, in the Noise category. There are two further options, Even 

Rows and Odd Rows. 

Even/Odd Row selection 

 Even Rows: The odd (bottom) row fields will be discarded and the image will be interpolated 

from the even (top) row fields. Use typically if your source is in the NTSC format or in 

1080i50/1080i60 (HD). 

 Odd Rows: The even (top) row fields will be discarded and the image will be interpolated 

from the odd (bottom) row fields. Use typically if your source is in PAL DV (tape-based 

camcorders). 

  



Sharpen filters 

Sharpen filters can be used to bring into focus photos that appear slightly blurred. 

Available filters include: 

 Clarity—sharpens the image by affecting local contrast. 

 High Pass—sharpens image edges. 

 Unsharp Mask—sharpens image edges as an alternative to High Pass. 
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Clarity 

The Clarity filter enhances the local contrast in an image. Its greatest influence is in the mid-tonal 

range. This results in a sharpening effect. 

 
 

Using the Clarity filter to accentuate the outline and details of the image's subject. 

About the Clarity filter 

In Photo Persona, this filter can be applied as a non-destructive, live filter. It can be accessed via the 

Layer menu, from the New Live Filter Layer category. 

In Develop Persona, this filter is available on the Basic panel (Enhance). 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls intensity of the filter. Type directly in the text box or drag the slider to set 

the value. 

Setting the value via a text box is not available in Develop Persona. 
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High Pass 

The High Pass filter retains details where sharp color transitions occur, generally at the edges, and 

suppresses the rest of the image.  

 
 

High Pass filter applied with an Overlay blend mode for sharpening. 

About the High Pass filter 

When a High Pass filter is applied at a high radius value to a duplicate layer and combined with a 

contrast blend mode (such as overlay, soft light or hard light), it can be used as a useful sharpening 

technique. 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls how many pixels are kept and how many are suppressed. (At higher radius 

values, only edge pixels are kept.) 

 Monochrome—when selected, the final effect only contains grayscale values. 
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Unsharp Mask 

In spite of its misleading name, the Unsharp Mask filter is a flexible and powerful way to increase 

apparent sharpness in an image. 

 

 

Unsharp Mask can be used to add punch to an image, or to help sharpen soft images. 



About the Unsharp Mask filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Radius—controls the number of pixels affected around the existing light pixels. A smaller 

radius enhances smaller scale detail. Type directly in the text box or drag the slider to set the 

value. 

 Factor—controls how much contrast is added. Type directly in the text box or drag the slider 

to set the value. 

 Threshold—controls how much contrast there needs to be between colors before the 

sharpening effect 'kicks in'. Use higher values for grainy images or skin tones. 

The Unsharp Mask filter affects the whole image (or selection). For fine control, it can be useful to 

apply it to a separate duplicate layer(s), and then either use a mask to allow sharpening of only 

specific areas, or use blends modes set to lighten/darken and change the opacity of these layers to 

get the effect that you want. 
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Apply Image 

Apply Image lets you composite images together on the same layer and use a number of expressions 

for advanced channel blending. 

 

 

Blending a fashion model's photo with a transparent overlay. 



About Apply Image 

Apply Image lets you blend a layer from a source image into a target image's layer. The images are 

composited into a single layer. Channel expressions and blend modes are available to composite the 

layers. 

The source image can be scaled automatically to the target image horizontally, vertically or both, 

avoiding having to size the images equally first. 

To blend two images:  

1. Open your target image. 

2. From the Layers panel, select the layer that you want to blend the source image with. 

3. From the Filters menu, select Apply Image. 

4. Click Load Image and navigate to, then select the source image to import. If the image is 

another layer within your document, you can also click-drag it onto the dialog box to use it. 

5. (Optional) Check the Equations option in order to enable channel blending. 

6. (Optional) Set the Opacity level to control how transparent the imported image appears. 

7. Select a Blend Mode to alter how the source image's colors blends with the target image. 

Select from the pop-up menu. 

8. (Optional) Uncheck Scale Horizontal To Fit to retain the imported images native width. 

When checked, the image is stretched/shrunk to the main image. Uncheck Scale Vertical To 

Fit to retain native height. 

9. Click Apply. 

To use channel expressions:  

1. With the Apply Image dialog open, either load an image or choose Use Current Layer As 

Source to blend the image with itself. 

2. Check the Equations option in order to enable channel blending. 

3. Choose a color space to blend in with the Equation Color Space dropdown. 

4. Now use the available expressions to blend channel information. Some expressions include: 

o Use D+Channel to specify a destination image channel (the original layer). E.g., DB 

for Destination Blue channel. 

o Use S+Channel to specify a source image channel (the image you have loaded in). 

E.g., SR for Source Red channel. 



o Use +, -, *, / to add, subtract, multiply or divide respectively. E.g., SR/SG*SB to divide 

Source Red by Source Green and then multiply by Source Blue. 

 

 

Removing a yellow color cast using channel expressions. 



Shadows / Highlights 

The Shadows / Highlights filter allows for stronger manipulation of the shadow and highlight tonal 

regions in an image. It can be used to reduce contrast, boost shadow detail and recover highlight 

detail. 

 

 

About the Shadows / Highlights filter 

This filter can be applied as a non-destructive, live filter. It can be accessed via the Layer menu, from 

the New Live Filter Layer category. 
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Settings 

The following settings can be adjusted in the filter dialog: 

 Shadows Strength—control how much shadow detail is boosted. 

 Shadows Range—specify the tonal range to boost. Moving the slider to the right will boost a 

greater range of shadow tones. 

 Shadows Radius—controls the range of neighboring pixels that are analyzed when boosting 

shadow detail. Moving the slider to the right produces a stronger contrast, similar to the 

Clarity filter. Move the slider to the left for a flatter result. 

 Highlights Strength—control how much highlight detail is recovered. 

 Highlights Range—sets the tonal threshold for recovering highlight detail. Move the slider to 

the right to recover a greater range of highlights. 

 Highlights Radius—controls the range of neighboring pixels that are analyzed when 

recovering highlight detail. Moving the slider to the right produces a stronger contrast, 

moving the slider to the left produces a smoother result but may make posterization more 

visible. 
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Lighting effects 

The Lighting feature simulates lighting from one or more light sources. 

 

 

About lighting 

Lighting effects simulate ambient, point, directional, and spot lighting in your design. You can 

supplement the single light source with additional light sources for more advanced lighting control; 

different light source types can be used in combination, each being independently configured and 

positioned using on-screen handles. 

Affinity Photo also lets you create lighting effects from 3D bump maps made from texture inherent in 

any image. 



Source types 

Different source types give dramatically different results. The types are best imagined with a few 

examples. 

 Spot: Casts a elliptical beam of light focusing on a specific subject of interest, like a torch. 

 Point: Casts omnidirectional light, like a light bulb. 

 Directional. Casts light directionally from infinity, e.g. from the sun. 

Lighting effects can be applied as a non-destructive, live filter, which can be accessed via the Layer 

menu, from the New Live Filter Layer category. 

Settings 

The following settings can be adjusted in the dialog: 

 Diffuse—sets the level of diffused 'scattered' light reflected from the surface. Higher values 

reflect more light. 

 Specular—sets the level of light reflected from the surface that reflects in a single outgoing 

direction (rather than being diffused), to form a highlight (hotspot). 

 Shininess—controls the spread of the specular reflection above. Set the value lower for larger 

and more widespread highlights; higher for smaller, sharper highlights. 

 Specular color—sets the color for specular reflection. 

 Ambient—Sets the level of uniform 'background' lighting. 

 Ambient light color—Sets a color for ambient light. 

 Light—Click to select a point light source. You can Add, Copy or Remove additional light 

sources. 

 Type—selects the light source type (see above). 

 Color—selects the light source color. 

 Distance—selects the light source distance from the page. 

 Texture—Creates texture from the image itself. 

For 3D Bump Maps: 

 Load bump map—click to load an image that you want to convert to a 3D bump map. Use 

Clear bump map to remove any applied map. 

 Uncheck Scale Horizontal To Fit to retain the imported images native width. When checked, 

the image is stretched/shrunk to the main image. 
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 Uncheck Scale Vertical To Fit to retain native height. 

 Opacity—alters the transparency of the texture. Type directly in the text box or drag the slider 

to set the value. 

To apply a spot light:  

1. From the Filters menu, select Lighting. 

2. From the Type pop-up menu, select 'Spot'. 

3. Drag the on-screen handle at the apex of the 'fan' shape to adjust the distance and direction 

of the light. 

4. (Optional) Drag the Elevation handle situated along the center line to set the height of the 

spot light above the page. 

5. (Optional) Drag the outer and inner handles at the end of the fan to set the outer and inner 

cone, respectively.  

To apply a point light:  

1. From the Filters menu, select Lighting. 

2. From the Type pop-up menu, select 'Point'. 

3. Reposition the default point light by dragging the center handle over a subject of interest. 

4. Drag the circle's edge inwards or outwards to set the light's distance from the page. 

To apply a directional light:  

1. From the Filters menu, select Lighting. 

2. From the Type pop-up menu, select 'Directional'. 

3. On the Lighting panel, drag the cross-hair within the Direction dial. 

To load a 3D bump map:  

1. On the Lighting panel, click Load bump map, navigate to, then select your image. 

2. Click OK. 

3. Adjust Texture to set the amount of texture displayed. 

  



Haze Removal 

 

 

Before and after using Haze Removal. 



About the Haze Removal filter 

This filter can be found in the Filters menu. 

Haze Removal can remove slight to extreme cases of haze affecting an image. Its most typical use is 

for landscape photography where the haze causes low contrast and low saturation, but it can also be 

used to improve images taken during rainy and foggy conditions. 

Settings 

The following settings can be adjusted in the filter dialog: 

 Distance—controls the depth of the haze removal: moving the slider to the right removes 

haze towards the background of the image. 

 Strength—specifies how strong the haze removal effect should be. More strength results in 

more extreme haze removal. 

 Exposure Correction—allows for correction of the image's exposure: use if haze removal 

causes underexposure or overexposure. 

  



Using plugins 

Installed PhotoShop-compatible 64-bit plugins can be made available to Affinity Photo to extend the 

range of effects available to you. 

About plugins 

Configuring plugins in Affinity Photo can be automatic or be configured manually on a per plugin 

basis. 

With an active internet connection, detected or added plugins are evaluated and their support status 

is reported next to the plugin name under the "Detected Plugins" list. 

 Automatic: Some third-party plugins can install automatically to Affinity Photo's default plugin 

folder. No further configuration is needed. 

 Manual: Installed plugins are located manually and then linked to from within Affinity Photo 

as described below. You'll need to target the .plugin file itself, then allow supporting files, 

necessary for the plugin to operate, to be accessed. 

Due to the varying standard of third-party plugins, you may experience problems when using this 

feature. This is beyond Serif's control, so we recommend that you save your work before using 

plugins, then test your plugins before commencing. 

To view auto-configured installed plugins:  

1. From the Affinity Photo menu, select Preferences. 

2. From the Edit menu, select Preferences. 

3. Select the Photoshop Plugins tab. 

4. Click Open Default Folder in Finder. 

5. Click Open Default Folder in Explorer. 

This default location is not configurable. 

To enable untested or potentially unsupported plugins:  

1. Check "Allow Unknown Plugins to be used" beneath the Detected Plugins list. 

To link to your plugin file manually:  

1. From the Affinity Photo menu, select Preferences. 

2. Select the Photoshop Plugins tab. 



3. Under the Plugin search folders box, click Add, then navigate to the parent folder that 

contains the .plugin file. For example, this could be in a PhotoShop folder such as 

/Applications/Adobe PhotoShop CS6/Plug-ins. 

You can add as many plugins as you like by repeating the above process. 

To allow access to supporting plugin files:  

1. From the Photoshop Plugins tab, under the Plugin support folders box, click Authorize 

Global. 

2. The folder dialog will default to root ("Macintosh HD"). You can click Authorize here and 

access to support files will be applied recursively, or you can specify a particular directory that 

contains the support files. 

3. The folder dialog will default to root. You can click Authorize here and access to support files 

will be applied recursively, or you can specify a particular directory that contains the support 

files. 

4. Press Close. 

To apply an installed plugin:  

 From the Filters menu, select the plugin from the Plugins flyout. 

You'll be prompted to restart Affinity Photo for the plugins to take effect. 

If your plug-in entries are displayed but are grayed out, ensure that you have a pixel layer selected 

rather than a mask, adjustment, live filter, shape, curve, or text layer. 

  



Stitching panoramas 

Panoramas are created in the Panorama Persona. This persona is only available through stitching 

together multiple images and serves as a dedicated workspace for panorama editing. 

Multiple images can be stitched together to create a wider and taller scene, referred to as a panorama. 

The benefits of creating a panorama are: 

 Capturing a much wider view of a scene. 

 Producing higher resolution images than can be achieved with just one exposure; useful for 

printing large images and other large size applications. 

Panorama Persona can create multiple panoramas simultaneously from your image collection. Each 

detected panorama is stitched and previewed, before you create your panorama(s) by preview 

selection. A new document is created per panorama. 

 Individual Images 

 Final Panorama 

 

Shooting tips 

 Where possible, use either a tripod or fast shutter speeds to avoid motion blur; blurry subjects 

will produce poor results when stitching. 

 Keep your exposure settings (shutter speed, aperture, ISO, white balance) identical between 

shots to produce a consistent result. 

 Try to avoid shooting at extreme wide angles as this will introduce lens distortion. If you are 

using a typical zoom kit lens (e.g., 18-55mm), try zooming in to its maximum focal length. 

 Always shoot from the same vantage point for best results. 



To stitch one or more panoramas:  

1. From the File menu, select New Panorama. 

2. From the dialog, click Add to locate and select your images. 

3. (Optional) If you have images you do not wish to include, you can uncheck them from the 

image list. 

4. Click Stitch Panorama to stitch images together. One or more previews are generated in the 

adjacent Panoramas window. 

5. (Optional) For multiple panoramas, deselect a preview thumbnail if you don't want to make 

that panorama. 

6. Click OK (this may take time depending on number of images and their complexity). 

You may need to fine-tune your panorama using masking and transforming techniques (see Editing 

panoramas) before removing unwanted transparent regions using cropping or inpainting. 

To finish your panorama:  

In the Panorama Persona, do one of the following: 

 Select the Crop Tool, and from its context toolbar, select Crop to Opaque. 

 Select Inpaint Missing Areas from above your panorama. The inpainting process takes 

place on exit and intelligently replaces transparent regions at the edge of your image with 

alternative image content. 
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Editing panoramas 

If panorama stitching yields alignment errors or you simply require more control over how each image 

is stitched, you can further edit the panorama between the initial stitching and the final result. 

To edit a panorama:  

1. Create a new panorama following the instructions listed in Stitching panoramas. 

2. When the initial stitching is complete, the panorama will be opened with a selection of tools 

available.  

 

 

3. To correct alignment, use the Transform Source Image tool and click-drag the corner 

handles of stack images to transform them. The center handle can also be dragged to alter 

the stack image's position. 

4. For more detailed editing, use the Add to Source Image Mask tool to paint in areas that you 

want to use from the stack's surrounding images. Use the Erase from Source Image Mask to 

remove areas. 

5. Make your edits accordingly, then click Apply and the final panorama will be rendered. 

Panorama editing tools:  

 Hand Tool— move across the panorama by click-dragging. 

 Zoom Tool— zoom in and out of the panorama. 

 Transform Source Image—manipulate the corners of each stitched image to manually 

align them. 
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 Add to Source Image Mask—add an area to the current image mask that will reference 

the surrounding stacks. 

 Erase from Source Image Mask—erase an area from the current image mask; this will use 

the original image's data rather than referencing from the surrounding stacks. 

 Crop—crop the panorama to remove transparent/missing areas. 

 Inpaint Missing Areas—automatically inpaints missing areas (represented by transparent 

checker-boarding) when the final panorama is rendered. Enabled by default. 

When using Add to Source Image Mask and Erase from Source Image Mask, single-click on the 

correct stack image first to select it. Unused areas of a stack image are covered in a transparent 

overlay. 

  



32-bit HDR editing 

Affinity Photo has full support for 32-bit float editing, including import/export for OpenEXR and 

Radiance formats. Compared to 8-bit or 16-bit, 32-bit presents an unbounded color space that can 

contain a vast amount of tonal information. This means the information can be modified to extremes 

without losing fidelity or accuracy. For example, highlight detail blown out by an adjustment or filter 

can be recovered even after successive operations. 

Uses for 32-bit HDR 

Popular uses for 32-bit editing include: 

 HDR merging from several exposures to produce an image with greatly increased dynamic 

range. The result typically has to be tone mapped in order to be viewed properly on most 

displays. 

 3D render editing. Full renders and buffer passes from 3D software and 3D engines can be 

professionally color managed and edited losslessly. 

 General image editing and design work with increased precision. Useful for fine gradient work, 

heavy tonal manipulations and composite work. 

If you are using 32-bit editing for lossless workflows (e.g., 3D compositing/rendering) where you are 

not compressing or modifying the tonal range, you can use the 32-bit Preview panel to preview 

different areas of the large 32-bit tonal range. The added functionality of OpenColorIO can be 

accessed through this panel. 

Photo supports multi-layered (multichannel) OpenEXR documents. For more information, see 32-bit 

OpenEXR support. 
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Examples 

3D render passes 

 

 

Before: Base HDR color render pass of a 3D scene. After: Base HDR color tone mapped and 

blended with scene color pass. 

  



Exposure merging for greater dynamic range 

 

 

Before: Single exposure from camera. After: 7 bracketed exposures merged and lightly tone 

mapped. 

  



Merging to 32-bit HDR 

Multiple exposures of the same subject can be merged to produce an unbounded 32-bit document, 

which contains a significant amount of tonal range—more, in fact, than most displays outside of 

specialized equipment can reproduce. The resulting 32-bit image can then be edited with Photo's 

extensive set of tools, adjustments and filters, or it can be tone mapped in order to map the extensive 

32-bit tonal range to a result that looks suitable for most displays. 

To HDR merge several images:  

1. From the File menu, select New HDR Merge. 

2. From the dialog, click Add to locate and select your images. 

3. Click OK to begin merging the images. 

4. (Optional) If your image set contains moving subjects between each exposure, check 

Automatically Remove Ghosts. 

5. The HDR merging is previewed in stages: first, the image alignment, then the HDR merge 

itself. 

6. By default, the merged result will then be taken into the Tone Mapping Persona for tone 

mapping. See Tone Mapping HDR images for more information. 

You can stop Photo from automatically entering the Tone Mapping Persona and tone mapping your 

32-bit image. On the New HDR Merge dialog, uncheck Tone map HDR image. Once the HDR merge 

is complete, you will then remain in the Photo Persona to make further edits. 

If you choose not to automatically tone map your image, the Sources panel will be displayed, allowing 

you to manually retouch the merged result. If Automatically Remove Ghosts was checked, the 

Sources panel will contain a de-ghosted source as well as the original merged source. For more 

information, see Sources panel. 

Below you will see a 32-bit image being displayed as 8-bit with no tone mapping or further tonal 

adjustments applied. 32-bit simply contains too much tonal range to display, so we typically apply a 

procedure called Tone Mapping to map that tonal information to a range that can be displayed 

accurately. See the topic Tone Mapping HDR images for more information. 
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Before: A 32-bit image with no tone mapping—the range of 32-bit is too great to display. 

Instead we see an image with extreme contrast. 

After: A 32-bit image after being tone mapped. The vast range of tonal information has 

been "mapped" to a range that can be reproduced by most displays. 

Once work on a 32-bit image is completed, you may need to convert its color format and, crucially, its 

color profile if you intend to distribute or share it. For example, you might want to export as an 8-bit 

JPEG with an sRGB color profile. Alternatively, if you are maintaining a lossless workflow, you can stay 

in 32-bit and export to a linear unbounded format. 

To convert the color format and profile before export:  

1. From the Document menu, select Color Format and choose your desired format; for 

example, RGB 8-bit. 

2. A color profile will be automatically assigned: for RGB 8-bit/16-bit documents, this will be 

sRGB IEC61966-2.1. 

To maintain a 32-bit workflow for importing into other software:  

1. From the File menu, select Export. 

2. Choose the OpenEXR format and click Export, then specify where to save your document. 

  



Tone Mapping HDR images 

Tone Mapping is the process of taking a range of tones and remapping them to a smaller range that 

most displays and other devices can accurately reproduce. 

 
A tone mapped 32-bit image. 

 

To tone map an HDR image:  

1. With a 32-bit document open, select a pixel layer and then click Tone Mapping Persona. 

2. Once in the Tone Mapping Persona, your image will have a default tone map applied to it. 

3. Experiment with the adjustments in the Tone Map panel. See below for a list of options. 

4. On the context toolbar, click Apply. 



 

 
Before/after of a tone mapped image. 

Presets 

The Tone Mapping Persona contains a number of presets that appear on the left hand side within the 

Presets panel. Simply click one to apply it. You can also create your own presets, or import new ones. 

  



Settings 

The following settings are available in the Tone Map panel: 

 Tone Compression—controls how much of the unbounded tonal range to map. Increasing 

the slider results in more tone compression. 

 Local Contrast—adds or removes local contrast. Increasing local contrast helps to boost 

clarity in the image. 

 Exposure—raises or lowers the overall exposure. 

 Black Point—sets the black clipping level. Increase to further clip black tones. 

 Brightness—controls mid tone levels. Increase to raise mid tones. 

 Contrast—controls global contrast. Use in conjunction with Clarity to significantly change the 

tone mapped look. 

 Saturation—adds or decreases overall color intensity. 

 Vibrance—adds or decreases color intensity without clipping color tones. 

 White Balance—changes the balance of color tones. Tones can be made cooler or warmer by 

dragging the Temperature slider, and color casts can be corrected using the Tint slider. 

 Shadows & Highlights—controls compression of shadow and highlight tones. Useful for fine 

tuning tones. 

 Detail Refinement—controls additional sharpening to the image. Its effects are more subtle 

compared to the Detail Refinement found in the Develop Persona. For a "gritty", over 

sharpened effect, try a large Radius value and small Amount value. 

 Curves—allows adjustment of tonal range using a curves graph. 

Tone Mapping non-HDR images 

The Tone Mapping Persona can also be entered from non 32-bit documents, which means you can 

achieve a tone mapped look from any 8 or 16-bit imagery. 

  



32-bit OpenEXR support 

Affinity Photo has full OpenEXR 32-bit document support, including multichannel (or "multilayer") 

import and export. 

OpenColorIO Integration 

With an OpenColorIO configuration (see OpenColorIO for more information), OpenEXR documents 

with a valid color space affix (eg filename_acescg.exr) will be converted from that color space to 

scene_linear upon import. 

Additional configuration 

Additional OpenEXR options are available from the Color options on the Preferences menu: 

 Associate OpenEXR alpha channels—when enabled, alpha channel information is merged to 

its associated RGB pixel layer's alpha channel. By default (disabled), imported alpha channels 

are imported as separate layers with an .A affix. 

 Post divide EXR colors by alpha—when enabled, divides color channels by the alpha 

channel. 

 Perturb zero EXR alpha—when enabled, alters zero alpha information so post-division with 

color channel information can be achieved if Post divide EXR colors by alpha is enabled. By 

default (disabled), zero alpha information is left untouched. 

Multichannel import/export 

Photo supports multichannel OpenEXR documents for both import and export. 

Multichannel import: 

 Each channel is imported to a discrete layer in the Layers panel. 

 Each layer retains its affix (e.g., .RGBA, .XYZ). 

 Layers can be hidden or shown and edited individually. 

Multichannel export: 

 Each discrete layer with its channel affix (e.g., .RGBA) is exported to its own channel. 

 All layers are exported to channels regardless of whether they are hidden or shown at the 

time of export. 

 In order to export as multichannel OpenEXR, either the correct preset must be chosen, or the 

multichannel setting must be enabled on the OpenEXR export dialog. See below for more 

information. 
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An example of how a multichannel OpenEXR document looks once imported.To export a 

multichannel OpenEXR document:  

1. From the File menu, choose Export. 

2. Select the EXR export format. 

3. From the Preset dropdown, select OpenEXR 32-bit linear (layered). 

4. (Optional) Access the More dialog to configure the multilayer settings: 

o Include unknown channels—channels whose type cannot be determined will still be 

exported as a single luminance-based channel. 

o Compression—determine a compression format to use for a reduced file size. 

Compression may also be disabled entirely. 

o Image pixels—choose whether to encode Image channels (RGBA etc) as 16-bit (half 

float) or 32-bit (full float). 

o Spatial pixels—choose whether to encode Spatial channels (XYZ etc) as 16-bit (half 

float) or 32-bit (full float). 

o Other pixels—choose whether to encode other/undetermined channels as 16-bit 

(half float) or 32-bit (full float). 

5. Choose Export to export the document to a chosen filename and directory. 

  



Using OpenColorIO 

In addition to 32-bit editing support, Affinity Photo also implements OpenColorIO; a color 

management system that provides a full color managed workflow. It is predominantly used for motion 

picture production but can be used for any situation where accurate end-to-end color management is 

required. 

Setting up OpenColorIO 

By default, Photo's OpenColorIO features are not immediately usable. An .ocio configuration file is 

required alongside a number of supporting files such as lookup tables. 

The OpenColorIO website (http://www.opencolorio.org) contains some sample configurations that 

provide a number of suitable input and output profiles, including several Academy Color (ACES) 

configurations. 

To configure OpenColorIO in Photo:  

1. Download and extract your chosen OpenColorIO configuration to a folder. 

2. From the Affinity Photo menu, select Preferences. 

3. From the Edit menu, select Preferences. 

4. On the Color tab, under OpenColorIO Configuration File, choose Select and navigate to the 

extracted directory. Choose the .ocio configuration file. 

5. Under OpenColorIO Search Folder, click Select and choose the extracted directory (it should 

already be the current highlighted directory from when the .ocio configuration file was 

selected). 

6. You will be prompted to restart the app, which is necessary for the OpenColorIO settings to 

take effect. 

Using OpenColorIO 

OpenColorIO is exposed in Affinity Photo through two methods: 

 The 32-bit Preview panel contains a Display Transform option that only becomes available 

with a valid OpenColorIO configuration. This can be used to achieve a non-destructive, color 

managed workflow. See 32-bit Preview for more information. 

 An OCIO adjustment layer (see OCIO Adjustment) can be added to losslessly convert between 

color spaces. You can have multiple OCIO adjustment layers within a document, which allows 

you to accommodate composite layers from different color spaces. An example layer stack 

might be (in hierarchical order): 

o OCIO Adjustment—from Utility - Linear - sRGB back to Role - scene_linear 
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o sRGB Pixel Layer—composite element 

o OCIO Adjustment—from Role - scene_linear to Utility - Linear - sRGB 

o Pixel Layer—original layer 

 

An OCIO Adjustment layer going from Role - scene_linear to Utility - Linear - sRGB. 

When loading OpenEXR documents, Photo always converts from the source color space to 

scene_linear. With a valid OpenColorIO configuration, Photo will also present a message to let you 

know which color profile it has converted from. This is usually determined by a filename affix, for 

example "render_acescg.exr". 

  



Image stacks 

Non-destructive image stacks blend together a series of images based on the same scene or almost 

identical subject matter. Visual differences between images in the series can then be removed, 

composited together, or used for creative effects. 

About image stacks 

Use image stacks for: 

 Exposure merging: Merging images of varying exposures. 

 Object Removal: Use a series of images to blend out unwanted subject matter from a specific 

image in an image set. 

 Noise reduction: Blend together multiple shots of the same subject and average out the noise. 

 Creative effects: Simulate long exposure imagery and combine bright subjects (e.g., fireworks) 

for a composite effect. 

About stack operators 

A choice of operators can be applied to your stack depending on what you want to achieve. Median 

can be used for most blending operations such as object removal, exposure merging (exposure 

blending) and noise reduction. 

Stack operators include: 

 Mean—averages pixel content across the stack of images. Good for long exposure simulation 

and noise reduction. 

 Median—removes pixel content that is not consistent in each image. Suitable for object 

removal and noise reduction. 

 Maximum—uses the maximum pixel values from each image. Can be used for creative 

exposure blending where the subject is lighter than the background. 

 Minimum—uses the minimum pixel values from each image. Suitable for exposure blending 

where the subject is darker than the background. 

 Range—indicates areas that change across the image stack. Good for analyzing what has 

changed between each image. 

 Mid-Range—uses the middle pixel values from each image. Can be used to increase tonal 

range if used with bracketed exposures. 

 Total—produces the total value of pixels from each image. Usually results in overexposure, 

but can be used to lighten very underexposed imagery. 



 Standard Deviation—analytical: measures the distribution of information between the 

images. Useful for object removal as it clearly indicates areas that will be averaged out with a 

Median operator. 

 Variance—analytical: as Standard Deviation, indicates how pixel values are spread between 

images. More intense distributions are shown very clearly. 

 Skewness—analytical: highlights edge detail and indicates the intensity of pixel value 

distribution. Can be used to determine tonal and spatial differences between images. 

 Kurtosis—analytical: detects the peakedness of an image. A brighter result represents low 

noise levels and a tonal uniformity (most pixels at dominant gray level). Darker results 

represent greater noise and less tonal uniformity (more pixels further away from dominant 

gray level). 

 Entropy—analytical: represents the number of bits required to encode information in the 

stack. Could be used with stacked video frames (within the same scene or shot). 

To create a stack:  

1. From the File menu, select New Stack. 

2. From the dialog, click Add to locate and select your images for blending. Click Open to add 

the images to the stack list. 

3. (Optional) Uncheck Automatically Align Images to manually align images later in the Layers 

panel. 

4. Choose a Perspective or Scaling operation from the menu to allow for successful auto-

alignment. The former applies a perspective adjustment to each image; the latter repositions 

and/or sizes the image layer. 

5. Check Live Alignment to allow the above perspective adjustment to be made non-

destructively (this may affect performance depending on size and number of images to be 

stacked). 

6. Click OK. 

Your images are blended and presented in a Live Stack Group in the Layers panel. You can manually 

align layers if auto-alignment isn't 100% accurate. 

Once stacked, you may notice 'checkerboard' transparency at the very edge of your stack group. This 

is an intentional result of auto-alignment and can be either cropped away or, if you're merging the 

stack image layers together, inpainted out instead. 

To change stack operator:  



1. On the Layers panel, click the Stack operator icon on the Live Stack Group. The default 

operator is Median as indicated by the icon. 

2. From the pop-up menu, select a stack operator suited to the type of photos you are stacking 

(see above). The icon will change depending on the operator selected. 

Once you've applied a stack operator, the image layers in the stack shouldn't require manipulation (of 

opacity, blend modes, blend ranges, etc.) except for possible re-alignment (if auto-adjustment was not 

satisfactory). However, depending on image content you may need to apply additional adjustments to 

the stack or mask some areas for best results. 

 

  



Exposure merging using stacks 

Exposure merging brings together images deliberately shot at different exposure levels to produce an 

image of a higher dynamic range. Such an approach is likely when areas in your shot are in high 

contrast and you'd like to bring together differently exposed areas as a solution. 

Not to be confused with HDR merge, exposure merging composites images without creating an HDR 

image or applying HDR tone mapping, producing quicker and often more natural results. 

 

Shooting tips 

Here are a few things to consider when shooting. 

 To allow for perfect image alignment, use a tripod or ensure your camera is in a fixed position. 

 Ensure enough photos have been taken to cover the full dynamic range required from the 

scene. 

 If available, you can take advantage of your camera's auto bracketing feature to obtain photos 

at multiple exposure levels. 

 Take advantage of continuous shooting modes to automatically capture your images. 

 Avoid flash photography. 

To create an exposure merging stack:  

1. From the File menu, select New Stack. 

2. From the dialog, click Add to locate and select your images. Click Open to add the images to 

the stack list. 

3. Click OK. 

4. On the Layers panel, select the Mean or Mid-Range stack operator from the Stack Operator 

pop-up menu on the Live Stack Group layer. 

  



Object removal using stacks 

Object removal solves the problem of moving subject matter being included in your images—think of 

passing crowds, vehicles, birds flying, or other annoying distractions. Obviously, a single shot taken at 

a specific time may be the perfect solution but it may not be practical or possible to wait for this. 

 

Shooting tips 

 To allow for perfect image alignment, use a tripod or ensure your camera is in a fixed position. 

 Take a pragmatic approach and be realistic. Scenes full of moving objects cannot be 

completely emptied, nor will stationary objects magically disappear (but can be made to using 

the Inpainting Brush tool later!). 

To create an object removal stack:  

1. From the File menu, select New Stack. 

2. From the dialog, click Add to locate and select your images. Click Open to add the images to 

the stack list. 

3. Click OK. 

4. On the Layers panel, select the Median stack operator from the Stack operator pop-up menu 

on the Live Stack Group layer. 

Be prepared to selectively retouch images in your stack if ghosting occurs. This may be due to the 

same or different objects overlapping in more than one image. To resolve, add a mask to your 

problem image in the stack (hide/show each image layer to locate the ghosting effect). 

  



Noise reduction using stacks 

Noise Reduction with stacking allows you to improve the SNR (Signal to Noise ratio) of your imagery 

by stacking together multiple shots of the same subject and "averaging" out the noise. Since the 

subject remains consistent from shot to shot but noise is random, it can be removed efficiently 

without compromising the clarity of the subject. 

This technique is beneficial for static scenes, especially in low light photography where noise is often 

unavoidable, either due to high ISO values or long exposures. 

 

Shooting tips 

Here are a few things to consider when shooting. 

 To help image alignment, use a tripod or ensure your camera is in a fixed position. 

 The higher the ISO value you shoot at, the greater the number of shots you will need to 

effectively reduce the noise. 

 If shooting handheld, use a high speed burst mode if available for the best framing 

consistency between shots. 

 Try and use a fixed white balance to avoid large differences in tone between the shots. 

To create a noise reduction stack:  

1. From the File menu, select New Stack. 

2. From the dialog, click Add to locate and select your images. Click Open to add the images to 

the stack list. 

3. Click OK. 

4. On the Layers panel, select either the Median or Mean stack operator from the Stack 

Operator pop-up menu on the Live Stack Group layer. Results between each mode may vary: 

try both and see which you prefer. 



Creative effects using stacks 

Stacking can be used for more individual, creative effects that require specific image content to 

achieve. 

 

Shooting tips 

Here are a few things to consider when shooting. 

 To help image alignment (if you are using it), use a tripod or ensure your camera is in a fixed 

position. 

 Try and use a fixed white balance to avoid large differences in tone between the shots. 

To create a stack:  

1. From the File menu, select New Stack. 

2. From the dialog, click Add to locate and select your images. Click Open to add the images to 

the stack list. 

3. Click OK. 

4. On the Layers panel, experiment with the Stack Operator. Median is selected by default, but 

try Maximum and Range in particular for more creative effects. 

  



Focus merging images 

Multiple images of the same subject that have different focus distances can be merged together to 

create an image that has a greater depth of field. Focus merging will take the most detailed areas 

from each image (e.g., the areas in focus) and blend them together for the final output. The benefits 

of focus merging are: 

 Increased depth of field for macro photography whilst being able to use larger apertures. This 

avoids having to use smaller apertures (e.g., f/16) where diffraction may become an issue and 

produce a soft image. 

 Ensuring front-to-back sharpness with landscape photography. While hyperfocal distances 

typically result in a large area of the scene being in focus, focus merging can be used for more 

difficult scenarios, such as elements close to the lens that may not be covered by the 

hyperfocal distance. 

 

 

Before: One image with shallow depth of field. After: 50 images focus merged to produce 

image with greater depth of field. 



Shooting tips 

 For best alignment, the images will want to be acquired with the camera on a tripod or some 

form of stabilization. 

 Keep your exposure settings (shutter speed, aperture, ISO, white balance) identical between 

shots to produce a consistent result. 

 Some cameras have a focus bracketing feature, which takes a burst of shots, changing the 

focus distance for each shot. 

 Your focus differential (how much the focus changes between each shot) should depend on 

the type of photography. Macro photography will typically need a narrower differential, and 

more shots, to ensure front-to-back sharpness. Landscape or wide angle photography can 

have a wider differential and fewer shots (e.g., shots focused at foreground, hyperfocal and 

infinity distances). 

To focus merge several images:  

1. From the File menu, select New Focus Merge. 

2. From the dialog, click Add to locate and select your images. 

3. Click OK to begin merging the images. 

4. The focus merging is previewed in its three stages: initial alignment, image blending, and final 

merging. 

5. Once focus merging is complete, the final result can be seen as a new document, ready to 

edit. 



 

 

Before: One image with shallow depth of field. After: 20 images focus merged to produce 

image with greater depth of field. 

  



Focus merge source cloning 

Once a set of images have been focus merged, Photo will display the Sources panel populated with a 

list containing the final merged result and all the individual images used to create the focus merge. 

This gives you the option of re-editing areas of the result using the Clone Brush Tool. 

 
 

The Sources panel for cloning and retouching focus merge results. To edit a merged result 

using the Sources panel:  

1. Ensure the Clone Brush Tool is selected from the Tools panel. 

2. Click an image from the list in the Sources panel to set it as the current clone source. 

3. You can enable the Toggle source preview eye icon which will allow you to preview each 

image and find the best source to clone from. When you have chosen the correct source, 

disable this option in order to edit the merged result again. 

4. Using the realtime preview as a guide, paint over the areas of the focus merged image you 

wish to replace with the clone source. 

  



Equirectangular projection 

 

 

Before: Unmapped equirectangular image (360x180). After: Projected image. 

Equirectangular images, typically 360x180 panoramas, can be mapped to a live projection in Affinity 

Photo and edited whilst they are being projected. This allows for instant feedback of detailed 

retouching, brush work and masking—all operations that would be difficult on an unmapped 

equirectangular image. 

360x180 imagery is often obtained either from dedicated 360 cameras, or by stitching a series of shots 

together using dedicated 360 stitching software. 

To edit an equirectangular image in live projection:  



1. With an equirectangular image layer selected, from the Layer menu, choose Live 

Projection>Equirectangular Projection. 

2. The image layer will then enter live projection and the Edit Live Projection tool will be 

automatically selected. 

3. Use the Edit Live Projection tool to navigate around the image until you settle on an area 

you wish to edit. 

4. Using the appropriate tools, make your edits. 

To pan around an image in live projection:  

1. If you choose another tool when panning in live projection, you will temporarily leave the Edit 

Live Projection tool. 

2. To pan around the image again, either: 

o Choose the Move Tool, then from the context toolbar, select the Edit Live 

Projection tool. 

o From the Layer menu, choose Live Projection>Edit Live Projection (you can also 

use the keyboard shortcut listed for this option). 

To add additional layers in live projection view:  

1. Whilst in live projection view, you can add content to the projected image such as text, 

images and brush work on new layers. 

2. Add your new layer content. For example, you could add some Text at the Nadir (bottom 

pole) with a copyright notice. 

3. Position and rotate the layer as you wish using the Move Tool. You can also match 

perspective by using the Perspective Tool. 

4. With the new layer selected, from the Layer menu, choose Merge Down. This will merge and 

rasterize the layer into the main equirectangular image layer. 

5. Once the content is merged, you can pan around the live projection by choosing the Move 

Tool, then selecting the Edit Live Projection tool from the context toolbar. 

To exit live projection and convert the image back to equirectangular mapping:  

1. Converting your image layer back to its original equirectangular mapping will allow you to 

export and share it—some image hosts support 360 image projection, or alternatively you can 

implement a Javascript/WebGL-based viewer on your own web pages if you wish. 

2. To clear the live projection, select your image layer, then from the Layer menu, choose Live 

Projection>Remove Projection. 



Examples 

 

Removing the tripod at the Nadir (bottom pole) using the Inpainting Brush. 

 

 

Before: The original equirectangular image. After: Using live projection to compose a scene 

from a certain area of the 360 image.  



Perspective projection 

Perspective projection allows you to project (or map) perspective planes to flat 2D representations 

and edit them. 

 

Editing multiple planes in Perspective projection. 

After adding a perspective plane, you can temporarily remove perspective. This lets you apply texture, 

text, and brush strokes in 2D without having to manually transform the content to maintain 

perspective. Once edited, and the projection is removed, the added edits are transformed 

automatically ensuring that perspective is kept realistic. 

Multiple planes can be defined—each one can be edited individually. 

To use Perspective projection:  

1. With an image open, from the Layer menu, choose Live Projection>Perspective Projection. 

2. An initial perspective plane will be added covering the image. Drag the four corner nodes to 

align the plane to a particular area within the image (e.g., vanishing point). 

3. Select any tool, adjustment or filter to automatically project the plane to a flat 2D canvas. 

4. Using the appropriate tools, make your edits. 

5. Once finished with the chosen perspective plane, select the Move Tool, then from the context 

toolbar, choose Edit Live Projection. 

To add additional perspective planes:  

1. Whilst in the Edit Live Projection mode, from the context toolbar, choose Add Plane. 

2. Transform the second plane using its corner nodes. 

3. Select between multiple planes by clicking anywhere on them. 

To remove perspective planes:  

1. Whilst in the Edit Live Projection mode, click on a plane to select it. 



2. From the context toolbar, choose Remove Plane. 

To exit Live Perspective projection:  

 At any time during Perspective projection editing, from the Layer menu, choose Live 

Projection>Remove Projection. 

Examples 

 

 

Before: Original image. After: Image with an area edited using Perspective projection.  

  



Macros 

Affinity Photo supports a powerful and intuitive macro recording and playback feature, presented as 

the Macro panel. It allows you to record multiple operations and then play them back sequentially as 

one action. 

 

The Macro panel showing a series of recorded actions. 

About macros 

Through the Macro panel, you can record any operation in Photo; from applying a Gaussian Blur to 

adding a gradient fill. It is hugely useful for workflow purposes as you can record common workflow 

steps and apply them to your documents in a single click. Additionally, you can exclude operations 

from the recording if they were performed accidentally or are no longer needed, and expose certain 

parameters to the user for configurable playback. 

Macros can be saved locally (they appear in the Library panel) and exported to an .afmacro file 

format for sharing and re-importing. 

To record a macro:  

1. On the Macro panel, click the Start recording icon. 

2. Perform the operations you wish to record. They will appear one by one in the macro 

operation list. 

3. (Optional) Uncheck any operations you do not wish to include (e.g., if they are no longer 

required). 

4. When you are finished recording, click the Stop recording icon. 

5. (Optional) To continue recording the macro, click the Start recording icon again. 

6. (Optional) To play back and preview your macro, click the Play icon. 



7. (Optional) To retrospectively change parameters on a particular operation, click the Settings 

icon next to the operation. This is useful for fine tuning your macros, or quickly creating 

variations (e.g., Moderate, Standard, Extreme, etc). 

8. (Optional) Within the Settings dialog for a recorded action, enable the Eye icon to expose the 

parameter to the user (making it interactive) when the macro is run. 

To reset (clear) the macro operation list:  

 With one or more operations listed, click the Reset icon. 

To save a macro:  

1. Once you have recorded your macro, click the Add to Library option. 

2. You will be prompted to choose a category and enter a name for your recorded macro. Enter 

a name and click OK. 

3. The Library panel will become visible with the saved macro appearing in its library category. 

To export a macro:  

1. Once you have recorded your macro, click the Export option. 

2. A file export dialog will then appear. Choose where to export your macro and name it 

accordingly, then click Save. 

3. The macro will then be saved as an .afmacro file. 

To import a macro:  

1. From the Macro panel, click the Import option. 

2. A file import dialog will appear. Navigate to the .afmacro file, select it and click Open. 

3. The macro operations will then populate the macro operations list. You can then modify, play 

back or save the macro. 

  



Batch jobs 

Batch jobs allow a number of image files to be processed: specific processing instructions can be 

automated, boosting workflow efficiency. 

 

The Batch Job dialog with files added to the Sources list. 

About batch jobs 

The Batch Job feature allows you to specify an unrestricted number of source files to process and 

export. Raw files will be automatically developed, and both the exported file format and image 

dimensions are configurable. 

Batch jobs can work in conjunction with Macros. Any number of pre-recorded macros can be applied 

to the source files, meaning you can very quickly apply certain operations to several files. 

To start a batch job:  

1. On the File menu, choose New Batch Job. 

2. Below the Sources list, choose Add to bring up a file import dialog. 

3. Select your desired image files (including raw files) to add to the Sources list and click Add. 

4. Set your Output options (see below for more information), then click OK to begin batch 

processing. 

Settings 

The following settings are available in the Batch Job panel: 
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 Parallel processing—when checked, allows images to be processed asynchronously—one for 

each processor core or thread. For most modern machines with dual/quad-core processors, 

leaving this on is recommended for more efficient processing. 

 Output: 

o Save into original location—writes the new image files into the same directory as 

the originals. 

o Save into:— allows you to specify a different directory to write the new image files 

into. 

 Save as AFPhoto—writes an .afphoto version of each source image. 

 Save as JPEG—writes a JPEG version of each source image. 

 Save as PNG—writes a PNG version of each source image. 

 Save as TIFF—writes a TIFF version of each source image. 

 Save as OpenEXR—writes a 32-bit OpenEXR version of each source image. 

 Available Macros—lists all macros in their respective categories for adding to the batch job. 

Click Apply to add the currently selected macro to the Applied Macros list. 

 Applied Macros—lists macros that will be applied to each source image in the batch job. 

  



Warping using Liquify Persona 

Liquify Persona provides the perfect environment for highly accurate warping of images. 

 
 

Before and after liquify effect applied. 

When a warp is applied to an image, the overlaid mesh will update to describe the warp on a grid. 

Furthermore, modifying the grid will update the warped image below. 

Image warping is controlled using a combination of the Liquify tools. These can be divided into three 

types: 

 Direct—these affect the image by painting over image pixels. These include the Push 

Forward, Push Left, Twirl, Pinch, Turbulence and Reconstruct Liquify tools. 

 Indirect—these affect the mesh. These include the Clone Mesh Liquify tool. 

 Masking—these apply or remove masked areas. These include the Freeze and Thaw Liquify 

tools. 

These Liquify tools are supported by a dedicated Brush panel. 

Warping can be further modified and controlled using the Mesh and Mask panels. 

To warp using the Liquify tools:  

1. Click a Liquify tool. 

2. Adjust settings on the Brush panel. 

3. Do one of the following: 

o Click or drag on the image to apply the default warp effect. 

o -click or -drag on the image to apply the opposite warp effect. (Not available on all 

tools.) 

4. The effect of the tool is cumulative. If the result is not strong enough, repeat the step above. 
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Modifier keys 

The following modifier (s) can be used: 

 Press the and s and drag on the page. Dragging left or right will decrease or increase the 

brush size, respectively. Alternatively, use the [ or ] s, respectively. Dragging up or down will 

decrease or increase the brush hardness, respectively. 

 Press the right mouse button, then left mouse button and drag on the page. Dragging left or 

right will decrease or increase the brush size, respectively. 

 With many Brush tools in Photo or Liquify Persona, you can quickly change the opacity of 

your brush using numerical keys. 

To warp using Clone Mesh:  

1. Click the Liquify Clone Mesh Tool. 

2. Adjust settings on the Brush panel. 

3. -click on the area of the mesh you wish to copy. 

4. Click on the area of the mesh to 'paste' the copied effect. 

5. Repeat the step above to apply the copied effect elsewhere on the image. 

To remove a warp effect:  

For individual pixels: 

1. Click the Liquify Reconstruct Tool. 

2. Click or drag on the image to remove the warp effect. 

For the entire image: 

 On the Mesh panel, click Reset Mesh. 

To strengthen or subdue the current warp effect:  

1. On the Mesh panel, set the Reconstruct Mesh value: 

o Above 100% to strengthen the effect. 

o Below 100% to subdue the effect. 

2. (Optional) Click Apply and then repeat the above step to further strengthen or subdue the 

effect. 

To permanently apply the warp effect:  

 On the context toolbar, click Apply. 



The warp is permanently applied to the image and the Photo Persona environment will 

display. 

To discard applied warp effects and exit Liquify Persona, click Cancel on the context toolbar. 

Mesh controls 

The Toolbar provides quick access to mesh controls which allow you to reset, save and load a mesh.  

 Reset Mesh—applies a new mesh and removes all currently applied effects from the 

underlying image. 

 Save Mesh—saves the current mesh for future application. 

 Load Mesh—applies a previously saved mesh. 

For more information on mesh controls, see the Mesh Panel topic. 

View modes in Liquify Persona 

There are a variety of view modes available in Liquify Persona which give you the opportunity of 

seeing how your warped image compares to the original. 

To activate view modes:  

On the Toolbar, do one of the following: 

 Click None to display the warped image in isolation. 

 Click Split to display both warped and original image on the same page. A sliding divider can 

be repositioned to view the image 'Before' and 'After' warping 

 Click Mirror to display warped and original image side-by-side on separate pages. Panning 

and zooming affects both pages simultaneously so the same area is always displayed in both 

pages 
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Masking in Liquify Persona 

Protect parts of an image from warp effects applied in Liquify Persona by applying a mask. 

 
Before and after liquify effect applied, with mask in place (shown in red). 

Freezing areas to make a mask 

There may be areas of your image which you want to protect from being warped by the Liquify tools. 

You can do this by 'freezing' those areas using the Liquify Freeze Tool. Frozen areas can be thawed 

using the Liquify Thaw Tool, if you wish them to be subject to warps once more. 

To apply a mask:  

Do one of the following: 

 With the Liquify Freeze Tool selected, drag on the page to select areas to be masked. 

 On the Toolbar, select Mask All to apply a mask to the entire image. 

To remove areas of a mask:  

Do one of the following: 

 With the Liquify Thaw Tool selected, drag on the page to remove areas from a mask. 

 On the Toolbar, select Clear Mask to remove a mask entirely from the image. 

To invert masked areas:  

 On the Toolbar, select Invert Mask. 

To mask (or freeze) large areas of your image, do one of the following: 

 On the Toolbar, select Mask All and then use the Liquify Thaw Tool to remove parts of the 

mask. 

 Use the Liquify Freeze Tool to select areas to be warped and then on the Toolbar, select 

Invert Mask. 



Brush Panel (Liquify Persona only) 

The Brush panel allows you to control the settings for the Liquify tools. 

Settings 

The following settings are available in the panel: 

 Size—the brush (stroke) size in pixels. Type directly in the text box or drag the slider to set the 

value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the slider to set the value. 

 Opacity—the strength of the effect applied with each stroke. Type directly in the text box or 

drag the slider to set the value. 

 Speed—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type 

directly in the text box or drag the slider to set the value. 

 Ramp—determines the shape at the edge of the brush (and therefore the shape of the mesh 

after a stroke has been applied). Select from the pop-up menu. 

Mask Panel (Liquify Persona only) 

The Mask panel allows you to control the mask applied to the warped image. 

The following settings are available in the panel: 

 Clear Mask—removes the current mask from the image. 

 Mask All—applies a mask to the entire image. 

 Invert Mask—reverses the mask settings so all areas which are not masked become masked 

and vice versa. Opacity values of masked pixels are also inverted. 

  



Mesh Panel (Liquify Persona only) 

The Mesh panel allows you to set the appearance of the grid superimposed on the image. 

The following settings are available in the panel: 

 Show Mesh—when selected (default), a grid of horizontal and vertical lines displays as an 

overlay on the image. 

 Divisions—sets the size of squares in the mesh. Type directly in the text box or drag the slider 

to set the value. 

 Color—sets the color of the mesh lines. Click the color swatch to display a pop-up panel. See 

the Color panel topic for more information on the settings available. 

 Opacity—how see through the mesh is. Type directly in the text box or drag the slider to set 

the value. 

 Reconstruct Mesh—sets the strength of the overall warp effect across the entire grid. 0% will 

remove any currently applied effect from the image. Type directly in the text box or drag the 

slider to set the value. 

 Apply—applies the current warp effect to the image and resets the Reconstruct Mesh setting 

to 100%. 

 Load Mesh—applies a previously saved mesh. 

 Save Mesh—saves the current mesh for future application. 

 Reset Mesh—applies a new mesh and removes all currently applied effects from the 

underlying image. 

 Last Mesh—applies mesh settings used in the last Liquify session. 

  

file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Panels/clrPanel.html


Painting brush strokes 

Use the Paint Brush Tool to apply brush strokes to your design. 

 

Applying brush strokes to color scanned line art. 

Painting 

The Paint Brush Tool and other brush-based tools can be used to add brush strokes to your image for 

creative or corrective reasons. An impressive selection of categorized brushes is available for use with 

these tools in the Brushes panel. Each category in the panel contains brushes of varying properties 

and characteristics. 

The appearance of brush strokes are determined by a combination of the chosen brush tool, the 

Brushes panel and the tool's context toolbar. 

If you want to save a brush, these can be stored in the panel as a custom brush for future use. 

The Undo Brush Tool can be used to undo modifications made to an image layer by other painting 

tools. 

To paint brush strokes:  

1. Use the Layers panel to select the layer that you want to work on, or create a new layer. 

2. From the Tools panel, select the Paint Brush Tool or other brush-based tool. (See tip below.) 

3. From the Brushes panel, select a brush thumbnail of your choice. (See tip below.) 

4. Adjust the context toolbar settings. 

5. Select a stroke color from the Color panel. 

6. Drag on the page in the direction that you want the brush stroke to follow. 

If you wish to switch brush tools, while maintaining the selected brush type, you can set this 

preference using the Assistant Manager. Alternatively, you can set Affinity Photo to automatically 

select a particular brush tool when a brush type is selected. See the Modifying brushes topic for more 

information. 
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When using the brush tools, the area under the cursor shows a preview of the currently set brush 

color and properties. You can switch the preview off via Affinity Photo>Preferences>User Interface. 

When using the brush tools, the area under the cursor shows a preview of the currently set brush 

color and properties. You can switch the preview off via Edit>Preferences>User Interface. 

Modifier keys 

The following modifier (s) can be used: 

 The draws a straight brush stroke from the end of the previous brush stroke to the next 

position you click. 

 Press the and holding down the left mouse button picks up a new color under the brush to 

paint with. 

 Press the and s together and drag on the page. Dragging left or right will decrease or increase 

the brush size, respectively. Alternatively, use the [ or ] s, respectively. Dragging up or down 

will decrease or increase the brush hardness, respectively. 

 Press the right mouse button, then left mouse button and drag on the page. Dragging left or 

right will decrease or increase the brush size, respectively. 

 With many Brush tools in Photo or Liquify Persona, you can quickly change the opacity of 

your brush using numerical keys. 

To undo painted modifications:  

1. From the Tools panel, select the Undo Brush Tool. 

2. Paint over pixels which you want to return to their original value. 

To erase brush strokes after you paint:  

1. From the Tools panel, select the Erase Brush Tool. 

2. Paint over areas of your brush stroke. 

To use opacity quick keys:  

1. Select a Brush tool. 

2. Press a numerical key, or two numerical keys in quick succession, to set the opacity. For 

example: 

o Press 4 for 40% opacity. 

o Press 0 for 100% opacity. 

o Press 4 and 5 for 45% opacity. 

o Press 0 and 7 for 7% opacity. 



Erasing 

Affinity Photo lets you erase areas of a layer using a combination of the Erase Brush Tool, the Brushes 

panel and the tool's context toolbar. Alternatively, you can use the Background Erase Brush Tool or 

the Flood Erase Tool to remove pixels from a layer. 

 

Use of Erase Brush Tool, Background Erase and Flood Erase tools. 

Erasing on a layer 

You can use the Erase Brush Tool to erase unwanted pixels directly on the layer using the same 

principles as using the Paint Brush Tool. 

The Background Erase Brush Tool takes a sample of the color under the cursor when you begin to 

erase, and will remove all closely matching colors along the stroke. 

The Flood Erase Tool removes areas of the layer based on the color selected using a powerful 

tolerance setting. 

Erasing on a vector layer 

As pixels don't exist on a vector layer, a pixel mask is created and applied over the vector layer 

instead; the erasing process prevents the shape, line or text from being modifiable from that point 

forward. However, the pixel mask can be modified at any point using pixel brushes. See Layer masking 

for more details. 

The Flood Erase Tool cannot be used on a vector layer. 

To erase on a pixel layer:  

1. From the Layers panel, select a pixel layer. 

2. From the Tools panel, select the Erase Brush Tool. 

3. From the Brushes panel, select a brush of your choice. 

4. Adjust the context toolbar settings. 

5. Drag on the page in the direction that you want the erase brush stroke to follow. 
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To use the Background Erase Brush Tool:  

1. From the Layers panel, select a layer. (If you select a vector layer, it will be automatically 

rasterized when the tool is used.) 

2. From the Tools panel, select the Background Erase Brush Tool. 

3. From the Brushes panel, select a brush of your choice. 

4. Adjust the context toolbar settings. 

5. Place the cursor over the color you want to erase in the image and drag within the image to 

erase the targeted color beneath the brush cursor. 

To use the Flood Erase Tool:  

1. From the Layers panel, select a pixel layer. 

2. From the Tools panel, select Flood Erase Tool. 

3. Adjust the context toolbar's Tolerance setting to control the extent of flood erasing across 

pixels. Experimenting will produce labor saving results. 

4. Click on the image to select the target pixel. 

To erase on a vector layer:  

1. From the Layers panel, select the vector layer. 

2. From the Tools panel, select the Erase Brush Tool. 

3. Paint on the vector layer to erase. 

You'll notice a mask thumbnail appear next to the layer. While this remains selected you can continue 

erasing. 

A layer mask is added by default, however, using the Assistant Manager you can control how pixel 

erasing works on vector layers. You can optionally rasterize the layer completely or take no action 

(preventing erasing from occurring). 
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Mixing paint colors 

Affinity Photo gives you the opportunity to digitally simulate the mixing of wet paint applied to a 

canvas. 

 

Effect of dragging the Paint Mixer Brush across color boundaries. 

Using the Paint Mixer Brush 

The Paint Mixer Brush is pre-loaded with the Foreground color selected on the Color panel. As you 

drag on the page, this color blends with the color of pixels underneath the stroke, giving a smudged 

appearance to the image. 

By default, the mixed color remains on the Paint Mixer Brush. However, the brush can be manually 

'cleaned' at any time. As soon as you drag on the page with a clean brush, the brush will pick up the 

color directly underneath it. 

Alternatively, the mixed color can be manually removed from the brush at any time and reloaded with 

the Foreground color. You can also set this to occur automatically every time you begin a new stroke. 

To simulate a clean brush (with no paint on it), set the Foreground color on the Color panel to None. 

As soon as you drag on the page, the brush will pick up the color directly underneath it. 

To mix paints:  

1. On the Tools panel, select Paint Mixer Brush. 

2. On the Color panel, set the Foreground color. 



3. On the Brushes panel, select a brush type. 

4. Adjust the context toolbar settings. 

5. Drag on the page. 

To simulate a clean brush (with no paint on it):  

With the Paint Mixer Brush selected, do any of the following: 

 Set the Foreground color on the Color panel to None. 

 On the context toolbar, click Clean Brush 

To remove mixed paint and reload the Paint Mixer Brush:  

 With the Paint Mixer Brush selected, on the context toolbar, select Load Brush. 

To automatically clean and reload the brush after each stroke, on the context toolbar, select the Auto 

Load Brush option. 

  



Replacing colors by brush 

You can recolor areas of an image using the Color Replacement Brush Tool. 

 

 

Before and after painting with the Color Replacement Brush Tool with the Foreground color 

set to blue. 



Using the Color Replacement Brush Tool 

The Color Replacement Brush Tool takes a sample of the color under the cursor when you begin to 

paint, and will replace all closely matching colors along the stroke with the current Foreground color. 

The targeted color's hue will be replaced with the current Foreground color's hue, while retaining 

lightness values of the original pixels. 

To replace colors by brush:  

1. From the Layers panel, select a layer. (If you select a vector layer, it will be automatically 

rasterized when the tool is used.) 

2. From the Tools panel, select the Color Replacement Brush Tool. 

3. From the Brushes panel, select a brush of your choice. 

4. Adjust the context toolbar settings. 

5. From the Color panel, choose a Foreground color to replace the color you want to change. 

6. Drag the brush cursor over the targeted color. 

  



Pixel-aligned painting 

To achieve hard-edged painted strokes, which align to individual pixels, you can use the Pixel Tool. 

 

The Pixel Tool adds pixels directly to the layer using the same principles as using the Paint Brush Tool. 

You can select from any of the brushes from the Brushes panel to use with the Pixel Tool. 

To apply pixel brush strokes:  

1. Use the Layers panel to select the layer that you want to work on, or create a new layer. 

2. From the Tools panel, select the Pixel tool. 

3. From the Brushes panel, select a brush thumbnail of your choice. Use hard-edged brushes 

from the Basic category for best results. 

4. Adjust the context toolbar settings. 

5. Select a stroke color from the Color panel. 

6. Drag on the page in the direction that you want the brush stroke to follow. 

Although the Pixel Tool will align to pixels by design, switching on a one-pixel fixed grid may help 

stroke alignment. 

The keyboard modifiers available to the Paint Brush Tool apply equally to the Pixel Tool. 
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Creating custom pixel brushes 

You can create a custom brush from a preset or from scratch using a raster image. 

To create a custom preset brush stroke from scratch:  

On the Brushes panel, click Panel Preferences and then select: 

 New Intensity Brush—creates a brush stroke based on the opacity values of a raster image. 

In the pop-up dialog, navigate to and select a file, and click Open. 

 New Round Brush—creates a brush stroke based on a circular shape. 

 New Square Brush—creates a brush stroke based on a rectangular shape. 

 New Image Brush—creates a brush stroke based on the color values of a raster image. In the 

pop-up dialog, navigate to and select a file, and click Open. 

The new brush is added to the selected category using default settings. To edit the default settings, 

follow the procedure below from step 3. 

To create a custom preset brush stroke from a preset:  

1. On the Brushes panel, select a brush and click Edit Brush. 

2. In the dialog, click Duplicate and then Close. 

3. Select the new brush at the bottom of the panel and click Edit Brush. 

4. Adjust the settings in the dialog. See Modifying brushes for more information. 

5. Click Close. 

Additional options from Panel Preferences allow you to create, rename, delete, import and export 

brush categories. 

Move brushes to any created category by -clicking and selecting a category name from the Move 

Brush to Category menu option. Custom categories adopt the naming convention 'Brushes', 'Brushes 

2', 'Brushes 3', etc. 
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Modifying brushes 

Brushes can be modified before you paint on your design. Basic modifications can be made from the 

context toolbar, while advanced adjustments can be made from the Brushes panel. Both methods set 

brush properties for subsequent brush strokes, but the latter edits your brush permanently. 

Settings 

The following settings are available: 

General 

 Size—sets the default width of the stroke. This can still be overwritten for individual brush 

strokes using the context toolbar. 

 Accumulation—sets the deviation in the opacity or visibility of the stroke as it is painted. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. 

 Spacing—sets the distance between each nozzle point. A lower percentage results in the 

nozzles blending together to give a flowing stroke. A higher percentage pushes nozzles away 

from each other creating a spray-style stroke. 

 Flow—controls how fast color is built up under your brush. 

 Shape—sets the diameter of the brush nozzles. 

 Rotation—sets the angle at which the brush nozzles are drawn. Great for non-round brushes, 

e.g. for calligraphic effects. 

 Blend Mode—changes how the applied color interacts with existing colors on a layer. Select 

from the pop-up menu. 

 Wet edges—sets the default 'wet edge' behavior of the brush. Select from the pop-up menu. 

The 'wet edge' behavior builds paint up along the edges of your pixel brush stroke, producing 

a watercolor effect. 

 Associated Tool—sets the tool which is automatically selected when the brush is selected. 

Select from the pop-up menu. 

The associated tool's icon will appear next to the brush on the Brushes panel. 

Dynamics 

 Jitter settings determine the extent to which a chosen controller (Pressure, Velocity, Rotation, 

etc.) will affect the above General settings. Pick a controller from the pop-up menu and click 



the adjacent Ramp profile icon to select a standard profile from lower thumbnails or create 

your own using the ramp chart. Move circular nodes to reshape the ramp, add nodes to the 

ramp by clicking on the line, or select a node to delete a node with the (simplifying the ramp). 

Check Linear for straight lines between all nodes; If unchecked (non-linear), nodes are 

connected using smooth curves. 

 Scatter X—sets the deviation in the horizontal position of the stroke the preset will allow as a 

stroke is painted. 

 Scatter Y—sets the deviation in the vertical position of the stroke the preset will allow as a 

stroke is painted. 

Hue, Saturation, and Luminosity Jitter settings affect the brush color, which is set via the Color panel. 

Similarly, Flow Jitter affects brush opacity, also set on the Color panel. 

Texture 

For nozzle control: 

 Brush Nozzles—displays the nozzles currently used in the current brush. 

 Add—adds an additional nozzle to the preset. 

 Remove—deletes the selected nozzle from the preset. 

For base texture control: 

 Base Texture—displays the underlying texture or pattern for the current brush. 

 Set Texture—launches a dialog to add a base texture, as an image, to the brush. For example, 

to simulate a textured surface like paper or canvas. 

 Remove—deletes the base texture from the current brush. 

 Invert—creates a negative version of the texture. 

 Mode—controls how the base texture contributes to the current brush. Select from the pop-

up menu. 

o None—the base texture is ignored, so only the brush nozzles are used. 

o Nozzle—allows nozzles to build up brush color onto the base texture depending on 

flow and opacity response. 

o Final—the density of the base texture is kept constant, with no nozzle flow or opacity 

response. 

 Scale—sets the size at which the texture is displayed. A lower percentage will display the 

texture at a larger size. A higher percentage will display the texture tiled at a smaller size. 



Images for base textures should be JPG or PNG. Any reasonably sized image will be acceptable as the 

base texture can be scaled (above). 

Additional settings: 

 Reset—returns all stroke settings to those of the saved brush preset. 

 Duplicate—saves the current stroke settings to a new preset. 

 Close—exits the dialog and applies stroke settings to the selected preset. 

To modify brush settings:  

1. Choose one of the following: 

o With the Paint Brush Tool selected, on the context toolbar, click More. 

o On the Brushes panel, click Edit Brush. 

2. Adjust the settings in the dialog. 

3. Click Close. 

For more information on creating custom brush presets, see the Creating custom brushes topic. 
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Using layer effects 

Layer effects can be applied to any layer to add more creativity to your design. 

Available layer effects:  

 Gaussian Blur 

 Outer Shadow 

 Inner Shadow 

 Outer Glow 

 Inner Glow 

 Outline 

 Bevel/Emboss 

 3D Effect 

 Color Overlay 

 Gradient Overlay 

Layer effects can be applied to any layer from either the Effects panel or the Layers panel. 

When a layer has one or more effects applied, an icon appears to the right of the layer’s name in 

the Layers panel. 

By working with duplicate layers, blend modes and masks, it's possible to obtain a great degree of 

control over the effects that you generate. 

To apply layer effects:  

1. Select the layer(s) that you want to apply the effect to. 

2. On the Effects panel, select the checkbox of the effect that you want to apply. 

3. Adjust the settings as desired—options vary for each effect. 

4. If required, select any other effects and adjust the settings. 

To edit layer effects:  

1. Select the layer that you want to edit. 

2. On the Effects panel, click the arrow to expand the options for the effect you want to edit. 

Applied effects will be checked. 

3. Adjust the settings as desired—options vary for each effect. 

4. If required, repeat for any other effects. 
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To edit layer effects using the Layer Effects dialog:  

1. Click the effects icon on the layer entry in the Layers panel. 

2. In the dialog, click on the label of the effect that you want to edit. 

3. Adjust the settings as desired—options vary for each effect. 

4. If required, repeat for any other effects. 

If you create a set of layer effects that you want to use again you can save time and effort by saving 

them as a style to the Styles panel. This way they can be applied to any new layer with a single click. 

  



3D Effect 

The 3D effect is used to create the impression of a textured surface. 

 
Before and after effect applied. 

Settings 

The following settings are shown on the Effects panel: 

 Opacity—controls the transparency of the effect. 

 Radius—controls the extent of the effect. 

 Layer Effects—provides access to the Layer Effects dialog for more advanced settings 

and controls. 

The following advanced settings can be adjusted in the Layer Effects dialog: 

 Depth—sets the depth of the effect. This can be linked to Radius or set independently. 

 Soften—blurs the shadows and highlights. 

 Profile—defines how the light is applied and sculpts the ridges, valleys, and bumps that are 

shaded in the process. 

 Remove Profile—returns the profile to the default setting where light is applied evenly. 

 Diffuse—sets the amount of diffuse color reflected from the surface when lit by the Light 

source. A high setting will give a matt appearance, while a low setting will give a gloss 

appearance. 

 Specular—sets the intensity of specular color reflected from the surface when lit by the Light 

source. A high setting will give a gloss appearance, while a low setting will give a matt 

appearance. 

 Shininess—sets the amount of specular color reflected from the surface when lit by the Light 

source. A high setting gives sharper highlights, while a low setting will give widespread 

highlights. 



 Specular color—sets the specular color. Click the color box to choose the color from the pop-

up panel. 

 Ambient—sets the intensity of ambient light. 

 Ambient light color—sets the color of the ambient light. Click the color box to choose the 

color from the pop-up panel. 

 Light source—select a light source from the pop-up menu. You can then adjust the settings 

below for the selected light source. 

 Add—applies an additional light source to the effect. 

 Remove—deletes the selected light source. If there is only one light source it cannot be 

removed. 

 Direction—represents the position of the light source, shadow or gradient. Click or drag to 

adjust the direction (and set the Azimuth and Elevation automatically). 

 Azimuth—defines the direction of the light source, shadow or gradient. 

 Elevation—defines the 'height' of the light source. 

 Color—sets the color of the selected light source. Click the color box to choose the color from 

the pop-up panel. 

 Scale with Object—when selected (default), the effect scales in proportion to the layer 

contents if the content is resized. If this option is off, the effect's scale remains unchanged 

when the layer content is resized. 

 Fill Opacity—sets the opacity of the layer contents without affecting the applied effects. 

To apply a preset or custom profile:  

1. Click the Profile thumbnail. 

2. On the pop-up panel, choose either: 

o one of the Standard profile thumbnails. 

o A custom profile: Click on the curve to add a node, drag a node or portion of the 

curve to shape it. 

3. Select the Linear checkbox to create a sharp curve or deselect to create a smooth curve. 

4. Click away from the pop-up panel to apply the profile. 

  



Bevel/Emboss 

The Bevel/Emboss effect is used to add rounded edges and shadows to give a 3D impression. 

 

 

Before and after effect applied. 

Depending on the type of bevel or emboss set, the rounded edge might be inside or outside layer 

content, convex or concave, and may include a shadow. 

For all bevel/emboss effects you can adopt a preset or custom profile that defines the bevel/emboss 

edge. 

Settings 

The following settings are shown on the Effects panel: 

 Opacity—controls the transparency of the effect. 

 Radius—controls the extent of the effect. 

 Layer Effects—provides access to the Layer Effects dialog for more advanced settings 

and controls. 



By default, you'll apply a Pillow Emboss effect when using the Effects panel. For an inner/outer bevel 

and a basic emboss effect, use the Layer Effects dialog. 

The following advanced settings can be adjusted in the Layer Effects dialog: 

 Type—sets an Inner bevel, Outer bevel, Emboss or Pillow emboss effect. Select from the pop-

up menu. 

 Depth—sets the depth of the effect. This can be linked to Radius or set independently. 

 Soften—blurs the shadows and highlights. 

 Profile—defines how the light is applied and sculpts the ridges, valleys, and bumps that are 

shaded in the process. 

 Invert—reverses the effect of the lighting profile. 

 Remove Profile—returns the profile to the default setting where light is applied evenly. 

 Direction—represents the position of the light source, shadow or gradient. Click or drag to 

adjust the direction (and set the Azimuth and Elevation automatically). 

 Azimuth—defines the direction of the light source, shadow or gradient. 

 Highlight—sets the blend mode, color and opacity for the highlight. Blend mode defaults to 

screen. 

 Shadow—sets the blend mode, color and opacity for the shadow. Blend mode defaults to 

multiply. 

 Scale with Object—when selected (default), the effect scales in proportion to the layer 

contents if the content is resized. If this option is off, the effect's scale remains unchanged 

when the layer content is resized. 

 Fill Opacity—sets the opacity of the layer contents without affecting the applied effects. 

To apply a preset or custom profile:  

1. Click the Profile thumbnail. 

2. On the pop-up panel, choose either: 

o One of the Standard profile thumbnails. 

o A custom profile: Click on the curve to add a node, drag a node or portion of the 

curve to shape it. 

3. Select the Linear checkbox to create a sharp curve or deselect to create a smooth curve. 

4. Click away from the pop-up panel to apply the profile. 

  



Color Overlay 

The Color Overlay effect is used to apply a solid color on top of any existing colors. 

 

 

Before and after effect applied. 

Settings 

The following settings are shown on the Effects panel: 

 Color—sets the color of the effect. Click the color box to choose the color from the pop-up 

panel. 

 Opacity—controls the transparency of the effect. 

 Layer Effects—provides access to the Layer Effects dialog for more advanced settings 

and controls. 

The following advanced settings can be adjusted in the Layer Effects dialog: 

 Blend mode—changes how the effect interacts with content below the current layer. 

 Scale with Object—when selected (default), the effect scales in proportion to the layer 

contents if the content is resized. If this option is off, the effect's scale remains unchanged 

when the layer content is resized. 

 Fill Opacity—sets the opacity of the layer contents without affecting the applied effects. 



Gaussian Blur 

The Gaussian Blur effect is used to create a pleasing, smooth blur using a weighted average. 

 

 

Before and after effect applied. 

Settings 

The following settings are shown on the Effects panel: 

 Radius—controls the extent of the effect. 

 Preserve Alpha—when checked, object edges are not subject to blurring. 

The following advanced settings can be adjusted in the Layer Effects dialog: 

 Scale with Object—when selected (default), the effect scales in proportion to the layer 

contents if the content is resized. If this option is off, the effect's scale remains unchanged 

when the layer content is resized. 

 Fill Opacity—sets the opacity of the layer contents without affecting the applied effects. 



Gradient Overlay 

The Gradient Overlay effect is used to apply a grayscale or color gradient on top of any existing colors. 

 

 

Before and after effect applied. 

Settings 

The following settings are shown on the Effects panel: 

 Opacity—Controls the transparency of the effect. 

 Layer Effects—provides access to the Layer Effects dialog for more advanced settings 

and controls. 



The following advanced settings can be adjusted in the Layer Effects dialog: 

 Type—determines the gradient type used. Select from the pop-up menu. 

 Gradient—sets the grayscale or color gradient. Click the gradient thumbnail to edit. 

 Scale—defines the spread of the gradient separately for the X (horizontal) and Y (vertical) 

axes. 

 Offset—defines the start and end points of the gradient. This is set separately for the X 

(horizontal) and Y (vertical) axes. 

 Angle—defines the direction of the light source, shadow or gradient. 

 Scale with Object—when selected (default), the effect scales in proportion to the layer 

contents if the content is resized. If this option is off, the effect's scale remains unchanged 

when the layer content is resized. 

 Fill Opacity—sets the opacity of the layer contents without affecting the applied effects. 

  



Inner Glow 

The Inner Glow effect is used to add a color border to the inside of an edge. It can be set to the edge 

or center of the edge. 

 

 

Before and after effect applied. 

Settings 

The following settings are shown on the Effects panel: 

 Color—sets the color of the effect. Click the color box to choose the color from the pop-up 

panel. 



 Opacity—controls the transparency of the effect. 

 Radius—controls the extent of the effect. 

 Layer Effects—provides access to the Layer Effects dialog for more advanced settings 

and controls. 

The following advanced settings can be adjusted in the Layer Effects dialog: 

 Blend mode—changes how the effect interacts with content below the current layer. 

 Intensity—determines how much the radius of the effect is blurred. 

 Center/Edge—determines the origin of the effect. 

 Scale with Object—when selected (default), the effect scales in proportion to the layer 

contents if the content is resized. If this option is off, the effect's scale remains unchanged 

when the layer content is resized. 

 Fill Opacity—sets the opacity of the layer contents without affecting the applied effects. 



Inner Shadow 

The Inner Shadow effect is used to add a diffused shadow to the inside of an edge. 

 

 

Before and after effect applied. 

Settings 

The following settings are shown on the Effects panel: 

 Color—sets the color of the effect. Click the color box to choose the color from the pop-up 

panel. 

 Opacity—controls the transparency of the effect. 



 Radius—controls the extent of the effect. 

 Offset—changes the distance between the layer content and the effect. 

 Offset Tool—drag on the layer content to set that angle and offset simultaneously. 

 Angle—defines the direction of the light source, shadow or gradient. 

 Layer Effects—provides access to the Layer Effects dialog for more advanced settings 

and controls. 

The following advanced settings can be adjusted in the Layer Effects dialog: 

 Blend mode—changes how the effect interacts with content below the current layer. 

 Intensity—determines how much the radius of the effect is blurred. 

 Scale with Object—when selected (default), the effect scales in proportion to the layer 

contents if the content is resized. If this option is off, the effect's scale remains unchanged 

when the layer content is resized. 

 Fill Opacity—sets the opacity of the layer contents without affecting the applied effects. 

  



Outer Glow 

The Outer Glow effect is used to add a color border to edges. 

 

 

Before and after effect applied. 

Settings 

The following settings are shown on the Effects panel: 

 Color—sets the color of the effect. Click the color box to choose the color from the pop-up 

panel. 

 Opacity—controls the transparency of the effect. 



 Radius—controls the extent of the effect. 

 Layer Effects—provides access to the Layer Effects dialog for more advanced settings 

and controls. 

The following advanced settings can be adjusted in the Layer Effects dialog: 

 Blend mode—changes how the effect interacts with content below the current layer. 

 Intensity—determines how much the radius of the effect is blurred. 

 Scale with Object—when selected (default), the effect scales in proportion to the layer 

contents if the content is resized. If this option is off, the effect's scale remains unchanged 

when the layer content is resized. 

 Fill Opacity—sets the opacity of the layer contents without affecting the applied effects. 



Outer Shadow 

The Outer Shadow effect is used to add a shadow to edges. 

 

 

Before and after effect applied. 

Settings 

The following settings are shown on the Effects panel: 

 Color—sets the color of the effect. Click the color box to choose the color from the pop-up 

panel. 

 Opacity—controls the transparency of the effect. 



 Radius—controls the extent of the effect. 

 Offset—changes the distance between the layer content and the effect. 

 Offset Tool—drag on the layer content to set that angle and offset simultaneously. 

 Angle—defines the direction of the light source, shadow or gradient. 

 Layer Effects—provides access to the Layer Effects dialog for more advanced settings 

and controls. 

The following advanced settings can be adjusted in the Layer Effects dialog: 

 Blend mode—changes how the effect interacts with content below the current layer. 

 Intensity—determines how much the radius of the effect is blurred. 

 Fill knocks out shadow—when checked (default), if the fill is semi-transparent, the option 

prevents the effect from showing through the fill and contributing negatively. 

 Scale with Object—when selected (default), the effect scales in proportion to the layer 

contents if the content is resized. If this option is off, the effect's scale remains unchanged 

when the layer content is resized. 

 Fill Opacity—sets the opacity of the layer contents without affecting the applied effects. 

  



 

 

Outline 

The Outline effect is used to add a colored outline to layer content. 

 

 

Before and after effect applied. 

Settings 

The following settings are shown on the Effects panel: 



 Color—sets the color of the effect. Click the color box to choose the color from the pop-up 

panel. 

 Opacity—controls the transparency of the effect. 

 Radius—controls the extent of the effect. 

 Layer Effects—provides access to the Layer Effects dialog for more advanced settings 

and controls. 

The following advanced settings can be adjusted in the Layer Effects dialog: 

 Blend mode—changes how the effect interacts with content below the current layer. 

 Alignment—sets the position of the outline. Select from the pop-up menu. 

 Fill style—sets the type of fill applied to the outline. 

 Scale with Object—when selected (default), the effect scales in proportion to the layer 

contents if the content is resized. If this option is off, the effect's scale remains unchanged 

when the layer content is resized. 

 Fill Opacity—sets the opacity of the layer contents without affecting the applied effects. 

The Fill style includes the Contour type. Contour applies a gradient fill which runs from the inner to 

the outer edge of the outline width. 

  



About color 

Affinity Photo can use different color models to represent different ways of describing color. These 

models (RGB, CMYK, Lab, and Gray) can be selected as you create your new document. 

Color definitions are described comprehensively on the internet, so in this section we'll just focus on 

how to set a color model, the model's color space, and how a color profile represents that color space. 

In terms of selecting color as you design, Affinity Photo provides the Color panel's HSL color wheel by 

default or optional sets of sliders. Furthermore, the Swatches panel can be used for easy access to 

preset and custom 'saved' colors that you'd like to use again. 

If you're happy to leave color management until output is required, you can create new documents 

with the suggested default color format RGB/8 with sRGB IEC61966-2.1 color profile. 

Color models 

A screen uses varying amounts of light to create the colors that you see. In the physical world, inks are 

used to create the color on the page. Color is stored by turning colors into numbers. A color model is 

used to describe the numerical system used. 

As not all devices have the same ability to display color, a color space is used to define the gamut 

(available range) of color. By working within a color space suitable for the intended output device, you 

can be confident that your colors will be able to be displayed as intended. 

In Affinity Photo, you can take advantage of an end-to-end CMYK or Lab color-managed workflow as 

you create a new document. 

About color models 

Different color models represent color as numbers in different ways. When working in Affinity Photo, 

you can choose one of four color models. 

RGB model 

The RGB model is an additive color model. The primary colors of light, Red, Green and Blue, are 

combined in various degrees to make other colors in the spectrum. 

 

A representation of the RGB color model. This model is universal within digital cameras and 

electronic displays. 



CMYK model 

The CMYK model is a subtractive model. Cyan, Magenta and Yellow are combined to make each color. 

A fourth ink, Black, is also used for extra control and can be used either on its own for a true black, or 

combined with the other inks for a rich black. 

 

A representation of the CMYK color model. When the three colors combined they make 

black. Black is also added as a separate color for extra tonal control. 

The way that the color model is implemented is defined by the color space that is chosen; this is 

possible by selecting a color profile. 

Lab 

Lab color represents the theoretical range of human vision using three channels: Lightness (L), and 

two color channels of opposing values of 'red - green' (a) and 'yellow - blue' (b). It can be very useful 

when used creatively, especially as Lightness can be adjusted without any change to hue or saturation. 

 

A representation of the Lab color opposition model. Lightness (L) is controlled separately to 

the two color channels (a, b).To select a new document's color model:  

 As you create a new document, select an option from the Color Format pop-up menu. 

The Color Format of a document is a combination of a color model and a bit depth setting (8 or 16). 

To change your document's color model at any time:  

 From the Document menu, select an option from the Color Format sub-menu. 
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Color spaces 

Your color space dictates the range of colors that are available to your screen or other output device. 

About color space 

Each output device, for example, your display or printer, is only capable of producing a certain range 

of colors. A color space is a specific implementation of the color model used to define the color 

gamut (i.e., the range of available color). For example, Adobe RGB, sRGB, Apple RGB, and so on, are all 

unique color spaces for the RGB color model. Different color spaces are also available for CMYK and 

Lab color models. 

Each output device, for example, your display or printer, is only capable of producing a certain range 

of colors. A color space is a specific implementation of the color model used to define the color 

gamut (i.e., the range of available color). For example, sRGB, Apple RGB, and so on, are all unique 

color spaces for the RGB color model. Different color spaces are also available for CMYK and Lab color 

models. 

In order for a device to know which color space to use, it looks at the assigned color profile. You can 

choose your color space by assigning a color profile to your document. 

Which color space should I use? 

Which color space you choose depends on what you're doing and the color model you're choosing to 

operate in. 

If you're unsure of what color space to operate, it's advisable to stick with the default sRGB IEC61966-

2.1 profile if using the RGB color model. 

If you need to use a color space that is not available in Affinity Photo, it will have to be installed on 

your system. Devices can install color profiles for you. Consult your system's color management 

documentation for instructions. 
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Color management 

The color and tonal information in a digital document is stored as numbers. When we share these 

documents between devices, the device has to work out how to display the color. As not all devices 

can display the same color gamut it can lead to colors looking different on each device. 

 

Images without color profiles (or with unsupported color profiles) may not look the same 

across each device. 

To ensure that the color looks the same on each device, we use color profiles to tell the device how to 

display or render the color information. 

 

Images with the correct profile for a calibrated device should closely match. 

In Affinity Photo, an opened file's color profile is honored by default. You have the option to convert it 

to the current working color space. When placing images into an existing document, the image's 

embedded color profile will always be converted to the document's current working space. 

On export, you can choose to embed the document's or a named color profile to ensure accurate 

color management. Alternatively, the exported file can be unprofiled by not embedding the document 

or named profile. 

Assigning color profiles 

Affinity Photo lets you choose global default color profiles, assign a color profile as you create a 

document, or at any point during your session. 

Most commercial printers will accept sRGB as they'll be able to do their own profiling at the print 

stage to get the best results for your work. 



For the CMYK color model, it's best to consult your print partner for an appropriate CMYK color profile 

recommendation. 

To select default global color profiles:  

1. From Affinity Photo>Preferences (Color option), select an RGB, CMYK, Grayscale or LAB 

color profile from the pop-up menus. 

2. From Affinity Photo>Preferences (Color option), select an RGB, CMYK, Grayscale or LAB 

color profile from the pop-up menus. 

3. Choose a Rendering Intent option and check Black Point compensation. 

The chosen profile will be used as the current working space and will be offered when creating new 

documents, or will be used if you choose to convert an opened file's color space (discarding its own 

color profile). 

To select a new document's color profile:  

 As you create a new document, select an option from the Color Profile pop-up menu. 

To convert the color space of file to be opened to the current working space:  

 Prior to opening the file, from Affinity Photo>Preferences, check the Convert opened files 

to working space option. 

 Prior to opening the file, from Edit>Preferences, check the Convert opened files to 

working space option. 

Options exist to warn that a file's working space will be converted, or that an unprofiled file will be 

assigned the current working space's profile. 

To change your document's color profile at any time:  

1. From the Document menu, select Convert ICC Profile. 

2. Select a profile from the list in the dialog. 

3. Click Convert. 

To embed a color profile on file export:  

1. With Export Persona active, choose your Preset in the Export Options panel. 

2. (Optional) Select a different ICC profile from the pop-up menu. Otherwise, the document's 

color profile will be embedded. 

3. Check Embed ICC profile. 

You can also embed an ICC profile via File>Export (click More> in the dialog). 
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By default, exported files are unprofiled, i.e. a color profile is not embedded within them. This 

maintains a low file size optimized for web use. On opening the file, your working color profile will be 

assigned to the file. 

About soft proofing 

Soft proofing simulates output as you edit and design with respect to the color profile and the paper 

medium you intend to print on. 

In Affinity Photo, this can be done by applying a Soft Proof adjustment to your project. You can then 

preview how your output will appear, preventing any nasty surprises at print time. 

Because soft proofing is applied as an adjustment you can apply multiple adjustments, and therefore 

produce soft proofs for multiple output devices. 

As an example, if you want to create several different output types, you might want to start with a 

color profile on document creation with a wide gamut (e.g., Adobe RGB 1998), and then change the 

profile to match the output destination. However, color information may be thrown away if changing 

to a smaller color gamut—simply changing back to a profile with a wider gamut will not restore the 

additional color information. By applying a soft proof adjustment you prevent this, allowing you to 

work in a wider gamut until you are ready to change to your chosen output profile. 

 

  



Sampling (or picking) colors 

The act of color picking lets you sample colors within or outside Affinity Photo, then use them 

throughout your design. 

About sampling colors 

Color sampling appears in two slightly different forms within Affinity Photo. It exists as a 'component' 

of selected panels as well as a standalone tool. 

Both versions function in slightly different ways: 

 A color picker appears on the Color and Swatches panels (and other color-related pop-up 

panels) in the Photo Persona. 

 The standalone Color Picker Tool appears on the Tools panel in the Photo Persona only. 

Regardless of which you use, a sampled color is stored and applied from the swatch next to the color 

picker's icon on the Color or Swatches panel. 

To use the Color Picker Tool:  

1. On the Tools panel, select the Color Picker Tool. 

2. Adjust the settings on the context toolbar. 

3. Do one of the following: 

o (For on-page sampling) Click to pick up any color on the page. 

o (For screen-wide 'magnified' sampling) Drag to select any color under a magnifier 

anywhere within or outside the app. 

To use a panel's color picker:  

 From the Color panel, Swatches panel or any pop-up panels, drag from the color picker icon 

to select any pixel on your screen. 

To apply a sampled color to an object:  

1. Select one or more objects. 

2. On the Color or Swatches panel, click the selector (e.g. Fill or Stroke) to which you want to 

apply the color. 

3. Click the swatch next to the color picker icon on the panel. 

To automatically apply a sampled color to a vector object:  

1. Select one or more vector objects. 



2. On the Color or Swatches panel, click the selector (e.g. Fill or Stroke) to which you want to 

apply the color. 

3. On the Tools panel, select the Color Picker Tool. 

4. On the context toolbar, ensure Apply to Selection is selected. 

5. Do one of the following, to apply to selected objects: 

o Click a color on the page. 

o Drag to select any color under a magnifier anywhere within or outside the app. 

  



Selecting colors 

Affinity Photo offers several ways of choosing colors for your photo edits and design. 

About selecting colors 

An essential requirement for efficient editing and design is the ability to access colors easily and 

intuitively. You may have a preferred method for color selection, so Affinity Photo provides a choice: 

 Color panel—for selection from color wheel, sliders, or boxes using different color models. 

 Swatches panel—for selection by swatch from different preset or custom categories, including 

PANTONE® Colors. 

 Color Picker—for sampling colors anywhere on your screen; great for complementary color 

work. 

 Context toolbar—for selection of Fill and/or Stroke colors from the context toolbar that 

displays when vector content is selected. 

 Gradient tool—apply or edit a color gradient across a pixel or vector layer. Choose from the 

tool's context toolbar. 

Using the Color panel 

With the Color panel, colors can be adopted by tools (or applied to vector content) in just a few clicks. 

Opacity and noise are further color attributes which can be applied. Colors can be saved to a palette in 

the Swatches panel. 

To select a color (using default HSL Color Wheel):  

1. Click the Foreground or Background swatch at the top left of the panel. 

2. Click for a hue color on the outer ring. 

3. Click in the inner triangle to set the combined Saturation and Lightness. 

The relevant swatch updates to the selected color. 

Click Panel Preferences menu on the Color panel to select color via RGB, HSL, CMYK, LAB or 

Grayscale sliders; in 8 bit, 16 bit or percentage modes where applicable; or use Hue, Saturation or 

Lightness boxes. 

To switch colors between the swatch selectors:  

 Click the double-headed arrow. The colors switch (but the active swatch selector remains the 

same.) 

To adjust opacity or noise setting:  



1. Select the toggle button to the bottom-left of the panel. 

2. Drag the slider to set the value. 

To use a different color model:  

1. Click the Panel Preferences menu, and select Sliders from the menu. 

2. At the top right of the panel, click the current color mode displayed, e.g. RGB, to reveal a pop-

up menu. 

3. Select a different color model from the menu. 

To apply a color tint:  

1. Click the Panel Preferences menu, and select Tint from the menu. 

2. Drag the slider to the left or right to increase or decrease the color tint, respectively. 

To use a different color mode:  

 Click the Panel Preferences menu, and select 8 bit, 16 bit or Percentage from the menu. 

To save colors to Swatches panel:  

Click the Panel Preferences menu, and select one of the following: 

 Add Color to Swatch—adds the current color to the currently loaded palette in the Swatches 

panel. 

 Select a chord type from the Add Chord to Swatch pop-up menu—adds a chord of the 

current color to the currently loaded palette in the Swatches panel. 

Using the Swatches panel 

The Swatches panel provides color swatch presets that are selectable from various categories. You can 

easily apply grays, solid colors, or gradient colors as presets. 

To use a color swatch:  

Do one of the following: 

 Choose a palette category from the category pop-up menu and click a color swatch in the 

palette. 

 Click a swatch from the Recently used swatches. 

 Click a None swatch to make the color completely transparent. 

Hold down the when selecting a swatch to honor the opacity and/or noise already applied to your 

object (i.e. only the color of the object will update). 



Using the Color Picker 

The picker lets you sample colors within or outside Affinity Photo, then use them in your project. 

To use the Color Picker:  

1. Drag the Color Picker icon to the color you want to sample. 

2. Click the swatch selector you want to apply the color to. 

3. Click the swatch next to the Color Picker to apply the color. 

Using context toolbar (vector content only): 

For quick access, Fill and Stroke swatches are available from the context toolbar of any selected vector 

content. 

To apply a fill or stroke color to vector content:  

1. Select the object. 

2. From the context toolbar, click either the 'Stroke' or 'Fill' swatch. 

3. From the flyout choose color from a Swatches, Color, or Gradient pane. 

Using the Color pane, you have the option of selecting color using an HSL Color Wheel by default; 

RGB, RGB (HEX), HSL, CMYK, Lab, Grayscale sliders; or independent Hue, Saturation, or Lightness 

boxes. 

Using Gradient 

Use the Gradient tool to apply your own gradient paths across either a pixel layer or to vector content 

fills; you can also apply solid and bitmap fills. The tool's context toolbar lets you change the gradient 

to be radial, elliptical, or conical. 

To use the Gradient tool:  

1. Select a pixel or vector layer. 

2. Select the Gradient tool from the Tools panel. 

3. From the context toolbar, select a fill type from the Type pop-up menu. 

4. Drag the cursor across the content. 

Hold down the to constrain the angle of the gradient path to 45°. 

Create and modify your own gradient fills by clicking the color swatch, adjacent to the Type pop-up 

menu, on the context toolbar. 

For preset gradient fills, use the Swatches panel. 



Accessing PANTONE® Colors 

PANTONE® Color palettes are available from the main Swatches panel. They are also available from 

the pop-up Swatches panel on the context toolbar when a shape, line, or stroke is selected. 

To access PANTONE® Colors:  

 On the Swatches panel (or pop-up Swatches panel), from the category pop-up menu, select 

your preferred PANTONE palette. 

Registration color 

Printing to PDF will allow you to include printer marks, including registration marks assigned with 

registration black (100%C:100%M:100%Y:100%K). However, you can add this registration color as a 

swatch that can be assigned to an object on the page, creating an on-page registration mark. 

To add a registration color as a swatch:  

 From the Swatches panel, click Panel Preferences, then select Add Registration Color. 

You can then apply the swatch to an object on the page. 

 

  



Color Chords 

A color chord is a spread of harmonious colors which can be used in conjunction with each other to 

produce appealing designs. 

About color chords 

Color chords are created by first choosing a base color and then picking a chord type (built on 

professional color theory). A spread of colors is then populated and stored in the current palette in the 

Swatches panel. You can then select from these colors as you design. 

Chord types are based on the HSL color wheel and include: 

 Complementary—the base color and its opposite on the color wheel. 

 Split Complementary—the base color and the colors adjacent to its opposite on the color 

wheel. 

 Analogous—the base color and the colors adjacent to it on the color wheel. 

 Accented Analogic—as for Analogous but, like Complementary, also includes the base 

color's opposite. 

 Triadic—three colors spaced equally around the color wheel starting from the base color. 

 Tetradic—four colors arranged around the color wheel in two complementary color pairs, 

starting from the base color. Otherwise known as 'Rectangle'. 

 Square—four colors spaced equally around the color wheel starting from the base color. 

 Tints—colors which vary in lightness from the base color to white. 

 Shades—colors which vary in lightness from the base color to black. 

 Tones—colors which vary in saturation from the base color to gray. 

You'll find a wide range of color theory websites on the Internet. 

To create a color chord:  

1. (Optional) On the Swatches panel, click Panel Preferences and choose an 'Add Palette' option. 

2. Do one of the following: 

o With no content selected, select a color using the Color or Swatches panel. 

o Select page content with the color you wish to work with. Remember to select the 

appropriate color selector on the Color or Swatches panel. 

3. On the Color panel, click the Panel Preferences menu and select a chord type from the Add 

Chord to Swatch pop-up menu. 



Gradient editing 

The Gradient tool does a great job in drawing a simple color gradient across layers (pixel layers, fill 

layers, adjustment layers, live filter layers, layer masks) as well as vector and text content. However, 

you might want to apply a more complex fill, introducing more than two colors along the gradient 

path, adjust where each color is positioned and/or control color transitions. You can do this in two 

ways. 

 Directly on the Gradient tool path. 

 Via the tool's context toolbar. 

Using the former, you modify the gradient by eye; the latter lets you design with precision and 

absolute control. 

 

Complex gradient applied directly to page content and then adjusted using the pop-up 

panel from the context toolbar. 

Gradient settings 

The following settings can be adjusted via tool's context toolbar (color swatch): 

 Type—determines the gradient type (linear, elliptical, etc.) via a pop-up menu. 

 Position—controls the position of the stop along the gradient from left (0%) to right (100%), 

with 50% representing the central point. 

 Mid Point—adjusts the spread of colors between the selected color stop and the stop to its 

right. 

 Color—click the color swatch to display a pop-up panel where you can modify the selected 

stop's color (including noise value). 
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 Opacity—controls how see through the stop is. 100% represents fully opaque, 0% represents 

fully transparent. 

 Insert—adds a new stop between a selected stop and the stop to its right. The stop adopts 

the color at its new position. 

 Copy—duplicates the selected stop, positioning it between the selected stop and the stop to 

its right. 

 Delete—removes the selected stop from the gradient. Deleting an end stop shortens the path 

back to the adjacent stop. 

 Reverse—the gradient is reversed, i.e. like a mirror image. 

To modify a gradient (directly on an object):  

With the Gradient tool selected, click the content with a gradient fill applied and then do any of the 

following: 

 Click on the gradient path to add a stop. 

 Click a stop to select it. Selected stops display larger than other stops. 

 Drag a stop to reposition it along the gradient path. End stops can be repositioned (by 

dragging) to extend or contract the gradient's length; the angle of the gradient can also be 

changed by dragging. 

 Drag a mid point marker to adjust the spread of colors between two color stops. 

 Apply a color (or opacity or noise value) to a selected stop from the Color panel. 

 Delete a selected stop by pressing . 

To modify a gradient (via the tool's context toolbar):  

1. With the Gradient tool selected, click page content. 

2. From the context toolbar, select the color swatch. 

3. Click the Gradient option which lets you modify your gradient using the above settings. 

  



Matting 

Matting is a useful feature which allows you to swap out regions of transparency with a color of your 

choice, particularly useful when repurposing transparent PNG files. 

 

 
Before and after matting applied. Color sampled from the cat's eye. 

  



To replace transparency with a color matte:  

1. From the Edit menu, click Matte. 

2. From the dialog, choose one of the following: 

o Custom Color—pick any color from the adjacent swatch using a pop-up HSL Color 

wheel. 

o Primary Color—uses the currently set primary color from the Color panel. 

o Secondary Color—uses the currently set secondary color from the Color panel. 

3. (Optional) Reduce the Opacity to limit the color strength. 

4. Click Apply. 

For a complementing color, try color sampling on the image, using the sampled color as the primary 

color. 

  



Using channels 

The image or document's color mode determines the number and type of color channels available to 

you. Each channel stores color information specific to it, which, when combined with other channels, 

brings about the full color image. For example, a red channel would store only red color information 

in RGB color mode. 

Channel information is displayed in the Channels panel. 

Color modes and channels 

For each color mode, the following channels are available. 

 RGB: Red, Green, Blue channels 

 CMYK: Cyan, Magenta, Yellow, Black channels 

 Grayscale: Intensity channels 

 Lab: Lightness, AOpponent, BOpponent channels 

On new documents, the Color Format option presents Color mode and bit depth options in 

combination. 

Image and layer channels 

The Channels panel always displays an image's channels when loaded. From an image channel you 

can: 

 Hide the channel. 

 Protect the channel from editing. 

 Create a Spare Channel (i.e., a saved selection) from the channel information. 

 Store a new selection based on the channel information. 

 Add, subtract, or intersect a channel's selection to/from/with a previously made selection, 

respectively. 

For any currently selected layer (pixel, mask, adjustment or Live filter), the layer's channel(s) are 

displayed below the image channels. From each layer's channel you can:  

 Invert, clear, and fill the channel information. 

 Create a new grayscale layer. 

 Create a new mask layer. 

 Create a Spare Channel (i.e., a saved selection) from the channel information. 



Alpha channels 

The Channels panel also displays the alpha channel for the whole image or currently selected pixel, 

mask, adjustment, or Live filter layer. These channels store transparency information, so it's a great 

place for more advanced masking control. 

Pixel selections 

Another great use of alpha channels is the ability to store more complex selections that would 

otherwise be difficult or time consuming to recreate again. The Channels panel reports your current 

pixel selection as a channel entry, so by creating a 'new' Spare Channel from that pixel selection 

you've stored the selection for future use. 

Pixel selections and masks 

Because alpha channels store both selection and masks, the Channels panel acts as a great central 

point for working between masks and selections. 

Blend ranges 

You can control how specific color channels of the current layer blend with the underlying layer(s). For 

more information, see Layer blend ranges. 

To hide/show image channels:  

 From the Channels panel, click Visible on the channel entry. 

To protect image channels from editing:  

 From the Channels panel, click Editable on the channel entry. A grayed out icon means the 

channel is no longer editable. 

To create a mask or grayscale layer from a current layer's channel:  

 -click the layer's channel, then click Create Mask Layer or Create Grayscale Layer. 

The new layer is added to the Layers panel. 

To invert, clear or fill a layer's channel:  

 -click the layer's channel, then click an option from the pop-up menu. 

To save a selection as an alpha channel:  

 With a pixel selection in place, -click the 'Pixel Selection' entry and select Create Spare 

Channel. 

The selection is stored at the bottom of the Channels panel as a new 'Spare Channel' entry. 
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Vector specific. 

Global colors 

Global colors can be created and applied to different objects in your design. If you want to change the 

color across your design at a later time, you can simply edit the global color in the Swatches panel and 

all objects update with the new color automatically and simultaneously. 

About global colors 

The global color could be applied as a solid fill, stroke, or a color used in a gradient fill. They can be 

made while in RGB, CMYK, HSL, LAB, Grayscale, or Tinting color modes. 

Global colors are added to the currently selected document palette in the Swatches panel. If a 

document palette does not exist when your document's first global color is created, a new document 

palette is automatically created for you in which the color will be stored. Once created, you can apply 

the global color to your design. 

A global color is indicated by a tab in the bottom-left corner of its color swatch. 

You can check if a global color has been assigned to an object's stroke or fill by using the Color panel. 

If you're importing a document palette containing global colors as a System or Application palette, 

the global colors will be converted to standard colors. 

If you're importing a document palette containing global colors as an Application palette, the global 

colors will be converted to standard colors. 

To create a global color from an existing object:  

Do one of the following: 

 Select the object, choose a Document palette in the Swatches panel, set the Stroke/Fill color 

selector, then click Add current color to palette as a global color. 

 -click the object and select Add to Swatches, then From Fill as Global, From Line as Global 

or From Both as Global depending on the object property you want to save. 

To create a global color from scratch:  

1. On the Swatches panel, select a Document palette from the palette pop-up menu. If no 

Document palette exists you can create one from the panel's Panel Preferences menu. 

2. From Panel Preferences, select Add Global Color. 

3. Adjust the settings in the dialog. 

4. Click Add. 



To convert an existing color swatch into a global color:  

1. In the Swatches panel, choose a Document palette from the pop-up menu. 

2. -click a displayed swatch and select Make Global. 

If you have objects in your design which had the original color applied, these will not be updated to 

use the global color automatically. You will have to apply the global color manually. 

To edit a global color:  

1. On the Swatches panel, -click the chosen color swatch and select Edit Fill. 

2. From the dialog, select a color. 

All objects using the global color will be updated automatically. 

Spot colors 

When you create global colors from scratch, you can set these to be a spot colors. 

In professional printing, spot colors can be used instead of CMYK process colors when your artwork 

contains a very limited color set. By setting these colors to be spot colors, print costs can be reduced 

significantly. You may also be able to accurately reproduce colors otherwise impossible with process 

colors. 

As well as setting a global color to be a spot color, you can use pre-supplied PANTONE® spot colors. 

A spot color swatch is indicated by a small dot in the bottom-right corner of its color swatch. 

You can check if a spot color has been assigned to an object's stroke or fill by using the Color panel. 

When publishing to PDF, the Honor spot colors option in the Export Options panel (Export Persona 

selected) lets you include spot colors in your output. You can also make the spot colors overprint in 

the same panel. 

In advance of using this feature, consult your print provider for advice on their use. 

To create a spot color:  

1. On the Swatches panel, select a Document palette from the palette pop-up menu. If no 

Document palette exists you can create one from the panel's Panel Preferences menu. 

2. From Panel Preferences, select Add Global Color. 

3. Adjust the settings in the dialog. 

4. Select the Spot option. 

5. Click Add. 
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Overprinting 

For professional printing, global colors can be made to overprint. By applying an overprint color to 

objects selectively you can control overprinting. 

About overprinting 

Overprinting means that you can print one ink color on top of another instead of, by default, the 

underlying color being 'knocked out' (removed). 

As a professional printing feature, overprint works when publishing PDFs using a CMYK color space 

and PDF/X compatibility. 

You don't need to explicitly make an overprint for black, for black text or black graphics, as this is set 

by default. On PDF publishing, you can control black overprinting using the Overprint black option in 

the Export Options panel (for any PDF export options). 

An overprint color swatch is indicated by a curved tab in the top-right corner of its color swatch. 

You can check if an overprint color has been assigned to an object's stroke or fill by using the Color 

panel. 

In advance of using this feature, consult your print provider for advice on its use. 

To create an overprint color from scratch:  

1. On the Swatches panel, select a Document palette from the palette pop-up menu. If no 

Document palette exists you can create one from the panel's Panel Preferences menu. 

2. From Panel Preferences, select Add Global Color. 

3. Adjust the settings in the dialog. 

4. Select the Overprint option. 

5. Click Add. 

To make an existing global color overprint:  

 On the Swatches panel, -click the global color swatch's thumbnail, then select Overprint. 
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About lines and shapes 

When you want to draw vector lines and shapes you'll need to use the Pen and Shape tools. Editing 

lines and shapes is done with the Node tool or the as you draw. 

 

An example of combined vector lines and shapes. 

Lines 

A line has distinct start and end points, called nodes, with one or more nodes placed along the line's 

length which delimit each line segment and the segment's shape. 

 

Segments between nodes can be straight (A) or curved (B). Multiple segments make up more 

complex curves (C). 

The type of node controls how the curve is shaped between segments. There are three basic types of 

node: 

 Sharp (A)—curve abruptly changes direction at the node creating a sharp non-symmetrical 

corner. 

 Bézier (B)—curve is smooth at the node (controllable by control handles; not shown). 

 Smart (C)—curve is symmetrical using a line of best fit at the node. 
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When drawing curves, any combination of nodes can be used to create the desired curve. 

For Smart and Bézier curves, each node has one or two control handles when drawn. For Bézier curves, 

the length and slope of the control handles determine the shape of the line segment; Smart curves 

automatically set the control handle position to form a best fitting curve through the node. 

 

Shapes 

A shape is a closed curve—it has no discernable start or end—made up of multiple curves. 

 

You can also easily create geometric type shapes using the Shape tools. These have special properties 

that enable you to quickly create otherwise difficult to draw shapes, such as circles, rectangles and 

polygons. 

Curves and closed shapes can be given stroke and fill properties. 
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Draw lines and shapes 

Vector curves (lines and shapes) are easily created using the Pen Tool. The tool has several modes that 

change the way the curve is drawn. 

To draw precise curves with the Pen Tool:  

1. Select the Pen Tool. 

2. On the context toolbar, click one of the modes: 

o Pen Mode—click-drag on the page to create repeated nodes; repositioning the 

displayed off-curve control handles at each node defines the shape of the next 

segment as you lay down nodes. 

o Smart Mode—click repeatedly on the page to lay down each node; a best fitting 

curve is created without need for control handle adjustment. 

o Polygon Mode—click repeatedly on the page to lay down each node; a line is 

created with sharp nodes made up of straight segments. 

o Line Mode—click and drag on the page to create a simple single-segment 

straight line. 

3. To complete the curve without closing it, press the . To close the curve, click on the starting 

node. 

To continue an existing curve:  

1. Place the pen pointer over the final node on the curve that you want to continue. 

2. Click once to select the node. 

3. Continue to place new nodes as needed. 

To close curves to create a custom shape, Do one of the following: 

 With the line selected with the Pen or Node Tool, click Close Curve on the context toolbar. 

 For the Pen tool only, click on the starting node to join the curves and create the shape. 

Modifier keys 

The following modifier can be used to speed up the workflow: 

 The temporarily activates the Node tool. 

 The constrains control handles to 45 degree intervals in Pen mode. 

 The forces the node into cusp mode. 
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Edit vector lines and shapes 

Vector lines and shapes are easily edited using either: 

 The as you draw your line or shape. 

 The Node Tool. 

 

Use the former for fine tuning and line adjustment as you draw, the latter for more prolonged editing 

operations. 

To edit lines as you draw:  

 Press the to move nodes and adjust control handles when fine tuning of your line is needed. 

Color and opacity can also be altered from the Color panel. 

With pressed, you can edit other lines in the same way by clicking them. 

To change curvature of a segment:  

Do one of the following: 

 Select the node and then drag the control handles. 

 

 Drag on the segment directly to pull it into position. 

 

  



Modifier keys 

When using the Node Tool, the following modifier keys can be used to speed up the workflow: 

 The constrains the control handle to 45 degree intervals. In Smart mode, node positioning is 

constrained vertically or horizontally instead. 

 The changes the node type to a sharp node to create a cusp. 

The Node Tool can be used in conjunction with the Transform panel to position or scale selected 

nodes precisely. 

To add nodes:  

 With the path selected, click at the point where you want the node to be added. 

To delete nodes:  

 Select the node and press the . 

The curve will automatically reshape because of the deleted node, but you can retain the curve's 

original geometry by pressing + instead. 

To close curves:  

Do one of the following: 

 Select the path and click Close Curve on the context toolbar. 

 Drag the end node and drop on top of start node when the pointer changes. 

To break (split) curves:  

 Select the node at the point at which you want the curve to break and click Break Curve on 

the context toolbar. 

To join curves:  

1. With the Node Tool (hold down the if using the Pen Tool), hold down with the and select both 

curves. 

2. Click Join Curves on the context toolbar. 

To reverse curves:  

 Click Reverse Curve on the context toolbar. The start node becomes active, ready for further 

drawing from the opposite end of the curve. 

To convert nodes to a different type, Do one of the following: 

 Select the node(s) you want to change and click one of the node types, Sharp, Smart or 

Smooth, on the context toolbar. 

 Hold the and click on the node to convert it to a Sharp node. 



About geometric shapes 

Most geometric shapes, such as squares, circles and polygons, are difficult to draw accurately 

freehand. We've provided a selection of useful shapes to help you solve this problem. The shapes are 

fully geometrically correct, customizable, and can even be converted to curves for additional editing. 

 

Once created, the shapes are easy to modify by changing the properties on the context toolbar or by 

dragging the special red handles. When hovered over, the direction in which they can be dragged is 

indicated by the pointer and/or a horizontal line. 

Available shapes:  

 Rectangle Tool 

 Ellipse Tool 

 Rounded Rectangle Tool 

 Triangle Tool 

 Diamond Tool 

 Trapezoid Tool 

 Polygon Tool 

 Star Tool 

 Double Star Tool 

 Square Star Tool 

 Arrow Tool 

 Donut Tool 

 Pie Tool 

 Segment Tool 

 Crescent Tool 

 Cog Tool 

 Cloud Tool 
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 Callout Rounded Rectangle Tool 

 Callout Ellipse Tool 

 Tear Tool 

 Heart Tool 
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Draw and edit shapes 

Geometric and other special shapes that would be otherwise hard to draw can be easily created using 

one of the corresponding shape tools. Once drawn, both the shape and its stroke can be made into 

curves for more freeform design. 

 

To draw a new shape:  

1. Choose one of the shape tools, e.g., Rounded Rectangle Tool from the Tools panel. 

2. Drag on the page to create the shape and use the modifier to constrain the shape's 

proportions if needed. 

 

3. Modify options as required, either by changing the values on the context toolbar or by 

dragging the red handle(s) (if available). 

 

When you hover over a handle, a red guide line will appear to suggest the direction of drag needed to 

modify your shape. 

To edit an existing shape:  

1. Click the Node Tool. 

2. Select the shape, either by clicking the shape or by clicking the layer entry in the Layers panel. 

3. Edit the shape as required by either by directly dragging the red handle(s), or by changing the 

values on the context toolbar. 

Shapes have special snapping properties which allow lines to snap to various angles within the shape. 



To convert a shape to curves:  

 Click Convert to Curves, found in either the Layer menu or on the context toolbar. 

 

The shape is now made from curves. Segments and nodes can be modified with the Node Tool. 

Modifier keys 

As you create shapes, the following modifier keys can be used while the shape is being drawn: 

 The constrains shape's proportions at the time of creation. 

 The draws or resizes from center (can be combined with the ). 

 Where appropriate, on many shapes, the moves the red handles in pairs. 

 The lets you rotate a shape about its opposite handle. 

 Pressing the right mouse button lets you rotate a shape about its opposite handle. 

 

  



Joining vector shapes 

Vector shapes can be joined together to create composite shape variations which can be fully edited 

as curves. 

Joining operations 

There are various Boolean operations available: 

Add—creates a new curve layer from the sum of the selected shape layers. 

 

Before and after operation. 

Subtract—removes overlapped areas of the lowest shape layer. All other selected shape layers are 

discarded. 

 

Before and after operation. 

Intersect—creates a new curve layer from the overlapping areas of selected shape layers. 

 

Before and after operation. 

Divide—splits shape layer areas into separate curve layers; the curve layer from the intersecting area 

retains the color of the upper shape layer. 

 

Before and after operation. 

Combine—merges selected shape layers into a curve layer with transparent area where filled regions 

overlap. 



 

Before and after operation. 

New curve layers adopt the properties of the lowest shape layer in the selection. 

To implement join operations:  

1. Select multiple shape layers. 

2. Press the and click, then from the Geometry sub-menu, select an operations command. 

3. Press the right mouse button, then from the Geometry sub-menu, select an operations 

command. 

  



Converting to curves 

You can create new shapes by converting geometric shapes (created using the Shape tools) into 

curves and then adjusting the nodes of the resulting shape. 

 

The rounded rectangle shape is converted to curves to allow the horizontal edges to be 

modified. 

The Convert to Curves operation is not limited to geometric shapes. You can also convert text to 

curves too. 

 

Text converted to curves and then nodes removed to modify bowl, counter, and aperture of 

the letters. 

Once a shape or text has been converted to curves, it can no longer be edited in its conventional way. 

For example, you would not be able to change the font of text once it has been converted to curves. 

To convert a shape to curves:  

1. Select the shape with either the Move or the Node Tool. 

2. Do one of the following: 

o Click Convert to Curves on the context toolbar. 

o From the Layer menu, select Convert to Curves. 

The shape is now made from curves. Segments and nodes can be modified by double-clicking with 

the Node Tool. 

  



Styles 

Instead of having to create layer effects from scratch, the Styles panel can be used to apply a pre-

designed style to your layer content. If you want to save combinations of layer effects for future use, 

these can be stored in the panel as a custom style. 

For vector shapes and text, the fill, color and transparent properties of the shape/text can be saved as 

a style along with any applied layer effects. You can reuse the style on vector shapes later. 

If you plan to save some styles, create a custom category in the panel first. 

To apply a style:  

1. Select a layer from the Layers panel. 

2. From the Styles panel, select a category from the pop-up menu. 

3. Click a style thumbnail. 

To create a custom category:  

 Click Panel Preferences and choose Add Styles Category from the menu. 

To rename a styles category:  

1. Choose the category you want to rename from the category pop-up menu. 

2. Click Panel Preferences and choose Rename Category from the menu. 

3. Type a new name for the category in the dialog and click OK. 

To save a style:  

1. On the Styles panel, select a category to save the style into. 

2. Do one of the following: 

o Select the object whose style you want to save, click Panel Preferences on the Styles 

panel, then choose Add Style from Selection from the menu. 

o -click the object and select Create Style. 

  



Paste Style and Layer Effects 

The Paste Style and Paste FX features allow you to copy layer styles (i.e, fills and strokes or 

combinations of layer effects) from one layer and apply them directly to another layer. 

To copy and paste layer attributes and effects:  

1. Select the layer with the style to be copied. 

2. From the Edit menu, select Copy.* 

3. Select the layer which will receive the copied style. 

4. Do any of the following: 

o From the Edit menu, select Paste Style. 

o From the Edit menu, select Paste FX. 

*Alternatively, you can cut (rather than copy) the layer. From the Edit menu, select Cut. 

 

  



Working with text 

There are two varieties of text, Artistic and Frame, to give you flexibility when working with 

typography. 

Text objects contain both character and paragraph elements, making it easy to modify standard text 

attributes such as font, size, format, and alignment. Both text tools have quick access settings on the 

context toolbar and supporting panels and dialogs for more extensive, advanced options. 

When snapping is switched on, the baseline of the first line in a text object will snap to the baseline of 

the first line in other text objects. 

When performing text editing, Photo supports all standard text selection and formatting techniques 

and shortcuts. 

Affinity Photo lets you temporarily hide text while you're concentrating your design work on other 

areas of your page. 

The unique features of artistic text and frame text are discussed in the Artistic text and Frame text 

topics. 

If you're opening projects created on another computer, the original fonts used may be missing from 

your computer. If so, you'll get a Missing Fonts dialog indicating the fonts which are missing. The font 

will be substituted for a replacement system font. 

When text using the missing font is selected in your project, its font name will be prefixed with a '?' on 

the context toolbar, and will show in red text in the Font pop-up menu. 

By default, the size of text is expressed in points, regardless of the units set within your document. If 

you wish text size to reflect document units, this can set in Preferences. 

To select text objects for formatting:  

 With the Move Tool selected, do one of the following: 

o Click a text object to make formatting changes to all the text within the text object. 

o Double-click a text object to make formatting changes to sections of text within the 

text object. 

 With either of the text tools selected, click a text object to make formatting changes to 

sections of text within the text object. 

To hide/show all text:  

 From the Text menu, select Hide All Text. To display again, select Show All Text. 
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Artistic Text 

Artistic text, as the name suggestions, is best suited to decorative or artistic typographical design. 

Artistic text can be modified in many of the same ways as drawn objects, while still retaining standard 

text attributes. This makes it ideal for single words, headlines, pull quotes, etc,. 

When artistic text is resized, the text stretches or contracts to fit its new dimensions. It's relative font 

size automatically updates on the context toolbar. 

Although paragraph attributes can be set for artistic text, it is more likely modifications will be to 

character attributes and on-page positioning using design aids and a creative eye. 

Artistic text can be converted to curves for advanced typographical design. Once artistic text is 

converted to curves, you will not be able to use standard text attributes to modify it. 

To create artistic text:  

With the Artistic Text Tool selected: 

1. Drag on the page to set the size of the text. 

2. Do one of the following: 

o Type your text 

o Paste previously copied text. 

o From the Text menu, select Insert Text from File. In the pop-up dialog, navigate to 

and select a file, and click Open. 

For text imported from external applications, use Paste without Format (Edit menu) for 'clean' 

unformatted text. 

To resize artistic text:  

With the artistic text selected, do one of the following: 

 To resize height and width simultaneously (constraining the aspect ratio), drag the object's 

corner handles. 

 To resize height and width independently (unconstrained), drag the object's central, side 

handles. 

Modifier keys 

When using the Artistic Text Tool, the following modifier keys can be used: 

 The reverses the resize conventions (as described above). 

 The resizes the text from the center. 



 The allows placed text to be rotated about its opposite handle. 

 Pressing the right mouse button lets you rotate placed text about its opposite handle. 

Text Tools and the  

The uses the following logic when a Text Tool is active: 

1. If the is used when glyphs (characters) are selected, the glyphs are deselected but the caret 

(cursor) remains inside the text object. (You can then continue editing the text within the text 

object.) 

2. If the caret is inside the text object and no glyphs are selected, the will remove the caret and 

select the text object. (You can then press V to switch to the Move Tool to reposition the text 

object.) 

3. With the text object selected, pressing the will deselect the text object. 

  



Frame text 

Frame text is perfect for presenting paragraphs with a formalized structure and layout. If you want to 

present text in columns, frame text is the ideal solution. 

By clicking in the drawn frame then typing, you're able to fill the frame with frame text. If excess text 

overflows the bottom of the frame, you can either reduce the text's font size from the context toolbar 

or make the text frame larger; both methods will make the text fit the frame. 

To create frame text:  

With the Frame Text Tool selected: 

1. Drag on the page. This sets the initial size of the text frame. 

2. Do one of the following: 

o Type your text. 

o Paste (V) previously copied text. 

o From the Text menu, select Insert Text from File. In the pop-up dialog, navigate to 

and select a file, and click Open. 

For text imported from external applications, use Paste without Format (Edit menu) for 'clean' 

unformatted text. 

Modifier keys 

When using the Frame Text Tool, the following modifier keys can be used: 

 The constrains frame's proportions at the time of creation (to a square) or when resizing. 

 The resizes the frame from its center. 

 The allows placed frame text to be rotated about its opposite handle. 

 Pressing the right mouse button lets you rotate placed frame text about its opposite handle. 

Text Tools and the  

The uses the following logic when a Text Tool is active: 

1. If the is used when glyphs (characters) are selected, the glyphs are deselected but the caret 

(cursor) remains inside the text object. (You can then continue editing the text within the text 

object.) 



2. If the caret is inside the text object and no glyphs are selected, the will remove the caret and 

select the text object. (You can then press V to switch to the Move Tool to reposition the text 

object.) 

3. With the text object selected, pressing the will deselect the text object. 

Resizing text frames 

When resizing a frame you can control whether: 

 Text remains at its set size and reflows through the frame. 

 Text scales as the frame is resized. 

To reflow text with frame resize:  

With the text frame selected, do one of the following: 

 To resize height and width simultaneously, drag the object's corner handles. 

 To resize height and width independently, drag the object's side handles. 

 

To scale text with frame resize:  

 With the text frame selected, drag the object's scale handle (extends from the bottom-right 

corner of the selection). 

 

  



Character formatting 

Character formatting describes text attributes which are applied at a character level. 

Character formatting includes attributes such as font and size and may be applied to a single letter or 

single word as well as full paragraphs or stories. This type of formatting is useful for both art and 

frame text. 

With your text (or text object) selected, character formatting settings are available from the context 

toolbar, the Text menu, and the Character panel. 

Incremental changes 

Rather than setting a finite value for certain text attributes, the Text menu offers the following 

incremental changes: 

 Size 

o Bigger/Precise Bigger—increases the size of the text by ten increments/one 

increment. 

o Smaller/Precise Smaller—decreases the size of the text by ten increments/one 

increment. 

 Spacing 

o Use Default—sets the character tracking to the font's default setting. 

o Use None—sets the character tracking to zero. 

o Tighten/Tighten More—condenses character tracking by one increment/five 

increments. 

o Loosen/Loosen More—expands character tracking by one increment/five 

increments. 

To access the Character panel:  

Do one of the following: 

 With text selected, on the context toolbar, click Character. 

 From the Text menu, select Show Character. 

 From the View menu, select Studio>Character. 

  



Paragraph formatting 

Paragraph formatting describes text attributes which are applied at a paragraph level. 

Paragraph formatting includes attributes such as alignment, leading, and indents which can only be 

applied to full paragraphs or stories. 

This type of formatting can be applied to artistic text, but is more appropriate for frame text. 

With your text (or text object) selected, paragraph formatting settings are available from the context 

toolbar, the Text menu, and the Paragraph panel. 

To access the Paragraph panel:  

Do one of the following: 

 With text selected, on the context toolbar, click Paragraph. 

 From the Text menu, select Show Paragraph. 

 From the View menu, select Studio>Paragraph. 

To add tab stops:  

On the Paragraph panel, in the Tab Stops section: 

1. Set the tab stop space using the input box. 

2. Click Add New Tab Stop. 

A new tab stop is added to the paragraph and is listed on the left within the Tab Stops section. If you 

repeat the above procedure to add multiple tab stops, the tab stop space is calculated from the 

position of the previously added tab stop. 

To modify and delete tab stops:  

On the Paragraph panel, in the Tab Stops section, do one of the following: 

 Double-click a listed tab stop and type in a new value to adjust the tab stop position. 

 Select a listed tab stop and set the Alignment and/or Leader. 

 Select a listed tab stop and click Delete Selected Tab Stop to remove a tab stop. 

  



OpenType font features 

Affinity Photo provides support for OpenType font features. These extend the font's character set 

which lets you present text with a greater degree of typographical control. 

 

Text example of an OpenType stylistic set using the font Gabriola. 

Font features supported include ligatures, alternates, swash variants, stylistic sets, and figure positions. 

You'll also get ligature control via the Ligatures sub-menu. 

To apply OpenType font features:  

1. Assign a font to your text that supports OpenType font features. 

2. From the Text menu, select Show Typography. 

3. Adjust the settings in the dialog. 

The available font features differ between fonts. This is dependent on how the font was designed by 

the font designer. 

As OpenType fonts are cross-platform, you can make use of OpenType fonts from both Mac and 

Windows operating systems. 

 

  



Special characters 

Special characters can be added to your text objects to increase your design options. 

Typographical and special characters are available for insertion into a text object from the Text and 

Edit menus. These characters include line breaks, non-breaking spaces, and copyright and trademark 

symbols, as well as icons, emoticons, and other embellishments. 

The following characters can be added from the Text menu's Insert Character flyout: 

 Line Break 

 Em Dash 

 En Dash 

 Figure Dash 

 Em Space 

 En Space 

 Zero Width Space 

 Non-Breaking Space 

 Non-Breaking Hyphen 

 Soft Hyphen 

To add special characters:  

With an insertion point in the text object: 

1. From the Edit menu, select Emoji & Symbols. 

2. Select a category by clicking the icons at the bottom of the pop-up dialog. 

3. Click a displayed symbol to add it to the text object at the insertion point. 

  



Spelling 

The built-in spell checker ensures the text in your design is perfect before being published. 

There are several ways to interact with the spell checker, including using the Spelling dialog or 

searching for and handling spelling errors directly on the page. 

Spelling errors are indicated by red underlining. 

Settings 

The following options are available from the Spelling dialog (spell checker): 

 Current word—select and type to manually input a suggested correction. 

 Suggestions list—select a word from the list of suggestions to replace the current word. 

 Change—substitutes the misspelt word with the current word. 

 Find Next—displays the next misspelt word. 

 Ignore—ignores the mis-spelling of the current word. 

 Learn—adds the current word to the dictionary. 

 Define—looks up the current word in the launched macOS dictionary application. 

 Guess—shows a list of possible alternatives for the current word. 

 Check Spelling In—sets the scope of the spell check. Select from the pop-up menu. 

To check spelling:  

From the Text menu, from the Spelling sub-menu, select one or more of the following: 

 Spelling Options—runs the spell checker. 

 Check Spelling—displays and selects the next misspelt word. 

 Check Spelling While Typing—highlights spelling errors as you type. 

To correct a misspelt word on the page:  

 With one of the text tools selected, -click the misspelt word and select an alternative from the 

pop-up menu. 

To ignore a misspelt word on the page:  

1. Select the misspelt word. 

2. From the Text menu, from the Spelling sub-menu, select Ignore Misspelt Word. 

  



Using text styles 

Text styles can be applied to text within your designs for efficiency and consistency. 

About text styles 

A text style is a set of one or more attributes which can be applied to text in bulk. Later, if you chose 

to modify a text style, any text which uses that style will update to conform to the changes you've 

made. 

Every new document comes with a default set of text styles but the Text Styles panel provides you 

with the ability to create and manage a document's text styles as well as remove them. 

Text styles are assigned to one of three types (paragraph, character and group), but are flexible in how 

they can be used. For more information, see Text style types. 

Applying text styles 

Text styles can be applied to text using the Text Styles, Paragraph or Character panels, the context 

toolbar or a custom keyboard shortcut. 

Furthermore, if you have established a strict order for your text styles, using Next Style, you can apply 

an entire set of text styles to a story (or portion of a story) in one go. 

If local formatting has been applied, this can be quickly removed using the Text Styles panel, leaving 

the currently applied text styles in place. 

To apply a text style to a paragraph:  

1. With the Artistic Text Tool or Frame Text Tool selected, click inside a paragraph or drag to 

select multiple paragraphs. 

2. Do one of the following: 

o On the context toolbar, select a text style from the Paragraph Style pop-up menu. 

o On the Paragraph panel, select a text style from the Paragraph Style pop-up menu. 

o On the Text Style panel, select a paragraph text style. 

o Use a custom keyboard shortcut. 

To apply a text style to a sentence, word or character:  

1. With the Artistic Text Tool or Frame Text Tool selected, select a portion of text. 

2. Do one of the following: 

o On the context toolbar, select a text style from the Character Style pop-up menu. 

o On the Character panel, select a text style from the Character Style pop-up menu. 
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o On the Text Style panel, select a character text style. 

o Use a custom keyboard shortcut. 

To apply ordered text styles to a story:  

1. With the Artistic Text Tool or Frame Text Tool selected, select multiple paragraphs. 

2. On the Text Styles panel, click on a listed style's options menu and select Apply ... Then 

Next Styles. 

To remove local formatting:  

1. With the Artistic Text Tool or Frame Text Tool selected, select a portion of text. 

2. On the Text Style panel, select Reset Formatting. 

  



Creating and managing text styles 

Text styles can be created in the Text Styles panel, ready for applying to text. They can also be 

managed and modified to improve your design and workflow. 

There are several ways to create a new text style: 

1. build it from scratch—the new text style will have no initial connection to any other text style. 

2. duplicate it from another style—the new text style will initially be exactly the same as the 

selected text style but has no connection to that style. 

3. base it on an existing style—the new text style will use the selected text style as its base. A 

connection between the styles is retained and a hierarchy is established. 

A text style can be modified in two ways: 

 Editing the text style directly. 

 Updating the text style to match some selected, locally formatted text. 

You can also set up your own keyboard shortcuts to apply individual text styles to text. 

To create a text style from scratch:  

1. (Optional) Select a portion of text or click inside a paragraph. 

2. On the Text Styles panel, select: 

o Create Paragraph Style—to create a new paragraph style. 

o Create Character Style—to create a new character style. 

o Create Group Style—to create a new group style. 

See Text style types for more information. 

3. Adjust the settings in the dialog. 

4. (Optional) In the Edit Text Style dialog, select the Apply style to selection option to apply 

the style to the text selected in step 1. 

5. Click OK. 

To create a text style from an existing style:  

1. On the Text Styles panel, click on a listed style's options menu and select: 

o Duplicate—to start with settings exactly the same as the selected style. 

o Create Style Based on—to automatically set the dialog's Based on option to the 

selected style. 

2. Adjust the settings in the dialog. 
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3. Click OK. 

To edit an existing text style:  

1. On the Text Styles panel, click on a listed style's options menu and select Edit. 

2. Adjust the settings in the dialog. 

3. Click OK. 

To update a text style:  

1. Select a portion of text or click inside a paragraph and make any local changes via the context 

toolbar, Character panel or Paragraph panel. 

2. On the Text Styles panel, select: 

o Update Paragraph Style—to update the paragraph style applied to the current text 

to match the local formatting. 

o Update Character Style—to update the character style applied to the current text to 

match the local formatting. 

To assign a keyboard shortcut to a text style:  

1. On the Text Styles panel, click on a listed style's options menu and select Edit. 

2. In the dialog, select the Style section and then click inside the Keyboard shortcut box. 

3. Press your required key combination. 

4. Click OK. 

If a warning icon appears in the box, the shortcut is already assigned to another action or text style. 

Hover over the icon to see what that action or text style is. 

To remove a keyboard shortcut from a text style, click the cross icon inside the Keyboard shortcut 

box. 

Options 

The following options are available in the Style section of the Edit Text Style dialog: 

 Based on—sets the default settings for this style. In a hierarchical sense, the Base on text style 

is the master style to this subordinate style. 

 Next style—for paragraph styles, this determines the text style automatically applied to the 

following paragraph (see note). 

 Keyboard shortcut—sets the keyboard shortcut which will apply this text style. 

 Type—determines the predominant nature of the text style. 



 Show in both panels—if this option is off (default), the text style can only be applied in its 

predominant way (determined by the Type set above). When selected, a paragraph style can 

be applied as a character style and vice versa. 

 Reset Formatting—removes all the settings applied in the Character, Typography and 

Paragraph sections of this dialog. The settings in this Style section remain unchanged. 

The Next style feature is only activated when you press the when typing text or when using the 

Apply ... Then Next Styles option in the Text Styles panel. 

Additional Edit Text Style dialog options:  

 Style name—defines the name the text style will use throughout the app. 

 Character—assigns character-level attributes to the text style or overwrites those determined 

by the Based on style. See Character panel for details. 

 Typography—activates OpenType features for the text style or overwrites those determined 

by the Based on style. See OpenType font features for details. 

 Paragraph—assigns paragraph-level attributes to the text style or overwrites those 

determined by the Based on style. See Paragraph panel for details. 

 Style settings—lists all the attributes applied to the current text style. 

 Apply style to selection—applies the current text style to any selected text (if text was 

selected prior to entering the dialog). 

Where [no change] is shown, an attribute remains unchanged from the Based on style. 
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Removing text styles 

Text styles can be detached from selected text or detached throughout a document. A text style can 

also be removed entirely from your document. 

There are a few things to consider when detaching and deleting text styles. Do you want to: 

 Remove the text style from being applied to text or delete it entirely from the document. 

 Return styled text to the default settings or leave it as it is currently formatted. 

 Affect specific instances of text or all text within the document. 

 Do a combination of the above. 

Each detachment or deletion method will have a different impact on the text and text styles in your 

document. Chose the method below based on the outcome you desire. 

To detach a text style from styled text and return text to default settings:  

1. Select a portion of text or click inside a paragraph. 

2. Do one of the following: 

o On the context toolbar, select [No Style] from a text style pop-up menu. 

o On the Paragraph or Character panel, select [No Style] from a text style pop-up 

menu. 

o On the Text Styles panel, select the paragraph or character [No Style]. 

To affect all the text in your document, first select all the text objects in your document and then 

follow the procedure above. 

To detach a text style from styled text but leave text unaffected:  

1. Select a portion of text or click inside a paragraph. 

2. On the Text Styles panel, click a text style's option menu and select Detach Paragraphs 

From or Detach Characters From. 

To remove a text style from a document and return all styled text in the document to 

the default settings:  

Do one of the following: 

 Select a portion of text or click inside a paragraph and then, on the Text Styles panel, click 

Delete Style. 

 On the Text Styles panel, click a text style's option menu and select Delete. 

To remove all connected text styles from a document and return all styled text in the 

document to the default settings:  



 On the Text Styles panel, click a group or master text style's option menu and select Delete 

Group. 

To remove all text styles from a document but leave text unaffected:  

 From panel preferences on the Text Styles panel, select Detach and Delete All Styles. 

  



Text style types 

There are three types of text style in Affinity Photo which are used for differing purposes. 

About text style types 

There are no restrictions on what text attributes and properties can be applied to a text style, 

regardless of its type. Instead, the type determines the predominant purpose of that text style. 

There are three types of text style: 

 Paragraph—used to define the properties of paragraphs. 

 Character—used to define the properties of individual glyphs (or words, lines and sentences 

inside a paragraph). 

 Group—used to define the properties for a group of text styles. 

Paragraph and Character text styles 

Although text styles are assigned a type, Affinity Photo gives you the option of applying paragraph 

and character text styles flexibly. For example, you can set paragraph styles to selected glyphs as if 

they are character styles, without affecting the style applied to the paragraph. To activate this feature, 

you must set the text style to Show in both panels. 

If a keyboard shortcut is attached to a text style, that shortcut will apply the style using its 

predominant nature. For example, if you select a portion of text and use a shortcut to apply a 

paragraph text style, the selected text's paragraph will be modified, not just the selected text. 

Group text styles 

A Group text style cannot be applied directly to text on the page. Instead it defines the foundations 

on which other text styles are built and allows you to quickly create a text style hierarchy. Group text 

styles only display in the Text Styles panel. 

The Group style can be considered as the group's parent or master text style. All other styles which 

are based on a Group style are considered to be child or subordinate styles. 

You can create subordinate text styles within a group by selecting the Group text style as the Based 

on style. 

The complexity of your hierarchy is entirely in your hands—subordinate styles can also be master 

styles with their own subordinates and group styles can be introduced as subordinates to a master 

group style. 

To edit a text style's type:  
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1. On the Text Styles panel, click on a listed style's options menu and select Edit. 

2. In the dialog's Style section, select an option from the Type list. 

3. Click OK. 

To allow flexible use of a text style:  

1. On the Text Styles panel, click on a listed style's options menu and select Edit. 

2. In the dialog's Style section, select the Show in both panels option. 

3. Click OK. 

To create a text style hierarchy:  

1. On the Text Styles panel, select Create Group Style. 

2. Adjust the settings in the dialog. 

3. Click OK. 

4. On the Text Styles panel, click on the newly created group style's options menu and select 

Create Style Based on. 

5. Adjust the settings in the dialog. 

6. Click OK. 

  



Export 

The Export dialog provides a streamlined approach to exporting your document or current selection 

to a common file format. You can make use of pre-supplied or your own saved presets, as well as 

access more advanced settings. 

For a more comprehensive set of export options, use Export Persona. 

General settings 

The following general settings can be adjusted from the Export dialog: 

 Format—select the format for your exported file. 

Export formats include PNG, JPEG, GIF, TIFF, PSD, PDF, SVG and EPS. 

 Preset—sets predefined export options for the selected file format. Select from the pop-up 

menu. 

As well as the default application presets, this pop-up menu will give you the option of 

selecting a custom preset. 

 More—accesses advanced settings for the chosen file format. For more information on these 

settings, see the Export Options panel topic. 

 Area—instead of exporting the whole page, you can export the currently selected layer 

content, with or without its background using the 'Selection with background' or 'Selection 

without background' options. 

To export drawn slices or specific layers, use Export Persona. 

 Don't export layers hidden by Export Persona—when selected, layers which have been 

hidden while in Export Persona are excluded from the exported file even if they display on the 

page. If this option is off, all objects on the page (which are within the Area selected above) 

will be exported regardless of whether they are hidden in Export Persona. 

Additional settings 

For PNG, JPEG, GIF and TIFF file formats: 

 Size—by default, displays the native dimensions of your image. Type value(s) to set an 

alternative width and/or height for your exported image. 

 Lock aspect ratio—when selected (default), the image's native aspect ratio is honored. If 

this option is off, exported image width and height can be set independently. 
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For PNG, JPEG, GIF, TIFF and PSD file formats: 

 Resample—select which resampling method (see note below) to use if the image is to be 

upsampled or downsampled on export. 

For JPEG file formats: 

 Quality—sets the resulting quality of the exported image. Higher quality may result in 

significantly larger file sizes. 

For SVG file formats: 

 Export text as curves for font independence— when selected, the text in the resulting file 

will be drawn as curves (therefore displaying precisely as intended, even if viewed on a device 

without the used fonts installed). If this option is off (default), text will be exported as text and 

the viewing device will need the used fonts installed for it to be viewed correctly. 

For PDF, SVG and EPS file formats: 

 Raster DPI—this option lets you choose the resolution for rasterization for effects which will 

be rasterized on export. 

For EPS file formats: 

 Postscript level—sets the version of the exported postscript file. Select from the pop-up 

menu. 

For TIFF file formats: 

 Save Affinity Layers—Layers in the document are preserved in the exported TIFF image. 

Resampling methods 

The following resample settings are available: 

 Nearest Neighbor—simple resampling which has the fastest processing time. Use for hard-

edge images. 

 Bilinear—algorithmic resampling for use when shrinking images. 

 Bicubic—algorithmic resampling for use when enlarging images. Resampling is smoother 

than Bilinear but has a slower processing time. 



 Lanczos 3—complex algorithmic resampling which gives the best results but with the longest 

processing time. Available as 'separable' and 'non-separable'; the latter gives marginally better 

results, but is slightly slower than 'separable'. 

Depending on the image format, the export dialog will offer an Estimated File Size for the exported 

image. 

To export a design as an image:  

1. From the File menu, select Export. 

2. Adjust the settings in the dialog. 

3. Click Export. 

To create a custom preset from advanced settings:  

1. From the File menu, select Export. 

2. In the dialog, select More. 

3. Adjust the settings in the dialog. 

4. Click Manage Presets and select Create preset. 

5. Type in the name of the custom preset and click OK. 

For more information on the settings available in the More dialog, see the Export Options panel topic. 
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Print 

You can print the project's page to create a physical or PDF copy for distribution. 

The final print of the page will include all currently visible objects. This might vary depending on the 

active Persona. For instance, objects which are visible in other Personas will not display in Export 

Persona if they are set to 'not export'. Layer visibility and exportability is controlled by the Layers 

panel. 

Settings 

Affinity Photo supports all the standard printing options available for the OS along with the following 

settings (available via the Show Details of the dialog): 

 Actual Size—the project's current image and canvas size is honored. 

 Scale to Fit—the image is temporarily scaled to fill the selected page size with no cropping 

taking place. 

 Scale—the image is printed at the temporary scale set in the adjacent input box. 

If you intend on printing to Actual Size, we recommend checking your image and canvas size before 

proceeding to print. 

To print project pages:  

1. From the File menu, select Print. 

2. In the dialog, adjust settings as appropriate. 

3. Click Print. 
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Exporting using Export Persona 

The Export Persona is a dedicated workspace for exporting layers, groups, and objects as export slices 

to different file formats and image sizes simultaneously. You'll also be able to export custom drawn 

slices. 

How it works 

The Export Persona uses a combination of panels and tools to create slices. Slices are export areas 

which you choose to output from your document. 

The Layers panel, Export Options panel and Slices panel are used in combination in Export Persona. A 

Slice Tool is a unique tool in Export Persona which is used to create custom slices. 

Using the Layers panel 

The Layers panel is different from the Layers panel in Draw Persona. It is used exclusively as a 

precursor for selecting layers, groups, or objects from which slices can be created, and added to the 

Slices panel. 

When you export a Layers panel item as a slice, the slice will automatically size to what is considered 

to be the extent of the selected item. A circle symbol at the top right of the slice indicates that it is 

auto-sized. If you choose to resize the slice, the symbol changes to a square, indicating that the slice 

has been modified. A resized slice created from a Layers panel item can be reset to 'auto-sized' at any 

point. 

Using the Export Options panel 

The Export Options panel lets you set up your default export settings, or settings for the currently 

selected item prior to slice creation. 

Using the Slices panel 

The Slices panel stores all your slices (from the Layers panel or Slice Tool) ready for export directly 

from the panel. Each created slice has an initial export format (e.g., PNG, JPG, or SVG) associated with 

it on creation, with additional export formats being added per slice if needed; each export format lets 

you export at different size scaling or absolute sizes. 

You can use the filenames in the Slices panel to specify (or create) a folder hierarchy in which to place 

your exported files. This is achieved through the use of the forward slash, or oblique, character. 

For example, a PNG hero image could be placed within an img folder within an assets folder using the 

following syntax: assets/img/hero 



If any part of the folder structure does not exist, the folder hierarchy will be created when the 

appropriate slices are exported using Export Slices (n). 

You can export the entire document's page using File>Export or by selecting the predefined spread 

area on the Slices panel. 

Using the Slice Tool 

The Slice Tool gives you full freedom to create export areas of all sizes, over any part of your 

document. 

The Force Pixel Alignment option on the Toolbar, when selected, will ensure your slices snap to 

full pixels when created, moved or modified. 

To set default export options:  

1. On the Export Options panel, select the Defaults tab. 

2. Adjust settings as appropriate. 

3. Jump back to the Selection tab when finished. 

The settings will be used when your next slice is created. 

To export an area of the document as an image:  

1. Do one of the following: 

o On the Layers panel, select a layer, group or object and click Create Slice. 

o With the Slice Tool selected, drag on your page to define your export area. 

2. Do one of the following: 

o On the Export Options panel, adjust export settings as appropriate. 

o Jump to the Slices panel, expand the slice entry and alter the export format or choose 

an Export preset from the pop-up menu (PNG, JPEG, and Apple icon design presets 

only). 

3. (Optional) On the Slices panel, click the + icon under the export format entry to add an 

additional graphic export format. 

4. (Optional) On the Slices panel, click the indented + icon under the export size entries to add 

increasing levels of resolution (2x, 3x, etc.) to the export format. 

5. Do one of the following, to control what gets exported: 

o Select Click to export all formats for this item. 
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o Select Click to export this size. This exports a specific export format for a slice at a 

specific size. 

o Click Export Slices (n) to export all formats and sizes for all checked slices in the 

Slices panel. 

6. Navigate to and select the storage folder for the exported image(s) and then click Export. 

7. (Optional) On the Slices panel, select Continuous if you want to automatically re-export 

export areas if the document is subsequently changed. This option is only available if Export 

Slices (n) was selected above. 

Modifier keys 

When using the Slice Tool, the following modifier keys can be used: 

 The constrains the area's proportions to a square. 

 The if pressed as you drag out a slice area, draws from the center of the original drag position 

(can be combined with the ). 

To reset the dimensions of an manually resized export area created from a layer:  

1. With the Slice Tool, select a resized export area. 

2. On the context toolbar, select Revert to auto sized. 

  



Export Options panel 

Set the export options for a predefined export area using the Export Options panel. 

About the Export Options panel 

Once an export area has been defined, the Export Options panel allows you to set specific export 

attributes for that area. Using the panel, different export areas on the page can have different settings 

applied. This gives you full control over your exported images. 

You can save custom settings as a preset for future use. 

General settings 

The following settings are available in the panel: 

 Mode—with Selection enabled, the export options can be modified for the selected export 

area to be different from the default export option settings; Defaults, when enabled, sets the 

default export options for new slices. 

 Preset—sets predefined export options for a range of common file formats, color modes, and 

bit depths. Select from the pop-up menu. 

 File format—sets the graphics format for the exported image. Select from the pop-up menu. 

 Resampler—select which resampling method (see note below) to use for the export. 

 Embed metadata—when selected, any raster image's original metadata is preserved in the 

exported file. If this option is off, all original metadata is removed. 

Additional settings 

For JPEG, PNG, TIFF, GIF, OpenEXR and Radiance HDR file formats: 

 Pixel format—sets the color mode for the exported image. Select from the pop-up menu. 

 Matte—sets the background color for the exported image. Select from the pop-up panel. 

 ICC Profile—by default, this is set to the ICC profile of the project (document). However, the 

project's ICC profile can be overwritten for this export area. Select from the pop-up menu. 

 Embed ICC profile—when selected, the ICC profile is included within the exported image's 

data, allowing the image to be viewed using the correct profile on any device. If this option is 

off, the viewing device must possess the ICC profile otherwise a substitute profile is used. 

  



For JPG, PDF, SVG and EPS file formats: 

 Quality—sets the resulting quality of the exported image. Higher quality may result in 

significantly larger file sizes. 

For PDF, SVG and EPS file formats: 

 Rasterize—select an option for rasterizing design elements which are unsupported by the file 

format. Select from the pop-up menu: 

o Nothing—no elements within the design are rasterized on export, therefore 

unsupported elements are not included in the exported file. 

o Everything—all elements within the design are rasterized for a resulting exported file 

which perfectly matches your original design. 

o Unsupported properties—only unsupported elements are rasterized in the exported 

file. 

 Downsample images—select whether to downsample raster images within the design. 

 Above—if this set DPI is exceeded by raster design elements, those elements will be 

rasterized down to this set DPI. This option is dependent on the Downsample images option 

being active. 

 Use document resolution—ensures the export is the same DPI as the current project's 

setting. 

 Use DPI—overrides the current project's resolution setting for the export. The exported 

image's DPI is set using the adjacent input box 

 Allow JPEG compression—when selected, rasterized design elements will be compressed to 

decrease exported file size. If this option is off, rasterized design elements will be exported as 

uncompressed. 

For PNG and GIF file formats: 

 Palletized—when selected, encodes the exported image by mapping it to the Palette and 

Colors settings set below. (This option cannot be switched off for GIF images.) 

 Palette—by default, this is set to be automatically determined. However, you can specify an 

encoding palette yourself. Select from the pop-up menu. 

 Colors—selects the number of colors available in the palette. Select from the pop-up menu. 

  



For SVG and EPS file formats: 

 (Use) Relative coordinates—when selected, objects in the exported file have relative 

positions for maximum editability. If this option is off, object positions are fixed to create a file 

which is optimized for viewing. 

For JPG file format: 

 Progressive—when selected, the exported image is progressively compressed for optimized 

viewing when downloading. 

For PSD file format: 

 Compatibility mode—when selected, the exported file will be compatible with other 

applications which do not support some features (file size may also increase). If this option is 

off, the exported file may not be readable by other applications (depending on the features 

used in the image). 

 Smallest file sizes—when selected, the exported file will be compressed where possible but 

may not be readable by other applications. If this option is off, no compression will take place 

for the exported file. 

 Rasterize all layers—when selected, layer content is rasterized in the exported file (the layer 

structure is retained). If this option is off, no rasterization takes place on export. 

 Strategies—set the way to export specific project attributes. Select from the pop-up menu. 

o Preserve accuracy—the listed attribute will be rasterized to preserve its intended 

design. 

o Preserve editability—the listed attribute will be exported with its original settings to 

allow for easy editing. 

For PDF file format: 

 Compatibility—sets the version and type of PDF to be exported. Select from the pop-up 

menu. 

 Color Space—choose whether to use the document's current color space or export using a 

selected color space. Select from the pop-up menu. 

 Profile—choose whether to use the document's current color profile or export using a 

specific color profile. Select from the pop-up menu. 

 Embed profiles—when selected (default), the chosen (or document's) color profile will be 

embedded in the exported file. If this option is off, the exported file will not have the color 



profile embedded with it (the viewing device will need to have the appropriate color profile 

installed to view the exported PDF accurately). 

 Honor spot colors—when selected, spot colors within the design are exported as spot colors. 

If this option is off, spot colors are converted to an equivalent color within the exported file's 

color space (see above). 

 Overprint black—when selected, design elements which use CMYK black are set to overprint. 

If this option is off, CMYK black elements are set to be indistinguishable to other colors during 

printing. 

 Include bleed—when selected, any Bleed set in Document Setup will be included in the PDF 

output. 

 Include printer marks—when selected, the PDF output will show printer marks around the 

page edge. All printer marks are added by default. However, particular types of printer marks 

can be switched off, depending on your preference. These include: 

o Crop marks 

o Registration marks 

o Color and grayscale bars 

o Page information 

 Embed fonts—select an option for handling fonts used in the document. 

o Text as Curves—all text is converted to curves. This ensures the resulting exported 

file will display correctly regardless of the fonts installed on the viewing device. 

o All Fonts—any fonts used in the document are embedded in the exported file. This 

ensures the resulting exported file will display correctly regardless of the fonts 

installed on the viewing device. 

o Uncommon Fonts—fonts used are only embedded in the exported file if they are not 

part of the fonts traditionally installed on most devices. The viewing device must have 

the expected fonts installed to view any common fonts in the exported file. 

o No Fonts—no fonts are embedded in the exported file. A viewing device must have 

all the used fonts installed to accurately view the exported file. 

 Subset fonts—when selected, embedded fonts will only include the glyphs used in the 

document. If this option is off, all glyphs for the used fonts are embedded in the exported file, 

regardless of whether they appear in the document or not. 



 Allow advanced features—when selected, all design features supported by the PDF file 

format are exported as vectors. If this option is off, depending on the nature of these features, 

they are rasterized or converted to curves on export. These features include: 

o Artistic text which has been horizontally or vertically stretched. 

o Text which has an applied stroke. 

o Linear and radial gradients. 

o Non-solid transparencies. 

If the Allow advanced features option is selected on export, the resulting PDF, when 

imported into other applications, may cause the above advanced features to be rasterized or 

rendered incorrectly. The third party's app may also display an error message on PDF import. 

For SVG file format: 

 Export text as curves—when selected, the text in the resulting file will be drawn as curves 

(therefore displaying precisely as intended, even if viewed on a device without the used fonts 

installed). However, this option will increase file size, and text won't be editable as text or 

available to "text to speech" in other apps. If this option is off, text will be exported as text and 

the viewing device will need the used fonts installed for it to be viewed correctly. 

 Longer text spans—when selected, text is placed relative to previous lines of text (therefore 

producing smaller file sizes and simpler file structures). If this option is off, text is placed with 

absolute coordinates. 

 Use hex colors—when selected, colors in the exported file are expressed as RGB Hex values 

(therefore reducing file size but less human-readable). If this option is off, colors are exported 

as standard RGB values. 

 Flatten transforms—when selected, transformed objects are 'fixed' in the exported file. This 

allows for the file to be viewed more accurately across applications. If this option is off, 

objects remain dynamically transformed to allow for more flexible editing. 

 Use tile patterns—when selected, rasterized areas may be converted to a vector shape with a 

filled bitmap to give smoother, sharper edges. However, this might not be supported by some 

apps. If this option is off, objects will exist as singular elements within the exported file. 

 Set viewBox—when selected, the exported file includes coordinates and dimensions which 

define the view box of the image. If this option is off, no view box data is included in the 

exported file. The export area is used to define the view box. 



 Add line breaks—when selected, the code in the exported file will be optimized for human 

viewing and reading. If this option is off, the image will be exported with code on a single line 

which will make the file size significantly smaller. 

For EPS file format: 

 Postscript level—sets the version of the exported postscript file. Select from the pop-up 

menu. 

 Minimize size—when selected (default), the exported file will be compressed to create the 

smallest file size possible. 

Resampling methods 

The following resample settings are available: 

 Nearest Neighbor—simple resampling which has the fastest processing time. Use for hard-

edge images. 

 Bilinear—algorithmic resampling for use when shrinking images. 

 Bicubic—algorithmic resampling for use when enlarging images. Resampling is smoother 

than Bilinear but has a slower processing time. 

 Lanczos 3—complex algorithmic resampling which gives the best results but with the longest 

processing time. Available as 'separable' and 'non-separable'; the latter gives marginally better 

results, but is slightly slower than 'separable'. 

To save custom settings as a preset:  

1. Set the export options as desired. 

2. Click Panel Preferences, and select Create preset from the pop-up menu. 

3. Enter a name and click OK. 

The new preset is added to the end of the Preset pop-up menu and is also accessible from the Export 

dialog. 

You can delete and rename custom presets by selecting the appropriate option from the Panel 

Preferences pop-up menu. 

  



Slices panel 

The Slices panel allows you to export defined areas of your design to universally recognized raster 

image formats. 

About the Slices panel 

Once an export area has been defined, the Slices panel allows you to export the area at various sizes 

and formats. 

The panel can be populated with one or more slices. Each slice possesses a single export setup, within 

which multiple export formats (detailing file format and scaling options) may be stored. In turn, each 

export format can have multiple export sizes. This allows different graphics formats, of different sizes, 

to be exported from each slice simultaneously. 

 

The Slices panel showing export areas in the document. 

Options 

The following options are available in the panel: 

 Batch builder—Creates Xcode JSON batches from multiple Apple Universal or Application 

icon slices. For Xcode UI development only. 

 Export preset—presents slice presets offering common graphics formats and options for 

Apple app icon design. 

 Copy export setup to clipboard—copies a selected slice's export setup (including 

multiple export formats) to clipboard. If you select a graphic-specific export format within the 

setup, the button can be used to copy that export format to another slice's export setup. 

 Replace export setup from clipboard—pastes a copied slice's export setup from the 

clipboard to another selected 'target' slice. A copied export format can be pasted too. 



 Add Export format from clipboard—pastes a copied export format selected from a 

slice's export setup and adds it to another slice's export setup. 

 Delete—removes the panel item and corresponding export area from the page. The Page 

panel item cannot be deleted. 

 Continuous—when selected, slices are re-exported automatically if the content within the 

slices are modified. This option becomes available once Export Slices (n) has been clicked 

and an export folder selected. 

 Export Slices (n)—exports all checked panel items. 

The forward slash (or oblique) character can be used in slice filenames in export setups in the Slices 

panel. The word preceding the slash will be used to create a containing folder for the file named at the 

end, when exported using Export Slices (n). 

For example, a PNG slice with a filename in the Slices panel of assets/img/hero will create hero.png 

within an img folder within an assets folder. 

Export Setup Options 

The following options are available in the export setup for each slice entry: 

 Page—indicates that the export area is the entire page. 

 Slice—indicates an export area drawn with the Slice Tool. 

 Slice (from item)—indicates an export area created from an layer, group or object. 

 Thumbnail—visually indicates the area to be exported. 

 Filename—displays the name for the export area. Type directly in the text box to set your own 

file name. If a name has not been set, unique names are suggested. 

 Active/Inactive—when checked, the area is exported when Export Slices (n) is clicked at 

the bottom of the panel. 

 Export—exports the area represented by the panel item. 

 Path—defines the folder name for the JSON imageset to be written to. For Xcode UI 

development only. 

 Builder—generates supplementary Xcode JSON files along with the exported slices for Apple 

icons. For Xcode UI development only. 

  



Export Format Options 

You can store multiple formats within every slice's export setup. The following options are available 

for each format: 

 File format—select a file format to be exported from the pop-up menu. 

 Size scaling—select scaling options (e.g., 1x, 2x, etc.) to set for the export format. 

 Additional properties—lets you choose a custom DPI and a path and filename made up of 

defined tokens or custom user variables. 

 Export—exports the slice using this export format. 

  



Layers panel (Export Persona) 

The Layers panel in Export Persona lets you create slices from entire layers, groups or selected objects. 

About the Layers panel 

The panel lets you target layers, groups or objects in your document that you want to specifically 

export. By selecting them, they can be made into slices from the same panel; the Create Slice option 

generates slices for the Slices panel from which raster images can be exported. 

 

The Layers panel showing layers in the current document. 

Options 

The following options are available in the panel: 

 Visible in export—when enabled, the item is visible and can be exported. When disabled, 

the item is hidden and can't be exported. 

 Make item visible—when enabled, the item is visible. When disabled, the item is hidden. 

The item can be exported in both states. 

 Edit All Layers—allows selection of objects across all layers (rather than the current layer). 

 Create Slice—creates a slice from the selected layer, group or object in readiness for 

export. 

For child objects, the visibility options may show as being partly grayed out if the parent object 

has the corresponding visibility option switched off. 

  



Using undo, redo and history 

It's easy to revert changes to a file when you've either made a mistake or if you simply don't like the 

result. 

Any edits you make to your document are stored in the History panel. You can then use this, or 

standard quick keys, to undo an edit. You can also redo an edit which you have recently undone. 

A document's history can be saved along with the document, so earlier edits can be returned to even 

if the document is closed and reopened. 

To undo or redo a change:  

Do one of the following: 

 From the Edit menu, click Undo to go back one step, or Redo to redo the step previously 

undone. 

 On the History panel, click one of the entries in the list to jump to that state. 

 On the History panel, drag the slider left to undo a change, right to redo a change. 

To return to root:  

 On the History panel, drag the slider to the farthest position to the left. 

To save history with a document:  

1. From the File menu, select Save History With Document. 

2. In the Saving With History dialog, click Yes to accept the conditions discussed in the dialog. 

3. Save your document. 

Saving your document's history with your document may significantly increase the size of your project 

file. 

You can switch off the save history feature by repeating step 1 of the procedure above. 

To set the History panel preferences:  

1. In the Affinity Photo menu, click Preferences. 

2. In the Edit menu, click Preferences. 

3. Click Performance. 

4. Drag the Undo Limit slider left to reduce the number of stored changes, right to increase the 

number of stored changes. 

5. Click Close. 
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Using snapshots 

Snapshots are great for storing your current work at any point in time, much like a freeze frame. You 

might do this in advance of carrying out more complex operations where you might need to restore 

back to a previous point in time (if things don't go to plan!). 

If you're experimenting with different approaches, you can also create different snapshots for each 

approach which lets you explore, compare and evaluate each in turn. You then have the option to 

choose a preferred snapshot to continue working from. Compared to reverting edits step-by-step 

using the History panel, snapshots let you define a stage in your session from which you can restore 

from. If needed, you can also take your snapshot to a new document. 

About the Snapshot panel 

The Snapshot panel is available from the Photo and Develop Personas; for the former, it can be 

switched on via View>Studio; for the latter, it can be viewed by clicking 'Snapshot' at the top right of 

your workspace. 

The Snapshot panel can also be used in conjunction with the Undo Brush Tool to paint back to a 

chosen snapshot. Enabling the panel's camera icon preceding an entry sets the chosen snapshot to 

paint back to. In Photo Persona, snapshots are saved with your document and are available to be used 

in future sessions. 

To create a snapshot:  

 From the Snapshots panel, click Add Snapshot. 

The snapshot, showing date and time, is added to the panel. 

To restore a snapshot:  

1. From the Snapshots panel, select a snapshot from the list. 

2. Click Restore Snapshot. 

To create a new document from a snapshot:  

1. From the Snapshots panel, select a snapshot from the list. 

2. Click New Document from Snapshot. 

To delete a snapshot:  

1. From the Snapshots panel, select a snapshot from the list. 

2. Click Delete. 

Any saved snapshot can be added to your document as a flattened layer using Layer>New Layer 

From Snapshot. 



Guides 

Guides are non-printing, non-exporting lines that float over your page and assist with positioning of 

layer content. They can be created and positioned by dragging from a ruler (for 'by eye' placement) or 

via the Guides Manager (for precision using the document's units or a percentage). 

 

To add a guide:  

Do one of the following: 

 Drag from either the horizontal or vertical ruler which can be switched on via the View menu. 

 From the View menu, select Guides Manager. Click the Add new guide icon for either 

horizontal or vertical guides. 

To move a placed guide:  

Do one of the following: 

 Drag the guide with the Move Tool when you see the cursor change. 

 From the View menu, select Guides Manager. Double-click on the value for the guide you 

want to edit and type a new position into the value field. (Note that you do not need to type 

the units.) 

To position guides by percentage:  

1. From the View menu, select Guides Manager. 

2. Select the Percent option. 

Percentages are calculated from the top-left of the document page. 

To show or hide guides:  

 From the View menu, select Show Guides. A check mark is displayed next to the menu item 

when the guides are visible. 
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If guides are hidden, they will automatically become viewable again if a new guide is added by 

dragging from a ruler. 

To remove guides:  

Do one of the following: 

 With the Move Tool selected, drag the guide off the page. 

 From the View menu, select Guides Manager. Click to select the value for the guide you want 

to delete and then click the Remove guide icon. 

When creating or moving layer content, you can snap to guides. 

  



Margins 

Page margins allow you to design with printing in mind. 

 

The margins give an indication of the extent of the page that will be printed when using a desktop 

printer. Design elements positioned outside the margins may not be printed. 

Margin positions are set up on document creation either manually or by using the settings of an 

installed printer. They are non-printing and non-exporting. 

Margins can also be used for snapping to when creating or moving layer content. 

To set page margins:  

1. On document setup, check Include margins. 

2. In the dialog, do one of the following: 

o Set the Left Margin, Right Margin, Top Margin, and Bottom Margin. 

o Click Retrieve Margin from Printer to automatically set margins to the settings of 

your desktop printer. 

If you intend to export your design, rather than printing it directly, you can design without added 

margins. If this is the case, you can keep the Include Margins unchecked on document setup. 

To hide/show margins:  

 From the View menu, deselect/select Show Margins. A check mark is displayed next to the 

menu item when the margins are visible. 

  



Rulers 

Rulers are useful when you need to accurately place layer content or guides in the Document View. 

 

The point where 0 appears on each ruler is called the ruler origin. 

To show or hide rulers:  

 From the View menu, select Show Rulers. A check mark is displayed next to the menu item 

when the rulers are visible. 

To change document units:  

 With either the View Tool or Zoom Tool selected, choose a unit of measurement from the 

pop-up menu on the context toolbar. 

Changing the units will automatically change the units on displayed rulers. 

  



Dynamic guides 

Dynamic guides are intelligent guide lines which automatically appear when moving and aligning 

vector shapes or a curve's nodes. 

Dynamic guides appear automatically in two instances: 

 As you drag vector layer content to help you align and resize to a shape's, line's or text's 

edges, centers, vertices, and page elements (e.g. page margins). These guides display in red 

when aligning horizontally and in green when aligning vertically. 

 

 

You'll only see them when snapping is enabled, and when your snapping preset has the Snap 

to object bounding boxes option checked. 

 When drawing curves with the Pen Tool. If snapping options on the tool's context toolbar are 

enabled, nodes or control handles can be snapped to other nodes. To help this, dynamic 

guides show while dragging nodes or handles. Snapping and guide behavior is completely 

independent of the 'global' Snapping option on the main toolbar. 

 



Rotate canvas 

Rather than rotating the document, you can rotate the canvas instead, which is akin to physically 

rotating your working space. This allows you to view your document from a different angle without 

manipulating its layout. 

About canvas rotation 

Being able to rotate the canvas is beneficial for a number of applications: 

 Brush and fine detail work 

 Product design (e.g., product box/packaging layouts with content at 90/180 degree angles) 

 Tablet-assisted design (drawing at angles) 

To rotate the canvas:  

 From the View menu, select Rotate Left or Rotate Right. The canvas will be rotated in 15 

degree increments. 

From the same menu, select Reset Rotation to reset the canvas back to its original rotation. 

For greater efficiency, assign your own custom keyboard shortcuts to rotating and resetting canvas 

operations. See Customizing keyboard shortcuts for more information. 

For Trackpad users, canvas rotation can be carried out using a gesture. 

To switch off/on canvas rotation (for Trackpads):  

 From Affinity Photo>Preferences (Tools option), uncheck or check Enable Canvas Rotation 

with Trackpad. 
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Snapping 

Snapping simplifies the positioning of crop areas, selection areas, and layer content (pixel or vector) 

by 'magnetizing' areas or content to other content or page elements (guides, page edges, etc.). 

Snapping for accurate crop and selection areas 

To precisely create the above areas you can use snapping to position to previously placed guides or to 

the page edge itself. 

Simply drag out your crop or selection area until its edge meets the positioned guide. 

Snapping for vector lines, shapes, and text 

Snapping causes images, brush strokes, lines, shapes, and selection areas to align to nearby grid lines, 

guides, margins, or spreads, or any combination of these. You can also snap to object bounding 

boxes, key points on shapes and to an object's geometry. Text can also snap to the baseline of other 

text (the first line only for text frames). 

To activate/deactivate snapping:  

 Click Snapping on the main toolbar. 

To temporarily override snapping:  

 Press the while you're positioning. Snapping won't occur while the is depressed. 

Snapping for vector layers 

To help understand snapping behavior, colored dynamic guides and target nodes display when you 

snap to objects. The colors used are: 

 Red line: Object snaps to target horizontally. 

 Green line: Object snaps to target vertically. 

 Yellow node: Object snaps to shape's key points horizontally and vertically. 

 Purple node: A curve's node snaps to a shape's key points. 

 Blue line: Object snaps to third plane when using triangular projection grid. 

 Orange line: Object snaps to target horizontally or vertically if a projection grid is active. 

Dynamic guides work in conjunction with snapping to provide a visual aid when aligning. Dynamic 

guides also include labels which report the distance between the snapping objects (measured in the 

document's set units). 



For web graphic development, you may wish to use Force Pixel Alignment. This complements any 

active snapping settings. 

Snapping candidates 

Snapping candidates are page objects which are available for you to snap to. You can set how 

candidates are created using the following settings: 

 Candidate List—limits the number of objects which are snapping candidates to the number 

you set. Creating a new object, or hovering over an existing object, designates it as a 

snapping candidate in this case. Only the active snapping candidates can be snapped to. 

 Immediate layers—limits the number of candidates to the objects on the current layer. 

 Immediate layers and children—limits the number of candidates to the objects on the 

current layer and any of the layer's subordinate child layers. 

 All layers—does not limit the number of snapping candidates in the document. 

To activate/deactivate snapping:  

 Click Snapping on the main toolbar. 

To temporarily override snapping:  

 Press the while you're positioning an object. Snapping won't occur while the is depressed. 

Snapping presets for vector layers 

A powerful and comprehensive set of snapping options are available to you. To make snapping setup 

quick and easy, one of several snapping presets can be chosen which group recommended snapping 

options according to how you plan to work. 

To select a snapping preset:  

1. Click the Snapping option's arrow. 

2. From the Preset pop-up menu, select a preset. 

To customize a snapping preset:  

1. Click the Snapping option's arrow. 

2. Select a preset on which to base your new snapping options. 

3. Check individual options on/off to override the current preset's options. 

The options will be in effect immediately. 

To save as a custom preset for future use:  

1. Click the button adjacent to the Presets pop-up menu. 
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2. Select Create preset. 

The custom preset is in effect immediately. 

Snapping options for vector layers 

Individual snapping options can be switched on or off to suit your needs, drawing style, and the 

project you are working on. The preset that you initially adopted will be customized in the process. 

The following options are available from the pop-up dialog:  

 Screen tolerance—controls the distance you have to be to an object before snapping occurs. 

 Enable snapping—when checked, objects will snap to specified criteria. This must be selected 

to change other options. 

 Presets—Select a preset which is a grouping of snapping options for specific ways of working. 

o Page layouts—for designs to be printed, where snapping to placed guides, margins, 

and spreads is important. 

o Page layouts with objects—as above but with additional object-to-object alignment. 

o Object creation—perfect for simple object-to-object alignment to bounding boxes 

and their midpoints, plus for some shapes to key points. Key points are automatically 

added points on some objects, e.g. where a shape's corner is made rounded, key 

points are placed at the start and end of the rounded corner. 

o Curve drawing—the setup for non-geometric use (i.e., drawing with the pen or brush 

tools). 

o UI design—for UI/web design for pixel accuracy when using snapping to fixed guides 

and grid. 

 Only snap to visible objects—when checked, only visible objects are snapped to. 

 Show snapping candidates—when checked, highlights the active snapping candidates, i.e. 

objects that can be snapped to by prior selection or hover over. 

 Show snapping hints—when checked, displays potential snapping candidates when objects 

are near by. 

 Force pixel alignment—identical to the Toolbar option—see Force Pixel Alignment. 

o Move by whole pixels—identical to the Toolbar option—see Force Pixel Alignment. 

 Snap to grid—when checked, content snaps to a line grid (if switched on from the View 

Menu). Not available when using Force Pixel Alignment. 
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 Snap to guides—when checked, content snaps to guides (if switched on from the View 

Menu). 

 Snap to spread—when checked, content snaps to the edge of the page (ignoring margins). 

o Include spread mid points—when checked, content snaps to vertical or horizontal 

center of the page. This option is only available if the above option is selected. 

 Snap to margin—when checked, content snaps to page margins (if switched on from the 

View Menu). 

o Include margin mid points—when checked, content snaps to vertical or horizontal 

center of the page margin. This option is only available if the above option is selected. 

 Snap to object bounding boxes—when checked, objects can be aligned based on its 

bounding box. 

o Include bounding box mid points—when checked, objects snap to vertical or 

horizontal center of a target object. This option is only available if the above option is 

selected. 

o Snap to gaps and sizes—when checked, arrows represent matched gaps between 

snapping candidates and matched horizontal and/or vertical sizes. 

 Snap to shape key points—when checked, objects can be aligned to key points on shapes, 

such as the start and end of a rounded corner. 

 Snap to object geometry—when checked, objects can be snapped to object vertices and not 

simply to the bounding box or key points. Vertices are object corners or intersections, such as 

the points of a star, within a shape's bounding box. 

Snapping always snaps to the currently set measurement unit (set via the View Tool or Zoom Tool). 

You can also access the above settings from the Snapping Manager via the View menu. 

  



Force Pixel Alignment 

Force Pixel Alignment will snap vector objects, nodes and handles, and pixel selection areas to full 

pixels when created, moved or modified. If this option is off, objects and selections can occupy partial 

pixels. 

Force Pixel Alignment is particularly useful for web graphic development. 

Move By Whole Pixels 

In addition to Force Pixel Alignment, the Move By Whole Pixels option allows you to constrain the 

movement of vector objects, nodes and handles to whole pixels. 

Move By Whole Pixels is particularly useful for repositioning an object by a particular pixel distance 

while also maintaining the relevant partial pixels an object occupies. 

If you deactivate Move By Whole Pixels but have Force Pixel Alignment active, moving an object 

which occupies partial pixels will also transform it marginally. 

Force Pixel Alignment complements any active snapping settings. 

To activate/deactivate Force Pixel Alignment:  

 Click Force Pixel Alignment on the Toolbar. 

To activate/deactivate Move By Whole Pixels:  

 With Force Pixel Alignment active, click Move By Whole Pixels on the Toolbar. 

To temporarily override snapping:  

 Press the while you're positioning. Snapping won't occur while the is depressed. 
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Grids 

A non-printing, non-exporting grid can be displayed on your page to help you lay out layer content 

more accurately. 

 

Grid overlaid over image with layer content selected 

The grid is overlaid over your page to help you align objects. They are gray by default but can be any 

color you choose. 

Grids can be automatic or fixed—the former (as default) changes the frequency of grid subdivisions 

as you zoom in/zoom out, the latter always keeps the grid frequency constant (irrespective of zoom 

level). 

Grids work best when combined with snapping, in particular when the Snap to Grid option is enabled. 

They can be based on any document unit and will line up perfectly with rulers (when switched on). 

To show or hide grid:  

 On the View menu, select Show Grid. 

To adjust automatic grid spacing:  

With the Zoom Tool selected, do one of the following: 

 Zoom in to see smaller grid divisions. 

 Zoom out to see larger grid divisions. 

At all zoom levels the grid shows as grid 'blocks' further split into grid subdivisions. 

To create a fixed square grid:  

1. From the View menu, select Grid and Axis Manager. 

2. Uncheck Use automatic grid. 

3. Set the Spacing and Divisions values. 

4. Click Close. 

To customize grid color:  

1. From the View menu, select Grid and Axis Manager. 
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2. Click the Grid lines or Subdivision lines swatch to display a pop-up panel to set the line 

color(s). 

3. Drag the sliders to set the opacity of either, or both, line colors. 

4. Click Close. 

For a different color or opacity for the subdivision lines compared to the main grid lines, click the Link 

the grid colors symbol next to the swatches. 

To create a rectangular grid:  

1. From the View menu, select Grid and Axis Manager. 

2. Uncheck Use automatic grid. 

3. Select Advanced and uncheck Uniform. 

4. Do one of the following: 

o Set the Spacing and Divisions for the first and second axis. 

o Select Fixed aspect ratio, set the Spacing and Divisions for the first axis and then set 

the Aspect ratio and Divisions for the second axis. 

5. Click Close. 

To create a fixed angular grid:  

1. From the View menu, select Grid and Axis Manager. 

2. Uncheck Use automatic grid. 

3. Select Advanced. 

4. From the Grid type pop-up menu, select Two axis custom. 

5. Set the Angle of either axis. 

6. Click Close. 

To set isometric angles, set First and Second Axis to 30° and 150°, respectively. 

To change document units:  

 With either the View Tool or Zoom Tool selected, choose a unit of measurement from the 

pop-up menu on the context toolbar. 

  



Parallel projections 

Affinity Photo makes use of a highly customizable projection grid, perfect for UI/game design, digital 

design modelers, and mock ups. 

 

Isometric and Triangular grids. 

About parallel projections 

Plane sets can be enabled so you can design on front, side and top planes; each plane can be toggled 

into by using a single key modifier. 

Instead of the commonly used isometric projection grid, a choice of other project grid presets can be 

selected (e.g., dimetric, triangular); you can even create custom projection grids with options for grid 

sizing, custom aspect ratios, and gutters for more advanced use. 



Drawing on projection grids 

Once in a specific mode and plane set you can create line and shape drawing using the Pen Tool or 

pre-designed geometric shapes. 

For pen drawing, use the Pen Tool's Polygon or Line Modes for straight line segments. For geometric 

shapes, skew shapes to fit your grid. 

About snapping controls 

Grids work best when combined with snapping (switch on via top toolbar), in particular when the Snap 

to Grid option is enabled from the Snapping button's pop-up menu. Object handles snap precisely to 

any grid line and line intersections. 

Grids can be based on any document unit, shown when switching on the rulers. 

About custom grids 

If you're looking beyond the projection mode presets such as isometric you can customize the grid to 

your liking. 

To set your projection grid:  

1. From the View menu, select Grid and Axis Manager. 

2. Uncheck Use automatic grid. 

3. Click Advanced to access projection grids. 

4. From the Grid type pop-up menu, select a project mode, e.g. Isometric. 

The Grid and Axis Manager is also ideal for laying out two-dimensional fixed grids as well as 

projection grids. 

To create plane sets:  

 On the dialog, check Create plane set. 

You can then cycle between planes on demand to design on top, side, and front of your drawing. 

To jump between planes:  

 Press the ' . 

To customize your projection grid:  

1. From the Grid type pop-up menu, select Two axis custom or Triangular custom. 

2. Select Create plane set to activate and configure the Up axis. 

3. Adjust the settings in the dialog. 

4. Click Close. 



Assistant Manager 

The Assistant Manager controls how painting, layer addition, and applying filters has an effect on 

layers in your document. The Manager lets you choose whether or not to be alerted of layer 

operations as they occur. 

Alert messages inform you that Affinity Photo has performed an action that you need to be aware of. 

This is as a result of the last operation you performed. Assistant Manager can decide the default type 

of action to take. While in Photo Persona, several types of operation can lead to different actions. 

 Painting with no layer selected: Creates a new pixel layer for your brush strokes using 'Add 

new pixel layer and paint' if there is no pixel or vector layer selected; 'Take no action' means 

that no pixel painting is allowed. 

 Erasing from vector layers: Erases on a created layer mask applied to your vector layer, 

immediately rasterize the vector layer and erase directly on it, or take no action. 

 Other brushes on vector layers: For retouching pixel brushes (e.g., Burn Brush Tool, Smudge 

Brush Tool, etc.), any applied brush stroke rasterizes the vector layer by default. You can 

change this behavior by selecting 'Take no action' which doesn't convert the layer or apply the 

stroke. 

 Brush tool sharing: Choose whether a selected brush is shared between tools of a similar 

nature (e.g. Dodge, Burn and Sponge Brush Tools), shared across all tools, or each tool's brush 

is set independently. 

 Applying filters to vector layers: For effect and retouch filters from the Filters menu, 

applying a filter to a vector layer rasterizes it by default. You can change this behavior by 

selecting 'Take no action' which doesn't convert the layer or apply the filter. 

 Adding adjustment layer to selection: If you've created a selection, any adjustment applied 

to the selection is added as a new adjustment layer above the currently selected layer or 

made a child adjustment layer of the selected layer instead. With no layer selected, a new 

adjustment layer is added to the top of the layer stack in both instances. 

 Adding mask layer to selection: Analogous to 'Adding adjustment layer to selection' above, 

but for mask layers. 

 Adding filter layer to selection: Analogous to 'Adding adjustment layer to selection' above, 

but for filter layers. 

To change Assistant Manager settings:  

1. From the View menu, click Assistant Manager. 

2. Select options from the relevant option's pop-up menu. 



To switch off alerts or the Assistant Manager completely:  

1. From the View menu, click Assistant Manager. 

2. Uncheck Alert when assistant takes an action or Enable assistant, respectively. 

In Develop Persona, the Assistant Manager will present a limited set of options that allow you to 

control how RAW files are developed. See Developing a raw image for more details. 
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Vector content defaults 

When you create vector content, its appearance is initially determined by the default settings for the 

particular content you are creating. 

These defaults can be changed in the current document, saved globally for future documents or 

returned to factory settings at any time. Synchronizing defaults lets you base a new default on 

currently selected content, with the option to save the defaults or revert to saved defaults if needed. 

Vector content defaults are stored separately for stroke and fill attributes, art text attributes, and 

frame text attributes. 

To synchronize defaults to current selection:  

1. Select an object with the attributes you wish to save as default settings. 

2. From the Edit menu, select Defaults, then Synchronize from selection. 

Synchronized defaults override saved defaults for this document only. This is a great way to work with 

a set of defaults temporarily for a single document without having to save them. 

To save defaults:  

 From the Edit menu, select Defaults, then Save. 

The defaults used for this document become the global defaults for all future documents. 

To revert synchronized defaults back to saved defaults:  

 From the Edit menu, select Defaults, then Revert. 

If vector content is currently selected, its attributes revert to the default settings. 

To reset defaults to factory settings:  

 From the Edit menu, select Defaults, then Factory Reset. 

If vector content is currently selected, its attributes revert to the default settings. 

The Synchronize from selection and Revert defaults menu options apply to the current document 

only. The Save and Factory Reset menu options apply globally. 

  



At a Glance 

The workspace is designed to make photo editing easy, with all of the tools you need at your finger 

tips. If you've worked with raster image editing applications before, you'll find that many of the 

commands and options will be familiar to you. 

Within Affinity Photo, each active Persona has its own workspace layout, tools and panels. These are 

visible when the Persona is selected. However, the fundamental concept of the workspace is common 

to all Personas. 

 

The default document view and workspace (Photo Persona active). 

Document View 

The document view, shown by default, shows the page that you are working on. 

Menu bar 

The Menu bar organizes commands in menus and shows the commands appropriate to the Persona 

that you are currently working in. Shortcut menus provide a quick way to access commands that are 

also found in the standard menus. 

Persona toolbar 

Hosts the current Personas available in Affinity Photo. The active Persona's icon appears in with 

saturated colors. 

Toolbar 

The Toolbar hosts some of the most commonly used commands and functions for the active Persona. 

Like menus, it's also fully customizable. 
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Context toolbar 

The context toolbar contains the commands and options that are specific to the active tool. 

Tools panel 

The Tools panel contains the tools that you will need when working on your projects. The tools 

contained inside the panel change according to the Persona that you are currently working in. The 

Tools panel can either be docked or free-floating (Separated mode only) depending on your 

preference. It can also be customized. 

Studio panels 

These panels contain settings that support your project workflow and active tool. Some panels may 

change to reflect the Persona that you are currently working in. Panels can either be docked or free-

floating depending on your preference. Their layout can be customized. 

Status bar 

The status bar at the bottom of the active document view provides useful information such as hints 

and shortcuts for the current tool or operation. 

  

file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Workspace/contextBar.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Workspace/workspaceModes.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Workspace/customizingToolsPanel.html
file:///C:/Program%20Files/Affinity/Affinity%20Photo/PhotoHelp/Contents/Resources/en-US.lproj/pages/Workspace/customizingWorkspace.html


Keyboard shortcuts 

You can quickly access common tools and commands using your keyboard. Many of the shortcuts are 

the same as those that you use in other apps (such as C to copy). You'll find many of the shortcuts 

listed next to menu items (and in the list below). 

You can quickly access common tools and commands using your keyboard. Many of the shortcuts are 

the same as those that you use in other apps (such as +C to copy). You'll find many of the shortcuts 

listed next to menu items (and in the list below). 

For complete flexibility, you can customize keyboard shortcuts to your own way of working. 

Editing shortcuts 

Action Key 

Resize Document -+I 

Resize Canvas -+C 

Select multiple -click 

Select overlapping layer content -click 

Reset Selection Box . 

Toggle Snapping ; 

Erase with Pixel Tool  

Switch between Stroke/Fill (or Color 1/Color 

2) color selectors (Color and Swatches 

panels) 

X 

Swap Stroke/Fill (or Color 1/Color 2) color 

selectors 

X +X  

Set No fill on Stroke/Fill (or Color 1/Color 2) 

color selectors 

/ (International and 

selected keyboards only) 

Toggle between Crop Tool overlays (Crop 

Tool enabled) 

O 

Flip golden spiral overlay (Crop Tool 

enabled) 

+O 

Modify attribute listed on a panel or dialog Drag attribute text label 
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Action (Transforming) Key 

Move with horizontal, vertical 

or diagonal constraint 

-drag 

Rotate in 15° intervals -drag rotation/corner handle 

Rotate around opposite corner -drag corner handle Drag corner 

handle then hold down right mouse 

button  

Cancel a sizing, moving, or 

creating operation 

 

Resize from center -drag from a corner handle 

Mirror shearing -drag Ctrl-drag  

Nudging Arrow keys 

Nudging (10x measurement 

units) 

-arrow keys 

Vector-specific shortcuts 

Action Key 

Resize maintaining aspect ratio -drag from a corner 

handle 

Edit curves as you draw  

Creates cusp node (sharp corner) -drag control handle 

Snap a curve's control handle to 45° 

intervals 

-drag control handle 

Convert to Curves +  

File shortcuts 

Action Key 

New Document N +N  

New From Clipboard N +++N  

Open Document O +O  



Close Document/Close App (when no documents open) W +W  

Switch Document/View +  

Save S +S  

Save As S ++S  

Export S +++S  

Print P +P  

Tools shortcuts 

Action Key 

Flood Fill Tool / Gradient cycle G 

View Tool H 

Move Tool V 

Crop Tool C 

Selection Tools cycle W 

Pen and Node Tool cycle P 

Zoom Tool Z 

Clone Tool S 

Shape Tools cycle U 

Text Tools cycle T 

Dodge, Burn and Sponge Brush Tool cycle O 

Retouch Tools cycle J 

Painting Tools cycle B 

Erase Tools cycle E 

Marquee Selection Tools cycle M 

Free hand Selection Tool L 



Action (Liquify Persona only) Key 

Liquify Push Forward Tool P 

Liquify Push Left Tool L 

Liquify Twirl Tool T 

Liquify Pinch Tool U 

Liquify Turbulence Tool B 

Liquify Mesh Clone Tool C 

Liquify Reconstruct Tool R 

Liquify Freeze Tool F 

Liquify Thaw Tool W 

Liquify Zoom Tool Z 

Liquify View Tool H 

Action (Develop Persona only) Key 

White Balance Tool W 

Red Eye Removal Tool R 

Blemish Removal Tool L 

Overlay Paint Tool B 

Overlay Erase Tool E 

Overlay Gradient Tool G 

Crop Tool C 

Zoom Tool Z 

View Tool H 

Action (Export Persona only) Key 

Slice Tool S 

Layer Select Tool L 



Action (Panorama Persona only) Key 

Transform Source Image Tool A 

Add To Source Image Mask Tool L 

Erase From Source Image Mask Tool U 

Edit shortcuts 

Action Key 

Undo Z +Z  

Redo Z +Y  

Copy Merged ++C 

Paste Style V ++V  

Paste FX V ++V  

Paste Inside V ++V  

Paste without Format V +++V  

Fill +F5 

Inpaint + 

Layer operations shortcuts 

Action Key 

Select All Layers A ++A  

Group G +G  

Ungroup G ++G  

Duplicate J +J  

Invert I +I  

Move to Front ] ++]  

Move Forward One ] +]  



Move to Back ++[ ++[  

Move Back One [ +[  

New Layer N ++N  

Merge Down E +E  

Merge Selected E ++E  

Merge Visible E +++E  

Toggle between Frequency Separation layers F 

Action (Live Projection only) Key 

Edit Live Projection P ++P  

Brush shortcuts 

Action Key 

Picks up a new brush color -drag 

Change selected layer 

content/brush tool's opacity 

numeric keys (4=40%, 43=43%, 

etc.) 

Increase/decrease brush width ] [ 

Decrease/increase brush width with 

on-screen readout 

-drag (left/right) Right mouse 

button press++drag (left/right)  

Decrease/increase brush hardness 

with on-screen readout 

-drag (up/down) Right mouse 

button press++drag (up/down)  

Text shortcuts 

Action Key 

Bigger text +  

Smaller text < +<  

Precise bigger text ++  

Precise smaller text < ++<  

Tighten +  



Loosen +  

Tighten More ++  

Loosen More ++  

Bold B +B  

Italic I +I  

Underline U +U  

Show Character T +T  

Show Typography T ++T  

Superscript + ++=  

Subscript - ++-  

Align Left L ++L  

Align Center C ++C  

Align Right R ++R  

Justify Left | ++|  

Increase Paragraph Leading +  

Decrease Paragraph Leading +  

Precise Increase Paragraph Leading ++  

Precise Decrease Paragraph Leading ++  

Raise Baseline ++  

Lower Baseline ++  

Precise Raise Baseline +++  

Precise Lower Baseline +++  

Spelling Options ; ++;  

Line Break +  

Non Breaking Space +  



En Dash - +-  

Em Dash - ++-  

View shortcuts 

Action Key 

Zoom In + +=  

Zoom Out - +-  

Zoom to Fit 0 (or double-click View Tool icon) +0 (or 

double-click View Tool icon)  

(Zoom to) 100% 1 (or double-click Zoom Tool icon) +1 (or 

double-click Zoom Tool icon)  

(Zoom to) 200% 2 +2  

(Zoom to) 400% 3 +3  

(Zoom to) 800% 4 +4  

(Zoom to) Actual Size 8 +8  

(Zoom to) Pixel Size 9 +9  

Hot key zoom in -click +-click  

Hot key zoom out -click +-click  

View tool H 

Hot key panning  

Scroll vertically up/down Mouse scroll wheel 

Scroll horizontally 

left/right 

+Mouse scroll wheel 

Switch between views ` +`  

Show Rulers R +R  

Show Guides ; +;  

Show Grid ' +'  



Grid Plane cycle ' 

Split View cycle (not 

Photo Persona) 

, 

Pixel selection/Mask shortcuts 

Action Key 

Select All A +A  

Deselect D +D  

Invert Pixel Selection I ++I  

Add to selection (Marquee/Free 

hand selection tools only) 

-drag Drag with left and right 

button down  

Remove from selection  

Grow/Shrink B +B  

Feather F6 +F6  

Refine Edges R ++R   

Move selection in 1-pixel 

increments 

Arrow key 

 

Move selection in 10-pixel 

increments 

arrow key +arrow key  

 

Selection from layer -click layer thumbnail or O -click 

layer thumbnail or ++O   

Selection from layer luminance -click layer thumbnail +-click 

layer thumbnail   

Polygon selection (Freehand 

Selection Tool only) 

-click on page. +-click on page.  

 

Quick Mask Q 

 

Workspace shortcuts 

Action Key 

Show/Hide Studio (panels) H ++H  



Show/Hide Toolbar T ++T  

Toggle UI  

Hide Workspace H +H  

Adjustment and Filter shortcuts 

Action Key 

Levels (Adjustment) L +L  

HSL (Adjustment) U +U  

Invert (Adjustment) I +I  

Curves (Adjustment) M +M  

Black and White (Adjustment) B +++B  

Repeat Filter F +F  

Liquify Persona shortcuts 

Action Key 

Mask All A +A  

Clear Mask D +D  

Invert Mask I +I  

Misc shortcuts 

Action Key 

Preferences , +,  

OSX shortcuts 

Action Key 

Special Characters  

Toggle Full Screen F 

Hide Workspace H 



Hide Others (applications) H 

Media Browser M 

  



Toolbar 

The Toolbar hosts commonly used tools and options to keep them at your fingertips. Options are 

placed in logical groups to improve ease of use. 

The tools and options may differ depending on the currently active Persona. 

Settings 

The following options are available from the Toolbar. 

Enhancement: 

 Auto Levels—automatically applies a levels adjustment to the image. 

 Auto Contrast—automatically applies a contrast adjustment to the image. 

 Auto Colors—automatically applies a color adjustment to the image. 

 Auto White Balance—automatically applies a white balance adjustment to the image. 

Selection: 

 Select All—selects all pixels on the entire layer. 

 Deselect—deselects all pixels in the current selection. 

 Invert Selection—selects the portion of the current layer outside the current selection. 

Quick Mask: 

 Quick Mask—click to switch to Quick Mask mode to create selections using the painting 

tools. 

 Quick Mask options—customize settings from the pop-up menu. 

Snapping: 

 Force Pixel Alignment—when selected (default), vector content and pixel selections will 

snap to full pixels when created, moved or modified. If this option is off, partial pixels can be 

occupied. 
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 Snapping—when selected, layer content will obey the snapping rules defined by the 

current snapping options. If this option is off (default), snapping is disabled. 

 Snapping options—customize settings from the pop-up menu. 

Assistant Options: 

 Assistant options—click to control layer rasterization behavior and enable supporting on-

screen alerts. 

Order: 

 Move to Back—repositions the selected layer(s) at the bottom of the Layers panel. 

 Back One—moves the selected layer(s) down one position in the Layers panel. 

 Forward One—moves the selected layer(s) up one position in the Layers panel. 

 Move to Front—repositions the selected layer(s) at the top of the Layers panel. 

The above options are also available from the Arrange menu. 

Align: 

 Arrange—displays a pop-up dialog allowing you to align and distribute layer content. 

Insert Target: 

 Insert behind the selection—when selected, new layers are added below the currently 

selected layer(s). 

 Insert at the top of the layer—when selected, new layers are added at the top of the 

layer stack. 

 Insert inside the selection—when selected, new layers are added inside the current 

selection. 

If all target options are off (default), new layers are added above the currently selected layer. 

  



Mesh (Liquify Persona only): 

 Reset Mesh—applies a new mesh and removes all currently applied effects from the 

underlying image. 

 Save Mesh—saves the current mesh for future application. 

 Load Mesh—applies a previously saved mesh. 

Mask (Liquify Persona only): 

 Mask All—applies a new mask to the entire image. 

 Clear Mask—removes the mask from the image. 

 Invert Mask—reverses which areas are masked and which areas are not. 

Split View (Liquify and Develop Personas only): 

 None—displays in full view. 

 Split—displays in split view for side-by-side 'Before - After' comparison. 

 Mirror—displays a split mirrored view for side-by-side 'Before - After' comparison. 

Before / After (Develop Persona only): 

 Sync Before—updates the 'Before' view using the settings applied in the 'After' view. 

 Sync After—removes all the settings applied in the 'After' view to return the image to the 

'Before' view. 

 Swap—switches the applied settings of the 'Before' and 'After' views. 

Orientation (Develop Persona only): 

 Rotate Counter-clockwise—rotates the image 90° to the left. 

 Rotate Clockwise—rotates the image 90° to the right. 

Design Aids (Develop Persona only): 

 Show Clipped Highlights—when selected, highlight areas which suffer from loss of detail 

due to clipping are displayed on the image in red. 



 Show Clipped Shadows—when selected, shadow areas which suffer from loss of detail 

due to clipping are displayed on the image in blue. 

 Show Clipped Tones—when selected, midtone areas which suffer from loss of detail due 

to clipping are displayed on the image in yellow. 

  



Persona Toolbar 

The Persona toolbar hosts the current Personas available in Affinity Photo. 

Settings 

The following options are available from the Toolbar: 

 Photo Persona—provides the core set of photo editing tools. 

 Liquify Persona—switches to warping tools for retouch and special distortion effects. 

 Develop Persona—switches to a tonal and lens correction environment with support for 

raw image development. 

 Tone Mapping Persona—moves to an environment for tone mapping HDR and non-

HDR imagery through global and local contrast. 

 Export Persona—switches to a slice-based image export environment. 

The active Persona can also be switched by accessing the top Affinity Photo menu. 

The active Persona can also be switched by accessing the top File menu. 

The Panorama Persona is only accessible through the New Panorama feature on the File menu. 

Context toolbar 

The context toolbar always updates to show the options available for the currently selected tool, 

making it quick and easy to tailor the settings as you edit and design. 

In Normal mode, the context toolbar appears below the Toolbar and immediately above the 

document view. In Separated mode, the context toolbar floats and can be placed anywhere on your 

screen. 

Each time you select a new tool, the context toolbar shows the commands and options relevant to the 

selected tool. 

In some cases, the commands shown by the context toolbar change depending on selection type and 

the active Persona. 

The toolbar is always visible, even in full screen view. It cannot be turned off as the toolbar is essential 

for most tools. 
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Photo editing tools. 

View Tool 

The View Tool is used to move the visible portion of your document in the Document view. 

The context toolbar for the View Tool also contains the tools to change the zoom level of your 

document. 

If you double-click on the View Tool's icon on the Tools panel, the zoom will be set to 'Fit'. 

Tool shortcut: H  

Hot key panning:  

You can never pan so far that your page disappears out of view, regardless of current zoom level. 

Settings 

Zoom settings are changed on the context toolbar. 

 Set a zoom level. Select from the pop-up menu. 

 Drag the slider to adjust the zoom level. 

 Set a unit of measurement. Select from the pop-up menu. 

  



Move Tool 

The Move Tool allows you to select layer content. Once selected, the Move Tool allows you to move, 

rotate, and resize the selected content. 

Use the Shift key with the tool to constrain objects to Vertical, Horizontal or diagonal (45°). 

Tool shortcut : V. 

Settings 

The following settings are available on the context toolbar: 

 Preferences—provides access to the Preferences dialog for advanced application settings 

(shows when no content is selected). 

 Reset Selection Box—after reshaping, rotating, or shearing the layer content, this option 

resets the selection box to vertical (shows when layer content is selected): 

 Lock Children—when checked, any child layer(s) of a selected ungrouped layer cannot be 

altered when the selected layer is transformed. Great for maintaining the size, position and 

aspect ratio of a clipped picture when resizing its parent layer. 

For vector content, the context toolbar options update depending on the object selected. Settings 

may include the following: 

 Fill—click the color swatch to display a pop-up panel to update fill color. 

 Stroke—click the color swatch to display a pop-up panel to update stroke color. 

 Line style—click to display a pop-up panel to set the Width and line style. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

 Ungroup—splits selected group into individual content for focused manipulation. 



Under Preferences>Tools, the Move Tool Aspect Constrain option can be used to specify whether 

or not to constrain the aspect ratio by default when resizing. The option can also be set to automatic, 

letting the software decide based on the selected content. 

Color Picker Tool 

The Color Picker Tool allows you to sample colors from anywhere on your document or screen. 

Sampled (or picked) colors from the Color Picker Tool are stored in the swatch next to the tool's icon 

on the Color or Swatches panel. 

Tool shortcut : I 

Settings 

The following settings can be adjusted from the context toolbar: 

 Apply to Selection—when selected (default), the picked color will automatically apply to the 

selected object's Fill or Stroke, depending on which color selector is active on the Color or 

Swatches panel. If this option is off, the picked color is not automatically applied. 

 Source—determines from where the tool can pick colors—Current Layer restricts picking to 

the currently selected layer; Global picks from all layers. 

 Radius—Choose to sample from directly under the cursor (Point 1x1) or from differently sized 

square areas where the color is averaged. 
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Crop Tool 

The Crop Tool allows you to remove portions of your photo or image. Crops are non-destructive and 

can use specific aspect ratios as required. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Apply—applies the crop to your image once you've defined the crop area (based on the 

positioned overlay). 

 Mode—sets the aspect ratio of the crop area. Select from the pop-up menu. 

 Crop dimension boxes—for Custom Ratio and Absolute Dimension modes, sets the width and 

height, respectively. 

 Units—sets the units used by the crop area. 

 Rotate—rotates the crop area by 180°. 

 Straighten—switches to Straighten mode to align crooked photos horizontally or vertically. 

 Overlay—offers various overlays for better photo composition. 

 Reset—resets all settings to their defaults. 

 Darken Border—renders areas outside of the crop boundary darker for easier previewing. 

Zoom Tool 

The Zoom Tool is used to change the zoom level of your page in the Document view. 

If you double-click on the Zoom Tool's icon on the Tools panel, the zoom will be set to 100%. 

Tool shortcut: Z  

If you have a trackpad, you can use 'pinch to zoom' to zoom in and out at any time, regardless of tool 

selection. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Set a zoom level. Select from the pop-up menu. 

 Drag the slider to adjust the zoom level. 

 Set a unit of measurement. Select from the pop-up menu. 



Vector line tools.  

Pen Tool 

The Pen Tool is used to precisely draw lines and shapes. 

 

It has four modes, Pen mode, Smart mode, Polygon mode and Line mode, which are available to 

select in the context toolbar. Each mode changes how the line is drawn. 

Pen mode 

The most powerful and precise mode used to create bézier lines and shapes with smooth or sharp 

corners and nodes. 

Smart mode 

Easily create flowing lines and shapes by clicking and placing nodes. 

Polygon mode 

Used to draw straight lines with sharp nodes and shapes with straight edges. 

Line mode 

Used to draw single-segment straight lines. 

 

Pen Mode, Smart Mode, Polygon Mode, Line Mode 



Settings 

The following settings can be adjusted from the context toolbar: 

 Mask—converts the shape into a protected area, masking the remaining layer content. 

 Selection—converts the shape into a selection. 

 Mode—switches between Pen, Smart, Polygon and Line mode (see above). 

 Convert—converts the selected node into a Sharp, Smooth, or Smart node. 

 Action—Manipulates the curve(s): 

o Break Curve opens the shape at the selected node. 

o Close Curve joins the start and end nodes to create an enclosed shape. 

o Smooth Curve modifies a line or shape, by adding and removing nodes, to make it 

more aesthetic. 

o Join Curve connects two separate curves together to make one curve. Curves need to 

be both selected with the using either the Node Tool or as you draw. 

o Reverse Curve lets you draw from the opposite end of the curve. The start node 

becomes active, ready for further drawing. 

 Snap—Controls node snapping: 

o Align to nodes of selected curves—will snap any node you drag to any other 

node on the same or a different curve. 

o Snap to geometry of selected curves—will snap dragged nodes to the same or 

different curve's path or node. 

o Snap all selected nodes when dragging—will snap multiple selected nodes, 

when dragging, to a "target" node on any selected curves. 

o Snap off-curve handles—will align a dragged control handle to an adjacent node. 

These options are independent of the global snapping options. 

 Use Fill—When checked, the concave area of the line is filled with the currently set fill color 

(from Color panel) as you draw. 
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Node Tool 

The Node Tool is used to edit existing lines and shapes. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Convert—converts the selected node into a Sharp, Smooth, or Smart node. 

 Action—Manipulates the curve(s): 

o Break Curve opens the shape at the selected node. 

o Close Curve joins the start and end nodes to create an enclosed shape. 

o Smooth Curve modifies a line or shape, by adding and removing nodes, to make 

it more aesthetic. 

o Join Curves connects two separate curves together to make one curve. Curves 

need to be both selected with the using either the Node Tool or as you draw. 

o Reverse Curve lets you draw from the opposite end of the curve—The start node 

becomes active, ready for further drawing. 

 Snap—Controls node snapping: 

o Align to nodes of selected curves—will snap any node you drag to any other 

node on the same or a different curve. 

o Snap to geometry of selected curves—will snap dragged nodes to the same or 

different curve's path or node. 

o Snap all selected nodes when dragging—will snap multiple selected nodes, 

when dragging, to a "target" node on any selected curves. 

o Snap off-curve handles—will align a dragged control handle to an adjacent node. 

These options are independent of the global snapping options. 
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Selection tools.  

Selection Brush Tool 

The Selection Brush Tool allows you to select a region of your image by painting. 

The Selection Brush Tool functions in a similar way to the other brushes in Affinity Photo. By simply 

dragging on your image, you can add or remove regions from a selection. The selection will grow or 

shrink depending on the brush settings. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Mode—sets the way in which your selection develops as you paint: 

o Add—the brush stroke adds areas to the current selection. If there is no selection in 

place, you will create a new selection by painting. 

o Subtract—the brush stroke removes areas from the current selection. 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Snap to edges—selection is expanded to the edges of content underneath the brush stroke. 

 All layers—if this option is off (default), the selection is only applied to the current layer. 

When selected, the selection applies to all layers in your image. 

 Refine—click to display the Refine Selection dialog to access advanced selection settings. 
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Flood Select Tool 

The Flood Select Tool enables you to select pixels of a similar color. 

Pixels added to a selection are determined by the color of the pixel or adjacent pixels under the tool 

when you click or drag across the page, respectively. The dragging operation controls the selection 

tolerance, i.e. how much the selection will grow to encompass pixels of similar color values under the 

cursor. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Mode—select from New, Add, Subtract, and Intersect. 

 Tolerance—sets the range of pixels affected when a pixel is clicked. For lower tolerance 

settings, pixels must be very close in value to the clicked pixel. For higher tolerance settings, 

pixel color can vary widely from the clicked pixel. 

 Contiguous—when enabled, only selects a range of pixels within the same area. If disabled, 

similar pixel ranges will be selected even if they are separated and in different parts of the 

image. 

About selection modes 

The four modes available from the context toolbar affect how your selection develops. 

 New—cancels all current selections and creates a new selection. 

 Add—adds areas to the current selection. If there is no selection in place, a new selection will 

be created. 

 Subtract—removes areas from the current selection. 

 Intersect—a new selection area is created from the overlap between the newly added 

selection area and the current selection. 

  



Marquee Selection Tools 

The Marquee Selection Tools provide various ways of applying selections to your image. 

The Marquee Selection Tools are available in various shapes including Rectangular, Elliptical, 

Column, and Row. All marquees are applied by simply selecting the desired shape and then dragging 

on your image. 

A Free Hand Selection Tool is also available for defining the selection area as a drawn pencil line, 

polygonal straight line edges, or snapped magnetic nodes. 

Settings 

The settings for each tool vary but may include some or all of the following settings, which can be 

adjusted from the context toolbar: 

 Mode—select from New, Add, Subtract, and Intersect. 

 Refine—click to display the Refine Selection dialog to access advanced selection settings. 

 Feather—reduces the sharpness of selection edges by partially selecting edge pixels. 

 Antialias—if this option is off (default), pixels at the edge of the selection are opaque. When 

selected, selection edges are smoothed by applying transparency to edge pixels. 

 Width—sets the width of the Column or Row selection tools. 

About selection modes 

The four modes available from the context toolbar affect how your selection develops. 

 New—cancels all current selections and creates a new selection. 

 Add—adds areas to the current selection. If there is no selection in place, a new selection will 

be created. 

 Subtract—removes areas from the current selection. 

 Intersect—a new selection area is created from the overlap between the newly added 

selection area and the current selection. 

Free Hand selection types 

The Free Hand Selection Tool offers three distinct selection types: 

 Freehand—creates a selection which follows the cursor's exact movements. 
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 Polygonal—creates a selection based on connected straight lines with a single click defining 

each change in direction. 

 Magnetic—creates a selection by creating automatic nodes that snap to distinct edges while 

following the cursor's movement. Click to define custom node positions. 

Modifier keys 

When using the Free Hand Selection tool, the following modifier keys can be used to aid in the 

creation of selections: 

 The temporarily switches to Polygonal if using Freehand. 

 The temporarily switches between Polygonal and Magnetic. 

 If using Polygonal and Magnetic, dragging will temporarily invoke Freehand.  



Fill tools. 

Flood Fill Tool 

The Flood Fill Tool allows you to fill in areas of your page, selection, or object with a single click. 

The Flood Fill Tool works by replacing the color of pixels on the current layer with the Fill color set on 

the Color panel. The pixels affected are determined by the following: 

 The color of the pixel under the tool when you click on your page. 

 Whether the pixels are within the same selection area. 

 The pixels are directly connected to the clicked pixel or any others that are affected. 

 The tool's Tolerance settings (see below). 

Settings 

The following settings can be adjusted from the context toolbar: 

 Tolerance—sets the range of pixels affected (filled) when a pixel is clicked. For lower 

tolerance settings, pixels must be very close in value to the clicked pixel. For higher tolerance 

settings, pixel color can vary widely from the clicked pixel. 

 Contiguous—if enabled, the flood will only be applied to affected pixels that are in the same 

area of the image. If disabled, the flood will be applied to all the pixels that match the 

tolerance setting regardless of where they are in the image. 

  



Gradient 

The Gradient tool allows you to apply and adjust gradient colors on all layers, including pixel layers, 

fill layers, adjustment layers, live filter layers, layer masks, as well as vector and text content. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Type—converts the gradient's color type. For example, from Linear to Radial. 

 Select, pick, and modify the layer's solid or gradient color—click the color swatch to display a 

pop-up panel. See the Color panel, Swatches panel, and Gradient editing topics for more 

information on the settings available. 

 Rotate gradient—rotates the applied gradient by 90°. 

 Reverse gradient—the end stops swap places. (All intermediate stops are also 

repositioned accordingly.) 

 Maintain fill aspect ratio—if this option is off (default), the end stops can be resized 

separately which changes aspect ratio. When selected, the end stops are locked to keep the 

aspect ratio (i.e. changing one will automatically update the other). This setting affects only 

Elliptical and Bitmap fills. 
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Paint tools. 

Paint Brush Tool 

The Paint Brush Tool lays down pixels on the page, creating strokes with antialiased edges. This 

creates a natural transition between the stroke and the surrounding pixels. 

Its variable width lines can be controlled either by velocity—most useful when drawing with a 

mouse—or by pressure—for use when drawing with a pressure-sensitive device. 

Other brush-based tools use similar settings to control the appearance of the applied pixels, although 

there may be slight variations. 

Most brushes use a soft, round brush as their default. Alternative styles can be selected from the 

Brushes panel. 

With any Brush tool selected in Photo Persona, you can quickly change the opacity of your brush 

using numerical keys. For more information, see the Painting brush strokes topic. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the pixel brush effect is applied (1% is very slow, 100% is immediate). Type 

directly in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the pixel brush are. The brush appears softer as the 

percentage decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 Blend Mode—changes how the applied pixels interact with existing pixels on a layer. Select 

from the pop-up menu. 

 Wet Edges—builds paint up along the edges of your pixel brush stroke, producing a 

watercolor effect. 
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 Protect Alpha—when checked, you are not able to paint on the current layer's transparent 

regions. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Color Replacement Brush Tool 

The Color Replacement Brush Tool works by replacing the color of pixels on the current layer with 

the Foreground color selected on the Color panel. 

The pixels affected by the Color Replacement Brush are determined by the following: 

 The color of the pixel under the tool when you click on your page. 

 Whether the pixels are within the same selection area. 

 The pixels are included in the painted stroke. 

 The tool's Tolerance settings (see below). 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 Tolerance—sets the range of pixels affected when a pixel is clicked. For lower tolerance 

settings, pixels must be very close in value to the clicked pixel. For higher tolerance settings, 

pixel color can vary widely from the clicked pixel. 

 Sample continuously—if this option is off (default), the initial click position determines the 

reference color to be replaced. When selected, new reference colors are determined as the 

cursor moves. 

 Contiguous—when selected (default), only adjacent qualifying pixels under the stroke are 

recolored. If this option is off, all qualifying pixels under the stroke are recolored, even if they 

are non-adjacent. 
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This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Pixel 

The Pixel Tool draws pixel-aligned, hard-edged lines. This is in contrast to the Paint Brush Tool which 

may have a slight pixel variance due to its antialiasing. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the line thickness in pixels. Type directly in the text box or drag the pop-up slider to 

set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 Blend mode—changes how the applied pixels interact with existing pixels on a layer. Select 

from the pop-up menu. 

 Protect Alpha—when checked, you are not able to paint on the current layer's transparent 

regions. 

 Alternate—changes the behavior of the alternate modifier (-Click): 

o Erase—erases created pixels. 

o Background color—temporarily switches to the background color in the swatch. 

o Undo from snapshot—paints-in from a chosen snapshot (see Using snapshots). 

You can erase pixel brush strokes while the is pressed. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Paint Mixer Brush 

The Paint Mixer Brush is ideal for digitally simulating the mixing of wet paint applied to a canvas. As 

you drag the Paint Mixer Brush across the page, the color currently on the brush blends with the color 

on the page, smudging and mixing them together. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 Strength—defines the extent to the smudging. Type directly in the text box or drag the pop-

up slider to set the value. 

 Load Brush—removes the mixed color currently on the brush and replaces it with the Color 1 

swatch color set on the Color panel. 

 Auto Load Brush—when selected, each new stroke will automatically Load Brush as 

described above before pixels are applied to the page. 

 Clean Brush—removes the mixed color currently on the brush, leaving a brush with no initial 

color applied to it. 

 Model—selects a different color model for use with the brush. RYB is a historical subtractive 

color model based on red, yellow and blue as primary colors. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Erase tools. 

Erase Brush Tool 

You can erase from any area of your photo using the Erase Brush Tool. Erased pixels become 

transparent. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. 100% opacity erases pixels completely on the first 

pass. A lower opacity only partially erases the pixels. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Background Erase Brush Tool 

With the Background Erase Brush Tool, you can erase pixels of a similar color. This makes it useful 

for tasks such as erasing the background while leaving the foreground intact. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. 100% opacity erases pixels completely on the first 

pass. A lower opacity only partially erases the pixels. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Tolerance—how dissimilar the pixels can be compared to the sampled pixel for the pixels to 

be erased. A low percentage affects only pixels very similar to the sampled pixel 

 Sample continuously—if this option is off (default), samples the color only once on the first 

click. When selected, samples color continuously as you drag. 

 Contiguous—when selected (default), affects neighboring pixels as well as the sampled pixel 

color. If this option is off, affects only the selected pixel color. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Flood Erase Tool 

The Flood Erase Tool enables you to erase pixels of a similar color with a single click. 

Flood Erase Tool works by replacing the color of pixels on the current layer with fully transparent 

pixels. The pixels affected are determined by the following: 

 The color of the pixel under the tool when you click on your page. 

 Whether the pixels are within the same selection area. 

 The pixels are directly connected to the clicked pixel or any others that are affected. 

 The tool's Tolerance settings (see below). 

Settings 

The following settings can be adjusted from the context toolbar: 

 Tolerance—sets the range of pixels affected when a pixel is clicked. For lower tolerance 

settings, pixels must be very close in value to the clicked pixel. For higher tolerance settings, 

pixel color can vary widely from the clicked pixel. 

  



Retouch tools. 

Dodge Brush Tool 

Dodging is a technique used in photography to control exposure and make areas of a photo lighter. 

The Dodge Brush Tool allows you to precisely lighten areas of your image, and even limit the effect 

to just shadows, highlights or midtones. The effect is cumulative—the more you paint over an area, 

the more pronounced the lightening effect will be. 

When using this brush you'll get the best results by using a low opacity setting and gradually building 

up the effect. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 Tonal Range—limits the effect to a specific tonal range. Choose Shadows, Midtones or 

Highlights from the pop-up menu. 

 Protect Hue—when selected, the color tone remains faithful to the original hue. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Burn Brush Tool 

Burning is a technique used in photography to control exposure and make areas of a photo darker. 

The Burn Brush Tool allows you to precisely darken areas of your image, and even limit the effect to 

just shadows, highlights or midtones. The effect is cumulative—the more you paint over an area, the 

more pronounced the darkening effect will be. 

When using this brush you'll get the best results by using a low opacity setting and gradually building 

up the effect. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 Tonal Range—limits the effect to a specific tonal range. Choose Shadows, Midtones or 

Highlights from the pop-up menu. 

 Protect Hue—when selected, the color tone remains faithful to the original hue. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Sponge Brush Tool 

The Sponge Brush Tool can be used to selectively saturate or desaturate areas within an image. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 Saturate—when selected, brush strokes increase the saturation of the existing pixels. 

 Desaturate—when selected, brush strokes decrease the saturation of the existing pixels. 

 Vibrance—when selected, brush strokes adjust the intensity of subtle colored pixels, while 

minimizing clipping of highly saturated colored pixels. 

 HSL Saturation—when selected, adjusts the color intensity of all pixels. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Clone Brush Tool 

The Clone Brush Tool paints samples from one part of an image onto another. It's useful for 

removing defects, general photo retouching and duplicating parts of an image. Like all brush tools, it 

is pressure sensitive to create natural looking strokes when using a pressure-sensitive device. 

The Clone Brush Tool can clone from other images (called Global Sources) using the Sources panel. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 Blend mode—changes how the applied pixels interact with existing pixels on a layer. Choose 

mode type from a pop-up menu. 

 Aligned—when selected (default), the origin of the sample remains a fixed distance from the 

pointer. If this option is off, the origin of the sample always returns to the sample location 

defined initially. 

 Source—the source determines the layer(s) from which the pixels are sampled from. Select 

from the pop-up menu. 

 Add Global Source—sets the currently defined sample origin as a global source for use in 

other images. Remember to select a source using -click first. 

 Rotation—sets the degree of rotation applied to the sample. The result can be previewed 

inside the brush cursor. Type directly in the text box or drag the pop-up slider to set the value. 

 Scale—sets the scale of the sample between 1% and 1000%. Type directly in the text box or 

drag the pop-up slider to set the value. The result can be previewed inside the brush cursor. 
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 Flip—allows for horizontal and vertical flipping of the resulting clone relative to the sampled 

area. Choose horizontal, vertical or both directions from a pop-up menu. 

The Rotation setting can be adjusted using the left and right arrow keys. The Scale setting can be 

adjusted using the up and down arrow keys. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Undo Brush Tool 

The Undo Brush Tool can be used to selectively undo modifications to individual pixels, restoring 

them to a previous history state or a saved snapshot. 

After setting a brush source, you can blend the image's current state back to a previous state, like 

painting backwards in time. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 Blend Mode—changes how the applied pixels interact with existing pixels on a layer. Select 

from the pop-up menu. 

 Blend—when selected (default), pixels which do not overlap those in the selected history or 

snapshot state are unaffected, allowing the blending of the current document state with the 

selected, previous state. If this option is off, all pixels are returned to the previous state when 

painted. 

 Protect Alpha—When checked, you won't be able to paint on the current layer if it has 

transparent regions. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 

To paint from history or a saved snapshot:  

1. Display the History or Snapshot panel. 
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2. Click the Undo Brush Source camera icon on the history state or snapshot you want to paint 

back to. 

3. Begin painting with the Undo Brush Tool. 

  



Blur Brush Tool 

You can use the Blur Brush Tool to blur hard edges within an image. The effect is cumulative so the 

more you paint over an area, the more pronounced the blur effect will be. The blur is only applied to 

pixels on the currently selected layer. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Sharpen Brush Tool 

Sharpening increases the contrast of neighboring pixels. The Sharpen Brush Tool gives you full 

control over the areas that are sharpened and has a cumulative affect. You can easily apply clarity and 

unsharp mask sharpening selectively with a few strokes of a brush! 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 Mode—determines the sharpening effect to be applied. Select from the pop-up menu. 

About the sharpening modes 

The three modes available from the context toolbar have slightly different effects on the underlying 

pixels. 

 Clarity—increases local contrast. 

 Unsharp Mask—increases contrast of edge pixels. 

 Harsh—increases contrast on all pixels. 

When using this brush you'll get the best results by using either low opacity or flow settings and then 

gradually building up the effect. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Median Brush Tool 

The Median Brush Tool can be used to selectively reduce noise by blending pixels under the stroke. 

As with all brush tools, you can create natural looking strokes when using a pressure-sensitive device. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Smudge Brush Tool 

The Smudge Brush Tool allows you to drag color around an image, similar to dragging a brush or 

finger through wet paint. It can be used to blend colors and create interesting brush effects. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 Strength—defines the extent to the smudging. Type directly in the text box or drag the pop-

up slider to set the value. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Healing Brush Tool 

The Healing Brush Tool enables you to repair and retouch unsightly areas of an image. 

The Healing Brush Tool can clone from other images (called Global Sources) using the Sources panel. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

 Aligned—when selected (default), the origin of the sample remains a fixed distance from the 

pointer. If this option is off, the origin of the sample always returns to the sample location 

defined initially. 

 Source—the source determines the layer(s) from which the pixels are sampled from. Select 

from the pop-up menu.. 

 Add Global Source—sets the currently defined sample origin as a global source for use in 

other images. Remember to select a source using -click first. 

 Rotation—sets the degree of rotation applied to the sample. The result can be previewed 

inside the brush cursor. Type directly in the text box or drag the pop-up slider to set the value. 

 Scale—sets the scale of the sample between 1% and 1000%. Type directly in the text box or 

drag the pop-up slider to set the value. The result can be previewed inside the brush cursor. 

 Flip—allows for horizontal and vertical flipping of the resulting healing area relative to the 

sampled area. Choose horizontal, vertical or both directions from a pop-up menu. 

The Rotation setting can be adjusted using the left and right arrow keys. The Scale setting can be 

adjusted using the up and down arrow keys. 
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This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 
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Patch Tool 

The Patch Tool allows you to repair a more extensive area of an image by selecting pixels and 

replacing them from another target area of your current or other document. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Mode—select from New, Add, Subtract, and Intersect. 

 Selection is source—if this option is off (default), the selection is the target area where pixels 

will be replaced. When selected, the selection is the source area from where pixels will be 

copied. 

 Texture Only—if this option is off (default), hue information from the source area is 

preserved and the target area's hue will update accordingly. When selected, hue information 

from the source area is disregarded and the target area's hue will remain unchanged. 

 Transparent—if this option is off (default), the source area is placed on the target area as 

fully opaque. When selected, the source area is placed one the target area with varying 

transparency depending on the color value of individual pixels. 

 Source—the source determines the layer(s) from which the pixels are sampled from. Select 

from the pop-up menu. The 'Global' option enables patching using pixels previously sampled 

in another document (raster layer only). 

 Set Global Source—sets the currently defined sample origin as a global source for use in 

other images. 

 Rotation—sets the degree of rotation applied to the sample. The result can be previewed 

inside the selection. Type directly in the text box or drag the pop-up slider to set the value. 

 Scale—sets the scale of the sample between 1% and 1000%. Type directly in the text box or 

drag the pop-up slider to set the value. The result can be previewed inside the selection. 

About selection modes 

The four modes available from the context toolbar affect how your selection develops. 

 New—cancels all current selections and creates a new selection. 

 Add—adds areas to the current selection. If there is no selection in place, a new selection will 

be created. 

 Subtract—removes areas from the current selection. 



 Intersect—a new selection area is created from the overlap between the newly added 

selection area and the current selection. 

Blemish Removal Tool 

The Blemish Removal Tool enables you to remove small imperfections from images with a single 

click. 

You can save presets of the applied blemish fixes, which can be useful for reapplying saved fixes to 

other images, e.g. when correcting images where the camera had dust on its sensor. 

The tool is available in both Photo Persona and Develop Persona. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the area size in pixels. Type directly in the text box or drag the pop-up slider to set 

the value. 

 Save Preset—saves the current blemish fixes to a preset for later application. 

 Blemishes—Displays the blemish preset(s) saved with Save Preset. 

 Load Preset—Loads the currently selected blemish set in the Blemishes pop-up menu. 
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Inpainting Brush Tool 

The Inpainting Brush Tool restores damaged, lost, deteriorated or unwanted areas of an image. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Width—the brush (stroke) size in pixels. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Opacity—how see through the brush is. Type directly in the text box or drag the pop-up 

slider to set the value. 

 Flow—how fast the brush effect is applied (1% is very slow, 100% is immediate). Type directly 

in the text box or drag the pop-up slider to set the value. 

 Hardness—how hard the edges of the brush are. The brush appears softer as the percentage 

decreases. Type directly in the text box or drag the pop-up slider to set the value. 

 More—click to display the Brushes dialog to access advanced brush settings. 

 Force pressure to control size—Click to control brush size with pressure if using a pressure-

sensitive device. This overrides brush defaults. 

This Brush Tool can be associated with a particular brush in the Brushes panel. For more information, 

see the Modifying brushes topic. 

Red Eye Removal Tool 

The Red Eye Removal Tool quickly fixes the red eye effect in your photos and preserves the detail of 

the eye. 

Settings 

This tool has no customizable settings. 
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Vector shape tools. 

Rectangle Tool 

Rectangles are commonly used when drawing and are arguably one of the most used shapes in 

artwork and design. The Rectangle Tool makes it extremely quick and easy to draw rectangles and 

squares. 

 

Default shape before customization. 

Customization 

The context toolbar's Single radius option can be used to allow one of several corner types to be 

applied selectively to any corner. Once applied, the displayed red handle can be dragged to control 

the corner radius. 

 

Two possible outcomes when the options are customized—selective rounded and mixed 

corner shapes. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Single radius—when selected (default), allows you to modify all four corners simultaneously 

by setting one radius. If this option is off, you can set each corner radius individually and 

change corner type. 

 Absolute sizes—by default, the corner radius is specified as a percentage of the object and 

scales as the object is resized. When selected, this option allows you to specify the corner 

radius in units. If the object is resized, the corner radius remains the same instead of scaling 

with the object. 

 Corner—sets the style and radius of the rectangle's corners. You can choose a Rounded 

(fillet), Straight (chamfer), Concave (scallop) or Cutout option. 



 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

Ellipse Tool 

An ellipse is a useful object and one that is virtually impossible to create freehand. The Ellipse Tool 

takes the hassle out of creating circles and ellipses. 

 

Default shape before customization. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Convert to Doughnut—Swaps the ellipse for a doughnut shape. 

 Convert to Pie—Swaps the ellipse for a pie shape. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 



Rounded Rectangle Tool 

The Rounded Rectangle Tool provides an easy way to create rectangles with rounded corners. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Rounded Rectangle Tool has several options on the shape and on the context toolbar to enable 

the radius of the corners to be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Single radius—when selected (default), allows you to modify all four corners simultaneously 

by setting one radius. If this option is off, you can set each corner radius individually and 

change corner type. 

 Absolute sizes—by default, the corner radius is specified as a percentage of the object and 

scales as the object is resized. When selected, this option allows you to specify the corner 

radius in units. If the object is resized, the corner radius remains the same instead of scaling 

with the object. 

 Corner—sets the style and radius of the rectangle's corners. You can choose a Rounded 

(fillet), Straight (chamfer), Concave (scallop) or Cutout option. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 



 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Triangle Tool 

Create all types of triangles including true isosceles and right-angle triangles easily with the Triangle 

Tool. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Triangle Tool offers a handle on the shape and options on the context toolbar to enable the 

triangle to be modified. 

 

Two possible outcomes when the option is customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Top point—controls the position of the top point of the triangle from left (0%) to right 

(100%), with 50% representing a central point. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Isosceles, Right-Angled and Equilateral triangles 

 To create an isosceles triangle, set the top point to 50%. 

 To create a right-angled triangle, set the top point to either 0% or 100%. 

 To create a true equilateral triangle (where all three sides are the same length), use the 

Polygon Tool. Ensure that you constrain the shape with the as you draw, and then set the 

number of sides to 3 on the context toolbar. 
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Diamond Tool 

Easily create diamonds, rhombuses and kites with the Diamond Tool. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Diamond Tool has the option on the shape and on the context toolbar to change the height of 

the midpoint to create a kite shape. 

 

Two possible outcomes when the option is customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Mid point—controls the position of the mid points of the sides of the shape from bottom 

(0%) to top (100%), with 50% representing a central point. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Trapezoid Tool 

Easily create trapezoids with the Trapezoid Tool. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Trapezoid Tool has options on the shape and on the context toolbar to change the position of the 

top corners. This sets the length of the top edge (base) and the angles of the lateral sides (legs). 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Left/Right point—controls the position of the top-left/right corner of the trapezoid from left 

(0%) to right (100%), with 50% representing a central point. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

The left point cannot be positioned further to the right than the current position of the right point, 

and vice versa. 



Polygon Tool 

The Polygon Tool enables you to create useful multi-sided geometric shapes. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Polygon Tool has several options on the shape and on the context toolbar to enable the number 

of sides, and the side curvature to be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Sides—sets the number of sides (and angles) of the polygon. 

 Curve—sets the convex or concave nature of the sides of the polygon. The percentage curve 

available is determined by the number of sides. For straight sides, set to 0%. 

 Smooth points—applies smoothing to the points of the polygon, resulting in the appearance 

of a continuous curve. This only applies when the curve of sides is greater than 0%. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 



 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

Equilateral triangles 

To create a true equilateral triangle (where all three sides are the same length), use the Polygon Tool. 

Ensure that you constrain the shape with the as you draw, and then set the number of sides to 3 on 

the context toolbar. 

  



Star Tool 

The Star Tool enables you to create all sorts of stars quickly and easily. The added controls even 

makes it possible to add curved sides to create alternative shapes. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Star Tool has several options on the shape and on the context toolbar to enable the number of 

points, the inner radius (length of points) and the curvature of the left and right sides of the points to 

be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Curved edges—when checked, the sides of the star's points can be curved using the 

Left/Right curve settings. 

 Points—sets the number of protrusions on the shape. 

 Inner radius—controls the length of the points relative to the center of the star. 

 Outer circle/Inner circle—sets the roundness at the point's tips or inner vertices. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 



 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Double Star Tool 

The Double Star Tool enables you to create all sorts of stars quickly and easily. The Double Star Tool 

can have different values for its primary and secondary points to create a unique appearance. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Double Star Tool has several options on the shape and on the context toolbar to enable the 

number of (primary) points and the inner radius (length of points) of the primary and secondary 

points to be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Points—sets the number of primary points of the star. 

 Inner radius—controls the length of the points relative to the center of the star. 

 Point radius—controls the length of the secondary points relative to the center of the star. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 



 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Square Star Tool 

The Square Star Tool enables you to create all shapes from crosses to sunbursts quickly and easily. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Square Star Tool has several options on the shape and on the context toolbar to enable the 

number of sides and the cutout to be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Sides—sets the number of squared points on the shape. 

 Cutout—controls the width of all squared points by cutting out the region between the 

shape's bounding box and the red shape handle. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Arrow Tool 

The Arrow Tool makes it easy to quickly add arrows to your design. 

 

Default shape and handle position (in red) before customization. 

Customization 

The arrow has several options on the shape and on the context toolbar to enable the body thickness 

and the shape and size of the arrow head to be controlled. 

 

Two possible outcomes when the options are customized. 

Fixed head proportions option 

When Fixed head proportions is selected, if the shape is resized horizontally, the arrow head retains 

its proportions and the body shrinks or stretches. 

 

This example shows what happens when you resize an arrow (A) with (B), and without (C), 

Fixed head proportions selected. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Thickness—controls the height of the arrow body. 

 Ends—sets the 'head' style on either end of the arrow. 

 Proportional—when selected (default), the head proportions remain fixed when the arrow is 

resized. If this option is off, the head resizes with the design. 



 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

Context toolbar options update depending on the Ends style selected (see above). Settings may 

include the following: 

 Length—controls the length of the arrow head/tail. 

 A control for the depth and shape of the end style. 

 Size—controls the horizontal width of the arrow tail. (When Proportional is set, 100% 

represents a perfect circle, square or diamond.) 

  



Donut Tool 

The Donut Tool easily creates an ellipse shape with a hole cut out of the center. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Donut Tool has the option on the shape and on the context toolbar to control the size of the hole 

and completion of the circle. 

 

Two possible outcomes when the option is customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Hole radius—controls the width of the hole at the shape's center. 

 Start/End angle—sets the position of the start/end points relative to 360°. The greater the 

difference in the angles, the larger the portion of pie. 

 Total angle—sets the position of the total angle relative to the start angle. 

 Invert angles—switches the Start and End angle values. This converts acute shapes to obtuse 

(and vice versa) and flips the shape horizontally and/or vertically. 

 Close Pie—if the circle is incomplete, closes the shape to create a full circle. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 



 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Pie Tool 

The Pie Tool makes it easy to create pie shapes, pie segments and donuts with segments removed. As 

the segments are geometrically correct, it's easy to create shapes with the exact angle you need for 

charts and other uses. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Pie has several options on the shape and on the context toolbar to enable the start and end angle 

and the size of the donut hole to be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Hole radius—controls the width of the hole at the shape's center. 

 Start/End angle—sets the position of the start/end points relative to 360°. The greater the 

difference in the angles, the larger the portion of pie. 

 Total angle—sets the position of the total angle relative to the start angle. 

 Invert angles—switches the Start and End angle values. This converts acute shapes to obtuse 

(and vice versa) and flips the shape horizontally and/or vertically. 

 Close Pie—if the circle is incomplete, closes the shape to create a full circle. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 



 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Segment Tool 

The Segment Tool makes it easy to create an ellipse with a percentage removed as a section. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Segment Tool has several options on the shape and on the context toolbar to enable the 

percentage removed from the upper and lower section of the ellipse, and the angle of the ellipse to 

be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Angle—sets the shape's starting angle. 

 Lower/Upper line—controls the position of the shape's two straight lines. This determines 

the thickness of the segment. 

 Mirror—updates the above settings to give a reversed (flipped) version of the current shape. 

 

 Negate—updates the above settings to give the inverse (opposite) of the current shape. 

 



 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Crescent Tool 

The Crescent Tool can be used to create crescent shapes from the thinnest 'New Moon' shape, to a 

full ellipse. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Crescent Tool has two options on the shape and on the context toolbar to enable the amount of 

curve on the left and right side of the shape to be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Left/Right curve—controls the curve of the left/right side of the shape. Negative values 

move the curve to the left, positive values move the curve to the right. 

 Mirror—updates the above settings to give a reversed (flipped) version of the current shape. 

 

 Negate—updates the above settings to give the inverse (opposite) of the current shape. 

 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 



 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Cog Tool 

The Cog Tool is possibly one of the most versatile shape tools in the shape toolset. It's geometrically 

accurate and has a wide range of customizable control points to allow you to create a wide range of 

useful shapes, from cogs to sunbursts! 

 

Default shape and handle position (in red) before customization. 

Customization 

The Cog Tool has several options on the shape and on the context toolbar to enable the number of 

teeth, tooth and notch size, and inner radius and hole size to be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Teeth—sets the number of protrusions on the shape. 

 Inner radius—controls the width of cog's teeth relative to the width of the shape. 

 Hole radius—controls the width of the hole at the shape's center. 

 Tooth size—controls the width of the upper end of the cog's teeth. 

 Notch size—controls the width of the lower end of the cog's teeth. 

 Curvature—adds a curved edge to cog teeth. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 



 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Cloud Tool 

The Cloud Tool makes it easy to add clouds to your designs. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Cloud Tool has several options on the shape and on the context toolbar to enable the number of 

bubbles and the radius of the bubbles to be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Bubbles—sets the number of protrusions on the shape. 

 Inner radius—controls the length of the bubbles relative to the width of the shape. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Callout: Rounded Rectangle Tool 

The Rounded Rectangle Callout Tool provides a quick way of creating a callout or speech bubble in 

your design. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Rounded Rectangle Callout Tool has several options on the shape and on the context toolbar to 

enable the size, shape and position of the tail, the radius of the corners (including the ability to edit 

each corner separately) and the depth of the callout rectangle to be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Single radius—when selected (default), allows you to modify all four corners simultaneously 

by setting one radius. If this option is off, you can set each corner radius individually. 

 Absolute sizes—by default, the corner radius is specified as a percentage of the object and 

scales as the object is resized. When selected, this option allows you to specify the corner 

radius in units. If the object is resized, the corner radius remains the same instead of scaling 

with the object. 

 Radius—sets the radius of the rectangle's rounded corners. 

 Tail height—controls the height of the shape's protrusion relative to the height of the shape. 

 Tail end position—controls the position of the point of the protrusion from left (0%) to right 

(100%), with 50% representing a central point. 

 Tail position—controls the position of the protrusion along the base of the shape from left 

(0%) to right (100%), with 50% representing a central point. 



 Tail width—controls the width of the protrusion along the base of the shape. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Callout: Ellipse Tool 

Create traditional looking callouts and speech bubbles with the Callout Ellipse Tool. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Ellipse Callout Tool has several options on the shape and on the context toolbar to enable the 

size, shape and position of the tail, and the depth of the callout ellipse to be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Absolute sizes—by default, the tail height and end position are specified as a percentage of 

the object and scales as the object is resized. When selected, this option allows you to specify 

these attributes in units. If the object is resized, the tail height and end position remain the 

same instead of scaling with the object. 

 Tail height—controls the height of the shape's protrusion relative to the height of the shape. 

 Tail end position—controls the position of the point of the protrusion from left (0%) to right 

(100%), with 50% representing a central point. 

 Tail angle—controls the width and position of the protrusion along the base of the shape. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 



 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Tear 

The Tear Tool enables you to create many types of tear or droplet shapes quickly and easily. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Tear Tool has several options on the shape and on the context toolbar to enable the ball size, 

curve, tail position and bend to be controlled. 

 

Two possible outcomes when the options are customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Fixed ball size—by default, the elliptical end of the shape scales as the object is resized. 

When selected, a new option allows you to specify a fixed size. 

o Ball size—controls the curvature of the elliptical end of the shape. A value of 0% 

gives the shape a completely flat base. 

 Curve—controls the curvature of the edges which connect the elliptical end of the shape to 

the point. 

 Tail position—controls the position of the point of the shape from left (0%) to right (100%), 

with 50% representing a central point.  

 Bend—controls additional edge curvature (see Curve above). Positive values curve both 

edges to the right (with the left edge affected more), negative values curve both edges to the 

left (with the right edge affected more). 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 



 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Heart Tool 

Create heart shapes with variable lobes with the Heart Tool. 

 

Default shape and handle position (in red) before customization. 

Customization 

The Heart Tool has the option on the shape and on the context toolbar to enable the height of the 

lobes to be controlled. 

 

Two possible outcomes when the option is customized. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Spread—controls the height of the heart's lobes. 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Cat 

Cats are cool. Everyone loves cats, especially the guys here on the Affinity team! So if you need a cat 

to add to your images, the Affinity Cat comes to the rescue! 

 

Customization 

The Affinity Cat shape can't be customized, well, not unless you convert him to curves first. We think 

he's cool enough. 

Activating the Cat shape tool 

To use the Cat shape tool, you must hold the as you open the Shapes flyout. Affinity Cat will be 

available in the list. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Show Rotation Center—displays a movable rotation center about which the shape can be 

rotated. 

 Hide Selection—when selected, the object's selection box is temporarily hidden when 

transforming the object. If this option is off, the selection box remains visible during 

transformation. The selected behavior persists across all objects unless it is manually switched. 

 Reset Selection Box—after reshaping, rotating, or shearing the shape, this option resets 

the selection box to vertical. 

 Convert to Curves—converts the selected object into a series of connected lines and 

nodes. 

  



Text tools. 

Artistic Text Tool 

The Artistic Text Tool allows you to add artistic text to your design. 

Artistic text, as the name suggestions, is best suited to decorative or artistic typographical design. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Font—sets the font of the text. Select from the pop-up menu. 

 Set text size—type directly in the text box or drag the pop-up slider to set the value. 

 Set text format—click to display a pop-up menu with optional formats for the selected font, or 

select Bold, Italic, and/or Underline. 

 Character Style—applies a character style to the selected text. Select from the pop-up menu. 

 Paragraph Style—applies a paragraph style to the selected text or to the paragraph in which 

the caret currently resides. Select from the pop-up menu. 

 Set paragraph alignment—select from Left Align, Center Align, Right Align, or Justified 

(with additional pop-up menu options). 

 Set leading (distance between text baselines)—type directly in the text box or select from the 

pop-up menu. 

 Character—provides access to the Character panel for advanced text settings. 

 Paragraph—provides access to the Paragraph panel for advanced paragraph settings. 

When setting the Leading, specifying a unit of measurement (i.e. mm or inches) will set an Exact 

distance, while specifying a percentage will set a % Height based on the text's font size. 
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Frame Text Tool 

The Frame Text Tool allows you to add a text frame which acts as a container for paragraph text. 

Frame text is best suited to working with text which will be presented in paragraphs with a formalized 

structure and layout. If you want to present text in columns, frame text is the ideal solution. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Font—sets the font of the text. Select from the pop-up menu. 

 Set text size—type directly in the text box or drag the pop-up slider to set the value. 

 Set text format—click to display a pop-up menu with optional formats for the selected font, or 

select Bold, Italic, and/or Underline. 

 Character Style—applies a character style to the selected text. Select from the pop-up menu. 

 Paragraph Style—applies a paragraph style to the selected text or to the paragraph in which 

the caret currently resides. Select from the pop-up menu. 

 Set paragraph alignment—select from Left Align, Center Align, Right Align, or Justified 

(with additional pop-up menu options). 

 Set leading (distance between text baselines)—type directly in the text box or select from the 

pop-up menu. 

 Character—provides access to the Character dialog for advanced text settings. 

 Paragraph—provides access to the Paragraph dialog for advanced paragraph settings. 

When setting the Leading, specifying a unit of measurement (i.e. mm or inches) will set an Exact 

distance, while specifying a percentage will set a % Height based on the text's font size. 
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Warp tools. 

Mesh Warp Tool 

The Mesh Warp Tool allows you to distort an image (or portion of an image) using a highly 

customizable grid comprising of nodes and lines. 

Settings 

The following settings can be adjusted from the context toolbar: 

 Apply—accepts the current warp applied to the image and exits the warp operation. 

 Choose between Destination and Source mode from the pop-up menu. Source mode allows 

you to set default mesh points that can then be restored with Synchronize. 

 Synchronize—restores the original, unwarped image while maintaining any adjusted mesh 

grid. 

 Reset—restores the grid to a uniform rectangular shape. Nodes which have been added are 

distributed evenly across the grid. 

 Hide Mesh—hides/shows the grid. The warp mesh can still be adjusted when hidden 

(indicated by the cursor change). 

 Resampling—select which resampling method (see note below) to use for the warped image. 

 Convert—switches the selected node to Sharp or Smooth. 

Resampling methods 

The following resample settings are available: 

 Bilinear—algorithmic resampling for use when compressing images. 

 Nearest Neighbor—simple resampling which has the fastest processing time. Use for hard-

edge images. 

 Bicubic—algorithmic resampling for use when enlarging images. Bicubic resampling is 

sharper than Bilinear resampling but has a slower processing time. 

  



Perspective Tool 

The Perspective Tool allows you to modify the perspective of your image. It has full History support, 

meaning each modification (such as handle dragging and option toggling) can be undone. 

 

 
Using the Perspective Tool to alter the appearance of a building/structure. 

Settings 

The settings can be adjusted from the pop-up dialog after selecting the tool: 

 Planes—set the number of planes on which perspective can be applied. Select from the pop-

up menu. 

 Mode—set the mode in which the grid will operate. 'Destination' automatically applies 

perspective to the whole image as you adjust the grid. 'Source' lets you size, position and 

shape the grid without affecting the image; you can then apply perspective to the image by 

jumping back to the 'Destination' option and dragging handles. 



 Show Grid—when selected (default), a grid displays over your image to allow you to adjust 

the perspective with precision. If this option is off, only the boundaries of the perspective area 

is displayed. 

 Autoclip—(Available in Dual Plane mode) Specifies whether or not to alter the image beyond 

the boundaries of the perspective grid points. If disabled, the image will look continuous; if 

enabled, the image will have visible seams where the perspective tool has been applied that 

can then be retouched. 

 Before/After—if this option is off (default), your page displays your image with the current 

perspective applied. When selected, your page displays the adjusted and original images 

simultaneously with a sliding divider which can be repositioned and shows 'Before' and 'After'. 

  



Liquify Tools 

The Liquify tools can be used in isolation or combination to allow you to warp an image as 

appropriate. 

The Liquify tools available include:  

Push Forward Tool 

Shifts pixels in the direction of the stroke. 

Push Left Tool* 

Shifts pixels 90° to the left of the stroke direction. This spreads and compresses edges along the 

stroke. 

Twirl Tool* 

Applies a clockwise rotational distortion under the stroke (centered around the middle of the tool 

cursor). If the tool is used in one area multiple times, the strength of the distortion increases. 

Pinch Tool* 

Applies a concave spherical distortion under the stroke. If the tool is used in one area multiple times, 

the strength of the distortion increases. 

Turbulence Tool 

Applies a crumbling distortion under the stroke which compacts some mesh lines together while 

expanding others. If the tool is used in one area multiple times, the strength of the distortion 

increases. 

Mesh Clone Tool 

Paints samples from one part of the mesh onto another. Ideal for applying previously set mesh 

adjustments to another area of the image. (-click sets the sample area.) 

Reconstruct Tool 

Reduces the warp effect applied to an image using the above tools. If the tool is used in one area 

multiple times, the strength of the underlying effect decreases. With the appropriate number of 

applications, the area will return to its original, unwarped state. 

  



Freeze Tool 

Protects areas of the image from any warp effects by applying a mask. 

Thaw Tool 

Allows areas of the image to be warped by removing the current mask. 

Modifier s 

When using the above tools the following modifier s can be used: 

 You can quickly decrease or increase the brush width using the [ or ] s, respectively. 

 The reduces the rate at which the warp effect is applied. 

 For tools marked with an asterisk (*), the switches modes to achieve the opposite warp effect. 

Settings 

Tool settings can be adjusted using the Brush panel. 
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Raw Tools 

The Raw tools allow you to make and modify adjustments applied to an image in Develop Persona. 

The Raw tools available include:  

View Tool 

Used to move the visible portion of your document in the Document view. 

Zoom Tool 

Used to change the zoom level of your page or canvas in the Document view. 

Red Eye Removal Tool 

Quickly fixes the red eye effect in your photos and preserves the detail of the eye. 

Blemish Removal Tool 

Enables you to remove small imperfectionsremove small imperfections from images. 

Overlay Paint Tool 

Allows you to add areas to the selected overlay adjustment. 

Overlay Erase Tool 

Allows you to remove areas of the selected overlay adjustment. 

Overlay Gradient Tool 

Allows you to apply linear, elliptical, or radial graduated opacity to the selected overlay adjustment. 

Crop Tool 

Removes areas of an image to improve composition. 

White Balance Tool 

Automatically sets the White Balance of the image depending on the color of the pixel clicked under 

the tool's cursor or pixels selected by dragging (averaged color). 
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Export tools. 

Slice Tool 

The Slice Tool allows you to create and edit export areas so you can select portions of your page to 

be exported as individual raster images. 

Available in Export Persona only. 

  



32-bit Preview panel 

The 32-bit Preview panel provides configurable exposure and gamma controls to preview the vast 

tonal range of a 32-bit document without tonally modifying it. This is especially useful for floating 

point lossless workflows (e.g., 3D rendering), where edits need to be made to the image without 

sacrificing the available tonal range through tonal compression or adjustments. 

About the 32-bit Preview panel 

The panel options include: 

 Exposure—increases or decreases the preview exposure of the image, allowing you to better 

visualize the highlight or shadow tonal ranges for editing. 

 Gamma—alters the gamma correction value. 

 Display Transform—(OpenColorIO option) allows you to switch between a Linear RGB color 

space, unmanaged, or a display transform to a different color space: 

o ICC Display Transform—transform using the monitor's assigned ICC profile. 

o Unmanaged—no transform is applied. 

o OCIO Display Transform—choose an output profile to preview your document with 

this color space. Generally you want to match this with the display profile of your 

panel (e.g., P3 or Rec.2020 for specifically profiled monitors). 

In order to use the Display Transform options, you must have a valid OpenColorIO configurable file 

and directory defined. See Using OpenColorIO for more information. 

If you intend on tone mapping or tonally modifying your image to compress its tonal range, you will 

likely not need to use this panel. 
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Adjustment panel (Photo Persona only) 

The Adjustment panel allows you to apply color and tonal corrections to your image non-

destructively, i.e., without making permanent changes to the underlying pixels. 

About the Adjustment panel 

The Adjustment panel presents color and tonal adjustments under adjustment type (e.g., HSL Adjust) 

as a series of preset thumbnails. 

 

The Adjustment panel. 

Selecting an adjustment type expands the view to show adjustment thumbnails, with each thumbnail 

applying an adjustment intended for specific uses (e.g., Desaturate); clicking on a thumbnail applies 

that preset.  

The adjustment is added as an adjustment layer to your layer stack. 

As you apply a preset you can fine-tune the preset's settings, optionally creating the modified 

adjustment as a new preset. 

You can also apply an adjustment layer directly from the Layers panel instead of starting from a 

preset. 



Settings 

The following general settings are available from all adjustment dialogs: 

 Delete—closes the dialog and deletes the adjustment layer, removing the adjustment from 

the image. 

 Merge—merges the current adjustment layer with the layer immediately below it in the layer 

order. 

 Add Preset—adds the current adjustment settings as a preset for use with later images and 

projects. 

 Reset—reverts all dialog settings to default. 

 Opacity—how see through the adjustment layer is. 

 Blend mode—changes how the applied pixels interact with existing pixels on the layer below. 

Choose mode type from a pop-up menu. 

Not all adjustments have a dedicated dialog or customizable settings. 

Batch panel 

The Batch panel lists all images that are currently being processed as part of a batch job. The panel 

can be switched on via View>Studio, but has no use outside of previewing the progress of a batch 

job. 

Upon starting a Batch Job, the Batch panel will automatically appear to provide a progress report. 
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Brushes panel (Photo Persona only) 

The Brushes panel hosts a selection of brush presets which can be selected for use with the Paint 

Brush Tool and other brush-based tools. Any custom brushes you design can be saved to your own 

panel categories. ABR Brush files can be imported and will be available in their own separate 

categories. 

About the Brushes panel 

A choice of pre-designed brushes are available as selectable thumbnails. With the brush tool selected, 

the selected thumbnail sets the type of brush to be used. Brushes are arranged in categories. 

 

The Brushes panel. 

The panel displays the following: 

 Category pop-up menu. To display brush thumbnails for the chosen category. 

 Edit. Loads the selected brush, allowing it to be customized and optionally saved as a new 

brush preset. 

 Brush thumbnails for the current category. 

The following options are available from the Panel Preferences menu: 

 Create New Category—adds a new, empty category to the pop-up menu. 

 Rename Category—allows you to rename the currently selected brush category. 

 Delete Category—removes the currently selected brush category. 

 Import Brushes—allows you to import a set of pre-designed brushes, including those in ABR 

format. 

 Export Brushes—allows you to export the currently selected brush category, ready for 

sharing with other users. 



 New Intensity Brush—creates a brush stroke based on the opacity values of a raster image. 

In the pop-up dialog, navigate to and select a file, and click Open. 

 New Round Brush—creates a brush stroke with a soft, feathered edge. 

 New Square Brush—creates a brush stroke with a hard edge. 

 New Image Brush—creates a brush stroke based on an image. In the pop-up dialog, 

navigate to and select a file, and click Open. 

For more information on creating custom brushes, see Creating custom brushes. 
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Channels panel (Photo Persona only) 

The Channels panel displays the color channels and alpha channel for the whole image or selected 

layer. 

The panel also lets you create and manipulate selections from channels and store selections as 

channels. 

About the Channels panel 

As well as the channel information for the image and current layer, you'll also see the: 

 current pixel selection. 

 Mask alpha* 

 Adjustment layer alpha* 

 Live Filter layer alpha* 

 Any stored selections (as spare channels) for future use. 

* When selected in the Layers panel. 

By default, all color channels are visible and editable. 

 

Channels panels showing channel for the image and selected layer (left), plus selected mask 

and stored selections for future use (right). 

  



Settings 

The following options are displayed on the Channels panel: 

 Reset—reverts the channel settings back to default. 

 Channel thumbnail—displays the color channel as a thumbnail. 

 Visible—hides/shows the channel. 

 Editable—protects/makes editable the channel. 

 Toggle Quick Mask—toggles between selection and Quick Mask. 

 Invert—inverts the pixel selection. 

 Delete—removes the saved spare channel from the document. 

More options are available via the context menu (-click) to allow you to: 

 Create selections from channels. 

 Add to, subtract from, and intersect channel with current selection. 

 Retrieve stored selections. 

 Load selections to current layer channel, mask, adjustment layer, or filter layer. 

 Create grayscale layers. 

 Create mask layers. 

 Invert selections, layer channels and masks. 

  



Color panel (Photo Persona only) 

The Color panel is used to choose color for various brush tools and to apply color to the stroke and 

fill of vector shapes, lines, and text. 

A pop-up version of the Color panel may appear when choosing color from within other dialogs. 

About the Color panel 

The Color panel can operate in several color modes—RGB, HSL, CMYK, LAB and Grayscale—and has 

various ways of presenting color options—using sliders, a color wheel (HSL only), or color boxes. Color 

tints can also be applied from within the panel. 

 

Color panel (RGB sliders): (A) Foreground/Background color selectors with color 'none' 

swatch and 'swap' arrow, (B) RGB sliders, (C) RGB spectrum, (D) Opacity/Noise toggle, (E) 

Panel Preferences, (F) Color model selection, (G) Color picker tool and picked color swatch, 

(H) Opacity controls, (I) Noise controls. 

The active color selector is shown at the front of the two color selectors. Choosing a new color will 

apply it to the active color selector. 

For vector shapes, lines and text, the color selector is for stroke and fill color instead of Foreground 

and Background color, respectively. 

The Gradient Tool changes the appearance of the Color panel. Only one color selector swatch is 

shown to represent the color of the currently selected stop on the gradient. 

Using the Color panel 

With the Color panel, colors can be set for use by a tool in just a few clicks. Opacity and noise are 

further color attributes which can be applied. 



To set the color of a selector:  

1. Click the selector you want to apply the color to. It will show at the front of the two color 

selectors. 

2. Do one of the following: 

o Choose a color from the color model's Sliders, Wheel (HSL only), or Boxes. 

o Click the picked color swatch. 

o Click the None swatch to make the color completely transparent (for the tool, fill or 

stroke). 

To switch colors between the selectors:  

 Click the double-headed arrow. The colors switch but the active swatch selector remains the 

same. 

You can switch color selectors by pressing the X . 

To adjust opacity or noise setting:  

1. Select the Opacity/Noise toggle button on the bottom-left of the panel. 

2. Drag the slider to set the value. 

Color selection preferences and color models 

When choosing colors in the Color panel, you can choose from various selection preferences and 

color model values. The color selection preferences are changed in the Panel Preferences menu. 

Depending on the color model selected, you can also choose to work in 8 bit, 16 bit or Percentage 

mode. 

Some of the selection methods allow you to set color using values other than RGB. This doesn't 

change the working color profile of the document, but changes the input values for the colors. 

You can specify color values for RGB, HSL, CMYK and Grayscale depending on the pop-up menu in the 

Color panel. This is not the same as the working color profile. For example, if your working profile is an 

RGB profile, choosing 100% K (black) from the CMYK color model doesn't convert your document to 

CMYK. Instead the color applied will be an RGB approximation of 100% K (black). However, if you 

convert or export the document to a CMYK profile, the 100% K (black) will be honored. 

The following color selection preferences are available from the Panel Preferences menu. 

 Wheel—HSL Color Wheel 

1. Drag on the outer ring to set the hue. 

2. Drag in the triangle to set saturation and lightness. 



 Sliders—RGB, HSL, CMYK, LAB, Grayscale 

1. Select the color mode from the pop-up menu. 

2. (Optional) From the Panel Preferences menu, select 8 bit, 16 bit or Percentage. 

3. Drag sliders or type directly into the value boxes to set the color values. 

 Boxes—Hue, Saturation, Lightness only 

o Hue—Drag on the hue slider to set the hue, drag in the box to set the saturation and 

lightness. 

o Saturation—Drag on the saturation slider to set the saturation, drag in the box to set 

the hue and lightness. 

o Lightness—Drag on the lightness slider to set the lightness, drag in the box to set the 

saturation and hue. 

 Tint 

o Drag the slider to the left or right to increase or decrease the color tint, respectively. 

Using the Color Picker 

The picker lets you sample colors within or outside Affinity Photo, then use them in your design. 

To use the Color Picker:  

1. Drag the Color Picker icon to the color you want to sample. 

2. Click the selector in the Color or Swatches panel you want to apply the color to. 

3. Click the swatch next to the Color Picker to apply the color. 

Saving chosen colors for later use 

Once your color has been chosen and applied to a tool or content, there are several ways to preserve 

this color for later use. 

The following options are available from the Panel Preferences menu. 

 Copy Color to Clipboard as Hex—this calculates the current color's Hex value and adds it to 

the clipboard. This is useful for web developers, to standardize on colors between graphics 

and HTML coding in a web environment. 

 Add Color to Swatch—adds the current color to the currently loaded palette in the Swatches 

panel. 

 Add Chord to Swatch pop-up menu—adds a chord of the current color to the currently 

loaded palette in the Swatches panel. 



Effects panel (Photo Persona only) 

Apply layer effects directly to layer contents using the Effects panel. 

About the Effects panel 

Layer effects can be applied to layer content. These effects are also non-destructive so you can change 

them at any time. 

 

The Effects panel. 

The following controls and effects are available in the panel: 

 Fill Opacity—alters the line and fill opacity of the layer, without altering the opacity of the 

applied layer effect(s). 

 Gaussian Blur—blurs the layer content. 

 Outer Shadow—adds a shadow behind the layer content. 

 Inner Shadow—adds a shadow inside the layer content's edges. 

 Outer Glow—adds a color glow that emanates from outside the layer content's edges. 

 Inner Glow—adds a color glow that emanates from inside the layer content's edges. 

 Outline—adds an outline to the layer content. 

 3D—adds lighting to give a 3D appearance. 



 Bevel/Emboss—adds various combinations of highlights and shadows. 

 Color Overlay—applies a solid color to layer content. 

 Gradient Overlay—applies a linear gradient to layer content. 

More advanced options for each layer effect are available via Layer Effects next to each effect in 

the Effects panel. 

  



EXIF panel 

EXIF information is normally included in photos created on modern digital cameras; it is written into 

the image file automatically and provides a record of camera details, exposure settings, aperture 

settings, author/copyright, and more, from your image. In Affinity Photo, this information is displayed 

in the EXIF panel. 

About the EXIF panel 

The EXIF panel is available from the Photo and Develop Personas; for the former, it can be switched on 

via View>Studio; for the latter, it can be expanded into view by clicking 'EXIF' at the very bottom right 

of your workspace. 

 

The EXIF panel. 

The following panel options are available: 

 EXIF list—The pop-up menu lets you display EXIF data as a 'Summary' list, 'All' data (as 

Key/Value pairings list), or a full 'RAW data' output. 

 Delete EXIF data—Clears all EXIF data from the image. 

  



Gradient Editor (Photo Persona only) 

The Gradient Editor makes it very easy to set up and edit gradients with pinpoint accuracy. 

A gradient that has been applied to a layer object can also be saved for use later on. 

About the Gradient Editor 

When you edit a gradient fill from within the workspace, the Gradient Editor appears, either as a pop-

up panel or as the Gradient Editor dialog. 

Each gradient is made up of two or more color stops. Clicking a stop selects it. The properties of each 

stop—including color and opacity—can be changed individually to create the desired gradient. 

The following options are available: 

 Type—Changes the type of the applied gradient fill. Choose from Linear, Radial, Elliptical, and 

Conical. (Not available in the pop-up panel.) 

 Position—Sets the position of the selected stop (not available for the start and end stop). 

 Mid Point—Changes how gradually the gradient spread changes between the selected stop 

and the stop immediately to its right. At 50% the gradient change is linear. 

 Clr—Changes the color of a selected stop. Click the color thumbnail to show the pop-up color 

panel. 

 Opacity—Sets the transparency of the selected stop. 

 Insert—Inserts a new stop. 

 Copy—Copies the selected stop and its properties. 

 Delete—Deletes the selected stop. 

 Reverse—Reverses the gradient direction. 

To edit a gradient in the Gradient Editor:  

Do any of the following: 

 Click to select a color stop. 

o Click the color thumbnail to show the pop-up color panel, and choose a new color. 

o Change the spread of the gradient by moving the Mid Point, either by dragging the 

vertical bar on the gradient line, or by changing the input values. 

o Change the value for Opacity for the stop. 



 To add a new stop, either click Insert to add a stop half way between two stops, or double-

click on the gradient line. The color and opacity of the stop will be set to the color at that 

point in the gradient spread. 

 To delete an unwanted stop, click to select it, and then click Delete. 

 To duplicate a stop (including all properties), click to select the stop that you want to 

duplicate and click Copy. The new stop will be placed half way between the stop it was copied 

from and the stop to the immediate right. 

Changes made in the Gradient Editor are not reversible using Undo. 

  



Histogram panel 

The Histogram panel shows the distribution of Red, Green, Blue, and Luminance values for the image, 

layer, or current selection. 

About histograms 

The panel gives a valuable 'heads up' of the colors present in your image, which is useful for deciding 

if color or tonal correction is needed. 

 

The Histogram panel showing pixel distribution in an RGB image (showing advanced details). 

In LAB or CMYK color modes, channels for that mode are displayed instead of Red, Green and Blue 

(RGB). 

Color distribution statistics can optionally be presented at the bottom of the panel to provide further 

color information. Your cursor can be moved around the histogram, displaying the pixel count at the 

color level (0-255) your cursor is currently placed at. 

Min/Max inputs can also be presented at the bottom of the panel to constrain or expand the tonal 

range the histogram represents. This is especially useful for unbounded 32-bit documents where you 

may want to either represent more out of range information or clip it further. 

The yellow triangle on the histogram can be clicked to display color distribution levels in finer detail. 

To display specific channels:  

 Select the All Channels pop-up menu, and select a specific channel. 

To show the histogram for a selected layer or selection:  

1. Select a layer or make a selection. 

2. Check Layer or Marquee, respectively. 

Not available in Develop Persona. 

To display histogram statistics and min/max inputs:  

 (Optional) Click Panel Preferences and choose the Advanced option. 



History panel 

The History panel tracks changes and shows each state as a labeled entry in a list. This allows you to 

return to earlier points in time quickly and easily. 

About the History panel 

The History panel shows changes that are applied. The oldest state is the topmost in the list. When 

edits are made, new states are added to the bottom of the list. 

 

The History panel showing the actions that have been carried out on the file. 

If you click on an earlier state and then make a different change, any states that originally came after it 

are deleted. 

A document's history can be saved along with the document, so earlier edits can be returned to even 

if the document is closed and reopened. 

Unless you choose to save the document's history with the document, the undo states listed in the 

History panel are cleared when the document is closed. 

Options 

The following options are available in the panel: 

 Position—points on the slider represent edits made to a document from root (creation or 

opening) on the left to the latest edit on the right. Drag the slider left to undo a change, right 

to redo a change. 

 State—gives a brief description of the edit made to the document. Click a state to jump 

back/forward to that edit. 

 Enable the camera icon preceding an entry to set the chosen source from which the Undo 

Brush Tool can paint back to. 
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Info panel 

The Info panel provides continuous data readings using samplers. These can sample from the current 

position of the cursor or from a placed target position. 

About the Info panel 

The type of data tracked includes: 

 color values (based on a chosen model) 

 total ink level 

 horizontal and vertical position 

 relative height, width, distance and angle 

 document color format and ICC profile 

 memory information 

The panel allows you to sample from under the cursor or by dragging one or more targets to the page 

which lets you measure color at chosen positions. The latter is useful when comparing colors before 

and after applying image adjustments or filters. 

 

The Info panel. 

The Info panel is available from the Photo Persona and can be switched on via View>Studio. 

The following panel options are available for each sampler: 

 Color Model—Sets the color model, or total ink level, to be tracked. Select from the pop-up 

menu. 

 Cursor—Samples data under the current cursor position. 

 Target—Samples data under a placed target on the image. 

To set a target position:  



1. On the sampler, click the target icon. 

2. On the page, drag the red target to a desired location. 

To reset the target position, drag a new target from the panel to replace the existing target. 

To add a new sampler:  

 Click the Panel Preferences menu, and select Add New Sampler from the menu. 

To remove a sampler:  

1. Click to select the sampler. 

The sampler will be highlighted in blue. 

2. Click the Panel Preferences menu, and select Remove Selected Sampler from the menu. 

  



Layers panel (Photo and Export Persona) 

The Layers panel lets you manage your design more easily by assembling layer content onto separate 

layers, each layer being independently controlled. 

About the Layers panel 

Layers are composited together to form your complete design which shows up on your page. 

The panel can be used to build up your design as multiple layers, with each layer devoted to a 

particular facet (e.g., brush strokes, images, adjustments, as well as vector shape, line and text). 

From the Layers panel you can: 

 Create or delete layers 

 Apply blend modes to layers 

 Arrange and reorder layers 

 Select layers 

 Show and hide layers 

 Group layers 

 Lock layers 

 Clip layers 

 Create masks 

 Add layer adjustments, effects, and filters 

 Create export slices (Export Persona only) 



 

The Layers panel, in Photo Persona (left) and Export Persona (right), showing layers in the 

current document. 

The panel displays the following: 

 Opacity—Adjusts opacity of the selected layer(s). 

 Blend Mode—Changes how the applied pixels interact with existing pixels on the layer below. 

Choose mode type from a pop-up menu. 

 Blend Ranges—Click to access a dialog for setting the blend ranges, blend gamma and 

antialiasing settings for the selected layer. 

 Lock/Unlock—Click to lock or unlock selected layers to prevent or allow editing. 

 Expand/Collapse—Click to expand/contract the layer, revealing child layers, or group layer 

to expand the group's content. 

 Layer entry—The created layer, showing a thumbnail of layer contents and the layer name. 

 Hide/Show layer—Uncheck to hide the layer; check to make it visible again. 

 Edit All Layers—Allows selection and editing of layer contents across all layers (rather than 

the current layer). 

 Mask Layer—Creates a layer mask to reveal a portion of a layer while the rest of the layer 

remains hidden. 



 Adjustments—Adds a non-destructive adjustment layer for tonal and color correction. 

 Layer Effects—Applies a layer effect to the currently selected layer. 

 Live Filters—Applies a non-destructive filter layer to add creative effects. 

 Group Layers—Groups the currently selected layers. 

 Add Pixel Layer—Creates an empty new pixel layer above the currently selected layer. 

 Remove Layer—Deletes the currently selected layer. 

 Create Slice—Creates a slice from the layer content in readiness for export. Only shows in 

Export Persona. 

Hidden layers will not print or export. 

  



Library panel 

The Library panel stores macros and allows them to be applied to the current document via a single 

click. Both stock macros and custom saved or imported macros appear in this panel. 

About the Library panel 

The Library panel is available from the Photo Persona; it can be switched on via View>Studio. It is 

also launched automatically when a macro is saved from the Macro panel. 

 

The Library panel showing pre-supplied macros (Default category) and custom macros 

(MyMacros category). 

For more information on how to record, edit and use macros, see Macros. 

Options 

The following options are available in the panel: 

 Category—displays all macros in that category. Click a category's title to collapse or expand 

the category. 

 Search—allows you to narrow down the macros in the panel to those with names which 

conform to the search criteria. Type directly in the text box. 

The following options are available from panel preferences: 

 Create New Category—adds a new, custom macros category to the panel. 

 Import Macros—adds a new category to the panel pre-populated macros. 

The following options are available from the category option menus: 
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 Rename—allows you to rename the category. 

 Delete—removes the category (and all its macros) from the panel. 

 Move Up—repositions the category above the previous category so it is listed higher in the 

panel. If this option is grayed out, the category is at the top of the panel. 

 Move Down—repositions the category below the next category so it is listed lower in the 

panel. If this option is grayed out, the category is at the bottom of the panel. 

 Export Macros—exports all the macros stored in the current category as a single .afmacros 

file. On import, the macro category and individual macros are installed. 

  



Macro panel 

The Macro panel provides a means of recording, saving, importing and exporting macros—a series of 

actions and operations that can be quickly reproduced and applied to speed up and aid workflows. 

About the Macro panel 

The Macro panel is available from the Photo Persona; it can be switched on via View>Studio. 

 

The Macro panel showing a series of recorded actions. 

For more information on how to record, edit and use macros, see Macros. 

Settings 

The following options are displayed on the panel: 

 Start recording—click to record your actions and operations which are added to the panel 

as you record. 

 Stop recording—click to stop recording your macro. 

 Play—click to play back and preview your recorded macro. 

 Reset—click to clear the currently recorded macro operations and actions. Use to start 

recording from scratch again. 

 Add to Library—saves your recorded macro to the macro library. A macro needs to be 

saved or it will be lost on subsequent macro recording. 

 Export—exports your recorded macro to a .afmacro file which can be shared with other 

Affinity Photo users or stored externally from the app. 

 Import—imports a previously exported .afmacro file. 

 Settings—click the cog icon to customize a specific operations's settings for the already 

recorded macro. 
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 Disable/Enable macro operation—Uncheck to exclude the operation from playback; 

check to include it again. 

  



Navigator panel 

The Navigator panel lets you zoom into your design and pan around to view specific areas. You can 

also add, remove and switch between custom view points, which are saved zoom levels and positions. 

 

The Navigator panel with zoom setting of 100%. 

Depending on the zoom level, a view rectangle denotes the area currently visible in the main view. 

To zoom into/or out of your design:  

Do one of the following: 

 Click Zoom In or Zoom Out. 

 Drag the slider to change the zoom level. 

To pan around your design:  

 Drag the view rectangle around in the panel. The main view displays the areas enclosed in the 

view rectangle. 

To add, remove and rename a view point:  

 Click Panel Preferences, then select Advanced. 

 With your desired zoom level and position set, click the cog icon and select Add. 



 To rename the view point, click the cog icon and select Rename. 

 To remove the view point, click the cog icon and select Remove. 

To switch between view points:  

 Click Panel Preferences, then select Advanced. 

 From the pop-up menu, select the view point you wish to move to. The view will automatically 

change. 

 To move between view points sequentially, you can also access Move to Previous View 

Point and Move to Next View Point in the View menu. 

Adding new view points and moving between existing view point functions are mappable to custom 

keyboard shortcuts; see Customizing shortcuts for more information. 
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Scope panel 

The Scope panel provides a variety of charts which allow you to examine the distribution of luminance 

and chrominance in an image, allowing you to judge whether tonal or color correction is needed. It 

can be used as an alternative to, or in combination with, the Histogram panel. 

About the Scope panel 

The charts available on the Scope panel allow you to analyze an image in order to identify areas which 

need correcting. Some of these issues may be subtle to the eye but may dramatically improve a photo 

once corrected. Example issues which may be identified using the Scope panel include tonal problems 

or color casts. 

The Scope panel is available from the Photo and Develop Personas; for the former, it can be switched 

on via View>Studio; for the latter, it can be expanded into view by clicking 'Scope' at the top right of 

your workspace. 

 

The Scope panel displaying the Intensity Waveform for the adjacent photo. 

Available charts 

 Intensity Waveform—displays a scatter plot of the luminance values of pixels in an image. 

The X axis gives the horizontal location of the pixel while the Y axis provides its luminance 

value. 

 RGB Waveform—as with Intensity Waveform, but displays RGB rather than luminance values. 

 RGB Parade—as with Intensity Waveform, but separated into RGB components. 
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 Power Spectral Density—represents the image in the frequency domain. Low frequencies are 

represented as solid lines. High frequencies can be seen as speckles. The color of the 

frequency plot indicates the dominant color tone in the image. 

 

Power Spectral Density: the solid orange line represents the blurrier, low frequency tones of 

the image. The speckled areas represent the high frequencies. The blue and purple color of 

the high frequencies suggests the presence of chrominance noise. 

 Vectorscope—displays a circular chart which monitors an image's color information. 

Saturation is measured from the center outwards from desaturation to full saturation. The 

direction of the pattern indicates the image's hue. 

Settings 

The following settings are available in the panel: 

 Chart—sets the chart currently displayed in the panel. Select from the pop-up menu. 

 Gain—sets the brightness of the points on the waveform displayed in the panel. This does not 

affect pixels in the image. 

  



Sources panel 

The Sources panel provides a means of storing multiple clone sources that you can use in conjunction 

with the Clone Brush and Healing Brush tools. 

About the Sources panel 

The Sources panel is available from the Photo Persona; it can be switched on via View>Studio. 

The panel lets you set up multiple global sources and define the "pickup" area for each source, in 

advance of (or during) cloning, healing, or patching. After a Focus Merge or HDR Merge, the panel will 

also automatically appear. 

 

The Sources panel with clone sources from several documents (showing circled clone 

areas).To add a global clone source and define its clone area:  

1. Open an image, then from the Sources panel, click Add Global Source. 

2. Double-click on the newly created source entry, then hover over the area of your document 

you wish to set as a clone source and click once. 

Global sources can also be added to the panel when using the Clone Brush, Healing Brush or Patch 

tools by clicking Add Global Source on the tool's context toolbar. 

To clone from a clone source:  

1. Ensure you have either the Clone Brush tool or Healing Brush tool selected. 

2. On the Sources panel, make sure the Toggle Source Preview option is disabled. Your current 

document that you wish to edit should be displayed. 

3. Select a source from the Sources panel list. 

4. Hover over your document; you should see a preview of the clone source area. Simply click 

once or click-drag to begin cloning or healing. 
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Settings 

The following settings are available in the Sources panel: 

 Toggle source preview—when enabled, allows you to cycle through and preview each 

source. Disable to return to editing your current document. 

 Add Global Source—Makes the currently active document a global source, which gets added 

to the bottom of the panel. When the source entry is selected and preview is enabled, you 

need to define a source area for that source before it can be used to clone from. 

 Delete Global Source—deletes the currently selected global source. 

  



Stock panel (Photo Persona only) 

The Stock panel provides access to stock photos directly from within Affinity Photo. 

About the Stock panel 

The panel acts as an in-app image browser which connects to one of several photo providers (e.g., 

Shutterstock). You can search the provider's images, browse image thumbnails, add stock images to 

the page and purchase the photo within the panel. 

 

The Stock panel populated with images. 

Settings 

The following settings are available in the panel: 

 Archive—sets the archive currently displayed in the panel. Select from the pop-up menu. 

 Search—type in the box to display images tagged with matching terms. Click the cross to 

remove the search term and display all images. 

 Commercial—when selected, images displayed in the panel are restricted to those which can 

be used for commercial purposes. 

 Model Released—when selected, images displayed in the panel are restricted to those which 

have a valid model release. 

  



Styles panel (Photo Persona only) 

The Styles panel lets you apply pre-designed drag-and-drop styles to vector layers. 

About the Styles panel 

Styles can comprise an individual effect with predefined settings or a combinations of effects that 

complement each other. The Styles panel lets you apply these with one click. 

You can also save any style to the Styles panel for future use. For vector shapes and text, the stroke, 

opacity and other vector properties can be stored. 

 

The Styles panel showing styles in the Default category. 

The panel displays the following: 

 Category pop-up menu. To display style thumbnails for the chosen category. 

 Style thumbnails for the current category. 

 Search—allows you to filter styles in the panel to those with names which conform to the 

search criteria. Type directly in the text box. 

Settings 

The following options are available from the Panel Preferences menu: 

 Add Styles category—creates a new style category that you can save your custom styles into. 

 Remove category—deletes the currently active custom category. 

 Rename category—renames the currently active custom category. 

 Import Styles category—if styles have been previously exported to a file you can import 

them using this option. 

 Export Styles category—exports the current category, and its styles, to a file. 



 Add Style from Selection—if your object is selected, select this option to save the object 

style to the current Styles panel category. 

  



Swatches panel (Photo Persona only) 

The Swatches panel makes it easy to use predefined colors, and also to define, store and reuse your 

own selection of colors. 

About the Swatches panel 

The Swatches panel stores your recently used colors and lets you access a range of predefined 

palettes, each containing solid or gradient fill swatches. These can be selected for use with various 

tools and for applying directly to objects. You can also create and store your own swatches as custom 

color palettes either for the document, application or system-wide. 

As well as accessing various palettes, you can create global, spot, and overprint colors for vector 

content. Your registration color can also be customized. 

The panel contains a search facility for displaying only named swatches which match the typed 

description. 

 

Swatches panel: (A) Foreground/Background color selectors with color 'none' swatch and 

'swap' arrow, (B) Color picker tool and picked color swatch, (C) Category list, (D) Category 

color palette swatches, (E) Search, (F) Panel Preferences, (G) Opacity control, (H) Recently 

used colors, (I) None, Black, Mid-gray and White swatches, (J) Add current color to palette as 

a global color, (K) Add current fill to palette, (L) Registration color, (M) Global color, (N) 

Overprint color, (O) Spot color. 



 

Markings which distinguish specialist color swatches: (A) Global, (B) Overprint, (C) Spot. 

The active color selector is shown at the front of the two color selectors. Choosing a new color will 

apply it to the active color selector. 

For vector shapes, lines and text, the color selector is for stroke and fill color instead of Foreground 

and Background color, respectively. 

The Swatches panel also shows None, Black, Mid-gray and White swatches, recently used colors and 

an opacity control. Swatches are organized into color palettes by category. 

To add a customized registration color for professional printing, click Panel Preferences, then 

select Add Registration Color. 

Preset color palettes (available from the category list pop-up menu) include macOS color palettes 

such as Apple, Web Safe Colors, System, and Crayons. 

Preset color palettes (available from the category list pop-up menu). 

To list swatches by name instead of thumbnail, click Panel Preferences, then select Show as List.  

You can switch color selectors by pressing the X . 

The Gradient Tool changes the appearance of the Swatches panel. Only one color selector swatch 

is shown to represent the color of the currently selected stop on the gradient. 

Hold down the when selecting a swatch to honor the opacity and/or noise already applied to any 

vector shape, line or text (i.e. only the color will update). 

Working with palettes 

The ten most recently used colors are automatically added to the panel on a temporary basis. You can 

permanently store custom colors and gradients that you use most often in any of the palettes or you 

can create custom palettes to host them. 

Although you can add colors to any of the predefined palette categories, we recommend that you 

always create your own.  

The following types of palette exist within Affinity Photo: 

 Document—these palettes are saved within the current document. 

 Application—these palettes are saved within Affinity Photo. These palettes are available to 

any Affinity Photo document. 



 System—these palettes are saved to your operating system. These palettes are available 

within Affinity Photo and other applications installed on your system. 

 PANTONE®—these palettes are based on PANTONE® Colors. These palettes are available to 

any Affinity document. 

Saving and deleting custom color palettes 

To create a new palette:  

 Click Panel Preferences and choose an 'Add Palette' option. 

From Panel Preferences, you can also rename and delete the selected palette. 

To save a color or gradient to a palette:  

1. On the Swatches panel, select a palette from the palette pop-up menu. 

2. Do one of the following: 

o -click an object, then from the pop-up menu, click Add to > Swatches and choose to 

add color from fill, stroke or both. 

o Select Add current color to palette. 

To edit a saved swatch:  

 Double-click a saved swatch. 

To delete a saved swatch:  

 -click the swatch you want to remove and choose Delete Fill from the pop-up menu. 

Generating a palette from document 

You can generate a palette from the colors used throughout your document. 

To generate a palette from document:  

 Click Panel Preferences and choose an option from Create Palette from Document. 

A new palette is created (named after the document) using all the colors currently in the document. 

Generating a palette from an image 

You can generate a palette of colors from any supported image file. 

To generate a palette from an image:  

 Click Panel Preferences and choose Create Palette From Image. 



 From the Create Palette From Image dialog, click Select Image or click-drag an image onto 

the dialog to load it. 

 Change the Number of Colors slider to generate more or fewer colors from the selected 

image. 

 Use the Location option to specify whether the generated palette should be system-wide, 

application-wide, or limited to the current document. You can also add the colors to the 

current active palette too. 

 Click Create to complete the palette generation. 

Sharing custom palettes 

You can also share custom color palettes for use by other Affinity Photo users. 

To export a color palette:  

1. Choose the palette you want to export from the palette pop-up menu. 

2. Click Panel Preferences and choose Export Palette from the menu. 

3. Type a name for the exported file, choose the disk location you want to save it to and click 

Save. 

To import a color palette:  

1. Click Panel Preferences and choose Import Palette from the menu. 

2. Locate the file you want to import and click Open. 

3. (Optional) If the palette you are importing has the same name as an existing palette, choose 

an appropriate action in the dialog. 

The newly imported palette will now be available to choose in the palette pop-up menu. 

Setting default palettes 

Any palette can be set as the default used for specific color formats. For example, you can set RGB/8 

documents to have a different default palette to CMYK/8 documents. 

To set a default palette:  

1. On the Swatches panel, select a palette from the palette pop-up menu. 

2. Click Panel Preferences and choose a color format option from the Set as Default for from 

the pop-up menu. 

  



Text Styles panel 

The Text Styles panel gives you access to all the text styles in your document, allowing you to apply 

them, modify them, delete them or create new ones. 

About the Text Styles panel 

The Text Styles panel shows you which styles are applied to the current selection and gives you the 

option to apply paragraph and character styles at the caret position or to selected text. 

The panel also gives you options for creating new paragraph and character styles, redefining existing 

styles, or deleting them. 

Furthermore, there are options for setting specific text styles as defaults and for importing text styles 

from other projects. 

For more information on using text styles, see Using text styles. 

 

The Text Styles panel displaying default text styles. 

Display preferences 

There are several options, available from panel preferences, which allow you to change how styles are 

displayed in the panel: 

 Show Hierarchical—styles appear nested below styles which they are Based on. 

 Show Samples—when selected (default), a style's appearance mirrors what will be seen on 

the page. If this option is off, styles will all show as plain text. 
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 Sort By Type—when selected (default), paragraph styles are listed first, followed by character 

styles. If this option is off, styles are listed purely in alphabetical order. 

Options 

The following options are available in the panel: 

 Current Formatting—displays the formatting applied to the selected text or at the current 

caret's position. Click the arrow to the left to display overflowing information, if necessary. 

 Reset Formatting—removes overwrites and local formatting from the selected text, 

ensuring it honors the Current Formatting perfectly. 

 Type—specifies whether the text style is a paragraph, character or group type. 

 Text style—displays the name of text styles currently available in the document. 

 Keyboard shortcut—displays the key combination necessary to apply the text style. A shortcut 

must first be applied to a text style. 

 Options menu—provides access to a pop-up menu with creation and editing options. 

 Create Paragraph Style—launches the Edit Text Style dialog ready for creating a new 

paragraph style. 

 Create Character Style—launches the Edit Text Style dialog ready for creating a new 

character style. 

 Create Group Style—launches the Edit Text Style dialog ready for creating a new group 

style. 

 Update Paragraph Style—redefines the current paragraph style to conform with the local 

formatting of the selected text. 

 Update Character Style—redefines the current character style to conform with the local 

formatting of the selected text. 

 Delete Style—removes the selected paragraph or character style from the document and 

any instances of their application. 
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Transform panel 

When selected, layer content can be easily moved, resized and sheared by adjusting the values in the 

Transform panel. 

About the Transform panel 

The Transform panel repositions, sizes, rotates, or shears layer content precisely. All transforms are 

carried out in relation to a defined anchor point—corner, edge midpoint or center—allowing the 

selected transform to be adjusted. 

 

The Transform panel showing settings applied to layer content. 

The following controls are found on the Transform panel: 

 Anchor point selector—transforms are carried out from the selected anchor point. Click on an 

anchor point to select. 

 X—Horizontal position. Increasing the value moves the layer content to the right. 

 Y—Vertical position. Increasing the value moves the layer content down the page. 

 W—Width. Adjusts the layer content's width in relation to the selected anchor point. 

 H—Height. Adjusts the layer content's height in relation to the selected anchor point. 

 Link—When enabled, width and height are adjusted in proportion to each other, 

maintaining the current aspect ratio. When deselected, they can be adjusted independently. 

 R—Rotation. Rotates the layer content by a specified number of degrees in relation to the 

selected anchor point. 

 S—Shear. Shears the layer content by a specified number of degrees in relation to the 

selected anchor point. 

All transform measurements are in relation to the ruler's zero point, and display in the currently set 

measurement units. 

The number of decimal places allowed can be set via Affinity Photo>Preferences>User Interface. 

The number of decimal places allowed can be set via Edit>Preferences>User Interface. 

Instead of adding absolute input values you can enter expressions instead. 



Changing the UI appearance 

Affinity Photo has a dark User Interface. This makes it easier to accurately view and edit the colors in 

your designs. However, you can make the interface darker or lighter if you prefer. 

To change the lightness of the UI:  

1. Choose Affinity Photo>Preferences. 

2. Choose Edit>Preferences. 

3. Click the User Interface label. 

4. Drag the sliders to set the Background Gray Level and/or UI Gamma level. 

  



Preferences 

Preferences comprise a series of miscellaneous options that are applied across your application. They 

can be used to set up your own way of working. 

General options  

 Choose whether to restore the last session when launching application. 

 Choose to open PSDs with editable text objects. 

 Select whether to show or hide file extensions. 

 Choose whether to create SVGs when copying objects for better cross-platform interaction. 

 Choose whether to overwrite imported PSD files when using the Save command, rather than 

creating an *.afdesign file. We recommend reading the warning provided in the dialog before 

selecting this option. 

 Language—Sets the UI language independently of the operating system. Select from the 

pop-up menu. 

Color options  

 You can set up your default RGB, CMYK, Grayscale and LAB color profiles for use in future 

documents. Select from the pop-up menus. 

 Rendering Intent—Choose the rendering intent for your images. Select from the pop-up 

menu. 

 Choose whether to apply black point compensation when opening an image. 

 Choose whether to convert an opened file color space to the working space and also choose 

whether to warn that this has occurred. 

 Choose whether to receive a warning when a working profile is assigned to an unprofiled 

image. 

 Configure OpenColorIO by choosing a configuration file and working directory. See Using 

OpenColorIO for more information. 

 Configure additional OpenEXR document import options. See 32-bit OpenEXR support for 

more information. 

Performance options  

 RAM Usage Limit—allows you to set your preference for optimizing application performance 

for your projects. 

 Disk Usage Warning At—choose the limit at which you are warned about disk usage. 
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 Undo Limit—choose the history length you are able to access. 

 View Quality—choose the way in which the image displays during modifications. Select from 

the pop-up menu. 

 Choose whether to dither gradients, when working on projects, to speed up performance. 

 Choose a clipping option for optimizing performance. 

 File recovery interval—choose the behavior of the application's autosave. 

 Choose whether to use hardware OpenGL and/or only integrated GPU. Try the opposite of the 

default settings if you are experiencing performance issues. 

 Retina Rendering—choose your rendering experience. Select from the pop-up menu. 

o Automatic (Best)—renders as non-retina followed by retina for balanced 

performance and quality. 

o Low quality (Fastest)—renders as non-retina only for highest performance level but 

compromises on quality. 

o High quality (Slowest)—renders as retina only for high quality but may compromise 

performance. 

 Rendering—choose your rendering experience. Select from the pop-up menu. 

o Default—renders using the default method—typically the installed graphics card. 

o Graphics display adapter—the name here varies depending on your graphics card 

and its driver. If you have multiple graphics cards installed you may see more than 

one option here. 

o WARP—use Windows Advanced Rasterization Platform. Try this if you are 

experiencing performance issues with the default option. 

User Interface options  

 Background Gray Level—controls the grayscale level of the page background. 

 UI Gamma—adjusts the contrast of the user interface. 

 Font UI Size—optionally increase the font size of UI text. 

 Tooltip Delay—set the length of time before a tooltip appears when hovering over a UI 

element. 

 Decimal Places for Unit Types—controls the number of decimal places allowable for each 

document measurement unit. 

 Locks (or keeps unlocked) an imported image as a background layer. 



 Choose whether line width (thickness) displays in points or in the document's measurement 

units. 

 Choose whether text is expressed in points or in the document's measurement units. 

 Choose whether the brush cursor display a preview of pixels to be placed. 

 Overlays a cross-hair over the brush cursor for better targeting. 

 Makes icons display in grayscale. 

 Expands layer to reveal selected object entry when object is selected on the page. 

 Choose whether to commit filters if subsequently carrying out a new operation while the 

Apply dialog is still open or whether to receive a prompt to Apply or Discard the filter instead. 

Clicking Apply will always commit the filter, irrespective of the this setting. 

 Choose whether to activate touch bar support. 

Tools options  

 Tool Handle Size—makes selected layer content's bounding box handles and curve nodes 

(and handles) smaller or larger. 

 Choose whether +click displays context menus (alternative to right-click with a multi-button 

mouse). 

 Enable or disable the Force Touch context menu; when enabled, the menu is accessed by a 

strong-press on a Force Touch-compatible trackpad. 

 Choose whether the middle mouse button will allow scrolling or zooming. 

 Move Tool Aspect Constrain—controls the default constraining behavior when resizing 

objects using the Move Tool. Select from the pop-up menu. 

 Create Text with Blend Gamma—controls the default blend gamma applied to text on 

creation. 

 Nudge Distance—sets the amount by which an object is moved when using the arrow keys. 

Select measurement units from the pop-up menu. 

 Modifier Nudge Distance—sets the nudge amount by which an object is moved when using 

the arrow keys along with the . 

 Additional dictionary folder—add an additional folder that you can copy dictionary files 

into. The directory is scanned during start-up and found dictionaries will be added. 

Keyboard Shortcuts options  

 Use these options to define your own keyboard shortcuts. See the Customizing keyboard 

shortcuts topic. 
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Photoshop Plugins options  

 Open Default Folder in Finder—Gain direct access to the default folder which is searched for 

plugins. Plugins can be added to this folder for easy access from the Filters menu. 

 Open Default Folder in Explorer—Gain direct access to the default folder which is searched 

for plugins. Plugins can be added to this folder for easy access from the Filters menu. 

 Add/Remove Plugin Search Folder—adds or removes a folder in which to search or access 

support files to make plugins accessible from the Filters menu. 

 Add/Remove Plugin Support Folder—adds or removes folders that contain supporting files 

for plugins (for example directories containing executables or presets). 

 Authorize Global—authorizes access to supporting plugin files across multiple users and 

further resolves compatibility issues. 

Miscellaneous options  

 Your current Fills, Brushes, Object Styles, User Defaults and Fonts can be reset to factory 

defaults. 

To set preferences:  

 From the Affinity Photo menu, select Preferences. 

 From the Edit menu, select Preferences. 

To navigate to particular preference options, use the arrow keys, pop-up menu or search facility at the 

top of the dialog. 

Apple System Preferences allow you to control elements of the Affinity User interface such as scrollbar 

behavior. 

  



Expressions for field input 

Instead of adding absolute values into input fields, you can add expressions. These allow you create 

new values based on percentages, mathematical symbols, and another field's value. 

The expression or variable presented after the comma can be used as alternative, often shortform, 

versions of the expression or variable. 

Sizing expression examples 

Use when resizing a document or transforming an object via the Transform panel. 

Input Result 

+=20 Increase value by 20. 

-=20 Decrease value by 20. 

*2 Double size. 

/2 Divide by a half. 

50%, *0.5 Decrease by half. 

120%, *1.2 20% bigger. 

Relational expression examples 

Use when resizing a document or transforming an object via the Transform panel. 

Input Result 

w+20 Scales based on addition of other input value. Example entered 

into Height box to set height as width plus 20 pixels. 

w-20 Scales based on subtraction of other input value. Example 

entered into Height box to set height as width minus 20 pixels. 

2*w Scaling based on a multiple of other input value. Example is 

entered into Height box to set height to double the width. 

w/2 Scaling based on a division of other input value. Example 

entered into Height box to set height to half the width. 

Sq(w) Scales based on the square of other input value. Example 

entered into Height box to set height as the square of the width. 



Sqrt(w) Scales based on the square root of other input value. Example 

entered into Height box to set height as the square root of the 

width. 

w^3 Scales based on a power of other input value. Example entered 

into Height box to set height as the width to the power of three. 

12pt / 

x 

Sets the text's x-height to 12pt. 

Mathematical constants 

For general use throughout the user interface. 

Input Constant 

pi, Pi, PI, π For Pi 

phi, Phi, PHI, gr, GR, φ For golden ratio 

root2, rad, rt For Pythagoras’s constant 

e Euler’s constant 

Transform variables 

Use when moving, scaling, rotating or shearing objects via the Transform panel. 

Input Variable 

xposition, x X position 

yposition, y Y position 

width, w Width 

height, h Height 

rotation, r Rotation 

shear, s Shear 

 

  



 

Document variables 

Use when setting dimensions using the New Document or Document Setup dialogs. 

Input Variable 

spreadwidth, w Document width 

spreadheight Document height 

marginleft, l Left document margin 

marginright, r Right document margin 

margintop, t Top document margin 

margin, b Bottom document margin 

Typographical variables 

Use when setting the size of text. 

Input Variable 

xheight, x X-height 

ascent, a Ascent 

capheight, c Cap height 

Transform-Page variables 

Use when sizing and positioning content using the Transform panel in relation to the page (spread). 

spreadwidth, sprw, sw, pw The width of the current spread 

spreadheight, sprh, sh, ph The height of the current spread 

spreadleft, sprl, sl, pl The position of the left edge of the current 

spread 

spreadright, sprr, sr, pr The position of the right edge of the current 

spread 

spreadtop, sprt, st, pt The position of the top edge of the current 

spread 



spreadbottom, sprb, sb, 

pb 

The position of the bottom edge of the 

current spread 

marginsizeleft, mgnszl, 

msl 

The size of the left margin on the current 

spread 

marginsizeright, mgnszr, 

msr 

The size of the right margin on the current 

spread 

marginsizetop, mgnszt, 

mst 

The size of the top margin on the current 

spread 

marginsizebottom, 

mgnszb, msb 

The size of the bottom margin on the 

current spread 

marginleft, mgnl, ml The position of the left margin on the 

current spread 

marginright, mgnr, mr The position of the right margin on the 

current spread 

margintop, mgnt, mt The position of the top margin on the 

current spread 

marginbottom, mgnb, mb The position of the bottom margin on the 

current spread 

designareawidth, 

areawidth, aw 

The space between the left and right 

margins on the current spread 

designareaheight, 

areaheight, ah 

The space between the top and bottom 

margins on the current spread 

Advanced mathematical expressions 

For general use throughout the user interface. 

Input Variable 

Abs(x) Absolute value 

IDiv(x,y) Results in the integer (whole number) of x divided 

by y (no rounding is applied) 

IRem(x,y) Results in the remainder of x divided by y 

Sin(a) Sine 



aSin(a) Inverse Sine 

Cos(a) Cosine 

aCos(a) Inverse Cosine 

Tan(a) Tangent 

aTan(a) Inverse Tangent 

aTan2(a, b) Arctangent 

Min(a, b, ...) Smaller of values 

Max(a, b, ...) Larger of values 

Mid(a, b) Average of a and b 

Average(a, b, ...) Average of arguments 

Lerp(a, b, f) Linear interpolation (a + (b - a) f) 

Clamp(a, lo, hi) a if it is between lo and hi, otherwise lo or hi 

ClampMin(n, min) clamp values below minimum 

ClampMax(n, max) clamp values above maximum 

Round(n) Round to integer 

Roundup(b), ceil(n) Round up to integer 

Rounddown(b), 

floor(n) 

Round down to integer 

Truncate(n) Truncate n places after decimal point. 

Noise(seed / x, y) Generate 1D noise either from a seed or based on 

X/Y input. 

Noise2(seed / x, y) Generate 2D noise either from a seed or based on 

X/Y input. 

Noise3(seed / x, y) Generate 3D noise either from a seed or based on 

X/Y input. 

Noise4(seed / x, y) Generate 4D noise either from a seed or based on 

X/Y input. 



Customizing keyboard shortcuts 

While the default keyboard shortcuts broadly follow industry standards and common use in other 

applications, it's possible to customize your keyboard shortcuts exactly to your liking. 

You can customize shortcuts on an application-wide or on a per-Persona basis. Shortcuts can be 

customized for tools, menu items, panel switch on/off, filters, and tool operations, either being added 

as new shortcuts or replacing existing shortcuts. 

You can optionally save your customized shortcuts to a file (.affshortcuts) that can be shared with 

other users or backed up for safe keeping. 

Available settings are as follows: 

 Persona—The pop-up menu sets the Persona for shortcut customization. 

 UI Element—The pop-up menu displays the menus, commands and operations for the 

currently selected Persona. A Miscellaneous category groups shortcuts for commonly 

performed operations and lets you switch on/off panels via shortcuts. 

 Apply to all—If checked, the shortcut applied to a UI element is shared across every Persona. 

If unchecked, you can uniquely assign a custom shortcut to work just within the currently 

selected Persona in the initial Persona pop-up menu. 

 Ignore Modifier—Lets you create shortcuts using a single letter designation instead of using 

keyboard modifiers. 

 Reset—All customized shortcuts are reset back to default. 

 Clear All Shortcuts—All default and customized shortcuts are removed. 

 Load—Loads a previously saved .affshortcuts file. This will overwrite your current keyboard 

shortcut allocations. 

 Save—Saves the current set of shortcuts to a .affshortcuts file for sharing or backup. 

To assign (re-assign) a keyboard shortcut:  

1. From the Affinity Photo menu, select Preferences. 

2. From the Edit menu, select Preferences. 

3. Select the Keyboard Shortcuts tab. 

4. From the initial two pop-up menus, filter shortcuts by Persona and then by UI Element, 

respectively. 

5. From the lower shortcut list, click in the box (containing empty or existing shortcut) at the end 

of a shortcut entry for the shortcut you want to change. 



6. Press your chosen keyboard key(s) to assign. This adds the new shortcut or overwrites the 

assigned shortcut. 

If your chosen shortcut has already been assigned, a warning triangle ( ) shows next to the shortcut. 

To resolve, assign a different shortcut. 

Some shortcuts show a symbol ( ) next to them. This indicates that the shortcut is shared between 

several tools. Hover over the symbol to see other tools. 

To delete a keyboard shortcut:  

 Click the cross-hair icon at the end of the shortcut entry. 

  



Customizing the workspace 

Each Persona's workspace can be customized to fit your individual way of working. 

To hide/show a panel:  

 From the View menu, click the panel name on the Studio flyout. To show again, click the 

panel name again. 

To hide/show all panels:  

 From the View menu, click Hide Studio on the Studio flyout. To show all panels, click Hide 

Studio again. 

To collapse a panel group:  

 Double-click on the active panel label. 

To expand a panel group:  

 Click on the label of the panel that you want to view. 

To move a panel:  

 Drag the panel label to its new position, either: 

o As a free floating panel. 

o As an item in an existing panel group. 

To resize a panel:  

 Drag any corner of a panel. 

To dock a panel:  

 Drag the panel label to a panel group. 

 Drag the panel label to an area of the studio. A highlight indicates where the panel can be 

docked. 

To move a panel group:  

 Drag the panel group to a new position, either: 

o As a free floating panel group. 

o As new items in an existing group. 

To dock a panel group:  

 Drag the panel group to another panel group. 

 Drag the panel group to an area of the studio. A highlight indicates where the panel can be 

docked. 



To reset the Persona's workspace:  

1. Select the Persona that you want to reset the workspace for. 

2. From the View menu, click Studio > Reset Studio. 

Customizing the Tools panel 

The Tools panel can be docked or floating, on show or hidden, depending on your preference. 

The Tools panel can be customized to fit your individual way of working. By removing tools, you can 

slim down the Tools panel and add available tools when needed. 

To dock/undock the Tools panel:  

 From the View menu, select Dock Tools. 

To show/hide the Tools panel:  

 From the View menu, select Show Tools. 

To remove/or add a tool:  

1. From the View menu, select Customize Tools. 

2. Drag a tool icon from the Tools panel into the flyout, or vice versa. 

3. Click Close. 

To reset the Tools panel:  

1. From the View menu, select Customize Tools. 

2. From the flyout, click Reset. 

The Tools panel is reset back to its default. 

To set the number of columns on the Tools panel:  

1. From the View menu, select Customize Tools. 

2. From the flyout, select from the Number of Columns pop-up menu. 

If the number of columns is two or more, the Tools panel will also display color selectors. These are 

similar to those which appear on the Color panel and Swatches panel. 
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Customizing the Toolbar 

The Toolbar organizes some of the most commonly used commands and functions in each Persona to 

keep them at your fingertips. The Toolbar can be customized to fit your individual way of working. 

To show/hide tool group labels on the Toolbar:  

1. Choose View > Customize Toolbar. 

2. From the dialog's Show pop-up menu, select Icon Only or Icon and Text. 

To hide/show the Toolbar:  

 Choose View > Show Toolbar. 

To customize the Toolbar:  

1. Choose View > Customize Toolbar. 

2. Drag the items from the dialog to the Toolbar. 

3. Remove items by dragging them off the Toolbar and onto your Document view. 

To reset the Toolbar:  

1. Choose View > Customize Toolbar. 

2. Drag the default set strip of tools at the bottom of the dialog to the Toolbar. This will revert 

the Toolbar back to its original settings (removing any custom buttons). 

  



System requirements 

The minimum system requirements are as follows: 

 Intel processor with 64-bit support (Core 2 Duo onwards). 

 2GB RAM 

 601MB of available hard-disk space* 

 1280 x 768 display 

* additional free space required during installation (cannot install on a volume that uses a case-

sensitive file system or on removable flash storage devices). 

Minimum: 

 Windows-based PC with mouse or equivalent input device. 

 Operating systems (64 bit): 

o Windows® 10 

o Windows® 8.x 

o Windows® 7 (Service Pack 1; Aero enabled) 

 PC Memory: 

o 2GB RAM (4GB RAM recommended) 

 Hard Drive Space: 

o 785MB for install (additional space required during installation) 

 Monitor resolution 

o 1024 x 768 (at 100% scaling) 

o 1280 x 960 (at 125% scaling) 

o 1600 x 1024 (at 150% scaling) 

o 1920 x 1440 (at 200% scaling) 

Additional disk resources and memory are required when editing large and/or complex documents. 

Recommended: 

 For optimum performance, it's recommended to ensure Aero support is enabled in your 

Windows Operating System. 

  



Supported file formats 

Affinity Photo is capable of opening many raster and vector file formats. Photo also imports PDF and 

Adobe PSD files, and exports a range of raster file formats and the PSD file format. 

File type Open Export 

Adobe Illustrator (AI) x
1
  

Adobe Freehand (10 and MX) x
2
  

Adobe PhotoShop (PSD) x x 

Adobe PhotoShop (PSB) x  

DNG x  

EPS x x 

GIF x x 

JPEG x x 

J2K,JP2 x  

JPEG-XR/JXR (WDP/HDP) x  

PDF x
1
 x 

PNG x x 

RAW x
3
  

SVG x x 

TGA x  

TIFF x x 

WEBP x  

OpenEXR x x 

Radiance HDR x x 

1
 Multi-page files can be imported, with each page being placed on its own artboard. 

2
 Multi-page Freehand files open with each page concatenated onto a single page. Add file extensions 

.fh10 or .fh11 in Finder to import. Text import is not supported. 

3
 For a comprehensive up-to-date list, see Supported Develop (RAW) cameras. 
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