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IInnttrroodduucciinngg    

CCuussttoommGGuuiiddee    

CCoouurrsseewwaarree  

Thank you for choosing CustomGuide courseware as the 

solution to your training needs. A proven leader in the 

computer training industry, CustomGuide has been the 

key to successful training for thousands of students and 

instructors across the globe. 

This manual is designed for computer users of all 

experience levels. Novice users can use it to learn skills 

such as formatting text, while advanced users can use it to 

create their own templates. 

All this information is quickly accessible. Lessons are 

broken down into basic step-by-step instructions that 

answer “how-to” questions in minutes. You can print a 

complete 300-page training manual or a single page of 

instructions. 

Here’s how a CustomGuide manual is organized: 

Chapters 
Each manual is divided into several chapters. Aren't sure 

if you're ready for a chapter? Look at the table of contents 

that appears at the beginning of each chapter. It will tell 

you the name of each lesson and subtopic included in the 

chapter. 

Lessons 

Each chapter contains lessons on related topics. Each 

lesson explains a new skill or topic and contains an 

exercise and exercise file to give you hands-on-

experience. These skills can also be practiced using 

CustomGuide Online Learning. 

Review 

A review is included at the end of the manual. Use these 

quiz questions and answers to assess how much you've 

learned.  



8 © 2010 CustomGuide, Inc. 

How It Works 

1. Open Microsoft Word 
Our customizable courseware is provided as simple-to-

use, editable Microsoft Word documents—if you can use 

Microsoft Word you can create your own training 

materials in minutes! 

2. Select Your Topics 

Select the content you need from our award-winning 

courseware library. You can even mix and match topics 

between titles, such as Microsoft Outlook and Microsoft 

Word. 

3. Customize 
Arrange topics in the order you want—the courseware 

automatically updates to reflect your changes. Add your 

organization’s name and logo for a professional “in-

house” look. 

4. Print and Distribute 
Print as many copies as you need at your site, without 

paying any per-unit royalties or maintaining physical 

inventories. You can print single-page handouts, a group 

of related lessons, or a complete manual. It’s fast, 

convenient, and very affordable. 

5. Teach and Learn 
You’ll love having your own customized training 

materials, and your users will appreciate the colorful 

illustrations, down-to-earth writing style, and the 

convenience of having a reference guide that they can 

use in or out of the classroom. 

 

3
rd

 Generation Courseware: What’s New? 

CustomGuide is pleased to introduce 3rd generation courseware. Completely redesigned from years of customer feedback, 

3rd generation courseware features a streamlined design that is easier to customize and use as a reference tool. Take a look at 

the table below for more information regarding these features. 

Streamlined design Featuring a professional-looking, easy-to-read design, 3
rd

 generation courseware appeals to 
instructors, students and individual users alike.  

Exercise Notes A new Exercise Notes section appears at the top of each lesson. Rather than practicing the 
topic step by step through the lesson as in 2

nd
 generation courseware, the topic can be 

practiced using the exercise file and exercise described here. 

Table of Contents In addition to the Table of Contents found at the beginning of each courseware title, 3
rd

  
generation courseware includes a Table of Contents at the beginning of each chapter, making 
it even easier to locate the lessons you need. 

Smart Quizzes The Quiz section, located at the back of the book, automatically updates itself when the 
manual is customized. For example, if you remove a lesson regarding cutting and pasting text, 
there will be no questions in the Quiz section that relate to cutting and pasting text. 

Easier customization The design of 3
rd

 generation is simplified, which makes it easier to customize. All you have to 
do is click and drag or copy and paste, or press the <Delete> key to remove a lesson, and 
voila; you’re done! 

Use as a reference tool 3
rd

 generation courseware breaks tasks down into basic step-by-step instructions and can be 
used as a virtual help desk, answering “how-to” questions in minutes. 
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Courseware Features 

 

 
 

 Lessons are presented on one or two pages, so 
you can follow along without wondering when a 
lesson ends and a new one begins. 

 Each lesson includes a hands-on exercise and 
practice file so users can practice the topic of the 
lesson. 

 Clear step-by-step instructions answer “how-to” 
questions. Anything you need to click appears like 

this. 

 Tips let you know more information about a specific 
step or topic as a whole. 

 Whenever there is more than one way to do 
something, the most common method is presented 
in the numbered step, while the alternate methods 
appear beneath. 

 Tables provide summaries of the terms, toolbar 
buttons, and options covered in the lesson. 

 The table of contents, index, tables, figures, and 
quiz questions automatically update to reflect any 
changes you make to the courseware. 

 Icons and pictures show you what to look for as you 
follow the instructions. 

Working with Shapes and Pictures 

 Exercise 

Exercise File: AmericanHistory7-3.docx 

Exercise: Select the header row containing 
the month labels, the Income row, the Total 

Exp. Row, and the Net Inc. row (use the Ctrl 

key to select multiple rows). Create a 2-D 

Clustered Column chart. 

 

 
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Whenever you insert a graphic into a document, it is 

inserted inline with text by default. This means that the 
text in the document moves in order to accommodate the 

graphic. This lesson will show you how to adjust text 

wrapping and how to use the grid to position objects. 

Positioning Pictures 

1.  Double-click the object whose text wrapping you 

wish to adjust. 

2.  Click the Text Wrapping button in the Arrange group. 

3.  Select a text wrapping style from the list. 

The Format contextual tab appears on the Ribbon. 

Horizontal and vertical gridlines appear on the page. 

Tip: Gridlines do NOT appear in the printed 

document. 

Tips 

If you want to use a graphic with other graphics or 

objects, they must be on a drawing canvas. See the 

lesson on Inserting Shapes for more information. 

 

Adjust text wrapping 

To adjust how text reacts to the objects in your documents, 

change the object’s text wrapping. 

A list of text wrapping styles appears. Take a look at 
the Text Wrapping Styles table for a description of 

each style. 

The text wrapping style is applied to the image. 

Other Ways to Adjust Text Wrapping:  
Right-click the image, point to Text Wrapping 

in the contextual menu, and select an option 

from the submenu. 

Other Ways to Display the Grid:  
Press <Shift> + <F9>, or click the Format 

contextual tab on the Ribbon, click the Align 

button in theArrange group, and select View 

Gridlines from the list. 

1.  Click the View tab on the Ribbon. 

2.  Click the Gridlines check box in the Show/Hide group. 

To display/hide the grid 

Just like the graph paper you used to use in geometry 

class, the grid consists of horizontal and vertical lines that 

help you draw and position objects. 

Table 7-2: Text Wrapping Styles 

 
In Line 

with Text 

This places the object at the insertion point in a 

line of text in the document. The object remains 

on the same layer as the text. 

 Square 
Wraps text around all sides of the square 

bounding box for the selected object. 

 Tight 

Wraps text tightly around the edges of the actual 

image (instead of wrapping around the object’s 

bounding box). 

 
Behind 

Text 

This removes text wrapping and puts the object 

behind text in a document The object floats on 

its own layer. 

 
In Front 

of Text 

This removes text wrapping and puts the object 

in front of text in a document. The object floats 

on its own layer. 

 
Top and 

Bottom 

Wraps text around the top and bottom of the 

object, leaving the area to the right and left of 

the object clear. 

 Through 
Similar to the Tight style, this style wraps text 

throughout the image. 

 

Figure 7-3: A document with the grid displayed. 
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Microsoft Excel is a powerful spreadsheet 

program that allows you to make quick 

and accurate numerical calculations and 

helps you to make your data look sharp 

and professional. The uses for Excel are 

limitless: businesses use Excel for 

creating financial reports, scientists use 

Excel for statistical analysis, and families 

use Excel to help manage their investment 

portfolios.  

If you’re moving from Excel 2003 or 

earlier to Excel 2010, you’ll see that 

Excel has undergone a major redesign. 

You’ll still be familiar with much of the 

program’s functionality, but you’ll notice 

a completely new user interface and many 

new features that have been added to 

make using Excel more efficient. 

This chapter is an introduction to working 

with Excel. You’ll learn about the main 

parts of the program screen, how to give 

commands, use help, and about new 

features in Excel 2010. 

 

 

11 
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Starting Excel 2010 

In order to use a program, you must start—or launch—it 

first.  

Windows Vista and Windows 7 

1. Click the Start button. 

The Start menu appears.  

2. Click All Programs. 

The left pane of the Start menu displays the programs 

and menus installed on your computer. 

3. Click Microsoft Office. 

4. Select Microsoft Office Excel 2010. 

The Excel 2010 program screen appears. 

 Other Ways to Launch a Program: 
Click the Start button and type the program name 

in the Search box. Click the program in the search 

results to launch it. 

 Tips 

 If you use Excel 2010 frequently, you might consider 

pinning it to the Start menu. To do this, right-click 

Microsoft Office Excel 2010 in the All Programs 

menu and select Pin to Start Menu. 

 Windows 7 users can also pin a program to the 

taskbar. To do this, right-click the Excel button in the 

taskbar and select Pin this program to taskbar from 

the contextual menu. 

 Exercise 

• Exercise File: None required. 

• Exercise: Start the Microsoft Office Excel 2010 program. 

Figure 1-1: The All Programs menu in Windows 7. 

Program Fundamentals 
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What’s New in Excel 2010 

Excel 2010 is very different from previous versions. The 

table below gives you an overview of what to expect.  

Table 1-1: What’s New in Excel 2010 

Customizable Ribbon The Ribbon makes all the commands needed to work with a program readily available. The Ribbon was 

introduced in Excel 2007, but has been improved in Excel 2010: now you can create your own tabs and 

groups for the Ribbon. You can also rename or change the order of default tabs and groups. 

Backstage View Backstage view is where you open, save, print, share, and manage your files and program options. To 

access Backstage view, click the File tab on the Ribbon. 

Workbook Management Three new tools help you manage, protect, and share your workbooks: Recover previous versions lets 

you revert to an earlier version of your workbook. Protected view helps protect your computer from 

online attacks when opening files from the Internet. The Trusted documents feature remembers which 

files you trust so you aren’t prompted each time the file is opened. 

Paste with Live Preview Allows you to preview how pasted content will look with various paste options before you paste it. 

More Themes and Styles Predefined styles and themes let you change the overall look and feel of a worksheet in just a few clicks. 

Now Office 2010 has even more themes you can apply to your documents. 

Improved Picture-Editing 

Tools 

There are many new ways to edit pictures and images in your documents. 

Insert screen shots: You can take a screen shot or screen clipping and add it to your documents. 

Improved SmartArt: Now you can add SmartArt that uses photographs. 

Other tools: New picture editing tools let you refine the brightness, contrast, or sharpness of a picture; 

add artistic effects; and control cropping and compression. 

Accessibility Checker The Accessibility Checker lets you find and fix issues that can make it difficult for people with 

disabilities to read or interact with your workbook. 

Language Tools Improved language tools let multilingual users set preferences for language settings in Office 2010. 

Better conditional 

formatting 

Conditional formatting allows you to analyze Excel data with just a few clicks. New icon sets and 

formatting options for data bars are available to add to conditional formatting in your documents.  

Improved charts Sparklines are tiny charts that fit within a cell. They are useful for showing a snapshot of your data in a 

small amount of space. 

Expanded charting limits: Now the number of data points in a data series is only limited by available 

memory. 

Double-click to format charts: In Excel 2010, you can instantly access formatting options by double-

clicking a chart element. 

Macro recording for chart elements: You can use the macro recorder to record formatting changes to 

charts and other objects. 

Improved PivotTables PivotTables are easier to use and are more responsive in Excel 2010. Multi-threading to speed up 

performance; the ability to fill down labels; and new search features are some of the enhancements in 

Excel 2010.  

Slicers are a visual way to filter the data in PivotTables. When a slicer is inserted, you use buttons to 

filter the data and display what you need. Slicers also make it easy to see which filters are applied. 

Improved functions Excel 2010 includes a set of more accurate functions for statistics. Some existing functions have also 

been renamed so they better describe what they do. 

Improved filtering A new search filter helps you to find what you need in large worksheets quickly. Search filters can be 

used in tables, PivotTables, and PivotCharts. AutoFilter buttons also remain visible as you scroll down in 

a table. 

Equations in text boxes Excel 2010’s built-in Equation Tools make it easier to write and edit equations by keeping them inside 

text boxes on a worksheet. 

 Exercise 

• Exercise File: None required. 

• Exercise: Review the new features in Microsoft Office 

Excel 2010. 

Program Fundamentals 



  University of Virginia Health System 13 

Understanding the Excel 
Program Screen 

The Excel 2010 program screen may seem confusing and 

overwhelming at first. This lesson will help you become 

familiar with the Excel 2010 program screen as well as 

the new user interface. 

  

 File tab: Contains basic file management commands—such 

as New, Open, Save, and Close—and program options. 
 View buttons: Use these buttons to quickly switch between 

Normal, Page Layout, and Page Break Preview views. 

 Quick Access Toolbar: Contains common commands such 

as Save and Undo. You can add more commands as well.  
 Worksheet tabs: Workbooks have three worksheets by 

default. You can move from one worksheet to another by 

clicking the worksheet tabs. 

 Title bar: Displays the name of the workbook you are 

working on and the name of the program you are using. 
 Status bar: Displays messages and feedback on the current 

state of Excel. Right-click the status bar to configure it. 

 Close button: Click the close button in the Title bar to exit 

the Excel program entirely, or click the close button in the 

Ribbon to close only the current workbook. 

 Name box: Displays the active cell address or object name. 

Click the list arrow to enter formulas. 

 Ribbon: The tabs and groups on the Ribbon replace the 

menus and toolbars found in previous versions of Excel. 
 Row and column headings: Cells are organized and 

referenced by row and column headings (for example, cell 

A1). 

 Scroll bars: Use the vertical and horizontal scroll bars to 

view different parts of the worksheet. 
 Active cell: You can enter or edit data in the active cell. 

 Zoom slider: Click and drag the slider to zoom in or out of a 

window. You can also use the + and – buttons. 
 Formula Bar: Allows you to view, enter, and edit data in the 

active cell. Displays values or formulas in the cell. 

 Exercise Notes 

• Exercise File: None required. 

• Exercise: Understand and experiment with the different 

parts of the Microsoft Office Excel 2010 screen. 

Program Fundamentals 
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Giving Commands 

Excel 2010 provides easy access to commands through 

the Ribbon. The Ribbon keeps commands visible while 

you work instead of hiding them under menus or toolbars. 

Ribbon 

The Ribbon is made up of three basic components: tabs, 

groups, and buttons. It is the primary way to give 

commands in Excel. 

Tabs: Commands are organized into tabs on the Ribbon. 

Each tab contains a different set of commands. There are 

different types of tabs: 

 Command tabs: These tabs appear by default 

whenever you open the Excel program. In Excel 

2010, the Home, Insert, Page Layout, Formulas, 

Data, Review, and View tabs appear by default. 

 Contextual tabs: Contextual tabs appear whenever 

you perform specific task, or when a specific object 

is selected. The tabs offer commands relative to only 

that object or task. For example, whenever you select 

an image, the Picture Tools tab appears on the 

Ribbon.  

Groups: The commands found on each tab are organized 

into groups of related commands. For example, the Font 

group contains commands used for formatting fonts. Click 

the Dialog Box Launcher ( ) in the bottom-right corner 

of a group to display even more commands. Some groups 

also contain galleries that display several formatting 

options. 

 Trap: Based on the size of the program window, 

Excel changes the appearance and layout of the 

commands within the groups. 

Buttons: One way to issue a command is by clicking its 

button on the Ribbon. Buttons are the smallest element of 

the Ribbon. Click a button to give a command. 

 Tips 

 You can hide the Ribbon so that only tab names 

appear, giving you more room in the program 

window. To do this, double-click the currently 

displayed command tab. Or, right-click a Ribbon tab 

and select Minimize Ribbon from the contextual 

menu. To display the Ribbon again, click any tab. 

 Exercise 

• Exercise File: None required. 

• Exercise: Click each tab on the Ribbon to view its 

commands. Click the File tab to view Backstage view.  

Figure 1-2: Elements of the Ribbon. 

Figure 1-3: Hiding the Ribbon gives you more room in the 
program window. 
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File tab 

The File tab appears in the upper-left corner of the 

program window. When clicked, it opens Backstage view, 

which is where you find commands for basic file 

management, including New, which creates a new file; 

Open, which opens an existing file; Save, which saves the 

currently opened file; and Close, which closes the 

currently opened file. This is also where you find 

commands for controlling program options and sharing. 

 Tips 

 The File tab replaces the File menu and Office Button 

found in previous versions of Excel. 

Quick Access Toolbar 

The Quick Access Toolbar appears to the right of the File 

tab and provides easy access to the commands you use 

most frequently. By default, the Save, Undo, and Redo 

buttons appear on the toolbar; however, you can 

customize this toolbar to meet your needs by adding or 

removing buttons. 

Figure 1-4: The Info tab in Backstage view. 

Figure 1-5: The Quick Access Toolbar. 
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Using Command Shortcuts 

Command shortcuts provide other ways to give 

commands in Excel. Shortcuts can be a time-saving and 

efficient alternative to the Ribbon. Use shortcuts for the 

commands you use most frequently.  

Keystroke shortcuts 

Without a doubt, keystroke shortcuts are the fastest way to 

give commands in Excel. They’re especially great for 

issuing common commands, such as saving a workbook. 

In order to issue a command using a keystroke shortcut, 

you simply press a combination of keys on your 

keyboard. For example, rather than clicking the Copy 

button on the Ribbon to copy a cell, you could press and 

hold the copy keystroke shortcut, <Ctrl> + <C>. 

Contextual menus 

A contextual menu displays a list of commands related to 

a specific object or area. To open a contextual menu: 

1. Right-click an object or area of the worksheet or 

program screen. 

A contextual menu appears, displaying commands 

that are relevant to the object or area that you right-

clicked. 

2. Select an option from the contextual menu, or click 

anywhere outside the contextual menu to close it 

without selecting anything. 

Mini Toolbar 

The Mini Toolbar appears when you select text or data 

within a cell or the formula bar, and contains common 

text formatting commands. 

1. Select text or data within a cell or the formula bar. 

The Mini Toolbar appears near the text or data you 

selected. 

 Trap: Sometimes the Mini Toolbar can be hard to 

see due to its transparency. To make the Mini 

Toolbar more visible, point to it. 

 Tip: To close the Mini Toolbar while text is still 

selected, press <Esc>. 

2. Click a button on the Mini Toolbar. 

The command is given in Excel. 

 Exercise 

• Exercise File: None required. 

• Exercise: Memorize some common keystroke shortcuts.  

  Open a contextual menu in the main part of the program 

window. 

Table 1-2: Common Keystroke Shortcuts 

<Ctrl> + <O> Opens a workbook. 

<Ctrl> + <N> Creates a new workbook. 

<Ctrl> + <S> Saves the current workbook. 

<Ctrl> + <P> Prints the worksheet. 

<Ctrl> + <B> Toggles bold font formatting. 

<Ctrl> + <I> Toggles italic font formatting. 

<Ctrl> + <C> Copies the selected cell, text or object. 

<Ctrl> + <X> Cuts the selected cell, text or object. 

<Ctrl> + <V> Pastes the selected cell, text or object. 

<Ctrl> + <Home> Moves the cell pointer to the beginning 

of the worksheet. 

<Ctrl> + <End> Moves the cell pointer to the end of the 

worksheet. 

Figure 1-6: A contextual menu. 

Figure 1-7: The Mini Toolbar. 

Program Fundamentals 
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 Tips 

 If you don’t want the Mini Toolbar to appear every 

time you select text, click the File tab and click 

Options. Click the Personalize category, uncheck the 

Show Mini Toolbar on selection check box, and 

click OK. 

 A larger version of the Mini Toolbar and a contextual 

menu appear when you right-click an object or area 

of the worksheet window. 

Key Tips 

Key Tips appear whenever you press the <Alt> key. You 

can use Key Tips to perform just about any action in 

Excel, without ever having to use the mouse. 

To issue a command using a Key Tip, first press the <Alt> 

key. Tiny letters and numbers, called badges, appear on 

the Quick Access Toolbar, and all of the tabs on the 

Ribbon. Depending on the tab or command you want to 

select, press the letter or number key indicated on the 

badge. Repeat this step as necessary until the desired 

command has been issued. 

Figure 1-8: Press the <Alt> key to display Key Tips. 
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Creating a New Workbook 

 Creating a new workbook is one of the most basic 

commands you need to know in Excel. A new workbook 

automatically appears upon starting Excel, but it’s also 

helpful to know how to create a new workbook within the 

application. You can create a blank new workbook, such 

as the one that appears when you open Excel, or you can 

create a new workbook based on a template. 

Create a new blank workbook 

1. Click the File tab on the Ribbon and select New. 

The New tab of Backstage view appears. By default, 

the Blank Workbook option is already selected. 

2. Make sure the Blank Workbook option is selected 

and click Create. 

The new blank workbook appears in the Excel 

application screen. 

 Other Ways to Create a Blank Workbook: 
Press <Ctrl> + <N>. Or, double-click the Blank 

Workbook option in Backstage view. 

Create a workbook from a template 

1. Click the File tab on the Ribbon and select New. 

The New tab of Backstage view appears. There are 

several ways you can create a new workbook from a 

template.  

 Recent templates: Select a template in the 

Recently Used Templates area and click Create. 

 Sample templates: Click this category to view 

templates that are already installed on your 

computer. Select the template you want to use and 

click Create. 

 My templates: Select My Templates to open a 

dialog box that displays templates you have 

created and saved on your computer. 

 New from existing: Select New from Existing to 

open a dialog box that allows you to browse for a 

workbook on your computer that you want to base 

a new workbook on. This is essentially like 

creating a copy of an existing file. 

 Office.com Templates: Click a category to view 

templates that you can download from Office 

Online. Find the template you want to use and 

click Download. 

 Exercise 

• Exercise File: None required. 

• Exercise: Create a new blank workbook. Then create a 

new workbook from a Microsoft Office Online template. 

Figure 1-9: The New tab of Backstage view. 

Program Fundamentals 
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Opening a Workbook 

Opening a workbook lets you use a workbook that you or 

someone else has previously created and then saved. This 

lesson explains how to open a saved workbook. 

Open a workbook 

You can locate workbook on your computer and simply 

double-click it to open it, but you can also open a 

workbook from within the Excel program. 

1. Click the File tab and select Open. 

The Open dialog box appears. Next, you have to tell 

Excel where the file you want to open is located. 

 Other Ways to Open a Workbook: 
Press <Ctrl> + <O>. 

  2. Navigate to the location of the saved file. 

The Open dialog box has several controls that make it 

easy to navigate to locations and find files on your 

computer:  

 Address bar: Click a location in the Address bar 

to open it. Click the arrow to the right of a 

location to view a list of folders within that 

location. Select a folder from the list to open it. 

 Folders List: Shortcuts to common locations on 

your computer, such as the Desktop and 

Documents library. 

 Search box: This searches the contents—

including subfolders—of that window for the text 

that you type. If a file’s name, file content, tags, or 

other file properties match the searched text, it 

will appear in the search results. Search results 

appear as you enter text in the search box. 

3. Select a file and click Open. 

Excel displays the file in the application window. 

 Tips 

 To open a workbook that has been used recently, 

click the File tab, click Recent, and select a 

workbook from the Recent Workbooks list. 

 You can pin a workbook to the Recent Workbooks 

list so that it is always available there. Click the Pin 

this document to the Recent Workbooks list button 

next to the workbook that you want to always be 

available. Click it again to remove the workbook 

from the Recent Workbooks list. 

 Exercise 

• Exercise File: Sales.xlsx 

• Exercise: Open a workbook. 

Figure 1-10: The Open dialog box. To open a file, you 

must first navigate to the folder where it is saved. Most 
new files are saved in the Documents folder by default. 
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Previewing and Printing a 
Worksheet 

Once you have created a worksheet, and your computer is 

connected to a printer, you can print a copy. Before you 

do this, it’s a good idea to preview how it’s going to look. 

1. Click the File tab on the Ribbon and select Print. 

Notice that the print settings and a preview of the 

document appear together, with print settings on the 

left and a preview on the right.  

 Tip: Use the scroll bar or the page navigation 

controls below the preview to view other pages in 

the document. 

 Other Ways to Preview and Print: 
Press <Ctrl> + <P>. 

After previewing the document, you can specify 

printing options, such as which pages or the number 

of copies to print. 

2. Specify printing options and click the Print button. 

The document is sent to the printer. 

 

 Exercise Notes 

• Exercise File:  Sales.xlsx 

• Exercise: Preview and print the worksheet. 

Figure 1-11: The Print settings and Print Preview as shown in Backstage view. Use the print 

settings in the left column to control how the document is printed. Use the print preview area in 
the right column to preview how the document will look when printed. 

Program Fundamentals 
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Saving a Workbook 

After you’ve created a workbook, you need to save it if 

you want to use it again. Also, if you make changes to a 

workbook you’ll want to save it. You can even save a 

copy of an existing workbook with a new name, to a 

different location, or using a different file type. 

Save a new workbook 

1. Click the Save button on the Quick Access Toolbar.  

The Save As dialog box appears.  

 Other Ways to Save: 
Press <Ctrl> + <S>. Or, click the File tab and 

select Save. 

2. Specify the drive and/or folder where you want to 

save your workbook. 

The Save As dialog box has several controls that 

make it easy to navigate to locations on your 

computer: 

 Address bar: Click a location in the Address bar 

to open it. Click the arrow to the right of a 

location to view a list of folders within that 

location. Select a folder from the list to open it. 

 Folders List: Shortcuts to common locations on 

your computer, such as the Desktop and 

Documents library. 

 Search box: This searches the contents—

including subfolders—of that window for the text 

that you type. If a file’s name, file content, tags, or 

other file properties match the searched text, it 

will appear in the search results. Search results 

appear as you enter text in the search box. 

3. Enter the file name in the File name text box. 

4. Click Save. 

 Exercise Notes 

• Exercise File: None required. 

• Exercise: Create a new workbook and save it with the file 

name “Saved Workbook.” Type your name in cell A1 and 

save the workbook with a new name: “Updated Workbook”. 

Figure 1-12: The Save As dialog box. The Documents 

library is the default location for saving, but you can 
change the save location as necessary. 
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Save workbook changes 

Once you make changes to a workbook you’ve saved 

before, you need to save it again. 

1. Click the Save button on the Quick Access Toolbar. 

Any changes you have made to the workbook are 

saved. 

 Other Ways to Save: 
Press <Ctrl> + <S>. Or, click the File tab and 

select Save. 

Save a workbook under a different name 
and/or location 

You can save another copy of a saved document using a 

new name or in a new location. 

1. Click the File tab and select Save As. 

The Save As dialog box appears. 

2. Enter a different name for the file in the File name 

text box  

Navigate to a new location to save the file as 

necessary. 

3. Click Save. 

Save a workbook as a different file type 

Just as some people can speak several languages, Excel 

can read and write in other file formats, making it easier 

to share information between programs. 

1. Click the File tab and select Save As. 

The Save As dialog box appears. 

2. Click the Save as type list arrow and select a file 

format. 

3. Click Save. 

Table 1-3: Common Excel File Formats 

File Type Description 

Excel Workbook (.xlsx) The default format for Excel 2010 

workbooks. 

Excel Macro-Enabled 

Workbook (.xlsm) 

This file format supports macros 

in Excel 2010. 

Excel 97- Excel 2003 

Workbook (.xls) 

Workbooks in this format can be 

used by all versions of Excel. 

Does not support XML. 

PDF (.pdf) Use this format for files you want 

to share, but do not want to be 

changed.  

Web page (.htm, .html) This format is used to create Web 

pages. 

XML Data (.xml) This file type is used exclusively 

for XML-enabled workbooks. 

CSV (.csv) Use this to share workbook data 

with other programs or lists, such 

as databases. 
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Closing a Workbook 

When you’re done working on a workbook, you need to 

close it. 

1. Click the File tab on the Ribbon and select Close. 

The workbook closes. You can access the file again 

by opening it later. 

  Other Ways to Close a Workbook: 
Press <Ctrl> + <W>. Or, click the Close button 

in the upper right corner of the workbook window 

(do not confuse this with the program Close 

button on the title bar). 

 Tip: If you have multiple workbooks open, 

clicking the active workbook’s Close button only 

closes that one workbook. The other workbooks 

remain open in the window until you click their 

close buttons as well. 

  Trap: The Close button located in the title bar 

closes only the active workbook if there is more 

than workbook open. However, if there is only 

one workbook open, it closes the workbook and 

causes you to exit the Excel program entirely.  

 Exercise Notes 

• Exercise File: Any open workbook. 

• Exercise: Close all open workbooks. 

Figure 1-13: Closing a workbook. 
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Using Help 

When you don’t know how to do something in Excel 

2010, look up your question in the Excel Help files. The 

Excel Help files can answer your questions, offer tips, and 

provide help for all of Excel’s features. 

Search for help 

1. Click the Microsoft Excel Help button ( ) on the 

Ribbon. 

 The Excel Help window appears. 

 Other Ways to Open the Help window: 
Press <F1>. 

2. Type what you want to search for in the “Type words 

to search for” box and press <Enter>. 

 A list of help topics appears. 

3. Click the topic that best answers your question. 

Excel displays information regarding the selected 

topic. 

Browse for help 

1. Click the Microsoft Excel Help button ( ) on the 

Ribbon. 

The Excel Help window appears. 

2. Click the category that you want to browse. 

The topics within the selected category appear. 

3. Click the topic that best answers your question. 

Excel displays information regarding the selected 

topic. 

Choose the Help source 

If you are connected to the Internet, Excel 2010 retrieves 

help from the Office Online database by default. You can 

easily change this to meet your needs.  

1. Click the Search button list arrow in the Excel Help 

window. 

A list of help sources appears. 

2. Select an option from the list. 

Now you can search from that source. 

 

 Exercise 

• Exercise File: None required. 

• Exercise: Search the term “formulas”. Browse topics in 

the “Formulas” category of Help.  

Figure 1-14: The Excel Help window. 
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 Tips 

 Office 2010 offers enhanced ScreenTips for many 

buttons on the Ribbon. You can use these ScreenTips 

to learn more about what a button does and, where 

available, view a keystroke shortcut for the 

command. If you see the message “Press F1 for more 

help”, press <F1> to get more information relative to 

that command. 

 When you are working in a dialog box, click the 

Help button ( ) in the up per right-hand corner to 

get help regarding the commands in the dialog box. 

Table 1-4: Help buttons 

 Back 
Return to the previous help 

topic. 

 Forward 

Return to move forward to the 

next help topic after clicking 

Back. 

 Stop 
Stop the transfer of information 

from the online Help database. 

 Refresh 
Refresh the page to correct page 

layout or get the latest data. 

 
Home 

Click here to return to the Help 

home page. 

 
Print 

Click here to print the current 

help topic. 

 
Change Font Size 

Click here to change the size of 

the text in the Help window. 

 

Show Table of 

Contents 

Click here to browse for help 

using the Table of Contents. 

 
Keep On Top 

Click here to layer the Help 

window so that it appears behind 

all other Microsoft Office 

programs. 

Program Fundamentals 
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Exiting Excel 

When you’re finished using Excel 2010, you should exit 

it. Exiting a program closes it until you need to use it 

again.  

1. Click the File tab.  

2. Click the Exit button.  

The Excel program window closes. 

 Other Ways to Exit Excel: 
If there is only one Excel program window open, 

click the Close button in the title bar. Or, right-

click the Excel button on the taskbar and select 

Close window from the Jump List. 

 Tips 

 Having too many programs open at a time could slow 

down your computer, so it’s a good idea to exit all 

programs that aren’t being used. 

 Exercise 

• Exercise File: None required. 

• Exercise: Exit the Microsoft Office Excel 2010 program. 

Figure 1-15: There are two ways to exit Excel. 
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PPrrooggrraamm  FFuunnddaammeennttaallss  RReevviieeww  

Quiz Questions 

1. Excel automatically opens with Windows. (True or False?) 

2. Which of the following is NOT a new feature in Excel 2010? 
A. Backstage view 
B. Improved picture editing 
C. The Ribbon 
D. Paste with Live Preview 

3. The Ribbon can be hidden so that only tab names appear. (True or False?) 

4. The File tab contains basic file commands. (True or False?) 

5. What is the Quick Access Toolbar? 
A. There are no toolbars in Excel 2010. 
B. What appears when you select text. 
C. A customizable toolbar of common commands that appears above or below the Ribbon. 
D. An extension of the Windows taskbar. 

6. Which of the following is NOT a common keystroke shortcut in Excel? 
A. <Ctrl> + <Alt> + <Delete> 
B. <Ctrl> + <S> 
C. <Ctrl> + <O> 
D. <Ctrl> + <Home> 

7. You can only create a new workbook by launching the Excel program. (True or False?) 

8. To open a workbook, click the File tab and select ______. 
A. Open 
B. Find 
C. Look in 
D. Search 

9. Print settings and print preview appear side by side in Backstage view. (True or False?) 

10. When you save a workbook with a different name, the old workbook is deleted. (True or False?) 

11. You can close a workbook which one of the following ways? 
A. Press <Ctrl> + <C>. 
B. Click and drag the workbook window to the Recycle Bin. 
C. Click the workbook’s Close button. 
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D. Press <Delete>. 

12. What key can you press to get help in Excel? 
A. <Esc> 
B. <Ctrl> + <H> 
C. <F1> 
D. <F11> 

13. Which of the following are ways to exit Excel? (Select all that apply.) 
A. Click the File tab and click Exit Excel. 
B. Click the Office Button and click Close Excel. 
C. Click the Close button on the title bar. 
D. Click the Close button on the Quick Access Toolbar. 

 

Quiz Answers 

1. False. You must start Excel to begin using it. 

2. C. The Ribbon was introduced in Excel 2007, so it is not new in Excel 2010. It has been improved, however, so that it 

is possible to customize tabs and groups on the Ribbon. 

3. True. Double-click a tab to hide the Ribbon, then click any tab to view commands once again. 

4. True. The File tab contains basic file commands, similar to the File menu of previous versions. 

5. C. The Quick Access Toolbar is a customizable toolbar of common commands that appears above or below the 

Ribbon. 

6. A. <Ctrl> + <Alt> + <Delete> is a Windows command, not an Excel command. 

7. False. It's true that a new workbook appears automatically when you open Excel. However, that is not the only way to 

create a new workbook. 

8. A. Select Open and then navigate to the saved file you want to open. 

9. True. In Backstage view, print settings appear alongside a preview of how the document will look when printed. 

10. False. The original workbook remains intact, with its original name. 

11. C. Click the Close button or press <Ctrl> + <W> to close a workbook. 

12. C. Press <F1> to access help in Excel. 

13. A and C. Click the File tab and click Exit, or click the Close button on the title bar. 

 



  University of Virginia Health System 29 

GGeettttiinngg  SSttaarrtteedd  

wwiitthh  

WWoorrkksshheeeettss  

Navigating a Worksheet .................................... 30 

Entering Labels and Values .............................. 31 

Selecting a Cell Range ...................................... 32 

Overview of Formulas ....................................... 33 

Entering Formulas ............................................. 34 

Filling In Content Automatically ....................... 36 
 

This chapter will show you the most basic 

tasks in Excel: entering labels and 

numbers, and entering formulas. 

Using Exercise Files 
This chapter suggests exercises to practice 

the topic of each lesson. There are two 

ways you may follow along with the 

exercise files: 

 Open the exercise file for a lesson, 

perform the lesson exercise, and close 

the exercise file. 

 Open the exercise file for a lesson, 

perform the lesson exercise, and keep 

the file open to perform the remaining 

lesson exercises for the chapter. 

The exercises are written so that you may 

“build upon them”, meaning the exercises 

in a chapter can be performed in 

succession from the first lesson to the last. 

 

22 
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Navigating a Worksheet 

Before you start entering data into a worksheet, you need 

to learn how to move around in one. You must make a cell 

active by selecting it before you can enter information in 

it. You can make a cell active by using: 

 The Mouse: Click any cell with the white cross 

pointer.  

 The Keyboard: Move the cell pointer using the 

keyboard’s arrow keys. 

To help you know where you are in a worksheet, Excel 

displays row headings, indentified by numbers, on the left 

side of the worksheet, and column headings, identified by 

letters, at the top of the worksheet. Each cell in a 

worksheet has its own cell address made from its column 

letter and row number—such as cell A1, A2, B1, B2, etc. 

You can immediately find the address of a cell by looking 

at the Name Box, which shows the current cell address. 

1. Click any cell to make it active. 

The cell address appears in the name box. 

Now that you’re familiar with moving the cell pointer 

with the mouse, try using the keyboard. 

2. Press <Tab>. 

The active cell is one cell to the right of the previous 

cell. Refer to Table 2-1: Navigation Shortcuts for 

more information on navigating shortcuts. 

 Tips 

 Excel 2010 worksheets have 1,048,576 rows and 

16,384 columns! To view the off-screen portions of 

the worksheet, use the scroll bars. 

 Using the <Ctrl> key with arrow keys is very 

powerful. These key combinations jump to the edges 

of data. For example, if you have a group of data in 

columns A-G and another group in columns R-Z, 

<Ctrl> + <  > jumps between each group of data. 

 Exercise Notes 

• Exercise File: Sales2-1.xlsx 

• Exercise: Practice moving around in the worksheet using 

both the mouse and keyboard. 

Figure 2-1: Examples of cell references. 

Table 2-1: Navigation Shortcuts 

Press To Move 

 or <Tab> One cell to the right. 

 or  

<Shift> + <Tab> 

One cell to the left. 

 or  

<Shift> + <Enter> 

One cell up. 

 or <Enter> One cell down. 

<Home> To column A in the current row. 

<Ctrl> + <Home> To the first cell (A1) in the 

worksheet. 

<Ctrl> + <End> To the last cell with data in the 

worksheet. 

<Page Up> Up one screen. 

<Page Down> Down one screen. 

<F5> or  

<Ctrl> + <G> 

Opens the Go To dialog box where 

you can go to a specific cell address. 

Getting Started with Worksheets 

The active cell is in: 
The B column  and 
the 2 row, so its cell 
reference is B2. 
 
 

 A B C 

1 A1 B1 C1 

2 A2 B2 C2 

3 A3 B3 C4 

 

Cells are referenced as A1, 
A2, B1, B2, and so on, with 
the letter representing a 
column and the number 
representing a row. 
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Entering Labels and Values 

Now that you’re familiar with worksheet navigation in 

Excel, you’re ready to start entering data. There are two 

basic types of information you can enter in a cell: 

 Labels: Any information not used in calculations. 

Labels are used for headings in columns and rows, 

and as data in columns and rows. Excel treats cell 

data containing letters or non-numerical punctuation 

as text and automatically left-aligns it inside the cell. 

 Values: Numerical data, including: numbers, 

percentages, fractions, currencies, dates, or times, 

usually used in formulas or calculations. Excel treats 

information that contains numbers, dates or times as a 

value and automatically right-aligns it in the cell.  

 Excel even treats dates as values, makes it possible to 

perform calculations and formulas on the labels. For 

example, you can subtract one date from another to 

find how many days are between them. You can 

control how dates appear with cell formatting. 

1. Select the cell where you want to enter data. 

2. Type the data in the cell. 

3. Press the <Enter> or <Tab> key. 

The cell entry is confirmed and the next cell becomes 

active. 

 Other Ways to Confirm a Cell Entry: 
Click the Enter button on the Formula Bar.  

If the contents do not fit in the cell, the text spills into 

the empty cell to the right. If that cell is not empty, 

Excel truncates the data so only part of it is visible. 

  Tips 

 If you want to start a label with a number, type an 

apostrophe at the beginning of the label. This tells 

Excel that the cell contents are a label, not a value. 

 AutoComplete can help you enter labels. Enter the 

first few characters of a label; Excel displays the 

label if it appeared previously in the column. Press 

<Enter> to accept the entry or resume typing to 

ignore the suggestion. 

 You can reformat dates after entering them. For 

example, if you enter 4/4/12, you can easily reformat 

to April 4, 2012. This is covered in another lesson. 

 Exercise Notes 

• Exercise File:  Sales2-1.xlsx 

• Exercise: Type the label “Sales and Expenses” in cell A1. 

Enter the following labels in cell range A7:A11:  

Supplies, Office, Salaries, Utilities, Total 

 Enter the following values in the cell range D4:F4:  

18500, 16500, 15500 

 Enter today’s date in B13. 

Figure 2-2: A worksheet with labels and values. 

Table 2-2: Examples of Valid Date and Time Entries 

October 17, 2010 5:45 PM 

10/17/10 5:45 AM 

10-17-10 5:45  

(Excel assumes 5:45 AM) 

17-Oct-10 17:45  

(5:45 PM on a 24-hour clock) 

Oct-17  

(Excel assumes the current 

year.) 

17:45:20  

(5:45 PM and 20 seconds) 

Getting Started with Worksheets 

Excel treats dates as values, but 
the dates appear differently in the 
cell in which they are entered.  
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Selecting a Cell Range and 
Entering Data in a Cell Range 

Selecting a cell range 

To work with a range of cells, you need to know how to 

select multiple cells. 

1. Click the first cell you want to select in the cell range 

and hold the mouse button. 

2. Drag to select multiple cells. 

As you drag, the selected cells are highlighted. 

3. Release the mouse button. 

The cell range is selected. 

 Other Ways to Select a Cell Range: 
Select the first cell of the cell range. Press and 

hold the <Shift> key and select the last cell of the 

cell range. 

  Tips 

 To select all the cells in a worksheet, click the Select 

All button where the row and column headers come 

together, or press <Ctrl> + <A>. 

 To select multiple non-adjacent cells, select a cell or 

cell range and hold down the <Ctrl> key while you 

select other cells. 

Entering data in a cell range 

When you have to enter a lot of data, selecting the range 

makes data entry easier and faster. Selecting a range of 

cells restricts the cell pointer so it can only move inside 

the selected range. 

1. Select the range of cells in which you want to enter 

data. 

By selecting a range, you restrict where the cell 

pointer can move and can concentrate on data entry 

instead of moving the cell pointer back and forth. 

2. Enter the data in the first cell. Press <Tab> or 

<Enter> to move on to the next cell. 

When the active cells reaches the end of a column or 

row, the next time your press <Tab> or <Enter>, the 

cell pointer moves to the next cell in the selected 

range. 

3. Click any cell in the worksheet to deselect the range. 

 Exercise Notes 

• Exercise File: Sales2-2.xlsx 

• Exercise: Select the cell range E7:F10 and then enter the 

data below in cell range E7:F10. 

 E F  

7 2500 1500  

8 400 400  

9 7000 7000  

10 3000 3000  

Figure 2-3: Entering text in a selected cell range. 

Table 2-3: Navigating in a Selected Cell Range 

Down <Enter> 

Up <Shift> + <Enter> 

Right <Tab> 

Left <Shift> + <Tab> 

Getting Started with Worksheets 

Click to select the entire 
worksheet. 
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Overview of Formulas and Cell 
References 

This lesson introduces formulas and the different elements 

that are required to write a formula.  

Values 

Values are any numerical data entered in a worksheet. 

Once values are entered in the worksheet, they can be 

used in formulas.  

Formulas  

Formulas are values, but unlike regular values, formulas 

contain information to perform a numerical calculation, 

such as adding, subtracting, or multiplying. A cell with the 

formula =5+3 will display the result of the calculation: 8. 

All formulas must start with an equal sign (=). Then you 

specify more information: the values you want to 

calculate and the arithmetic operator(s) or function 

name(s) you want to use to calculate the values.  

 Operators are the basic symbols used in 

mathematics: + (plus), - (minus), / (divide), * 

(multiply). In Excel, you use these just as you would 

to write out a math problem.  

 Functions are used more often in Excel. Functions 

are pre-made formulas that you can use as shortcuts, 

or to perform calculations that are more complicated.  

Relative and absolute cell references 

Formulas can contain numbers, like 5 or 8, but more often 

they reference the contents of cells. A cell reference tells 

Excel where to look for values you want to use in a 

formula. For example, the formula  =A5+A6 adds the 

values in cells A5 and A6.  

Using cell references is advantageous because if you 

change the values in the referenced cells, the formula 

result automatically updates using the new values. There 

are two types of cell references: relative and absolute.  

 Relative: Relative references refer to cells in relation 

to the cell that contains the formula. When the 

formula is moved, it references new cells based on 

their location relative to the formula. Relative 

references are the default type of references in Excel. 

 Absolute: Absolute references always refer to the 

same cell, even when the formula is copied. Absolute 

references are indicated with dollar signs ($A$1) in 

formulas. Pressing <F4> changes a cell reference to 

absolute. 

 Exercise Notes 

• Exercise File: None required. 

• Exercise: Understand how formulas are used in Excel. 

Getting Started with Worksheets 

Values 
Values in Column A. 

Formulas 
A formula in cell B1 
using the multiplication 
operator. 
The cell displays the 
result of the formula, 
while the Formula Bar 
displays the formula. 

The results of each 
formula are the same 
because each formula 
refers to the same cell. 

Absolute cell reference 
When the formula in cell 
C1 is copied to the rest of 
the cells in column C, the 
cell references are not 
updated. 

Relative cell reference 
When the formula in cell 
B1 is copied to the rest 
of the cells in column B, 
the cell references are 
updated in each row. 

The results of each 
formula are different 
because each formula 
refers to a different cell. 
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Entering Formulas 

This lesson takes a look at how to enter formulas in a cell. 

A formula starts with an equal sign, followed by: 

 Values or cell references joined by an operator.  

Example: =5+3 or  =A1+A2 

 A function name followed by parentheses containing 

function arguments. Functions are the most common 

way to enter formulas in Excel. 

Example: =SUM(A1:A2) 

Enter a formula with an operator 

1. Click a cell where you want to enter a formula. 

2. Type =, then type cell references and operators. 

You can also enter the formula in the Formula Bar. 

3. Press <Enter>. 

The formula calculates the result and displays it in 

the cell where you entered it.  

Enter a formula with a function 

1. Click a cell where you want to enter a formula. 

2. Click the Insert Function button in the Formula Bar. 

If you know the name of the function you want to 

use, you can type it out instead of selecting it from 

the Function button. 

 Other Ways to Enter a Function: 
Click the Formulas tab on the Ribbon and click 

the Insert Function button in the Function 

Library group.  

3. Select the function you want to use and click OK.  

The Function Arguments dialog box appears. 

4. Enter the function arguments and click OK. 

The result of the formula appears in the cell. 

  Tips 

 You can use the Formula AutoComplete feature to 

help you create and edit complex formulas. Type an  

= (equal sign) in a cell or the Formula Bar and start 

typing the formula. A list of functions and names that 

match the text you entered appears. Select an item 

from the list to insert it into the formula. 

 Exercise Notes 

• Exercise File: Sales2-3.xlsx 

• Exercise:  In cell B11, total the values in B7:B10 

 In cell G4, multiply F4 by G2, making G2 an absolute cell 

reference. 

In cell G7, multiply F7 by G2, making G2 an absolute cell 

reference. 

 In cell C11, AutoSum the column C expense values. 

Figure 2-4: Entering a formula in a worksheet. 

Table 2-4: Examples of Operators and Functions 

= All formulas start with an equal sign. 

+ 
   =A1+B1 

- 
   =A1-B1 

* 
   =B1*2 

/ 
   =A1/C2 

SUM 
   =SUM(A1:A3) 

AVERAGE 
   =AVERAGE(A2,B1,C3) 

COUNT 
   =COUNT(A2:C3) 

Getting Started with Worksheets 

The formula of the cell 
is displayed in the 
Formula Bar. 

The value of the formula 
is displayed in the cell. 
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Enter an absolute cell reference in a formula  

1. Enter the formula using operators or functions. 

2. Click the cell you want to reference and press the 

<F4> key. 

Dollar signs $ are added to the cell reference in the 

formula. 

 Other Ways to Add an Absolute Cell Reference 

in a Formula: 
Type the address of the cell with $ (dollar signs) 

before every reference heading. (For example, 

type $B$4). 

Total values automatically with AutoSum 

Adding up the values in a range of cells is the most 

popular formula in Excel, so they’ve made this easy to do 

with the AutoSum feature. AutoSum inserts the SUM 

function (which adds all the values in a range of cells) and 

selects the range of cells Excel thinks you want totaled. 

1. Click a cell next to the column or row of numbers 

you want to sum. 

For example, if you want to add up a column of 

numbers, click the cell at the bottom of the column. 

Or, if you want to add up a row of numbers, click the 

cell to the right of the row. 

2. Click the Home tab and click the AutoSum button in 

the Editing group. 

The SUM function appears in the cell and a moving 

dotted line appears around the cell range that Excel 

thinks you want to sum. If the range is not correct, 

click and drag to select the correct range. 

 Tip: Click the AutoSum button list arrow to 

choose from other common functions, such as 

Average. 

 Other Ways to Enter AutoSum: 
Press <Alt> + <=> . 

3. Press the <Enter> key to confirm the action. 

The cell range is totaled in the cell. If you change a 

value in the summed range, the formula will 

automatically update to show the new sum. 

Figure 2-5: A formula with a relative (F4) and an absolute 
($G$2) cell reference. 

Figure 2-6: AutoSum automatically enters a SUM formula 
and selects the cells it thinks you want to total. 

Getting Started with Worksheets 

AutoSum 
button 
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Entering Content 
Automatically 

Since entering data is a major task in Excel, this lesson 

covers three tools that make are very useful in data entry: 

Fill, AutoComplete, and PickList. 

Use Fill 

Fill is a great way to enter sequential numbers, months or 

days quickly. Fill looks at cells that you have already 

filled in and makes a guess about how you want to fill in 

the rest of the series. For example, if you enter January, 

Fill will fill in the following months for you. You can also 

use Fill to copy formulas to adjacent cells. 

1. Select a cell or cell range that contains the data and 

increment you want to use.  

Excel can detect patterns pretty easily. A series of 1, 

2, 3, 4 is easy to detect, as is 5, 10, 15, 20. It can also 

detect a pattern with mixed numbers and letters, such 

as UPV-3592, UPV-3593, UPV-3594.  

 Tip: If you select only one cell, that same value is 

copied to the adjacent cells when you Fill—unless 

Excel recognizes it as a date or time, in which 

case it will fill in the next logical date or time 

period. 

2. Position the mouse pointer over the fill handle (the 

tiny box in the cell’s lower-right corner) until the 

pointer changes to a plus sign . 

3. Click and drag the fill handle to the cells that you 

want to fill with the information. 

As you click and drag, a screen tip appears 

previewing the value that will be entered in the cell 

once you release the mouse button. 

Table 2-5: Fill Series Examples 

Selected Cell(s) Entries in Next Three Cells 

January February, March, April 

Jan Feb, Mar, Apr 

5:00 6:00, 7:00, 8:00 

Qtr 1 Qtr 2, Qtr 3, Qtr 4 

5 10 15, 20, 25 

1/20/12 1/21/12,  1/22/12,  1/23/12 

UPV-3592 UPV-3593, UPV-3594, UPV-3595 

 Exercise Notes 

• Exercise File: Sales2-4.xlsx 

• Exercise: Fill in the month labels in row 3. Labels should 

start with Jan in column B and end with Jun in column G.  

 Copy the formula in cell G7 to cells G8:G10. Copy the 

formula in cell C11 over to columns D, E, F, and G. 

Figure 2-7: Fill fills in months after January into the 

selected cells. Notice that a screen tip previews the 
content being filled into the cells. 

Figure 2-8: Formulas that are copied with Fill are updated 

relative to their location. This formula copied from C11 is 
updated to use cell references from the D column. 

Getting Started with Worksheets 
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Control fill options 

If Fill doesn’t enter cell content the way you expected, 

you can correct the content using AutoFill Options. This 

button appears after using the Fill command, and it offers 

valuable control over how the Fill command works. 

1. Enter cell content using Fill. 

After releasing the mouse button, the Fill Options 

button appears. 

2. Click the Fill Options button. 

A list of ways you can control the cell content that is 

entered appears. 

3. Select a fill option from the list. 

The cell content is changed according to the fill 

option you chose. 

Repeat values in a column 

Excel’s AutoComplete feature helps speed up data entry, 

especially if you’re using repetitive information. 

1. Type the first few characters of a label. 

Excel displays the label, if it appears previously in 

the column.  

2. Press <Enter>. 

Excel accepts the entry. 

If a suggestion appears and you don’t want to use it, 

resume typing to ignore the suggestion. 

Select contents from a list 

The PickList is a list of data you’ve used and helps keep 

your information consistent. 

1. Right-click the cell where you want to enter a label 

and select Pick from Drop-down List from the 

contextual menu. 

A list appears under the cell. 

2. Select an entry from the list. 

The data is entered and the list disappears. 

Figure 2-9: Click the AutoFill Options button to choose a 

different result of the Fill. 

Getting Started with Worksheets 
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GGeettttiinngg  SSttaarrtteedd  wwiitthh  WWoorrkksshheeeettss  

RReevviieeww  

Quiz Questions 

14. Press ______ to move the cell pointer one cell to the left. 
A. <Enter> 
B. <Shift> + <Tab> 
C. The up arrow key 
D. <Tab> 

15. You can select all the cells in a worksheet at once. (True or False?) 

 

Quiz Answers 

14. B. Pressing <Shift> + <Tab> moves the cell pointer one cell to the left. 

15. True. You can select all cells at once by pressing Ctrl + A. 
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This chapter will show you how to edit 

your Excel worksheets. You’ll learn how 

to edit cell contents; cut, copy and paste 

information; insert and delete columns 

and rows; undo any mistakes you might 

make; and even correct your spelling 

errors. 

Using Exercise Files 
This chapter suggests exercises to practice 

the topic of each lesson. There are two 

ways you may follow along with the 

exercise files: 

 Open the exercise file for a lesson, 

perform the lesson exercise, and close 

the exercise file. 

 Open the exercise file for a lesson, 

perform the lesson exercise, and keep 

the file open to perform the remaining 

lesson exercises for the chapter. 

The exercises are written so that you may 

“build upon them”, meaning the exercises 

in a chapter can be performed in 

succession from the first lesson to the last. 
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Editing Cell Contents 

Once you’ve entered data into a cell, you can edit, clear, 

or replace those cell contents. 

Edit cell contents 

1. Double-click the cell you want to edit. 

The cell is in edit mode.  

In Edit mode, the arrow keys move from character to 

character in the cell instead of from cell to cell. While 

Excel is in Edit mode you can also move the insertion 

point by clicking the I-beam pointer where you want 

to insert text. 

 Other Ways to Enter Edit Mode: 
Select the cell. Click anywhere in the Formula 

Bar, or press <F2>. 

2. Edit the contents of the cell.  

Use the arrow keys and the <Delete> and 

<Backspace> keys to help you edit the cell contents. 

3. Press <Enter>. 

 Other Ways to Edit Cell Contents: 
Select the cell, then edit the cell’s contents in the 

Formula Bar and. Press <Enter> or click the 

Enter button on the Formula bar. 

Replace cell contents 

1. Select the cell. 

2. Enter new data. 

3. Press <Enter>. 

The newly typed information replaces the previous 

cell contents. 

Clear cell contents  

1. Select the cell. 

2. Press <Delete>. 

 Other Ways to Clear Cell Contents: 
Under the Home tab on the Ribbon, click the 

Clear button in the Editing group. 

 Tip: Note that this clears the cell contents, not the 

actual cell.  

 Exercise Notes 

• Exercise File: Mileage3-1.xlsx 

• Exercise: Edit cell A1 so it reads “Mileage Report”. Edit 

cell B3 so it reads “Destination”. Edit C3 to read 

“Beginning”. Edit D3 to read “Ending”. 

 Clear the contents of cells G3:G10. 

 Edit the formula in F4 to use an absolute reference to F2 

instead of the value “0.3”.  

Then copy the formula in F4 to F5:F12. 

Figure 3-1: Clearing cell contents. 

Figure 3-2: Replacing cell contents. 

Editing a Worksheet 

Press 

<Delete> 

Type 
any text 
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Copying and Moving Cells 

You can move or copy information in an Excel worksheet 

by cutting or copying, and then pasting the cell data in a 

new place. You can work with one cell at a time or ranges 

of cells. 

 Tips 

 You may cut, copy, and paste any item in a 

worksheet, such as clip art or a picture, in addition to 

cell data. 

 Copy cells 

When you copy a cell, the selected cell data remains in its 

original location and is added to the Clipboard. 

1. Select the cell(s) you want to copy. 

 Tip: If you want to cut or copy only selected parts 

of a cell’s contents, double-click the cell to 

display a cursor and select the characters you 

want to cut. 

2. Click the Home tab on the Ribbon and click the 

Copy button in the Clipboard group. 

 Other Ways to Copy Cells: 
Press <Ctrl> + <C>. Or, right-click the selection 

and select Copy from the contextual menu. 

3. Select the cell where you want to paste the copied 

content. 

When you select a destination to paste a range of 

cells you only have to designate the first cell where 

you want to paste the cell range. 

4. Click the Home tab on the Ribbon and click the 

Paste button in the Clipboard group. 

The copied cell data is pasted in the new location. 

 Other Ways to Paste Cells: 
Press <Ctrl> + <V>. Or, right-click where you 

want to paste and select Paste from the contextual 

menu. 

 Exercise Notes 

• Exercise File: Mileage3-2.xlsx 

• Exercise: Copy cell B5 and paste it in cell B11.  

Move cells A3:F12 to A9:F18. 

 Using click and drag, move the cells back to A3:F12. 

Figure 3-3: Copying and pasting a cell. 

Editing a Worksheet 

A moving dashed border 
appears around a cell or cell 
range when you cut or copy it. 

The copied content is 
pasted into the new cell. 
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Move cells 

Moving cells typically involves a process of cutting and 

pasting. When you cut a cell, it is removed from its 

original location and placed in a temporary storage area 

called the Clipboard. 

1. Select the cell(s) you want to move. 

2. Click the Home tab on the Ribbon and click the Cut 

button in the Clipboard group. 

A line of marching ants appears around the selected 

cells and the message “Select destination and press 

ENTER or choose Paste” appears on the status bar.  

 Other Ways to Cut Cells: 
Press <Ctrl> + <X>. Or, right-click the selection 

and select Cut from the contextual menu. 

3. Select the cell to which you want to move the cells. 

When you select a destination to paste a range of 

cells, you only have to designate the first cell where 

you want to paste the cell range. 

4. Click the Home tab on the Ribbon and click the 

Paste button in the Clipboard group. 

The copied cell data is pasted in the new location. 

 Other Ways to Paste Cells: 
Press <Ctrl> + <V>. Or, right-click where you 

want to paste and select Paste from the contextual 

menu. Or, select the destination and press 

<Enter>. 

Moving and copying cells using the mouse 

 Using the mouse to move and copy cells is even faster 

and more convenient than using the cut, copy and paste 

commands. 

1. Select the cell(s) you want to move. 

2. Point to the border of the cell or cell range.  

3. Click and hold the mouse button.  

4. Drag the pointer to where you want to move the 

selected cell(s) and then release the mouse button.  

 Tips 

 Press and hold the <Ctrl> key while clicking and 

dragging to copy the selection. 

Figure 3-4: When cells are cut and pasted, they are 

moved to a new location in the worksheet. 

Figure 3-5: Moving a cell range using the mouse. 

Editing a Worksheet 

The screen tip previews the address of 
the cell range as it is moved. 
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Controlling How Cells Are 
Moved or Copied 

You can control how cell content looks or behaves when it 

is pasted. For example, you can keep the data’s 

formatting, or have it take on the formatting properties of 

the destination cells. 

Use Paste Options 

You can control how content is pasted in your 

spreadsheets using the Paste Options in Excel. 

1. Paste the content in the spreadsheet and click the 

Paste Options button. 

The Paste Options button appears in the lower-right 

corner of the pasted content. A list of different ways 

you can paste the content appears.  

 Other Ways to Use Paste Options: 
Before pasting, click the Paste button list arrow in 

the Clipboard group on the Home tab and select a 

paste option from the list. 

 Tip: The options available depend on the type of 

content being pasted. For example, content that 

contains formulas will have more paste options 

than content that contains only text. 

2. Point at a paste option. 

A live preview of how the content will look using 

that paste option appears. 

3. Click a paste option. 

The data is pasted using the selected option. 

Table 3-1: Paste Option Commands 

 Paste Paste using default settings.  Values Paste only values from cells. 

 Formulas Paste only formulas from cells.  Values & Number 

Formatting 

Paste the values and number 

formatting from cells. 

 Formulas & Number 

Formatting 

Paste formulas and number 

formatting. 
 Values & Source 

Formatting 

Paste the values and all formatting 

from source cells. 

 Keep Source Formatting Paste using formatting from the 

original cells. 
 Formatting Paste only the formatting used in 

source cells. 

 No Borders Remove borders from pasted cells.  Paste Link Paste a link to the selected cells. 

 Keep Source  

Column Widths 

Keep the width of the original cells.  Picture Paste a picture of the selected cells. 

 Transpose Flip the data so the rows are flipped 

to columns and vice versa. 
 Linked Picture Paste a picture of the cells with a link 

to the original cells. 

 Exercise Notes 

• Exercise File: Mileage3-3.xlsx 

• Exercise: Use Paste Options to copy the values only from 

E4:E12 to E14:E22. 

 Enter the value 1.25 in cell G4. Use paste special to 

multiply E4:E12 by this value. 

Figure 3-6: The Paste Options button appears after 

pasting so you can specify how data is pasted into your 
worksheet. 

Editing a Worksheet 
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Use Paste Special commands 

You can also control how content is pasted using the Paste 

Special command.  

1. Copy or cut an item as you normally would. 

2. Click the cell where you want to paste the item.  

3. Click the Home tab and click the Paste button list 

arrow in the Clipboard group.  

Now open the Paste Special dialog box. 

4. Select Paste Special. 

The Paste Special dialog box appears. 

 Other Ways to Open Paste Special: 
Press <Ctrl> + <Alt> + <V>. 

5. Select a paste option and click OK. 

The content is pasted into the spreadsheet using the 

selected option. 

6. Press <Enter>. 

The pasted content is deselected. 

Table 3-2: Paste Special Commands 

Paste Option Description 

All Pastes all cell contents and formatting. Same as the Paste command. 

Formulas Pastes only the formulas as entered in the formula bar. 

Values Pastes only the values as displayed in the cells. 

Formats Pastes only cell formatting. Same as using the Format Painter button. 

Comments Pastes only comments attached to the cell. 

Validation Pastes data validation rules for the copied cells to the paste area. 

All using Source theme Pastes all cell contents and formatting, including the theme, if one was applied to the source data. 

All except borders Pastes all cell contents and formatting applied to the copied cell except borders. 

Column widths Pastes only the width of the source cell’s column to the destination cell’s column. 

Formulas and number formats Pastes only the formulas and number formats. 

Values and number formats Pastes only the values and number formats. 

Operation (several options) Specifies which mathematical operation, if any, you want to apply to the copied data.  

Skip blanks Avoids replacing values in your paste area when blank cells occur in the copy area. 

Transpose Changes columns of copied data to rows, and vice versa. 

Paste Link Links the pasted data to the source data by pasting a formula reference to the source data. 

 

Figure 3-7: Paste Special multiplies the value of the 

copied cell (G4) with the values in the selected cell range 
(E4:E12).  

Editing a Worksheet 
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Collecting Items to Move or 
Copy 

If you do a lot of cutting, copying, and pasting you will 

appreciate the Office Clipboard. The Clipboard lets you 

collect multiple cut or copied items at a time, which you 

can then paste as needed. You can even use it to collect 

and paste items from other Office programs.  

1. Click the Home tab on the Ribbon and click the 

Dialog Box Launcher in the Clipboard group. 

The Clipboard task pane appears along the left side of 

the window. 

2. Cut and copy items as you normally would. 

The Clipboard can hold 24 items at a time. As long as 

the Clipboard is open, it collects items that are cut or 

copied from all Office programs. The icon next to 

each item indicates the program the item is from. See 

Table 3-3: Icons in the Clipboard Task Pane for 

examples of some common icons. 

3. Click where you want to paste an item from the 

Clipboard. 

4. Click the item in the Clipboard. 

The item is pasted in the workbook. 

 Tips 

 While the Clipboard is displayed, each cut or copied 

item is saved to the Clipboard. If the Clipboard is not 

displayed, the last cut or copied item is replaced. 

 To remove an item from the Clipboard, click the 

item’s list arrow and select Delete. Click the Clear 

All button in the task pane to remove all items from 

the Clipboard. 

 Exercise Notes 

• Exercise File: Mileage3-4.xlsx 

• Exercise: Display the Clipboard. Copy these cell ranges: 

A6:F6; A10:F10; A12:F12. 

 Paste the copied items in A14, A15, and A16. 

 Close the Clipboard and clear the contents of cells A14:F16. 

Table 3-3: Icons in the Clipboard Task Pane 

 Content cut or copied from Microsoft Excel. 

 Content cut or copied from Microsoft PowerPoint. 

 Content cut or copied from Microsoft Word. 

 Content cut or copied from Microsoft Outlook. 

 Cut or copied graphic object. 

 Web page contents cut or copied from a Web 

browser. 

 Content cut or copied from a program other than 

Microsoft Office. 

Figure 3-8: A worksheet with the Clipboard task pane displayed. 

Editing a Worksheet 

Copied and cut items 
appear in the Clipboard 
task pane. 

Click to control how 
the Clipboard 
operates. 
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Checking Your Spelling 

You can use Excel’s spell checker to find and correct 

spelling errors in your worksheets. To check the spelling 

of a worksheet all at once, use the Spelling dialog box. 

1. Click the Review tab on the Ribbon and click the 

Spelling button in the Proofing group. 

Excel begins checking spelling with the active cell.  

  Tip: Depending on which cell is active when you 

start the spell check, you may see a dialog box 

that asks you if you want to start your spell check 

from the beginning of the sheet. Select Yes. 

 Other Ways to Check Spelling: 
Press <F7>. 

If Excel finds an error, the Spelling dialog box 

appears with the misspelling in the “Not in 

Dictionary” text box. You have several options to 

choose from when the Spelling dialog box opens: 

 Ignore Once: Accepts the spelling and moves on 

to the next spelling error. 

 Ignore All: Accepts the spelling and ignores all 

future occurrences of the word in the worksheet. 

 Add to Dictionary: If a word is not recognized in 

the Microsoft Office Dictionary, it is marked as 

misspelled. This command adds the word to the 

dictionary so it is recognized in the future. 

 Change: Changes the spelling of the word to the 

spelling that is selected in the Suggestions list.  

 Change All: Changes all occurrences of the word 

in the worksheet to the selected spelling.  

 Trap: Exercise caution when using this 

command—you might end up changing 

something you didn’t want to change. 

 AutoCorrect: Changes the spelling of the word to 

the spelling that is selected in the Suggestions list, 

and adds the misspelled word to the AutoCorrect 

list so that Excel will automatically fix it 

whenever you type it in the future. 

2. If the word is spelled incorrectly, select the correct 

spelling from the Suggestions list. Then click 

Change, Change All, or AutoCorrect. If the word is 

spelled correctly, click Ignore Once, Ignore All, 

Add to Dictionary. 

Excel applies the command and moves on to the next 

misspelling. 

 Exercise Notes 

• Exercise File:  Mileage3-5.xlsx 

• Exercise: Run spell check and correct spelling for the 

entire worksheet. 

Figure 3-9: The Spelling dialog box. 

Figure 3-10: This message appears when Excel is 
finished checking the worksheet. 
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Once Excel has finished checking your worksheet for 

spelling errors, a dialog box appears, telling you the 

spelling check is complete. 

3. Click OK. 

The dialog box closes. 

Turn the spell checker on or off 

By default, Excel checks for spelling errors as you type. 

To turn this feature on or off:  

1. Click the File tab on the Ribbon and click the 

Options button. 

The Excel Options dialog box appears. 

2. Click the Proofing tab and click the Check spelling 

as you type check box. 

3. Click OK. 

 Tips 

 The AutoCorrect feature automatically corrects 

commonly misspelled words for you as you type. 

Editing a Worksheet 
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Inserting Cells, Rows, and 
Columns 

While working on a worksheet, you may need to insert 

new cells, columns, or rows. When you insert cells, the 

existing cells shift to make room for the new cells. 

Insert cells 

1. Select the cell or cell range where you want to insert 

cells. 

The number of cells you select is the number of cells 

that will be inserted. 

2. Click the Home tab on the Ribbon and click the 

Insert button list arrow in the Cells group. Select 

Insert Cells.  

The Insert dialog box appears. Here you can tell   

Excel how you want to move the existing cells to 

make room for the new ones by selecting “Shift cells 

right” or “Shift cells down.”  

You can also select “Entire row” or “Entire column” 

in the Insert dialog box to insert an entire row or 

column and not just a cell or cells. 

3. Select the insert option you want to use and click 

OK. 

 The cell(s) are inserted and the existing cells shift.  

 Other Ways to Insert Cells: 
Right-click the selected cell(s) and select Insert 

from the contextual menu. Select an option and 

click OK. 

Insert rows or columns 

1. Select the row heading below or column heading to 

the right of where you want to insert the new row or 

column. 

The number of row or column headings you select is 

the number of row or columns that will be inserted. 

2. Click the Home tab on the Ribbon and click the 

Insert list arrow in the Cells group. Select Insert 

Rows or Insert Columns.  

The row or column is inserted. Existing rows are 

shifted downward, while existing columns are shifted 

to the right. 

 Other Ways to Insert Rows or Columns: 
Right-click a row or column heading and select 

Insert from the contextual menu. 

 Exercise Notes 

• Exercise File:  Mileage3-6.xlsx 

• Exercise: Insert new cells in A2:F2 and shift cells down.  

 Insert news cells in F3:F13 and shift cells to the right. 

 Insert two new rows above row 2. 

Figure 3-11: Existing cells shift down to make room for the 
inserted cells. 

Figure 3-12: The Insert dialog box. 

Editing a Worksheet 

1. Select where you want to insert new cells. 

2. The new cells appear in the selected cell range. 

Click the Insert 
Options button to   
choose settings 
for new cells. 
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Deleting Cells, Rows, and 
Columns 

You can quickly delete existing cells, columns, or rows 

from a worksheet. When you delete cells the existing cells 

shift to fill the space left by the deletion. 

Delete cells 

1. Select the cell(s) you want to delete.  

2. Click the Home tab on the Ribbon and click the 

Delete list arrow in the Cells group. Select Delete 

Cells. 

The Delete dialog box appears. Here you can tell 

Excel how you want to move the remaining cells to 

cover the hole left by the deleted cell(s) by selecting 

“Shift cells left” or “Shift cells up.” 

 Tip: You can also select Entire row or Entire 

column in the Delete dialog box to delete an 

entire row or column. 

3. Select an option and click OK. 

The cell(s) are deleted and the remaining cells are 

shifted. 

 Trap: Pressing the <Delete> key only clears a 

cell’s contents; it doesn’t delete the actual cell. 

 Other Ways to Delete Cells: 
Right-click the selection and select Delete from 

the contextual menu. Select an option and click 

OK. 

Delete rows or columns 

1. Select the row or column heading(s) you want to 

delete. 

2. Click the Home tab on the Ribbon and click the 

Delete button in the Cells group.  

The rows or columns are deleted. Remaining rows 

are shifted up, while remaining columns are shifted to 

the left. 

 Other Ways to Delete Rows or Columns: 
Select the column or row heading(s) you want to 

delete, right-click any of them, and select Delete 

from the contextual menu. Or, click the Delete list 

arrow and select Delete Sheet Rows or Delete 

Sheet Columns. The row or column of the active 

cell is deleted. 

 Exercise Notes 

• Exercise File:  Mileage3-7.xlsx 

• Exercise: Delete rows 2, 3, and 4. 

 Delete cells F2:F12 and shift cells left. 

Figure 3-13: Existing cells shift up to replace deleted cells. 

Figure 3-14: The Delete dialog box. 

Editing a Worksheet 

1. Select rows you want to delete. 

2. The existing cells shift up to replace the deleted rows. 
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Using Undo and Redo 

The undo and redo commands are very useful commands 

for working with cell contents and cell formatting. 

Undo an action 

Undo does just that—it undoes any actions as though they 

never happened. 

1. Click the Undo button on the Quick Access Toolbar.  

Your last action is undone. For example, if you had 

deleted an item and then decided you wanted to keep 

it after all, undo would make it reappear. 

 Other Ways to Undo: 
Press <Ctrl> + <Z>. 

Redo an action 

Redo is the opposite of undo: it redoes an action you have 

undone. For example, if you decide that you do, after all, 

want to delete an item that you have just brought back 

with undo, you can redo the delete action. 

1. Click the Redo button on the Quick Access Toolbar. 

The last action you undid is redone. 

 Other Ways to Redo an Action: 
Press <Ctrl> + <Y>. 

 Tip: Click the Redo button list arrow to redo 

multiple actions. 

Undo or redo multiple actions 

1. Click the Undo button list arrow or Redo button list 

arrow on the Quick Access Toolbar. 

A list of the actions in Excel appears. To undo or redo 

multiple actions, point to the command you want to 

undo or redo.  

For example, to undo the last three actions, point at 

the third action in the list. Each action done before 

the one you select is also undone. 

 Tip: You can undo or redo up to 100 actions in 

Excel, even after saving the workbook. 

2. Click the last action you want to undo or redo in the 

list. 

The command you select and all subsequent actions 

are undone or redone. 

 Exercise Notes 

• Exercise File:  Mileage3-8.xlsx 

• Exercise: Delete the contents of cell A1. Undo the action, 

then redo the action.  

 Enter “.35” in F2. Delete rows 4 and 5. Undo both actions, 

then redo both actions. 

Figure 3-15: Using the Undo command. 

Getting Started with Worksheets 

Undo 
button 

Undo button 
list arrow 

Undo multiple 
actions by selecting 
the actions you wish 
to undo. 
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Finding and Replacing 
Content 

Don’t waste time scanning your worksheet for labels and 

values that you want to replace with something new: 

Excel’s find and replace commands can do this for you 

with just a few clicks of your mouse. 

Find 

The Find feature makes it very easy to find specific words 

and values in a worksheet. 

1. Click the Home tab on the Ribbon and click the Find 

& Select button in the Editing group. Select Find 

from the list. 

The Find tab of the Find and Replace dialog box 

appears. 

 Other Ways to Find Text: 
Press <Ctrl> + <F>. 

2. Type the text or value you want to find in the “Find 

what” text box. 

3. Click the Find Next button. 

Excel jumps to the first occurrence of the word, 

phrase, or value that you entered. 

4. Click the Find Next button again to move on to other 

occurrences. When you’re finished, click Close. 

Replace 

Replace finds specific words and values, and then 

replaces them with something else. 

1. Click the Home tab on the Ribbon and click the Find 

& Select button in the Editing group. Select Replace 

from the list. 

The Replace tab of the Find and Replace dialog box 

appears. 

 Other Ways to Replace Text: 
Press <Ctrl> + <H>. 

2. Type the text or value you want replace in the “Find 

what” text box. 

3. Type the replacement text or value in the “Replace 

with” text box. 

 Exercise Notes 

• Exercise File:  Mileage3-9.xlsx 

• Exercise: Find all instances of “Minneapolis” in the 

worksheet. 

 Replace all instances of “Mankato” with “Blaine”. 

Figure 3-16: Opening the Find and Replace dialog box. 

Figure 3-17: The Find tab of the Find and Replace dialog 
box. 

Figure 3-18: The Replace tab of the Find and Replace 

dialog box. 

Editing a Worksheet 
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4. Click the Find Next button. 

Excel jumps to the first occurrence of the word, 

phrase, or value in the “Find what” box. 

5. Choose how you want to replace the text: 

 Replace: Click to replace the current item. 

 Replace All: Click to replace each item found in 

the document. Use this command with caution: 

you might replace something you didn’t want to 

replace. 

6. Click Close. 

Search options 

Use Excel’s search options to change how Excel searches 

in the document.  

1. Click the More button in the Find and Replace dialog 

box to specify how to search for data. 

Table 3-4: Find and Replace Search Options 

describes the Search Options available under the Find 

and Replace tabs. 

 Trap: If you specify Search Options, make sure to 

turn them off when you are finished. Otherwise, 

subsequent find or replace commands will use the 

same search options. 

Table 3-4: Find and Replace Search Options 

Within Choose whether to search within just the current sheet or the entire workbook. 

Search Search by rows (left to right, then top to bottom) or columns (top to bottom, then left to right). 

Look in Specify which kinds of data you want to search in, such as formulas, values, or comments. 

Match case Searches exactly as text is typed in the text box. 

Match entire cell contents Searches only for cells that match the contents in the text box entirely. Parts of phrases or words are 

not included. 

Format button Specify formatting characteristics you want to find attached to the text in the Find what text box. 

 

Figure 3-19: The Find and Replace dialog box with search 
options displayed. 

Editing a Worksheet 
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Adding Comments to Cells 

Sometimes you may need to add notes to a workbook to 

document complicated formulas or questionable values, 

or to leave a comment for another user. Excel’s cell 

comments command helps you document your 

worksheets and make them easier to understand. Think of 

cell comments as Post-It Notes that you can attach to any 

cell. Cell comments appear whenever you point at the cell 

they’re attached to. 

Insert a comment  

1. Click the cell you want to attach a comment to. 

2. Click the Review tab on the Ribbon and click the 

New Comment button in the Comments group. 

3. Type a comment. 

4. Click outside the comment area when you’re 

finished. 

 Other Ways to Insert a Comment: 
Right-click the cell you want to attach a comment 

to and select New Comment from the contextual 

menu. Type a comment. 

View a comment 

1. Point to the red triangle-shaped comment marker 

that’s located in the cell with the comment. 

 Tip: To display a comment all the time, click the 

cell with the comment, then click the Review tab 

on the Ribbon and click the Show/Hide 

Comments button in the Comments group. Or, 

click the Show All Comments button in the 

Comments group to display all the comments in a 

worksheet at once. 

Edit a comment 

1. Click the cell that contains the comment you want to 

edit. 

2. Click the Review tab on the Ribbon and click the 

Edit Comment button in the Comments group. 

3. Edit the comment. 

You can change the size of a comment text box by 

clicking and dragging one of the eight sizing handles 

that surrounds the comment. 

 Exercise Notes 

• Exercise File:  Mileage3-10.xlsx 

• Exercise: Add a comment to cell A10 that reads, “This 

date may be incorrect.”  

 View the comment. 

 Edit the comment to add the sentence, “Would you please 

check my receipts to verify this?” 

 Delete the comment. 

Figure 3-20: Cells with comments have a red comment 
indicator in the upper right corner of the cell. 

Editing a Worksheet 

Comment text box 

Resize handle 
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4. Click outside the comment area when you’re 

finished. 

 Other Ways to Edit a Comment: 
Right-click the cell with the comment you want to 

edit and select Edit Comment from the 

contextual menu. Edit the comment. 

Delete a comment 

1. Click the cell that contains the comment you want to 

delete. 

2. Click the Review tab on the Ribbon and click the 

Delete button in the Comments group. 

 Other Ways to Delete a Comment: 
Right-click the cell you want to delete and select 

Delete Comment from the contextual menu. 

Editing a Worksheet 
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Quiz Questions 

16. You can replace cell contents by typing over the current contents. (True or False?) 

17. To copy cells using the mouse, press and hold the _____ key while clicking and dragging the selection. 
A. <Alt> 
B. <Ctrl> 
C. <Shift> 
D. <F4> 

18. The Paste Options button appears after pasting cells in Excel. (True or False?) 

19. With the Paste Special command, you can choose to paste only ________. 
A. values 
B. formulas 
C. cell comments 
D. All of these are correct. 

20. The Office Clipboard is available in other Office programs besides Excel. (True or False?) 

21. Which button should you click to leave misspelled text alone and move to the next questionable word? 
A. Ignore Once 
B. Ignore All 
C. Add to Dictionary 
D. Change 

22. When you insert a row, the existing rows are shifted in which direction? 
A. Left 
B. Upward 
C. Downward 
D. Right 

23. Pressing the <Delete> key deletes the selected cell and its contents. (True or False?) 

24. You can undo multiple actions in Excel. (True or False?) 

25. To access the find and replace commands, click the Find & Select button in the _______ group on the Home tab. 
A. Editing 
B. Cells 
C. Number 
D. Clipboard 
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26. You can delete a cell comment, but you can’t edit one. (True or False?) 

 

Quiz Answers 

16. True. Simply click a cell and type to replace its contents. 

17. B. Press and hold the <Ctrl> key to copy cells using the mouse. 

18. True. The Paste Options button appears after pasting cells in Excel. 

19. D. You can use the Paste Special command to paste any of these elements. 

20. True. The Office Clipboard can be used in all Office programs. 

21. A. Click the Ignore Once button to leave text alone and move to the next questionable word. 

22. C. The existing rows are shifted downward when you insert a row. 

23. False. Pressing the <Delete> key only deletes the cell’s contents. 

24. True. You can undo multiple actions in Excel. 

25. A. Editing 

26. False. You can edit or delete a cell comment. 
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You probably have a few colleagues that 

dazzle everyone at meetings with their 

sharp-looking worksheets that use 

colorful fonts and borders.  

This chapter explains how to format a 

worksheet to make it more visually 

attractive and easier to read.  

You will learn how to change the 

appearance, size, and color of text and 

how to align text inside a cell. You will 

learn how to add borders and shading and 

how to use cell styles, as well as many 

other tools that will help your worksheets 

look more organized and professional. 

Using Exercise Files 
This chapter suggests exercises to practice 

the topic of each lesson. There are two 

ways you may follow along with the 

exercise files: 

 Open the exercise file for a lesson, 

perform the lesson exercise, and close 

the exercise file. 

 Open the exercise file for a lesson, 

perform the lesson exercise, and keep 

the file open to perform the remaining 

lesson exercises for the chapter. 

The exercises are written so that you may 

“build upon them”, meaning the exercises 

in a chapter can be performed in 

succession from the first lesson to the last. 

 

44  
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Formatting Text 

You can emphasize text in a worksheet by making the text 

darker and heavier (bold), slanted (italics), or in a 

different typeface (font). The Font group on the Home tab 

makes it easy to apply character formatting. 

1. Click the cell(s) with the label you want to format. 

2. Click the Home tab on the Ribbon and click a 

formatting button in the Font group. 

The text is formatted. 

 Other Ways to Format Text: 
Right-click the cell(s) you want to format. Click a 

formatting button on the Mini Toolbar. Or, right-

click the cell(s) you want to format and select 

Format Cells from the contextual menu or click 

the Dialog Box Launcher in the Font group. 

Select formatting options on the Font tab in the 

Format Cells dialog box. 

 Tips 

 To use different font formats for different characters 

within the same cell, make the formatting changes 

while in edit mode. 

 The formatting buttons in the Font group, such as 

Font Color and Font Size, are not just for formatting 

labels—you can use them to format values as well. 

 Text is often called a “label” in Excel, because text 

usually acts as a label to the data in the worksheet. 

 Exercise Notes 

• Exercise File: Sales4-1.xlsx 

• Exercise: Format cell A1 with 14 pt Cambria font, then 

format the cell ranges B3:G3 and A4:A12 with bold 

Cambria font. 

Figure 4-1: The Format Cells dialog box 

Table 4-1: Font Formatting Buttons 

 
Bold 

Make text darker and heavier. 

 
Italic 

Make text slant. 

 
Underline 

Add a line or double line under text. 

 
Font 

Select a different font. 

 
Font Size 

Adjust font size. 

  
Increase/Decrease 

Font Size 

Adjust font size by one increment, 

either larger or smaller. 

 
Font Color 

Adjust text color. 

Formatting a Worksheet 
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Formatting Values 

Applying number formatting changes how values are 

displayed—it doesn’t change the actual information. 

Excel is often smart enough to apply some number 

formatting automatically. For example, if you use a dollar 

sign to indicate currency, such as $548.67, Excel will 

automatically apply the currency number format for you. 

1. Click the cell(s) with the value(s) you want to format. 

2. Click the Home tab on the Ribbon and click a 

formatting button in the Number group. 

The values are formatted. See the table below for 

more information on buttons in the Number group.  

 Other Ways to Format Values: 
Right-click the cell(s) you want to format. Click a 

formatting button on the Mini Toolbar. Or, right-

click the cell(s) you want to format and select 

Format Cells from the contextual menu or click 

the Number group’s Dialog Box Launcher. 

Select formatting options on the Number tab in 

the Format Cells dialog box. 

 Tips 

 Create custom number formats in the Format Cells 

dialog box by selecting the Custom category, 

selecting a number format code in the list, and editing 

it in the Type text box. Watch the sample area to see 

how the custom number format you create will be 

displayed. 

 The formatting buttons in the Font group, such as 

Font Color and Font Size, are not just for formatting 

labels—you can use them to format values as well. 

Table 4-2: Number Formatting Buttons 

 
Number Format  

1000 Select from several number formats—like General, Number, or Time—or 

click More to see all available formats. 

 
Accounting Number 

Format 

$1,000.00 Apply the Accounting number format, which adds a dollar sign ($) and 

decimal point. 

 
Percent Style 

100% Apply the Percent format, which converts the value to a percentage and adds 

a percent symbol (%). 

 
Comma Style 

1,000 Add a thousands separator. 

  
Increase/Decrease 

Decimal  

1000.00  

or 

1000.0 

Increase or decrease the number of digits shown after the decimal point. 

 Exercise Notes 

• Exercise File: Sales4-2.xlsx 

• Exercise: Format the cell range B4:G12 with the 

Accounting number format and decrease the decimal places 

so no decimals are shown.  

 

 Select the range B6:G10 and display the Format Cells 

dialog box. Select the Accounting category and remove the 

dollar symbols from the range (select None as the symbol). 

Figure 4-2: Formatted values. 

Formatting a Worksheet 

Format values using 
the commands in the 
Number group. 

Accounting format with and 
without dollar symbols. 
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Adjusting Row Height and 
Column Width 

When you start working on a worksheet, all the rows and 

columns are the same size. As you enter information into 

the worksheet, you will quickly discover that some of the 

columns or rows are not large enough to display the 

information they contain.  

Adjust column width 

1. Point to the column header’s right border until the 

pointer changes to a . 

2. Click and drag to the left or right to adjust the width. 

A dotted line appears as you drag, showing you 

where the new column border will be. 

 Other Ways to Adjust Column Width: 
Right-click the column header(s), select Column 

Width from the contextual menu, and enter the 

column width. Or, select the column header(s), 

click the Format button in the Cells group on the 

Home tab, select Width, and enter column width. 

Adjust row height 

1. Point to the row header’s bottom border until the 

pointer changes to a . 

2. Click and drag up or down to adjust the height. 

A dotted line appears as you drag, showing you 

where the new row border will be. 

 Other Ways to Adjust Row Height: 
Right-click the row header(s), select Row Height 

from the contextual menu, and enter the row 

height. Or, select the row header(s), click the 

Format button in the Cells group on the Home 

tab, select Height, and enter the row height. 

AutoFit columns or rows 

The AutoFit feature automatically resizes columns or 

rows to fit the cell in each column or row that has the 

widest or tallest contents. 

1. Double-click the right border of the column(s) or 

bottom border of the row(s). 

 Tips 

 To AutoFit multiple rows or columns, select the rows 

and columns, then double-click the corresponding 

border to adjust all selected rows or columns. 

 Exercise Notes 

• Exercise File: Sales4-3.xlsx 

• Exercise: Adjust the width of column A to 13.00 points 

and the height of row 1 to 24.00 points.  

 AutoFit columns B through G. 

Figure 4-3: Increasing the width of column A. 

Formatting a Worksheet 
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Working with Cell Alignment 

By default, the contents of a cell appear at the bottom of 

the cell, with values (numbers) aligned to the right and 

labels (text) aligned to the left. This lesson explains how 

to control the alignment of data in a cell. 

1. Select the cell(s) you want to align.  

2. Click the Home tab on the Ribbon and click an 

alignment button in the Alignment group. 

The cell contents are realigned. See Table 4-3: Cell 

Alignment Buttons in the Alignment Group for more 

information about alignment options in Excel. 

 Other Ways to Align Cells: 
Right-click the cell(s) you want to align. Click an 

alignment button on the Mini Toolbar. Or, right-

click the cell(s) you want to align and select 

Format Cells from the contextual menu or click 

the Dialog Box Launcher in the Alignment 

group. Select alignment options on the Alignment 

tab in the Format Cells dialog box. 

Table 4-3: Cell Alignment Buttons in the Alignment Group 

     
Top/Middle/Bottom Align 

Align cell contents to the top, middle, or bottom of the cell using these three buttons. 

         
Align Left/Center/Right 

Align cell contents to the left side, center, or right side of the cell using these three buttons. 

 
Orientation 

Align cell contents diagonally or vertically. 

    
Decrease/Increase Indent 

Increase or decrease the margin between the cell contents and the cell border with these two 

buttons. 

 
Wrap Text 

Make all cell contents visible by displaying them on multiple lines within the cell (this increases 

the row’s height). 

 
Merge & Center list arrow 

Select from a few options for merging cells together and centering cell contents within the 

merged cells. 

 

 Exercise Notes 

• Exercise File: Sales4-4.xlsx 

• Exercise: Center align the labels in cells B3:G3.  

Merge and center the label “Income & Expenses” across 

cells A1:G1. 

Figure 4-4: An example of horizontal alignment options. 

Figure 4-5: An example of vertical alignment options. 

Formatting a Worksheet 
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Adding Cell Borders and 
Background Colors 

Adding cell borders and filling cells with colors and 

patterns can make them more attractive, organized and 

easy to read.  

Add a cell border  

Borders are lines that you can add to the top, bottom, left, 

or right of cells.   

1. Select the cell(s) you want to add the border to. 

2. Click the Home tab on the Ribbon and click the 

Border list arrow in the Font group.  

A list of borders you can add to the selected cell(s) 

appears. Use the examples shown next to each border 

option to guide your decision.  

If the border configuration you want doesn’t appear 

in the list, add one border at a time. 

3. Select a border type.  

The border is applied. 

 Tip: To remove a border, click the Border list 

arrow in the Font group and select No Border. 

Notice that the border option you chose now appears 

as the selected border type on the Border button. If 

you want to apply the some border to another cell, 

just click the Border button. 

 Other Ways to Add a Border: 
Right-click the cell(s) you want to add the border 

to. Click the Border list arrow on the Mini 

Toolbar and select a border. Or, right-click the 

cell(s) you want to format and select Format 

Cells from the contextual menu or click the 

Dialog Box Launcher in the Font group. Click 

the Border tab in the Format Cells dialog box and 

select border options. 

Draw a cell border 

Sometimes it’s easier to draw the borders you want to use 

in cells, so you can see the borders as they are applied. 

1. Click the Border button list arrow in the Font group 

of the Home tab and select Draw Border. 

The cursor changes into a pencil shape. 

 Exercise Notes 

• Exercise File: Sales4-5.xlsx  

• Exercise: Add a bottom border to cells B3:G3 and B9:G9. 

Add a light blue fill color (Accent 1, Lighter 80%) to the 

Income & Expenses merged cell. 

Figure 4-6: Worksheet with cell borders and a background 
color applied. 

Figure 4-7: The Format Cells dialog box with the Border 
tab displayed. 
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2. Click and drag the cell gridlines where you want to 

apply the border. 

The borders are applied to cells as indicated. 

 Tips 

 To change the style or color of the lines used by the 

Draw Border tool, click the Border button list arrow 

in the Font group and select the Line Color and Line 

Style you want to use. 

Add a cell background color 

Fill the background of a cell by adding a color or pattern.  

1. Select the cell(s) you want to add the color to. 

2. Click the Home tab on the Ribbon and click the Fill 

Color list arrow in the Font group. 

A list of colors you can add to the selected cell(s) 

appears. 

3. Select the color you want to use. 

The fill color is applied.  

Notice that the color you chose now appears as the 

selected color on the button. If you want to apply the 

shading to another paragraph, just click the button to 

apply the displayed shading color. 

 Other Ways to Apply Background Color: 
Right-click the cell selection and click the Fill 

Color list arrow on the Mini Toolbar. Select a 

color. Or, right-click the cell(s) you want to 

format and select Format Cells from the 

contextual menu or click the Dialog Box 

Launcher in the Font group. Click the Fill tab in 

the Format Cells dialog box and select a 

background color or fill effects. 

 Tips 

 You can use an image as the background of a 

worksheet. Click the Page Layout tab and click the 

Background button. Browse to and select the image 

you want to use as the worksheet background. Click 

Insert. 

Figure 4-8: Click and drag the Draw Border tool to add 
borders to cells. 

Figure 4-9: The Fill tab of the Format Cells dialog box. 
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Copying Formatting 

If you find yourself applying the same cell formatting 

again and again, then you should familiarize yourself with 

the Format Painter tool. The Format Painter allows you to 

copy the formatting of a cell or cell range and apply it 

elsewhere. 

 1. Select the cell(s) with the formatting you want to 

copy. 

2. Click the Home tab on the Ribbon and click the 

Format Painter button in the Clipboard group. 

 Other Ways to Access the Format Painter 

Button: 
Select the cell(s) with the formatting options you 

want to copy, then right-click the selection. Click 

the Format Painter button on the Mini Toolbar. 

The mouse pointer changes to indicate it is ready to 

apply the copied formatting. 

 Tip: Single-click the Format Painter button to 

apply copied formatting once. Double-click the 

Format Painter button to apply copied 

formatting as many times as necessary, then click 

it again or press the <Esc> key to deactivate the 

Format Painter. 

3. Click the cell to which you want to apply the copied 

formatting. 

The copied formatting is applied. 

 Exercise 

• Exercise File: Sales4-6.xlsx 

• Exercise: Use the Format Painter to copy the value 

formatting from the cell B4 to the range B10:G10. 

Figure 4-10: Using the Format Painter tool to copy 
formatting from cells in row 4 to cells in row 10. 
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Applying and Removing Cell 
Styles 

Styles contain preset font formatting, cell shading, and 

other formatting items that can be applied to a cell or cell 

range all at once. This is a convenient and easy formatting 

option for your cells. 

Apply a cell style 

1. Select the cell(s) you want to format.  

2. Click the Home tab and click the Cell Styles button 

in the Styles group. 

A gallery of styles appears. 

3. Select a cell style. 

 Tip: Hover the pointer over a style to preview 

how it will look before selecting it. 

Remove a cell style 

1. Select the cell(s) that have the cell style applied. 

2. Click the Home tab and click the Cell Styles button 

in the Styles group. 

3. Click Normal. 

 Tips 

 Cell styles are associated with the theme that is being 

used for the workbook. If you switch to a new theme, 

the cell styles will update to match it. 

 If you have another workbook that contains styles 

that you want to copy into the current workbook, 

click the Cell Styles button in the Styles group and 

select Merge Styles. 

 Exercise 

• Exercise File: Sales4-7.xlsx 

• Exercise: Apply the “Heading 3” cell style to the cell 

range B3:G3.  

Apply the “Heading 4” cell style to the cell range A4:A12. 

Apply the “Total” cell style to the cell range B12:G12. 

 Remove the “Heading 4” cell style from the range A4:A12.  

Figure 4-11: A preview of how the cell style will look 
appears as you hover over styles in the Cell Styles gallery. 

Formatting a Worksheet 
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Creating and Modifying Cell 
Styles 

You can modify cell styles and create new styles. 

Create a new cell style 

If you find that you keep applying the same formatting 

over and over, you should create a style with that 

formatting so you can apply those formatting settings with 

one click. 

1. Select the cell that has the formatting you want to use 

for the style. 

The new style will use these formatting properties.  

If you need, you will be able to modify the formatting 

further before the style is created. 

2. Click the Home tab and click the More button in the 

Cell Styles gallery of the Styles group. 

A list of all the available cell styles appears. 

3. Select New Cell Style.  

The Style dialog box appears with the formatting for 

the selected cell. You can further define the 

formatting for the cell if you wish. 

4. Type a name for the style in the Style name text box. 

The name should be easy to identify. 

5. (Optional) Check or uncheck “Style includes” boxes 

to select which formatting items you want the style to 

include. 

If you leave a check box empty, the default settings 

will be used for the cell. 

6. (Optional) Click the Format button and define 

formatting as needed.  

7. Click OK.  

The Format dialog box closes. 

8. Click OK. 

The Style dialog box closes and the new style is 

available in the Cell Styles gallery. 

9. Reapply the new style to the cell. 

 Tips 

 New styles are added to the theme that is currently 

applied to the workbook. 

 Exercise 

• Exercise File: Sales4-8.xlsx 

• Exercise: Create a new style using the formatting in cell 

A1, and name the style Income&Expenses. 

 Modify the Income&Expenses style: change the font size to 

16 pt. and add Bold formatting. 

Figure 4-12: The Style dialog box. 

Figure 4-13: The new style appears under the Custom 
section of the Cell Styles gallery. 
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 If you have another workbook that contains styles 

that you want to copy into the current workbook, 

click the Cell Styles button in the Styles group and 

select Merge Styles. 

Modify a cell style 

1. Click the Home tab and click the Cell Styles button 

in the Styles group. 

2. Right-click the cell style you want to modify and 

select Modify. 

The Style dialog box appears. This is where you can 

change the appearance of the style being modified or 

duplicated. 

 Trap: Selecting Modify changes the style, while 

selecting Duplicate adds a new custom style and 

leaves the original built-in style alone. 

3. Click the Format button and change formatting items 

on each tab, as needed. Click OK.  

The Format dialog box closes. 

4. Click OK. 

The Style dialog box closes and the style is modified. 

 Tips 

 To duplicate and then modify a cell style, right-click 

a style and select Duplicate. This creates a new 

custom style. 

 To remove a cell style from all cells and delete the 

cell style itself, click the Home tab on the Ribbon 

and click the Cell Styles button in the Styles group. 

Right-click the style you want to delete and select 

Delete. 

Figure 4-14: Change the formatting properties of a style 
as needed in the Format Cells dialog box. 

Figure 4-15: The Style dialog box shows updates to 

formatting after changes are applied in the Format Cells 
dialog box. 

Formatting a Worksheet 
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Using Document Themes 

A theme is a set of unified design elements that you can 

apply to a worksheet to give it a consistent look and feel. 

Document themes coordinate the look of a worksheet with 

theme colors, theme fonts, and theme effects. 

 Theme Colors: A set of eight coordinated colors 

used in formatting text and objects in the worksheet. 

 Theme Fonts: A set of coordinated heading and body 

font types. 

 Theme Effects: A set of coordinated formatting 

properties for shapes and objects in the document. 

Apply a document theme 

Applying a document theme affects all elements of the 

worksheet: colors, fonts, and effects. 

1. Click the Page Layout tab on the Ribbon and click 

the Themes button in the Themes group. 

A list of built-in document themes appears. The 

default theme is “Office.” 

 Tip: You may browse for additional themes 

online by clicking More Themes on Microsoft 

Office Online. Or, if a theme is saved elsewhere 

on your computer or network location, click 

Browse for Themes to go to the theme’s location. 

2. Click the document theme you want to apply. 

The formatting associated with the selected document 

theme is applied to the worksheet. 

Mix and match document themes 

You are not bound to the colors, fonts, or effects that are 

assigned to a document theme. You may mix and match 

theme colors, theme fonts, and theme effects. 

1. Click the Page Layout tab on the Ribbon. 

2. Click the Theme Colors, Theme Fonts, or Theme 

Effects button and select the set of colors, fonts, or 

effects you want to use. 

The change is applied to the document. The 

document theme isn’t changed, it is just no longer 

applied. If you want to use this set of theme items 

together again, you’ll have to save them as a new 

document theme. 

 Exercise 

• Exercise File: Sales4-9.xlsx 

• Exercise: Apply the Black Tie document theme.  

 Apply the Civic theme color set.  

 Save these settings as a new document using the name 

“Income&Expenses”. 

 Change the workbook back to the Office document theme. 

Figure 4-16: Selecting a document theme. 
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Create new theme colors and fonts 

You can also change which colors or fonts make up the 

theme colors and theme fonts. This can be useful if you 

want to create a document theme that is customized for 

your company or for a special project.  

1. Click the Page Layout tab on the Ribbon. 

2. Click the Theme Colors or Theme Fonts button. 

3. Select Create New Theme Colors or Create New 

Theme Fonts from the list. 

A dialog box appears where you can select colors or 

fonts. 

4. Select the colors or fonts you want to use. 

Once the color or font theme looks the way you want 

it to, save it. 

5. Type a name for the new theme in the “Name” text 

box. 

If you want to coordinate new theme colors and 

fonts, save them under the same name, just as they 

are with built-in themes. 

6. Click Save. 

Save a new document theme 

Finally, you can save any combination of theme colors, 

theme fonts, and theme effects as a new document theme. 

1. Apply the colors, fonts, and effects you want to use in 

the new document theme. 

2. Click the Page Layout tab on the Ribbon and click 

the Themes button in the Themes group. 

3. Select Save Current Theme. 

The Save Current Theme dialog box appears. 

4. Type a name for the theme in the File name box.  

5. Click Save. 

 Tips 

 When you save a new theme color or font, or save a 

new document theme, it becomes available in all 

Office programs. 

 To remove a custom theme or theme element, right-

click the theme and select Edit. Click Delete in the 

dialog box and click Yes to confirm the deletion. 

Formatting a Worksheet 
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Applying Conditional 
Formatting 

Conditional formatting formats cells only if a specified 

condition is true. For example, you could use conditional 

formatting to display weekly sales totals that exceeded 

$50,000 in bright red boldface formatting, and bright blue 

italics formatting if the sales totals were under $20,000. If 

the value of the cell changes and no longer meets the 

specified condition, the cell returns to its original 

formatting. 

Apply Highlight Cells Rules and Top/Bottom 
Rules 

You can highlight specific cells in a range using a 

comparison operator; only cells that meet the specified 

criteria will be formatted. For example, you can highlight 

cells with values that are greater than a certain value. 

1. Select the cell range you want to format. 

2. Click the Home tab on the Ribbon and click the 

Conditional Formatting button in the Styles group.  

A menu appears. Here you have several conditional 

formatting rules to choose from: 

Highlight Cells Rules: These conditions focus on 

general analysis. Preset conditions include: Greater 

Than; Less Than; Between; Equal To; Text That 

Contains; Date Occurring; Duplicate Values. 

Top/Bottom Rules: These conditions focus on the 

high and low values in the worksheet. Preset 

conditions include: Top 10 Items; Top 10%; Bottom 

10 Items; Bottom 10%; Above Average; Below 

Average. 

3. Point to Highlight Cells Rules or Top/Bottom Rules 

and select a conditional formatting rule.  

A dialog box appears, allowing you to specify the 

details relating to the rule. 

For example, if you selected the Greater Than rule, in 

the “Format cells that are GREATER THAN:” box 

you can enter a value or click a cell to enter a cell 

reference. Then you can click the list arrow and select 

the formatting you want to apply to cells that fit the 

criteria you set—in this example, cells that are 

greater than the value you entered. 

4. Complete the dialog box to define the condition. 

5. Click OK. 

The conditional formatting is applied to the cells. 

 Exercise 

• Exercise File: Sales4-10.xlsx 

• Exercise: Use conditional formatting to highlight cells that 

are below average in cell range B4:G4.  

 Add Blue data bars to cells B10:G10.  

 Add the 3 Arrows (colored) icon set to cells B12:G12. (You 

may need to widen columns so the contents are visible.) 

Figure 4-17: This list of options appears when you click 
the Conditional Formatting button in the Styles group. 

Figure 4-18: Applying conditional formatting. 
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Apply Data Bars, Color Scales and Icon Sets 

You can also format cells with data bars, color scales, or 

icon sets to visually display variations in the values of 

cells in a range. 

1. Select the cell range you want to format. 

2. Click the Home tab on the Ribbon and click the 

Conditional Formatting button in the Styles group. 

Let’s take a closer look at three similar types of 

conditional formatting: 

Data Bars: Colored bars appear in the cells. The 

longer the bar, the higher the value in that cell. You 

can choose from different bar colors. 

Color Scales: Cells are shaded different color 

gradients depending on the relative value of each cell 

compared to the other cells in the range. You can 

choose from different colors. 

Icon Sets: Different shaped or colored icons appear 

in cells, based on each cell’s value. You can choose 

from several types and colors of icons. 

3. Point to Data Bars, Color Scales or Icon Sets. 

A menu appears, differing based on your selection. 

4. Select a data bar, 2- or 3-color scale, or icon set. 

The conditional formatting is applied to the cells. 

 Tips 

 Additional options for data bars have been added to 

Excel 2010. You can apply solid fills and borders, 

and even change the direction of the bar. Data bars 

also have a new way to display negative values  

 More icon sets have been added to Excel 2010. You 

can also specify which icons appear from an icon set.  

Figure 4-19: Applying conditional formatting. 

Figure 4-20: The worksheet with conditional formatting 

applied. 
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Creating and Managing 
Conditional Formatting Rules 

You can create and manage new conditional formatting 

rules that follow the parameters and formatting you 

specify. 

Create a new rule 

1. Select the cell range you want to format with a 

customized rule. 

2. Click the Home tab on the Ribbon and click the 

Conditional Formatting button in the Styles group.  

3. Select New Rule. 

The New Formatting Rule dialog box appears. 

4. Select a rule type in the Select a Rule Type list. 

5. Complete the fields in the Edit the Rule Description 

area. 

This area will display different fields depending on 

the type of rule you selected. 

 Tip: Click Preview in the New Formatting Rule 

dialog box if you want to see how the rule will 

appear before you apply it. 

6. Click OK. 

The new rule is created and formatting is applied. 

 Other Ways to Create a New Rule: 
Click the Home tab on the Ribbon and click the 

Conditional Formatting button in the Styles 

group. Click Manage Rules, then click New 

Rule. Or, click the Home tab on the Ribbon and 

click the Conditional Formatting list arrow in 

the Styles group. Click one of the rule types, then 

click More Rules. 

Manage rules 

You can manage all aspects of conditional formatting—

creating, editing, and deleting rules—in one place using 

the Rules Manager. 

1. Select the cell range with the conditional formatting 

you want to manage. 

2. Click the Home tab on the Ribbon and click the 

Conditional Formatting button in the Styles group. 

 Exercise 

• Exercise File: Sales4-11.xlsx 

• Exercise: Create and apply a new formatting rule that 

applies bold formatting to values that are below average for 

cell range B4:G4.  

 Select cells B12:G12 and edit the rule so that the green icon 

appears for values greater than or equal to 60% and the 

yellow for values greater than or equal to 30%.  

 Clear all the conditional formatting on the worksheet. 

Figure 4-21: Creating a new conditional formatting rule. 
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3. Select Manage Rules.  

The Conditional Formatting Rules Manager dialog 

box appears. The rules applied to the selected cells 

appear in the dialog box.  

Use these buttons to manage the rules: 

 New Rule: Create a brand new conditional 

formatting rule. 

 Edit Rule: Edit the selected formatting rule. 

 Delete Rule: Delete the selected rule from the 

worksheet. 

 Tip: If you don’t select a cell range where 

conditional formatting is applied, you can view all 

the rules in the worksheet. Click the Show 

formatting rules for list arrow and select This 

Worksheet. 

4. Manage the formatting rules. Click OK when you are 

finished. 

Remove conditional formatting 

The Clear Rules command helps you remove conditional 

formatting rules from your worksheet. 

1. Click the Home tab on the Ribbon and click the 

Conditional Formatting list arrow in the Styles 

group. 

If you want to clear only a selection of cells, first 

select the cell range. 

2. Point to Clear Rules. 

3. Select Clear Rules from Selected Cells or Clear 

Rules from Entire Sheet. 

Conditional formatting is cleared either from the cells 

you’ve selected or the entire worksheet. 

Figure 4-22: The Conditional Formatting Rules Manager 
dialog box. 

Figure 4-23: Editing a formatting rule. 

Figure 4-24: The worksheet with edited conditional 
formatting. 
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Finding and Replacing 
Formatting 

Excel’s Find and Replace features can find and/or replace 

formatting in addition to text and information. 

1. Click the Home tab on the Ribbon and click the Find 

& Select button in the Editing group.  

2. Select Replace. 

The Find and Replace dialog box appears, displaying 

the Replace tab.  

 Other Ways to Open Find and Replace: 
Press <Ctrl> + <H>. 

3. Click the Options button. 

The dialog box expands to display more search 

options. 

4. Click the top Format button. 

The Find Format dialog box appears. 

5. Select the formatting options you want to find and 

then click OK. 

6. Click the bottom Format button. 

The Replace Format dialog box appears. 

7. Select the new formatting options you want to use 

and click OK. 

Once the formatting options are set, you’re ready to 

begin finding and replacing the formatting. 

8. Click Find Next to find each occurrence of the cell 

formatting. Click Replace to replace the cell 

formatting. 

After you replace an occurrence, Excel automatically 

moves to the next occurrence, so you only need to 

click Find Next if you want to skip an occurrence 

without replacing the formatting. 

 Tips 

 Click Replace All to replace all occurrences of the 

cell formatting at once. 

 To find other types of items, click the Find & Select 

button and then select one of the Find options: 

Formulas, Comments, Conditional Formatting, 

Constants, or Data Validation. 

 Exercise 

• Exercise File: Sales4-12.xlsx 

• Exercise: Replace all bold formatting in the worksheet 

with bold italic formatting. 

Figure 4-25: The Replace tab of the Find and Replace 
dialog box. 

Figure 4-26: The formatting of headings in cell range 

B3:G3 is updated through finding and replacing formatting. 
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FFoorrmmaattttiinngg  aa  WWoorrkksshheeeett  RReevviieeww  

Quiz Questions 

27. Which of the following is NOT a type of font formatting? 
A. Bold 
B. Italic 
C. Underline 
D. Comma Style 

28. Which of the following is NOT a type of number formatting? 
A. Number 
B. Accounting 
C. Dollar 
D. Percentage 

29. The _______ feature automatically resizes columns or rows to best fit cell contents. 
A. AutoFit 
B. AutoSize 
C. AutoAdjust 
D. FitRight 

30. You can align cell contents horizontally but not vertically within a cell. (True or False?) 

31. The Border list arrow is located in the ________ group on the Home tab. 
A. Alignment 
B. Clipboard 
C. Font 
D. Number 

32. Click the Format Painter button once to apply it once or twice to apply it multiple times. (True or False?) 

33. Excel contains preset formatting styles that you can quickly apply to cells. (True or False?) 

34. Which of these formatting properties can be included in style formatting? 
A. Number 
B. Font 
C. Fill and Border. 
D. All of these. 

35. Document themes consist of: 
A. Theme colors 
B. Theme fonts 
C. Theme effects 
D. All of these 



76 © 2010 CustomGuide, Inc. 

36. _________ allows you to highlight cells that meet specific criteria. 
A. Conditional formatting 
B. Font formatting 
C. Filtering 
D. Find and replace 

37. Which of the following is not a conditional format that can be applied to cells? 
A. Data Bars 
B. Characters 
C. Color Scales 
D. Icon Sets 

38. You can preview how a new conditional formatting rule looks before you apply it. (True or False?) 

39. You cannot edit a conditional formatting rule after you’ve created it. (True or False?) 

40. Which of the following types of items can NOT be found using Excel’s Find feature? 
A. Formulas 
B. Comments 
C. Conditional Formatting 
D. Styles 

 

Quiz Answers 

27. D. Comma Style is not a type of font formatting. 

28. C. Dollar is not a type of number formatting. 

29. A. AutoFit resizes columns or rows to best fit cell contents. 

30. False. You can align cell contents vertically and horizontally within a cell. 

31. C. The Border list arrow is located in the Font group. 

32. True. Click the Format Painter button once to apply it once or twice to apply it multiple times. 

33. True. Excel contains preset formatting styles that are all ready for you to apply to cells. 

34. D. Number, Font, Fill and Border, are all available in cell styles. You can also include Alignment and Protection 

formatting in the style. 

35. D. Document themes consist of theme colors, fonts, and effects. 

36. A. Conditional formatting allows you to highlight cells that meet specific criteria. 

37. B. Characters is not a conditional formatting option in Excel. 

38. True. Click Preview in the New Formatting Rule dialog box to see how new conditional formatting will look before 

you apply it. 
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39. False. You can edit a conditional formatting rule. 

40. D. Styles cannot be found using the Find feature. 
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Move a chart within a worksheet ............. 82 
Move a chart to another worksheet ......... 82 
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Copy data into a chart .............................. 85 
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Changing Chart Data ......................................... 86 
Change the source cell range .................. 86 
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Reorder the data series ........................... 87 
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Changing Chart Layout and Style .................... 88 
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Using Chart Templates ...................................... 96 
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Charts allow you to present data, 

relationships, or trends graphically. Charts 

are often better at presenting information 

than hard-to-read numbers in a table or 

spreadsheet. 

In this chapter, you will learn how to 

create, edit and format dynamic looking 

charts. 

Using Exercise Files 
This chapter suggests exercises to practice 

the topic of each lesson. There are two 

ways you may follow along with the 

exercise files: 

 Open the exercise file for a lesson, 

perform the lesson exercise, and close 

the exercise file. 

 Open the exercise file for a lesson, 

perform the lesson exercise, and keep 

the file open to perform the remaining 

lesson exercises for the chapter. 

The exercises are written so that you may 

“build upon them”, meaning the exercises 

in a chapter can be performed in 

succession from the first lesson to the last. 
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Delete a template ..................................... 96 

Changing Chart Type ........................................ 97 
Swap data over the axes ......................... 97 

Using Sparklines ................................................ 98 
Insert a sparkline ..................................... 98 
Change sparkline style ............................ 98 
Add data points to sparklines ................... 98 
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Choosing and Selecting the 
Source Data 

Charts are a great way to share data and information. The 

foundation of charts is the data they illustrate. Choosing 

the right data is the first and most important step in 

creating a chart. 

Choose the right data 

When you realize that you need a chart, you have to 

decide what data needs to be included in it. 

 What is the main point? 
What is the purpose of the chart? Identify the point of 

the chart, and then include the data that illustrates this 

point and puts it in context. 

 What is the truth? 
Avoid spinning the data. Communicate what the data 

shows, not what you want it to say. 

 Keep it simple. 
Only show the data that is relevant. This makes it 

easier to process the information that is important. 

Make sure that that the rest of the data is available so 

that your conclusions are backed up with ample 

evidence.  

Select the data 

Once you know what data and labels you wish to include 

in the chart, select them. 

1. Click and drag to select the cells you want to include 

in the chart. To select multiple non-adjacent cells, 

select a cell or cell range and hold down the <Ctrl> 

key while you select other cells. 

Include labels for rows and columns in the cells you 

select. These labels provide context for the chart data. 

 Tips 

 If a value changes in the chart’s data source, that 

change is automatically updated in the chart. 

 If you do not include labels in the selected cell range, 

Excel will insert placeholders in the chart.  

 Exercise 

• Exercise File: Survey5-1.xlsx 

• Exercise: Select A4:D9 and A12:D12. 

Figure 5-1: An example of results from a survey. You want 

to show that among all travel destinations, the most 
popular destination for trips taken for leisure is Europe. 

Figure 5-2: In this example, the data labels in column A 

and row 4 are selected along with the values in B5:D9 and 
B12:D12. 
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Choosing the Right Chart 

Once you’ve determined the results you want your chart 

to display, choose the chart that best suits this purpose. 

The most popular charts are column, line, pie, and bar 

charts. 

 

Chart Types in Excel 

 

Column 

Column charts are used when you want to compare different values vertically side-

by-side. Each value is represented in the chart by a vertical bar. If there are several 

series, each series is represented by a different color. 

 

Line 

Line charts are used to illustrate trends over time. Each value is plotted as a point on 

the chart and is connected to other values by a line. Multiple items are plotted using 

different lines. 

 
Pie 

Pie charts are useful for showing values as a percentage of a whole. The values for 

each item are represented by different colors. 

Limit pie charts to eight sections. 

 

Bar 

Bar charts are just like column charts, except they display information in horizontal 

bars rather than in vertical columns. 

 

Area 

Area charts are the same as line charts, except the area beneath the lines is filled 

with color. 

 

XY (Scatter) 

Scatter charts are used to plot clusters of values using single points. Multiple items 

can be plotted by using different colored points or different point symbols. 

 

Stock 

Stock charts are effective for reporting the fluctuation of stock prices, such as the 

high, low, and closing points for a certain day. 

 

Surface 

A surface chart is useful for finding optimum combinations between two sets of 

data. Colors and patterns indicate values that are in the same range. 

 

Doughnut 

A doughnut chart shows the relationship of parts to a whole, but it can contain more 

than one data series. (You may want to try stacked column or stacked bar charts 

instead.) 

 

Bubble 

Bubble charts are similar to XY Scatter charts, but they compare three sets of values 

instead of two, with the third set determining the size of the bubble. 

 

Radar 

Radar charts compare the aggregate values of a number of data series. 

 Exercise 

• Exercise File: None required. 

• Exercise: Review the different types of charts available in 

Excel. 
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Inserting a Chart 

Once you’ve chosen the type of chart you wish to use, 

insert the chart in your worksheet. 

1. Make sure the cell range containing the data and 

labels you want to chart are selected.  

  Tip: You can chart non-adjacent cells if you hold 

down the <Ctrl> key while selecting the cells. 

2. Click the Insert tab on the Ribbon. 

In the Charts group, there are several chart types to 

choose from. Each of the chart types then has several 

charts to choose from. 

3. Click a chart type button in the Charts group. 

A list of charts for the selected chart type appears. 

4. Select the chart you want to use from the list. 

The chart appears in the worksheet and the Chart 

Tools appear on the Ribbon. The Chart Tools include 

three new tabs—Design, Layout and Format—that 

help you modify and format the chart. 

 Tips 

 To see all available chart types, click any chart type 

in the Charts group, and then select All Chart Types. 

The Insert Chart dialog box appears, displaying every 

chart type that is available. 

Move a chart within a worksheet 

Usually you will have to move a chart after it is inserted 

because it covers up the data on the worksheet. 

1. Select the chart. 

2. Point to the chart’s border.  

The pointer changes to a cross-arrow pointer. 

3. Click and drag the chart in the worksheet. 

Move a chart to another worksheet 

You can move a chart to another worksheet as an 

embedded object or move it to its own worksheet. 

1. Under Chart Tools on the Ribbon, click the Design 

tab and click the Move Chart button in the Location 

group. 

The Move Chart dialog box appears, displaying two 

options: 

 Exercise 

• Exercise File: Survey5-3.xlsx 

• Exercise: Select cell range A4:D9 and insert a 2-D 

Clustered Column chart. 

 Move the chart so that the upper left corner is in cell A14.   

 Resize the chart so that it covers A14:F28. 

Figure 5-3: Selecting a chart to insert. 

Figure 5-4: To move a chart within a worksheet, click and 
drag the chart to a new location. 
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 New sheet: Moves the chart to its own worksheet. 

 Object in: Allows you to embed the chart in 

another existing worksheet. 

2. Select the option you want to use and enter or select a 

worksheet name. 

3. Click OK. 

 Resize the chart 

1. Select the chart.  

Eight sizing handles appear along the chart edges 

once it is selected. Sizing handles are used to change 

the size of charts and other objects. 

 Tip: Clicking a chart displays the Chart Tools on 

the Ribbon, which include the Design, Layout, 

and Format tabs. 

2. Click a sizing handle and drag it to resize the chart.  

The chart is resized. 

 Tip: A faint outline appears as you drag the chart 

border so that you can preview the size of the 

chart before releasing the mouse button. 

 Other Ways to Resize a Chart: 
Under Chart Tools on the Ribbon, click the 

Format tab and use the Height and Width fields 

in the Size group.  

Figure 5-5: To resize a chart, click and drag the corner of 

the chart. 
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Editing, Adding, and 
Removing Chart Data 

After you’ve inserted the chart, you’ll probably still 

change the data. You can edit, add, and remove chart data 

even after you’ve inserted your chart. 

Edit chart source data 

The values in a chart are linked to the worksheet data 

from which the chart is created. If you change the source 

data, the chart will automatically chart the new values. 

1. Replace and edit values in the source data. 

The changes are automatically reflected in the chart.  

Add a data series 

You can always add data to a chart after it has been 

created. Here’s how to add a data series. 

1. Select the chart; then click the Design tab and click 

the Select Data button in the Data group. 

The Select Data Source dialog box appears. 

2. Click the Add button under Legend Entries (Series). 

The Edit Series dialog box appears. 

3. In the “Series name” box, select the name of the 

series from the worksheet or type the series name.  

4. In the “Series values” box, select the data range of 

the data series or type the cell range reference. 

 Tip: Remove placeholder text before selecting the 

series values. For example, if a {1} appears in the 

Series values text box, remove these characters so 

only the equals sign (=) remains. Then you are 

ready to enter or select values. 

5. Click OK. 

The Edit Series dialog box closes. 

6. Click OK. 

The Select Data Source dialog box closes, and the 

data is added to the chart. 

 Other Ways to Add Data to a Chart:  
If the chart uses adjacent cells for source data, 

click and drag the sizing handles around the 

source data on the worksheet. 

 Exercise 

• Exercise File:  Survey5-4.xlsx 

• Exercise: Change the value in cell B7 to “134”. 

 Add the “Total” data series to the chart. 

 Add the “Middle East” category to the chart. 

 Remove the “Total” data series from the chart. 

Figure 5-6: The Select Data Source dialog box. 

Figure 5-7: Adding a new data series. 

Figure 5-8: Another way to add and remove data in a 

chart is to click and drag the sizing handles around the 
source cells. These sizing handles only appear if the 
source data is adjacent. 
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Copy data into a chart 

Another way to add data to a chart is to copy it into the 

chart. This is useful if your chart uses non-adjacent cells 

for source data or if the chart and source data are not on 

the same worksheet. 

1. Select the cells containing the data you wish to add to 

the chart, including labels for the data. 

2. Click the Home tab on the Ribbon and click the 

Copy button in the Clipboard group. 

The data is copied to the clipboard. 

3. Select the chart to which you wish to add the data. 

4. Click the Paste button in the Clipboard group. 

The chart is updated to include the pasted data.  

Remove a data series 

If you need to simplify your chart or you need to get rid 

of some data, it’s easy to remove a data series from the 

chart. 

1. Under Chart Tools on the Ribbon, click the Design 

tab and click the Select Data button in the Data 

group. 

The Select Data Source dialog box appears. 

2. Select the data series you want to remove under 

Legend Entries (Series). 

3. Click the Remove button under Legend Entries 

(Series). 

The data series is removed from the chart. 

 Other Ways to Delete Data: 
Select the source data you want to remove from 

the chart and press <Delete>. 

4. Click OK. 

The Select Data Source dialog box closes and the 

chart is updated. 

Figure 5-9: The Select Data Source dialog box. 

Click to remove a data 
series from the chart. 
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Changing Chart Data 

Once you see data in a chart, you’ll find that there are 

some tweaks and changes that need to be made. Here are 

a few ways to change the data in your chart. 

Change the source cell range 

If you need to use a new set of data for your chart, you 

can change the data source. 

1. Under Chart Tools on the Ribbon, click the Design 

tab and click the Select Data button in the Data 

group. 

The Select Data Source dialog box appears. 

2. Click the Chart Data Range reference button and 

select the cell(s) you want to use as the data source. 

Press and hold the <Ctrl> key to include non-

adjacent cells in the data source. 

3. Press <Enter>. 

The Select Data Source dialog box expands. The new 

cell range for the source data is selected in the Chart 

data range text box. 

4. Click OK. 

The dialog box closes and the chart is updated with 

the new data. 

Rename or edit a data series 

Charts are not completely tied to the source data. You can 

change the name and values of a data series without 

changing the data in the worksheet. 

1. Under Chart Tools on the Ribbon, click the Design 

tab and click the Select Data button in the Data 

group. 

The Select Data Source dialog box appears. 

2. Select the series you want to change under Legend 

Entries (Series). 

3. Click the Edit button. 

The Edit Series dialog box appears. 

4. In the “Series name” box, type the label you want to 

use for the series, or select the label from the 

worksheet. 

 Tip: If you type a name for the data series, that 

name is not added to the worksheet, it only 

appears in the chart. 

 Exercise 

• Exercise File:  Survey5-5.xlsx 

• Exercise: Change the source cell range to A4:D4, A6:D9, 

A12:D12. 

 Rename the “Other” data series “Adventure” without 

changing the source data. 

 Reorder the data series to this order: 

Leisure 

Business 

Adventure 

 Rename the “United States” category “U.S.” 

Figure 5-10: The Select Data Source dialog box. 

Figure 5-11: The Edit Series dialog box. 
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5. In the “Series values” box, select the data range of 

the data series, or type the cell range reference. 

 Other Ways to Enter Cell Range Values: 
You can type values for the data series in the 

“Series values” box. These values will not be 

added to the worksheet; they only appear in the 

chart. 

6. Click OK. 

The Edit Series dialog box closes and the updated 

series label appears in the Select Data Source dialog 

box. 

7. Click OK. 

The Select Data Source dialog box closes and the 

changes are displayed in the chart. 

Reorder the data series 

You can change the order of data in the chart, without 

changing the order of the source data. 

1. Under Chart Tools on the Ribbon, click the Design 

tab and click the Select Data button in the Data 

group. 

The Select Data Source dialog box appears. 

2. Select the data series you want to move under Legend 

Entries (Series). 

3. Click the Move Up or Move Down arrows to reorder 

the data series. 

The chart is updated to display the new order of data. 

Update horizontal axis labels 

You can update or change the horizontal axis labels by 

selecting a cell range of labels in the worksheet. 

1. Under Chart Tools on the Ribbon, click the Design 

tab and click the Select Data button in the Data 

group. 

2. Click the Edit button under the Horizontal 

(Category) Axis Labels. 

3. Select the range of cells you wish to use for the axis 

labels. 

4. Click OK. 

 Other Ways to Update Axis Labels: 
Edit the label in the source data. 

Figure 5-12: The Select Data Source dialog box. 

Creating and Working with Charts 

Use the Move Up and Move Down 
buttons to rearrange the data series. 



88 © 2010 CustomGuide, Inc. 

Changing Chart Layout and 
Style 

An easy way to change the look and feel of a chart is by 

applying one of the built-in layouts and styles that are 

available in Excel 2010. 

Apply a chart layout 

Built-in chart layouts allow you to quickly adjust the 

overall layout of your chart with different combinations of 

titles, labels, and chart orientations. 

1. Select the chart. 

The Chart Tools appear on the Ribbon. 

2. Under Chart Tools on the Ribbon, click the Design 

tab. 

Here you can see the Chart Layouts and Chart Styles 

groups. 

3. Select the option you want to use from the Chart 

Layouts gallery in the Chart Layouts group. Or, click 

the Quick Layout button in the Chart Layouts group 

and select an option. 

The chart changes to the selected layout. 

Apply a chart style 

Built-in chart styles allow you to adjust the format of 

several chart elements all at once. Styles allow you to 

quickly change colors, shading, and other formatting 

properties. 

1. Select the chart. 

The Chart Tools appear on the Ribbon.  

2. Under Chart Tools on the Ribbon, click the Design 

tab. 

3. Select the option you want to use from the Chart 

Styles gallery in the Chart Styles group. 

The new style is applied.  

 Tips 

 The Chart Layouts and Chart Styles groups offer 

many formatting options. A few are displayed by 

default, but you can click the arrow buttons to scroll 

down and access additional layouts and styles, or you 

can click the More button to expand a gallery. 

 Exercise 

• Exercise File: Survey5-6.xlsx 

• Exercise: Apply built-in Layout 9 and Style 1 to the chart. 

Figure 5-13: The Chart Layouts group. 

Figure 5-14: The Chart Styles group. 
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Working with Chart Labels 

If you have a specific layout in mind for your chart’s 

labels, you can add, remove, and format the labels as 

needed. 

Edit chart label text 

It’s easy to edit the text of a label that already appears in 

the chart. 

1. Select the chart and double-click the label you wish 

to edit.  

A cursor appears in the label. 

2. Edit the label text and click the chart. 

 Tips  

 Text that is linked to worksheet data cannot be 

directly edited. To edit these labels, you need to edit 

the labels and data in the actual worksheet. 

Add or move a chart label 

Labels can be moved to different locations or layouts on 

the chart. 

1. Select the chart. 

2. Under Chart Tools on the Ribbon, click the Layout 

tab. 

In the Labels group, there are several labels to choose 

from, as shown in Table 5-1: Chart Labels. 

3. Click the button for the label you want to use in the 

Labels group. 

A list of options for that label appears. 

 Tip: If you don’t see a label option that suits you, 

click the More Options button at the bottom of 

the list to display the Format dialog box. Here you 

can fine-tune the label to your specifications. 

4. Select the option you want to use from the list. 

The label appears on the chart. If you add a chart or 

axis title, placeholder text will appear that you can 

replace with your own text. 

 Tips 

 To add data labels to one data series, select that data 

series instead of the entire chart area. 

 Exercise 

• Exercise File:  Survey5-7.xlsx 

• Exercise: Replace existing chart label placeholders: Add 

the text “Popular Leisure Destinations” to the chart title. 

Add the text “Responses” to the Primary Vertical Axis Title. 

 Move the legend to the bottom of the chart. 

 Remove the Primary Horizontal Axis Title from the chart. 

Figure 5-15: Editing a chart label. 

Table 5-1: Chart Labels 

 

Chart Title: Tells people what the chart is 

about.  

 

Axis Titles: Tells people about the data being 

charted on the axis. 

 

Legend: Displays the name of a data series in 

the chart. 

 
Data Labels: Labels the specific values of 

data in the chart. 

 
Data Table: Adds a table that contains all the 

data in the chart. 
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Format a chart label 

Labels can be moved to different locations on the chart. 

1. Double-click the label. 

The Format dialog box appears with formatting 

options for the label. 

2. Apply the formatting options you wish to use and 

click Close. 

The dialog box closes and formatting is applied to the 

label. 

Remove a chart label 

You may also remove labels from charts. 

1. Select the chart. 

2. Under Chart Tools on the Ribbon, click the Layout 

tab. 

3. Click the button for the label you want to remove in 

the Labels group. 

A list of options for that label appears. 

4. Select None. 

The label is removed from the chart. 

Figure 5-16: Formatting a chart label. 

Figure 5-17: Removing a chart label. 
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Changing the Chart Gridlines 

Gridlines are the lines in the background of a chart that 

correspond to the values in the chart. In column and bar 

charts, gridlines make it easier to compare the values in 

the chart. You can change how the gridlines stack up the 

data in the chart. 

Choose major and minor gridlines 

1. Select the chart. 

2. Under Chart Tools on the Ribbon, click the Layout 

tab and click the Gridlines button in the Axes group. 

A menu appears, allowing you to select whether you 

want to work with the vertical or horizontal axis. 

3. Select a gridline. 

A list appears with different display options for the 

vertical or horizontal gridlines. The table to the right, 

Table 5-2: Horizontal Gridline Examples, gives you 

an idea of available gridlines in Excel. The options 

for the vertical gridlines are the same, which you 

would most likely use for bar charts. 

4. Select the gridline option you want to use. 

The chart is updated to show the gridlines as selected. 

 Tip: To hide gridlines, select the None option. 

Format gridlines 

You can also change the line formatting used in gridlines.  

1. Select the chart. 

2. Under Chart Tools on the Ribbon, click the Layout 

tab and click the Gridlines button in the Axes group. 

3. Select a gridline and select More Primary Gridlines 

Options from the list. 

The Format Gridlines dialog box appears.  

4. Choose the formatting you wish to apply to gridlines 

and click Close. 

The dialog box closes and the gridline formatting is 

updated. 

 Exercise 

• Exercise File: Survey5-8.xlsx 

• Exercise: Show major and minor horizontal gridlines on 

the chart. 

 Remove horizontal gridlines from the chart. 

 Display only major horizontal gridlines on the chart. 

Table 5-2: Horizontal Gridline Examples 

 

None 

 

Minor Gridlines 

 

Major Gridlines 

 

Major & Minor 

Gridlines 

Figure 5-18: The Format Major Gridlines dialog box. 
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Changing the Scale 

The scale of the chart is how it displays units of 

measurement. For example, in what units do you want to 

show the data (i.e. thousands, millions)? Should it show 

lines for every 20 units? How high should the scale be 

displayed? Here’s how to change the scale of the chart. 

Change display units 

Changing the display units makes it easier to read charts 

that have large values. 

1. Select the chart. 

2. Under Chart Tools on the Ribbon, click the Layout 

tab and click the Axes button in the Axes group. 

3. Select an axis and select the display unit in which 

you want to show the data. 

The chart is updated to show the units and the axis 

label shows the unit of measurement that is used. 

 Tip: The axis you choose under the Axes button 

depends on the type of chart you’re using. If 

you’re using a column chart, select the vertical 

axis. If you’re using a bar chart, select the 

horizontal axis. 

Change the scale of the axis 

The scale of the axis determines how information appears 

in the chart. 

1. Select the chart. 

2. Under Chart Tools on the Ribbon, click the Layout 

tab and click the Axes button in the Axes group. 

3. Select an axis and select More Primary Axis 

Options from the list. 

The Axis Options tab is selected. Refer to Table 5-3: 

Format Axis Dialog Box for a description of the 

formatting options available in this tab. 

4. Select the axis display options you want to use and 

click Close. 

The scale of the chart is changed according to the 

options you chose. 

 Other Ways to Change Display Units: 
Right-click an axis in the chart and select Format 

Axis from the contextual menu. 

 Exercise 

• Exercise File:  Survey5-9.xlsx 

• Exercise: Change the display units for the vertical axis to 

thousands. Change it back to the default display units. 

 Change the scale of the vertical axis: change the major unit 

to 25 and change the maximum to 150. 

Figure 5-19: The Format Axis dialog box. 

Table 5-3: Format Axis Dialog Box 

Minimum/ 

maximum 

values 

By default, Excel chooses the minimum and 

maximum axis values for you, but you can 

adjust the scale of an axis by selecting Fixed 

and entering your own values. 

Major/minor 

unit 

Excel determines the axis unit of measure by 

default, but you can select your own here. 

Display units Choose the units you want to use to display 

axis values—for example, in thousands or 

millions. 

Major/minor 

tick mark 

type 

Select whether or not you want to display 

major or minor tick marks, as well as 

whether they are displayed inside, outside, or 

across the axis. 

Axis labels Decide where you want axis labels located. 
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Change number formatting for axis values 

You can change the number formatting used in an axis. 

For example, if the axis is displayed a monetary value, 

you can change the formatting to display the numbers 

with a currency symbol.  

1. Select the chart. 

2. Under Chart Tools on the Ribbon, click the Layout 

tab and click the Axes button in the Axes group. 

3. Select an axis and select More Primary Axis 

Options from the list. 

4. Click the Number tab and select the number 

formatting you wish to use. 

5. Click Close. 

The formatting is applied to the axis. 

 Other Ways to Change Number Formatting: 
Right-click an axis in the chart and select Format 

Axis from the contextual menu. Click the 

Number tab in the Format Axis dialog box. 

 Tips 

 If the source data already has specific number 

formatting, it will be reflected in the chart axes. 

Creating and Working with Charts 



94 © 2010 CustomGuide, Inc. 

Emphasizing Data 

One way to emphasize data is to change the formatting of 

a specific piece of data or a data series so it stands out 

from the rest of the chart.  

Change the color of data series 

You can make a data series stand out by applying a 

different color to the series. 

1. Select the chart and click the Layout tab on the 

Ribbon. 

2. Click the Chart Elements list arrow in the Current 

Selection group of the Layout tab. 

3. Select the data series you want to change. 

4. Click the Format Selection button in the Current 

Selection group. 

The Format Data Series dialog box appears. 

 Other Ways to Format the Data Series: 
Double-click a data point in the series. Or, right-

click a data point and select Format Data Series 

from the contextual menu. 

5. Click the Fill tab and apply the fill properties you 

want to use for the data series. 

6. Click Close. 

The formatting is applied to the data series. 

Change the color of a single data point 

If a single piece of data is what you want to focus on in a 

chart, you can change the formatting of that data to make 

it stand out. 

1. Click the data series of which the data point is a part.  

Once the data series is selected, you can format the 

individual data point. 

2. Double-click the data point you wish to format. 

The Format Data Point dialog box appears. 

3. Click the Fill tab and apply the fill properties you 

want to use for the data point. 

4. Click Close. 

The formatting is applied to the data point. 

 Exercise 

• Exercise File:  Survey5-10.xlsx 

• Exercise: Emphasize the Leisure data series with an 

orange fill color. 

 Emphasize the European Leisure data point with a dark 

orange fill color. 

Figure 5-20: Changing the color of a data series in the 
chart. 

Figure 5-21: Changing the color of a single data point 

makes it stand out from the rest of the data series and 
chart. 
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Annotate the chart 

You can add trend lines and other analytical elements to 

your chart using the Analysis commands.  

1. Select the chart. 

2. Under Chart Tools on the Ribbon, click the Layout 

tab. 

Here you can see the Analysis group, which contains 

four buttons: 

 Trend line: Add a linear trend line to the selected 

data series—works well with line-type charts. 

 Lines: Add drop lines (lines that connect a data 

series line to the horizontal axis) or high-low lines 

(lines that connect two data lines) in a line-type 

chart. 

 Up/Down Bars: Add bars that graph the distance 

between two lines in a line chart. 

 Error Bars: Add bars that show the margin of 

error on the chart. 

3. Click the button you want to use in the Analysis 

group. 

A list appears, displaying different options depending 

on which button you clicked. 

4. Select the option you want to use from the list. 

A dialog box may appear, depending on the option 

you chose. Complete the dialog box to finish the 

formatting as necessary. 

Use a different chart type for a data series 

Another way to make a data series stand out from the rest 

of the chart is to apply a different chart type to that series. 

This is called a combination chart. Combining charts can 

be a powerful way to show overarching trends in data.  

One of the most common ways to do this is to make one 

of the data series in a column chart a line chart. 

1. Right-click a single data series in the chart and select 

Change Series Chart Type from the contextual 

menu.  

2. Select a new chart type for the single data series. 

Figure 5-22: An example of an annotated combination 

chart. The Net Inc. data series uses a line chart type, while 
a linear trend line appears across the top of the chart. 

Trend line 
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Using Chart Templates 

You can save a template of a chart that you’ve customized 

with your own layouts and formatting. Then you can use 

the template to create similar charts in the future. 

Save a chart as a template 

When you save a chart as a template, that chart’s 

properties are saved for easy future use. 

1. Select the chart you want to save as a template.  

2. Under Chart Tools on the Ribbon, click the Design 

tab and click the Save as Template button in the 

Type group. 

The Save Chart Template dialog box appears. 

3. Type a name for the template in the File name box 

and click Save. 

Create a new chart using a template 

Once you’ve saved a template, you can use that template 

to create a new chart. 

1. Open a workbook and select the cell range you want 

to chart. 

2. Click the Insert tab on the Ribbon and click the 

Dialog Box Launcher in the Charts group. 

The Insert Chart dialog box appears. 

3. Click the Templates folder in the list on the left. 

The templates you’ve saved appear in the gallery. 

4. Select the template you want to use from the gallery 

on the right and click OK. 

Delete a template 

If you decide you no longer need a certain chart template, 

you can delete it. 

1. Click the Insert tab on the Ribbon and click the 

Dialog Box Launcher in the Charts group. 

The Insert Chart dialog box appears. 

2. Click the Manage Templates button. 

The Charts folder is displayed. 

3. Right-click the template file and select Delete. 

The file is deleted. 

 Exercise 

• Exercise File:  Survey5-11.xlsx 

• Exercise: Save the chart in Survey5-9.xlsx as a template 

and name it “Survey Results”.  

 Open the Survey5-1.xlsx file and create a new chart using 

the “Survey Results” template. Include cells A4:E12 in the 

chart. 

 Delete the “Survey Results” template. 

Figure 5-23: The Save Chart Template dialog box. 

Creating and Working with Charts 
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Changing Chart Type 

Different types of charts are better for presenting different 

types of information. For example, a column chart is great 

for comparing values of different items, but not for 

illustrating trends or relationships. If you find that a chart 

you’ve created isn’t the best fit for your data, you can 

switch to a different chart type. 

1. Select the chart.  

The Chart Tools appear on the Ribbon. 

2. Under Chart Tools on the Ribbon, click the Design 

tab. 

Now you can see the Type group. 

3. Click the Change Chart Type button in the Type 

group. 

The Change Chart Type dialog box appears. Here you 

can see the different types of charts that are available.  

4. Select a chart type in the list on the left, then select a 

chart sub-type from the list on the right. 

5. Click OK. 

 Tips 

 You can also create a combination chart. Right-click 

a single data series in the chart and select Change 

Series Chart Type from the contextual menu. Select 

a new chart type for the single data series. 

Swap data over the axes 

You can switch the rows and columns of data in a chart so 

they appear in opposite positions. 

1. Select the chart. 

2. Under Chart Tools on the Ribbon, click the Design 

tab. 

3. Click the Switch Row/Column button in the Data 

group. 

The chart is updated to the new data configuration. 

 Trap: If the source data is too complicated 

(includes lots of nonadjacent cells), Excel cannot 

swap data over the axes. 

 Exercise 

• Exercise File: Survey5-12.xlsx 

• Exercise: Change the chart to a “Stacked Column” chart 

type. 

 Change the chart to a pie chart. Swap the data over the axis 

to view data for Business, Leisure, and Other responses. 

Figure 5-24: Selecting a Stacked Column chart in the 

Change Chart Type dialog box. 

Figure 5-25: Sometimes you need to swap data over the 
axis to view the correct data after changing chart type. 

Creating and Working with Charts 
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Using Sparklines 

Sparklines are a new feature in Excel 2010. They provide 

a new way to chart information in a worksheet: in 

individual cells. Sparklines are a great way to show a 

snapshot of data on a worksheet. 

Insert a sparkline 

1. Click the Insert tab on the Ribbon. 

There are three types of sparklines you can insert. 

Refer to the table to the right, Table 5-4: Available 

Sparklines for more information about each type. 

2. Click sparkline you want to insert in the Sparklines 

group. 

A dialog box appears, asking you to define the range 

of cells that contain the data on which you want to 

base the sparklines. 

3. Select the data you wish to use in the sparkline. 

4. Click OK. 

The sparkline is inserted in the cell(s). 

Change sparkline style 

1. Select the sparkline(s). 

2. Click the Design tab. 

3. Click the More button in the Style Gallery and 

choose the formatting you wish to apply to the 

sparkline(s). 

The sparklines are updated with the new style 

formatting. 

Add data points to sparklines 

1. Select the sparkline(s). 

2. Click the Design tab. 

3. Click the check boxes for points you wish to show or 

highlight on the sparkline. 

The sparkline is updated to show the points you 

selected. 

 Tips 

 One advantage of using sparklines is that, unlike 

charts, sparklines are included when the worksheet 

that contains them is printed. 

 Exercise 

• Exercise File: Sparklines.xlsx 

• Exercise: Insert a Line sparkline in F4 that refers to the 

data in A4:E4. 

 Insert a Win/Loss sparkline in F8 that refers to data in 

A8:E8. 

 Add High and Low Points to the sparkline in F4. 

Table 5-4: Available Sparklines 

 
Line: Shows trends in the data over time. 

 
Column: Shows differences in quantity. 

 
Win/Loss: Shows gains or losses (i.e. 

positive and negative values). 

Figure 5-26: Sparklines in a spreadsheet. 

Creating and Working with Charts 
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CCrreeaattiinngg  aanndd  WWoorrkkiinngg  wwiitthh  CChhaarrttss  

RReevviieeww  

Quiz Questions 

41. Which of these is an important thing to consider when selecting data for a chart? 
A. What is the main point? 
B. Keep it simple. 
C. What is the truth? 
D. All of these. 

42. Which of these chart types would be best for illustrating values as a percentage of a whole? 
A. Area 
B. Pie 
C. Scatter 
D. Column 

43. A line chart 
A. displays trends over time. 
B. compares values across categories. 
C. displays the contribution of each value to a total. 
D. compares pairs of values. 

44. To create a chart, click the 
A. Home tab. 
B. Insert tab. 
C. Data tab. 
D. Formulas tab. 

45. Which of these statements is false? 
A. Horizontal axis labels can be changed without affecting the source data. 
B. The order of data series can be changed without affecting the source data. 
C. Data series labels can be changed without affecting the source data. 
D. The chart source cell range can be changed in an existing chart. 

46. To remove a chart label, select the label and press <Delete>. (True or False?) 

47. Which of these options is NOT true? 
A. Gridlines can be displayed for both the horizontal and vertical axes. 
B. You can remove all gridlines from a chart by choosing None for the axis. 
C. Gridlines can only be displayed using default settings. 
D. Major and minor gridlines can be shown at the same time. 

48. Which of these is a way to change the scale of a chart? 
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A. Change the display units of an axis in the chart. 
B. Change the minimum or maximum value displayed in the chart. 
C. Add number formatting to values in an axis. 
D. All of the above. 

49. You can double-click a chart element to change its formatting. (True or False?) 

50. If you decide you no longer need a chart template that you’ve saved, you can delete it. (True or False?) 

51. Chart type cannot be changed after a chart is created. (True or False?) 

52. What is a sparkline? 
A. A way to combine two different chart types in a chart. 
B. A summary of all the charts in a workbook. 
C. A printout of a chart. 
D. A snapshot of data on a worksheet. 

 

Quiz Answers 

41. D. Consider all of these when selecting data: the main point, the truth, and simplicity. 

42. B. Pie charts are best for showing values as a percentage of a whole. 

43. A. A line chart displays trends over time. 

44. B. To create a chart, click the Insert tab, then select a chart type and chart in the Charts group. 

45. A. Horizontal axis labels are tied to the source data; they only change if the source data is changed. 

46. False. To remove a chart label, click the label button in the Labels group and select None from the list. 

47. C. Gridlines can be formatted to use whatever color, style, and width you prefer. 

48. D. All of these are ways to change the scale of a chart. 

49. True. You can double-click a chart element to change its formatting. 

50. True. If you decide you no longer need a chart template that you’ve saved, you can delete it. 

51. False. The chart type can be changed after it is created. 

52. D. A sparkline is a snapshot of data on a worksheet. 
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Once you start filling up a workbook with 

data, you’ll find that it can be difficult to 

organize and view it all at once.  

Luckily, Excel gives you several options 

for viewing and working with data and 

windows. You can split windows, insert 

new worksheets, copy worksheets, work 

with multiple workbooks at once, hide 

data, protect and share workbooks.  

In this chapter, we’ll look at ways to make 

viewing and working with data easier. 

Using Exercise Files 
This chapter suggests exercises to practice 

the topic of each lesson. There are two 

ways you may follow along with the 

exercise files: 

 Open the exercise file for a lesson, 

perform the lesson exercise, and close 

the exercise file. 

 Open the exercise file for a lesson, 

perform the lesson exercise, and keep 

the file open to perform the remaining 

lesson exercises for the chapter. 

The exercises are written so that you may 

“build upon them”, meaning the exercises 

in a chapter can be performed in 

succession from the first lesson to the last. 

 

66 
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Using Workbook Views 

There are several ways to change how a workbook’s 

contents are displayed on a screen using Workbook views. 

You can also zoom in or out to view more or less of a 

workbook at a time. 

Change workbook views 

1. Click the View tab on the Ribbon. 

2. Click the button for the view you want to use in the 

Workbook Views group. 

The workbook’s contents are shown in the selected 

view. 

 Other Ways to Change Workbook View: 
Click the button for the view you want to use in 

the status bar of the workbook window. 

Excel offers several different workbook views. 

 Normal view: This is the default Excel view, and 

the one you’ll usually want to use when creating 

and editing workbooks. Row and column headers 

are displayed. 

 Page Layout view: Use this view to fine-tune a 

worksheet before printing, especially if it contains 

charts. You can edit the worksheet like it’s in 

Normal view, but you can also see the rulers, 

change page orientation, work with headers, 

footers and margins, and hide or display row or 

column headers. 

 Page Break Preview view: This view shows you 

where the page breaks will occur if you print the 

worksheet. This is helpful for making sure your 

data is laid out correctly to appear on the desired 

page(s). 

 Full Screen view: The worksheet stays in the 

view it was already in, but toolbars are hidden so 

that the worksheet fills the entire screen. To exit 

Full Screen view, click the Restore Down button 

on the Title bar. 

 Exercise 

• Exercise File: Bookings6-1.xlsx 

• Exercise: View the worksheet in Excel’s different views. 

Zoom in to 200 percent, then zoom back to 100 percent. 

Figure 6-1: The Workbook Views group on the View tab. 

Managing Workbooks 

Normal view is the default Excel view. This view maximizes the 
available screen space in the Excel window.  

Page Break view lets you view where the page will break if you 
print the worksheet. 

Page Layout view lets you fine-tune the worksheet before 
printing. 
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Zoom in or out 

Sometimes it is helpful to make a worksheet appear larger 

on the computer’s screen, especially if you have a small 

monitor or poor eyesight. It can also be helpful to zoom 

out so that you can see how the whole worksheet looks. 

1. Click and drag the Zoom slider on the status bar to 

the percentage zoom setting you want. 

 Other Ways to Zoom: 
Click the View tab on the Ribbon and click the 

Zoom button in the Zoom group. Or, click the 

Zoom to Selection button in the Zoom group to 

zoom in on the currently selected cell(s). 

Create a custom view 

Changing the print settings, zoom level, and workbook 

appearance every time you view or print a workbook can 

get old. By creating a custom view, you can save the view 

and print settings so you don’t have to reapply them over 

and over. 

1. Click the View tab on the Ribbon and click the 

Custom Views button in the Workbook Views group.  

The Custom Views dialog box appears. 

2. Click the Add button and type a name for the view in 

the Name text box. 

There are two additional settings here: 

 Print settings: Saves print settings such as page 

breaks. 

 Hidden rows, columns and filter settings: 

Keeps columns and rows hidden and any applied 

filters filtered. 

3. Select the settings you want to use in the view and 

click OK. 

Now your view settings are quickly accessible under 

the new custom view. 

 Tips 

 To view a custom view, click the View tab on the 

Ribbon and click the Custom Views button in the 

Workbook Views group. Select the view you want to 

use and click Show. 

Figure 6-2: Select a view or adjust the Zoom slider in the 
status bar. 

Managing Workbooks 

Change views Zoom 
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Selecting and Switching 
Between Worksheets 

By default, Excel workbooks contain three worksheets. 

You can make one worksheet active at a time or select 

multiple worksheets at once. 

Switching between worksheets 

You can switch between worksheets in a workbook by 

selecting a different sheet’s tab. 

1. Click the sheet tab for the worksheet you want to 

display. 

That worksheet becomes active, allowing you to view 

and edit it. 

 Other Ways to Select a Worksheet: 
Right-click the tab scrolling buttons and select 

the worksheet from the contextual menu. Or, use 

the tab scrolling buttons to scroll through the 

sheet tabs and then select one. 

Select multiple worksheets 

Selecting multiple worksheets at once lets you enter or 

edit data on multiple worksheets, as well as format or 

print multiple worksheets at once. 

 To select adjacent worksheets: Click the first sheet 

tab you want to select, press and hold the <Shift> 

key and click the last tab you want to select. 

Both tabs and all tabs in between are selected. 

 To select non-adjacent worksheets: Click the first 

sheet tab you want to select, press and hold the 

<Ctrl> key and click the other tabs you want to 

select. 

 To select all worksheets: Right-click a sheet tab and 

select Select All Sheets from the contextual menu. 

 Tips 

 When multiple worksheets are selected, [Group] 

appears in the title bar at the top of the worksheet. 

 To cancel a selection of multiple worksheets in a 

workbook, click an unselected sheet’s tab. Or, right-

click a sheet tab that is selected and select Ungroup 

Sheets from the contextual menu. 

 Exercise 

• Exercise File: Bookings6-1.xlsx 

• Exercise: View the Friday worksheet.  Use right-click to 

view the Wednesday worksheet. 

 Use the “Next Tab Scroll” button to view the Summary 

worksheet. Use the “First Tab Scroll” button to shift 

worksheet tabs and view the Tuesday worksheet. 

 Select the Tuesday and Friday worksheets at the same time. 

Then deselect the worksheets. 

Figure 6-3: Sheet tabs and scrolling buttons. 

Managing Workbooks 

Scrolls the 
previous sheet 
tab into view 

Sheet tabs 

Scrolls to the 
first sheet tab 
in the active 
workbook 

Scrolls to the last 
sheet tab in the 
active workbook 

Scrolls the next 
sheet tab into view 
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Inserting and Deleting 
Worksheets 

You can easily add worksheets to a workbook or delete 

unwanted ones. 

Insert a worksheet 

 1. Click the Insert Worksheet tab. 

A new worksheet is added to the workbook. 

 Tip: The Insert Worksheet tab is located next to 

the sheet tabs near the bottom of the workbook 

window. 

 Other Ways to Insert a Worksheet: 
Press <Shift> + <F11>. Or, click the Home tab 

on the Ribbon and click the Insert list arrow in 

the Cells group. Select Insert Sheet. Or, right-

click the tab of an existing worksheet, and select 

Insert from the contextual menu. Select 

Worksheet in the General tab of the Insert dialog 

box and click OK. 

Delete a worksheet 

1. Right-click the sheet tab you want to delete and select 

Delete from the contextual menu. 

A dialog box appears, asking you to confirm the 

deletion. 

2. Click Yes. 

The worksheet is deleted. 

  Other Ways to Delete a Worksheet: 
Select the worksheet you want to delete, click the 

Home tab on the Ribbon, click the Delete list 

arrow in the Cells group and select Delete Sheet. 

 Exercise 

• Exercise File:  Bookings6-2.xlsx 

• Exercise: Insert a new worksheet. 

 Delete the Comments, Foreign, Domestic, Receipts 

worksheets. 

Figure 6-4: Inserting a worksheet. 

Figure 6-5: Deleting a worksheet from a workbook. 

Managing Workbooks 
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Renaming, Moving, and 
Copying Worksheets 

You can manipulate your workbooks by renaming 

worksheets and moving them into different orders and 

even into different workbooks. 

Rename a worksheet 

By default, Excel worksheets are given the rather boring 

names Sheet1, Sheet2, Sheet3, and so on. You can give 

them more meaningful names. 

1. Double-click the sheet tab. 

The sheet name is selected so that it can be renamed.  

2.  Type a new name for the worksheet.  

3. Press <Enter>. 

The sheet is renamed. 

 Other Ways to Rename a Worksheet: 
Right-click the sheet tab, select Rename from the 

contextual menu, and type a new name. Or, select 

the worksheet you want to rename, click the 

Home tab on the Ribbon, click the Format button 

in the Cells group and select Rename Sheet. Type 

a new name. 

Move or copy a worksheet 

You can easily rearrange worksheets using the Move or 

Copy dialog box or by using the mouse. 

1. Select the sheet tab(s) for the worksheet(s) you want 

to move or copy. 

2. Right-click one of the sheet tabs you want to move or 

copy and select Move or Copy from the contextual 

menu. 

The Move or Copy dialog box appears. 

 Other Ways to Move or Copy a Sheet: 
Select the sheet(s) you want to move or copy. 

Click the Home tab on the Ribbon and click the 

Format button in the Cells group. Select Move or 

Copy Sheet from the list. 

3. Select the sheet after which you want your moved or 

copied sheet(s) to appear in the Before Sheet list. 

The moved or copied sheet will be placed in front of 

the sheet that is selected. 

 Exercise 

• Exercise File:  Bookings6-3.xlsx 

• Exercise: Rename Sheet1 to “Monday”.  

 Move the worksheets so the Monday thru Friday worksheets 

are in sequential order. 

Figure 6-6: Renaming a worksheet 

Figure 6-7: The Move or Copy dialog box. 

Managing Workbooks 

Click the To book list arrow to move or copy 
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4. (Optional) Click the Create a copy check box to 

copy the selected sheet. 

If this box is check marked, the worksheet(s) will be 

copied to the new location, instead of simply being 

moved. 

5. Click OK. 

The worksheet(s) are moved or copied to the new 

location. 

Move or copy a worksheet using click and 
drag 

The easiest way to move or copy a worksheet within a 

workbook is with the mouse. 

1. Select the sheet you want to move or copy. 

2. Click and drag the sheet tab to move it to a new 

location in the workbook. Or, press and hold the 

<Ctrl> key while you click and drag the sheet tab to 

copy the sheet. 

 Tips 

 To change the color of a sheet tab, right-click the tab, 

point to Tab Color and select a color from the 

palette. 

Figure 6-8: Click and drag to move a worksheet. 

Managing Workbooks 

Click and drag a worksheet tab 
to move it in the workbook. 
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Splitting and Freezing a 
Window 

Splitting or freezing a workbook window allows you to 

hold certain sections of a worksheet in place while 

scrolling to view other areas. It is especially useful when 

working with a large worksheet because you can lock 

column and row headings in place while scrolling through 

the data in the rest of the worksheet. 

Split a worksheet window 

To view multiple areas of the worksheet in the same 

window, you can split the window into two or four panes. 

When a worksheet window is split, panes are created in 

the window. These panes can be navigated independently, 

allowing you to make changes and view multiple areas of 

a worksheet at once. 

 1. Select the cell where you want to split the window.  

The worksheet will be split above and to the left of 

the active cell, creating four panes. 

To split into only two panes, select a cell in the top or 

bottom-most visible row, or the left-most visible 

column. 

2. Click the View tab on the Ribbon and click the Split 

button in the Window group. 

The worksheet is split into sections that can be 

navigated individually without moving other 

sections. 

 Other Ways to Split the Window: 
Click and drag the vertical split box or the 

horizontal split box to where you want the 

window to split. 

Adjust split panes 

You can adjust where the panes appear in the window 

after a split is created. 

1. Click and drag the split line. 

The size of the window pane is changed according to 

where you clicked and dragged the pane. 

Remove a worksheet window split 

1. Click the Split button in the Window group. 

The window is no longer split. 

 Other Ways to Remove a Window Split: 
Click and drag the split line to the edge of the 

window. 

 Exercise 

• Exercise File:  Bookings6-4.xlsx 

• Exercise: View the Tuesday worksheet. 

 Split the window at column C and scroll to the right in the 

right pane. Remove the split.  

 Set and freeze panes at column B and row 4. Scroll down to 

row 60. 

 Unfreeze the panes in the worksheet. 

Figure 6-9: A split worksheet window. 

Managing Workbooks 
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Freeze window panes 

When you freeze panes, the panes above and to the left of 

the active cell are immobilized. This is different from 

splitting, in which each section can be navigated. Also, 

while you can move split lines, you can’t move frozen 

sections without unfreezing and freezing again. 

1. Click the View tab on the Ribbon and click the 

Freeze Panes button in the Window group. 

Here you have three options: 

 Freeze Panes: Freezes the worksheet above and 

to the left of the cell that is currently active. 

Creates two or four panes depending on the 

location of the active cell. 

 Freeze Top Row: Keeps the top row visible and 

allows you to scroll through the rest of the 

worksheet. Creates two panes. 

 Freeze First Column: Keeps the first column 

visible and allows you to scroll through the rest of 

the worksheet. Creates two panes. 

2. Select the option you want to use from the list.  

The panes are frozen. You can use the scroll bars to 

move around in the worksheet. 

Remove a worksheet window split 

Now let’s unfreeze the panes. 

1. Click the Freeze Panes button in the Window group 

and select Unfreeze Panes. 

All cells in the worksheet are unfrozen so you can 

scroll freely throughout the entire worksheet. Figure 6-10: A worksheet with frozen panes: columns A-B, 

and rows 1-4. Information in the frozen panes remains on 
the screen as you scroll and move through a worksheet. 

Managing Workbooks 
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Creating Headers and Footers 

You can use a header to include the same information at 

the top of every printed page or a footer to include 

information at the bottom of every page. You can enter 

your own headers or footers, insert built-in ones, or insert 

specific elements such as pictures or page numbers. 

Create a basic header or footer 

 1. Click the Insert tab on the Ribbon and click the 

Header & Footer button in the Text group.  

The workbook automatically switches to Page Layout 

View and the cursor appears in the header area.  

The header and footer areas are split into three 

sections—left, right, and center. Click any of the 

sections to enter text in that section. 

 Tip: Enter your note here. To work with the footer 

instead of the header, click the Click to add 

footer text at the bottom of the worksheet or click 

the Go To Footer button in the Navigation group 

on the Design tab. 

2. Enter header text, then click away from the header 

area. 

When you are finished working with the header and 

footer, you can return to Normal view. 

 Other Ways to Create a Header or Footer: 
Click the View tab on the Ribbon and click the 

Page Layout View button in the Workbook Views 

group. Click in the header or footer area. 

Use Auto Headers & Footers 

Instead of entering your own header or footer text or 

fields, use built-in options that are already available. 

1. Click the Insert tab on the Ribbon and click the 

Header & Footer button in the Text group. 

Now you can add an auto header or footer. 

2. Click either the Header or Footer button in the 

Header & Footer group on the Design tab. 

Here you will see a list of many different types of 

page numbers, titles, dates, and file paths that can be 

added. 

3. Select the auto header or footer you want to use. 

It is automatically inserted into the worksheet. Any 

manual header or footer information you have 

previously entered is replaced. 

 Exercise 

• Exercise File:  Bookings6-5.xlsx 

• Exercise: View the Tuesday worksheet.  

 Open the header and add “Tuesday Reservations” in the 

center section.  

 Add a page number field in the right section of the footer. 

 Return to Normal view. 

Figure 6-11: Adding header text. 

Figure 6-12: A spreadsheet with header and footer. 

Managing Workbooks 
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Comment [Dan1]: Creating Headers and Footers 
 
Create a basic header or footer 
1. Open the Sales7-1.xlsx file. 
 
2. Click the Insert tab on the Ribbon and click the Header & Footer button in the 
Text group. 
 
3. Click the center section of the header. 
 

4. Type Monthly Sales. 

 
Use Auto Headers & Footers 
Explain these options to your students, even though they are not used in the 
exercise. 
 
Built-in headers and footers are incredibly helpful and time-saving. Take a look at 
these helpful options with students. 
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Insert Header & Footer Elements 

You can also insert individual elements into the header or 

footer such as pictures or page numbers. 

1. Click the Insert tab on the Ribbon and click the 

Header & Footer button in the Text group. 

The Header & Footer Elements group appears on the 

Design tab, displaying commands to add several 

different elements to your header or footer. 

2. Click the button in the Header & Footer Elements 

group for the element you want to add. 

 Tips 

 Headers and footers can be formatted using the 

commands in the Font group on the Home tab. 

 You can also work with headers and footers by using 

the Page Setup dialog box. Click the Page Layout 

tab and click the Dialog Box Launcher in the Page 

Setup group. Click the Header/Footer tab. Here you 

can edit headers and footers and select to withhold 

the header or footer from the first page or to 

designate different odd and even pages. 

Table 6-1: Header & Footer Elements Group 

Button Description 

 Page Number 
Displays the correct page number for each page. 

 Number of Pages 
Displays the total number of pages in the worksheet. 

 Current Date 
Displays the current date. 

 Current Time 
Displays the current time of day. 

 File Path 
Displays the workbook’s name and file path. 

 File Name 
Displays the workbook’s name. 

 Sheet Name 
Display’s the worksheet’s name. 

 Picture 
Opens the Insert Picture dialog box, where you can browse for and insert a picture file. 

 Format Picture 
Is only available once a picture has been inserted; this button allows you to adjust the picture’s size, 

brightness or contrast. 

Managing Workbooks 

Comment [Dan2]: Creating Headers and Footers cont’d 
 
Insert Header & Footer Elements 
5. Click the right section of the header. 
 
6. Click the Page Number button in the Header & Footer Elements 
group. 
The page number field is added to the worksheet. 
 
Table 7-1: Header & Footer Elements Group great additions to 
workbooks. See if the combination of elements you need already exists in 
built-in options. 
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Hiding Rows, Columns, 
Worksheets, and Windows 

You can hide rows, columns, worksheets and entire 

workbook windows from view. Data isn’t deleted, but 

simply hidden from view until you unhide it. 

Hide or unhide a row or column 

You can easily hide whole rows or columns from view.  

1. Select the row or column heading(s) for the row(s) or 

column(s) you want to hide. 

2. Right-click the heading and select Hide from the 

contextual menu. 

The row(s) or column(s) are hidden. 

 Other Ways to Hide a Row or Column: 
Select the row or column heading(s) for the 

row(s) or column(s) you want to hide. On the 

Home tab, click the Format button in the Cells 

group. Point to Hide & Unhide and select Hide 

Rows or Hide Columns. 

Now let’s look at how to unhide rows and columns. 

3. Select the row or column heading(s) on both sides of 

the hidden row(s) or column(s). 

For example, if columns C and D were hidden, you 

would select the B and E column headings. 

4. Right-click the heading and select Unhide from the 

contextual menu. 

 Other Ways to Unhide a Row or Column: 

Select the row or column heading(s) on both sides 

of the hidden row(s) or column(s). On the Home 

tab, click the Format button in the Cells group. 

Point to Hide & Unhide and select Unhide Rows 

or Unhide Columns. 

Hide or unhide a worksheet 

Sometimes you may want to hide an entire worksheet. 

1. Right-click the sheet tab for the worksheet you want 

to hide. 

2. Select Hide from the contextual menu. 

The sheet is hidden. It still exists in the workbook so 

any references to the sheet will still work. 

Now let’s unhide the sheet. 

 Exercise 

• Exercise File:  Bookings6-6.xlsx 

• Exercise: View the Tuesday worksheet.  

 Hide columns E – G.  Unhide them.  

 Hide the Wednesday worksheet, then unhide it.  

 Hide the Bookings workbook window, then unhide it. 

Figure 6-13: A worksheet before and after hiding columns. 
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All columns are visible.  

Columns E, F and G are hidden.  

A thick dark line indicates 
hidden columns. 

Comment [Dan3]: Hiding Rows, columns, Worksheets and Windows 
 
Hide or unhide a row or column 
1. Open the Sales6-8.xlsx file. 
 
2. Click the column E heading. 
 
3. Press and hold the <Shift> key. 
 
4. Click the column G heading. 
Let’s hide columns E:G. 
 
5. Right-click the heading and select Hide from the contextual menu. 
 
The columns are hidden. Notice that the letters do not update to accommodate the 
hidden columns. This verifies that the columns still exist in the spreadsheet. 
 
6. Click and drag to select column headings D:H. 
 
7. Right-click the column headings and select Unhide from the contextual menu. 
Columns E:G appear in the spreadsheet again. 
 
Hide or unhide a worksheet 
8. Right-click the Qtr 3&4 sheet tab. 
 
9. Select Hide from the contextual menu. 
 
10. Right-click a sheet tab and select Unhide from the contextual menu. 
 
11. Select Qtr 3&4 and click OK. 
 
Now delete the worksheet. 
 
12. Right-click the Qtr 3&4 sheet and select Delete from the contextual menu. 
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3. Right-click any sheet tab and select Unhide from the 

contextual menu. 

The Unhide dialog box appears.  

4. Select the sheet you want to unhide and click OK. 

The sheet is unhidden. 

 Other Ways to Hide and Unhide a Worksheet: 
Select the worksheet you want to hide. On the 

Home tab, click the Format button in the Cells 

group. Point to Hide & Unhide and select Hide 

Sheet. To unhide it, click the Format button in 

the Cells group, point to Hide & Unhide, and 

select Unhide Sheet. Click OK. 

Hide or unhide a workbook window 

You can also hide the entire active workbook window. 

1. Click the View tab on the Ribbon. 

2. Click the Hide Window button in the Window group. 

The active window is hidden. The Excel program 

window remains open and active, but the workbook 

is hidden. It does not even appear in the Switch 

Windows button or on the Taskbar. 

Here’s how to make the window reappear. 

3. Click the Unhide Window button in the Window 

group. 

The window is unhidden.  

 Tip: If there is more than one window hidden, the 

Unhide dialog box will appear. Select which 

window you want to unhide and click OK. 

Figure 6-14: Selecting a hidden sheet to unhide. 

Figure 6-15: Selecting a hidden workbook to unhide. 

Managing Workbooks 
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Setting the Print Area 

There are two ways to specify the workbook data that is 

printed: setting the print area and adjusting page breaks. 

Set print area 

Sometimes you may only want to print part of a 

worksheet. You can define an area so that any time you 

print, only that cell range is printed. 

1. Select the cell range you want to print.  

2. Click the Page Layout tab on the Ribbon and click 

the Print Area button in the Page Setup group. 

3. Select Set Print Area from the list. 

Dashed lines appear around the new print area.  

 Trap: When a print area is set, only the print area 

that is defined prints. You must clear the print area 

if you want to return to the default page setup. 

 Tips 

 Once you set a print area, you can add additional 

print areas. Select the additional cells, click the Print 

Area button in the Page Setup group, and select Add 

to Print Area. The added area also has dashed lines 

around it. 

Clear print area 

Clear the print area and return to the default page setup. 

1. Click the Page Layout tab on the Ribbon and click 

the Print Area button in the Page Setup group. 

A list of print area options appears. 

2. Select Clear Print Area from the list. 

The print area is cleared. 

View page breaks 

Excel automatically breaks the page based on the margins 

and other page settings, but you can adjust these page 

breaks or add your own to divide a worksheet into 

separate pages for printing. 

1. Click the View tab on the Ribbon and click the Page 

Break Preview button in the Workbook Views group.  

The worksheet appears in Page Break Preview view. 

Dashed lines indicate automatic page breaks, while 

solid lines represent page breaks that have been 

changed or added. 

 Exercise 

• Exercise File:  Bookings6-7.xlsx 

• Exercise: View the Tuesday worksheet. Set the print area 

to A1:E61. 

 Move the page break after row 60 up to row 40. 

 Add a page break after row 18, then remove the break. 

Figure 6-16: Setting a print area. 

Managing Workbooks 
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 Other Ways to Open Page Break Preview 

View: 
Click the Page Break Preview button on the 

status bar. 

Move a page break  

You can move existing page breaks in Page Break 

Preview view. 

1. Position the mouse pointer over the page break line 

so the cursor changes . 

2. Click and drag the page break to a new location. 

The dashed line turns into a solid line, indicating the 

break has been changed. 

Insert a page break 

You can insert new vertical and horizontal page breaks in 

the workbook. 

1. Right-click the cell below or to the right of where 

you want to insert the page break. 

A contextual menu appears.  

 Tip: It can be a little confusing to figure out 

which cell to click to insert a certain type of page 

break. See the table to the right for more 

information on where to click. 

2. Select Insert Page Break from the contextual menu. 

The break is inserted. 

 Other Ways to Insert a Page Break: 
Click the Page Layout tab on the Ribbon and 

click the Breaks button in the Page Setup group. 

Select Insert Page Break from the list. 

Remove a page break 

1. Click and drag the page break line outside of the 

Page Break Preview area. 

The page break is removed. 

 Other Ways to Remove a Page Break: 
Select the cell below or to the right of where you 

want to insert or remove a page break.  Click the 

Page Layout tab on the Ribbon and click the 

Breaks button in the Page Setup group.  Select 

Remove Page Break. Select Reset All Page 

Breaks to remove all page breaks. 

Figure 6-17: Moving a page break in Page Break Preview 
view. 

Table 6-2: Inserting Page Breaks 

Horizontally Select a cell in column A that is in the row 

below where you want the page break. 

Vertically Select a cell in Row 1 that is in the column 

to the right of where you want the page 

break. 

Horizontally 

and Vertically 

Select the cell below and to the right of 

where you want the page break. 

Managing Workbooks 

Page Break Preview 
button 

Click and drag the page break 
indicator line to where you want 
the page to break. 
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Adjusting Page Margins and 
Orientation 

Margins are the empty space between the worksheet data 

and the left, right, top, and bottom edges of the printed 

page. In this lesson, you’ll learn how to adjust a page's 

margins. 

You’ll also learn how to change the page orientation. 

Everything you print uses one of two orientations: portrait 

or landscape. In portrait orientation, the paper is taller 

than it is wide—like a painting of a person’s portrait. In 

landscape orientation, the paper is wider than it is tall—

like a painting of a landscape. 

Adjust margins 

By default, the margins in Excel worksheets are 0.75 

inches at the top and bottom, and 0.70 inches to the left 

and right. 

1. Click the Page Layout tab on the Ribbon and click 

the Margins button in the Page Setup group. 

A list of three margin options appears: Normal, Wide, 

or Narrow.  

2. Select the margin size you want to use from the list. 

The margins adjust to the new setting. 

 Tip: If you don’t see a margin size you want to 

use, select Custom Margins to display the 

Margins tab of the Page Setup dialog box. Here 

you can set your own custom margins and even 

adjust the size of headers and footers. 

Adjust orientation 

Portrait orientation is the default setting for printing 

worksheets, but you may often want to use landscape 

orientation instead. 

1. Click the Page Layout tab on the Ribbon and click 

the Orientation button in the Page Setup group. 

A list of two options appears:  

 Portrait: In Portrait orientation, the paper is taller 

than it is wide—like a portrait painting. 

 Landscape: In Landscape orientation, the paper is 

wider than it is tall—like a landscape painting. 

2. Select the page orientation you want to use. 

The orientation changes. 

 Exercise 

• Exercise File:  Bookings6-8.xlsx 

• Exercise: View the Tuesday worksheet. In Page Layout 

view, apply Wide margins and Landscape orientation. Print 

preview the worksheet. 

 Reapply Portrait orientation and preview the worksheet. 

Figure 6-18: Adjusting margins. 

Figure 6-19: An example of a spreadsheet in landscape 
orientation view. 

Managing Workbooks 



  University of Virginia Health System 117 

Adding Print Titles, Gridlines, 
and Row and Column 
Headings 

You can specify rows and columns to repeat on each 

printed page. You can also select whether you want to 

view or print cell gridlines and row and column headings. 

Print row or column titles 

The Print Titles command allows you to designate certain 

rows and columns to repeat on every printed page. 

 1. Click the Page Layout tab on the Ribbon and click 

the Print Titles button in the Page Setup group.  

The Page Setup dialog box appears, displaying the 

Sheet tab. 

In the Print titles area, there are two text boxes: 

“Rows to repeat at top” and “Columns to repeat at 

left.” You can use the cell reference buttons next to 

the text boxes to select the ranges that contain the 

labels you want to repeat on every page. 

2. Click the Rows to repeat at top or Columns to 

repeat at left cell reference button. 

The dialog box is minimized so you can see the 

spreadsheet and select the cells you want to repeat. 

3. Select the rows or columns you want to appear on 

every printed page and click the cell reference 

button. 

The dialog box expands to its full size once again. 

4. Click OK. 

Now when you print, the rows and/or columns you 

selected will appear on every page.  

View or print gridlines and headings 

You can also choose whether you want to view or print 

the worksheet cell gridlines or the column and row 

headings. 

1. Click the Page Layout tab on the Ribbon. 

The Sheet Options group has commands for working 

with the gridlines and headings in a workbook. 

 Gridlines: The gridlines that appear in the 

spreadsheet to delineate each cell by default. 

Select the Print option to print the gridlines with 

the data. 

 Exercise 

• Exercise File:  Bookings6-9.xlsx 

• Exercise:  View the Tuesday worksheet.  

 Use the Print Titles command to make row 4 repeat on 

every page.  

 Set Sheet Options to display gridlines and headings when 

printing.  

Figure 6-20: Adjusting print titles, gridlines and headings 

on the Sheet tab of the Page Setup dialog box. 

Managing Workbooks 

Click the cell reference button to 
minimize the dialog box and select 
cells in the spreadsheet. 
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 Headings: The column and row headings (A, B, 

C… and 1, 2, 3…) appear by default in the 

spreadsheet to help identify cells. Select the Print 

option so these headings are printed with the data. 

2. Select the options you want to use in the Sheet 

Options group. 

If you selected the Print check box for Gridlines or 

Headings, you can preview how the worksheet will 

print in Print Preview or Page Layout view. 

  Other Ways to Print Gridlines or Headings: 
Click the Page Layout tab on the Ribbon and 

click the Dialog Box Launcher in the Sheet 

Options group. Select the option you want to use 

in the Print area. Here you can even select a 

different printed page order (“Down, then over” 

or “Over, then down”).  

Figure 6-21: Worksheets without and with gridlines and headings. 
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A print preview of a worksheet without gridlines or headings 
displayed. 

A print preview of a worksheet with gridlines and headings 
displayed. 
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Adjusting Paper Size and Print 
Scale 

If you plan to print a worksheet on paper that isn’t Letter 

size, you’ll need to select a different paper size in Excel. 

You can also adjust the scale of your printed worksheet so 

that the printed data stretches or shrinks to fit the number 

of pages you specify. 

Adjust paper size 

You can print Excel worksheets on many different sizes of 

paper. 

1. Click the Page Layout tab on the Ribbon and click 

the Size button in the Page Setup group. 

 A list of common page sizes appears. 

2. Select the paper size you want to use from the list. 

The worksheet layout updates to the new paper size.  

Scale to fit 

You can tell Excel how many pages wide or tall you want 

the data to fit onto when printed. 

1. Click the Page Layout tab on the Ribbon. 

The Scale to Fit group has three options you can 

choose from to adjust the worksheet’s scale for 

printing: 

 Width: Select the maximum width—in number of 

pages—you want the printed data to occupy. 

 Height: Select the maximum height—in number 

of pages—you want the printed data to occupy. 

 Scale: Enter a percentage or use the arrow buttons 

to stretch or shrink the printed output to a 

percentage of its actual size. 

2. Select the scale command you want to use in the 

Scale to Fit group and adjust the scale as necessary. 

The worksheet is scaled to fit the new settings. 

 Other Ways to Scale to Fit: 
Click the Dialog Box Launcher in the Scale to 

Fit group to display the Page tab in the Page Setup 

dialog box. Select the options you want to use in 

the Scaling area. 

 Exercise 

• Exercise File:  Bookings6-10.xlsx 

• Exercise:  View the Tuesday worksheet.  

 In Page Layout view, adjust the paper size to Legal. Change 

the scale so that the worksheet fits onto 1 page wide by 1 

page tall.  

 Print preview the worksheet.  

 Change the scale back to automatic width and height and 

return the paper size to Letter. 

Figure 6-22: Adjusting paper size and scaling on a 
worksheet. 
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Printing a Selection, Multiple 
Worksheets, and Workbooks 

Excel offers several ways to print, so you can print 

selected data, multiple worksheets, or an entire workbook. 

Print selected data 

Selecting data and then printing it lets you have complete 

control over what is printed. This is sometimes easier than 

setting a print area. 

1. Select the data you wish to print. 

2. Click the File tab and select Print. 

3. Click the Print Active Sheets button and select Print 

Selection from the list. 

4. Click the Print button. 

Print multiple worksheets 

You can print several worksheets at once.  

1. Select multiple sheet tabs. 

 Tip: To select adjacent tabs, press and hold the 

<Shift> key and select the first and last worksheet 

tabs you want to select. Or, to select non-adjacent 

tabs, press and hold the <Ctrl> key and click the 

desired tabs. 

2. Click the File tab and select Print.  

3. Click the Print button. 

Print a single workbook 

Printing a workbook prints all the worksheets in the 

workbook. 

1. Open the workbook you wish to print. 

2. Click the File tab and select Print. 

3. Click the Print Active Sheets button and select Print 

Entire Workbook from the list. 

4. Click the Print button. 

 Exercise 

• Exercise File:  Bookings6-11.xlsx 

• Exercise: Print or print preview cells A4:E30. 

 Print or print preview the Tuesday, Thursday, and Summary 

worksheets. 

Figure 6-23: Backstage View with multiple pages selected 
for printing. 
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Several worksheets are 
selected for print, as indicated 
by [Group] in the title bar.  
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Working with Multiple 
Workbook Windows  

This lesson explains how to view and work with more 

than one workbook at a time. 

Switch between workbook windows 

If you have more than one workbook window open, you 

can quickly switch between the windows. 

1. Click the Excel button in the taskbar and select the 

window you want to view. 

 Other Ways to Switch Between Workbooks: 
Click the View tab on the Ribbon and click the 

Switch Windows button in the Window group. 

Select the workbook you want to view from the 

list. 

The selected document window becomes the active 

document. 

View multiple workbooks at once 

1. Click the View tab on the Ribbon and click the 

Arrange All button in the Window group. 

The Arrange Windows dialog box appears, allowing 

you to arrange the open workbooks in Tiled, 

Horizontal, Vertical, or Cascade order.  

2. Select the option you want to use. 

 Other Ways to View Multiple Workbooks: 
Click the View tab on the Ribbon and click the 

View Side By Side button in the Window group. 

If the Compare Side by Side dialog box appears, 

select the workbook you want to display alongside 

the active workbook and click OK. 

 Tips 

 Click the Save Workspace button in the Window 

group to save the layout of the open windows for 

future access. 

Create another workbook window 

You can view a workbook in more than one window at a 

time. 

1. Click the View tab on the Ribbon and click the New 

Window button in the Window group. 

Another window with the workbook’s contents 

appears in the Excel program window. 

 Exercise 

• Exercise File:  Bookings6-12.xlsx; Sales.xlsx 

• Exercise: Switch between the two workbooks.  

 Arrange the windows vertically. 

 Open a new window of the Bookings workbook. Close the 

new window. 

 Close the Sales workbook. 

Figure 6-24: The Arrange Windows dialog box. 

Figure 6-25: Two workbooks arranged vertically. 
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the multiple windows 
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workbook. 

New Window 
button 

Arrange All 
button 



122 © 2010 CustomGuide, Inc. 

 Tips 

 Viewing the same workbook in multiple windows 

does not create a new file. When a change is made to 

the workbook in one window, the change is reflected 

in all the windows for the workbook. 

 Each instance of a workbook window is marked in 

the title bar. For example, if a new window was 

opened for Workbook 1, the two windows would be 

named Workbook 1:1 and Workbook 1:2. 

 

Figure 6-26: A workbook with multiple workbook windows 
open. 

Managing Workbooks 
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Creating a Template 

If you find yourself recreating the same type of workbook 

over and over, you can save yourself some time by using a 

template. A template is a workbook that contains labels, 

formulas, formatting, and macros you use frequently. 

Once you have created a template you can use it to create 

new workbooks. 

1. Create or open a workbook to use as a template. 

2. Click the File tab on the Ribbon and select Save As. 

The Save As dialog box appears. 

There are three basic types of templates you can 

create: 

 Excel Template: This is the standard Excel 2007 

template that works with XML. 

 Excel Macro-Enabled Template: This type of 

template is the standard template but is enabled to 

work with XML. 

 Excel 97-2003 Template: Use this to create 

workbooks that are compatible with earlier 

versions of Excel. These files are not XML 

compatible. 

3. Click the Save as type list arrow and select the type 

of template you want to create.  

Once you change the file type to a template, the 

location automatically changes to the Templates 

folder. 

4. Enter a name for the template in the File name text 

box. 

5. Click the Save button. 

The template is saved. Now you can use the template 

to create new workbooks. 

 Exercise 

• Exercise File:  Bookings6-13.xlsx 

• Exercise: Save the file as an Excel Template and name it 

“Bookings”. 

Figure 6-27: Saving a workbook as an Excel Template. 

Managing Workbooks 
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MMaannaaggiinngg  WWoorrkkbbooookkss  RReevviieeww  

Quiz Questions 

53. Which of the following is NOT a view option in Excel? 
A. Normal view 
B. Edit view 
C. Page Layout view 
D. Page Break Preview view 

54. You can use the Zoom slider to change the magnification level of a worksheet. (True or False?) 

55. To select a worksheet, click the View tab on the Ribbon, click the Sheet button in the Worksheet Selection group, and 

select the sheet you want to make active. (True or False?) 

56. You can add additional worksheets to a workbook. (True or False?) 

57. You can move a worksheet within a workbook simply by dragging the sheet's tab to a new location. (True or False?) 

58. Splitting and freezing a workbook window are exactly the same thing. (True or False?) 

59. You can work with headers and footers easiest in Page Layout View. (True or False?) 

60. When you hide a row, column, or worksheet, the hidden data is deleted. (True or False?) 

61. In Page Break Preview view, you can move a page break by clicking and dragging it to a new location. (True or 

False?) 

62. In Page Break Preview view, you can move a page break by clicking and dragging it to a new location. (True or 

False?) 

63. Which of the following is NOT a preset margin size setting available in Excel? 
A. Large 
B. Normal 
C. Wide 
D. Narrow 

64. The Sheet Options group on the Page Layout tab has commands that allow you to view or print which of the 

following: 
A. The Formula Bar 
B. Formulas 
C. Page numbers 
D. Gridlines 
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65. The default paper size in Excel is: 
A. Legal 
B. Letter 
C. Executive 
D. A4 

66. Which of these is not a possible way to print? 
A. Print selected data 
B. Print multiple workbooks 
C. Print an entire workbook 
D. Print multiple worksheets from a workbook 

 

Quiz Answers 
 

53. B. Edit view is not an Excel view option. 

54. True. The Zoom slider on the status bar lets you zoom in and out of a worksheet. 

55. False. To select a worksheet, click that worksheet's tab at the bottom of the workbook window. 

56. True. You can add and delete worksheets. 

57. True. You can move a worksheet within a workbook simply by dragging the sheet's tab to the new location. Hold down 

the Ctrl key if you want to copy it. 

58. False. They are similar, but splitting allows you to scroll through all window sections independently. Also, you can 

move split lines but not frozen sections. 

59. True. Page Layout View makes it easy to work with headers and footers. 

60. False. Hiding data doesn't delete it, it just hides it from view until it is unhidden. 

61. True. In Page Break Preview view, you can move a page break by clicking and dragging it to a new location. 

62. True. In Page Break Preview view, you can move a page break by clicking and dragging it to a new location. 

63. A. Large is not a margin size option in Excel. 

64. D. You can view or print gridlines and headings using the commands in the Sheet Options group. 

65. B. Letter is the default paper size in Excel. 

66. B. In Excel 2010, you can only print one workbook at a time. 
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Formulas with Multiple Operators ................. 128 

Inserting and Editing a Function.................... 129 
Insert Function dialog box...................... 129 
Function Library ..................................... 130 
Edit a function ........................................ 130 

AutoCalculate and Manual Calculation ......... 131 
Use AutoCalculate ................................. 131 
Change AutoCalculate options .............. 131 
Manual formula calculation options ....... 131 

Defining Names ............................................... 133 
Define a name for a cell range .............. 133 
Define names with the New Name dialog 
box ......................................................... 133 

Using and Managing Defined Names ............ 135 
Use defined names ................................ 135 
View defined names .............................. 135 
Edit defined Subheading........................ 135 
Delete defined names ............................ 136 

Displaying and Tracing Formulas .................. 137 
Display formulas .................................... 137 
Trace precedents and dependents ........ 137 
Use the Watch Window ......................... 138 

Understanding Formula Errors ...................... 139 

Using Logical Functions (IF) .......................... 141 

Using Financial Functions (PMT) ................... 142 

Using Database Functions (DSUM) ............... 143 

Using Lookup Functions (VLOOKUP) ........... 144 

User Defined and Compatibility Functions ... 145 
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Date & Time Functions .................................... 147 

Math & Trig Functions ..................................... 149 

Statistical Functions ........................................ 151 

Lookup & Reference Functions ..................... 152 

Database Functions......................................... 153 

Formulas are the heart and soul of a 

spreadsheet. Without formulas, Excel 

would be nothing more than a grid for 

displaying numbers and text. As you will 

see in this chapter, formulas can do a lot 

more than just adding, subtracting, 

multiplying, and dividing. Excel has 

hundreds of different formulas you can 

use to create complex statistical, financial, 

and scientific calculations. The most 

expensive calculator in the world couldn’t 

come close to matching all of Excel’s 

functions.  

In this chapter, you’ll learn about more 

complex formula writing, how to insert 

and edit functions, how to define names, 

and how to trace formulas and diagnose 

errors. 

Using Exercise Files 
This chapter suggests exercises to practice 

the topic of each lesson. There are two 

ways you may follow along with the 

exercise files: 

 Open the exercise file for a lesson, 

perform the lesson exercise, and close 

the exercise file. 

 Open the exercise file for a lesson, 

perform the lesson exercise, and keep 

the file open to perform the remaining 

lesson exercises for the chapter. 

The exercises are written so that you may 

“build upon them”, meaning the exercises 

in a chapter can be performed in 

succession from the first lesson to the last. 
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Text Functions ................................................. 154 

Logical Functions ............................................ 155 
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Formulas with Multiple 
Operators 

Formulas can contain several values, such as 81 and 3.5; 

cell references, such as B5 and C1:D11; operators, such as 

* (multiplication) and + (addition); and functions, such as 

SUM and AVERAGE. When you combine several 

operations and functions into a single formula, Excel 

performs the operations in a predetermined order. 

When a formula contains several operators with the same 

precedence, Excel calculates the formula from left to 

right. You can change the order by enclosing the part of 

the formula you want Excel to calculate first in 

parentheses. The table below, Order in Which Excel 

Performs operations in Formulas, is a good reference for 

how to structure formulas with multiple operations. 

 Tips 

 All formulas must begin with an equal sign (=). 

Table 7-1: Order in Which Excel Performs Operations in Formulas 

 

( ) 

Parentheses change the order of evaluation.  

For example: 

=(20+5)/(10-5) would add 20 and 5 (25), subtract 10 by 5 (5) and then divide the results to equal 5. 

But… 

=20+5/10-5 would divide 5 by 10 (0.5), add the result to 20 (20.5) and then subtract 5 to equal 15.5. 

: Reference Operator 

% Percent 

^ Exponentiation 

* and / Multiplication and division 

+ and - Addition and subtraction 

=  < >  <=  

>= 
Comparison 

 Exercise 

• Exercise File: None required. 

• Exercise: Open a new blank workbook. In cell A1, enter 

=(20+5)/(10-5). In cell A2, enter =20+5/10-5.  

Notice that the parentheses cause the formulas to have 

different results.  

 Close the workbook without saving. 

Figure 7-1: Understanding how formulas with multiple 
operators are performed in Excel. 
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Inserting and Editing a 
Function 

There are several hundred functions available in Excel. 

Some are simple, such as the SUM function. Others are 

much more complex and contain several different 

arguments. For example, the syntax for the DB function, 

which is used to depreciate an asset, is 

DB(cost,salvage,life,period,month). 

Fortunately, the Insert Function feature is available to 

help you select, enter, and edit worksheet functions. 

Insert a function using the Insert Function 
dialog box 

1. Select the cell where you want to enter the formula 

and click the Insert Function button on the Formula 

Bar. 

The Insert Function dialog box appears. The table on 

the next page, Function Categories, describes the 

function categories available in Excel. 

 Other Ways to Open the Insert Function 

Dialog Box: 
Click the Formulas tab on the Ribbon and click 

the Insert Function button in the Function 

Library group. 

2. Click the Or select a category list arrow and select a 

function category. 

All the functions in the selected category appear in 

the “Select a function” list. 

 Other Ways to Find a Function in the Insert 

Function Dialog Box: 
Type a description of the function in the “Search 

for a function” text box and click Go. The related 

functions appear in the “Select a function list.” 

 3. Select the function you want to use in the “Select a 

function” list and click OK. 

The Function Arguments dialog box appears. Here 

you need to enter the arguments, which are the values 

or cell references needed to calculate the function.  

 Tip: Instead of typing argument values into the 

dialog box, you can click a Collapse Dialog 

button, select a cell range in the worksheet, and 

then click the Expand Dialog button. 

4. Enter the arguments in the text boxes and click OK. 

The function is inserted into the cell.  

 Exercise 

• Exercise File: Sales7-1.xlsx 

• Exercise: Use the Insert Function dialog box to insert the 

AVERAGE function in cell B13 and find the average of all 

the Net Inc. values (B11:G11). 

 Use the Date & Time button in the Function Library group 

on the Ribbon to insert the TODAY function in cell A1. 

Figure 7-2: Selecting a function category in the Insert 
Function dialog box. 

Figure 7-3: Function Arguments dialog box. 
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Insert a function using the Function Library 

Another way you can access functions by category is in 

the Function Library group.  

1. Select the cell where you want to enter the formula 

and click the Formulas tab on the Ribbon. 

In the Function Library group, you’ll see the same 

categories of functions that are available in the Insert 

Function dialog box, plus the AutoSum button that 

automatically inserts the Sum function. 

2. Click a function category button in the Function 

Library and select the function you want to use. 

The Function Arguments dialog box appears. 

3. Enter the arguments in the text boxes and click OK. 

The function is inserted into the cell. 

 Tip: If you click a function category button in the 

Function Library and then point to a function, a 

ScreenTip appears that describes the formula. 

Edit a function 

1. Select the cell with the function you want to edit. 

Choose from the following options: 

 Click the Insert Function button on the formula 

bar and edit the function arguments in the 

Function Arguments dialog box. 

 Click in the formula bar and directly edit the 

function in the formula bar. 

Table 7-2: Function Categories 

Most Recently Used Lists the functions you’ve used most recently. 

All Lists every function available in Excel. 

Financial Lists financial functions to calculate interest, payments, loans, etc. 

Date & Time Lists functions to calculate date and times values. 

Math & Trig Lists math and trigonometry functions, such as SUM, COS, and TAN. 

Statistical Lists statistical functions, to calculate averages, standard deviations, etc. 

Lookup & Reference Lists functions that lookup or reference values. 

Database Lists functions that lookup or calculate values in a list or database. 

Text Lists functions that can be used with text or labels. 

Logical Lists IF…THEN conditional-type functions. 

Information Lists functions that return information about values and the worksheet itself. 

Engineering Lists functions used in engineering calculations. 

Cube Lists functions that extract data from OLAP cubes. 

Figure 7-4: The Function Library group on the Formulas 

tab. 
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AutoCalculate and Manual 
Calculation 

You have a few options for how Excel calculates 

worksheets. Besides using formulas, Excel can 

automatically perform certain calculations—all you have 

to do is select the cells. You can also tell Excel when you 

want to manually calculate formulas in a worksheet. 

Use AutoCalculate 

You don’t always need to enter a formula to make a quick 

calculation. For example, if you have a column containing 

a few numbers you want to add together, you can simply 

select the cells and look to the status bar for the answer—

Excel has calculated the sum for you there. 

1. Select the cells you want to average, count or sum. 

Excel’s AutoCalculate feature takes the cells you 

selected and displays the results to these common 

calculations in the status bar, as shown in the 

example to the right. 

Change AutoCalculate options 

You can also change and add calculations in the status bar. 

1. Right-click the status bar. 

The Customize Status Bar list appears. Here you can 

add Numerical Count, Minimum or Maximum to the 

status bar. You can also remove Average, Count or 

Sum if you’d like. The table to the right, 

AutoCalculate Options in the Status Bar, displays 

more information about these options. 

2. Select the calculations that you want to be displayed 

on the status bar.  

The calculations you selected appear on the status 

bar. 

Manual formula calculation options 

By default, Excel recalculates all the formulas in a 

workbook whenever you change a value that affects 

another value. However, you can change the calculation 

options so that formulas will only calculate when directed 

by you. 

1. Click the Formulas tab on the Ribbon and click the 

Calculation Options button in the Calculation group. 

Three options appear in the list: 

 Exercise 

• Exercise File: Sales7-2.xlsx 

• Exercise: Select the cell range B9:G9 and look at the 

status bar to see the average monthly expenses. 

 Select the Manual calculation option. Enter 12,000 in cell 

B3 and notice that no other values change. Click the 

Calculate Now button and watch the worksheet formulas 

calculate new values.  

 Change back to Automatic calculation. 

Table 7-3: AutoCalculate Options in the Status Bar 

By 

Default 

Average Average of selected cells. 

Count Number of selected cells that 

contain data. 

Sum Sum of selected cells. 

Optional Numerical 

Count 

Number of selected cells that 

contain numbers. 

Minimum Smallest value in the selection. 

Maximum Largest value in the selection. 

Figure 7-5: The AutoCalculate feature in the status bar. 
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 Automatic: This is selected by default. Values are 

automatically recalculated whenever a change 

occurs in the workbook. 

 Automatic Except for Data Tables: The 

workbook is automatically updated with any 

changes. Data tables are only updated manually.  

 Manual: The workbook is only updated when 

directed by the user. 

2. Select a calculation option. 

If you select an option other than Automatic, you will 

need to tell Excel when you want to recalculate.  

The Calculate Now button calculates the entire 

workbook when you click it, while the Calculate 

Sheet button only calculates the current worksheet. 

3. Click the Calculate Now or Calculate Sheet button 

in the Calculation group. 

The workbook or worksheet recalculates. 

 Other Ways to Calculate: 
Press <F9> to Calculate Now; press <Shift> + 

<F9> to Calculate Sheet. 
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Defining Names 

Defining a name makes your formulas much easier to 

understand and maintain. For example, you could name 

the cell range B16:H16 “Total Sales.” Then, instead of 

totaling sales with the formula =SUM(B16:H16), you 

could use the defined name to create the more readable 

formula, =SUM(TotalSales). 

You can define a name a cell range, formula, constant, or 

table. 

Define a name for a cell range 

You can define a name for a cell, cell range, or even 

multiple non-adjacent cells that you have selected. 

1. Select the cells you want to name. 

If you want to select a range of non-adjacent cells, 

press and hold the <Ctrl> key while selecting cells. 

2. Click the Name Box on the formula bar. 

The Name Box is at the left end of the formula bar 

and displays the name of the cell in the upper left 

corner of the currently selected range. 

3. Type a name for the selection. 

You can enter up to 255 characters. 

 Trap: You can’t use a cell reference, like B2, as a 

name, and you can’t use spaces in a name (use an 

underscore or period instead). 

4. Press the <Enter> key. 

The defined name is confirmed. 

 Other Ways to Define a Name for a Cell Range: 
You can use existing row and column labels as 

defined names. Select the cell range to name, 

including the row and/or column labels. Click the 

Formulas tab on the Ribbon and click the Create 

from Selection button. Select the name options 

you want to use and click OK. The resulting 

defined name refers to only the cells with values, 

not the cells with the row and column labels. 

Define names with the New Name dialog box 

For more options and flexibility when defining names you 

can use the New Name dialog box. Here you can define 

names for cell references, constants and formulas. 

1. Click the Formulas tab on the Ribbon and click the 

Define Name button in the Defined Names group. 

The New Name dialog box appears. 

 Exercise 

• Exercise File: Sales7-3.xlsx 

• Exercise: Create defined names for each of these cell 

ranges—B5:B8, C5:C8, D5:D8—and name them 

JanExpenses, FebExpenses, and MarExpenses, respectively. 

Figure 7-6: A defined name in the Name Box. 
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 Other Ways to Display New Name Dialog Box:  
Click the Formulas tab on the Ribbon. Click the 

Name Manager button in the Defined Names 

group. Click the New button. 

2. Enter a name in the Name text box.  

The name should be something that is easy to 

remember, and identifies what is being named. 

3. Click the Scope list arrow and select the scope you 

want to use. 

The scope determines whether the name is 

recognized by the whole workbook or just individual 

worksheets within the workbook. 

 Tip: Names in which the scope is a worksheet can 

be recognized in other sheets of the workbook. 

Just qualify the sheet name first, for example: 

Sheet1!Income_FY08. 

4. (Optional) Enter a comment in the Comment box. 

The comment will be visible in the Name Manager 

dialog box. 

5. Complete the “Refers to” box as necessary. 

The “Refers to” box displays the currently selected 

cell or cell range. You have a few options: 

 Define a name for the current cell range: Keep 

the current cell range selected. Do nothing. 

 Select a different cell range: In the “Refers to” 

box, select a different cell range: Click the 

Collapse Dialog button, select different cells on 

the worksheet and click the Expand Dialog 

button. 

 Define a name for a constant: In the “Refers to” 

box, enter an equal sign (=) followed by a 

constant value, such as 7.2. 

 Define a name for a formula: In the “Refers to” 

box, enter an equal sign (=) followed by a 

formula, such as FV(8,6,C4). 

6. Click OK. 

The name is defined and the dialog box closes. 

 Tips 

 You can use upper- and lowercase letters in defined 

names, but Excel doesn’t distinguish between them. 

 Besides creating defined names, you can also create 

“table names.” Excel automatically creates a table 

name like “Table1” when a table is created, but you 

can use the Name Manager to change the name. 

Figure 7-7: The New Name dialog box. 
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Using and Managing Defined 
Names 

Once you create defined names, you can use them in 

formulas. You can also use the Name Manager dialog box 

to view, edit, delete, and create new defined names. 

Use defined names 

Once cells have been given names, they are easy to 

reference in other formulas. 

1. Click the Formulas tab on the Ribbon, click the Use  

in Formula button in the Defined Names group, and 

select a name from the list. 

The defined name is inserted into the currently 

selected cell or the formula you are editing. 

 Other Ways to Use a Name: 
Type a defined name in a formula. 

View defined names 

There are a few places you can view all of a workbook’s 

defined names: 

 Name Manager dialog box: Click the Formulas tab 

on the Ribbon and click the Name Manager button 

in the Defined Names group. Here you can see a list 

of the defined names and table names. The list 

includes the name, current value, current reference 

for the name, scope, and any comments related to the 

name. You can click and drag the right column border 

to change the width of a column. 

 Worksheet cells: Find an area in the worksheet with 

two blank columns. Select a cell that will become the 

upper-left corner of the list. Click the Formulas tab 

on the Ribbon, click the Use in Formula button and 

select Paste Names. Click the Paste List button. The 

defined names and the related descriptions appear in 

the columns. 

 Name Box list: Click the arrow next to the Name 

Box to view the defined names. If you select a name 

here, the cell range that is defined by that name is 

selected in the worksheet. 

Edit defined names 

You can use the Name Manager dialog box to edit defined 

names. 

1. Click the Formulas tab on the Ribbon and click the 

Name Manager button in the Defined Names group. 

The Name Manager dialog box appears. 

 Exercise 

• Exercise File: Sales7-4.xlsx 

• Exercise: Edit the defined names in the Name Manager 

dialog box so they read Jan, Feb, and Mar instead of 

JanExpenses, FebExpenses, and MarExpenses.  

 In cell B14, enter the formula =AVERAGE(Jan,Feb,Mar) to 

find the average expenses per month for the first quarter of 

the year.  

 Delete the JanIncome defined name. 

Figure 7-8: As you enter defined names in a formula, the 
cells they represent are highlighted. 

Figure 7-9: Defined names are denoted in the Name 

Manager dialog box by an icon that looks like a note tag. 
Table names appear with a table icon 
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2. Select a defined name and click the Edit button.  

The Edit Name dialog box appears. This dialog box is 

essentially the same as the New Name dialog box. 

Here you can change the name of the defined name 

or change what the name refers to. 

3. Make changes to the defined name as desired, then 

click OK.  

You return to the Name Manager dialog box. 

4. Click Close. 

 Other Ways to Edit Defined Names: 
Select the defined name you want to edit in the 

Name Manager dialog box, then change the 

information in the “Refers to” box. 

Delete defined names 

If you want to remove a defined name, you can delete it in 

the Name Manager dialog box. You can also delete more 

than one defined name at once. 

1. Click the Formulas tab on the Ribbon and click the 

Name Manager button in the Defined Names group. 

The Name Manager dialog box appears. 

2. Select the defined name(s) you want to delete. 

Press and hold the <Shift> key to select multiple 

adjacent names or the <Ctrl> key to select multiple 

non-adjacent names for deletion. 

3. Click the Delete button. 

A message appears, asking if you’re sure you want to 

delete the defined name or names. 

4. Click OK. 

The defined name or names are deleted. 

 Tips 

 In the Name Manager dialog box, you can filter the 

list of defined names by scope; whether or not they 

have errors; or by type of name (defined or table). 

Click the Filter button and select the filter you want 

to use. 

 You can also click the New button in the Name 

Manager dialog box to define a new name. 

Figure 7-10: The Edit Name dialog box. 
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Displaying and Tracing 
Formulas 

You can better understand the formulas in a workbook by 

displaying formulas, tracing precedents and dependents, 

and using the Watch Window. 

By default, Excel displays the results of formulas in the 

worksheet instead of showing the actual formulas. 

However, you can choose to have Excel display the 

formulas so you can see how they’re put together. 

Also, by tracing precedents and dependents, you can 

display arrows that show you which cells affect a selected 

cell and which cells that cell affects. And the Watch 

Window allows you to constantly keep tabs on important 

formulas and their values. 

 Display formulas 

1. Click the Formulas tab on the Ribbon and click the 

Show Formulas button in the Formula Auditing 

group. 

Formulas are displayed in the worksheet and the 

columns widen to accommodate the formulas, if 

necessary. 

 Tip: If you display formulas and then select a cell 

that contains a formula, colored lines appear 

around cells that are referenced by the formula. 

Now let’s hide the formulas again. 

2. Click the Show Formulas button in the Formula 

Auditing group again.  

 Formulas are no longer displayed and the columns 

return to their original sizes. 

 Tip: If you print a worksheet with formulas 

displayed, the formulas print instead of values. 

Trace formula precedents and dependents 

Sometimes you may want to know what other cells are 

affected by or are affecting a certain cell. You can trace 

the influence of formulas by displaying arrows that show 

precedent and dependent cells. 

1. Select a cell that contains a formula you want to 

trace. 

2. Click the Formulas tab on the Ribbon. 

In the Formula Auditing group, there are a couple 

different buttons you can choose from: 

 Exercise 

• Exercise File: Sales7-5.xlsx 

• Exercise: Display, then hide, the formulas in the 

worksheet.  

 Select cell B14 and trace precedents, then remove the 

arrows.  

 Add cell B14 to the watch window. Then, change cell B5 to 

$1,000 to watch the value update in the watch window. 

Close the Watch Window. 

Figure 7-11: The Formula Auditing group on the Formulas 
tab. 

Figure 7-12: A worksheet with formulas displayed. 
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 Trace Precedents: Displays arrows that show 

what cells affect the currently selected cell. 

 Trace Dependents: Displays arrows that point to 

cells that are affected by the currently selected 

cell. 

 3. Click the Trace Precedents or Trace Dependents 

button in the Formula Auditing group. 

Arrows appear, illustrating how the cells relate to the 

formula in the currently selected cell. Dots appear on 

the arrows to point out which specific cells are 

involved. If there are precedents or dependents on 

another worksheet, an icon appears letting you know 

that. 

Once you’re done analyzing your formulas, you can 

remove the arrows. 

4. Click the Remove Arrows button in the Formula 

Auditing group. 

All the tracing arrows disappear from the worksheet. 

 Tip: If you want to remove only precedent arrows 

or only dependent arrows, click the Remove 

Arrows button list arrow and select an option. 

Use the Watch Window 

 The Watch Window allows you to monitor the values of 

certain cells as changes are made to worksheets. You can 

add cells you want to watch from different worksheets 

and even different workbooks.  

1. Click the Formulas tab on the Ribbon and click the 

Watch Window button in the Formula Auditing 

group. 

The Watch Window appears. Here you can add cells 

you want to track. 

2. Click the Add Watch button. 

The Add Watch dialog box appears. 

3. Select the cell or cell range you want to watch and 

click Add. 

The workbook and worksheet names, defined name, 

cell reference, current value, and formula for the 

selected cell(s) appear in the Watch Window. 

 Tip: If you no longer want to track a certain cell, 

select it in the Watch Window and click the 

Delete Watch button. 

4. Click the Watch Window’s Close button. 

The Watch Window closes. 

Figure 7-13: Arrows tracing formula precedents for B14. 

Figure 7-14: The Watch Window. 
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Understanding Formula Errors 

Sometimes Excel comes across a formula that it cannot 

calculate. When this happens, it displays an error value. 

Error values occur because of incorrectly written 

formulas, referencing cells or data that don’t exist, or 

breaking the fundamental laws of mathematics. Excel 

includes an Error Checking feature to help you deal with 

errors. 

1. Click the Formulas tab on the Ribbon and click the 

Error Checking button in the Formula Auditing 

group. 

The cell pointer moves to the first cell that contains  

an error and the Error Checking dialog box appears. 

Here you can see the formula arguments that are 

causing the error and Excel explains the error type.  

See the table below, Excel Errors, for further 

description of errors in Excel. 

The Error Checking dialog box also has several 

buttons to help you with errors:  

 Help on this error: Displays a Help topic that 

explains the type of error you’re seeing. 

 Show Calculation Steps: Displays the Evaluate 

Formula dialog box, which breaks down the 

formula arguments for you so that you can isolate 

the error. Click Evaluate to show the current 

value of the underlined argument or click Step In 

to examine the source of a particular argument. 

 Ignore Error: Allows you to skip the current 

error and move to the next error in the worksheet. 

 Edit in Formula Bar: Places the cursor in the 

formula bar, where you can directly edit the 

formula arguments and fix the error. 

  Tip: You can click the Previous or Next buttons 

to move between errors in the worksheet, and you 

can click the Options button to change the error 

checking rules. 

 Other Ways to display the Evaluate Formula 

Dialog Box: 
Click the Evaluate Formula button in the 

Formula Auditing group. 

2. Click the button you want to use in the Error 

Checking dialog box. 

Now you can follow Excel’s advice to fix the error. 

 Other Ways to Fix an Error: 
Select the cell that contains an error and point to 

the SmartTip icon that appears next to the cell. A 

tip appears, telling you why you are getting this 

 Exercise 

• Exercise File: Sales7-6.xlsx 

• Exercise: Add “/0” onto the end of the formula in cell B13 

so that the #DIV/0! error appears.  

 Then add “+A8” onto the end of formula in cell B14 so that 

the #VALUE! error appears.  

 Display the Error Checking dialog box, and use the Edit in 

Formula Bar button to delete “/0” from cell B13 and “+A8” 

from B14.  

Figure 7-15: The Error Checking dialog box. 

Figure 7-16: The Evaluate Formula dialog box. 
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type of error. Click the list arrow and select an 

error checking option. 

 Tips 

 Another way you can analyze errors is by tracing 

them with arrows. Select a cell with an error, click 

the Error Checking list arrow in the Formula 

Auditing group, and select Trace Error. Arrows 

appear, pointing out the cells that are involved in the 

erroneous formula. 

 If a formula contains its own cell location as a 

reference, it results in a circular reference, and the 

formula can’t calculate correctly. To locate circular 

references in your worksheet, click the Error 

Checking list arrow in the Formula Auditing group, 

point to Circular References, and select a cell that 

contains a circular reference from the list.  

Table 7-4: Excel Errors 

##### The numeric value is too wide to display within the cell. You can resize the column by dragging the 

boundary line between the column headings. 

#VALUE! You entered a mathematical formula that references a text entry instead of a numerical entry. 

#DIV/0! You tried to divide a number by zero. This error often occurs when you create a formula that refers to a 

blank cell as a divisor. 

#NAME? You entered text in a formula that Excel doesn't recognize. You may have misspelled the name or 

function, or typed a deleted name. You also may have entered text in a formula without enclosing the 

text in double quotation marks.   

#N/A This error occurs when a value is not available to a function or a formula. If certain cells on your 

worksheet contain data that is not yet available, enter #N/A in those cells. Formulas that refer to those 

cells will then return #N/A instead of attempting to calculate a value. 

#REF! The #REF! error value occurs when a cell reference is not valid. You probably deleted a cell range that is 

referenced in a formula. 

#NUM! The #NUM! error value occurs when you use an invalid argument in a worksheet function. 

#NULL! You specified an intersection of two ranges in a formula that do not intersect. 
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Using Logical Functions (IF) 

This lesson introduces a very useful function, the IF 

function. The IF function is a conditional function or 

logical function because it will evaluate a condition you 

specify and return one value if the condition is true and 

another value if the condition is false. For example, you 

could use the IF function in an invoice to create a formula 

that would subtract a 5% discount from the invoice if the 

total was more than $500.00, otherwise it wouldn’t 

subtract anything. 

The IF function is one of the more difficult functions, but 

it’s also very powerful. 

1. Click the Insert Function button on the Formula bar. 

The Insert Function dialog box appears. 

2. Click the Or select a category list arrow and select 

Logical.  

Functions that fall under this category are shown in 

the Select a function box.  

3. Select IF in the Select a function box and click OK. 

The Function Arguments dialog box appears.  

 Other Ways to Find a Function: 
Type the function’s name in the Search for a 

function box. Or, select the function from the 

Select a function box. 

You’re ready to start entering the IF formula. There 

are three parts in this formula: 

 Logical Test: This is this first argument, and it 

evaluates a statement as true or false. 

 Value if True:  If the statement in the Logical 

Test is true, then this value is entered. 

 Value if False: If the statement in the Logical Test 

is false, then this value is entered. 

3. Enter the arguments for the IF function and click OK. 

The function is run, and the results appear in the cell. 

 Tip: Remember, you can also create cell 

references by clicking the cell or cell range you 

want to reference. Click the Collapse Dialog 

button to collapse the function palette and select 

the cell range if the Function Arguments dialog 

box is in the way. 

 Other Ways to Use the IF Function in a 

Formula: 
Write the formula using the syntax 

=IF(logical_test,value_if_true,value_if_false). 

 Exercise 

• Exercise File: Functions.xlsx, IF worksheet 

• Exercise: Determine the Federal Income Tax for these 

people and enter these arguments for the IF function in cell 

B17: 

Logical_test: B14>=500 

Value_if_true: B14*.15 

Value_if_false: B14*.1 

 Copy the IF function from B17 to cells C17:H17. 

Figure 7-17: The syntax for the IF Function. 

Figure 7-18: The Function Arguments dialog box. 
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Using Financial Functions 
(PMT) 

The PMT function is a very valuable function if you work 

with real estate, investments, or are considering taking out 

a loan. The PMT function calculates the payment for a 

loan based on periodic payments and a constant interest 

rate. For example, say you want to take out a $10,000 car 

loan at 8% interest and will pay the loan off in four years. 

You can use the PMT function to calculate that the 

monthly payments for such a loan would be $244.13. 

You can also use the PMT function to determine 

payments to annuities or investments. For example, if you 

want to save $50,000 in 20 years by saving the same 

amount each month, you can use PMT to determine how 

much you must save. 

1. Click the Insert Function button on the Formula bar. 

The Insert Function dialog box appears. 

2. Click the Or select a category list arrow and select 

Financial.  

Functions that fall under this category are shown in 

the Select a function box.  

3. Select PMT in the Select a function box and click 

OK. 

The Function Arguments dialog box appears.  

4. Enter the required arguments for the PMT function 

and click OK. 

The results of the function are displayed in the 

selected cell. 

 Tip: Remember, you can also create cell 

references by clicking the cell or cell range you 

want to reference. Click the Collapse Dialog 

button to collapse the function palette and select 

the cell range if the Function Arguments dialog 

box is in the way. 

 Other Ways to Use the PMT Function in a 

Formula:  
Write the formula using the syntax 

PMT(rate,nper,pv) 

 Exercise 

• Exercise File:  Functions.xlsx, PMT worksheet 

• Exercise:  In cell D4, create a PMT function that uses 

these arguments: 

Rate: C4/12 

Nper: B4*12 

Pv: A4 

 The result is a negative number: Add a – (negative) symbol 

between the = and PMT in the Formula bar so the value is 

positive. 

 Copy the PMT function to D5:D6. 

Figure 7-19: The syntax for the PMT Function. 

Figure 7-20: The Function Arguments dialog box. 

Figure 7-21: The results of the PMT function. 
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=PMT(.09/12,36,10000) 
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Using Database Functions 
(DSUM) 

Excel’s database functions perform calculations only for 

records that meet the criteria you specify. All the database 

functions use the same basic syntax: =Function(database, 

field, criteria). These arguments (parts) of a database 

function include: 

 Database: Is the cell range that makes up the list or 

database. 

 Field: Indicates which column is used in the 

function. You can refer to fields by their column 

labels as long as you enclose them with double 

quotation marks, such as "Name". You can also refer 

to fields as a number that represents the position of 

the column in the list: 1 for the first column in the 

list, 2 for the second, and so on. Make sure you refer 

to their position in the list, and not the column 

heading numbers! 

 Criteria: Is a reference to the cell or cell range that 

specifies the criteria for the function. 

This lesson explains how to use database functions by 

creating a formula with the simplest database function—

the DSUM function. 

1. Click the Insert Function button on the Formula bar.  

The Insert Function dialog box appears. 

2. Click the Or select a category list arrow and select 

Database. 

Functions that fall under this category are shown in 

the Select a function box. 

3. Select DSUM in the Select a function box and click 

OK. 

The Function Arguments dialog box appears.  

4. Enter the required arguments for the DSUM function 

and click OK. 

 Tip: It is important to understand how the field 

must be entered: either the name in double 

quotations, or by the number (for example, 

column A is 1, B is 2, and so on). 

 Other Ways to Use the DSUM Function in a 

Formula: 
Write the formula using the syntax 

=DSUM(database, field, criteria). 

 Exercise 

• Exercise File:  Functions.xlsx, DSUM worksheet 

• Exercise: Enter the DSUM function in C27 using these 

arguments: 

 Database: A1:I23 

Field: “Annual Trips” 

Criteria: C25:C26 

Figure 7-22: The syntax for the DSUM function. 

Figure 7-23: The Function Arguments for the DSUM 
function. 

Figure 7-24: An example of the DSUM function. 
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=DSUM(A1:I23, "Annual Trips", C25:C26) 
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number of the 
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C27 displays the number of records in the Annual Trips column 
(column I) that match the criteria in C26. 
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Using Lookup Functions 
(VLOOKUP) 

The VLOOKUP function looks up information in a 

worksheet. The VLOOKUP searches vertically down the 

left most column of a cell range until it finds the value you 

specify. When it finds the specified value, it then looks 

across the row and returns the value in column you 

specify. The VLOOKUP function works a lot like looking 

up a number in a phonebook: first you look down the 

phonebook until you find the person’s name, then you 

look across to retrieve the person’s phone number. 

 Tips 

 It’s important to understand that VLOOKUP only 

looks down the column that is farthest left in the 

specified cell range. In then looks across the row. 

1. Click the Insert Function button on the Formula bar. 

The Insert Function dialog box appears. 

2. Click the Or select a category list arrow and select 

Lookup and Reference. 

Functions that fall under this category are shown in 

the Select a function box. 

3. Select VLOOKUP in the Select a function box and 

click OK. 

The Function Arguments dialog box appears. 

4. Enter the required arguments for the VLOOKUP 

function. 

 Other Ways to Use the VLOOKUP Function in 

a Formula: 
Write the formula using the syntax =VLOOKUP 

(lookup_value,table_array, col_index_num) 

 Tips 

 The HLOOKUP function is similar to the VLOOKUP 

function, except it searches horizontal from left to 

right across the top row of a cell range until it finds 

the value you specify. When it finds the specified 

value it then looks down the column to find the 

specified value. Because of the way data is typically 

structured, VLOOKUP is much more powerful than 

HLOOKUP. 

 Exercise 

• Exercise File:  Functions.xlsx,  VLOOKUP worksheet 

• Exercise: Start by adding a label for the results of the 

VLOOKUP function and criteria: Type Sales by Client in 

cell E25 and type 21 in cell E26. 

 Enter the VLOOKUP function in E27 using these 

arguments: 

Lookup_value: E26 

Table_array: A1:J23 

Col_index_num: 9 

Range_lookoup: False 

Figure 7-25: The syntax for the VLOOKUP function. 

Figure 7-26: The Function Arguments for the VLOOKUP 
function. 
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=VLOOKUP(E26, A1:I23, 9) 
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Lookup Value 
The value to 
be found in the 
first column of 
the table array 
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User Defined and 
Compatibility Functions 

Functions are one of the major changes in Excel 2010. 

Many functions have been renamed to better reflect their 

usage, or replaced with a function that is more accurate. 

The descriptions for the functions themselves are also 

clearer, so it easier to understand how a function is to be 

used. 

User Defined functions 

If add-ins that you install contain functions, these add-in 

or automation functions will be available in this category. 

Compatibility functions 

All the functions in this category have been replaced or 

renamed, but they are still available for backward 

compatibility. Consider using the new functions instead of 

these, because they may not be available in future 

versions of Excel. 

Tables describing the rest of the function categories, along 

with more detailed examples of the functions in each 

category, appear in the following pages. 

 Exercise 

• Exercise File: None required. 

• Exercise: Understand the User Defined and Compatibility 

function categories in Excel 2010. 

More Functions and Formulas 
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Financial Functions 

Excel’s financial functions are vital if you work with 

investments or real estate. Financial functions help you do 

things like determine loan payment amounts, calculate the 

future value of investments, and find rates of return. This 

table lists some of the Financial Functions available in 

Excel 2010. 

Table 7-5: Overview of Financial Functions 

FV =FV(rate, number of periods, 

payment, present value, type) 

Calculates the future value of an investment based on periodic, constant 

payments and a constant interest rate.  

Example: You plan to deposit $2,000 a year for 35 into an IRA, and you expect a 

10% average rate of return. 

=FV(10%,35,-2000) equals $542,048.74 

IMPT =IPMT(rate, period, number of 

periods, present value, future 

value, type) 

Calculates the interest payment for over a specified period of time, with constant 

periodic payments and a constant interest rate. 

Example: The following formula calculates the interest due in the first month of a 

three-year $8000 loan at 10 percent annual interest: 

IPMT(0.1/12, 1, 36, 8000) equals -$66.67 

IRR =IRR(values, guess) Calculates the internal rate of return of investment. The investments do not have 

to be equal, but they must occur at regular intervals. The internal rate of return is 

the interest rate received for an investment consisting of payments (negative 

values) and income (positive values) that occur at regular periods. 

Example: You want to start a business. It will cost $40,000 to start the business, 

and you expect to net the following income in the first three years: $10,000, 

$15,000, and $20,000. Enter the four values in the cells A1:A4 of the worksheet, 

making sure to enter the initial $40,000 investment as a negative value. 

IRR(A1:A4) equals 5% 

NPV =NPV(rate, value1, value2, ...) Calculates the net present value of an investment by using a discount rate and a 

series of future payments (negative values) and income (positive values). 

PMT =PMT(rate, number of periods, 

present value, future value, type) 

Calculates the payment for a loan based on constant payments and a constant 

interest rate. 

Example: The following formula calculates the monthly payment on a $20,000 

loan with an annual interest rate of 9% that must be paid in 36-months. 

PMT(9%/12, 36, 20000) equals ($635.99) 

PV =PV(rate, number of periods, 

payment, future value, type) 

Returns the present value of an investment. 

Example: An annuity that pays $600 every month for the next 20 years costs 

$50,000, and the money paid out will earn 7 %. You want to determine whether 

this would be a good investment. Using the PV function, you find that the present 

value of the annuity is: 

PV(0.07/12, 12*20, 600, , 0) equals ($77,389.50) 

RATE =RATE(total number of payments, 

payment, present value) 

Determines the interest rate per period of an annuity. 

Example: You want to calculate the rate of a four-year (48 month) $8,000 loan 

with monthly payments of $200. Using the RATE function you find: 

RATE(48, -200, 8000) equals 0.77 percent 

This is the monthly rate, because the period is monthly. The annual rate is 

0.77%*12, which equals 9.24 percent. 

 Exercise 

• Exercise File: None required. 

• Exercise: Become familiar with Excel’s Financial 

functions. 

More Functions and Formulas 
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Date & Time Functions 

You can use dates and time in your formulas just like any 

other value. For example, if cell A1 contained the entry 

5/1/12 you could use the formula =A1+100 to calculate 

the date 100 days later, which is 8/9/12. 

One very important thing to know about working with 

date and time functions: while Excel can display dates 

and times using just about any format, it actually stores 

dates as chronological numbers called serial values. So 

when you think of dates as months, days, and, years, such 

as May 1, 2012, Excel thinks of dates in terms of serial 

numbers, such as 36281. 

Since the date and time formulas often return serial 

number values, you should format any cells with date or 

time formulas with data and time formats that you can 

easily understand. You can also create custom number 

formats to display the results of date formulas. For 

example, the custom format dddd would display only the 

day, Monday, instead of the entire date, 8/9/2012. 

This table lists some of the Date & Time Functions 

available in Excel 2010. 

Table 7-6: Overview of Date & Time Functions 

DATE =DATE(year, month, day) Enters a date in the cell. 

Example: DATE(12,5,1) equals May 1, 2012. 

TODAY =TODAY( ) A special version of the DATE function. While the DATE function 

can return the value of any date, the TODAY function always returns 

the value of the current date. 

TIME =TIME(hour, minute, second) Enters a time in the cell. Uses a 24-hour (military) time system. 

Example: TIME(14,30) equals 2:30 PM. 

NOW =NOW( ) A special version of the TIME function. While the TIME function 

can return the value of any time, the NOW function always returns 

the value of the current time. 

WEEKDAY =WEEKDAY (serial_number, 

return_type) 

Returns a day of the week for a specific date. The serial_number 

argument is a date value (or reference to one). 

Example: WEEKDAY("2/14/12") equals Wednesday. 

YEAR =YEAR (serial_number, 

return_type) 

Returns a value of the year for a specific date. The serial_number 

argument is a date value (or reference to one). 

Example: YEAR("3/15/2012”) equals 1998. 

MONTH =MONTH (serial_number, 

return_type) 

Returns a value of the month for a specific date. The serial_number 

argument is a date value (or reference to one). 

Example: MONTH("3/15/2012”) equals 3. 

DAY =DAY(serial_number, 

return_type) 

Returns a value of the day for a specific date. The serial_number 

argument is a date value (or reference to one). 

Example: DAY("3/15/2012”) equals 15. 

 Exercise 

• Exercise File: None required. 

• Exercise: Become familiar with Excel’s Date & Time 

functions. 

More Functions and Formulas 
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Table 7-6: Overview of Date & Time Functions 

HOUR =HOUR (serial_number) Returns hour value for a specific time. The serial_number argument 

is a time value (or reference to one). Uses a 24-hour time format. 

Example: HOUR("12:15:45”) equals 12. 

MINUTE =MINUTE (serial_number) Returns the minute value for a specific time. The serial_number 

argument is a time value (or reference to one). Uses a 24-hour time 

format. 

Example: MINUTE("12:15:45”) equals 15. 

SECOND =SECOND (serial_number) Returns a value of a second for a specific time. The serial_number 

argument is a time value (or reference to one). Uses a 24-hour time 

format. 

Example: SECOND("12:15:45”) equals 45. 

HOUR =HOUR(serial_number) Returns the hour as a number from 0 (12:00 A.M.) to 23 (11:00 

P.M.). 

Example: HOUR(“3:30 PM”) equals 15. 

DAYS360 =DAYS360(start_date,end_date) Returns the number of days between two dates based on a 360-day 

year (twelve 30-day months), which is used in some accounting 

calculations. 

Example: DAYS360("1/30/12", "2/1/12") equals 1. 

More Functions and Formulas 
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Math & Trig Functions 

You can find many of Excel’s mathematical functions on 

a typical scientific calculator. If you still remember your 

algebra classes, many of these functions, such as SIN, 

COS, and LOG should be familiar to you. 

This table lists some of the Math & Trig Functions 

available in Excel 2010. 

Table 7-7: Overview of Math & Trig Functions 

ABS =ABS(number) Determines the absolute value of a number. The absolute value of a 

number is the number without its sign. 

ACOS =ACOS(number) Returns the arccosine of an angle. ACOS is the inverse of the COS 

function. 

ACOSH = ACOSH(number) Returns the inverse hyperbolic cosine of a number. 

AGGREGATE =AGGREGATE(…) Returns an aggregate in a list or database. 

ASIN =ASIN(number)  Returns the arcsine of an angle. ASIN is the inverse of the SIN 

function. 

CEILING 

CEILING.PRECISE 

=CEILING(number, significance) 

=CEILING.PRECISE(number, 

significance) 

Rounds a number up, to the nearest multiple of significance. 

Rounds a number up, to the nearest integer or to the nearest 

multiple of significance. 

COMBIN =COMBIN(number, 

number_chosen) 

Calculates the number of possible combinations from a given 

number of items. 

Example: You want to form a two-person team from five 

candidates, and you want to know how many possible teams can be 

formed. COMBIN(5, 2) equals 10 teams. 

COS =COS(number) Returns the cosine of an angle. 

DEGREES =DEGREES(angle) Converts radians into degrees. 

EVEN 

ODD 

=EVEN(number) 

=ODD(number) 

Rounds a number up to the nearest even or odd integer. 

EXP =EXP(number) Calculates the value of the constant e (approximately 

2.71828182845904) raised to the power specified by its argument.  

Example: EXP(2) equals e2, or 7.389056 

FACT =FACT(number)  Calculates the factorial of a number. The factorial of a number is 

the product of all the positive integers from one up to the specified 

number. 

Example: FACT(5) equals 1*2*3*4*5 equals 120 

 

FLOOR 

FLOOR.PRECISE 

=FLOOR(number, significance) 

=FLOOR.PRECISE(number, 

significance) 

Rounds a number down to the nearest multiple of significance. 

Rounds a number down, to the nearest integer or to the nearest 

multiple of significance. 

LN =LN(number) Calculates the natural (base e) logarithm of a positive number. 

LOG 

 

=LOG(number, base) Calculates the logarithm of a positive number using a specified 

base. 

LOG10 =LOG(number) Calculates the base 10 logarithm of a number. 

 Exercise 

• Exercise File: None required. 

• Exercise: Become familiar with Excel’s Math & Trig 

functions. 

More Functions and Formulas 
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Table 7-7: Overview of Math & Trig Functions 

MOD =MOD(number, divisor) Returns the remainder after number is divided by divisor. 

Example: MOD(3, 2) equals 1, the remainder of dividing 3 by 2. 

 

PI =PI( ) Returns the value of the constant pi ( ), accurate to 14 decimal 

places. 

PRODUCT =PRODUCT(number1, 

number2…) 

Multiplies all the numbers in a range of cells 

 

RADIANS =DEGREES(angle) Converts degrees to radians. 

RAND =RAND() Generates a random number between 0 and 1. 

RANDBETWEEN =RANDBETWEEN (bottom, 

top) 

Generates a random number between the bottom and top 

arguments. 

ROUND 

ROUNDDOWN 

ROUNDUP 

=ROUND(number, num_digits) Rounds a number to a specified number of digits. The 

ROUNDDOWN and ROUNDUP function take the same form as 

the ROUND function, and as their name implies, always round 

either up or down. 

SIGN =SIGN(number) Determines the sign of a number. Results in 1 if the number is 

positive, zero (0) if the number is 0, and -1 if the number is 

negative. 

SIN =SIN(number)  Returns the sine of an angle. 

SQRT =SQRT(number) Returns a positive square root of a number. 

SUM =SUM(number1, number2…) Adds all the numbers in a range of cells. 

SUMIF =SUMIF(range,criteria, 

sum_range) 

Adds the cells only if they meet the specified criteria. 

Example: You want to total the cell range B1:B5 only if the value 

in cellA1 is greater than 500. 

SUMIF(A1,">500",B1:B5) 

TAN =TAN(number) Returns the tangent of an angle. 

More Functions and Formulas 
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Statistical Functions 

Excel offers a large number of functions to help you 

analyze statistical data. 

This table lists some of the Statistical Functions available 

in Excel 2010. 

Table 7-8: Overview of Statistical Functions 

AVERAGE =AVERAGE(number1, 

number2…) 

Calculates the average, or arithmetic mean, of the numbers in the 

range or arguments. 

COUNT =COUNT(number1, 

number2…) 

Counts the number of cells that contain numbers, including dates 

and formulas. Ignores all blank cells and cells that contain text or 

errors. 

COUNTA =COUNTA(number1, 

number2…) 

Counts the number of cells in a range that are not empty. 

COUNTIF =COUNTIF(range,criteria) Counts the number of cells within a range that meet the given 

condition. 

MAX =MAX(number1, number2…) Returns the largest value in a range. Ignores logical values and text. 

MEDIAN =MEDIAN(number1, 

number2…) 

Returns the median, or the number in the middle of the set of given 

numbers. 

MIN =MIN(number1, number2…) Returns the smallest value in a set of numbers. Ignores logical 

values and text. 

MODE.MULT 

 

MODE.SNGL 

=MODE.MULT(number1, 

number2…) 

=MODE.SNGL(number1, 

number2…) 

Determines which value occurs most frequently in a set of numbers. 

 

Returns the most frequently occurring, or repetitive, value in an 

array or range of data. 

STDEV =STDEV(number1, number2…) Estimates standard deviation based on a sample. The standard 

deviation is a measure of how widely values are dispersed from the 

average value. 

STDEVA 

 

STDEVPA 

=STDEVA(value1, value2…) 

 

=STDEVPA(value1, value2…) 

Estimates standard deviation based on a sample, including logical 

values and text. Text and the logical value FALSE have the value 0; 

the logical value TRUE has the value 1. 

Calculates standard deviation based on an entire population, 

including logical values and text. Text and the logical value FALSE 

have the value 0; the logical value TRUE has the value 1. 

VAR.P =VAR.P(number1, number2…) Estimates variance based on the entire population (ignores logical 

values and text in the population). 

VAR.S =VAR.S(number1, number2…) Estimates variance based on a sample (ignores logical values and 

text in the sample). 

VARA =VARA(value1, value2…) Estimates variance based on a sample, including logical values and 

text. Text and the logical value FALSE have the value 0; the logical 

value TRUE has the value 1. 

VARPA =VARPA(value1, value2…) Calculates variance based on the entire population, including logical 

values and text. Text and the logical value FALSE have the value 0; 

the logical value TRUE has the value 1. 

 Exercise 

• Exercise File: None required. 

• Exercise: Become familiar with some of Excel’s Statistical 

functions. 
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Lookup & Reference 
Functions 

You can use Excel’s Lookup & Reference functions to 

locate values in rows or columns of data. 

This table lists some of the Lookup & Reference 

Functions available in Excel 2010. 

Table 7-9: Overview of Lookup & Reference Functions 

COLUMN 

COLUMNS 

=COLUMN(reference) 

=COLUMNS(array) 

Returns the column number of a reference. 

Returns the number of columns in an array or reference. 

HLOOKUP =HLOOKUP(lookup_value, 

table_array, row_index_num, 

range_lookup) 

Looks for a value in the top row of a table or array of values and 

returns the value in the same column from a row you specify. 

LOOKUP =LOOKUP(…) Looks up a value either from a one-row or one-column range or 

from an array. Provided for backward compatibility. 

ROW 

ROWS 

=ROW(reference) 

=ROWS(array) 

Returns the row number of a reference. 

Returns the number of rows in a reference or array. 

TRANSPOSE =TRANSPOSE(array) Converts a vertical range of cells as a horizontal range, or vice versa. 

VLOOKUP =VLOOKUP(lookup_value,tabl

e_array,col_index_num, 

range_lookup) 

 

Looks for a value in the leftmost column of a table, and then returns 

a value in the same row from a column you specify. By default, the 

table must be sorted in an ascending order.  

 Exercise 

• Exercise File: None required. 

• Exercise: Become familiar with Excel’s Lookup & 

Reference functions. 

More Functions and Formulas 
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Database Functions 

Database functions return results based on filtered criteria. 

All the database functions use the same basic syntax 

=Function(database, field, criteria). The arguments 

include: 

 Database: The cell range that makes up the list or 

database. 

 Field: Indicates which column is used in the 

function. You can refer to fields by their column label 

enclosed with double quotation marks, such as 

"Name" or as a number that represents the position of 

the column in the list: 1 for the first column, 2 for the 

second, and so on—not the column heading numbers! 

 Criteria: Is a reference to the cell or cell range that 

specifies the criteria for the function. For example, 

you might only want to total records from a certain 

region. 

This table lists some of the Database Functions available 

in Excel 2010. 

Table 7-10: Overview of Database Functions 

DAVERAGE =DAVERAGE(database, field, 

criteria) 

Averages the values in a column in a list or database that match 

conditions you specify. 

DCOUNT =DCOUNT(database, field, 

criteria) 

Counts the cells containing numbers in the field (column) of records 

in the database that match the conditions you specify. 

DGET =DGET(database, field, criteria) Extracts from the database a single record that matches the 

conditions you specify. 

DMAX =DMAX(database, field, 

criteria) 

Returns the largest number in the field (column) of records in the 

database that match the conditions you specify. 

DMIN =DMIN(database, field, criteria) Returns the smallest number in the field (column) of records in the 

database that match the conditions you specify. 

DSTDEV =DSTDEV(database, field, 

criteria) 

Estimates standard deviation based on a sample from selected 

database entries. 

DSUM =DSUM(database, field, 

criteria) 

Adds the numbers in the field (column) of records in the database 

that match the conditions you specify. 

DVAR =DVAR(database, field, criteria) Estimates variance based on a sample from selected database entries. 

 Exercise 

• Exercise File: None required. 

• Exercise: Become familiar with Excel’s Database 

functions. 
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Text Functions 

Excel offers a category of functions aimed at working 

with text. These functions allow you to remove, combine, 

and replace different pieces of text in a worksheet. 

This table lists some of the Text Functions available in 

Excel 2010. 

Table 7-11: Overview of Text Functions 

CONCATENATE CONCATENATE 

(text1,text2,...) 

Joins several text strings into one text string. 

EXACT EXACT(text1,text2) Checks whether two text strings are exactly the same, and returns 

TRUE or FALSE. EXACT is case-sensitive. 

LEFT LEFT(text,num_chars) Returns the specified number of characters from the start of a text 

string. 

LEN LEN(text) Returns the number of characters in a text string. 

LOWER LOWER(text) Converts all letters in a text string to lowercase. 

MID MID(text,start_num,num_chars) Returns the characters from the middle of a text string, given a 

starting position and length. 

PROPER PROPER(text) Converts a text string to proper case; the first letter in each word in 

uppercase, and all other letters to lowercase. 

REPLACE REPLACE(old_text,start_num,n

um_chars,new_text) 

Replaces part of a text string with a different text string. 

RIGHT RIGHT(text,num_chars) Returns the specified number of characters from the end of a text 

string. 

SUBSTITUTE SUBSTITUTE(text,old_text,ne

w_text,instance_num) 

Replaces existing text with new text in a text string. 

TRIM TRIM(text) Removes all spaces from a text string except for single spaces 

between words. 

UPPER UPPER(text) Converts a text string to all uppercase letters. 

 

 

 Exercise 

• Exercise File: None required. 

• Exercise: Become familiar with Excel’s Text functions. 
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Logical Functions 

Excel has a number of logical functions to choose from. 

These functions allow you to evaluate logical arguments 

and conditions. The most famous logical function is 

probably the IF function. 

This table lists some of the Logical Functions available in 

Excel 2010. 

Table 7-12: Overview of Logical Functions 

AND AND(logical1,logical2, ...) Checks whether all arguments are TRUE, and returns TRUE if all 

arguments are TRUE. 

FALSE FALSE() Returns the logical value FALSE. 

IF IF(logical_test,value_if_true,val

ue_if_false) 

Checks whether a condition is met, and returns one value if TRUE, 

and another value if FALSE. 

IFERROR IFERROR(value,value_if_error) Returns value_if_error if expression is an error and the value of the 

expression itself otherwise. 

NOT NOT(logical) Changes FALSE to TRUE, or TRUE to FALSE. 

OR OR(logical1,logical2,...) Checks whether any of the arguments are TRUE, and returns TRUE 

or FALSE. Returns FALSE only if all arguments are FALSE. 

TRUE TRUE() Returns the logical value TRUE. 

 Exercise 

• Exercise File: None required. 

• Exercise: Become familiar with Excel’s Logical functions. 

More Functions and Formulas 
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Information Functions 

Excel has a number of information functions to choose 

from. These functions allow you to evaluate logical 

arguments and conditions.  

This table lists some of the Information Functions 

available in Excel 2010. 

Table 7-13: Overview of Information Functions 

AND AND(logical1,logical2, ...) Checks whether all arguments are TRUE, and returns TRUE if all 

arguments are TRUE. 

FALSE FALSE() Returns the logical value FALSE. 

IF IF(logical_test,value_if_true,val

ue_if_false) 

Checks whether a condition is met, and returns one value if TRUE, 

and another value if FALSE. 

IFERROR IFERROR(value,value_if_error) Returns value_if_error if expression is an error and the value of the 

expression itself otherwise. 

NOT NOT(logical) Changes FALSE to TRUE, or TRUE to FALSE. 

OR OR(logical1,logical2,...) Checks whether any of the arguments are TRUE, and returns TRUE 

or FALSE. Returns FALSE only if all arguments are FALSE. 

TRUE TRUE() Returns the logical value TRUE. 

 Exercise 

• Exercise File: None required. 

• Exercise: Become familiar with Excel’s Information 

functions. 

More Functions and Formulas 
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Engineering and Cube 
Functions 

These last functions are also possibly the functions that 

will be used the least. . 

This table lists some of the Engineering Functions 

available in Excel 2010. 

Table 7-14: Overview of Engineering Functions 

BESSELI BESSELI(x,n) Returns the modified Bessel function In(x). 

BIN2DEC BIN2DEC(number) Converts a binary number to decimal. 

COMPLEX COMPLEX(real_num,i_num,suffix) Converts real and imaginary coefficients into a 

complex number. 

CONVERT CONVERT(number,from_unit,to_unit) Converts a number from one measurement system to 

another.  

DELTA DELTA(number1,number2) Tests whether two numbers are equal. 

 

This table lists some of the Cube Functions available in 

Excel 2010. 

Table 7-15: Overview of Cube Functions 

CUBEKPIMEMBER CUBEKPIMEMBER(connection, kpi_name, 

kpi_property, [caption]) 

Returns a key performance indicator (KPI) property 

and displays the KPI name in the cell. A KPI is a 

quantifiable measurement, such as monthly gross 

profit or quarterly employee turnover, that is used to 

monitor an organization's performance. 

CUBEMEMBER CUBEMEMBER(connection, 

member_expression, [caption]) 

Returns the logical value FALSE Returns a member 

or tuple from the cube. Use to validate that the 

member or tuple exists in the cube. 

CUBEMEMBERPROPERTY CUBEMEMBERPROPERTY(connection, 

member_expression, property) 

Returns the value of a member property from the 

cube. Use to validate that a member name exists 

within the cube and to return the specified property 

for this member. 

CUBERANKEDMEMBER CUBERANKEDMEMBER(connection, 

set_expression, rank, [caption]) 

Returns the nth, or ranked, member in a set. Use to 

return one or more elements in a set, such as the top 

sales performer or the top 10 students.  

CUBESET CUBESET(connection, set_expression, 

[caption], [sort_order], [sort_by]) 

Defines a calculated set of members or tuples by 

sending a set expression to the cube on the server, 

which creates the set, and then returns that set to 

Microsoft Excel. 

CUBESETCOUNT CUBESETCOUNT(count) Returns the number of items in a set.  

CUBEVALUE CUBEVALUE(connection, 

[member_expression1], 

[member_expression2], …) 

Returns an aggregated value from the cube. 

 Exercise 

• Exercise File: None required. 

• Exercise: Become familiar with some of Excel’s 

Engineering and Cube functions. 

More Functions and Formulas 
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Quiz Questions 

67. To change the order of evaluation, enclose the part of the formula to be calculated first in parentheses. (True or False?) 

68. Which of the following is NOT a category of functions in Excel? 
A. Scientific 
B. Financial 
C. Logical 
D. Math & Trig 

69. By default, Excel recalculates the formulas in a workbook whenever you change a value that affects another value. 

(True or False?) 

70. You can define a name for multiple non-adjacent cells. (True or False?) 

71. Which of the following is NOT a button found in the Defined Names group? 
A. Name Manager 
B. Evaluate Formula 
C. Define Name 
D. Use in Formula 

72. Click the __________ button to display arrows that show what cells affect the currently selected cell. 
A. Show Formulas 
B. Watch Window 
C. Define Name 
D. Trace Precedents 

73. The Error Checking dialog box does not include which one of the following buttons? 
A. Help on this error 
B. Show Calculation Steps 
C. Edit in Formula Bar 
D. Show Formulas 

74. What are the three arguments or parts of an IF formula? 
A. IF, THEN, ELSE 
B. The conditional statement, the value if the test is false, and the value if the test is true. 
C. The logical test, the value if the test is true, and the value if the test is false. 
D. The conditional statement, the expression, and the value. 

75. Which is NOT a required part of a PMT function? 
A. The interest rate. 
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B. The amount of the loan, or principal. 
C. The number of payments. 
D. If the interest rate is Fixed or Variable. 

76. The DSUM function calculates the totals of specific records based on your criteria. (True or False?) 

77. Which of the following functions looks up values vertically down a column and then horizontally across a row? 
A. HLOOKUP 
B. DSUM 
C. DLOOKUP 
D. VLOOKUP 

 

Quiz Answers 

67. True. To change the order of evaluation, enclose the part of the formula to be calculated first in parentheses. 

68. A. Scientific is not a category of functions in Excel. 

69. True. By default, Excel recalculates the formulas in a workbook whenever you change a value that affects another 

value. 

70. True. You can define a name for multiple non-adjacent cells. 

71. B. The Evaluate Formula button is not found in the Defined Names group. 

72. D. Click the Trace Precedents button to display arrows that show what cells affect the currently selected cell. 

73. D. The Error Checking dialog box does not have a Show Formulas button. 

74. C. The three parts of an IF formula are the logical test, the value if the test is true, and the value if the test is false. 

75. D. A fixed or variable interest rate option is not part of the PMT function. 

76. True. The DSUM calculates the totals of specific records based on your criteria. 

77. The VLOOKUP functions can look up values vertically down a column and then horizontally across a row. 
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If you organize data into a range of rows 

and columns, you can then easily sort the 

data into a desired order, or filter the data 

to display specific information, such as 

records from a specific zip code.  

In this chapter, you will learn how to sort 

and filter data in data ranges in several 

different ways. 

 

Using Exercise Files 
This chapter suggests exercises to practice 

the topic of each lesson. There are two 

ways you may follow along with the 

exercise files: 

 Open the exercise file for a lesson, 

perform the lesson exercise, and close 

the exercise file. 

 Open the exercise file for a lesson, 

perform the lesson exercise, and keep 

the file open to perform the remaining 

lesson exercises for the chapter. 

The exercises are written so that you may 

“build upon them”, meaning the exercises 

in a chapter can be performed in 

succession from the first lesson to the last. 

 

88  
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Sorting by One Column 

 In Excel you can take ranges of data and sort them into 

different orders. For example, you can sort text 

alphabetically, numbers by size, dates and times 

chronologically, cells or fonts by color or icon, or you can 

create a custom sort. Usually you sort by column (or 

field), but you can also sort by row (or record). 

Before you sort your data, make sure it’s organized into 

two components: 

 Fields (columns): Records are broken up into fields 

which store specific pieces of information, such as 

first and last name. 

 Records (rows): Each record contains information 

about a unique thing or person, just like a listing in a 

phone book. 

Once you have your data organized in columns and rows, 

you can sort by values in a certain column. 

  Trap: If your data has column headings, don’t 

select them when sorting, or they’ll be sorted 

along with your data—unless you first click the 

Sort & Filter button in the Editing group on the 

Home tab, select Custom Sort, and check the My 

data has headers box. 

1. Select the range of data or select a cell in the column 

you want to sort by. 

 Trap: If you select a column of data with more 

data next to it, the Sort Warning dialog box 

appears, asking if you want to expand your 

selection. Normally you will want to do this; 

otherwise, the column of data you’ve selected will 

be sorted independently of the surrounding data. 

2. Click the Home tab on the Ribbon and click the Sort 

& Filter button in the Editing group. 

A list of sorting options appears, which change 

according to the type of data you are sorting: 

 Text options: Sort A to Z or Sort Z to A. 

 Number options: Sort Smallest to Largest or Sort 

Largest to Smallest.  

 Date options: Sort Oldest to Newest or Sort 

Newest to Oldest. 

 Exercise 

• Exercise File: SalesReps8-1.xlsx 

• Exercise: Sort the data in the Last column from A to Z. 

(Don’t include the column header—Last—along with the 

data.) 

Figure 8-1: Before and after sorting data. 

Working with Data Ranges 

After sorting from A to Z by the Last column… 

Before sorting… 
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3. Select a sort option. 

The column is sorted based on the values in the left-

most column in the selected range. All the fields 

within each record move together. For example, if 

you sort a list of first and last names by last name, the 

first names still correspond to the last names after 

sorting. 

 Other Ways to Sort: 
Select the entire range or select a cell in the 

column you want to sort by. Click the Data tab on 

the Ribbon and click one of the sort buttons in the 

Sort & Filter group. Or, right-click a cell in a 

column that contains data, point to Sort, and 

select a sort option from the list. 

 Tips 

 To sort by rows instead of columns, click the Sort 

& Filter button in the Editing group on the Home 

tab, select Custom Sort, click Options in the Sort 

dialog box and select Sort left to right. 

Figure 8-2: Always expand the selection if you are sorting 

data in a list. If you don’t, the data will be mismatched with 
other records or fields. 

Working with Data Ranges 
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Sorting by Colors or Icons 

If you want to sort by cell colors, font colors, or by icons, 

you need to use a custom sort. 

1. Select the range of data or a cell within the range. 

The data should contain cell or font color formatting 

or icons created with conditional formatting. 

2. Click the Home tab on the Ribbon and click the Sort 

& Filter button in the Editing group. 

3. Select Custom Sort. 

The Sort dialog box appears. First you need to select 

which column to sort by. 

 Tip: If the range you are sorting includes headers, 

select the My data has headers option so that the 

headers aren’t sorted with the rest of the data. 

4. Click the Sort by list arrow and select the column 

you want to sort by. 

Next specify the type of sort. You can choose from 

Values (which allows you to sort on text, numbers or 

dates like you already learned about), Cell Color, 

Font Color, and Cell Icon. 

5. Click the Sort On list arrow and select the type of 

sort you want to use. 

Based on the type you select, the Order area will 

update to display different options. If you are sorting 

by colors or icons, you’ll need to select the order that 

you want the colors or icons to be sorted. 

 Tip: You need to define the sort order for cell 

colors, font colors, or icons. Excel does not have a 

default order like it does for values. 

6. Click the first list arrow in the Order column and 

select a cell or font color, or icon. 

Now you need to tell Excel where you want to put the 

color or icon you selected. You can select On Top or 

On Bottom to move it to the top of bottom of the 

column sort; if you are sorting by rows, select from 

On Left or On Right. 

7. Click the second list arrow in the Order column and 

select the option you want to use. 

Now the data will be sorted with the color or icon 

you selected placed on top or bottom as you 

specified. You can specify additional colors or icons 

by adding additional levels to the sort. 

 Exercise 

• Exercise File: SalesReps8-2.xlsx 

• Exercise: Sort the data by the Sales column so that the red 

cell icon is on top.  

Add a second sort level to sort by the Sales column, Cell 

Icon, and this time with the yellow icon on top. Now the 

sales reps should be sorted from red icons on top, green 

icons on the bottom.  

Finally, clear conditional formatting from the sheet: click 

the Conditional Formatting button in the Styles group on the 

Home tab. Point to Clear Rules and select Clear Rules from 

Entire Sheet. 

Figure 8-3: Sorting by cell icon in the Sort dialog box. 

Working with Data Ranges 
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8. (Optional) Click Add Level button in the Sort dialog 

box. 

A sort level is added.  

 Tip: Click the Delete Level button to delete the 

selected sort level you no longer want to use. 

9. (Optional) Repeat the steps to define the new sort 

level. Click OK when you’re done. 

For example, if you sort by a different color in the 

second sort level and order it On Top, it will move up 

just below the color selected to be On Top in the first 

level of the sort. 

Working with Data Ranges 
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Sorting by Multiple Columns 

If you want to sort by more than one column, you need to 

use a custom sort. For example, you can sort first by last 

name column, then by first name. That way, all the 

Andersons will be listed before the Bakers, and Andy 

Anderson will come before Bill Anderson. 

1. Select a range of cells with at least two columns of 

data or select a cell within the range. 

2. Click the Home tab on the Ribbon and click the Sort 

& Filter button in the Editing group.  

3. Select Custom Sort. 

The Sort dialog box appears. 

4. Click the Sort by list arrow and select the first 

column you want to sort by. 

5. Click the Sort On list arrow and select the type of 

sort you want to use. 

Most of the time you’ll sort by values, which 

includes text, numbers, and dates. 

6. Click the Order list arrow(s) and select the option(s) 

you want to use. 

To sort by multiple columns, you need to use more 

sort levels. 

7. (Optional) Click Add Level. 

Excel will sort the data by each level in order. 

8. (Optional) Repeat the sorting steps for the next level, 

selecting the next column you want to sort by, and 

add more levels. 

Excel will sort the data by each level in order. 

 Tip: Click the Delete Level button to delete a sort 

level you no longer want to use. 

9. Click OK. 

The data range is sorted accordingly. 

 Exercise 

• Exercise File: SalesReps8-3.xlsx 

• Exercise: Sort by multiple columns to see who has the 

highest sales by region: Sort first by the Region column and 

sort on Values from A to Z, then sort by the Sales column 

and sort on Values from Largest to Smallest. 

Figure 8-4: Sorting by multiple columns in the Sort dialog 
box. 

Figure 8-5: The results of the custom sort. 

Working with Data Ranges 
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Sorting by a Custom List 

A custom list allows you to sort by criteria that you define 

or by one of Excel’s predefined custom lists (which 

include, for example, Sun, Mon, Tue… or Jan, Feb, 

Mar…). 

Create a custom list 

First let’s look at how to create your own custom list. 

1. Enter the values you want to sort by, in the correct 

order from top to bottom, in a column of cells. 

For example, you could enter Small, Medium, and 

Large in successive cells. 

2. Select the values you just entered.  

Now you need to create the list. 

3. Click the File tab on the Ribbon and select Options 

from the list. 

The Excel Options dialog box appears. 

4. Click the Advanced tab, scroll down and click the 

Edit Custom Lists button. 

The Custom Lists dialog box appears. Here you can 

see the custom lists that are already stored in Excel. 

5. Make sure the cells you want to use as a list are 

selected in the Import list from cells. Click the 

Import button. 

Your new custom list appears in the dialog box. 

6. Click OK. 

The Custom Lists dialog box closes. 

7.  Click OK. 

The Excel Options dialog box closes and the custom 

list is created. 

 Tips 

 You can only create a custom list based on a value, 

not on cell color, font color, or an icon. 

 Exercise 

• Exercise File: SalesReps8-4.xlsx 

• Exercise: This exercise sorts the sales reps by position 

from most senior to least senior.  

In cells A10:A12, enter Senior Manager, Manager, and 

Associate. Create a custom list using those values. 

Next, sort the data by the Position field using the custom list 

you just created (if Sort levels appear in the dialog box from 

previous sorts, you can just modify the first one for this new 

sort).  

Then delete the values from cells A10:A12. 

Figure 8-6: Adding a custom list in the Custom Lists dialog 
box. 

Figure 8-7: The Custom Lists dialog box after the custom 
list is added. 

Working with Data Ranges 
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Sort by a custom list 

Once you’ve created a list, or if you just want to use one 

of Excel’s predefined custom lists, you’re ready to sort. 

1. Select the range of data you want to sort or select a 

cell within the range. 

2. Click the Home tab on the Ribbon, click the Sort & 

Filter button in the Editing group, and select Custom 

Sort. 

The Sort dialog box appears. 

3. Click the Sort by list arrow and select a column to 

sort by (the column with data that matches the 

custom list). 

4. Click the Order list arrow and select Custom List. 

The Custom Lists dialog box appears. 

5. Select the custom list you want to use and click OK.  

6. Click OK. 

The data is sorted according to the custom list. 

 Tips 

 To sort by rows instead of columns, click Options in 

the Sort dialog box and select Sort left to right. 

Figure 8-8: Results sorted by custom list. 

Working with Data Ranges 
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Filtering Data 

When you filter data, Excel displays only the records that 

meet the criteria you specify—other records are hidden. 

You can also filter by multiple columns; each time you 

filter by an additional column, the data is further reduced. 

Filter text, numbers and dates 

You can filter by values such as text, numbers, or dates. 

1. Select the range of data you want to filter or select a 

cell within the range.  

2. Click the Home tab on the Ribbon, click the Sort & 

Filter button in the Editing group, and click Filter. 

Filter buttons that look like arrows appear in the first 

cell of each field header. 

 Other Ways to Filter: 
Click the Data tab on the Ribbon and click the 

Filter button in the Sort & Filter group. 

3. Click the filter button for the column you want to 

filter. 

A list of filter options appears at the bottom of the 

list. There is an option for every entry in the field. 

4. Checkmark the check boxes of values that you want 

to display. Remove the checkmarks from check boxes 

of values that you want to hide. 

The data is filtered so that records that do not meet 

the criteria are hidden.  

 Other Ways to Select Filter Criteria: 
Click the Search box in the filter list and type the 

criteria by which you want to filter. The list 

displays criteria that match your search. 

You can keep filtering by additional columns. 

5. (Optional) Click another column’s filter button and 

apply more filter criteria. 

6. Click OK. 

The data is further reduced. 

Remove filtering 

You can remove a filter to once again display all the data. 

1. Click the Home tab on the Ribbon, click the Sort & 

Filter button in the Editing group, and select Filter. 

The filter buttons disappear and filtering is removed. 

 Exercise 

• Exercise File: SalesReps8-5.xlsx 

• Exercise: Filter the data by region so that only North sales 

reps appear. Then filter those records additionally so only 

Associates appear (only Denise Winters should remain). 

Remove the filters so all the data once again appears and the 

filter buttons disappear. 

Figure 8-9: Data filtered to display only North region sales 
reps. 

Figure 8-10: Setting criteria for a field. Items that are 

checked are shown. Items that are not checked are filtered 
out. 

Working with Data Ranges 

Filter buttons appear as arrows in 
the field headers. 

To make the AutoFilter 
menu wider or longer, click 
and drag the grip handle. 
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Creating a Custom AutoFilter 

Excel offers some predefined filter criteria that you can 

access using a Custom AutoFilter. This lesson explains 

how to filter data using Custom AutoFilter. 

1. Select a range of cells to filter plus the column header 

row (or a blank row, if there isn’t a header). 

2. Click the Home tab on the Ribbon, click the Sort & 

Filter button in the Editing group, and click Filter.  

Filter buttons appear in the first cell of each column 

in the range. 

3. Click the filter button in the column you want to 

filter. 

A list of options appears. Depending on whether the 

selected cells contain text, numbers, or dates, the 

options will differ. 

4. Point to the option that appears in the list: Text 

Filters, Number Filters, or Date Filters. 

A list of comparison operators, such as Equals, 

appears, as well as the Custom Filter option. 

5. Select Custom Filter. 

The Custom AutoFilter dialog box appears. 

 Tip: If you’re working with numbers or dates and 

you select a comparison operator such as Above 

Average (instead of selecting Custom Filter), the 

Custom AutoFilter dialog box won’t appear—the 

data will simply be filtered. 

6. Click the first list arrow and select a comparison 

operator. 

7. Click the second list arrow in the first row and select 

a value from the list or enter your own value in the 

text box.  

8. (Optional) Select And or Or and select a second 

criteria to filter the column by. 

 Tip: You can use wildcards when entering values 

in the Custom AutoFilter dialog box. Use a ? to 

represent any single character or a * to represent a 

series of characters. 

9. Click OK. 

The Custom AutoFilter dialog box closes and the data 

is filtered. 

 Exercise 

• Exercise File: SalesReps8-6.xlsx 

• Exercise: Use a custom filter to display only the sales reps 

that are not Associates. (Hint: For the Position column, 

select “Does not equal” as the operator and “Associate” as 

the value.) 

Clear the filter.  

Figure 8-11: The Custom AutoFilter dialog box. 

Working with Data Ranges 
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Using an Advanced Filter 

Advanced filtering is the most powerful and flexible way 

to filter your Excel data. It’s also the most difficult 

method, and requires more work to set up and use. With 

an Advanced Filter, you can: 

 Filter using criteria located outside of the data range. 

 Use wildcards in the filter criteria. 

 Extract and copy filtered results to another range on 

the worksheet.  

To create an Advanced Filter you must start by defining a 

criteria range. A criteria range is a cell range located 

outside of your data range that contains the filter criteria. 

1. Copy the desired column labels from the data range 

and paste them in the first row of the criteria range. 

For example, if you wanted to filter for sales reps 

with sales greater than $20,000 and who are also 

managers, you would copy the Sales and Position 

column labels to the criteria range. 

 Tip: The criteria range can be any area of open 

cells on your worksheet and you only need to 

copy the labels for the columns that contain 

criteria you’ll be filtering on. 

2. In the rows below the criteria labels, type the criteria 

you want to filter for.  

In the above example, you would type >20000 under 

the Sales label and Manager under the Position label.  

 Tip: You can enter values or text you want to 

filter for, and you can incorporate operators such 

as < or > to specify the records you want to filter 

for. You can also use wildcards—for example, 

enter *r to filter out text that doesn’t end with the 

letter “r”. 

3. Click the Data tab on the Ribbon and click the 

Advanced button in the Sort & Filter group. 

The Advanced Filter dialog box appears. Here you 

need to specify the range of data you want to filter, as 

well as the criteria you want to filter by. 

4. Make sure the Filter the list, in-place option is 

selected in the Action area. 

That way, the filtered results will be displayed right 

in the original data range. 

 Tip: To copy filtered results to another location 

on the worksheet, first prepare an extract range 

with labels for the fields you want to display. The 

 Exercise 

• Exercise File: SalesReps8-7.xlsx 

• Exercise: Use the Advanced Filter to filter for Sales 

>18,000, and a Position that ends with r (Hint: use *r). 

Clear the filter.  

Do the same Advanced Filter again, but this time extract the 

results to a different range. Extract only the Last and First 

columns to a different range (you should end up with Clem 

Brown being displayed in the extract range). 

Figure 8-12: The Advanced Filter dialog box. 

Figure 8-13: Data filtered in place using the Advanced 
Filter. 

Working with Data Ranges 

The Copy to 
another 
location option 
copies the 
results of the 
filter to 
another 
location in the 
worksheet or 
workbook. 

 

 

 

 

 

When the list is filtered in 
place, the records that don’t 
match the criteria are hidden. 

Criteria range 
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extracted fields needn’t be the same fields that are 

used in your criteria range. For example, you can 

set the filter to only show records from USA, and 

then extract only the names of records that match 

those criteria. Select Copy to another location in 

the Action area of the Advanced Filter dialog box. 

In the “Copy to” box, click the Collapse Dialog 

button, select the range for the extracted results—

including labels and blank rows to hold the 

results—and press <Enter>. 

5. Click the List range collapse dialog button and 

select the data range you want to filter. Press the 

<Enter> key. 

6. Click the Criteria range collapse dialog button and 

select the criteria range, including the column labels. 

Press the <Enter> key. 

7. Click OK. 

The data is filtered based on the criteria in the criteria 

range, and the results are displayed in the data range. 

 Tip: To remove the advanced filtering, click the 

Clear button in the Sort & Filter group on the 

Data tab. 

The table below, Comparison Operators and 

Wildcards, provides a description of operators and 

wildcards you can use for entering filter criteria. 

Table 8-1: Comparison Operators and Wildcards 

= Equal to 

< > Not equal to 

> Greater than 

< Less than 

> = Greater than or equal to 

< = Less than or equal to 

* Wildcard--any number of characters in the same position as the asterisk 

Example: “*east” finds "Northeast" and "Southeast" 

? Any single character in the same position as the question mark 

Example: sm?th finds "smith" and "smyth" 

Figure 8-14: Filter results copied to another location 
(extracted) using the Advanced Filter. 

Working with Data Ranges 

Criteria 
range 

Extract range 



172 © 2010 CustomGuide, Inc. 
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Quiz Questions 

78. Before you sort data, make sure it's organized into... 
A. a chart. 
B. alphabetical order. 
C. a pivot table. 
D. columns and rows. 

79. You can sort Excel data by any of the following, except by... 
A. font color. 
B. cell icon. 
C. number formatting. 
D. cell color. 

80. To sort by multiple columns, use the __________. 
A. Sort dialog box 
B. Column Specifier button 
C. Sort Columns window 
D. drag and drop feature 

81. You can create your own custom list for sorting or use a predefined custom list. (True or False?) 

82. Which one of the following is a way to turn on the filtering buttons? 
A. Click the Insert tab and click the Filter button in the Filter group. 
B. Click the Filter tab and click the Filter button in the Filter group. 
C. Click the Home tab on the Ribbon, click the Sort & Filter button in the Editing group, and click Filter. 
D. Type the formula =Filter(Data) in the first cell of the column you want to filter. 

83. You can use wildcards when entering values in the Custom AutoFilter dialog box. (True or False?) 

84. With an Advanced Filter, you can do all of the following, except... 
A. Extract and copy filtered results to another range on the worksheet. 
B. Use wildcards in the filter criteria. 
C. Filter using criteria located outside of the data range. 
D. You can do all of these things. 

 

Quiz Answers 

78. D. Before you sort data, make sure it's organized into columns and rows. 
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79. C. You can sort data by cell icon, cell or font color, but not by number formatting. 

80. A. Use the Sort dialog box to sort data by multiple columns. 

81. True. You can either create your own custom list or use a predefined custom list. 

82. C. To display the filtering buttons, click the Home tab on the Ribbon, click the Sort & Filter button in the Editing 

group, and click Filter. 

83. True. You can use wildcards when entering values in the Custom AutoFilter dialog box. 

84. D. You can do all these things with an Advanced Filter. 
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Tables—called lists in previous versions 

of Excel—make it easier to work with 

ranges of Excel data. By turning an Excel 

range into a table, you can work with the 

table data independently from the rest of 

the worksheet. You can quickly sort and 

filter the table columns, add total rows, 

and apply table formatting to an Excel 

table.  

Some examples of things you might track 

in a table include telephone numbers, 

clients, and employee rosters. Once you 

create a table in Excel, you can easily 

find, organize, and analyze its information 

with Excel’s rich set of table-management 

features. 

Using Exercise Files 
This chapter suggests exercises to practice 

the topic of each lesson. There are two 

ways you may follow along with the 

exercise files: 

 Open the exercise file for a lesson, 

perform the lesson exercise, and close 

the exercise file. 

 Open the exercise file for a lesson, 

perform the lesson exercise, and keep 

the file open to perform the remaining 

lesson exercises for the chapter. 

The exercises are written so that you may 

“build upon them,” meaning the exercises 

in a chapter can be performed in 

succession from the first lesson to the last. 

9 
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Creating a Table 

 By turning an Excel range into a table, you can work 

with the table data independently from the rest of the 

worksheet, and filter button arrows appear automatically 

on the column headers, allowing you to filter and sort 

columns even faster. You can also add total rows and 

quickly apply table formatting. 

Tables, like normal data ranges of data, consist of two 

parts: 

 Records (rows): Each record contains information 

about a unique thing or person, just like a listing in a 

phone book. 

 Fields (columns): Records are broken up into fields 

which store specific pieces of information, such as 

first and last name. 

 Tips 

 Before you turn a range of data into a table, 

remove blank rows and columns, and make sure 

that you don’t have different types of data within 

one column.  

 If desired, make sure you have entered column 

headers. For example, if you want to make a table 

that lists your company’s sales reps, you could 

enter headers such as Last Name, First Name, 

Territory, etc. Unique records, such as the names 

and territories of each of your sales reps, should 

be entered as rows. 

Create a table from a cell range 

If you already have an organized range of data, you can 

turn it into a table. 

 1. Select a cell range that you want to make into a table. 

Normally you will want the cell range to include a 

header row, with labels identifying each of the 

columns. 

  Other Ways to Create a Table: 
You can simultaneously create and format a table. 

Select the cells you want to include in the table 

and click Format as Table in the Styles group on 

the Home tab. Select a table style. Click OK. 

2. Click the Insert tab on the Ribbon and click the 

Table button in the Tables group. 

The Create a Table dialog box appears. Here you can 

edit the range that will become a table, and you can 

specify whether or not your table has a header row (if 

it doesn’t, Excel adds a header row above the table 

data). 

 Exercise 

• Exercise File: Table9-1.xlsx 

• Exercise: Turn the data range A1:H19, including the 

column labels, into a table. 

Figure 9-1: Creating a table from a cell range. 

Working with Tables 

This option should be 
selected if headers 
are included in the 
selected cell range. 
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3. Set the options in the Create a Table dialog box and 

click OK. 

The table is created. Filters are added to each column, 

and the table is automatically formatted. Under Table 

Tools on the Ribbon, the Design contextual tab 

appears. 

Create a blank table 

If you haven’t already entered the data you want to 

include in a table, you can create the table first. 

1. Select a range of cells that is approximately the size 

you want your table to be. 

You can always change the size later. 

2. Click the Insert tab on the Ribbon and click the 

Table button in the Tables group. 

The Create Table dialog box appears. 

3. Click OK. 

The table appears, including placeholder column 

headers that you can edit, and a resize handle that 

appears in the lower-right corner of the table. 

The table below, Tips for Organizing Tables, provides 

ideas for setting up your table data. 

Table 9-1: Tips for Organizing Tables 

Avoid putting blank rows and columns in the table. So that Microsoft Excel can more easily detect and select the table. 

Create column labels in the first row of the table. Excel uses the labels to create reports and to find and organize 

data. 

Design the table so that all rows have similar items in the same 

column. 

This makes the table more meaningful and organized. 

Try to break up information as much as possible. This gives you more power to sort, filter and manipulate the table. 

Each column should contain the same type of information. This will make the table easier to read and understand. 

Don’t use duplicate field names. Duplicate field names can cause problems when entering and 

sorting information. 

Working with Tables 
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Adding and Removing Data 

You can easily add or remove table data.  

Add table rows and columns 

1. Select a cell in the table row or the table column next 

to which you want to add the row or column. 

You will be able to add a new table row above the 

row you selected, or add a new column to the left of 

the column you selected (unless you selected the last 

column, in which case you can also add a column to 

the right). 

 Tip: Select only the columns or rows within the 

table for more inserting options. For example, 

clicking a column header does not allow you to 

choose if you want to insert new columns to the 

right or left. 

2. Click the Home tab on the Ribbon and click the 

Insert button list arrow. 

The options available here change, depending on the 

cell(s) that are selected in the table or sheet. 

3. Select the insertion option you want to use. 

A row or column is inserted into the table. 

 Other Ways to Insert a Table Row Or Column: 
Right-click the row or column where you want to 

add a row or column, point to Insert in the 

contextual menu, and select Insert Table Rows 

Above or Insert Table Columns to the Left or 

Right. Or, to add a new row to the bottom of the 

table, place the cell pointer in the last cell of the 

table and press <Tab>. 

 Tips 

 When you enter a formula in a blank column of a 

table, the formula is automatically extended to all the 

rest of the column—without using the AutoFill 

feature. If you add rows to the column, the formula 

appears in those rows as well. 

Remove table rows and columns 

You can also remove unwanted table rows and columns 

by deleting them.  

1. Select the table row(s) or columns(s) you want to 

delete. 

Remember that doing this removes the data from the 

worksheet completely. 

 Exercise 

• Exercise File:  Table9-2.xlsx 

• Exercise: Add this data to the bottom of the table:  

First Last Address City State Zip 

Elsa Martinez 413 Oak St Faribault MN 55021 

Bob Arthur 326 Elm Ave Toma WI 54660 

 

Annual Trips Income    

4 $40,000    

5 $88,000    

Figure 9-2: Adding data to a table. If data appears 

previously in a column, Excel will offer an AutoComplete 
option as you enter data. 

Working with Tables 
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2. Click the Home tab on the Ribbon and click the 

Delete button list arrow in the Cells group. 

3. Select Delete Table Columns or Delete Table Rows. 

The selected row(s) or column(s) are deleted. 

 Other Ways to Delete a Table Row or Column: 
Right-click the row or column you want to delete, 

point to Delete in the contextual menu, and select 

Table Columns or Table Rows. 

Resize a table 

Expand the size of a table to include more data, or reduce 

the size to remove data. 

1. Select a cell in the table. 

2. Under Table Tools on the Ribbon, click the Design 

tab. 

3. Click the Resize Table button in the Properties 

group. 

The Resize Table dialog box appears.  

4. Select the range you want to include in the table. 

5. Click OK. 

The table is resized. If cells are added to the table,   

they are empty so you can enter data in the cells. 

 Other Ways to Resize a Table: 
Click and drag the sizing handle in the lower-right 

corner of the table to include more or fewer cells. 

Or, enter data in a cell below or to the right of the 

table; the table automatically expands. 

Figure 9-3: Resizing a table using the sizing handle. 

Working with Tables 
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Working with the Total Row 

With the Total Row feature, Excel will automatically add 

a total row to the bottom of a table and sum the last 

column of the table. The total row can also perform other 

types of calculations. 

Add a Total row 

1. Select a cell in the table.  

Table Tools appear on the Ribbon. 

2. Click the Design contextual tab under Table Tools on 

the Ribbon. 

Now you have access to commands that can help you 

change the design of your table. 

3. Click the Total Row option in the Table Style 

Options group so that it is selected. 

A Total row appears at the bottom of your table and 

the last column is summed. 

 Tip: If the last column doesn’t contain numbers, 

Excel displays a count of the number of items in 

the column. 

Calculate Total row values  

Once you’ve added a total row, you can decide what type 

of calculation you want to perform for the total of each 

table column. 

1. In the Total row, select the cell at the bottom of the 

column that contains values you want to calculate. 

2. Click the cell’s list arrow and select the calculation 

you want to perform. 

The table below, Total Row Calculation Options, 

describes the different types of calculations that 

Excel can perform in the Total row. 

Structured references 

Structured references allow you to work easily with cell 

references and formulas in a table. For example, instead 

of using a cell range reference such as C2:C6 in a 

formula, you can refer to the cell range as SaleAmt (the 

table column name) instead. 

When you create a formula using structured references, 

you can use several different elements in place of the 

regular arguments. These include the table name, column 

header names, or special items that refer to areas of the 

table, such as a total row. 

 Exercise 

• Exercise File:  Table9-3.xlsx 

• Exercise: Add a Total row to the table.  

 Calculate the Average of the Income column. 

Figure 9-4: The table with the Total row added to the 
bottom of the table. 

Working with Tables 

Click the list arrow for a cell in the Total 
row to view common functions you can 
do with the table column’s values. 
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 Tip: When entering references in a formula in a 

table, if you click on the cells to select them 

(instead of typing in their cell addresses) Excel 

will enter structured references for you. 

Table 9-2: Total Row Calculation Options 

None No function is inserted. 

Average Calculates the average, or arithmetic mean, of the numbers in the column. 

Count Counts the number of all nonblank cells, regardless of what they contain. 

Count Numbers Counts the number of cells that contain numbers, including dates and formulas. Ignores all blank cells and cells 

that contain text or errors. 

Max Returns the largest value in a column. 

Min Returns the smallest value in a column. 

Sum Adds all of the numbers in a column. 

StdDev Estimates standard deviation based on a sample. The standard deviation is a measure of how widely values are 

dispersed from the average value. 

Var Estimates variance based on a sample. 

More Functions… Opens the Insert Function dialog box, where you can choose a different function to perform on the column’s 

values. 

Working with Tables 
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Sorting a Table 

Excel is very good at sorting information. Excel can sort 

records alphabetically, numerically, or chronologically (by 

date). Additionally, Excel can sort information in 

ascending (A to Z) or descending (Z to A) order. You can 

sort an entire list or any portion of a list by selecting it. 

1. Click the filter button for the column you want to 

sort. 

A list appears, displaying several options for sorting 

the table data. The options at the top are for sorting.  

 Other Ways to Sort: 
Click the Home tab and click the Sort & Filter 

button in the Editing group. Select a sorting 

option from the list. 

2. Select the sort option you want to use.  

3. Click OK. 

 Tips 

 If you add or edit data in a table that is filtered or 

sorted, you need to click the Reapply button in 

the Sort & Filter group on the Data tab to include 

the new or edited data. 

Custom Sorting 

When you need to sort by more than one field, you have 

to use a Custom Sort.  

The Custom Sort can sort records by more than one field, 

such as if you want to sort alphabetically by first and last 

name, or by state and city. 

1. Click a field’s filter button and select Sort by  

Custom Sort from the list. 

The Custom Sort dialog box appears. 

 Other Ways to Use Custom Sort: 
Click the Home tab and click the Sort & Filter 

button in the Editing group. Select Custom Sort 

from the list. 

2. Click the Sort by list arrow and select the field by 

which you want to sort.  

This is the first field you want to sort by. 

3. Click the Sort on list arrow and choose what you 

want to sort by in the field. 

The options for the Order change depending on what 

you choose for the Sort On variable. 

 Exercise 

• Exercise File:  Table9-4.xlsx 

• Exercise: Sort by Last name in Ascending order (A-Z).  

 Apply a custom sort to sort first by Last name, and then 

First name. 

Figure 9-5: The list before and after being sorted in 
ascending order by the Last field. 

Figure 9-6: An example of sorting a table by multiple 
fields. 

Working with Tables 
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4. Click the Order list arrow and select the order by 

which you want to sort the data. 

5. Click OK. 

6. (Optional) To sort by multiple fields, click the Add 

Level button and set the sort specifications for the 

next field. 

7. Click OK.  

The data in the table is sorted by the sort 

specifications. 

Figure 9-7: The table sorted by last name, then first name. 

Working with Tables 
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Filtering a Table 

When you create a table, a filter button that looks like a 

list arrow is added to the header of each column in the 

table. You can use this arrow to filter the table columns; 

they remain available when you scroll down the list. 

1. Click the filter button for the column you want to 

filter. 

A list appears, displaying several options for sorting 

or filtering the table data. The check boxes are all the 

data entries for the selected field. 

2. Click the check box(es) of the filter criteria you want 

to use. 

 Other Ways to Select Filter Criteria: 
Click the Search box in the filter list and type the 

criteria by which you want to filter. The list 

displays criteria that match your search. 

3. Click OK. 

Clear a filter 

When you’re finished with a filter, you can clear it so all 

the table data appears again. 

1. Click the filter button for the filter you want to clear. 

2. Select Clear Filter From from the list. 

The filter is cleared and the table data is displayed 

without the filter. 

Custom AutoFilter 

When you need to filter using more complicated criteria, 

you have to use a Custom AutoFilter. Custom AutoFilters 

are more difficult to set up and create than ordinary 

AutoFilters, but they’re much more flexible and powerful.  

1. Click a field name list arrow and select Custom from 

the list. 

2. Select Text Filters or Number Filters from the list. 

A list of ways to filter the text appears. 

3. Select a filter option from the list.  

The Custom Filter dialog box appears. 

4. Complete the dialog box as necessary and click OK. 

Excel now filters the table by the custom filter. 

 Exercise 

• Exercise File:  Table9-5.xlsx 

• Exercise:  Filter the table to show only records that take 2 

annual trips and are from Duluth. Clear the filters. 

 Apply a custom filter to show the top 10 records from the 

Incomes fields. Clear the filters. 

Figure 9-8: To filter, click a column filter button and click 

the check box(es) for the criteria by which you want to 
filter the table. 

Figure 9-9: Removing a filter. 

Figure 9-10: The Top 10 Custom Sort dialog box. 

Working with Tables 

When a filter is applied 
to a column, the filter 
button changes. 
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Removing Duplicate Rows of 
Data 

If there are duplicate rows of identical data in your table, 

Excel can find and remove the duplicate rows for you. 

 Trap: Removing duplicate values actually deletes 

the duplicate data, so you may want to copy the 

data to another worksheet or workbook first in 

case. 

1. Select a cell in the table. 

 Tip: You can remove duplicates from cell ranges 

outside of a table as well, but in that case you 

need to select the entire cell range you want to 

examine. 

2. Click the Data tab on the Ribbon and click the 

Remove Duplicates button in the Data Tools group. 

The Remove Duplicates dialog box appears. 

 Other Ways to Display the Remove Duplicates 

Dialog Box: 
Select a cell in the table. Under Table Tools on the 

Ribbon, click the Design tab. Click the Remove 

Duplicates button in the Tools group. 

3. Select the columns you want to check for duplicates. 

All columns are selected by default, but you can 

select/deselect individual columns in the Columns 

list. You can also use the Select All and Unselect All 

buttons to select columns. 

4. Click OK. 

Duplicate values are deleted and a message appears, 

telling you how many duplicate values that were 

found and removed. 

5. Click OK. 

 

 Exercise 

• Exercise File:  Table9-6.xlsx 

• Exercise: Remove duplicate rows of data (select all 

columns). 

Figure 9-11: The Remove Duplicates dialog box. 

Figure 9-12: The results of the remove duplicates 
command. 

Working with Tables 

Unselect All makes it easier if 
you only want to select a few 
columns. 

Choose the column(s) by which you want to 
delete duplicates.  
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Formatting the Table 

You can change the appearance of a table by applying a 

preset table formatting style. 

Apply a style while creating a table 

You can apply a style while also creating a table.  

1. Select a cell range that you want to format as a table. 

2. Click the Home tab on the Ribbon and click the 

Format as Table button in the Styles group. 

The table format gallery appears. Here you can select 

styles from the Light, Medium, or Dark categories. 

You may need to scroll down the list to see the Dark 

category. 

3. Select a table style. 

The Format As Table dialog box appears. 

4. Click OK. 

A table is created and formatted with the selected 

style. Table Tools appear on the Ribbon, and the 

Design contextual tab appears. 

Apply a table style to an existing table 

1. Select a cell in the table. 

2. Under Table Tools on the Ribbon, click the Design 

tab. 

3. Select the style you want to use in the Table Styles 

group. 

 Tip: To display the entire Table Styles gallery, 

click the More button in the Table Styles group. 

Remove a table style 

You can easily remove a table style from a table. 

1. Select the table that is formatted with the table style. 

The Design tab appears. 

2. Under Table Tools on the Ribbon, click the Design 

tab. 

3. Click the None style or select Clear in the Table 

Styles group. 

The table format is removed. 

 Exercise 

• Exercise File:  Table9-7.xlsx 

• Exercise: Apply Table Style Light 17 to the table. 

 Select the First Column and Last Column options in the 

Table Style Options group. 

Figure 9-13: The table with a new table style, and with 
First Column and Last Column style options applied. 

Working with Tables 

The Table Styles Gallery 
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Format the table style 

After applying a table style, you can format individual 

table style elements. 

1. Select a cell in the table. 

2. Under Table Tools on the Ribbon, click the Design 

tab. 

The formatting options available in the Table Style 

Options group include: 

 Header Row: Toggles the table’s header row on 

and off. 

 Total Row: Adds a total row to the bottom of the 

table. This option doesn’t just change formatting, 

but also allows you to calculate values in the total 

row. 

 First/Last Column: Displays special formatting 

for the first or last columns in the table. 

 Banded Rows/Columns: Displays odd and even 

rows and columns differently for easier reading. 

3. Select the option(s) you want to use in the Table Style 

Options group.  

Working with Tables 
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Using Data Validation 

You can help users enter accurate and appropriate 

information into your worksheets with Excel’s Data 

Validation feature. Data validation restricts the type of 

information that can be entered into a cell and can provide 

the user with instructions on entering information in a 

cell. 

Set validation criteria 

To use data validation, you first need to specify the 

validation criteria you want to use. 

1. Select the cells you want to validate. 

You will usually want to select a column of data, 

although you can select a single cell as well. 

2. Click the Data tab on the Ribbon and click the Data 

Validation button in the Data Tools group. 

The Data Validation dialog box appears, displaying 

the Settings tab. 

3. Click the Allow list arrow and select the criteria 

option you want to use. 

The table below and to the right, Validation Criteria 

Options, describes your choices. 

Depending on your criteria selection, you will next 

need to select a Data option, and/or select additional 

options in the dialog box. You may also need to enter 

values.  

4. Complete the remaining fields on the Settings tab and 

click OK. 

The data validation is set for the selected cell(s). Now 

when a user tries to enter data that is not valid, Excel 

will prevent the entry and display a message about 

the cell being restricted. 

 Tips 

 By default, when you enter invalid data in a validated 

cell, a warning message appears and entry of the 

invalid data is not allowed. However, you can modify 

the message that appears, and even allow invalid data 

to be entered into a validated cell. To do this, click 

the Error Alert tab in the Data Validation dialog box 

and select the desired options. 

 To find validated data in a worksheet, click the Find 

& Select button in the Editing group on the Home tab 

and select Data Validation. The validated cells are 

highlighted. 

 Exercise 

• Exercise File:  Table9-8.xlsx 

• Exercise: Extend the table to include column I, and add a 

“Purpose” label to the column.  

 Set data validation in column I so that the data entry can be 

selected from a list of these options: Senior Manager, 

Manager, Associate. Enter “Associate” using the list in I2. 

 Set data validation in column E that sets the text length of 

the entries equal to 2. Create an input message for column E 

cells that displays: “Enter the state code.” 

 To test it, enter “Minnesota” in cell E2 and press <Enter>. 

Click Retry and enter “MN”. 

Table 9-3: Validation Criteria Options 

Any value No validation criteria applied. Any value 

can be entered. 

Whole number Allows a whole number between 

minimum and maximum limits you set. 

Decimal Allows a decimal or a percent entered as a 

decimal between limits you set. 

List Allows a value from a list of choices you 

input or select from a range. A list arrow 

then appears in the cell, allowing the user 

to make a choice from the list. 

Date Allows a date within prescribed limits. 

Time Allows a time within prescribed limits. 

Text length Allows text containing a certain number of 

characters that you prescribe. 

Custom Allows you to enter a formula to calculate 

what is allowed in the cell. 

Figure 9-14: Creating a list in the Data Validation dialog 
box. 

Working with Tables 
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 To remove validation criteria, select the cells that 

contain the validation you want to remove, and click 

the Data Validation button in the Data Tools group 

on the Data tab. Click Clear All, then click OK. 

Create an input message 

You can set up Excel to display a message whenever a 

cell or range of cells is selected. These messages are 

useful for providing data entry instructions. 

1. Select the cells where you want an input message to 

appear. 

The input message will appear when the cell or cells 

are selected. 

2. Click the Data tab on the Ribbon and click the Data 

Validation button in the Data Tools group. 

The Data Validation dialog box appears.  

3. Click the Input Message tab. 

 Tip: Make sure the “Show input message when 

cell is selected” box is selected—it should be 

selected by default. 

4. Click in the Title box and type a title for the message. 

The title will be displayed along with the message 

when you select the cell(s). 

5. Click in the Input message box and type a data input 

message. 

For example, you could enter instructions such as 

“Enter State name as a two-letter abbreviation”. 

6. Click OK. 

Now when you select the cell(s), you will see the title 

and message displayed. 

Figure 9-15: Selecting data from a data validation list. 

Figure 9-16: Defining text length in the Data Validation 

dialog box. 

Figure 9-17: An error message appears when you try to 
enter data that does not match a data validation rule. 

Working with Tables 
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Summarizing a Table with a 
PivotTable  

You can analyze table data by using it in a PivotTable. 

1. Select a cell in the table. 

The Table Tools appear on the Ribbon.  

2. Under Table Tools on the Ribbon, click the Design 

contextual tab and click the Summarize with 

PivotTable button in the Tools group. 

The Create PivotTable dialog box appears. 

3. Click OK. 

A new sheet is added to the workbook to 

accommodate the PivotTable report. Here you can 

create a PivotTable to analyze the data in your table, 

according to your specifications.  

 Tips 

 Other lessons describe how to work with PivotTables 

in more detail. This is the simplest way to view a 

summary of the table in a PivotTable. 

 Exercise 

• Exercise File:  Table9-9.xlsx 

• Exercise: Summarize the table with a PivotTable on a new 

worksheet. Experiment with the PivotTable tools, then 

delete the worksheet containing the PivotTable. 

Figure 9-18: The Create PivotTable dialog box. 

Figure 9-19: Summarizing table data with a PivotTable. 

Working with Tables 

Click a check box 
to use the field’s 
data in the report. 

Click and drag the 
fields between the 
boxes to change 
how the data is 
analyzed. 

The pivot table report is displayed 
according to the fields you choose. 
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Converting to a Range 

If you no longer want a table, you can turn it back into a 

normal range. 

1. Select a cell in the table. 

Under Table Tools on the Ribbon, the Design 

contextual tab appears. 

2. Under Table Tools on the Ribbon, click the Design 

contextual tab and click the Convert to Range 

button in the Tools group. 

3. Click Yes. 

The table converts back to a normal range of cells, 

but the table formatting is still applied.  

 Other Ways to Convert a Table to a Range: 
Select the table, right-click the table and select 

Table  Convert to Range from the contextual 

menu. 

 Exercise 

• Exercise File:  Table9-10.xlsx 

• Exercise: Convert the table back to a normal range of 

cells. Undo that action.  

Figure 9-20: The Convert to Range button. 

Working with Tables 



  University of Virginia Health System 191 

WWoorrkkiinngg  wwiitthh  TTaabblleess  RReevviieeww  

Quiz Questions 

85. You can create a blank table or a table that uses an existing data range. (True or False?) 

86. Which of the following is NOT a way to resize a table? 
A. Click the Resize Table button in the Properties group. 
B. Use the Resize Table Wizard. 
C. Enter data in a cell below or to the right of the table. 
D. Click and drag the table’s sizing handle. 

87. By default, when you add a total row to a table, the last column is summed. (True or False?) 

88. Custom sorting allows you to sort data by multiple columns. (True or False?) 

89. Which of these is NOT a custom autofilter in Excel? 
A. Top 10 
B. Equals 
C. Contains 
D. Color 

90. Removing duplicates from a table moves the duplicate data to another worksheet. (True or False?) 

91. Once you apply a table style to a table, you can't change it to a different one. (True or False?) 

92. Which of the following is NOT a formatting option in the Table Style Options group? 
A. Header Row 
B. Checkered Rows 
C. Banded Columns 
D. First Column 

93. Which of the following statements is NOT true? 
A. You can provide users with information and feedback using Data Validation. 
B. To use Data Validation, click the Data Validation button in the Data Tools group on the Data tab. 
C. You must protect the worksheet to use the data validation feature. 
D. Data validation lets you restrict which type of information is entered in a cell. 

94. You can summarize and analyze table data using a ________. 
A. PivotTable 
B. PivotSheet 
C. PivotGrid 
D. DataSheet 
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95. When you convert a table to a range, the table formatting remains applied to the cells. (True or False?) 

 

Quiz Answers 

85. True. You can create a blank table or a table that uses an existing data range. 

86. B. There isn't a Resize Table Wizard in Excel. 

87. True. When you add a total row to a table, the last column is summed by default. 

88. True. Custom Sorting allows you to sort by multiple levels, so you can sort by multiple columns. 

89. D. Color is not a filter option in Excel. It is, however, a way you can sort. 

90. False. Removing duplicates from a table deletes the data completely. 

91. False. You can always change table styles. 

92. B. Checkered Rows is not an option in the Table Style Options group. 

93. C. You don't need to protect the worksheet to use the data validation feature. 

94. A.You can summarize and analyze table data using a PivotTable. 

95. True. When you convert a table to a range, the table formatting remains applied to the cells. 
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There are many ways to analyze 

worksheet data, including sorting and 

filtering records. This chapter explains 

how to use a PivotTable to analyze data 

ranges. 

A PivotTable is usually the best way to 

summarize and analyze data ranges or 

tables. PivotTables are good for grouping 

or expanding levels of data, switching 

columns and rows (“pivoting” data), and 

filtering and sorting. They lend 

themselves particularly well to 

summarizing long lists of data that need 

to be summed.  

This chapter explains how to create 

PivotTables, modify their structure, and 

create PivotCharts that graphically 

illustrate PivotTables. 

Using Exercise Files 
This chapter suggests exercises to practice 

the topic of each lesson. There are two 

ways you may follow along with the 

exercise files: 

 Open the exercise file for a lesson, 

perform the lesson exercise, and close 

the exercise file. 

 Open the exercise file for a lesson, 

perform the lesson exercise, and keep 

the file open to perform the remaining 

lesson exercises for the chapter. 

The exercises are written so that you may 

“build upon them”, meaning the exercises 

in a chapter can be performed in 

succession from the first lesson to the last. 

 

10 



194 © 2010 CustomGuide, Inc. 

Creating a PivotTable 

To create a PivotTable, you need to decide which fields 

you want to include, how you want your PivotTable 

organized, and what types of calculations your PivotTable 

should perform.  

Don’t worry if PivotTables are confusing at first, they will 

make a lot more sense once you’ve actually created one. 

1. Select a cell in a data range.  

 Other Ways to Create a PivotTable: 
Select a cell in a table, click the Design tab on the 

Ribbon, and click the Summarize with Pivot 

button in the Tools group. 

2. Click the Insert tab on the Ribbon and click the 

PivotTable button in the Tables group. 

The Create PivotTable dialog box appears and a 

moving dashed line appears around the data range 

that Excel will use for the PivotTable. 

 Tip: The data range doesn’t have to be in the 

current workbook. Select the Use an external 

data source option to select data outside the 

workbook. 

3. If necessary, select the data range you want to 

analyze, including column labels. 

Next you need to decide if you want to display the 

PivotTable in a new worksheet or one that already 

exists in your workbook. 

4. Select where you want the PivotTable report to be 

placed. 

You can choose a new or existing worksheet. 

 Tip: If you select Existing Worksheet, click the 

Collapse Dialog button and select the worksheet 

and upper-left cell of the range where you want to 

put the PivotTable. 

5. Click OK. 

The Excel window changes to display the structure 

for a new PivotTable, along with the PivotTable Field 

List task pane. No data has been pulled into the 

PivotTable yet—you’ll need to use the task pane to 

tell Excel how you want to lay out the PivotTable. 

 Tips 

 You can change how the PivotTable Field List task 

pane looks. Click the button arrow near the top right 

corner of the task pane and select a layout option. 

 Exercise 

• Exercise File: TripSales10-1.xlsx 

• Exercise: Create a PivotTable on a new worksheet using 

the data from the Promotion Sales worksheet. 

Figure 10-1: The Create PivotTable dialog box. 

Figure 10-2: Creating a new PivotTable. 

Working with PivotTables 

PivotTable Field 
List task pane 
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Specifying PivotTable Data 

Once you’ve created your PivotTable, you have to specify 

the data you want to analyze. You’ll simply select the 

fields you want to display in the PivotTable Field List, 

then adjust the layout by dragging them between the 

desired report areas at the bottom of the task pane. You’re 

not going to understand how to do this unless you try it—

so let’s get started! 

Add fields 

1. Click the check boxes next to the fields you want to 

use as data in the PivotTable. 

By default, nonnumeric fields are added to the Row 

Labels area, numeric fields are added to the Values 

area, and OLAP date and time hierarchies are added 

to the Column Labels area. However, the fields can 

be rearranged to other areas. 

 Other Ways to Add Fields: 
Right-click a field name and select the layout area 

to which you want to add the field. Or, click and 

drag a field name into a layout section. 

 Rearrange fields 

1. Click and drag fields between the areas in the task 

pane to reposition the PivotTable layout. 

The data and layout of the PivotTable change 

accordingly. 

 Tips 

 Drag a field between the Row Labels and Column 

Labels boxes to change the orientation of the 

PivotTable. 

 You can change PivotTable labels by typing a new 

label. 

 Exercise 

• Exercise File: TripSales10-2.xlsx 

• Exercise: Add the Office, Destination, and Tickets fields 

to the PivotTable.  

 Move the Office field to the Column Labels area.  

 Switch the positions of the Office and Destination fields. 

Figure 10-3: A PivotTable 

with data. 

1 The report filter area.  

Move a field to this area, then select the criteria by which 

you want to filter the PivotTable. 

2 The Column Label area. 

3 The Row Label area. 

4 The Results area.  

The results include data that from the fields in the column 

and row areas. Results are also filtered from the report 

filter area. 

Figure 10-4: This diagram illustrates how areas in the PivotTable Field List correspond to areas in the PivotTable report. 

Working with PivotTables 

The field section is where 
fields are added and 
removed in the PivotTable. 

The layout section is 
where fields are 
rearranged in the 
PivotTable. 
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Changing a PivotTable’s 
Calculation 

Besides adjusting the layout of your PivotTable data, you 

can also change how a PivotTable summarizes values. For 

example, you might want a PivotTable to display averages 

instead of totals. 

1. Make sure the cell pointer is located in the 

PivotTable.  

To change the calculation in a PivotTable, you need 

to change the value field settings. 

2. Under PivotTable Tools on the Ribbon, click the 

Options tab and click the Field Settings button in the 

Active Field group. 

The Value Field Settings dialog box appears, 

displaying the “Summarize by” tab. Here you can 

select calculation options including Sum, Count, 

Average, or Max, among others. 

3. Select the type of calculation you want to use to 

summarize the value data from the list. 

4. Click OK. 

The summarized value data in the PivotTable changes 

to using the new calculation. 

 Exercise 

• Exercise File: TripSales10-3.xlsx 

• Exercise: Change the calculation of the Tickets field from 

Sum to Max. 

 Change it back to Sum. 

Figure 10-5: The Value Field Settings dialog box. 

Working with PivotTables 
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Filtering and Sorting a 
PivotTable 

Much like you can with basic data ranges and tables in 

Excel, you can filter and sort data in a PivotTable. 

Filter a PivotTable 

1. Select a cell in the PivotTable. 

The Options and Design tabs appear under 

PivotTable Tools on the Ribbon. 

2. Click the filter button for a row or column label. 

A list sorting and filtering options appears. The 

bottom area of the list displays criteria by which you 

can filter. 

 Other Ways to Select Filter Criteria: 
Click the Search box in the filter list and type the 

criteria by which you want to filter. The list 

displays criteria that match your search. 

3. At the bottom of the list, click the check boxes next 

to the fields you want to filter out to uncheck them.  

Fields with checkmarks next to them will remain, 

while those without checkmarks will be filtered out. 

4. Click OK. 

The PivotTable is updated. 

  Other Ways to Filter a PivotTable: 
Drag a field into the Report Filter area of the 

PivotTable Field List task pane. Click the field’s 

filter button above the PivotTable and select what 

you want to filter by. Or, click a filter button, 

point to Label Filters or Values Filters, and 

select a filtering option. 

Sort a PivotTable 

1. Select a cell in the PivotTable. 

The Options and Design tabs appear under 

PivotTable Tools on the Ribbon. 

2. Click a filter button. 

Here you’ll see sort options at the top of the list, 

along with the filter options toward the bottom. 

3. Select a sort option. 

 Other Ways to Sort: 
Click the Options tab on the Ribbon. Click the 

button you want to use in the Sort group. 

 Exercise 

• Exercise File: TripSales10-4.xlsx 

• Exercise: Use the Row Labels filter button to display only 

records from Blaine. Clear the filter.  

 Try another way to filter: Add the Commission field to the 

Report Filter area of the PivotTable Field List and filter the 

PivotTable so only commissioned sales appear. Clear the 

filter.  

 Sort the PivotTable by Office (Row Labels) from Z to A, 

then sort again from A to Z. 

Figure 10-6: The PivotTable filtered to display only 

“Blaine” records. 

Figure 10-7: Adding a field to the Report Filter area. 

Working with PivotTables 

The filter button changes to make you aware 
that a filter has been applied. 

Drag fields 
you want to 
filter for to 
this area. 

Click the list arrow to choose 
how you want to filter the 
PivotTable. 
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Working with PivotTable 
Layout 

There are several options for altering the layout of your 

PivotTable and the PivotTable Field List task pane. 

Adjust PivotTable Field List layout 

You can change the layout of the PivotTable Field List 

makes it easier to work with. For example, you can 

display only the fields section if you have a long list of 

fields to choose from. Or, if you are done setting up the 

PivotTable, you can display only the area section.  

1. Select a cell in the PivotTable.  

The PivotTable Field List task pane appears.  

2. Click the layout button at the top of the PivotTable 

Field List task pane and select a layout option.  

You can choose to display only the fields section, 

only the report areas section, or both sections in 

different arrangements. The table below and to the 

right, PivotTable Field List Layout Options, is has 

more information about these arrangements. 

Show/Hide PivotTable elements 

You can change which elements are displayed in the 

PivotTable.  

1. Select a cell in the PivotTable.  

The Options and Design tabs appear under 

PivotTable Tools on the Ribbon. 

2. Under PivotTable Tools on the Ribbon, click the 

Options tab. 

The Show/Hide group contains three buttons. By 

default, they are all shown in the PivotTable. 

 Field List: Show or hide the PivotTable Field List 

task pane. 

 +/- Buttons: Show or hide the +/- buttons that 

allow you to expand or collapse multi-level 

PivotTable items. 

 Field Headers: Show or hide column and row 

field headers. 

3. Click the button you want to use in the Show/Hide 

group. 

If the button is an orange color, the element is 

displayed in the PivotTable. If the button is not 

orange, the element is hidden. 

 Exercise 

• Exercise File: TripSales10-5.xlsx 

• Exercise: Change the layout of the PivotTable Field List 

so the field and area sections are side-by-side. Then change 

them back to stacked.  

 In the Show/Hide group of the Options tab on the Ribbon, 

hide the Field List and Field Headers. Show both again.  

 In the Layout group of the Design tab on the Ribbon, turn 

off the row and column grand totals. Enable them again.  

 Change the report layout to Tabular Form. 

Figure 10-8: Changing PivotTable Field List layout. 

Table 10-1: PivotTable Field List Layout Options 

 
This is the default layout. The fields are stacked above 

the areas. 

 
The fields appear side by side with the areas. This is 

useful if there is a long list of fields to choose from. 

 
Only the fields list is displayed. This is ideal if you 

only need to work with adding fields to the PivotTable 

report. 

 

Only the areas are displayed (2 by 2). This is ideal if 

the fields you want have been added and you want to 

work with the report’s layout. 

 

Only the areas are displayed (1 by 4). This is ideal if 

the fields you want have been added and you want to 

work with the report’s layout. 

Working with PivotTables 

Layout button 
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Layout group on the Design tab 

The Layout group on the Design tab allows you to change 

what elements appear on the PivotTable. 

1. Select a cell in the PivotTable. 

The Options and Design tabs appear under 

PivotTable Tools on the Ribbon. 

2. Under PivotTable Tools on the Ribbon, click the 

Design tab. 

Here you can see the Layout group. It contains four 

buttons: 

 Subtotals: Click to show or hide subtotals, and to 

specify where to show them. 

 Grand Totals: Click to show or hide grand totals, 

and to specify whether they appear for rows, 

columns, or both. 

 Report Layout: Show the PivotTable in compact, 

outline, or tabular form. 

 Blank Rows: insert or remove a blank line 

between each grouped item in the PivotTable. 

3. Click the button you want to use in the Layout group. 

A list of options appears, depending on the button 

that was selected. 

4. Select an option from the list. 

The PivotTable layout is changed accordingly. 

Figure 10-9: The layout of the PivotTable in Tabular 

layout, and the Layout group on the Design tab. 

Working with PivotTables 
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Grouping PivotTable Items 

You can group PivotTable data in order to set it apart 

additional subsets of data. You can group most items, but 

dates are a common item to group. For example, you may 

want to group the information in the PivotTable by days, 

months, quarters, or years. 

Group dates or times 

1. Select the date or time field in the PivotTable.  

To select the field, click the name of the field in the 

PivotTable, such as the row or column header. 

2. Under PivotTable Tools on the Ribbon, click the 

Options tab and click the Group Field button in the 

Group group. 

The Grouping dialog box appears.  

3. Specify the starting and ending dates you want to 

group and the interval you want to group by. 

By default, the starting and ending dates are the first 

and last dates in the PivotTable. 

4. Click OK. 

The grouping is applied to the PivotTable report. 

 Tip: To group dates by weeks, select Days in the 

By area of the Grouping dialog box and enter 7 in 

the Number of days box. 

Group numeric items 

1. Select the numeric field in the PivotTable that 

contains the data you want to group by. 

2. Under PivotTable Tools on the Ribbon, click the 

Options tab and click the Group Field button in the 

Group group. 

The Grouping dialog box appears.  

3. Specify the starting and ending values you want to 

group and the interval you want to group by, then 

click OK. 

Group other selected items 

You can also group items that are not dates or numeric 

data, such as labels. 

1. Select the items in the PivotTable that you want to 

group. 

 Exercise 

• Exercise File: TripSales10-6.xlsx 

• Exercise: First, set up the PivotTable for grouping: 

Remove the Office field from the Row Labels area of the 

PivotTable Field List. Move the Destination field to the 

Row Labels area. Add the Date field to the Column Labels 

area.  

Select cell B3 and group the dates by month. Then ungroup 

the dates. 

Figure 10-10: Grouping the PivotTable dates by month. 

Working with PivotTables 

1. Select the field by which you want to group. This example 
happens to group by the Date field. 

2. Select the increment by which you want to group. This 
example will group the data so it is displayed by month, rather 
than by day. 

3. The data for each month is grouped together under one 
column, rather than being shown as separate days. 
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2. Under PivotTable Tools on the Ribbon, click the 

Options tab and click the Group Selection button in 

the Group group. 

The items are grouped and collapse buttons appear so 

you can collapse or expand the group of data. 

 Tip: You can also use this method to group 

specific items in a field. 

Ungroup items 

1. Select the items in the PivotTable that you want to 

ungroup. 

2. Under PivotTable Tools on the Ribbon, click the 

Options tab and click the Ungroup button in the 

Group group. 

The items are ungrouped. 

Working with PivotTables 
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Updating a PivotTable 

If you make changes to the source data a PivotTable is 

based on, the PivotTable isn’t automatically updated. 

Instead you must manually refresh the PivotTable anytime 

you change its underlying source data. This lesson 

explains how to do that, as well as how to change the 

source of the data the PivotTable is based on. 

Refresh PivotTable data 

If you’ve made changes to the data what your PivotTable 

pulls from, you need to refresh the PivotTable to update it. 

1. Select a cell in the PivotTable.  

The PivotTable Tools are displayed on the Ribbon. 

2. Under PivotTable Tools on the Ribbon, click the 

Options tab and click the Refresh button in the Data 

group. 

The PivotTable updates to include any changes to the 

source data. 

Change PivotTable data source 

You can easily change which data is used by the 

PivotTable. 

1. Select a cell in the PivotTable. 

The PivotTable Tools are displayed on the Ribbon 

2. Under PivotTable Tools on the Ribbon, click the 

Options tab and click the Change Data Source 

button in the Data group. 

The Change PivotTable Data Source dialog box 

appears, along with the current data source—which 

has a moving dotted line around it. 

3. Select a new data range. 

4. Click OK. 

The PivotTable updates with the data from the new 

source range. 

 Exercise 

• Exercise File: TripSales10-7.xlsx 

• Exercise: View the Promotion Sales worksheet and change 

the value in cell G2 to 5. Return to the PivotTable on Sheet2 

and refresh the PivotTable. The data updates in C23. 

 Change the PivotTable data source so that it uses only the 

range A1:G4 on the Promotion Sales worksheet. 

Figure 10-11: The Data group on the Options tab. 

Figure 10-12: The Change PivotTable Data Source dialog 
box. 

Working with PivotTables 

Refresh button 
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Formatting a PivotTable 

You can quickly format a PivotTable with Excel’s built-in 

styles and style options. 

Apply a built-in style 

1. Select a cell in the PivotTable. 

The PivotTable Tools are displayed on the Ribbon. 

  2. Click the Design tab and select a style in the 

PivotTable Styles group. 

The PivotTable is formatted with the style you 

selected. 

 Tip: Click the More button in the PivotTable 

Styles group to display an expanded PivotTable 

Styles gallery. 

Work with style options 

Besides applying a style to the table, you can select 

PivotTable style options that allow you to adjust the 

format for a part of a PivotTable. For example, you can 

apply special formatting to row headers or make the 

columns banded. 

1. Select a cell in the PivotTable. 

The PivotTable Tools are displayed on the Ribbon. 

2. Click the Design tab and select an option in the 

PivotTable Style Options group. 

Here is a brief description of the style options you 

can select from in the PivotTable Style Options 

group: 

 Row/Column Headers: Displays special 

formatting for the first row or column of the 

PivotTable. 

 Banded Rows/Columns: Applies different 

formatting to alternate rows or columns. 

 Tips 

 Besides using the formatting options on the Design 

tab, you can format a PivotTable using general 

formatting commands found on the Home tab. 

 Exercise 

• Exercise File: TripSales10-8.xlsx 

• Exercise: Apply Pivot Style Medium 24 from the 

PivotTable Styles gallery.  

 Select the Banded Rows style option and deselect the 

Column Headers option. 

Figure 10-13: Selecting a built-in PivotTable style from the 
PivotTable Styles group. 

Figure 10-14: The PivotTable report with the updated style 
and style options. 

Working with PivotTables 

PivotTable 
style options Built-in styles 
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Creating a PivotChart 

A PivotChart is similar to an ordinary chart created in 

Excel, except that it plots a PivotTable’s information. Like 

PivotTable reports, PivotCharts are dynamic, which 

means you can change a PivotChart’s structure. 

1. Select a cell in the PivotTable.  

The PivotTable Tools are displayed on the Ribbon. 

2. Under PivotTable Tools on the Ribbon, click the 

Options tab and click the PivotChart button in the 

Tools group. 

The Insert Chart dialog box appears, displaying 

different types of charts. 

3. Select the type of chart you want to use and click 

OK. 

The chart appears in the worksheet with your 

PivotTable.  

 Tip: Click and drag the PivotChart’s border to 

move the chart around in the worksheet. 

4. Modify the chart using the PivotChart Filter Pane and 

the PivotTable tools. 

 Tips 

 If you modify the PivotTable, the PivotChart will 

change also. 

  More detailed information about modifying and 

formatting charts can be found in the “Creating and 

Working with Charts” chapter. 

 Exercise 

• Exercise File: TripSales10-9.xlsx 

• Exercise: Insert a Clustered Column PivotChart. 

Figure 10-15: The Insert Chart dialog box. 

Figure 10-16: A clustered column 
PivotChart. 

Working with PivotTables 

Use the PivotChart 
Filter pane to 
change the 
information 
displayed in the 
chart. 

Click the row or column filter 
buttons to filter the data 
shown in the PivotChart. 
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Using Slicers 

Slicers are a new feature in Excel 2010 that has been 

added in order to provide an easy way to filter PivotTable 

data. Slicers label the filters applied, with details, so you 

can easily understand the data that is displayed and 

filtered in the PivotTable report. 

Create a PivotTable Slicer 

Here’s how to create a slicer in an existing PivotTable. 

1. Click the PivotTable report to select it. 

The PivotTable Tools contextual tabs appear on the 

Ribbon. 

2. Click the Options tab under PivotTable Tools on the 

Ribbon and click the Insert Slicer button in the Sort 

& Filter group. 

The Insert Slicers dialog box appears. All the fields in 

your PivotTable are listed here; you decide which 

fields you want to filter by in the PivotTable. 

3. Click the check box of the PivotTable fields by which 

you wish to filter. 

Keep in mind that you’ll get a separate slicer for each 

field you select. 

4. Click OK. 

The slicer(s) appear above the PivotTable. You can 

move a slicer to another location on the worksheet, 

and resize it as needed. 

 Exercise 

• Exercise File: Slicers1.xlsx; Sheet1 

• Exercise: View the number of tickets the St. Cloud office 

sold to Boston, New York, and Washington D.C. 

 (Insert slicers for the Destination and Office fields. Select 

the St. Cloud button in the Office slicer. Select the Boston, 

New York, and Washington, D.C. buttons in the Destination 

slicer.) 

Figure 10-17: The Insert Slicers dialog box. 

Figure 10-18: The 

PivotTable with two slicers 
applied. 

Working with PivotTables 

Click a check box 
to use a slicer for 
the selected field. 
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Filter data using a slicer 

After you create a slicer, it appears on the worksheet 

alongside the PivotTable, in a layered display if you have 

more than one slicer.  

1. Click a button in a slicer. Press and hold the <Ctrl> 

or <Shift> keys to select multiple buttons. 

The button is selected, and the PivotTable data is 

filtered accordingly. 

 Tip: Simply click the button again to stop 

filtering out the selected data. 

Format a slicer 

You can change the appearance of a slicer to match the 

color scheme of your PivotTable. 

1. Click the slicer you want to format. 

The Slicer Tools appear on the Ribbon. 

2. Click the Options tab under Slicer tools on the 

Ribbon and select the style you want in the Slicer 

Styles group. 

The style is applied to the slicer. 

 Tip: You can also click the More button in the 

Slicer Styles group to view more styles. 

Delete a slicer 

If you no longer want to filter PivotTable data, you can 

remove the slicer completely. 

1. Click the slicer and press <Delete>. 

The slicer no longer appears in the worksheet. 

 Other Ways to Delete a Slicer: 
Right-click the slicer, and then select Remove 

<Name of slicer> from the contextual menu. 

Figure 10-19: Anatomy of a slicer. 
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Sharing Slicers Between 
PivotTables 

If you’re working with a workbook that has several 

different PivotTables, it’s likely that you’ll want to apply 

the same filter to other PivotTables. This lesson shows 

you how to share slicers between PivotTables in a 

workbook. 

Apply a slicer to another PivotTable 

If you want to use a slicer in another PivotTable, you have 

to make the slicer available to that PivotTable. 

1. Click the slicer that you want to share in another 

PivotTable. 

The Slicer Tools appear on the Ribbon. 

2. Click the Options tab under Slicer Tools on the 

Ribbon and click the PivotTable Connections 

button. 

The PivotTable Connections dialog box appears. 

Other PivotTables you can share the slicer with are 

listed.  

3. Click the check boxes of the PivotTables in which 

you want the slicer to be available.  

4. Click OK. 

The slicer is now applied to the selected 

PivotTable(s). 

 

 Exercise 

• Exercise File:  Slicers2.xlsx, Sheet2 

• Exercise: Apply the Destination slicer from PivotTable 1 

to PivotTable 2. 

Figure 10-20: The PivotTable connections dialog box. 
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WWoorrkkiinngg  wwiitthh  PPiivvoottTTaabblleess  RReevviieeww  

Quiz Questions 

96. You can create a PivotTable in its own new worksheet or in one that already exists in your workbook. (True or False?) 

97. Specify the data you want to use in the PivotTable in the ___________ task pane. 
A. Select Fields 
B. Specify Fields 
C. PivotTable Field List 
D. PivotTable Layout 

98. Which of the following is NOT a calculation available in the Value Field Settings dialog box? 
A. Count 
B. Average 
C. StdDev 
D. These are all available 

99. You can filter a PivotTable by dragging a field into the _______ box in the PivotTable Field List. 
A. AutoFilter 
B. Report Filter 
C. Pivot Filter 
D. Data Filter 

100. Which of the following is NOT a button found in the Layout group on the Design tab? 
A. Header Row 
B. Grand Totals 
C. Report Layout 
D. Blank Rows 

101. You can group any type of PivotTable item except for dates. (True or False?) 

102. When you make changes to your PivotTable's source data, the PivotTable refreshes automatically to include the edits. 

(True or False?) 

103. Which of the following is NOT an option in the PivotTable Style Options group? 
A. Banded Columns 
B. Banded Rows 
C. Bold Headers 
D. Row Headers 

104. When you modify a PivotTable, the PivotChart is updated along with it. (True or False?) 

105. A slicer is a visual way to filter PivotTable content. (True or False?) 
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106. PivotTables can only be applied to a single PivotTable at a time. (True or False?) 

 

Quiz Answers 

96. True. You can create a PivotTable in either a new or existing worksheet 

97. C. Specify the data you want to use in the PivotTable in the PivotTable Field List task pane. 

98. D. All are available. 

99. B. You can filter a PivotTable by dragging a field into the Report Filter box in the PivotTable Field List. 

100. A. Header Row is not a button found in the Layout group on the Design tab. 

101. False. Dates are commonly grouped in PivotTables. 

102. False. You must manually refresh the PivotTable to include changes made to your source data. 

103. C. Bold Headers is not an option in the PivotTable Style Options group. 

104. True. When you modify a PivotTable, the PivotChart is updated along with it. 

105. True. Slicers provide a visual way to filter PivotTables. 

106. False. PivotTables can applied to other PivotTables in a workbook. 
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Most people don’t realize that Excel has 

numerous tools for analysis and 

organization, so they perform Excel tasks 

the manual way. 

This method can help you get by in 

simple situations, but isn’t very effective 

when you need to perform more complex 

what-if analysis or organize large lists of 

data.  

In this chapter, you will learn about 

Excel’s tools for analyzing and 

organizing. These include tools for 

creating multiple worksheet scenarios, 

using Goal Seek and Solver tools to 

perform what-if analysis, and organizing 

your data by subtotaling, outlining, or 

consolidating.  

Using Exercise Files 
This chapter suggests exercises to practice 

the topic of each lesson. There are two 

ways you may follow along with the 

exercise files: 

 Open the exercise file for a lesson, 

perform the lesson exercise, and close 

the exercise file. 

 Open the exercise file for a lesson, 

perform the lesson exercise, and keep 

the file open to perform the remaining 

lesson exercises for the chapter. (This 

chapter does not use the same exercise 

file for the duration of the chapter.) 

The exercises are written so that you may 

“build upon them”, meaning the exercises 

in a chapter can be performed in 

succession from the first lesson to the last. 

 

11 
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Creating Scenarios 

If you’ve ever used a worksheet to answer the question 

“What if?” you’ve already performed what-if analysis. 

For example, what would happen if your advertising 

budget increased by 40 percent? How about 50 percent? 

Excel has several tools for performing What-If Analysis, 

including Goal Seek, Data Tables, and Solver. In this 

lesson, you will learn how to create multiple what-if 

scenarios using Excel’s Scenario Manager. 

Create scenarios 

A scenario is a set of input values that you can substitute 

in a worksheet to perform what-if analysis. For example, 

you could create scenarios to show various interest rates, 

loan amounts, and terms for a mortgage. Excel’s scenario 

manager lets you create and store different scenarios in 

the same worksheet. 

1. Create or open a worksheet that contains one or more 

formulas. 

2. Click the Data tab on the Ribbon, click the What-If 

Analysis button in the Data Tools group, and select 

Scenario Manager from the list. 

The Scenario Manager dialog box appears with the 

message “No Scenarios defined. Choose Add to add 

scenarios.” You want to add a new scenario. 

3. Click the Add button. 

The Add Scenario dialog box appears.  

4. Type a name for the scenario and press <Tab>.  

The cursor moves to the Changing cells box. Here 

you need to select the cells that contain the values 

you want to change. 

 Tip: To select multiple nonadjacent cells, hold 

down the <Ctrl> key as you click them. 

5. Select the cells in the worksheet that contain the 

values you want to change, then click OK. 

The Scenario Values dialog box appears. Here you 

need to enter desired values for the changing cells.  

 Tip: To make sure you don’t lose the original 

values for the changing cells, use the original cell 

values in the first scenario you create. 

 Exercise 

• Exercise File: LoanPayment11-1.xlsx 

• Exercise: Add a scenario called Original that uses the 

original values in cell range A4:C4. 

 Next, add a scenario called 30 Year Loan and change the 

term of the loan to 30.  

 Show the 30 Year Loan scenario in the worksheet. 

Figure 11-1: The Add Scenario dialog box. 

Figure 11-2: The Scenario Values dialog box. 

Analyzing Data 
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6. Enter values in each of the boxes. Click OK, or click 

Add to add another scenario. 

The scenario is added. If you clicked OK, the 

scenario is listed in the Scenario Manager. If you 

clicked Add, the Add Scenario dialog box appears so 

you can add another scenario. 

7. Repeat steps 4 – 6 to add a new scenario. Click OK. 

The Scenario Manager dialog box lists each scenario 

that you created. 

8. Click the Close button. 

The Scenario Manager closes. 

 Tips 

 To edit a scenario, select the scenario in the Scenario 

Manager dialog box and click the Edit button. 

Display a scenario 

Once you have created scenarios in a worksheet, you can 

display the worksheet using the values from those 

scenarios. 

1. Click the Data tab on the Ribbon, click the What-If 

Analysis button in the Data Tools group, and select 

Scenario Manager from the menu. 

The Scenario Manager dialog box appears. 

2. Select the scenario that you want to display and click 

the Show button. 

The worksheet’s values are changed to the values you 

specified in the scenario. 

Figure 11-3: The Scenario Manager dialog box. 

Analyzing Data 
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Creating a Scenario Report 

A scenario summary report is a single compiled report 

that summarizes the results from several scenarios. It’s 

easier to read than switching between different scenarios. 

Create cell names 

The first step in creating a scenario summary report is to 

create names for the cells that change. 

1. Select the cells involved in the scenario and the labels 

you want to use to name them. 

2. Click the Formulas tab on the Ribbon and click the 

Create from Selection button in the Defined Names 

group. 

The Create Names from Selection dialog box 

appears. 

3. Select the option that describes where the labels are 

located in the selected cell range.  

The labels that are in the selected cell range will be 

used as names. 

4. Click OK. 

The cells are named using the labels. 

Create a Scenario Summary report 

Once you’ve created at least two scenarios and have 

named cells, you can create a summary report. 

1. Click the Data tab on the Ribbon, click the What-If 

Analysis button in the Data Tools group, and select 

Scenario Manager from the menu. 

The Scenario Manager dialog box appears. 

2. Click the Summary button. 

The Scenario Summary dialog box appears. 

3. Make sure the Scenario summary option is selected.  

Next you need to specify the result cells. These are 

the cells that are affected by the changing cells. 

 Tip: Alternatively, select the “Scenario PivotTable 

report” option to create a report that gives you an 

instant what-if analysis of your scenarios. 

4. Select the result cell range and click OK. 

A new Scenario Summary worksheet is added to the 

workbook that contains the summary report. 

 Exercise 

• Exercise File: LoanPayment11-2.xlsx 

• Exercise: Select the cell range A3:F4 and name the cells 

from the selection. 

 Create a scenario summary report (the result cell range is 

D4:F4). 

Figure 11-4: The Create Names from Selection dialog 
box. 

Figure 11-5: A Scenario Summary report. 

Analyzing Data 
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Working with Data Tables 

Another way to get answers to your what-if questions is 

by using a data table. A data table is a cell range that 

displays the results of a formula using different values.  

For example, you could create a data table to calculate 

loan payments for several interest rates and term lengths.  

There are two types of data tables:  

 One-input Data Table: Displays the results of a 

formula for multiple values of a single input cell. For 

example, if you have a formula that calculates a loan 

payment you could create a one-input data table that 

shows payment amounts for different interest rates. 

 Two-input Data Table: Displays the results of a 

formula for multiple values of two input cells. For 

example, if you have a formula that calculates a loan 

payment you could create a two-input data table that 

shows payment amounts for different interest rates 

and different term lengths. 

Create a one-input data table 

1. Set up the table area. Make sure you include the 

formula in the top row and the input values in the left 

column.  

Make sure the formula refers to the input cell. 

2. Select the table range that contains the formula and 

substitution values. 

This should include blank cells below the formula 

and to the right of the values—this is where the data 

table will go. 

3. Click the Data tab on the Ribbon, click the What-If 

Analysis button in the Data Tools group, and select 

Data Table. 

The Data Table dialog box appears. 

4. Type the cell reference for the input cell in the 

Column input cell box and click OK. 

Excel displays the results of the formula using each 

of the substituted values. 

 Tip: If you set up your table with the data in a 

row instead of a column, you would enter the cell 

reference for the input cell in the Row input cell 

box instead. 

 Exercise 

• Exercise File: LoanPayment11-3.xlsx 

• Exercise: Create a one-input data table:  

Enter =PMT(C4/12,B4*12,A4) in cell B7.  

Enter 6.0, 6.5, 7.0, 7.5, 8.0 in cells A8:A12.  

Select the cell range A7:B12 and create a data table. In the 

Data Table dialog box, enter C4 in the Column input cell 

box and click OK. 

 Delete the contents of B8:B12 to prepare for the two-input 

table. 

 Create a two-input data table: Move the formula in cell 

B7 to cell A7.  

Enter 5, 10, 15, 20 in cells B7:E7. Select the cell range 

A7:E12.  

Create a data table and enter B4 as the row input cell and C4 

as the column input cell.  

 Delete the contents of A7:E12. 

Figure 11-6: The Data Table dialog box and the resulting 

one-input data table showing different monthly payments 
at different interest rates. 
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Create a two-input data table 

1. Set up the table area. Make sure you include the 

formula in the upper-left cell and the values for the 

first input cell in the left column and the values for 

the second input cell in the top row. 

Make sure the formula refers to the two input cells. 

2. Select the table range that contains the formula and 

substitution values (both the row and column values). 

This should include blank cells below the formula 

and to the right of the values—this is where the data 

table will go. 

3. Click the Data tab on the Ribbon, click the What-If 

Analysis button in the Data Tools group, and select 

Data Table. 

The Data Table dialog box appears. Since this is a 

two-input table, two input cells need to be entered. 

4. Enter the cells you want to use for the Row input cell 

and the Column input cell and click OK. 

Excel displays the results of the formula with all the 

substituted values. 

Figure 11-7: The Data Table dialog box and the resulting 

two-input data table showing different monthly payments at 
different interest rates and different terms. 
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Using Goal Seek 

When you know the desired result of a single formula, but 

not the value the formula needs for the result, you can use 

the Goal Seek feature. For example, you can afford a 

$1,200 monthly payment, so how much of a loan can you 

take out? When goal seeking, Excel plugs different values 

into a cell until it finds one that works. 

1. Open or create a workbook that contains the formulas 

you want to work with. 

2. Click the Data tab on the Ribbon, click the What-If 

Analysis button in the Data Tools group, and select 

Goal Seek. 

The Goal Seek dialog box appears. 

3. Click the Set cell box, and click the cell in the 

worksheet that contains the formula you want to use. 

4. Click the To value box and enter the value you want 

to change it to.  

5. Click the By changing cell box, and click the cell 

you want to change to achieve the formula result. 

This cell must be a cell that is referenced by the 

formula. 

6. Click OK. 

Excel calculates and displays the value needed to 

achieve the formula result you desire.  

7. Click OK to replace the original values or click 

Cancel to keep the original values. 

 Exercise 

• Exercise File: LoanPayment11-4.xlsx 

• Exercise: Use Goal Seek to determine the maximum loan 

amount you could afford with a $1200 monthly payment. 

Figure 11-8: Using Goal Seek to determine the maximum 

loan amount with a $1200 monthly payment. 
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Using Solver 

Excel’s Solver tool can perform advanced what-if analysis 

on problems with many variable cells. You can also 

specify constraints, or conditions that must be met to 

solve the problem. 

Solver has been improved in Excel 2010 to include a new 

user interface, and better functionality. 

Install the Solver add-in 

Solver is an optional Excel add-in. You need to install it 

before you can use it. 

1. Click the File tab on the Ribbon and select Options 

from the menu. 

The Excel Options dialog box appears. 

2. Click the Add-Ins tab. 

By default, Excel Add-ins are displayed. The top of 

the list displays add-ins that are active, the bottom 

displays add-ins that are available, but are not 

currently active. 

3. Click the Go button. 

The Add-Ins dialog box appears, displaying a list of 

the add-ins available for Excel. 

4. Click the Solver Add-in check box to select it and 

click OK. 

A dialog box appears, asking to confirm that you 

want to install the add-in. 

5. Click Yes. 

Microsoft Office reconfigures so that Solver is 

installed in Excel. The Solver command will now be 

available in the Analysis group on the Data tab on the 

Ribbon. 

 Tip: You may need to restart Excel so that Solver 

installs properly. 

Use Solver 

1. Open or create a workbook that contains the problem 

you want to solve.  

A problem should consist of a formula that you want 

Excel to solve by changing the values of its inputs 

until it arrives at the desired result. 

 Exercise 

• Exercise File: Mailings11-5.xlsx 

• Exercise: Imagine you're in charge of a mailing campaign 

for five states. You have been given the following budget 

constraints: your total budget is $35,000, you must spend at 

least 50% of the budget on Minnesota mailings, and at least 

three mailings must go out in each state.  

 Based on this information, and the fact that the number of 

mailings must be a whole number, use Solver to calculate 

the maximum number of mailings you can send out to each 

state. 

Figure 11-9: The Add-Ins tab of the Excel Options dialog 
box. 

Figure 11-10: The Add-Ins dialog box. 

Analyzing Data 
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2. Click the Data tab on the Ribbon and click the 

Solver button in the Analysis group. 

The Solver Parameters dialog box appears. First you 

need to tell Excel the target cell. This is the cell that 

contains the formula you want to solve. 

3. Select the target cell in the worksheet. 

The cell reference for the target cell appears in the 

Set Target Cell box. 

4. Select a To option. If you select the Value of option, 

enter a value. 

Choose from Max, Min, or Value Of, depending on 

what value you want Solver to calculate. For 

example, if you select Max, Solver will change the 

specified cells to make the target cell as large as 

possible. 

Next, you need to specify the cells that Solver can 

change to meet your target cell goal. 

5. Click the Collapse Dialog button in the By Changing 

Cells box and select the cells that need to change to 

reach your goal. 

 Tip: Press and hold the <Ctrl> key to select 

multiple nonadjacent cells. 

Finally, add any constraints on the problem. For 

example, you could specify that one of the formula’s 

input cells can’t be greater than a certain value. 

6. Click the Add button in the Subject to the Constraints 

section. 

The Add Constraint dialog box appears.  

7. Enter a cell reference, select an operator, then enter 

the constraint value you want to apply to the cell.  

8. Click Add to add another constraint, or OK to 

continue.  

You return to the Solver Parameters dialog box. 

9. Click the Solve button. 

The Solver Results dialog box appears, letting you 

know whether or not Solver found a solution.  

10. Select Keep Solver Solution or Restore Original 

Values and click OK. 

Figure 11-11: The Solver Parameters dialog box. 

Figure 11-12: The Solver Results dialog box. 

Figure 11-13: The solution calculated by Solver. 
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  University of Virginia Health System 219 

Using Text to Columns 

The Convert Text to Columns feature in Excel allows you 

to split the contents of a cell into different columns. For 

example, you could split a person’s first and last name 

into separate columns. 

 You can split data into columns using two different 

methods: 

 Delimited: The data will be separated based on the 

location of commas or tabs within the data.  

 Fixed Width: You specify a fixed column break 

location. 

Let’s take a look at both methods. 

 Tips 

 Before using the text to columns feature, make sure 

there are enough blank columns next to your data so 

that the split data will have somewhere to go without 

copying over the rest of your data. 

 Split data using a delimiter 

If the data has delimiters such as commas or tabs, you can 

use them to split the data.  

1. Select the cell range you want to convert. 

2. Click the Data tab on the Ribbon and click the Text 

to Columns button in the Data Tools group. 

The Convert Text to Columns Wizard dialog box 

appears. 

3. Select the Delimited option and click Next. 

Here you need to select the types of delimiters you 

want to use to separate your data. Tabs, semicolons, 

commas, and spaces are all common delimiters.  

 Your selection will depend on the types of delimiters 

you have present in your data. For example, if you 

want to split first and last names using the space 

between the names, you’d select the Space option. 

4. Click the check box next to each delimiter you want 

to select in the Delimiters area. 

A preview appears, showing you how the data will be 

split into different columns based on your selection. 

5. Click Next. 

Next you can select a format for each column of data. 

 Exercise 

• Exercise File: MonthlySales11-7.xlsx 

• Exercise: Select cell A7 and split Denise Winters’ first and 

last names into two cells using the space between the words 

as the delimiter. 

Figure 11-14: Before splitting text. 

Figure 11-15: Step 2 of the Convert Text to Columns 
Wizard dialog box. 

Figure 11-16: After splitting text. 

Analyzing Data 
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6. Select a column in the Data preview area and then 

select a format option for that column in the Column 

data format area. Repeat for additional columns. 

 Tip: If you don’t want the new columns to replace 

the original data, click the Destination Collapse 

Dialog button and select the range where you 

want to put the split data. 

7. Click Finish. 

 Tip: A message may appear, asking if you want to 

replace the contents of the destination cells. If so, 

click OK. 

The data is split into different columns. 

Split data using a fixed column break 

You can also decide for yourself where you want to split 

the data using a fixed column break. 

1. Select the cell range you want to convert. 

2. Click the Data tab on the Ribbon and click the Text 

to Columns button in the Data Tools group. 

The Convert Text to Columns Wizard dialog box 

appears. 

3. Select the Fixed width option and click Next. 

Here you can manually add break lines to separate 

your data into different columns. 

4. Click in the Data preview area where you want to 

place a break line. 

A line appears, showing you where the data will be 

separated. 

5. Add additional break lines as desired, then click 

Next. 

Next you can select a format for each column of data. 

6. Select a column in the Data preview area and then 

select a format option for that column in the Column 

data format area. Repeat for additional columns. 

7. Click Finish. 

 Tip: A message may appear, asking if you want to 

replace the contents of the destination cells. If so, 

click OK. 

The data is split into different columns. 

Analyzing Data 
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Grouping and Outlining Data 

Many spreadsheets are created in a hierarchical style. For 

example, a worksheet might contain a column for each 

month, followed by a total column. By outlining your 

worksheets, you make them easier to understand and read. 

Instead of sifting through irrelevant information, you can 

collapse an outline to display each group’s bottom line. 

There are several ways to outline a workbook: 

 Using the Auto Outline Feature: The Auto Outline 

command automatically outlines a selected range of 

cells or the entire worksheet, based on formulas and 

the direction of references. 

 Grouping Data: You can group rows and columns 

manually by selecting them. 

   Using the Subtotals Feature: The Subtotals 

command calculates subtotal values for the labeled 

columns you select. Excel automatically inserts and 

labels the total rows and outlines the list. 

 Using the Consolidate Feature: You can consolidate 

several sheets using the Consolidate feature.  

This lesson explains how to use the Auto Outline feature 

and how to group data manually. 

 Group rows or columns manually 

1. Select the column or row data you want to group. 

2. Click the Data tab on the Ribbon and click the 

Group button in the Outline group. 

The Group dialog box appears. Here you need to 

select whether you want to group rows or columns. 

3. Select the Rows or Columns option and click OK. 

The selected rows or columns are grouped together. 

Hide or show detail 

Once you’ve grouped or outlined data, you can collapse 

or expand the group detail. 

1. Click the Data tab on the Ribbon and click the Hide 

Detail or Show Detail button in the Outline group. 

 Other Ways to Hide or Show Detail: 
Click the outline symbols next to or above the 

worksheet. These include the Row Level and 

Column Level buttons and the plus and minus 

button. 

 Exercise 

• Exercise File: MonthlySales11-8.xlsx 

• Exercise: Manually group rows 3 through 6 and practice 

hiding and displaying details. 

 Then remove the grouping.  

 Use the Auto Outline feature (Excel should outline columns 

E to G). Clear the outline. 

Figure 11-17: An example of grouped rows. 
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Ungroup rows or columns 

1. Select the grouped row or column data. 

2. Click the Data tab on the Ribbon and click the 

Ungroup button in the Outline group. 

Outline data automatically 

If your data contains detailed rows or columns that are 

summed or subtotaled, Excel can automatically group the 

data into outline form. 

 Tips 

  Excel will only outline numerical data that is related 

by a sum or subtotal formula. It cannot outline text 

data or numerical data that is not totaled by a 

formula. 

1. Make sure your data has column labels and contains 

formulas that summarize the data. 

The sum and subtotal functions are commonly used 

to summarize rows or columns. 

 Tip: Summary rows and columns should be 

below and to the right of the data, respectively. If 

they are above or to the left, click the Outline 

Dialog Box Launcher in the Outline group. 

Remove the checkmark from the Summary rows 

below detail or Summary columns to right of 

detail check box. 

2. Select a cell in the data range you want to outline. 

3. Click the Data tab on the Ribbon, click the Group 

button list arrow in the Outline group, and select 

Auto Outline. 

The data is automatically outlined so that you can 

collapse the detailed rows or columns and view only 

the totals or subtotals. 

Remove an outline 

1. Click the Data tab on the Ribbon, click the Ungroup 

button list arrow in the Outline group, and select 

Clear Outline. 

The outline is cleared from the worksheet. 

Figure 11-18: An example of spreadsheet after using the 
Auto Outline command. 

Figure 11-19: The Settings dialog box. 

Analyzing Data 

Columns E:G are grouped because they 
contain related data. Column G is a summary 
column of data contained in columns E and F. 
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Using Subtotals 

A quick and easy way to group and summarize data is to 

use Excel’s Subtotals feature. Usually you create subtotals 

with the SUM function, but you can also create subtotals 

using functions such as COUNT, AVERAGE, MAX, and 

MIN. The Subtotals feature also outlines the data, 

allowing you to display and hide the detail rows for each 

subtotal. 

Create subtotals 

1. Make sure your data is arranged into labeled 

columns, that the data in each column is of the same 

type, and that you’ve sorted the data based on the 

column you want to group the subtotals by. 

Now you’re ready to subtotal your data.  

 Tip: Excel’s Subtotals feature subtotals your data 

by automatically inserting the SUBTOTAL 

function. 

2. Select a cell in the data range. 

3. Click the Data tab on the Ribbon and click the 

Subtotal button in the Outline group. 

The Subtotal dialog box appears. 

4. Click the At each change in list arrow and select the 

column you want to subtotal. 

This command specifies what it is that you want to 

subtotal. For example, if you have a list of customers, 

the products they bought, and the amounts of the 

sales, and you want to subtotal the list by the type of 

product, you would select the column that contains 

the products. 

5. Click the Use function list arrow and select the 

function you want to use to calculate the subtotals. 

For example, you could select Sum, Count, Average, 

or Max. 

6. In the “Add subtotal to” box, click the check box next 

to each column that has values you want to subtotal. 

7. Click OK. 

The data is organized with subtotals. 

 Tips 

 To hide or show subtotals detail, click the Hide 

Detail and Show Detail buttons in the Outline group 

on the Ribbon or use the outline symbols next to the 

worksheet to hide or display individual subtotals. 

 Exercise 

• Exercise File: MonthlySales11-9.xlsx 

• Exercise: Subtotal the data at each change in Position 

using the SUM function and subtotal the Sales and 

Commission columns.  

 Click the 2 Column Level Symbol button to hide details, 

then click the 3 Column Level Symbol button to display 

them again.  

 Remove the subtotals. 

Figure 11-20: The Subtotal dialog box. 

Analyzing Data 
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 To add more subtotals, repeat the steps but uncheck 

the Replace current subtotals check box so you 

don’t overwrite the existing subtotals. 

Remove subtotals 

1. Click the Data tab on the Ribbon and click the 

Subtotal button in the Outline group.  

The Subtotal dialog box appears. 

2. Click the Remove All button.  

 The subtotals are removed. 

 

Figure 11-21: Subtotals of sales and commissions calculated at each change in position. In other words, the 
subtotal of each position appears in the list, with the grand total appearing at the bottom. 

Analyzing Data 
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Consolidating Data by 
Position or Category 

Excel can automatically summarize or consolidate 

information from multiple worksheets into a single master 

worksheet using the Consolidate feature. For example, if 

you have sales data from three different offices on three 

different worksheets, Excel can total them for you on 

another worksheet. 

Excel can consolidate information in three different ways: 

by position, by category, or by using formulas. This 

lesson describes the first two ways: 

 Consolidate by position: Used when data in all the 

worksheets is arranged in exactly the same order and 

location.  

 Consolidate by category: Used when the worksheets 

have the same row and column labels, but the rows 

and columns aren’t arranged in the same order on all 

the worksheets. Excel uses the labels to match the 

data. 

 Tips 

 Make sure the label spelling and capitalization are 

identical on each of the worksheets you want to 

consolidate by category.  

Consolidate by position or category 

Before you begin consolidating by position or category, 

make sure the data is arranged in labeled rows and 

columns without blank rows or columns. Each of the 

ranges you want to consolidate needs to be on a separate 

worksheet, with a blank worksheet for the consolidation’s 

destination. 

When consolidating, you don’t actually specify whether 

you are consolidating by position or category—Excel 

knows how to consolidate based on the data range you 

select and whether or not the consolidating worksheets are 

arranged identically.  

1. On the worksheet where you want to put the 

consolidated data, click the upper-left cell in the area 

where you want to put the consolidated data.  

2. Click the Data tab on the Ribbon and click the 

Consolidate button in the Data Tools group.  

The Consolidate dialog box appears.  

3. Click the Function list arrow and select the function 

you want to use to consolidate the data. 

Consolidation functions include Sum, Count or 

Average.  

 Exercise 

• Exercise File: MonthlySales11-10.xlsx 

• Exercise: Add a new worksheet to the workbook. 

Consolidate the data in E1:E6 (the Sales totals) from 

worksheets Jan, Feb, and Mar into the new worksheet. 

Copy the Sales label to the consolidated worksheet. 

Figure 11-22: Consolidating sales data from three 
different worksheets. 

Analyzing Data 

Jan sheet data Feb sheet data Mar sheet data 

Consolidated data 
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4. Click the Reference text box. Then click the first 

worksheet tab you want to consolidate and select the 

range you want to consolidate.  

 Tip: If source data is in a different workbook, 

click Browse to locate the file and click OK. 

5. Click the Add button.  

6. Repeat steps 4 and 5 to select the ranges on any other 

worksheets.  

 Tip: If you’re consolidating from multiple 

workbooks and you want the consolidation to 

update automatically whenever the source data 

changes, click the Create links to source data 

check box to select it.  

7. To copy labels to the consolidated worksheet, click 

the Top row and Left column options. 

This tells Excel where the labels are located in the 

source ranges. 

8. Once you’re ready to consolidate, click OK.  

The values from the selected ranges are combined on 

the consolidation worksheet using the function you 

selected. 

 Tips 

 If you choose to copy labels onto the consolidation 

worksheet, any labels that don’t appear in all of the 

source ranges will appear in separate rows or 

columns on the consolidation worksheet, along with 

their corresponding data cells. 

Figure 11-23: The Consolidate dialog box. 

Analyzing Data 

Select one of these options to use the 
label from the referenced data in the 
consolidated data. 
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Consolidating Data Using 
Formulas 

Consolidating with formulas is the most versatile and 

powerful way to consolidate data from multiple 

worksheets into a single worksheet because there is no 

prescribed format for the data that is consolidated.  

The cells you reference don’t need to be in the same 

position on each sheet, or even have the same labels, to be 

consolidated using this method. 

1. Copy any column or row labels you want to use from 

the source worksheets to the consolidation worksheet, 

then paste the labels where you want to see 

consolidated data. 

2. Enter a formula that references the source cells in 

each worksheet that you want to consolidate. 

For example, you could combine three different cells 

on three different worksheets by typing 

=SUM(Sheet2!A6,Sheet3!B7,Sheet4!D2). Or, to 

reference the same cell on different worksheets, you 

could enter =SUM(Sheet2:Sheet4!A6). 

 Tips 

 Instead of typing each cell reference, you can type 

the first part of the formula, for example =SUM(, and 

then click the cells you want to include. 

 Enter a comma between cell selections from different 

worksheets. 

  The consolidation will automatically update when the 

source cell ranges are changed.  

 Exercise 

• Exercise File: MonthlySales11-11.xlsx 

• Exercise: Find the total commissions paid to managers in 

the first quarter of the year. Copy the Commission label 

from the Jan worksheet to cell C1 of the Sheet2 worksheet.  

 In cell C2 on Sheet2, enter =SUM(  

Then select cells G3:G4 on the Jan sheet, type a comma, 

select  G3:G4 on the Feb tab, type a comma, and select  

G3:G4 on the Mar tab. Press Enter.  

 The total 19,650 appears in cell C2 on Sheet2. 

Figure 11-24: Consolidating data using a formula. 

Analyzing Data 
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Quiz Questions 

107. To make sure you don't lose the original values for the changing cells, you should use the original cell values in the 

first scenario you create. (True or False?) 

108. The result cells you specify in the Scenario Summary dialog box are ___________. 
A. the total row of your scenarios 
B. the data labels used in your scenarios 
C. the cells that you change in the scenarios 
D. the cells that are affected by the changing cells in the scenarios 

109. You can create either a one- or a two-input data table. (True or False?) 

110. Use Goal Seek when __________. 
A. you don't know the result of a formula, but you know the formula input values 
B. you know the desired result of a formula, but not the input value the formula needs to arrive at the result 
C. you want to quickly create scenarios 
D. you know the result of one formula, but not the result of another formula that references that formula 

111. Solver is an optional Excel Add-In feature. (True or False?) 

112. Which of the following is NOT a delimiter that Excel can use to split cell data? 
A. Space 
B. Semicolon 
C. Comma 
D. All of these are common delimiters 

113. You can group rows and columns manually by selecting them. (True or False?) 

114. You should sort data before you group and summarize its information using the Subtotals command. (True or False?) 

115. You can consolidate by _______ when the data in all the worksheets is arranged in exactly the same order and 

location. 
A. position 
B. category 
C. absolute reference 
D. column 

116. The cells you reference don't need to be in the same position on each sheet, or even have the same labels, to be 

consolidated using formulas. (True or False?) 
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Quiz Answers 

107. True. To make sure you don't lose the original values for the changing cells, you should use the original cell values in 

the first scenario you create. 

108. D. The result cells you specify in the Scenario Summary dialog box are the cells that are affected by the changing cells 

in the scenarios. 

109. True. You can create either a one- or a two-input data table 

110. B. Use Goal Seek when you know the desired result of a formula, but not the input value the formula needs to arrive at 

the result. 

111. True. Solver is an optional Excel Add-In feature. 

112. D. All of these are common delimiters that Excel can use to split cell data. 

113. True. You can group rows and columns manually by selecting them. 

114. True. Always sort data before using the Subtotals command. 

115. A. You can consolidate by position when the data in all the worksheets is arranged in exactly the same order and 

location. 

116. True. The cells you reference don't need to be in the same position on each sheet, or even have the same labels, to be 

consolidated using formulas. 
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Excel’s Internet features let you add 

hyperlinks to your workbooks to link 

them to another workbook, a file created 

in another program, or even a Web page. 

You can also connect to data sources 

through the Web, or to other databases. 

12 
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Inserting a Hyperlink 

In this lesson, you will learn how to use hyperlinks in 

Excel. A hyperlink is text or an image that points to a file, 

a specific location in a file, or a Web page on your 

computer, on a network, or on the Internet. Whenever you 

click on a hyperlink, you jump to the hyperlink’s 

destination (if it’s available). 

A hyperlink is usually indicated by colored and 

underlined text. On the Internet, hyperlinks are used all 

the time to move between different Web pages. 

1. Select the cell you want to use for the hyperlink and 

enter the text or image you want to hyperlink. 

2. Click the Insert tab on the Ribbon, and click the 

Hyperlink button in the Links group. 

 Other Ways to Insert a Hyperlink: 
Select the text and press <Ctrl> + <K>. Or, right-

click the cell and select Hyperlink from the 

contextual menu. 

The Insert Hyperlink dialog box appears. There are 

four different types of Hyperlink destinations you can 

create: 

 Existing File or Web Page: Creates a link that 

takes you to another Excel workbook or to a file 

created in another program, such as a Microsoft 

Word document, or to a Web page on the Internet. 

 Place in This Document: Takes you to a 

bookmark in the same document. 

 Create New Document: Creates a new Excel 

workbook and inserts hyperlinked text into your 

existing workbook that connects to the new one.  

 E-mail Address: Creates a clickable e-mail 

address. 

 3. Either browse to or enter the hyperlink’s destination 

and click OK. 

The hyperlink is created. Now whenever you click 

the hyperlink, Excel will take you to the hyperlink’s 

destination file or the location that you specified. 

 Tips 

 To edit an existing hyperlink, right-click the 

hyperlink and select Edit Hyperlink from the 

contextual menu. 

 To remove a hyperlink, right-click the hyperlink and 

select Remove Hyperlink from the contextual menu. 

 Exercise 

• Exercise File: TradeShow12-1.xlsx, Mileage.xlsx 

• Exercise: Open the TradeShow12-1.xlsx workbook. Type 

“Mileage Report” in cell A10. Select cell A10 and insert a 

hyperlink to the Mileage file in your Practice folder.  

 Click the hyperlink you just created to open the 

Mileage.xlsx file. 

Figure 12-1: The Insert Hyperlink dialog box. 

Figure 12-2: Click hyperlinked text to display the linked 
file or Web page. 

Working with the Web and External Data 

This hyperlink opens another file when clicked. 
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Importing Data from an 
Access Database or Text File 

Excel can connect to external data sources including other 

files, databases or Web pages. In order to work with data 

from an external source, you need to create a data 

connection in Excel. 

Import data from an Access database 

1. Click the Data tab on the Ribbon and click the From 

Access button in the Get External Data group. 

The Select Data Source dialog box appears. By 

default, it searches for data sources available on your 

computer and displays them in the dialog box. 

 Trap: If the Get External Data group does not 

appear on the Ribbon, click the Get External 

Data button and select an option from the list. 

2. Browse to and select the database file that contains 

the data you want to import. Click the Open button. 

The Select Table dialog box appears. Here you need 

to select which table you want to import from the 

database. 

 Tip: If the Select Table dialog box does not 

appear, there is only one table in the database, and 

it is automatically selected. 

3. Select a table and click OK. 

The Import Data dialog box appears. Here you tell 

Excel how you want the data displayed in your 

workbook—as a table, PivotTable, etc.—as well as 

where you want to put the data—in the existing 

worksheet or in a new one. 

4. Select an option for how you want to view the data 

and then select an option for where you want to put 

it. Click OK. 

 Tip: If you select to put the data in your existing 

worksheet, also select the cell where you want to 

put it. 

The data is imported from the Access database into 

your workbook.  

 Tips 

 If, while connecting to external data, you see a 

security notice telling you that you are connecting 

to an external source that may not be safe, click 

OK. 

 Exercise 

• Exercise File: Board of Directors Meeting.txt 

• Exercise: Create a new workbook and import the Board of 

Directors Meeting.txt file data into it. In the Text Import 

Wizard, leave the default options selected. Save the new 

workbook as April.xlsx. 

Figure 12-3: The Select Data Source dialog box. 

Figure 12-4: Select how you want to import the data into 

the workbook in the Import Data dialog box. 

Figure 12-5: The Access database data imported into a 

table in Excel. 

Working with the Web and External Data 
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Import data from a text file 

You can also import data from text files with .txt and .csv 

extensions. 

1. Click the Data tab on the Ribbon and click the From 

Text button in the Get External Data group. 

The Import Text File dialog box appears. 

 Trap: If the Get External Data group does not 

appear on the Ribbon, click the Get External 

Data button and select an option from the list. 

2. Browse to and select the text file that contains the 

data you want to import. Click the Import button.  

Step 1 of the Text Import Wizard appears. Here you 

need to select whether the file is delimited or fixed 

width. You also need to select the row of text from 

which you want to start importing data. 

3. Select a file type and enter the row at which you want 

to start importing. Click Next. 

Step 2 of the Text Import Wizard appears. Specify the 

delimiters used to separate the data in the text file. 

4. Select delimiters or specify fixed width column 

breaks. Click Next. 

Step 3 of the Text Import Wizard appears. Select a 

column and choose the format you want to use for its 

data. 

You can also select “Do not import column (skip)” 

and the column will not be included in the Excel 

workbook. 

5. Specify a format for each column, or skip the 

column. Click Finish. 

The Wizard closes and the Import Data dialog box 

appears, asking you where you want to import the 

data in the workbook. 

6. Select where you want to put the imported data. Click 

OK. 

The data from the text file appears in the workbook. 

Figure 12-6: Data imported from a text file. 

Figure 12-7: Importing data with the Text Import Wizard. 

Working with the Web and External Data 

Step 1: Select the file type that describes the data you want to 
import from the text file. 

Step 2: Set the delimiter used to separate data in the text file. A 
preview is shown of how the data looks with the selected 
delimiter. 

Step 3: Select a column and choose the format you want to use 
for the data. Or, select the option to skip the column. 
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Importing Data from the Web 
and Other Sources 

Instead of copying and pasting data into a worksheet from 

a Web page—which normally causes no end of formatting 

problems—you can import data from a growing number 

of Web sites. You can also get data from a variety of 

sources such as a SQL server.  

 Tips 

 Some data sources may require special security 

access, and the connection process can often be very 

complex. Enlist the help of your organization’s 

technical support staff to assist you. 

Import data from the Web 

1. Click the Data tab on the Ribbon and click the From 

Web button in the Get External Data group. 

The New Web Query window opens, displaying the 

Internet Explorer Home page. 

 Trap: If the Get External Data group does not 

appear on the Ribbon, click the Get External 

Data button and select an option from the list. 

2. Enter the address of the Web site you want to visit in 

the Address box and click Go. 

If the Web site is set up for you to export data, you’ll 

see table selection arrows next to the pieces of data. 

3. Click the table selection arrows next to the data you 

want to import, then click Import. 

 Tip: When you click a yellow table selection 

arrow, it turns into a green checkmark.  

The Import Data dialog box appears. Here you can 

specify where you want to put the data. 

4. Select an option for where you want to put the data. 

Click OK. 

The Web data appears in the workbook. 

 Exercise 

• Exercise File: None required. 

• Exercise: Create a new workbook and import data from 

http:// moneycentral.msn.com. 

 Close the workbook without saving. 

Figure 12-8: The New Web Query Window. 

Working with the Web and External Data 

Enter the address of the page from 
which you want to import data 

Table 
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Import data from other sources 

1. Click the Data tab on the Ribbon. Click the From 

Other Sources button in the Get External Data 

group. 

 Trap: If the Get External Data group does not 

appear on the Ribbon, click the Get External 

Data button and select an option from the list. 

Several data source options appear.  

2. Select a data source, then follow the onscreen 

instructions or instructions from your organization’s 

technical support staff to complete the connection. 

Working with the Web and External Data 
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Working with Existing Data 
Connections 

Besides allowing you to add connections, Excel has tools 

to help you view and manage the data connections that are 

accessible in your workbook, on your computer, or on 

your network. 

Access existing connections 

If you have added connections that you want to display, or 

if you want to open a connection that Excel has built in 

for you, you can use the Existing Connections dialog box. 

 1. Click the Data tab on the Ribbon and click the 

Existing Connections button in the Get External 

Data group. 

 Trap: If the Get External Data group does not 

appear on the Ribbon, click the Get External 

Data button and select an option from the list. 

The Existing Connections dialog box appears. Here 

you can see the connections in the open workbook, 

on your network, or on your computer. Excel has 

automatically included a few Web site connections in 

the “on your computer” section. 

2. Select the connection you want to display and click 

the Open button. 

The Import Data dialog box appears. 

3. Select how and where you want to display the data in 

your workbook and click OK. 

The data appears in your workbook. 

Manage connections 

You can see the connections that are present in your 

workbook and change their properties using the 

commands in the Connections group. 

1. Click the Data tab on the Ribbon. 

The Connections group offers several options for 

working with your workbook’s connections: 

 Connections button: Display the Workbook 

Connections dialog box where you can see the 

connections and locations of connections in your 

workbook. Here you can add, remove, refresh, or 

adjust the properties of the connections. 

 Exercise 

• Exercise File: April.xlsx 

• Exercise: Click cell outside the A1:D6 data range and 

view the existing connections from which you can get 

external data. Close the dialog box.  

 Click a cell within the A1:D6 data range and click the 

Connections button in the Connections group. Click “Click 

here to see where the selected connections are used” in the 

Workbook Connections dialog box. Close the dialog box. 

 Click the Properties button in the Connections group to 

view the properties for the external data range. Close the 

dialog box. 

Figure 12-9: The Existing Connections dialog box. 

Figure 12-10: The Workbook Connections dialog box. 

Working with the Web and External Data 
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 Properties button: Change the connection 

properties of the imported data currently selected 

in your worksheet. Properties include the name of 

the connection, formatting and layout, and refresh 

options. Refer to the table below, Data Range 

Properties, for more information about properties. 

 Refresh All button: Updates workbook data to 

match the external data source. 

 Edit Links: Shows the other files the workbook is 

connected to so you can edit or remove the links. 

2. Click a button in the Connections group and work 

with the connection as necessary. 

 Tips 

 When working with workbooks that have data 

connections, a Security Warning banner may appear 

below the Ribbon telling you that connections have 

been disabled. Click the Options button, select 

Enable this content, and click OK. 

Table 12-1: Data Range Properties 

Save query definition Check this option so your worksheet remembers where to go when it refreshes the data. Uncheck it so 

the data source cannot be refreshed again.  

Save password Check this option so that Excel automatically enters the password when the data source is refreshed.  

Enable background refresh Check this option so that when you refresh the data source you can continue working in Microsoft 

Excel. Otherwise, you must wait until Excel is completely finished refreshing the data source to work 

with the program. 

Refresh every Check this option to refresh the data source at specific intervals, and then enter the number of minutes 

you want between refreshes in the minutes box. 

Refresh data on file open Check this option so that the data source automatically refreshes when you open the workbook. The 

Save query definition check box must be selected to refresh the data. 

Remove external data from 

worksheet before saving 

Check this option so that Excel deletes the data source information when you save the worksheet.  

Include field names Check this option so that Excel automatically inserts the data source’s field names as column labels for 

the data source.  

Preserve column 

sort/filter/layout 

Check this option to preserve any sort order, filtering or column order changes you make in a data 

source when it is refreshed. 

Include row numbers Check this option to allow the data source to use its own row numbering.  

Preserve cell formatting Check this option to retain cell formatting that you apply in Microsoft Excel when you refresh the data 

source.  

Adjust column width Check this option so that Excel automatically adjusts its column width to display the imported data 

source information. 

Fill down formulas in 

columns adjacent to data 

Check this option if you want Excel to copy formulas in a data source to new columns when it is 

refreshed. 

Figure 12-11: The External Data Range Properties dialog 

box. 

Working with the Web and External Data 
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Quiz Questions 

117. A hyperlink is text or an image that points to a file, a specific location in a file, or a Web page on your computer, on a 

network, or on the Internet. (True or False?) 

118. To import data into Excel, use the buttons in the ___________ group on the Data tab on the Ribbon. 
A. Connect to External Data 
B. Get External Data 
C. Import Data 
D. Import Files 

119. When you click a yellow table selection arrow on a Web page, it turns into a green checkmarked box. (True or False?) 

120. Which of the following is NOT a button in the Connections group on the Data tab on the Ribbon. 
A. Hyperlink 
B. Refresh All 
C. Properties 
D. Connections 

 

Quiz Answers 

117. True. A hyperlink is text or an image that points to a file, a specific location in a file, or a Web page on your computer, 

on a network, or on the Internet. 

118. B. To import data into Excel, use the buttons in the Get External Data group on the Data tab on the Ribbon. 

119. True. When you click a yellow table selection arrow on a Web page, it turns into a green checkmarked box. 

120. A. Hyperlink is not a button in the Connections group. 
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If you find yourself performing the same 

task over and over again, you might want 

to consider creating a macro to complete 

the task for you. A macro helps you 

perform routine tasks by automating 

them. Instead of manually performing a 

series of time-consuming, repetitive 

actions, you can record a single macro 

that does the entire task all at once for 

you. 

This entire chapter is devoted to macros. 

We start with the basics: learning how to 

record and play a macro. Then you’ll 

move into some more advanced topics 

including how to write and edit macros 

using the Visual Basic programming 

language. 

Using Exercise Files 
This chapter suggests exercises to practice 

the topic of each lesson. There are two 

ways you may follow along with the 

exercise files: 

 Open the exercise file for a lesson, 

perform the lesson exercise, and close 

the exercise file. 

 Open the exercise file for a lesson, 

perform the lesson exercise, and keep 

the file open to perform the remaining 

lesson exercises for the chapter. 

The exercises are written so that you may 

“build upon them”, meaning the exercises 

in a chapter can be performed in 

succession from the first lesson to the last. 
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Recording a Macro 

A macro is a series of Excel commands and instructions 

that are recorded so that they can be executed as a single 

command. Instead of manually performing a series of 

time-consuming, repetitive actions in Excel yourself, you 

can create a macro to perform the task for you.  

There are two ways to create a macro: by recording them 

or by writing them in Excel’s Visual Basic programming 

language. This lesson explains the easy way to create a 

macro—by recording the task(s) you want the macro to 

execute for you. 

When you record a macro, imagine you’re being 

videotaped; everything is recorded—all your commands, 

the data you enter, even any mistakes you make. Before 

recording a macro, it’s helpful to write down a script that 

contains all the steps you want the macro to record. 

Practice or rehearse your script a couple times, to make 

sure it works, before you actually record it. If you do 

make a mistake while recording a macro, don’t worry—

you can always delete the existing macro and try again or 

edit the macro’s Visual Basic source code to fix the 

mistake.  

1. Click the View tab on the Ribbon and click the 

Macros button list arrow in the Macros group. Select 

Record Macro. 

The Record Macro dialog box appears. 

 Tip: If you click the Macros button list arrow and 

select Use Relative References, actions are 

recorded relative to the initially selected cell. 

2. Enter a name for the macro and press <Tab>. 

Next you can enter a shortcut key that will allow you 

to run the macro by pressing the <Ctrl> + <shortcut 

key>. 

3. Enter a shortcut key, if desired. 

Now you can tell Excel where to store the macro. 

You have three choices: 

 Personal Macro Workbook: If you want a macro 

to be available whenever you use Microsoft 

Excel, store the macro in your Personal Macro 

Workbook. 

 New Workbook: Stores the macro in a new 

workbook. 

 This Workbook: Stores the macro in the active or 

current workbook. 

 Exercise 

• Exercise File: WeeklySales13-1.xlsx 

• Exercise: Create a macro that inserts the current date with 

Bold and Center Alignment formatting: 

Click cell B3. Open the Record Macro dialog box and name 

the new macro “DateStamp”. Assign the macro the shortcut 

<Ctrl> + <d>, make sure This Workbook is selected, and 

enter the description “This macro inserts the current date”. 

Click OK. 

 To record the macro, type =Today() and click the Enter 

button on the Formula Bar. Make sure cell B3 is selected, 

copy it, and use the Paste Special command to paste values 

only in cell B3. Apply bold and center formatting. Stop 

recording the macro. 

 Save the workbook as a macro-enabled file type (.xlsm). 

Figure 13-1: The Record Macro dialog box. 

Working with Macros 
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4. Click the Store macro in list arrow and select where 

you want to store the macro. 

5. Click in the Description box and enter a description 

for the macro, if desired. 

6. Click OK. 

Now comes the important part—recording the macro. 

7. Record the macro: perform the actions you want to 

include in your macro. 

Once all the actions have been recorded, stop 

recording. 

8. Click the Macros button list arrow in the Macros 

group and select Stop Recording. 

The macro is recorded and ready to use. 

 Other Ways to Stop Recording: 
Click the Stop Recording button on the status 

bar. 

9. Save the workbook. Click No to save the file as a 

macro-enabled workbook. 

The Save As dialog box appears. 

10. Click the Save as type list arrow and select Excel 

Macro-Enabled Workbook (.xlsm) from the list. 

Click Save. 

The workbook is saved, and the macros will be 

available next time the workbook is opened. 

Figure 13-2: The Stop Recording button in the status bar 

indicates all your actions are being recorded in the macro. 
Click the Stop Recording button to stop recording the 
macro. 

Figure 13-3: This dialog box appears to warn you that 

macros must be saved in a different file type. 

Working with Macros 

Stop Recording 
button 
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Playing and Deleting a Macro 

Once you’ve recorded a macro, you’re ready to view and 

play it. 

 Tips 

  If you see a Security Warning message beneath the 

Ribbon telling you that macros have been disabled, 

click the Enable Content button. 

Play a macro  

1. Click the View tab on the Ribbon and click the 

Macros button list arrow in the Macros group. Select 

View Macros. 

The Macro dialog box appears. Here you can see the 

macros that you have recorded.  

2. Select the macro you want to run and click the Run 

button. 

The macro runs, performing the steps you recorded. 

Delete a macro 

1. Click the View tab on the Ribbon and click the 

Macros button list arrow in the Macros group. Select 

View Macros. 

The Macro dialog box appears. 

2. Select the macro you want to delete and click the 

Delete button. 

3. Click Yes. 

The macro is deleted. 

 Exercise 

• Exercise File: WeeklySales13-2.xlsm 

• Exercise: Run the DateStamp macro so that the current 

date appears in cell C3. 

Figure 13-4: Macros are usually disabled when the file is 
opened, even if the file is saved to be macro-enabled. 

Figure 13-5: Playing a macro in the Macro dialog box. 

Working with Macros 

Click the Enable Content button 
to enable macros. 
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Adding a Macro to the Quick 
Access Toolbar 

To make macros fast and easy to access, you can add 

them as buttons on the Quick Access Toolbar.  

 Tips 

 It may seem obvious, but you must create a macro 

before you can add it to the Quick Access Toolbar. 

1. Click the Customize Quick Access Toolbar button 

next to the Quick Access Toolbar and select More 

Commands. 

The Quick Access Toolbar tab of the Excel Options 

dialog box appears. 

2. Click the Choose commands from list arrow and 

select Macros. 

A list of your macros appears. 

3. Select the macro you want to add to the Quick Access 

Toolbar and click the Add button. 

The macro now appears in the list on the right side of 

the dialog box. At this point, you can select a symbol 

to represent your macro on the toolbar. 

4. Click the Modify button. 

The Modify Button dialog box appears, displaying 

dozens of symbols to choose from. 

5. Select a symbol. 

You can also modify the display name that will 

appear when you hover over the button on the 

toolbar. 

6. (Optional) Enter a different name for the button in the 

Display name box. 

7. Click OK to close the Modify Button dialog box. 

Click OK to close the Excel Options dialog box. 

The macro appears as a button on the Quick Access 

Toolbar. Now you can click it to run the macro. 

8. Click the macro button on the Quick Access Toolbar. 

 Tips 

 To remove a macro from the Quick Access Toolbar, 

right-click the button and select Remove from Quick 

Access Toolbar. 

 Exercise 

• Exercise File: WeeklySales13-3.xlsm 

• Exercise: Add the DateStamp macro to the Quick Access 

Toolbar, selecting the green triangle symbol to represent the 

macro on the Toolbar.  

 Then remove the DateStamp macro from the Quick Access 

Toolbar. 

Figure 13-6: The Quick Access Toolbar with a macro 

button added. 

Figure 13-7: Adding the DateStamp macro button to the 

Quick Access Toolbar. 

Figure 13-8: Selecting a button symbol in the Modify 

Button dialog box. 

Working with Macros 

Macro button 

Customize Quick 
Access Toolbar 
button 
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Editing a Macro’s Visual Basic 
Code 

This lesson introduces you to the Visual Basic (also called 

VB or VBA) programming language—the code Excel 

uses to record macros. Using the Visual Basic language 

and the Visual Basic editor you can make minor changes 

to your macros once you have recorded them. 

The best way to learn about Visual Basic is to view 

existing code. In this lesson we’ll look at how to view and 

edit the code for an existing macro. 

1. Click the View tab on the Ribbon and click the 

Macros button list arrow in the Macros group. Select 

View Macros. 

The Macro dialog box appears. Here you can see the 

macros that you have recorded. 

2. Select the macro you want to edit and click the Edit 

button.  

The Microsoft Visual Basic Editor program appears. 

Those funny-looking words are Visual Basic—the 

language that was used by Excel to record the macro 

you created.  

You don’t have to learn Visual Basic to be proficient 

at Excel, but knowing the basics can be helpful if you 

ever want to modify an existing macro. If you take a 

close look at the code for your macro, some of the 

procedures should make a little sense to you. For 

example, if your macro contains a copy or paste 

command, you may see the text “Selection.Copy” or 

“Selection.Paste”. 

You can delete sections of code to delete certain 

actions from the macro, or edit the code to change the 

macro’s actions. 

3. Edit the macro’s code as desired, then click the Save 

button on the Standard toolbar.  

4. Click the Close button in the upper right-hand corner. 

The Visual Basic Editor window closes. 

 Exercise 

• Exercise File: WeeklySales13-4.xlsm 

• Exercise: Open the DateStamp macro in editing mode. 

Edit the code so that the date is horizontally aligned to the 

left instead of on center.  

 Run the macro in cell D3 to see that the macro enters the 

date so it is aligned to the left side of the cell. 

Figure 13-9: Editing a macro’s code using the Microsoft 
Visual Basic Editor. 

Working with Macros 

Edit code by finding the property you want to 
change, and changing its code. For example, 
this property controls if the text is aligned to 
the Left, Center, or Right side of the cell. 
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Inserting Copied Code in a 
Macro 

Unless you’re a programmer, it’s unlikely that you will 

ever learn many of Visual Basic’s hundreds of functions, 

statements, and expressions—and that’s okay.  

A very useful technique you can use to edit and create 

macros is to insert code that has been copied, or 

plagiarized, from another macro. This technique lets you 

add steps to your existing macros by recording the steps 

you want to add in new macros, copying the appropriate 

code and inserting it into the existing macro.  

Display the Developer tab and enable 
macros 

Before copying code, we’ll display the Developer tab and 

enable macros by turning off macro security. 

1. Open any workbook, click the File tab on the Ribbon 

and select Options. 

The Excel Options window appears. 

2. Click the Customize Ribbon tab. Click Developer 

check box in the Customize the Ribbon column. 

Click OK. 

Next, enable all macros. 

3. Click the Developer tab on the Ribbon and click the 

Macro Security button in the Code group. 

The Trust Center window appears, displaying the 

Macro Settings. 

4. Select the Enable all macros… option and click OK. 

  Tip: For security purposes, once you’re done 

working with macros you’ll want to disable them 

again in the Trust Center. 

 Other Ways to Enable Macros for a Single 

Workbook: 
When a file that uses macros is open, click the 

Enable macros button in the Security Warning 

bar. 

Insert code in a macro 

1. Open the workbooks containing the macros you want 

to work with. 

This includes both the workbook with the macro to 

be copied from and the workbook with the macro to 

be pasted into. 

 Exercise 

• Exercise File: ExpenseReport13-5.xlsm 

• Exercise: The object of the exercise is to copy the code 

that inserts today’s date from the DateStamp macro into the 

ExpenseFillin macro. 

 First, open the ExpenseReport13-5 workbook, display the 

Developer tab and enable macros.  

 Open the DateStamp macro and copy the block of code 

starting at the line ActiveCell.FormulaR1C1 = 

"=TODAY()"   and ending at the line 

Selection.PasteSpecial Paste:=xlPasteValues.  

 Paste this code into the ExpenseFillin macro under the line 
Range("C5").Select 

 Save the changes to the ExpenseFillin macro.  

 Run the ExpenseFillin macro in cell A5. 

Figure 13-10: You can enable macros in the Trust Center 

so that macros are never blocked. Only do this if you are 
sure that files that you open that have macros are safe. 

Working with Macros 
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2. Click the View tab on the Ribbon and click the 

Macros button in the Macros group. Select the macro 

that contains the code you want to copy and click the 

Edit button.  

The Visual Basic Editor window opens. In the Project 

pane on the left side of the window you’ll see the 

macros associated with all the workbooks that are 

open. 

3. In the Project pane on the left side of the window, 

click the expand button to expand the source 

workbook’s project until you see the Modules folder. 

Expand this folder and double-click the module that 

contains the code you want to copy. 

The code for the selected module, or macro, appears 

in the window to the right. 

 Tip: A module is just like a folder where Excel 

puts the code each time you record a macro. 

4. Scroll through the code until you see the code you 

want to copy, then select the code and click the Copy 

button on the Standard toolbar. 

The code is copied. 

Now open the macro in which you want to paste the  

copied code. 

5. In the Project pane along the left side of the window, 

open the module in which you want to paste the 

copied code. 

The code for the selected module, or macro, is 

displayed in the window. 

 Tip: If the macros you want to copy and paste 

between are in the same workbook, they appear in 

the code part of the window together. They are 

simply separated by a line. 

6. Click where you want to paste the code and click the 

Paste button on the Standard toolbar. 

The copied code is inserted into the macro. 

7. Click the Save button on the Standard toolbar, then 

click the Visual Basic Editor window’s Close button. 

The Visual Basic Editor window closes. The macro 

with the newly inserted code is now ready to be run. 

Figure 13-11: The Macro dialog box. 

Figure 13-12: An example of copying code from one 

macro into another. The macros for the open workbook are 
displayed on the same screen. A line separates the 
macros. 

Working with Macros 

Navigate between 
macros in open 
workbooks in the 
Project pane. 

This code can be copied and pasted into 
the ExpenseFillin macro so that today’s 
date is inserted in cell C5. 
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Declaring Variables and 
Adding Remarks to VBA Code 

You’ve probably heard that programming is a lot like 

algebra. In algebra you use variables, like r in the 

equation r2. Programming uses variables too. You 

should always declare any variables when you use them 

in code. Declaring a variable is like telling Excel “I’m 

going to be using a variable named r in my code.”  

This lesson explains how to declare variables and how to 

add remarks—or declare variables—in your code. 

Declare a variable (DIM statement) 

In Visual Basic, you use the DIM statement to declare 

variables, using the syntax DIM variablename As 

datatype. 

1. Open the workbook that contains the macro with the 

code you want to change. 

 2. Click the View tab on the Ribbon and click the 

Macros button in the Macros group. 

The Macros dialog box appears.  

3. Select the macro that contains the code you want to 

work on and click Edit. 

 The macro opens in the VBA window. 

4. Click where you want to add the statement in the 

code. Add a Dim statement at the beginning of the 

procedure, using the syntax Dim VariableName As 

DataType. 

Here’s what the arguments of the Dim statement 

mean: 

• VariableName: The name of the variable. 

Example: EmployeeName. 

• DataType: The type of data you want to use in 

the variable, such as a number, date, or text. See 

the table on the next page, Data Types used in 

DIM Statements for a list of data types that can be 

used.  

Make sure you add an As between the variable name 

and the data type. Example: As String. 

 Exercise 

• Exercise File: ExpenseReport13-6.xlsm 

• Exercise: Open the ExpenseFillin macro in the Visual 

Basic Editor. Enter the following DIM and REM statements 

at the top of the macro’s code: 
 

Dim EmployeeName As String  
‘Declares the EmployeeName variable as a text 

string 

Dim EmployeeNo as Long 

‘Declares the EmployeeNo variable as an 

integer 

Figure 13-13: The syntax of a DIM statement. 

Figure 13-14: An example of DIM and REM statements. 

Working with Macros 

Dim Cost As Integer 

Dim 
Statement 

Variable Name 
The name of 
the variable 

Data Type 
The type of 
data used in 
the variable 

Notice how the colors help distinguish the statements. This is 
something the Visual Basic Editor automatically does to help you 
read code. 
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Add a remark to a procedure (REM 
statement) 

Code can be confusing, but you can make it easier to 

understand by adding explanatory remarks to it. These 

remarks are called REM statements. A REM statement 

doesn’t do anything—it’s just a way to add notes 

explaining the function of the code. 

1. Open the workbook that contains the macro with the 

code you want to change. 

2. Click the View tab on the Ribbon and click the 

Macros button in the Macros group. 

The Macros dialog box appears. 

3. Select the macro that contains the code you want to 

work on and click Edit. 

The macro opens in the VBA window. 

4. Click where you want to add the remark in the code. 

Type ' (an apostrophe) then type the rest of the 

remark. 

Table 13-1: Data Types used in DIM Statements 

Date Type Size Range 

Byte 1 byte 0 to 255 

Boolean 2 bytes True or False 

Integer 2 bytes -32,768 to 32,767 

Long (Long 

Integer) 

4 bytes 2,147,483,648 to 2,147,483,647 

Date 8 bytes January 1, 1000 to December 31, 

9999 

String (Text) Varies Approximately 2 billion characters 

Working with Macros 
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Prompting for User Input 

When creating macros and code it is often useful to 

prompt the user for information. You can then use this 

information in any number of ways—place it in a cell, use 

it in a calculation, or print it in a header or footer. 

This lesson explains one of the easiest ways to prompt the 

user for information—using the InputBox function. The 

InputBox function prompts the user for information by 

displaying a dialog box.  

The syntax for the InputBox function is 

InputBox(“Prompt”) where “Prompt” is the message you 

want to display (usually enclosed in quotation marks). 

1. Open the workbook that contains the macro with the 

code you want to change. 

2. Click the View tab on the Ribbon and click the 

Macros button in the Macros group. 

The Macros dialog box appears. 

3. Select the macro that contains the code you want to 

work on and click Edit. 

The macro opens in the VBA window. 

4. Click where you want to add the InputBox function 

to the code. 

5. Add an Input statement using the syntax 

InputBox(“Prompt”).  

 Exercise 

• Exercise File:  ExpenseReport13-7.xlsm 

• Exercise: Open the ExpenseFillin macro in the Visual 

Basic Editor. Enter the following InputBox statements 

below the second REM statement: 

 EmployeeName = InputBox("Enter the Employee Name.") 

EmployeeNo = InputBox("Enter the Employee Number.") 

 Run the ExpenseFillin macro in A5, entering your name and 

employee number when prompted. 

 (Note: The result of the macro will not be the data you 

entered when prompted because the macro is still set to 

enter Jeff Nelson and 45177 in B5 and C5.) 

Figure 13-15: An example of the InputBox code in a 
macro. 

Figure 13-16: An example of a dialog box prompting a 
user for information. 

Working with Macros 



250 © 2010 CustomGuide, Inc. 

Using the If…Then…Else 
Statement 

The If…Then…Else statement takes action based on a 

certain condition. For example, if an employee’s weekly 

sales are more than $2,500, then calculate a 5% 

commission bonus for the employee, else don’t calculate a 

bonus. 

1. Open the workbook that contains the macro with the 

code you want to change. 

2. Click the View tab on the Ribbon and click the 

Macros button in the Macros group. 

The Macros dialog box appears.  

3. Select the macro that contains the code you want to 

work on and click Edit. 

The macro opens in the VBA window. 

4. Click where you want to add the remark in the code. 

Add an If…Then…Else statement using the 

following syntax (italicized text is where variables 

belong in the statement):  

 If condition Then 

    statement if true 

 Else 

    statement if false 

 End If 

 Exercise 

• Exercise File:  ExpenseReport13-8.xlsm 

• Exercise: Use the If…Then…Else statement to enter the 

employee number 45177 if the employee is Jeff Nelson, else 

the user will have to enter their employee number. 

 Open the ExpenseFillin macro in the Visual Basic Editor. 

Enter the following If…Then…Else statement under the 

statement: EmployeeName = InputBox("Enter the 

Employee Name") 

 If EmployeeName = "Jeff Nelson" Then 

 EmployeeNo = 45177 

Else 

 EmployeeNo = InputBox("Enter the Employee Number.") 

End If 

 Run the ExpenseFillin macro entering Jeff Nelson as the 

Employee Name. 

Figure 13-17: The syntax of an If…Then…Else statement. 

Figure 13-18: An example of an If…Then…Else statement 

used in a macro. 

Working with Macros 
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WWoorrkkiinngg  wwiitthh  MMaaccrrooss  RReevviieeww  

Quiz Questions 

121. Which of the following is NOT a place where you can choose to store a macro? 
A. This Workbook 
B. New Workbook 
C. Universal Macro Workbook 
D. Personal Macro Workbook 

122. To play a macro in the Macro dialog box, click the _______ button 
A. Run 
B. Play 
C. Macro 
D. Go 

123. You can select a symbol of your choice to represent the macro on the Quick Access Toolbar. (True or False?) 

124. Excel macros are written in the ________ programming language. 
A. ABC 
B. Visual Basic 
C. Basic Macro 
D. Visual Excel 

125. You can change your macro security settings in the _________ window. 
A. Macro Center 
B. Code Center 
C. Trust Center 
D. VBA Control 

126. Which of the following statements declares a variable? 
A. REM HireDate as Date 
B. Dim HireDate as Date 
C. InputBox(HireDate) = Date 
D. Sub HireDate() = Date 

127. Which of the following statements would prompt a user for information? 
A. REM DOB as Date 
B. Sub HireDate( 
C. DIM HireDate( 
D. InputBox( 
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Quiz Answers 

121. C. The Universal Macro Workbook is not a place where you can store a macro. 

122. A. Click the Run button in the Macro dialog box to play a macro. 

123. True. You can select a symbol of your choice to represent the macro on the Quick Access Toolbar. 

124. B. Excel macros are written in the Visual Basic programming language. 

125. C. You can change your macro security settings in the Trust Center window. 

126. B. Dim HireDate as Date would declare the variable 'HireDate' as a date. 

127. D. The statement InputBox( 
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Customization is a great asset in an 

application. Customization lets you use a 

particular mix of commands and shortcuts 

that are best for your working style. 

The lessons in this chapter focus on how 

to customize the Ribbon, the Quick 

Access Toolbar, and AutoCorrect. We’ll 

also discuss how to access and review the 

default options for a program. 
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Customizing the Ribbon 

One of the most useful features in Office 2010 is that you 

can customize the Ribbon. Add your own tabs and groups, 

or rearrange the Ribbon to better fit your work style. 

Create a new tab or group 

 You can add new groups to tabs, or you can create new 

tabs with new groups. 

1. Click the File tab on the Ribbon and select Options.  

The Options dialog box appears. 

2. Click the Customize Ribbon tab. 

The left column displays commands that you can add 

to the Ribbon. 

The right column displays the tabs on the Ribbon, 

and the groups and commands in each tab. 

 Tip: Click the plus sign next to a tab or group to 

expand it. 

3. In the right column, select the tab where you wish to 

add the new tab or group.  

A new tab, which automatically includes a new 

group, will be inserted below the selected tab.  

A new group will be inserted within the selected tab. 

4. Click the New Tab or the New Group button. 

The new tab or group is added. 

Rename a tab or group 

Once you’ve created a tab or group, give it a name. 

1. Select the tab or group you want to rename. 

 2. Click the Rename button. 

The Rename dialog box appears. 

3. Enter a name for the selected tab or group in the 

Display Name text box.  

The tab or group is renamed. For a group, also select 

a symbol to represent the group. 

4. Click OK. 

The tab or group is renamed. 

 Exercise 

• Exercise File: None required. 

• Exercise: Create a new group on the Home tab called 

“Printing” and include the command to Print Preview and 

Print.  

 Restore the Ribbon defaults. 

Figure 14-1: Use the 

buttons in the Options 
dialog box to add a new 
tab or group to the Ribbon. 

Figure 14-2: Adding commands to groups on the Ribbon. 

Customizing Excel 

Click to 
create a 
new group. 
 

Click to 
create a 
new tab. 

Click to 
rename the 
selected tab 
or group. 

Click to reorder the 
selected tab or group. 

Click to view 
another group of 
commands. 

Click to view 
all the tabs on 
the Ribbon. 

Click to add the 
command on the 
left to the selected 
group on the right. 
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Add a command to a group 

Once you have created a new tab or group, you can add 

commands to the group. You can also add commands to 

groups that already appear on the Ribbon. 

1. In the right column, select the group to which you 

want to add a command. 

This could be a group you’ve created from scratch, or 

even a group that appears by default. 

2. In the left column, select the command you want to 

add to the Ribbon. Click the Add button. 

The command is added to the group. 

 Tip: Not finding the command you want to add? 

Click the Choose commands from list arrow and 

select the group of commands you want to view. 

Restore the default Ribbon 

If you no longer want to use the customizations you’ve 

added to the Ribbon, you can restore the Ribbon to its 

original, default settings. 

1. Click the Reset button. 

Two options appear: 

 Reset only selected Ribbon tab: Restores the 

default settings for the selected tab. 

 Reset all customization: Removes all Ribbon 

and Quick Access Toolbar customizations, 

restoring them to the default arrangement and 

appearance. 

2. Select the reset option you wish to use. 

The Ribbon is restored to its default settings. 

Remove a tab or group 

You can also remove a specific tab or group from the 

Ribbon. 

1. In the right column, right-click the tab or group you 

wish to use. 

2. Select Remove from the contextual menu. 

The tab or group is removed from the Ribbon. 

 Tips 

 Any changes you make to a program’s Ribbon will 

appear only in that program. 

 To hide a tab on the Ribbon, deselect its check box. 

Figure 14-3: The Home tab of the Ribbon, customized 

with a new group. 
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The Print Preview and 
Print command added 
to the Printing group. 
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Customizing the Quick Access 
Toolbar 

The Quick Access Toolbar is a shortcut for commands 

that are used often. If the Quick Access Toolbar doesn’t 

contain enough of your frequently used commands, you 

can customize it by adding or deleting commands. 

1. Click the File tab and select Options. 

The Excel Options dialog box appears. 

2. Click the Quick Access Toolbar tab.  

This tab displays options for customizing the Quick 

Access Toolbar.  

The left column displays commands you can add to 

the Quick Access Toolbar. The right column displays 

commands that appear there. 

3. In the left column, select the command you want to 

add to the Quick Access Toolbar. 

4. Click the Add button. 

The command is added to the Quick Access Toolbar. 

 Tips 

 Arrange the order in which the commands are 

displayed by clicking the Move Up and Move Down 

buttons to the right of the column. 

 Click the Reset button and select Reset only Quick 

Access Toolbar to return the Quick Access Toolbar 

to its default commands. 

 Select a command in the Quick Access Toolbar 

column and click the Remove button to remove it 

from the Quick Access Toolbar. 

 Exercise 

• Exercise File: None required. 

• Exercise: Add the Print Preview command from the 

Popular Commands group to the Quick Access Toolbar.  

 Move the Quick Access Toolbar below the Ribbon. 

Figure 14-4: Adding a command to the Quick Access 

Toolbar. 
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Using and Customizing 
AutoCorrect 

AutoCorrect automatically corrects many common typing 

and spelling errors as you type. It is also a great way to 

use shorthand for longer words, phrases, or symbols. 

AutoCorrect is a feature that is shared across the 

Microsoft Office suite—so any additions or changes you 

make to AutoCorrect in one program, such as Word, will 

appear in all Microsoft Office programs, like Excel, 

Excel, and Outlook. 

How AutoCorrect works 

You may have already noticed that sometimes your typos 

are corrected as you enter text in Word. When you type an 

AutoCorrect entry and then press the <Spacebar>, 

AutoCorrect replaces that text with the correct text.  

For example, AutoCorrect will change the mistyped 

words “hte” to “the”, or “adn” to “and”. AutoCorrect also 

corrects simple grammar mistakes, such as capitalization 

problems. For example, it would change “GOing” to 

“Going,” or capitalize the first letter in sentences. 

Create an AutoCorrect entry 

Excel already has many entries in AutoCorrect, but you 

can add your own entries to correct habitual misspellings, 

quickly insert a symbol, or insert a shorthand version of a 

long phrase that you frequently use. 

1. Click the File tab and select Options. 

The Excel Options dialog box appears. 

2. Click the Proofing tab. 

This tab displays options for how Excel corrects and 

formats text. 

3. Click the AutoCorrect Options button. 

The AutoCorrect dialog box appears with the 

AutoCorrect tab in front. 

4. Type the word or phrase you want to correct or use as 

shorthand in the Replace text box. 

This is the text that AutoCorrect will recognize when 

you type. 

5. Type the word or phrase you want to appear in the 

With text box. 

When the text in the “Replace” text box is typed with 

a space, the text in the “With” text box will appear. 

 Exercise 

• Exercise File: None required. 

• Exercise: Create an AutoCorrect entry that replaces “ot” 

with “to”.  

 Try the AutoCorrect entry with this phrase, “He was going 

ot the store.” 

Figure 14-5: An example of how AutoCorrect works. 

Figure 14-6: The AutoCorrect tab of the AutoCorrect 
dialog box. 
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6. Click Add. 

The entry is added to the AutoCorrect list. 

7. Click OK to close the AutoCorrect dialog box. Click 

OK to close the Excel Options dialog box. 

The dialog boxes close and the entry will now be 

available in all Excel workbooks, and also in all other 

Office applications. 

Customizing Excel 
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Changing Excel’s Default 
Options 

Microsoft spent a lot of time and research when it decided 

what the default settings for Excel should be. However, 

you may find that the default settings don’t always fit 

your own needs. 

This lesson isn’t so much an exercise as it is a reference 

on how to customize Excel by changing its default 

settings.  

1. Click the File tab and select Options. 

The Excel Options dialog box appears. 

2. Click the tabs on the left to view different option 

categories. 

See the table below, Tabs in the Excel Options Dialog 

Box, for more information on these categories. 

3. Change the options as you see fit. Click OK to 

confirm the changes. 

The changes are applied to the Excel program. 

Table 14-1: Tabs in the Excel Options Dialog Box 

General Change the most commonly modified options in Excel. This includes enabling the Mini Toolbar and Live 

Preview. Also, change the color scheme, control ScreenTips, and change the user name. 

Formulas Change options related to formula calculation, performance, and error handling. 

Proofing Change how Excel corrects and formats your text. Change the types of errors that Excel flags when looking 

for spelling and grammar errors. 

Save Customize how workbooks are saved, such as how often AutoRecover saves a workbook, and change default 

file locations. 

Language Add additional languages to edit your documents. Also set the language priority order for added languages. 

Advanced Advanced options for working with Excel. Change how Excel works when you edit text; modify how cut, 

copy, and paste commands operate; customize tools in the window, such as how it displays screen tips and 

scroll bars; adjust how Slide Show view looks and operates; control how the workbook is printed; choose 

advanced save options; and control various Web options. 

Customize Ribbon Create custom tabs and groups for the Ribbon. 

Quick Access Toolbar Add commands to the Quick Access Toolbar. 

Add-Ins View and manage Microsoft Office add-ins, such Acrobat PDFMaker and custom XML data. 

Trust Center Help keep your workbooks safe and your computer secure and healthy. Read privacy statements and change 

Trust Center Settings to control how Excel works with macros, add-ins, the message bar, trusted publishers 

and locations, and more. 

 Exercise 

• Exercise File: None required. 

• Exercise: Explore the tabs in the Excel Options dialog 

box. 

Figure 14-7: The Formulas tab of the Excel Options dialog 

box. 

Customizing Excel 
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Creating a Custom AutoFill 
List 

You’re already familiar with Excel’s AutoFill feature. It’s 

the nifty function that automatically enters a series of 

values. If you find yourself typing the same list of words 

frequently, you can save yourself a lot of time by creating 

a custom AutoFill list. Once you have created a custom 

AutoFill list all you have to do is type the first entry of the 

list in a cell, and use AutoFill to have Excel complete the 

rest of the list for you. 

Create a custom AutoFill list 

1. Click the File tab on the Ribbon and select Options. 

2. Click the Advanced tab and scroll down to the 

General section. Click the Edit Custom Lists button. 

The Custom Lists dialog box appears.  

3. Select NEW LIST under the Custom lists section. 

4. Type the first entry you want to include in the 

AutoFill list and press <Enter>. Repeat for each 

entry of the list. 

 Other Ways to Enter Custom List Entries: 
Select the cell range that contains the information 

you want to include in your custom AutoFill list. 

Then open the Custom Lists dialog box. Click 

Import. 

5. Click Add. 

The custom list is added to the dialog box. 

6. Click OK, OK. 

Use a custom AutoFill list 

Using a custom AutoFill list is just like completing any 

other series with AutoFill. 

1. Click the cell where you want to begin the custom fill 

series. 

2. Type an item from the series. 

3. Click and drag the cell’s fill handle to complete the 

series in the cells you select. 

 Exercise 

• Exercise File:  CustomizingExcel.xlsx 

• Exercise: Use the data in A1:A10 to create a custom 

AutoFill list. 

 Try using the AutoFill list in the worksheet. 

Figure 14-8: The Custom Lists dialog box. 

Customizing Excel 
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Creating a Custom Number 
Format 

You learned how to format values (numbers) in a previous 

lesson in this chapter. Excel comes with a huge number of 

predefined number formats you can use. With so many 

available number formats, it is unlikely that you will ever 

need to create your own custom number format, but if you 

do, here’s a brief overview. 

1. Click the Home tab on the Ribbon and click the 

Dialog Box Launcher in the Number group. 

2. Click Custom in the Category box. 

This is where you can modify a copy of an existing 

format code to meet your specifications. A custom 

number format is created by specifying format codes 

that describe how you want to display a number, date, 

time, or text. The table below, Format Codes for 

Numbers and Dates, gives some examples of how to 

use these codes when creating custom number 

formats. 

 Tip: The sample area of the number dialog box 

becomes very important when you’re creating 

custom number formats. Watch the sample area 

carefully to see how the custom number format 

3. In the Type list, select a number format that you want 

to customize. 

The number format appears in the Type box. 

4. Make changes to the number format in the Type box 

using the format codes shown in the table below, 

Format Codes for Numbers and Dates. 

Table 14-2: Format Codes for Numbers and Dates 

Numbers Dates and Times 

To Display Use this Code To Display Use this Code 

1234.59 as 1234.6 ####.# 1/1/11 as 1-1-11 m-d-yy 

12499 as 12,499 #,### 1/1/11 as Jan 1, 11 mmm d, yy 

12499 as 12,499.00 #,###.## 1/1/11 as January 1, 2011 mmmm, d, yyyy 

1489 as $1,489.00 $#,###.## 1/1/11 as Fri 1/1/11 ddd m/d/yy 

.5 as 50% 0% 1/1/11 as Friday, January 1 dddd, mmmm, d 

.055 as 5.5% 0.0% 4:30 PM as 4:30 PM h:mm AM/PM 

Hide value ;; 4:30 PM as 16:30 h:mm 

 Exercise 

• Exercise File:  CustomizingExcel.xlsx 

• Exercise: Select cell C1 and create this custom number 

format: ##-#### 

Figure 14-9: Creating a custom number format. 

Customizing Excel 
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CCuussttoommiizziinngg  EExxcceell  RReevviieeww  

Quiz Questions 

128. You can only add custom groups to custom tabs. (True or False?) 

129. What is the purpose of the Quick Access Toolbar? 
A. To provide quick access to the commands you use most frequently. 
B. To make Excel 2010 look more like previous versions. 
C. To provide Microsoft Access commands in the Excel program. 
D. To provide a backup in case the Ribbon fails 

130. AutoCorrect changes: 
A. Spelling errors 
B. Grammar errors 
C. Capitalization errors 
D. All of these. 

131. AutoCorrect entries created in Excel will not appear in any other programs. (True or False?) 

132. Which of the following is NOT a tab in the Excel Options dialog box? 
A. Proofing, which changes how Excel corrects your text. 
B. Display, which changes how content appears on the screen. 
C. General, which lists the most commonly modified options in Excel. 
D. Trust Center, which changes your privacy options. 

133. Which of the following is NOT an example of information that could be used in an AutoFill list? 
A. Since you can create your own AutoFill lists, you could use any of this information in an AutoFill list. 
B. The names of the seven dwarves. 
C. A product list. 
D. A list of employees. 

134. The United States decides to change the format of social security numbers. How can you create a custom number 

format for the new social security format? 
A. Click the Number tab on the Ribbon and click the Custom List button in the Number group. Select the Custom 

category and type the number format in the Type box. 
B. Buy and install the Custom Number Wizard Add-On for Microsoft Excel. 
C. Enter the number format in the Number Format list on the Formatting tab of the Ribbon. 
D. Click the Home tab on the Ribbon and click the Dialog Box Launcher in the Number group. Select the Custom 

category and type the number format in the Type box. 

 

Quiz Answers 

128. False. You can add custom groups to default tabs or to custom tabs. 



  University of Virginia Health System 263 

129. A. The purpose of the Quick Access Toolbar is to provide quick access to the commands you use most frequently. 

130. D. AutoCorrect changes spelling errors, grammar errors, and capitalization errors. 

131. False. AutoCorrect entries created in Excel will appear in all other Microsoft Office programs. 

132. B. There is no Display tab in the Excel Options dialog box. 

133. A. Since you can create your own AutoFill lists, you could use any of this information in an AutoFill list. 

134. D. To create a custom number format, click the Home tab on the Ribbon and click the Dialog Box Launcher in the 

Number group. Select the Custom category and type the number format in the Type box. 

 

 


